Network & Software Engineering

Network & Software Engineering
Network & Software Engineering
MANUEL D'UTILISATEUR
OJRA®
LOGICIEL DE PAIE
!
MANUEL DE L’UTILISATEUR
SOMMAIRE
Introduction
Chapitre 1 :
Installation et démarrage
Chapitre 2 : Architecture de NSE-OJRA
Chapitre 3 : Conception des rubriques de paie
Chapitre 4 : Maintenance des Fichiers et Tables de base
Chapitre 5 : La saisie des Revenus
Chapitre 6 : Le calcul de la paie et Edition des Bulletins
Chapitre 7 : Gestion des prêts et Avances
Chapitre 8 : L’édition des états de gestion
Chapitre 9 : Le serveur OJRA OLE
Annexe A : Liste des états de gestion
_____________________________________________________________________________________
Network and Software Engineering
2/34
!
MANUEL DE L’UTILISATEUR
NSE-OJRA
Le logiciel de gestion de la paie
OJRA est un logiciel de paie conforme aux normes légales et juridiques marocaines.
Adapté aux structures professionnelles d’activité diverses, OJRA gère les salariés et tous
les traitements liés à la paie.
ERGONOMIE ET SOUPLESSE D'UTILISATION
Alliant souplesse d'utilisation et convivialité dans un environnement graphique Windows
95/98 et Windows NT, OJRA vous offre une vision claire de ses fonctionnalités.
Grâce à la disposition des ses Menus et son Aide en ligne, l'utilisation de OJRA est
extrêmement facile.
EVOLUTIVITE
Avec des rubriques de paie déjà saisies et adaptées aux normes marocaines, OJRA vous
est livré prêt à l'emploi.
Entièrement paramétrable, il s'adapte aux exigences et spécificités de votre entreprise et
aux évolutions de la fiscalité marocaine vous garantissant ainsi la pérennité de votre
investissement.
RICHESSE FONCTIONNELLE
" Logiciel multi-sociétés et multi-exercices
" Interfacage dynamique avec le serveur Ojra OLE
" Gestion de l’IGR avec régularisation
" Edition des bulletins / papier libre ou pré-imprimé
" Très convivial, intuitif et facile à utiliser
" Nombreux états récapitulatifs périodiques ou cumulés
" Intégration complète avec le logiciel de comptabilité KHABIR
_____________________________________________________________________________________
Network and Software Engineering
3/34
!
MANUEL DE L’UTILISATEUR
Ce guide de l’utilisateur se propose de vous préparer à tirer pleinement parti de votre
logiciel. Il vous permet
de retrouver rapidement les informations qui vous seront
nécessaires pour son exploitation optimale.
Grâce à ses illustrations et ses instructions détaillées, il vous explique pas à pas la mise
en route du programme et son utilisation.
Dans cette documentation sont traités les sujets suivants :
• La définition des différents paramètres
• La gestion des fichiers de base
• La gestion du fichier du Personnel
• La gestion des Revenus
• La gestion des Prêts
• Le calcul de la paie
• L’utilisation du générateur d’états
• L'utilisation des utilitaires de la Base de données
La première partie :
Les chapitres de cette première partie vous expliquent les techniques à acquérir pour
exploiter votre progiciel.
L’un de ces chapitres indique la méthode à suivre pour l’installation des fichiers de la
disquette sur votre disque dur.
Un autre chapitre vous présente l'architecture du programme.
La deuxième partie :
Dans cette partie, nous décrivons le paramétrage de votre application et nous vous
expliquons comment saisir les revenus et comment exécuter le calcul automatique de la
paie.
La troisième partie :
Dans cette partie, nous expliquons comment éditer les bulletins de paie et comment
utiliser l'éditeur d'états.
_____________________________________________________________________________________
Network and Software Engineering
4/34
!
MANUEL DE L’UTILISATEUR
Chapitre 1
Installation et démarrage
L’installation du programme consiste à transférer le contenu des disquettes (ou CD-ROM)
sur le disque dur. La procédure d’installation fournie avec les disquettes (ou CD-ROM) est
automatique.
En effet, le programme d’installation vous guide pas à pas par une succession de
messages qu’il convient de suivre.
Configuration nécessaire
Pour pouvoir utiliser votre progiciel, vous devez disposer de produits matériels et logiciels
adéquats. La configuration nécessaire est la suivante :
Hardware :
# PC compatible IBM doté d’un processeur 486 ou supérieur
# 16 Mo de mémoire vive minimum
# 40 Mo d’espace disponible sur le disque dur
# Ecran couleur + Souris.
Software :
# Système d’exploitation Windows 9x / Windows NT / Windows 2000.
Configuration conseillée :
# Un micro-ordinateur doté d’un processeur Pentium (ou supérieur)
# 32 Mo de mémoire RAM
# 120 Mo d'espace disponible sur le disque dur
_____________________________________________________________________________________
Network and Software Engineering
5/34
MANUEL DE L’UTILISATEUR
!
Procédure d’installation
Le logiciel OJRA est fournie avec les disquettes de distributions de OJRA. Pour l’exécuter,
suivez les instructions suivantes :
1. Allumez votre ordinateur et chargez Windows
2. Insérer la disquette #1 dans le lecteur de disquette.
3. Dans le menu "Démarrer", choisissez la commande "Exécuter".
4. Tapez A:Setup dans la boite de texte et validez en cliquant sur le bouton OK.
5. Spécifiez le nom du répertoire où vous désirez installer «C :\OJRA », puis cliquez sur le
bouton continuer.
Après l’installation du programme, des changements des fichiers systèmes seront effectués
et le groupe de programmes "OJRA" sera créé.
Pour créer un raccourci de OJRA sur le bureau :
1. Cliquez avec le bouton droit de la souris sur le bureau;
2. Dans le menu affiché, choisissez "Nouveau" puis "Raccourci";
3. Tapez "C:\Ojra\Ojra.exe" (ou "C:\Ojra\Ojra32.exe") dans la ligne de commande, puis
cliquez sur suivant;
4. Dans la boîte de dialogue affichée, cliquez sur "Terminer"
Démarrage :
Après avoir créé le raccourci de Ojra sur le bureau, vous trouverez l’icône de programme
représentant votre application :
_____________________________________________________________________________________
Network and Software Engineering
6/34
!
MANUEL DE L’UTILISATEUR
Pour lancer l’application Ojra, double-cliquez sur cette icône.
Lorsque vous exécutez le programme, la première fenêtre de « Ojra » est affichée.
Cette fenêtre contient une barre de menus et une zone "Liste des sociétés créées".
La barre de menu est constituée des menus suivants :
• Le menu Edition est conçu pour la gestion multi-sociétés . Ce menu contient les options
suivantes :
# Ajouter : pour ajouter une nouvelle société
# Ouvrir : pour ouvrir la société sélectionnée
# Copier : pour copier la société sélectionnée vers une autre société
• Le menu Utilitaires. Ce menu contient les options suivantes :
# Réparer : pour réparer la société sélectionnée
# Compacter : pour compacter la société sélectionnée
# Mettre à jour : disponible quand il y a une nouvelle version de OJRA
_____________________________________________________________________________________
Network and Software Engineering
7/34
MANUEL DE L’UTILISATEUR
!
Au premier lancement de OJRA, la zone "Liste des sociétés créées" est vide. Vous devez
alors créer une société pour commencer à travailler.
Pour cela, suivez les étapes ci-dessous :
1. Cliquez sur le menu "Edition"
2. Cliquez sur l'option "Ajouter", une boîte de dialogue est alors
affichée pour saisir le nom de votre société
3. Tapez le nom de votre société, puis cliquez sur le bouton "Ajouter"
4. Le nom de votre société est alors affiché, sélectionnez-le;
5. Dans le menu "Edition", choisissez "Ouvrir"
6. Une fenêtre est alors affichée vous demandant de saisir votre nom (ou code) et votre
mot de passe.
NB : Ojra est configuré pour être administré par un utilisateur appelé "Super administrateur"
dont le code est "superadm" (sans mot de passe lors de la première utilisation).
La fenêtre d'autorisation d'accès contient deux champs de saisie :
1. Le champ "Code Utilisateur" pour saisir votre code
2. Le champ "Mot de passe" pour saisir votre mot de passe
_____________________________________________________________________________________
Network and Software Engineering
8/34
!
MANUEL DE L’UTILISATEUR
Après avoir saisi correctement votre code et votre mot de passe, le logiciel vous accorde
l’autorisation d’accès, et vous s’affiche la fenêtre principale.
Barre
de
Menu
Barre
de
Boutons
PARAMETRAGE
Avant d'expliquer en détail les diverses fonctionnalités de Ojra, il faut passez à une étape
nécessaire et obligatoire pour le fonctionnement du logiciel : le paramétrage.
Pour paramétrer Ojra, choisissez l'option "Paramètres Société" dans le menu "Fichier".
La fenêtre de paramétrage est alors affichée, elle contient les rubriques suivantes :
"
L’onglet "Société" vous permet d'indiquer le nom de votre Société, son adresse et
votre N° de téléphone et la Ville.
"
L’onglet "IGR / FP / CNSS" vous permet de saisir les paramètres concernant l'Impôt
général du le revenu, les frais professionnels et la CNSS.
_____________________________________________________________________________________
Network and Software Engineering
9/34
!
MANUEL DE L’UTILISATEUR
"
L’onglet "CIMR / Mutuelle" : cette fenêtre sert à spécifier les paramètres concernant la
CIMR et la Mutuelle.
"
L’onglet "Autres" contient les paramètres suivants :
# Impression des Bulletins : pour indiquer la destination d'impression (visualisation
avant impression / impression directe sur l'imprimante) et le Type de papier.
# Le type de fichier d'export des salariés : pour générer le fichier destiné à la CNSS
# Sauvegarde et Restauration : pour saisir les chemins de vos utilitaires de
sauvegarde et de restauration.
♦ L’onglet "Heures Supp" : cette fenêtre sert à paramétrer le taux des heures sup. 25% et
50%
Vous pouvez aussi utiliser les utilitaires qui sont livrés par Microsoft avec ses
systèmes d'exploitation Windows. Pour cela, suivez la méthode ci-dessous :
1. Cherchez le fichier "backup.exe" et copier le dans le répertoire où est installé Ojra
2. Cherchez le fichier "backup.cfg" et copier le dans le répertoire où est installé Ojra
3. Exécutez backup à partir du menu "Démarrer"
4. Créer un jeu de sauvegarde et enregistrer le dans le répertoire où est installé Ojra
sous le nom "Ojra.set"
5. Revenez à Ojra, et dans le champs "Sauvegarde", tapez le texte suivant :
C:\Ojra\BACKUP.EXE C:\Ojra\OJRA.SET
(Dans l'hypothèse que le répertoire où est installé Ojra est : "C:\Ojra")
Remarques :
1. Le paramétrage doit s'effectuer sur chaque poste si vous disposer de la version
réseau de Ojra
2. La disposition des rubriques peut être différente selon les versions de Ojra,
toutefois leurs principes ainsi que leurs fonctionnements restent les mêmes.
_____________________________________________________________________________________
Network and Software Engineering
10/34
!
MANUEL DE L’UTILISATEUR
Chapitre 2
Architecture de Ojra
OJRA est architecturé autour de 7 menus ou groupes de fonctions et une barre de Boutons.
Les menus apparaissent dans une barre sur la première fenêtre affichée lors du
chargement. La barre de Boutons quant à elle contient des boutons de raccourci.
Les fonctions de chaque Menu ou Bouton sont accessibles par clic de souris ou par des
raccourcis claviers.
La barre de menus contient les menus suivants :
• Le menu Fichier
• Le menu Définition des Revenus
• Le menu Gestion des Prêts
• Le menu Calcul de la Paie
• Le menu Editions
• Le menu Utilitaires
• Le menu Aide
En ce qui concerne la barre de boutons, vous trouverez les boutons suivants (à partir de la
gauche) :
• Le Bouton Matricule
• Le Bouton Rubrique
• Le Bouton Sauvegarder
• Le Bouton Quitter
_____________________________________________________________________________________
Network and Software Engineering
11/34
MANUEL DE L’UTILISATEUR
!
Le menu "FICHIER"
Le menu Fichier permet de gérer les fichiers principaux et tables de base.
Les fichiers principaux sont disponibles à l’aide des options suivantes :
• Personnel : pour la gestion du fichier Personnel
• Rubrique : pour la gestion du fichier des rubriques
Quant aux tables de base, elles sont disponibles dans l'option "Tables" du menu fichier.
Ces tables sont les suivantes :
•
Table des Départements : pour la codification des Départements
•
Table des Services : pour la codification des services
En plus de ces options, Ce menu contient :
• une option « Barèmes IGR » : pour le paramétrage des Taux d'IGR
• une option « Taux d'Ancienneté » : pour le paramétrage des Taux d'ancienneté
• Une option « Taux CIMR/Mutuelle » : pour codifier les Taux CIMR et Mutuelle
• Une option «Paramètres société» : pour saisir les paramètres de la société
• Une option «Imprimante» : pour configurer l'imprimante connectée à votre
ordinateur ou celle partagée en Réseau.
• Une option «Quitter» : pour quitter l'application.
_____________________________________________________________________________________
Network and Software Engineering
12/34
MANUEL DE L’UTILISATEUR
!
Le menu "Définition des Revenus"
Le menu " Définition des Revenus " assure la gestion des attributions des revenus aux
salariés. Ce menu contient les options suivantes :
• L'option "Revenus Types "
• L'option "Prép. Revenus Horaires "
• L'option "Revenus Mensuels"
• L'option "Revenus Journaliers"
• L'option "Revenus Semainiers"
• L'option "Revenus à la Quinzaine"
• L'option "Revenus Trimestriels"
Le menu "Gestion des Prêts"
Le menu " Gestion des Prêts " assure le suivi des prêts (non déductibles des charges)
accordés aux salariés. Ce menu contient les options suivantes :
• L'option " Saisie des Prêts " : pour saisir les prêts
• L'option " Liste des Prêts " : pour la consultation des prêts/avances
• L'option "Générer les Retenues " : pour générer les retenus
Le menu " Calcul de la Paie "
Le menu " Calcul de la Paie " assure les fonctions de calculs et d'annulations de la paie.
Ce menu contient les options suivantes :
• L'option " Simulation de calcul " : pour une simulation de calcul
• L'option " Copie de la Paie" : pour copier une paie d’un mois vers un autre
• L'option " Calcul de la Paie " : pour calculer la paie des salariés
• L'option "Annuler la Paie " : pour annuler la paie en cas d’erreurs
• L'option "Clôture Annuelle" : pour Clôturer la paie
_____________________________________________________________________________________
Network and Software Engineering
13/34
MANUEL DE L’UTILISATEUR
!
Le menu EDITIONS
Pour toutes les éditions qui vous sont proposées, vous disposez d’un générateur d’états qui
vous permet de faire des sélections selon plusieurs critères.
L’utilisation de ce générateur est assez simple, il suffit de choisir le ou les champs sur
lesquels vous voulez faire des sélections, les critères de sélection (=, < , > , <= , >=) et la
valeur de comparaison (Nombre, date ou Texte).
Le menu Editions regroupe tous les états disponibles dans Ojra. Ces états peuvent être
visualisés sur écran ou imprimé. La liste de ces états est disponible dans l’annexe 1.
Le menu UTILITAIRES
Le menu Utilitaires offre des options pour l’organisation de la base de données ainsi que
d’autres fonctionnalités.
Grâce à ces utilitaires vous pouvez :
• Compacter la base de données pour améliorer les performances du programme ;
• Réparer la base de données en cas d’altération ;
• Sauvegarder la base de données ;
• Restaurer (récupérer) une ancienne copie de votre base de données.
Nous avons également prévu de vous fournir :
•
une option pour la gestion des utilisateurs (disponible uniquement pour le super
administrateur),
•
une autre option pour changer votre mot de passe,
•
une calculatrice
_____________________________________________________________________________________
Network and Software Engineering
14/34
!
MANUEL DE L’UTILISATEUR
Chapitre 3
Conception des rubriques de paie
Présentation des rubriques de paie dans OJRA
Les rubriques de paie dans OJRA sont entièrement paramétrables. Elles sont organisées
en 6 classes. Cette classification est basée sur la structure générale ci-après définie.
Conception générale
Les rubriques sont conçues de telle façon que les données de la déclaration des revenus
salariaux et les retenus au titre de l’IGR (Etat 9421) puissent être extraites
méthodiquement.
En effet, la conception des rubriques doit permettre de faire ressortir, de manière
synthétique, les montants qui composent l’état 9421 à savoir :
• Le montant brut des traitements salaires et émoluments
• Le montant brut des avantages en argent ou en nature
• Le montant des indemnités à titre de frais d’emploi de service de route et allocations
similaires
• Les retenus pour pension ou retraite et prévoyance sociale
• Les remboursements ou intérêts des prêts
Codification des rubriques
Le mode de codification décimale caractérise le classement des rubriques. Le Code de la
rubrique et son intitulé permettent d’identifier les opérations enregistrées pour le calcul de la
paie et l’édition des bulletins.
_____________________________________________________________________________________
Network and Software Engineering
15/34
!
MANUEL DE L’UTILISATEUR
Un code rubrique comporte au moins 2 chiffres. Le niveau de détail est établi en ajoutant un
troisième chiffre ( ou un caractère alphanumérique).
• Le premier chiffre permet d’identifier une classe
• Le second chiffre permet d’identifier une sous-classe
Les opérations relatives à la paie sont donc réparties dans 6 classes. Ces classes sont les
suivantes :
• La classe 1 : Traitements / Salaires / Emoluments y compris les indemnités exonérées
• La classe 2 : Indemnités à titre de frais d'emploi de service de route et alloc. similaires
• La classe 3 : Remboursement ou intérêts des prêts déductibles de l'impôt général sur le
revenu
• La classe 4 : Autres Indemnités à titre de frais d'emploi de service de route et alloc.
Similaires
• La classe 5 : Remboursement des prêts non déductibles de l'impôt général sur le revenu
• La classe 6 : Retenues pour pension ou retraite et prévoyance sociale
• La classe 7 : Impôt général sur le revenu
La classe 1 est divisée en deux sous-classes, comprenant chacune une fourchette de
codes rubriques.
1. La sous-classe 10xx à 14xx : cette sous-classe comprend toutes les rubriques
déterminant les salaires « proprement dits », à savoir : le salaire de base, les heures
supplémentaires, la prime d’ancienneté, les congés payés, les commissions, etc...
2. La sous-classe 15xx à 19xx : cette sous-classe comprend toutes les rubriques
définissant les avantages en argent ou en nature qui peuvent être perçus par les
salariés.
_____________________________________________________________________________________
Network and Software Engineering
16/34
MANUEL DE L’UTILISATEUR
!
Travail avec les rubriques
Pour ajouter, chercher, ou supprimer une rubrique veuillez choisir l'option rubrique dans le
menu fichier.
La codifications des rubriques de paie
La codification des rubriques doit respecter les critères suivants :
1. Code : 4 caractères alphanumériques
2. Désignation : 30 caractères alphanumériques
3. Revenu : valeur booléenne (valeur possible : Oui (=1) / Non (=0) )
4. Imposable : dans le cas où la rubrique est codifiée comme revenu, cette valeur indique
si ce revenu est imposable ou non.
_____________________________________________________________________________________
Network and Software Engineering
17/34
MANUEL DE L’UTILISATEUR
!
Chapitre 4
Maintenance des Fichiers et Tables de base
Dans ce chapitre, nous allons présenter les étapes à suivre pour enregistrer les données de
base nécessaires à l’exploitation du programme. Ces étapes sont énoncées dans un ordre
opérationnel.
Toutefois, en ce qui concerne les rubriques de paie leur saisie peut s’effectuer au fur et à
mesure que vous les découvrez pendant votre travail.
Si ces étapes sont menées à bien, ils vous permettront par la suite un gain de temps
appréciable car il ne sera sans doute pas nécessaire d’y revenir.
Avant de passer à la saisie du fichier du Personnel, nous allons voir d’abord comment créer
et manipuler ces enregistrements.
Pour cela vous disposez d’une barre contenant les boutons suivants :
Créer / Valider / Annuler / Supprimer / Chercher / Quitter
Barre de boutons pour la manipulation des enregistrements
_____________________________________________________________________________________
Network and Software Engineering
18/34
MANUEL DE L’UTILISATEUR
!
Créer un nouvel enregistrement :
Pour créer (Ajouter) un nouvel enregistrement à un fichier, cliquez sur le bouton « Créer ».
Les champs de saisie sont alors initialisés aux valeurs par défaut.
Pour valider votre saisie cliquez sur le bouton « Valider », sinon cliquez sur le bouton
« Annuler ».
Modifier un enregistrement :
Pour Modifier un enregistrement, cliquez sur le bouton « Chercher ». Une boîte de dialogue
s’affiche pour vous demander de saisir la clé de l’enregistrement (Matricule dans le cas du
fichier d'un salarié).
Le logiciel cherche l’enregistrement demandé et affiche ses données. Vous êtes alors par
défaut en mode Consultation / Modification.
Pour valider votre modification cliquez sur le bouton « Valider », sinon cliquez sur le bouton
« Annuler ».
Chercher un enregistrement :
Pour chercher un enregistrement, cliquez sur le bouton « Chercher ». Une boîte de
dialogue s’affiche pour vous demander de saisir la clé de l’enregistrement (Matricule dans
le cas du fichier du Personnel).
Le logiciel cherche l’enregistrement demandé et affiche ses données. Vous êtes alors par
défaut en mode Consultation / Modification.
Supprimer un enregistrement :
Pour supprimer un enregistrement, cliquez sur le bouton « Supprimer ». Une boîte de
dialogue s’affiche pour vous demander de confirmer la suppression de l’enregistrement.
Quitter la saisie :
Pour quitter la saisie, cliquez sur le bouton « Quitter ».
_____________________________________________________________________________________
Network and Software Engineering
19/34
MANUEL DE L’UTILISATEUR
!
Enregistrement des fiches salariés
La saisie des fiches salariés est une étape nécessaire à l’exploitation de votre logiciel. Pour
saisir la liste des salariés, choisissez l’option «Personnel» du menu Fichier. Une fenêtre
contenant les champs de saisie concernant chaque Salarié est affichée. Cette fenêtre
contient aussi une barre de boutons servant à manipuler les enregistrements contenu dans
le fichier des salariés.
La fenêtre de saisie des salariés est divisées en 2 parties :
• La première partie contient les champs d'informations générales d'état civil, comme :
le N° CIN, la date de naissance, la situation familliale...
• La seconde partie contient les paramètres de paie du salarié, comme : Date Entrée, type
de paie, N° C.N.S.S…
_____________________________________________________________________________________
Network and Software Engineering
20/34
MANUEL DE L’UTILISATEUR
!
Maintenance des Tables de base
L'option "Tables" du menu "Fichier" sert à gérer les tables de base suivantes :
•
La codification des départements
•
La codification des services
Les options "Barème IGR" ; "Taux Ancienneté" ; "Taux CIMR et Mutuelle" vous permettent
respectivement de faire :
•
La codification des barèmes d'IGR
•
La codification des taux d'ancienneté
•
La codification des taux CIMR et Mutuelle
La codification des Départements et services
La codification des départements et services doit respecter les critères suivants :
1. Code : 4 caractères alphanumériques
2. Nom : 25 caractères alphanumériques
3. Responsable : 25 caractères alphanumériques
La codification des taux CIMR et Mutuelles
La codification des taux CIMR et Mutuelles doit respecter les critères suivants :
1. Catégorie : 4 caractères alphanumériques
2. Taux : valeurs numériques
_____________________________________________________________________________________
Network and Software Engineering
21/34
!
MANUEL DE L’UTILISATEUR
Chapitre 5
La saisie des Revenus
Une fois que vous avez terminé avec le paramétrage de votre application
et la
maintenance des fichiers de base, vous pouvez commencer à saisir les revenus des
salariés.
ENREGISTREMENT DES REVENUS-TYPE
La paie de chaque salarié est constituée d’éléments fixes et d’éventuels éléments
variables. Pour vous économiser le temps de (re)saisie des éléments fixes, OJRA vous
offre la possibilité de les saisir une fois pour toute et de les réutiliser à chaque période de
paie. Ces revenus fixes sont désignés dans OJRA par le terme « revenus-type ».
Pour saisir les revenus-type :
"
Allez dans le menu « Définitions des revenus », puis cliquez sur l’option "Revenus
Type" . Vous avez deux possibilités :
# Une saisie globale : pour la saisie des revenus types de plusieurs salariés
# Une saisie / Matricule : pour la saisie du revenu-type d’un seul salarié
"
Dans la fenêtre de saisie, Entrez le matricule du salarié pour lequel vous désirez définir
les revenus-type;
"
Cliquez sur le bouton « Chercher », pour consulter les rubriques qui sont éventuellement
déjà saisies pour ce salarié ;
"
Saisissez ensuite les rubriques de paie qui lui sont associées.
Remarque : Pour visualiser la liste des rubriques, cliquez sur le bouton ‘Afficher Rub.’.
_____________________________________________________________________________________
Network and Software Engineering
22/34
MANUEL DE L’UTILISATEUR
!
ENREGISTREMENT DES REVENUS REELS
L’enregistrement des revenus réels est une étape nécessaire pour le calcul de la paie.
Selon que le salarié est payé par jour, par semaine, par quinzaine ou mensuellement ;
OJRA vous propose les fenêtres adéquates pour exécuter cette opération.
Deux méthodes sont disponibles pour saisir le revenu réel d’un salarié. Ces deux méthodes
sont détaillées ci-dessous.
Méthode 1 : Vous avez déjà défini le revenu-type d’un salarié
"
Dans le menu « Définition des Revenus » ; choisissez l’option « Revenus Mensuels »
(ou autre)
"
Saisissez la période de paie, puis cliquez sur « Importer » pour importer les revenustype que vous avez déjà saisis
"
Une fois les revenus importés, ils sont affichés. Vous pouvez modifier leur valeur ou
ajouter d’autres revenus.
Remarque : La saisie des revenus-types vous permet de gagner un temps appréciable et
d’éviter les éventuelles erreurs de saisie.
_____________________________________________________________________________________
Network and Software Engineering
23/34
MANUEL DE L’UTILISATEUR
!
Méthode 2 : Vous n’avez pas défini de revenu-type pour un salarié
"
Dans le menu « Définition des Revenus » ; choisissez l’option « Revenus Mensuels »
(ou autre)
"
Saisissez la période de paie
"
Pour chaque revenu d’un salarié : saisissez son matricule, la rubrique de paie associée
et leurs valeurs
Remarque : le bouton "Prime d'Anc." affiché en bas de l'écran de saisie des revenus (voir
figure ci-dessous) sert à calculer et mettre à jour automatiquement les taux d'anciennetés
des salariés.
Il est conseillé de l'exécuter avant chaque calcul de la paie.
MAJ DES REVENUS
Vous avez la possibilité de mettre a jour vos revenus en choisissant l’option ‘’ Mise a jour
des revenus ’’ qui existent dans le menu ‘’ Définition des revenus’’ avec un possibilité de tri
selon le N CNSS / N CIMR/ N Mutuelle ou bien par Matricule
_____________________________________________________________________________________
Network and Software Engineering
24/34
!
MANUEL DE L’UTILISATEUR
Exemple :
Un salarié payé au mois, marié avec 2 enfants à charge, présente la situation suivante à la
fin du mois de Janvier 2000.
Salaire de base
8 000.00 DH
Prime de panier
900.00 DH
Indemnité de logement
900.00 DH
Indemnité Téléphonique
650.00 DH
Prime de transport
400.00 DH
Analyse de l'exemple :
Supposons que ce salarié bénéficie tous les mois de la même somme de prime de panier,
d’indemnité de logement et que l'indemnité téléphonique ainsi que la prime de transport est
une exception pour ce mois.
Commentaire
Dans ce cas de figure, notre salarié possède des rubriques de paie qui sont fixes ( qui
apparaissent chaque mois dans son Bulletin de paie) :
♦ Rubrique Salaire de base
♦ Rubrique Prime de panier
♦ Rubrique Indemnité de logement
Les rubriques non fixes (exception de chaque mois) :
♦ Rubrique Indemnité Téléphonique
♦ Rubrique Prime de transport
_____________________________________________________________________________________
Network and Software Engineering
25/34
MANUEL DE L’UTILISATEUR
!
Saisie dans OJRA
♦ Vous allez créer un revenu-type pour ce salarié qui va contenir les rubriques fixes
♦ Vous allez créer un revenu-mensuel pour ce salarié en important les éléments fixes
(revenu-type) que vous avez définis au préalable et en saisissant ensuite les éléments
variables.
Commentaire :
1. Créer pour ce salarié un revenu-type qui va
contenir que les rubriques fixes.
2. Allez dans le menu "Définition des revenus
mensuels", saisissez votre période de paie, entrez le
Matricule de votre salarié et cliquez sur le bouton
"Importer" pour importer les rubriques déjà saisies
dans le revenu-type de ce salarié.
3. Après avoir importé les rubriques relatives au
revenu-type, commencez à saisir les rubriques
variables (exceptionnelles) pour ce mois. Et validez
par OK à la fin de la saisie.
_____________________________________________________________________________________
Network and Software Engineering
26/34
MANUEL DE L’UTILISATEUR
!
Chapitre 6
Le calcul de la paie et édition des bulletins
Calcul de la paie
Le calcul de la paie suppose que vous avez, au préalable, saisi :
1. Les fiches salariés (Menu « Fichier -> Personnel »)
2. Les revenus réels des salariés (Menu « Définition des revenus -> Revenus
Mensuels... »)
Pour calculer la paie, cliquez sur l’option « Calcul de la paie » dans le menu « Calcul de la
paie ». La fenêtre de calcul est affichée.
La fenêtre de calcul de la paie est constituée :
"
d’un cadre « Type de paie » : Journalière / Hebdomadaire / Mensuelle...
"
d’un cadre « Période de paie » : pour définir la période de la paie
"
d’un cadre « Sélection des salariés » : pour sélectionner les salariés selon vos besoins
(tous les salariés/ un groupe de salariés/ un seul salarié)
Pour lancer le calcul, cliquez sur le bouton « OK »
Remarque :Vous pouvez éditer les bulletins automatiquement après le calcul de la paie, en
cochant la case « Imprimer automatiquement les bulletins » dans l’option « Calcul de la
paie ».
Annulation de la paie
Pour annuler la paie, cliquez sur l’option « Annuler la paie » dans le menu « Calcul de la
paie »
_____________________________________________________________________________________
Network and Software Engineering
27/34
MANUEL DE L’UTILISATEUR
!
Régularisation de l'IGR
Pour la régularisation de l’IGR en fin d’année, cliquez sur l’option « Calcul fin d’année »
dans le menu « Calcul de la paie »
Edition des Bulletins de paie
Pour Editer les bulletins de paie, suivez les instructions ci-dessous :
Dans le menu « Edition», cliquez sur l’option « Edition des Bulletins ». La fenêtre d’édition
est affichée. Elle est constituée
"
d’un cadre « Type de paie » : Journalière / Hebdomadaire / Mensuelle...
"
d’un cadre « Période de paie »
"
d’un cadre « Sélection des salariés »
Pour lancer l’édition, cliquez sur le bouton « OK »
_____________________________________________________________________________________
Network and Software Engineering
28/34
!
MANUEL DE L’UTILISATEUR
Chapitre 7
Gestion des prêts et avances
Dans le menu "Gestion des prêts", vous avez la possibilité de choisir les options suivantes :
•
" Saisie des prêts " : pour saisir des prêts accordés aux employés (Voir figure 1)
•
" Liste des prêts " : pour rechercher à base de plusieurs critères les prêts accordés aux
employés
•
" Générer les retenus " : pour générer des retenus de prêts accordés aux employés.
Il faut renseigner le Matricule / Date du Prêt /Date Début Remb /Montant du Prêt /
Montant Echéa.
Génération des Retenus :
Pour effectuer cette opération, il faut renseigner :
♦
La période de paie
♦
La fourchette des Matricules
Le programme calcule automatiquement la Retenue à effectuer pour le / les salarié (s) que
vous avez défini.
Vous avez la possibilité de modifier la valeur à retenir selon votre besoin.
_____________________________________________________________________________________
Network and Software Engineering
29/34
MANUEL DE L’UTILISATEUR
!
Remarque : le Traitement s'effectue Salarié par Salarié et vous êtes amené à cliquer sur le
Bouton " Suivant " pour visualiser vos enregistrements.
_____________________________________________________________________________________
Network and Software Engineering
30/34
!
MANUEL DE L’UTILISATEUR
Chapitre 8
L’EDITION D’UN ETAT
Le menu ‘’Editions’’ regroupe tous les états disponibles dans NSE-OJRA. Ces états
peuvent être visualisés sur écran ou imprimé directement. Pour toutes les éditions qui vous
sont proposées, vous disposez d’un générateur d’états qui vous permet de faire des
sélections selon plusieurs critères.
L’utilisation de ce générateur est assez simple, il suffit de choisir le ou les champs sur
lesquels vous voulez faire votre sélection, le critère de sélection (=, < , > , <= , >=) et la
valeur de comparaison (Nombre, date ou Texte). Si vous ne définissez aucune sélection, le
générateur d’états traite tous les enregistrements existants dans votre base de données.
Pour vous montrer l’utilisation du générateur d’états, nous vous proposons de traiter un
exemple : Prenons le cas de l’Edition d'un état des Revenus.
Pour éditer cet état, il faut suivre les étapes suivantes :
1. Aller dans le menu « Edition »
2. Activer l’option « Etat des Revenus
L'écran suivant est alors affiché :
Figure : Générateur d’états
_____________________________________________________________________________________
Network and Software Engineering
31/34
MANUEL DE L’UTILISATEUR
!
La fenêtre ci-dessus vous donne la possibilité de faire une sélection sur 4 critères :
• Une sélection sur le Matricule du Salarié
• Deux sélections sur les dates de paie
• Une sélection sur le type de paie (Mensuel , journalier , …)
Exemple :
Supposons que nous voulons avoir : l'état des revenus entre le 01/10/1999 et le 30/10/1999
de tous les salariés.
Il suffit de procéder comme suit :
1. Dans le cadre associé à la première date, sélectionnez le critère de comparaison ‘’ >= ‘’
dans la liste des opérateurs, puis saisissez la date début qui est dans notre exemple :
01/10/1999 ;
2. Dans le cadre associé à la seconde date, sélectionnez le critère de comparaison ‘’ <= ‘’
dans la liste des opérateurs, puis saisissez la date qui correspond dans notre
exemple au : 31/10/1999 ;
3. Cliquez sur le bouton OK pour lancer l’édition.
Une fenêtre contenant le résultat de la sélection s’affiche en mode visualisation. Vous
pouvez imprimer cet état en cliquant sur le bouton « imprimante ».
_____________________________________________________________________________________
Network and Software Engineering
32/34
!
MANUEL DE L’UTILISATEUR
Chapitre 9
Le Serveur OJRA OLE
Le logiciel Ojra vous est livré avec un serveur OLE (Object Linking and Embedding) qui va
faciliter d'une manière remarquable la personnalisation de votre gestion de paie et vous
faire gagner un temps appréciable.
Il s'est avéré judicieux de vous le présenter pour plus de maîtrise de l'ensemble du
Kit Ojra.
Le serveur OJRA se présente comme un Kit de développement contenant des
bibliothèques de procédures que vous pouvez utiliser à partir de n'import client OLE
(Microsoft Excel, Microsoft Word,…).
Dans ce chapitre, nous allons expliquer son utilisation avec un classeur Excel.
Ojra de Paie
Lien Dynamique
Serveur Ojra
OLE
Procédure :
1. Dans votre feuille Excel, il vous suffit de renseigner la période de paie, de saisir les
matricules des salariés, ainsi que les différents Taux de prime que vous voulez accorder
à vos employés.
2. Après avoir terminé la saisie, il suffit de cliquer sur un bouton pour envoyer vos
données au logiciel Ojra afin d'effectuer vos calculs de paie et éditer par la suite vos
bulletins de paie.
_____________________________________________________________________________________
Network and Software Engineering
33/34
!
MANUEL DE L’UTILISATEUR
ANNEXE
LLiissttee ddeess ééttaattss
Option
Edition des Bulletins
Etat des virements
Liste des salariés
Liste des rubriques
Liste des revenus-Types
Etat des revenus
Etat des salaires
Etat des Prêts
Déclaration CNSS
Déclaration IGR
Déclaration CIMR
Déclaration Mutuelle
Récap. Salaire-Mensuel
Récap. Salaire-Annuel
Etat centralisateur
Etat 9421
Etat
Le bulletin de paie
Etat des virements
Trié / Matricule
Trié / Nom
Trié /Date Entrée
Groupé /service
Groupé /Département
Fiche Texte CNSS
Trié /code
Trié / Désignation
Etat des revenus-types
Etat des revenus
Etat des salaires
Etat des prêts
Etat CNSS /Salarié
Etat CNSS / Mois
Bordereau de Déc.Sal
Etat IGR / Salarié
Etat IGR / Mois
Etat CIMR / Salarié
Etat CIMR / Mois
Etat CIMR / Trimestre
Etat Mutuelle / Salarié
Etat Mutuelle / Mois
Etat Mutuelle / Trimestre
Récap. Salaire-Mensuel
Récap. Salaire-Annuel
Etat centralisateur
Etat 9421
_____________________________________________________________________________________
Network and Software Engineering
34/34
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising