Basler Microscopy Software 取扱説明書

Basler Microscopy Software 取扱説明書
用户手册
Basler Microscopy
Software
目录
1.
关于本软件 .......................................................... 3
2.
使用Basler显微镜软件 ................................................ 4
3.
2.1.
简介 - 用户界面 ........................................................... 4
2.2.
使用文档 .................................................................. 5
采集图像 ............................................................ 7
3.1.
采集单幅图像 .............................................................. 7
3.2.
摄像控制 .................................................................. 9
3.2.1.
3.2.2.
3.2.3.
3.2.4.
3.2.5.
3.3.
采图设置 ................................................................. 20
3.3.1.
3.3.2.
3.3.3.
3.3.4.
3.3.5.
3.3.6.
3.3.7.
3.3.8.
4.
5.
6.
将实时图像最大化至整个屏幕 ........................................... 14
自动曝光时间 ......................................................... 14
手动曝光时间 ......................................................... 16
设置摄像头分辨率 ..................................................... 17
切换子阵列 ........................................................... 18
采图设置
采图设置
采图设置
采图设置
采图设置
采图设置
采图设置
采图设置
-
采集 - 常规 ............................................... 20
文档名 .................................................... 22
保存 ...................................................... 23
摄像头 - 常规 ............................................. 24
摄像头 - 调节 ............................................. 26
摄像头 - 颜色 ............................................. 27
摄像头 - 曝光 ............................................. 28
摄像头 - 信息 ............................................. 28
使用图像 ........................................................... 29
4.1.
更改图像的显示方式 ....................................................... 29
4.2.
处理图像 ................................................................. 32
4.3.
在图像上执行白平衡 ....................................................... 33
4.4.
使用绘图对象 ............................................................. 34
测量图像 ........................................................... 36
5.1.
总览 ..................................................................... 36
5.2.
测量图像 ................................................................. 38
配置系统 ........................................................... 43
6.1.
总览 ..................................................................... 43
6.2.
配置系统 ................................................................. 44
6.3.
手动放大倍率校准 ......................................................... 45
关于本软件
1.
关于本软件
采集图像
请注意: 视您使用的摄像头而定,摄像头和采集设置会有所不同。
您可以使用本系统在几步内采集到样品的高分辨率图像。本系统包括软件、Basle
r 摄像头和显微镜。通过图像采集流程,数据可以从安装在显微镜上的摄像头读
取,并显示在计算机显示屏上。
您可以先查看实时图像,并针对其进行最佳设置。实时图像会持续刷新。这意味
着,如果您移动了样品台,实时图像也会相应变化。您可以开启和关闭实时图
像,也可以采集所关注的样品部分的图像。执行该操作时,您将创建数字图像;
您可以保存该图像,并通过本软件的多种功能对其进行处理或测量。
测量图像
您可以对图像进行各种测量。例如,测量线条的长度。测量对象会显示在图像的
绘图层中。因此,您可以保留图像的所有信息。测量结果显示于表格中,与图像
一起保存。
处理图像
您可以处理采集到的图像,并按用途优化图像质量。优化时,您可以使用滤镜和
对比度优化函数。
00017 20112015
3
使用Basler显微镜软件
2.
使用Basler显微镜软件
2.1. 简介 - 用户界面
6B
图形用户界面决定了本软件的外观。它可以确定显示哪些菜单、如何调用各个功
能、如何以及在何处显示图像等内容。下面将描述用户界面的基本元素。
用户界面的外观
插图显示了示意性用户界面及其基本元素。
(1)
(2)
(3)
(4)
(5)
菜单栏
文档组
工具栏
工具窗口
状态栏
(1) 菜单栏
可以通过使用对应菜单调用多个命令。视图菜单包含各种命令,通过该菜单,您
可以更改用户界面的外观。
(2) 文档组
文档组包含所有已载入的图像。
启动本软件时,文档组为空。随着本软件的使用,文档组中会填入内容,例如,
在载入或采集图像或执行各种图像处理操作来更改源图像和创建新图像时。
(3) 工具栏
经常使用的命令链接到某个按钮,从而可以快速便捷地访问这些功能。请注意,
有很多功能只能通过工具栏访问,如为图像添加批注所需的绘图功能。
(4) 工具窗口
工具窗口将各种功能合并到不同的组中。这些可能是差别很大的功能。例如,在
属性工具窗口中,您可以找到可用于活动图像的所有信息。与对话框不同的是,
工具窗口只要开启就会始终在用户界面上可见。这样您即可随时访问工具窗口中
的设置。
(5) 状态栏
状态栏包含许多信息,如每个功能的简要描述。将鼠标指针放在命令名称或按钮
上,即可显示功能的简要描述。
00108 14092015
4
使用Basler显微镜软件
2.2. 使用文档
7B
可通过多种方法来打开、激活、保存或关闭图像。
保存图像
对于重要的图像,应始终在采集后便立即保存。如果图像名称后面带有星号图
标,则说明该图像尚未保存。
可通过多种方法来保存图像。
自动保存
1.
要保存单个图像,请在文档组中激活它。然后使用文件 > 另存为... 命
令或 [Ctrl + S] 键盘快捷键。
2.
使用文档工具窗口。
选定所需文档,然后使用上下文菜单中的保存命令。对于选定文档,多重
选定仍遵循 MS - Windows 的通用风格。
3.
使用画廊工具窗口。
选定所需文档,然后使用上下文菜单中的保存命令。对于选定文档,多重
选定仍遵循 MS - Windows 的通用风格。
1.
退出软件时,尚未保存的所有图像均会在未保存的文档对话框中列出。这
样您就有机会决定仍需要保存哪些图像。
2.
可以通过配置软件使所有图像在采集之后便自动保存。为此,请使用采图
设置 > 保存对话框。可以在这里通过配置本软件使所有图像在采集之后
便自动保存到数据库。
关闭图像
在软件中可通过多种方法来关闭图像。
1.
使用文档工具窗口。
选定所需图像,然后使用上下文菜单中的关闭命令。选择图像时,关于多
重选定的标准 MS-Windows 习惯适用。
2.
要关闭单个图像,请在文档组中激活该图像,然后使用文件 > 关闭命
令。或者,您也可以单击叉形按钮 [ x ]。您可以在图像选项卡标题的右
上角的图像名称旁找到该按钮。
3.
使用画廊工具窗口。
选定所需图像,然后使用上下文菜单中的关闭命令。选择图像时,关于多
重选定的标准 MS-Windows 习惯适用。
关闭所有图像
要关闭所有载入的图像,请使用全部关闭命令或 [Ctrl + Alt + W] 键盘快捷
键。该命令可在文件菜单以及文档和画廊工具窗口的上下文菜单中找到。
立即关闭图像
要立即关闭图像而不提示保存它,请在关闭它时按 [Shift] 键。未保存的数据将
会丢失。
5
使用Basler显微镜软件
打开图像
可通过多种方法打开或载入图像。
1.
使用文件 > 打开... 命令。
2.
将所需图像从 MS-Windows 资源管理器直接拖到软件的文档组中。
请注意: 同时,最多可在文档组中载入 150 个文档。
生成测试图像
为了熟练掌握本软件,有时候可以通过任意图像来尝试某项功能。
按 [Ctrl + Shift + Alt + T] 可生成彩色测试图像。
使用 [Ctrl + Alt + T] 快捷键,可以生成灰度值为 256 的测试图像。
激活文档组中的图像
有以下几种方法可激活文档组的其中一个图像,并将其显示在显示屏上。
1.
使用文档工具窗口。在该工具窗口中单击所需的图像。
2.
使用画廊工具窗口。在该工具窗口中单击所需的图像。
3.
在文档组中单击所需图像的标题。
4.
单击文档组右上角的小箭头
显示在显示屏上的图像。
以打开所有载入图像的列表。左键单击要
请注意: 您可以选定是通过单击鼠标还是通过双击鼠标在文档工具窗口和画廊工
具窗口中激活图像。
使用工具 > 选项... 命令。然后在树状视图中选定环境 > 常规选项。
选中通过单击激活文档复选框。此后,您只需单击鼠标左键,即可让所选图像显
示在文档组中。
若清除该复选框,现在可通过双击激活图像。
将图像附加到电子邮件
1.
载入要附加到电子邮件的图像。
2.
使用文件 > 发送电子邮件... 命令。
3.
检查是否选择了要附加的所有图像。
4.
单击发送按钮,以生成一封将选定图像以附件形式包含在内的电子邮件。
5.
•
如果所有图像的文件大小总和超过所允许的最大值,您将收到一条警
告消息。
•
新建电子邮件表单将由电子邮件程序打开。为此,电子邮件程序不需
要已经运行。此电子邮件将所有选定的图像文件作为附件包含在内。
输入收信人的地址和您的消息,然后寄出电子邮件。
00143 20112015
6
采集图像
3.
采集图像
3.1. 采集单幅图像
8B
您可以使用本软件在几步内采集到样品的高分辨率图像。在初次采集时,您应该
按照下面说明的步骤逐步完成。这样当您以后对类似的样品再次采集时,您会发
现初次采集时所做的许多设置都可以不用更改就直接采用。
1.
使用视图 > 布局 > 还原当前布局命令。
•
可以在用户界面上边缘菜单栏的正下方找到显微镜控制 (1) 工具栏。
在文档组的右侧,可以找到摄像控制 (2) 工具窗口。
设置放大倍率
2.
在显微镜控制工具栏上,单击您想要用于图像采集的物镜所对应的按钮。
打开实时图像
3.
在摄像控制工具窗口中单击实时观察按钮。
•
4.
实时图像 (3) 现在将显示在文档组中。将为实时图像自动创建新的图
像文档。
移动至样品中您感兴趣的位置。
采图设置中的首选项
使用采图设置设定图像采集的默认设置。
5.
打开采图设置对话框。为此,单击摄像控制工具窗口的工具栏上的采图设
置按钮。
6.
然后在树状视图中选定摄像头 > 常规选项。
从色温列表中,选择一种预定义的色彩设置,以在特定光线条件下采集样
品。选定所需色温。
7.
执行 Gamma 矫正。
在树状视图中选定摄像头 > 调节选项。
移动 Gamma 系数滑动游标可增加亮图像区域中的图像对比度,或仅增加
暗图像区域中的图像对比度。
8.
单击确定关闭采图设置对话框。
7
采集图像
摄像控制的设置
使用摄像控制工具窗口的功能设置图像质量。
9.
采集和保存图像
对焦到样品上。聚焦指针工具栏可帮助您对样品进行聚焦。
10.
核对色彩再现。如有必要,请执行白平衡。
11.
核对曝光时间。您既可以使用自动曝光时间功能,又可以手动输入曝光时
间。
12.
选定所需的分辨率。
13.
在摄像控制工具窗口中单击拍照按钮。
•
14.
采集的图像将显示在文档组中。
使用文件 > 另存为... 命令保存该图像。请使用 TIF 文件格式。
00027 20042016
8
采集图像
3.2. 摄像控制
9B
使用摄像控制工具窗口采集图像。默认情况下,该工具窗口会显示在用户界面的
右侧。如果该工具窗口不可见,请使用视图 >工具窗口 > 摄像控制命令将其打
开。
请注意: 摄像控制工具窗口中有些设置 (如可用分辨率) 会因摄像头的不同而有
所差异。因此,您使用的摄像头的功能可能和这里所描述的有所不同。
该工具窗口的结构
工具窗口由若干个部分构成。
(1)
(2)
(3)
(4)
(5)
(6)
工具窗口中的工具栏
采集图像
调整曝光时间
设置分辨率
输入图像注释
更改摄像头设置
9
采集图像
(1) 工具窗口的工具栏
在摄像控制工具窗口中,您可以找到下列按钮。您可以在工具窗口顶部的工具栏
中发现这些按钮。
白平衡
在摄像头上对实时图像执行白平衡。
聚焦指针
单击该按钮可显示聚焦指针工具栏。该工具栏可用作帮
助您对样品进行对焦的工具。
切换彩色灰度模式
可以选择使用摄像头采集实彩色图像还是灰度图像。
采图设置
单击该按钮,随后便可改变图像采集的各种设置。
单击该按钮可显示与其对应的工具窗口调节显示。该工
具窗口为您更改当前图像的外观提供了多种方法。
调节显示
当显示该工具窗口时,该按钮将显示为已点击状态。您
可通过按钮的背景颜色识别这种状态。要再次关闭该工
具窗口,请单击工具窗口标题中的叉号
。
切换饱和度指针
在实时模式下应用伪彩色方案。
最大化至整个屏幕
单击该按钮,可以仅在显示屏上显示实时图像。这样,
用户界面将会完全隐藏。
载入摄像头设置
保存摄像头设置
可以将摄像控制工具窗口中的所有当前摄像头设置保存
为参数集,之后便可在任意时间载入。例如,在需要为
特定样品设置某些定义的采集条件时使用。
10
采集图像
白平衡
在实时模式下,单击该按钮旁的小箭头,可打开可用白平衡功能列表,您可以选
择所需的功能。活动的功能将以该按钮上的图标指示。选定的功能也会通过菜单
中的勾号标识。
先决条件: 摄像头在 RGB 模式下运行。
切换彩色灰度模式
单触白平衡
选择单触白平衡命令,对活动的实时图像执行白平衡。
所确定的颜色设置会一直使用,直到您再次单击单触白
平衡按钮为止。
自动白平衡
在此模式下,颜色设置会持续地进行检查和调整。
对感兴趣区执行白平衡
使用对感兴趣区执行白平衡命令确定想用于白平衡的特
定图像片段。
一些摄像头也可用于采集灰度图像。
摄像头处于 RGB 模式,且在采集实彩色图像时,切换彩色灰度模式按钮如前所
示。释放该按钮以使用摄像头来采集灰度图像。
摄像头处于灰度模式,且在采集灰度图像时,切换彩色灰度模式按钮如前所示。
单击按钮可使用摄像头采集彩色图像。
切换饱和度指针
先决条件: 摄像头在灰度模式下运行。
饱和度指针可显示图像(或图像的一部分)是否曝光不足或曝光过度。开启饱和
度指针后,在实时图像中,所有亮度值过低的像素将以蓝色显示,而所有亮度过
高的像素将以红色显示。如果能在图像中看到过多的蓝色像素,说明图像曝光不
足。如果能在图像中看到过多的红色像素,说明图像曝光过度。
该调色板仅适用于实时图像。您采集的图像将会是普通的灰度图像。
(2) 采集图像
采集图像
单击实时观察按钮,可将摄像头切换到实时模式。图像窗口中随即会显示实时图
像。该按钮的外观也将发生变化。这使您可以立即认出已处于实时模式。
处于实时模式时,再次单击实时观察按钮可结束该模式,同时不采集图像。您也
可以采用另一种方法。为此,请使用采图设置 > 采集 > 常规对话框。
单击拍照按钮可以采集图像。此时通常会退出实时模式。采集的图像将显示在文
档组中。
图像采集 - 几种方法
可通过以下几种方法切换到实时模式来采集拍照:
• 使用摄像控制工具窗口。
• 使用采集 > 实时观察或采集 > 拍照菜单命令。
• 使用 [F7] 键可以切换到动态模式。
使用 [F8] 键采集图像。
11
采集图像
(3) 调整曝光时间
使用曝光组来设置曝光时间。
曝光时间控件内的功能取决于您选定的是使用自动曝光时间选项还是手动设置曝
光时间。始终会默认设置自动选项。
(1) 自动曝光时间
(2) 手动曝光时间
图像属性中的曝光时间
每次采集图像后,属性工具窗口中都会采用该曝光时间。您可以在摄像头组中找
到该信息。如果图像以 TIF 文件格式保存,则该信息将得到保留。
(4) 设置分辨率
可使用分辨率组来设置摄像头的分辨率。
请注意: 各种可用的分辨率取决于所使用的摄像头。
可以为实时图像和采集到的图像分别设置不同的分辨率。您可从实时观察列表或
者拍照列表 (1) 中选定所需的分辨率。
另一种降低摄像头分辨率的方法是使用子阵列缩小图像区域 (2) 的大小。
(1) 设置摄像头分辨率
(2) 切换子阵列
12
采集图像
(5) 输入图像注释
您可以在摄像控制工具窗口的便笺字段中输入文本。该文本随后将作为每次图像
采集的注释随图像一起保存。
请注意: 保存当前摄像头设置时,本软件不会保存便笺字段中的文本。关闭本软
件时,注释字段中的文本将会删除。
查看注释
在图像窗口中显示注释
删除或编辑单幅图像的
注释
采集图像后,可以在属性工具窗口的文档 > 注释字段中查看和编辑图像注释。为
此,载入图像,并使用 (例如) 视图 >工具窗口 > 属性命令显示该工具窗口。
可以让图像注释随信息印记一起显示在图像窗口中。
1.
转到属性工具窗口中的文档组。
•
2.
您将看到在摄像控制工具窗口所输入的注释已经被应用到便笺字段
中。
单击便笺字段。
•
当便笺字段处于激活状态时,会出现带有三个点的小按钮。
3.
单击该按钮。
4.
在便笺对话框中删除或更改注释。
(6) 更改摄像头设置
使用摄像头设置组更改亮度、对比度和颜色设置。
亮度和对比度
如果整幅图像太亮或太暗,请使用亮度滑动游标。数值小于 0 会降低图像亮度。
数值大于 0 会增加图像亮度。
移动对比度滑动游标可更改图像的对比度数值。数值小于 1 会降低图像对比度。
数值大于 1 会增强图像对比度。
更改图像对比度时,图像中最亮的部分将始终保持不变。
更改图像对比度后,图像的黑暗区域或明亮区域可能不再以最佳效果显示。在这
种情况下,可使用亮度滑动游标将整幅图像调至更亮或更暗。
您也可以在采图设置 > 摄像头 > 调节对话框中更改对比度和亮度值。
这些值随图像一起自动保存。您可以在属性工具窗口中查看这些值。
色调和饱和度
当图像中某种颜色占多数时,您可以增加饱和度数值。这样,您便可以使图像中
的其它颜色得到更好的再现。
要更改该参数,请移动其滑动游标。对饱和度的更改将会影响到所有色彩通道。
使用色调值改变所采集图像的颜色印象。例如,可以更好地识别图像中的某些结
构。
值 180 意味着图像中的颜色对应于样品颜色。
您也可以在采图设置 > 摄像头 > 颜色对话框中更改饱和度和色调值。
这些值随图像一起自动保存。您可以在属性工具窗口中查看这些值。
实时帧速率
实时帧速率字段显示实时模式下的当前帧速率(每秒图像数)。
在实时模式下,会有大量数据从摄像头传输到计算机。可能会发生系统的 USB 连
接数据传输速度不够高,无法支持全数据速率。这可能导致实时图像中出现某些
错误(例如,不顺畅或颜色失真)。
在这种情况下,可使用数据速率滑块减少传输的数据量。您可以在采图设置 > 摄
像头 > 调节对话框中找到此滑块。
6103 20042016
13
采集图像
3.2.1. 将实时图像最大化至整个屏幕
如果想在显示屏上只看到实时图像,请单击最大化至整个屏幕按钮。这样,用户
界面将会完全隐藏。您可在摄像控制工具窗口中找到该按钮。
实时图像的大小
关闭“最大化”模式
设置图像背景
在切换到“最大化”模式后,实时图像的缩放比例将无法更改。如果您要在“最
大化”模式下查看整幅实时图像,请在切换到“最大化”模式之前,单击适配窗
口大小按钮。
要关闭该模式并返回普通用户界面,请使用 [Esc] 键或单击退出最大化屏幕按
钮。
在“最大化”模式中,实时图像并不一定会占据整个显示屏的屏幕。您可以设置
一种不同的背景颜色。例如在处理荧光采集时,如果查看灰色背景的图像,则漫
射光可能会造成干扰。在这种情况下,您可以将背景设置为黑色。
为此,请使用工具 > 选项...命令。在树状视图中选定图像 > 常规选项。从背景
列表中选定您需要的背景。
3948 12015
3.2.2. 自动曝光时间
某些曝光时间矫正设置取决于使用的摄像头型号。因此,对于您的摄像头,曝光
组可能具有不同的外观。
打开自动曝光时间
用于设置曝光时间的功能可在摄像控制工具窗口中找到。
选定位于曝光组中的自动选项来选定自动曝光时间。
在自动曝光时间模式中,系统会连续计算实时图像的最佳曝光时间。拍照采集始
终使用在自动曝光时间模式中计算出的最后一个曝光时间。
“曝光”组中的功能
摄像控制工具窗口中的曝光组提供了可反映自动曝光时间模式功能的选项。
(1)
(2)
(3)
(4)
显示曝光时间
锁定当前曝光时间
设置区域
设置增益
14
采集图像
(1) 显示曝光时间
当前曝光时间显示在摄像控制工具窗口中和摄像控制工具栏上。
当前曝光时间也显示在摄像控制工具窗口中的功能组标题中。这将确保始终显示
曝光时间,即使您最小化功能组并且仅标题保持可见。
(2) 锁定当前曝光时间
单击锁定当前曝光时间
按钮,将当前计算出的曝光时间应用到整个动态采集
期间。
这样,您便关闭了图像采集期间的自动调整功能。这意味着即使您将摄像头移动
到了样品上完全不同的另一个地方,曝光时间也不会进行相应调整。
锁定当前曝光时间按钮保持激活状态 (也针对以后的实时图像),直到您再次将其
关闭。
(3) 设置区域
曝光时间始终基于直方图,即图像中的亮度分布进行计算。从区域列表中选定将
用于计算直方图进而计算自动曝光时间的图像片段。
完整图像
选定完整图像选项,以使整个图像的直方图都能用于计算曝光时间。如果将要观
察的结构均匀分散于整幅图像,那么建议使用该方法。
光斑
选定光斑选项,以计算只有一个矩形图像片段的直方图。区域列表中所示的大小
取决于所用的摄像头型号。切换到实时图像后,可看到标识对应图像片段的白色
虚线矩形。对于有些摄像头,您可以通过按住鼠标左键将该矩形框拖动到图像中
的任何位置,不过这种方法会影响曝光时间。如果相关详情仅在部分图像中可
见,也可使用该方法。这样便可最优化外观,以精确显示该图像片段。
以后如果需要,还可更改您已选定的图像片段。
(4) 设置增益
如果需要缩短曝光时间同时不使图像变暗,可使用增益滑动游标。增益增加越
多,曝光时间越短。但是,这将增大图像噪音。因此仅在确实需要缩短曝光时间
时使用增益滑动游标。
00127 04112015
15
采集图像
3.2.3. 手动曝光时间
打开手动曝光
用于设置曝光时间的功能可在摄像控制工具窗口中找到。
选定手动选项。然后您就可以根据需要来设置曝光时间。
“曝光”组中的功能
(1) 设置和显示曝光时间
(2) 设置增益
(1) 设置和显示曝光时间
调整曝光时间
显示曝光时间
手动设置曝光时间有以下几种不同方法。
•
为此,请移动滑动游标。
•
单击 [-] 和 [+] 按钮逐步更改曝光时间。
•
在编辑字段中输入曝光时间,然后按 [Enter] 键。或使用编辑字段旁边
的箭头按钮更改曝光时间。
当前曝光时间显示在摄像控制工具窗口中和摄像控制工具栏上。
当前曝光时间也显示在摄像控制工具窗口中的功能组标题中。这将确保始终显示
曝光时间,即使您最小化功能组并且仅标题保持可见。
(2) 设置增益
如果需要在不改变显微镜的曝光时间或照明亮度的同时增加灵敏度,可使用增益
滑动游标。增益增加越多,图像越亮。例如,当荧光很弱时,可以使用该设置。
00128 04112015
16
采集图像
3.2.4. 设置摄像头分辨率
在摄像控制工具窗口中,可使用分辨率组来设置摄像头的分辨率。如果该组未显
示,只需双击分辨率区域即可。
请注意: 大多数摄像头都能够以多种分辨率采集图像。有哪些分辨率可供使用,
这取决于所使用的摄像头。
“分辨率”组中的功能
(1)
(2)
(3)
(4)
设置实时图像的分辨率
设置拍照的分辨率
对实时观察和拍照使用相同的分辨率
切换子阵列
(1) 设置实时图像的分辨率
在实时列表中,选定所需的实时图像分辨率。例如,1920x1080 分辨率表示所采
集的图像由 1920x1080=2073600 个像素组成。
对于大多数摄像头,您可以在实时图像中减小分辨率。该方法将在分辨率后面的
括号中指出。选定的分辨率越小,实时图像反应就越快。相反,分辨率越大,图
像的空间分辨率就越好。
像素合并
使用像素合并方法时,摄像头上的像素在被读出时会进行合并。这样,从摄像头
传送到软件中的数据就会更少,实时图像的更新就会更快。
当您选定使用了像素合并模式的分辨率时,术语“像素合并”将会添加到分辨率
后的括号里。
切换子阵列
与像素合并模式一样,当减小图像区域的大小时,实时图像的反应速度将会增
加,并且会减小文件大小。不过与像素合并相反,当减小图像区域的大小时,显
示在实时图像中的图像片段将会以相同的空间分辨率显示,也就是说没有质量损
失。
分辨率组中有可用于减小图像区域的功能。
(2) 设置拍照的分辨率
在拍照列表中选定所需的拍照分辨率。
如果以较低分辨率采集图像,则可以获得较小的文件。使用 1920x1080 摄像头分
辨率时,采用最高分辨率的图像需要约 6000 KB 的储存容量,而采用最低分辨率
的相同图像需要的储存容量则约 500 KB。
图像在保存后,其大小将显示在属性工具窗口文档组里的文件大小字段中。
显示分辨率
当前图像采集的分辨率也显示在摄像控制工具窗口中的功能组标题中。这将确保
始终显示分辨率,即使您最小化功能组并且仅标题保持可见。
17
采集图像
(3) 对实时观察和拍照使用相同的分辨率
为了对实时图像和拍照采集使用相同的分辨率,请单击带有链图标的按钮。然
后,您只需要在其中一处设置另一分辨率即可。
从这一刻起,实时观察列表将显示为灰色。这样您就不能在该列表中进行任何设
置。不过,如果您在拍照字段中设置了另一个数值,那么所示数值将会自动更
新。
(4) 切换子阵列
修剪摄像头采集到的图像。
什么时候应使用什么分辨率?
高分辨率
使用最高分辨率时,即使彼此非常接近的样品结构在图像中也是独立显示的。这
种图像包含了样品的绝大部分信息。不过不足的是,高分辨率降低了采集实时图
像的速度。
适用于实时图像的低分
辨率
如果希望提高实时图像的反应速度,那么设置较低的分辨率就会很有效。这样,
从摄像头传送到软件中的数据就会更少,实时图像的更新就会更快。不过不可否
认,分辨率的降低也必然会导致采集的图像信息减少。
适用于实时图像和拍照
的不同分辨率
请注意: 相对于拍照,您可以为实时图像设置不同 (较低) 的分辨率。这非常有
用,例如,当您希望实时图像反应迅速,但又不希望在采集一幅图像时损失图像
质量,便可使用这种方法。
00129
3.2.5. 切换子阵列
切换子阵列按钮位于摄像控制工具窗口中。您可以在分辨率组中找到此按钮。使
用该按钮,您可以修剪摄像头采集到的图像。
为什么使用“切换子阵列”模式?
您可以使用切换子阵列模式实现多种目的。
快速实时图像
搭配支持此功能的摄像头,切换子阵列模式可以实现更快地采集实时图像。您可
以定义矩形图像片段,实时采集的读取范围就限制在此区域内。由于需要传送的
数据较少,从而可获得较高的帧频率。请注意,您必须先选中应用于实时观察复
选框,然后才能对实时图像使用切换子阵列模式。
切换子阵列 - 像素合并
与切换子阵列模式的方式相同,像素合并 (降低分辨率) 会提高实时图像的速
度。
与像素合并相反的是,使用切换子阵列模式时,实际上只能看到一个小样品片
段,而此样品片段可以按可能的最大摄像头分辨率显示。当您需要能快速反映聚
焦的实时图像并且只想复制非常小的样品结构时,可以使用切换子阵列模式。
分辨率组中还能找到像素合并功能。
也可以将像素合并与切换子阵列模式结合使用。这样可进一步提高实时图像中的
速度,同时进一步缩小文件大小。
修剪图像
有时可能需要修剪已采集的图像。使用切换子阵列模式,您就可在采集图像时剪
掉不感兴趣的边界,从而显著缩小文件的大小。
如果在采集图像之前没有设置切换子阵列模式的范围,而又只对此图像的一部分
感兴趣,则可以随时使用图像 > 裁剪命令对其进行修剪。
18
采集图像
功能描述
打开或关闭“切换子阵
列”模式
切换至实时模式。单击切换子阵列按钮打开切换子阵列模式。此按钮将保持已点
击的外观状态。随即便可看到切换子阵列模式的打开/关闭状态。
请注意: 您只能在实时图像中打开和关闭切换子阵列模式。
对实时图像也可使用
“切换子阵列”模式
指定“切换子阵列”模
式的图像片段
在任何情况下,切换子阵列模式都可用于拍照采集。如果您还想对实时图像使用
切换子阵列模式,请选中应用于实时观察复选框。
打开切换子阵列模式后,图像窗口中的蓝色方框将显示活动图像片段。
您可以随时利用鼠标来更改已在实时图像中选定的图像片段。
请注意: 只有在没有选中应用于实时观察复选框的情况下,才能更改切换子阵列
模式的图像片段。这是因为启用切换子阵列模式后,只会显示图像的一部分,这
意味着只能在显示的片段内而不能在此片段外定义新的图像片段。
指定“切换子阵列”模式的图像片段
1.
显示摄像控制工具窗口。为此,可以使用视图 > 工具窗口 > 摄像控制命
令。
2.
切换至实时模式。为此,请单击实时观察按钮。
3.
如有必要,可清除分辨率组中的应用于实时观察复选框。
4.
打开切换子阵列模式。为此,请单击切换子阵列按钮。
•
图像窗口中随后会有蓝色方框指示切换子阵列模式的活动图像片段。
如果您没有看到此方框,请再次单击切换子阵列按钮。
5.
要改变其位置,请按住鼠标左键,选定该框并将其拖动至期望的位置。依
照重要的图像细节来定位切换子阵列模式所用到的图像片段。
要更改其大小,请将鼠标指针移到它的一个手柄上。通过在按住鼠标键的
同时拖动该标记,您就可以根据需要调整方框的大小。
6.
单击拍照按钮停止实时模式并由此采集新图像。
•
采集的图像现在将只显示您已选定的图像片段。
00130 20112015
19
采集图像
3.3. 采图设置
10B
使用采图设置对话框可以更改图像采集的各种设置。
打开对话框
要打开该对话框,请单击采图设置按钮。该按钮位于摄像控制工具栏以及摄像控
制工具窗口的工具栏。
通过该对话框的树状视图,可以访问包含各种设置选项的对话框。从树状视图中
选定一个选项,即可显示对应的对话框。
请注意: 摄像头设置中的准确功能是由所使用的摄像头决定的。因此,本软件中
的功能可能与此处所述有所不同。
3987 20112015
3.3.1. 采图设置 - 采集 - 常规
该对话框提供了多个可用于处理实时图像的常规选项。
实时观察
实时图像将在文档组中分配到各自的窗口。该窗口标题将为实时观察 (进行中)。
该实时观察窗口的行为取决于实时观察组的设置。
停止实时图像时关闭实
时窗口
选定停止实时观察时关闭窗口选项,可在每次退出实时模式时关闭实时窗口。
通过单击实时观察按钮退出实时模式时,不会采集任何图像。
要采集图像,应通过单击拍照按钮退出实时模式。
停止实时图像时保留实
时窗口
选定停止实时观察时保留窗口选项,可在退出实时模式时保留实时观察窗口。
通过单击拍照按钮退出实时模式时,会停止实时图像并同时采集一幅图像。随后
您会在图像窗口中看到已停止的实时图像,其标题为实时观察 (停止)。正如其它
图像一样,您也可以将这个已停止的实时图像保存起来。
请注意: 已停止的实时图像和已采集的拍照不是同一种图像。这意味着,您可以
为实时图像和拍照采集设置不同的分辨率。在这种情况下,已停止的实时图像和
采集的单幅图像分别具有不同的分辨率。
通过单击实时观察按钮退出实时模式时,该模式的行为取决于每次进行实时观察
时新建窗口复选框的状态。
启动实时模式时创建新
文档
只有已选定停止实时观察时保留窗口选项时,才需要考虑每次进行实时观察时新
建窗口复选框。
清除每次进行实时观察时新建窗口复选框,可只打开一个实时窗口。
通过单击实时观察按钮退出实时模式时,您可在实时观察 (停止) 实时观察窗口
中找到已停止的实时图像。下次启动实时模式时,实时观察窗口中的内容将被改
写。
如果想在每次启动实时模式时都打开新窗口,请选中每次进行实时观察时新建窗
口复选框。这样可以防止改写最后的实时观察窗口的内容。
如果现在结束实时模式,则在任何情况下都会保留已停止的实时图像。将为停止
的实时图像创建新的图像文档。
当您想在实时图像中进行测量时,可使用此设置(停止实时观察时保留文档与每
次进行实时观察时新建文档一起)。当已完成测量时,请停止实时图像。随后可
将测量的图像与测量结果一起保存。这样在启动下一幅实时图像时,您便可以执
行新测量。
20
采集图像
拍照后继续使用实时模
式
选中采集之后继续实时观察复选框,可在拍照时仅在实时模式下暂停。拍照采集
随即会新建一个图像窗口,但实时图像的窗口仍然保持活动状态并且会立即切换
到实时模式。
要退出实时模式,请单击位于摄像控制工具窗口中的实时观察按钮。
校准
选择基本单位
您可以为图像采集设置要使用的 X/Y 校准基本单位。为此,请从基本单位列表中
选定要使用的单位。基本单位有米 [m] 和英寸 [in]。
当选定另一个基本单位时,从这时起所采集的所有图像都将自动以新的基本单位
校准。现在,应用于 X/Y 校准的所有值都将采用该新基本单位来指定。这些可以
是:
•
•
•
•
标尺的标记
属性工具窗口内的校准数据
测量图像时的测量结果
您可在图像窗口中显示的标尺标签。使用选项 > 图像 > 视图对话框显示
或隐藏标尺。标尺的标签在您重新启动软件前不会更改。
请注意: 更改基本单位时,已采集图像的 X/Y 校准所使用的基本单位不会改变。
例如,如果已经以米为基本单位采集了一幅图像,则该图像仍将以“米”或由此
衍生的单位 (如 mm 或 µm) 为单位进行校准。如果想用另一种基本单位测量该图
像,请使用图像 > 校准图像... 命令改变基本单位。
采集后确认
选中拍照之后检查放大倍率复选框,可在每次图像采集后自动打开校准图像对话
框。
在您在切换到实时图像后,如过依然希望可以更改用于图像采集的物镜放大倍
率,请使用此功能。
在校准图像 > XY 校准对话框中,选定放大倍率选项。现在,您就可以从设置放
大倍率 > 物镜列表中选择用于图像采集的物镜放大倍率。这将确保正确校准图
像。
清除该复选框后,您必须在开始图像采集前 (例如) 通过在显微镜控制工具栏上
单击相应按钮选定当前物镜放大倍率。这样您采集的图像才会正确校准。
3029 05112015
21
采集图像
3.3.2. 采图设置 - 文档名
在采集图像时,软件会为图像分配一个默认名称。例如,默认情况下,本软件采
集的第一幅图像会被命名为图像_01。您可以在采图设置 > 文档名对话框中更改
该名称。
预览
预览区域将显示您要采集的下一幅图像的名称。该预览区域会在您更改图像名之
后立即更新。
自定义
一个自动创建的名称由几个不同部分组成。在自定义组中,定义前缀和指定编号
系统。
定义前缀
在文本字段中可输入图像名的第一部分。Image 为默认前缀。默认情况下,采集
的图像名称为 Image01、Image02 等。
请尽量不要在图像名中使用任何特殊字符。某些特殊字符,例如“?”,在输入时
不会被接受。
移动前缀
还可以将在文本字段中定义的前缀移动到图像名称中的任何其它位置。
1.
2.
定义计数器
为此,请单击所有选项... 按钮。
•
将打开对话框,可以在其中组合从多个占位符自动创建的名称。
•
您可以在选定属性列的顶部位置看到在文本字段中定义的前缀。
选定前缀并使用向上和向下按钮。
在计数器位数字段中,定义编号应由几位数字组成,例如位数为“3”时,编号可
以为“001”。请注意,计数器位数字段中输入的数值不会成为编号的上限。这意
味着,举例来说,当输入的数值为 2,并且采集的最后一幅图像为 Image_99
时,下一幅图像将获得名称 Image_100。
如果想从某个数值开始编号,则应在计数器开始字段中更改数值。例如,在已经
采集了大量图像后,您可以将编号重置为 1。或者可以继续前一天的图像序列的
编号。如果更改计数器开始字段中的值,那么下一幅图像始终以设置的数值开
始。其它所有图像的编号将按每次加 1 的方式逐次增加。
每次启动软件时,都会使用计数器开始字段中设置的值重新启动图像的编号。
只有在清除自动还原复选框后,才可以更改计数器开始字段中的值。
请注意: 如果自动保存处于活动状态,则可以忽略计数器开始字段中的值。在这
种情况下,软件会核对当前目录下是否已经存在具有期望名称的文件。如果该文
件已存在,将自动使用下一个更高的可用编号。要打开或关闭自动保存流程,请
使用采图设置 > 保存对话框。
自动还原计数器
当您希望确保对相关的多幅图像进行连续无间断地编号时,请选中自动还原复选
框。这样,您就无法再手动更改图像的编号。
自定义文档名
本软件提供了多个可在图像名中使用的占位符。单击所有选项... 按钮,选定所
需的占位符。
3041 30092013
22
采集图像
3.3.3. 采图设置 - 保存
默认情况下,在采集图像时,会在文档组中创建和显示一个新图像文档。您可以
对此图像进行重命名并保存。如果关闭软件时您还未保存此图像,系统会询问您
是否要保存此图像。在采图设置 > 保存对话框中,您还可以将图像设置为在采集
后自动保存。
自动保存
您可以在采集后自动保存图像。
采集后自动保存图像
当您想把图像另存为文件时,请选定目标列表中的文件系统选项。然后在目录组
中,定义保存文档的目标路径。
请注意: 同时,最多可在文档组中载入 150 个文档。采集图像时,如果已载入最
大可能数量的文档,则会接收到错误消息。开启自动保存后,即使图像不再能显
示在当前窗口中,也会采集图像并将其保存至当前目录。
禁用自动保存
文件类型
选定不自动保存选项,以关闭自动保存图像功能。这样,在采集了图像并且希望
保存图像文件时,就必须通过使用 (例如) 文件 > 另存为... 命令手动保存图
像。在这种情况下,该对话框内没有任何其它功能可用。
在文件类型列表中,选定采集后应以何种文件格式保存图像。对于图像文件格式
TIF 和 JPEG,在保存图像时,还需要考虑其它设置。如果您要查看或更改这些设
置,请单击选项...按钮。
请注意: 本软件采集的图像始终包含一系列额外信息,它们可在属性工具窗口中
看到。只有以 TIF 格式保存图像,这些附加信息才能得到保留。
保存之后关闭窗口
选中保存之后关闭窗口复选框,可在保存图像后立即关闭图像文档。这样就会将
图像另存为文件。请注意,这会使您在采集图像之后不会在软件中看到图像。这
样做是为了在采集图像时避免占用太多的计算机内存资源。
目录
先决条件: 仅当您从自动保存 > 目标位置列表选定了文件系统选项后,目录组才
可用。
选定路径
创建子目录
路径字段显示了当前自动保存图像所使用的目录。
单击路径字段旁的 [...] 按钮,可选定在采集图像后用于保存这些图像的目录。
在采集图像后自动保存图像时,还可以将相关的图像单独保存到一个目录中。默
认情况下,同一天采集的所有图像会保存在一个单独的目录下。第二天又会自动
打开一个新目录。这样即使采集了大量图像后,您也能对采集结果始终有一个清
晰全面的了解。
选中创建子目录复选框,以将采集的图像保存到各自的子目录中。
如果要更改该子目录的推荐名称,请单击自定义... 按钮。自定义子目录名称对
话框即会打开。
本软件提供了多个可在目录名中使用的占位符。在选定占位符时,您同时也确定
了目录树状结构的组织标准。例如,您可以为每个用户设置一个子目录。
核对预览
预览区域显示了将用于下一次图像采集的当前子目录。该预览区域会在您更改子
目录名之后立即更新。
3040 06112015
23
采集图像
3.3.4. 采图设置 - 摄像头 - 常规
可使用该对话框进行各种常规摄像头设置。例如,您可以翻转采集的图像,在黑
白模式下使用彩色摄像头或选定调色板。
请注意: 某些设置会因摄像头的不同而有所差异。因此,您使用的摄像头的功能
可能和这里所描述的有所不同。
图像类型
设置位深度
部分摄像头可以采集不同图像类型的图像。从位深度列表中选定您想用摄像头采
集的图像类型。图像类型的根本区别在于其位深度,也就是每个像素可以采用的
亮度值的大小。
位深度列表中有哪些选项可用,这取决于您的摄像头。
选定 8 位 RGB 彩色选项可采集 24 位实彩色图像。
您可以在黑白模式下使用某些摄像头。选中 8 位灰度选项可采集 8 位灰度值图
像。
在彩色模式和灰度模式
间切换
如果您要在彩色模式和灰度模式间频繁切换,请单击切换彩色灰度模式按钮。您
可以在摄像控制工具窗口的工具栏中找到该按钮。此后,您只需要单击鼠标即可
从一种模式切换到另一种模式。
选择色温
只有当知道彩色图像的普通色温时,摄像头才能将其正确重现。使用该运算时,
图像中的各种颜色 (红、绿、蓝) 将按照这样的方式调节: 所示图像的白色区域
将准确再现为白色。
从色温列表中,选择一种预定义的色彩设置,以在特定光线条件下采集样品。这
将自动选择适合您摄像头的颜色设置。
5000 K 对应于早晨或黄昏的日光。
6500 K 对应于阴天的日光。
2800 K 对应于钨丝灯光。
如果您不需要根据特定光线条件调整颜色设置,则选择关闭选项。例如,当您希
望定量比较在不同光线条件下采集的图像时,这会有所帮助。颜色印象会变得十
分暗淡。
请注意: 在实时模式下,可以直接更改色温设置。因此,可以立即看到更改对色
彩再现的影响。
如有必要,使用白平衡调节这些默认设置。
摄像控制工具窗口中提供用于确定白平衡的不同方法,具体取决于您使用的摄像
头。
24
采集图像
翻转
水平
选中水平复选框可以在采集期间水平翻转图像。下图中左边显示的是源图像,右
边显示的是经过水平翻转后的图像。
垂直
选中垂直复选框可以在采集期间垂直翻转图像。下图中左边显示的是源图像,右
边显示的是经过垂直翻转后的图像。
水平和垂直
这两种形式的翻转可以互相结合。下图中左边显示的是源图像,右边显示的是经
过水平和垂直翻转后的图像。
伪彩色
先决条件: 仅当您选中了位深度列表中的 8 位灰度选项时,伪彩色组才可用。
使用调色板,您可以让图像以彩色形式显示在显示屏上。然后将为图像中的每个
亮度值分配一个色调。
使用无伪彩色
使用饱和度指针
默认情况下,在您采集图像时不会使用调色板。在这种情况下默认会选定伪彩
色 > 关闭选项。
选定使用饱和度指针选项,可以使所有具有低亮度值的像素显示为蓝色,而所有
具有高亮度值的像素显示为红色。现在,所用的调色板仅适用于实时图像。当采
集实时图像时,所有像素将以其实际颜色显示在文档组中。
利用该调色板,您可以立即知道图像是否获得了良好的照明。当图像中既有蓝色
又有红色像素时,将使用摄像头的完整动态范围。如果能在图像中看到过多的蓝
色像素,说明图像曝光不足。如果能在图像中看到过多的红色像素,说明图像曝
光过度。
如果要频繁开关使用饱和度指针选项,您可使用切换饱和度指针按钮。您可以在
摄像控制工具窗口的工具栏中找到该按钮。只需要单击鼠标即可打开或关闭该选
项。
对灰度图像使用伪色彩
查对表
选定调色板
最早可在图像采集时应用调色板。为此,请选定对灰度图像使用调色板选项。
使用所选的调色板,您可以仅对实时图像着色,或仅对所采集的图像着色,或对
两者都着色。为此,请从列表中的仅适用于实时观察、仅适用于拍照或适用于实
时观察和拍照里选定其中一项。
单击伪彩色... 按钮,以修改已选定的伪调色板或定义一个新调色板。
3002 20042016
25
采集图像
3.3.5. 采图设置 - 摄像头 - 调节
此对话框可用于手动更改会影响图像质量的摄像头设置。
请注意: 某些设置会因摄像头的不同而有所差异。因此,您使用的摄像头的功能
可能和这里所描述的有所不同。
更改实时图像的图像对
比度
在更改该设置前,请先切换到实时图像,这样您便可以立即看到修改后的效果。
为此,请使用采集 > 实时观察命令。
增强
Gamma 系数
移动 Gamma 系数滑动游标可增加亮图像区域中的图像对比度,或仅增加暗图像区
域中的图像对比度。
每次执行完图像采集后,Gamma 系数值都将被属性工具窗口所采用。如果图像以
TIF 文件格式保存,则该信息将得到保留。
不过这会同时更改所有色彩通道的参数。如果只想加重或调淡某种颜色,请使用
采图设置 > 摄像头 > 颜色对话框中的功能。
对比度和亮度
移动对比度滑动游标可更改图像的对比度数值。数值小于 1 会降低图像对比度。
数值大于 1 会增强图像对比度。
更改图像对比度时,图像中最亮的部分将始终保持不变。
更改图像对比度后,图像的黑暗区域或明亮区域可能不再以最佳效果显示。在这
种情况下,可使用亮度滑动游标将整幅图像调至更亮或更暗。
如果整幅图像太亮或太暗,请使用亮度滑动游标。数值小于 0 会降低图像亮度。
数值大于 0 会增加图像亮度。
您也可以在摄像控制工具窗口中查看对比度和亮度值,并且也可以在其中更改它
们。
这些值随图像一起自动保存。您可以在属性工具窗口中查看这些值。
限制吞吐量
在实时模式下,会有大量数据从摄像头传输到计算机。可能会发生系统的 USB 连
接数据传输速度不够高,无法支持全数据速率。这可能导致实时图像中出现某些
错误(例如,不顺畅或颜色失真)。
请注意: 如果您的系统在实时模式下出错,您应该仅降低数据速率。
在这种情况下,可使用数据速率滑块减少传输的数据量。在摄像控制工具窗口
中,现在将显示实时模式下相应更小的帧速率。
3001 20042016
26
采集图像
3.3.6. 采图设置 - 摄像头 - 颜色
可使用本对话框来手动更改摄像头的颜色设置。
请注意: 某些设置会因摄像头的不同而有所差异。因此,您使用的摄像头的功能
可能和这里所描述的有所不同。
更改实时图像中的颜色
设置
在更改颜色设置前,请先切换到实时图像,这样您便可以立即看到更改后的效
果。为此,请使用采集 > 实时观察命令。
对话框说明
白平衡
先决条件: 您只有在摄像头的彩色模式下,才能更改颜色设置。
利用增益数值,您可以单独加权个别色彩通道。例如,增加 R 数值可以增加图像
中红色的量。
您不应经常手动更改增益数值。相反,请使用摄像头的白平衡功能。该对话框的
各字段将自动采用白平衡的结果。
您可分别更改每个色彩通道的增益参数。要更改某参数,请移动对应的滑动游
标。R、G 和 B 分别代表红、绿、蓝三种颜色的色彩通道。
每次采集图像时,所用的增益数值都会传输至属性工具窗口。您可在摄像头组中
找到增益(白平衡)选项。如果图像以 TIF 文件格式保存,则该信息将得到保
留。
对于不同设备分别设置
白平衡
饱和度和色调
白平衡会受到光路中每种光学组件的影响。尤其,物镜会影响图像的颜色印象。
选中对于不同设备分别设置白平衡复选框以自动保存每个已执行的白平衡。此
后,当您使用具有有效白平衡的物镜采集图像时,此白平衡将被自动加载并应
用。
如果您已清除对于不同设备分别设置白平衡复选框,则不管使用的是什么物镜,
都将使用最近一次设置的白平衡。
滑块饱和度和色调提供了影响摄像头颜色设置的更多可能性。先将系统切换到实
时模式,然后再打开采图设置对话框。现在当您更改饱和度和色调值时,可以直
接在图像窗口中观察色彩再现会受到怎样的影响。
当图像中某种颜色占多数时,您可以增加饱和度数值。这样,您便可以使图像中
的其它颜色得到更好的再现。要更改该参数,请移动其滑动游标。对饱和度的更
改将会影响到所有色彩通道。
使用色调值改变所采集图像的颜色印象。例如,可以更好地识别图像中的某些结
构。值 180 意味着图像中的颜色对应于样品颜色。
您也可以在摄像控制工具窗口中查看饱和度和色调值,并且也可以在其中更改它
们。这些值随图像一起自动保存。您可以在属性工具窗口中查看这些值。
默认值
单击默认值按钮可选定预设的颜色设置。该操作会使当前设置全部丢失。
3003 20042016
27
采集图像
3.3.7. 采图设置 - 摄像头 - 曝光
可使用该对话框设置图像采集的最长可能曝光时间。这样可以防止曝光时间过
长。
最长曝光时间
可以设置实时图像和拍照的最长可能曝光时间。为此,请使用滑动游标。另外,
您也可以直接在文本字段中输入期望的数值。您在此处可以输入的最大数值取决
于所使用的摄像头。
手动和自动滑动游标对应于决定曝光时间的自动模式和手动模式这两种可能模
式。例如,您可以在摄像控制工具窗口中决定使用哪种模式。
3039 20112015
3.3.8. 采图设置 - 摄像头 - 信息
可使用该对话框来查看与摄像头有关的数据。
显示的信息
摄像头名称
使用的摄像头类型
序列号
本摄像头的序列号
API 版本
固件版本
驱动程序版本
使用的摄像头驱动程序的信息
3014 06112015
28
使用图像
4.
使用图像
4.1. 更改图像的显示方式
11B
可以在本软件的图像窗口中以非常不同的方式显示图像。有多种方法可以改变图
像的显示方式。
扩大或缩小图像窗口中的图像大小
有多种不同的方法可用于在图像窗口中更改图像的缩放比例。当前缩放比例显示
在状态栏的右下方。
在左侧,整个图像显示在图像窗口中。在右侧,缩放比例放大了图像片段,因此
可以以更高分辨率查看它。标尺与图像窗口中图像的放大倍率相关,会相应调
整。
不同的缩放选项将在下文中进行描述。
1.
使用缩放工具栏中的按钮。
2.
单击工具箱工具栏上的缩放工具按钮。
3.
如果未处于缩放模式: 右键单击图像窗口。在出现的上下文菜单中,您可
以找到几个可用于更改图像缩放比例的命令。
4.
旋转鼠标滚轮可更改缩放比例。
•
5.
您可以设置当您向前滚动鼠标滚轮时是否想要放大或缩小图像窗口中
图像的大小。为此,选中或清除向远离您的方向滚动鼠标滚轮 (前向
滚动) 以放大图像复选框。该复选框位于工具 > 选项 > 图像 > 缩放
对话框中。
使用图像导航工具窗口。
•
在图像导航工具窗口中,在按住鼠标左键的同时将导航框拖至更小的
尺寸。一旦释放鼠标键,图像窗口中就会只显示已选定的图像片段。
•
可在图像导航工具窗口的图像区域下面的编辑字段中直接输入所需缩
放比例,然后按 [Enter] 键,或使用滑动游标调整缩放比例。
更改图像的色彩映射
可以将灰度图像以彩色显示。可以使用色彩查对表进行该操作。
任务
创建色彩查对表,使其以黄色显示暗灰度值,并以不同红色阴影显示亮灰度值。
并且灰度越浅,红影也就越浅。
29
使用图像
在左侧为灰度图像。在右侧,使用色彩查对表为图像添加了色彩。通过添加色
彩,可以看到暗灰度值范围和亮灰度值范围中的更多细节。
创建色彩查对表
1.
载入一幅灰度图像。使用 [Ctrl + Alt + T] 快捷键可创建测试图像。
2.
使用图像 > 伪彩色... 命令打开伪彩色对话框。
•
3.
将鼠标指针移到对话框中的色彩查对表上。
•
4.
当前色彩查对表显示在当前色彩查对表组中。
指针随即变为手形。
按住鼠标左键,在色彩查对表的低灰度值区域上拖动鼠标。
•
该色彩查对表下方的蓝色栏即会指示已经选定的灰度范围。现在您便
可以为该灰度范围指派一种颜色。
5.
在修改调色板组中左端的颜色区域单击一次。
6.
在颜色对话框中选定需要的颜色,例如黄色,然后单击确定进行确认。
7.
在修改调色板组中右端的颜色区域中单击一次。
8.
在颜色对话框中选定需要的颜色,例如黄色,然后单击确定进行确认。
9.
单击修改调色板组中的应用按钮。
10.
•
当前图像上位于该选定灰度范围内的所有灰度随即以黄色显示。
•
当前色彩查对表也将相应更新。
按住鼠标左键,在色彩查对表的高灰度值区域上拖动鼠标。
•
该色彩查对表下方的蓝色栏即会指示已经选定的灰度范围。现在您便
可以为该灰度范围指派一种颜色。
11.
在修改调色板组中左端的颜色区域单击一次。
12.
在颜色对话框中选定需要的颜色,例如深红色,然后单击确定进行确认。
13.
在修改调色板组中右端的颜色区域中单击一次。
14.
在颜色对话框中选定需要的颜色,例如白色,然后单击确定进行确认。
15.
单击修改调色板组中的应用按钮。
•
当前图像上位于该选定灰度范围内的所有灰度随即以红色或者黄色显
示。与黄色像素不同,红色像素将一直变得更亮,同时亮度值也会更
高。
•
当前色彩查对表也将相应更新。
30
使用图像
保存色彩查对表
16.
单击保存色彩查对表按钮。您可以在伪彩色工具窗口顶部找到该按钮。
•
将色彩查对表另存为对话框随即打开。
17.
在名称字段中输入新色彩查对表的说明性名称,如黄色-红色。
18.
单击保存按钮可保存色彩查对表并返回伪彩色对话框。
•
19.
此后可以对附加灰度图像应用黄色-红色色彩查对表。
单击确定关闭伪彩色对话框。
•
现在,活动灰度图像将以彩色显示。
00270 28092015
31
使用图像
4.2. 处理图像
12B
流程菜单提供了可以用于更改所采集图像 (如增加图像对比度或图像锐度) 的若
干图像处理功能。
1.
载入要处理的图像,或激活文档组中的图像。
•
2.
在运算菜单中选定一个命令,如运算 > 增强 > 亮度调节...。
•
3.
4.
请注意,只有当图像已载入且在文档组中处于激活状态时,处理菜单
才可见。
图像处理对话框随即打开。处于激活状态的图像处理操作将显示在对
话框标题中。
单击预览按钮旁的小箭头打开含有所有预览功能的列表。选定原始图像和
预览图像选项。
•
此预览功能可将相同图像片段在对话框中显示两次。显示的第一幅为
源图像。第二幅为应用当前参数后得到的图像。
•
大部分图像处理操作都需要设置组中显示的一两个参数。
更改图像处理操作的参数。例如,减小 Gamma 值并增加亮度。
•
每次更改参数后,操作将立即应用于源图像,并且结果图像将会显示
在预览窗口中。
5.
如果当前参数并未达到您的预期要求,请单击默认值按钮以重新采用设置
组中的预设参数。
6.
当您找到最佳参数时,请单击确定按钮,使活动图像处理操作对图像应用
激活的参数。
•
“图像处理”对话框随即关闭。
•
请注意,图像处理操作会更改源图像,并且不会创建任何新图像文
档。不过,您可以使用编辑 > 撤消命令恢复源图像。
•
新图像未被自动保存。显示在文档组中图像名后的星号表示尚未保存
更改。
源图像 (左侧) 的对比度低。调节亮度可以获得对比度好很多的结果图像 (右
侧)。
00175 29092015
32
使用图像
4.3. 在图像上执行白平衡
13B
如果您图像中本应显示为白色的区域看起来偏红,或是偏别的颜色,这说明图像
有些偏色。在这种情况下,请使用运算 > 增强 > 白平衡... 命令执行白平衡。
1.
载入要处理的图像,或激活文档组中的图像。
2.
使用运算 > 增强 > 白平衡... 命令。
•
筛选: 白平衡对话框将打开。
3.
首先在图像中定义白点。白点应该是虽然实际为白色,但在图像中却没有
显示成白色的点或表面。
4.
例如,单击使用取色器选定白点按钮。
5.
•
对话框即会隐藏。鼠标指针将变为取色器。
•
取色器点的尺寸预定义为 3x3 像素。或者,您也可以使用椭圆或矩形
来定义白点,这样可将任意大的区域定义为白点。
单击图像中您要定义为白点的某个位置。
•
6.
7.
该位置即会以红色叉形标记。执行该操作后,您仍可以移动该点。为
此,请将鼠标移动到红色叉号上,使其呈现该形状。然后,按住鼠标
左键,将白点移动到所需位置。
单击鼠标右键确定您的选择,然后使用上下文菜单中的确认输入命令。
•
筛选: 白平衡对话框将重新打开。
•
在交互式白点设置组中,会显示已定义白点的三种颜色的色彩值。
•
在白点矫正参数组中,会显示为每种颜色确定的矫正值。
•
如果您采用这些值,则可在对话框的预览图像中看到矫正后图像的样
子。
•
如有必要,您仍可以手动更改已确定的白点矫正参数。预览窗口将随
即立刻进行相应更新。
如果满意预览图像效果,请单击应用按钮,然后单击确定。
•
随后会立即执行白平衡。这意味着调整图像中的颜色以使选定白点和
具有相同色彩值的所有区域显示为白色。您可以在图像中立即看到调
整后的效果。
8. 如果您对结果不满意: 请注意,您可使用编辑 > 撤消命令来撤消白平衡
调节。
00391 29092015
33
使用图像
4.4. 使用绘图对象
14B
可以使用各种绘图功能来标记图像。
插入绘图对象
任务
插入箭头
想要在图像中插入箭头并标记它。
1.
载入要标记的图像。
2.
设置图像窗口的缩放比例以用使标签易于阅读的大小显示图像。可以旋转
鼠标滚轮以更改图像窗口中的缩放比例。
3.
使用视图 > 工具栏 > 绘图命令来显示此工具栏
4.
单击绘图工具栏中的箭头按钮。
•
插入文字对象
显示和隐藏绘图对象
每个绘图对象在绘图工具栏上都有一个对应的按钮。单击要插入的绘
图对象的按钮,然后在图像上定义绘图对象。
5.
按住鼠标左键以绘制箭头。
6.
双击箭头可打开绘图对象属性对话框。在此处设置箭头的颜色和线宽。根
据线宽自动调整箭头头部的大小。
7.
单击绘图工具栏中的文字按钮。
8.
按住鼠标左键以绘制矩形。输入所需文字并设置其格式。
9.
使用 [Esc] 键可退出输入文字模式。
10.
您可以使图像和绘图层同时显示在显示屏上,也可以只显示图像而不显示
绘图层。单击绘图工具栏中的显示绘图按钮,可在显示和不显示绘图层之
间进行切换。
在图像上定义了两个绘图对象:箭头和箭头的标签。
选定绘图对象
选定多个对象
对于某些操作,选定一个以上的绘图对象会很有用。这使您能够将多个绘图对象
从一幅图像同时复制到另一幅图像上,或者同时格式化多个绘图对象。
1.
使用绘图工具栏中的按钮可创建多个绘图对象。
2.
如果必要,则切换到编辑对象模式。为此,请单击绘图工具栏的选定绘图
对象按钮。当编辑对象模式处于活动状态时,此按钮将显示为已点击状
态。您可以通过按钮的背景颜色识别这种状态。
按钮显示为已点击状态时,即说明已处于编辑对象模式。
3.
使用以下方法之一选定一组绘图对象。
34
使用图像
清除所选内容
•
左键单击某个对象。
按住 [Shift] 键,单击需要编辑的其它对象。
已选定的对象将以白色或灰色标记标识。
•
按住鼠标左键,拖出一个将多个对象包含在内的矩形。
这样即会选定完全位于该矩形中的所有对象。而所有其它当前所选内
容都会被取消。
•
要选定图像上的所有绘图对象,请使用 [Ctrl + A] 快捷键。
4.
如果必要,则切换到编辑对象模式。为此,请单击绘图工具栏的选定绘图
对象按钮。
如果按钮显示为已点击状态,这意味着已处于编辑对象模式。
5.
有多种方法可清除对绘图对象的选定:
•
使用编辑 > 清除选定命令。
•
使用 [Ctrl + D] 键盘快捷键。
•
使用鼠标左键单击文档背景中的任何位置。即会清除当前所选全部内
容。
•
要取消选择个别对象,请单击已选定的对象。
确定绘图对象的默认格式
1.
插入绘图对象,然后为其分配要用作默认设置的属性。例如,如果您想要
图像中的线条在默认情况下为红色,则将线条颜色从黑色更改为红色。
2.
必要时,可选定要用作格式模板的绘图对象。
3.
使用绘图 > 设置为绘图默认值命令。绘图菜单位于绘图工具栏中。
•
4.
已选定的绘图对象现被用作所有新绘图对象的模板。
插入另一个绘图对象,如椭圆。
•
新绘图对象的格式将完全采用第一个绘图对象所使用的格式。
35
测量图像
5.
测量图像
5.1. 总览
15B
您可以通过本软件测量距离和面积。所有结果会与图像保存在一起。
先决条件
为了进行测量,正确校准的图像是基本的先决条件。
如果您已经指定要使用哪个物镜,那么您使用软件所采集的图像将会自动获得正
确校准。
如果图像尚未得到校准,请使用图像 > 校准图像... 命令来执行校准。
选定测量环境
利用工具窗口进行测量
使用视图 > 工具窗口 > 测量命令。在测量工具窗口中,您可以快速访问会影响
测量的测量功能和设置。该工具窗口同时也是测量视图,它包含已在活动图像上
测量到的所有数值。
启动测量
通过选定所需测量功能开始测量。您可以在测量工具窗口中、测量工具栏上或测
量菜单中找到各种测量功能。
在默认测量模式下工作
单击测量功能后,本软件会立即自动切换到测量模式。您可以在测量模式下测量
图像结构。当您完成测量后会自动退出测量模式。
您可以立即执行其它测量,或使用所需任何其它软件功能。
在连续测量模式下工作
双击测量功能切换到连续测量模式。在连续测量模式下,鼠标指针会变为十字。
在连续测量模式下,您可立即使用这些测量功能进行其它测量。连续测量模式对
于所有已载入的图像都有效。因此,在该模式下您可以轻松地连续测量许多幅图
像。
在测量工具栏中选定的按钮保持激活以识别当前测量功能。
您将一直停留在该测量模式,直到明确将其关闭为止。为此,请单击测量工具栏
的选定测量对象按钮。
显示和保存测量结果
测量结果会直接显示在图像上以及测量工具窗口中。如果该工具窗口不可见,请
使用视图 > 工具窗口 > 测量命令显示该工具窗口。
保存测量结果
如果以 TIF 格式保存图像,则测量结果将随图像一起保存。
编辑测量
您可以随时对现有测量对象进行编辑。测量工具窗口中的测量数值随后将进行相
应地更新。
请注意: 当您载入含有测量对象的图像文件时,只有该图像文件是以 TIF 图像文
件格式保存时,才可对测量对象进行编辑。
选定测量对象
必须首先选定测量对象,然后才能进行编辑。为此,请单击选定测量对象按钮,
然后选定测量对象。您可以在测量工具窗口和工具栏上找到该按钮。
移动测量对象
您可以通过在按住鼠标左键的同时移动整个测量对象。
36
测量图像
增加/减少测量对象的大
小
您也可以更改测量对象的大小。将指针移动到标记上。通过在按住鼠标键的同时
拖动该标记,您就可以根据需要调整方框的大小。
通过移动手柄来更改测量对象。
删除测量对象
显示辅助线
单击键盘上的 [Del] 键以删除已选定的测量对象。您可以在图像中或测量工具窗
口的表格中选定您想要删除的测量对象。
您可为任意线段测量功能显示辅助线。在图像中选择测量对象,右键单击打开上
下文菜单,其中包含辅助线命令。
在动态模式下测量
测量功能也可用于实时图像。因此您可以 (例如) 在实时图像中快速测量片段。
请注意: 您在实时图像中执行的测量在采集时没有被传送至图像。
00150 14102015
37
测量图像
5.2. 测量图像
16B
您可以通过本软件测量距离和面积。
交互测量图像对象
任务
您需要测量超导体中的丝极。
为此,请载入合适的图像,或采集一幅图像。在相对角之间测量一些六边形丝极
的直径。然后编辑测量,并删除已执行的一些测量。
1.
使用视图 > 工具窗口 > 测量命令来显示测量工具窗口。
•
2.
设置标记颜色
您可以在用户界面的底端找到该工具窗口 (1)。
采集或载入图像。
将根据默认设置以红色字体并且不使用背景把测量结果写入图像。这会使得在某
些图像上难以读取测量结果。请更改标记设置。
3.
使用工具 > 选项...命令。
4.
在树状视图中单击测量 > 测量显示选项。
5.
单击背景颜色字段并选择颜色,例如黑色。
6.
选定文字颜色 > 固定颜色选项,从调色板中选定一种合适的颜色。如果
选定白色,会在黑色背景上以白色显示测量并以白色显示标签。
7.
使用确定关闭对话框。
38
测量图像
测量长度
8.
单击任意线段按钮。您可以在工具窗口顶部的工具栏上找到该按钮。
9.
使用鼠标左键单击以确定参照距离的起点和终点。
10.
重复测量几次。
11.
查看工具窗口和图像中的结果。
•
删除测量
12.
在测量工具窗口中单击其中一个测量结果。
•
13.
关闭图像
14.
图像中将选定相应的线段。
按下 [Del] 键。
•
图像和工具窗口中的测量都将被删除。
•
删除某个测量之后,图像和工具窗口中将减少一个测量。删除测量
后,剩余测量的 ID 不会更改。
在文档组中单击图像名右侧带叉号 [ x ] 的按钮。
•
15.
插图显示在该图像上执行了三次测量。测量 2 已被选定。
由于您添加了交互测量,因而图像已被更改。因此,无论您是否要保
存图像,都会收到系统询问。
请以 TIF 文件格式保存图像。测量结果也随之保存在图像文件中。您可
随时对它们进行编辑、删除或增加。
39
测量图像
输出各种测量参数
任务
测量面积
您需要测量工件的面积。输出各种参数,例如面积、周长以及直径。在图像中显
示直径。
1.
采集或载入图像。
2.
在测量工具窗口中,单击封闭多边形按钮。
3.
左键单击可以指定这个多边形每个顶点的位置。右键单击以完成测量。
4.
查看测量工具窗口中的结果。
•
查看测量参数的列表
5.
在测量工具窗口中,单击选定测量参数按钮。
•
输出其它测量参数
6.
下图显示了含有测量对象的图像。
在该对话框中,您将看到包含所有可用测量参数的列表。在该对话框
底部,您将会看到现在为所有对象计算的测量参数的列表。
转到所有可用参数的列表,然后单击“直径”测量参数。
•
右图显示如何计算该参数。
您可以发现,可采用不同方法来计算二维对象的直径。
7.
单击插图下方列表中的最大值选项,选定最大值 (直径) 测量参数。这将
确定工件的最大跨度。
8.
单击添加“最大值 (直径)”按钮。
•
9.
10.
该测量参数将添加到将要计算的测量参数的列表。所有这些测量参数
都将显示在该工具窗口中。
使用确定关闭对话框。
查看测量工具窗口中的直径结果。
40
测量图像
输出图像中的测量参数
11.
使用工具 > 选项... 命令,然后在树状视图中选定测量 > 测量显示选
项。
12.
选中文本 > 显示值复选框,然后单击确定关闭对话框。
•
现在测量值将显示在图像中。
13.
打开选定测量参数对话框。
14.
在所有已计算测量参数的列表的底部,单击最大值 (直径) 测量参数。
15.
在该列表右侧,有一个带蓝色箭头的按钮。单击该按钮可将测量参数移到
列表顶部。
16.
使用确定关闭对话框。
17.
查看图像中直径的结果。
请注意: 将新设置考虑在内之前,必须更新图像中的测量显示。可以通过添加其
它测量,也可以通过选定图像中现有的测量更新测量显示。
41
测量图像
测量多幅图像
任务
您想测量多幅图像中的细胞。为此,采集一些图像并逐个对它们进行测量。使所
有图像的结果同步显示。查看所有测量结果的平均值。
载入图像
1.
采集或载入一些图像。
测量细胞
2.
激活文档组中的第一个图像。
3.
双击位于测量工具窗口顶部的工具栏上的任意线段按钮。
•
4.
测量多个细胞的直径。
5.
激活下一幅图像。同样测量该图像上多个细胞的直径。
6.
再次单击任意线段按钮结束长度测量。
•
显示所有图像的测量结
果
随后会切换至连续测量模式。在连续测量模式下,可以立即进行其它
测量。
即对两幅图像上的细胞都进行了测量。
7.
使用工具 > 选项... 命令,然后在树状视图中选定测量 > 结果选项。
8.
清除显示测量对象 > 仅活动图像的测量对象复选框。
9.
使用确定关闭对话框。
•
现在,这两个图像的结果将同时显示在工具窗口中。
•
使用文档测量参数可在结果表格中显示与测量结果关联的图像的名
称。现在可以将测量结果明确地匹配至图像,即使所有测量结果都在
工具窗口中一并显示。
00154 16102015
42
配置系统
6.
配置系统
6.1. 总览
17B
先决条件: 已安装本软件,摄像头已连接到计算机。MS-Windows 中已安装摄像头
驱动程序。启动时,本软件现在可以识别连接的摄像头。
配置流程
要设置系统,请遵循以下必要步骤:
配置硬件
校准系统
配置硬件
每台显微镜都配备一个不同的物镜。此外,显微镜也可以具有倍率变换器或特定
放大倍率的摄像头接口。使用采集 > 设备 > 设备设置对话框来输入显微镜组
件。
您也可以在设备设置对话框中找到所有摄像头设置。
校准系统
当您已经输入使用的物镜以及 (如有必要) 摄像头接口和倍率变换器的放大倍率
时,通过软件采集的所有图像都会自动进行 X/Y 校准。如果该校准不够精确,请
使用手动放大倍率校准校准流程。
关于系统配置
必须在什么时候配置系
统?
应该在安装软件之后首次启动计算机时配置和校准系统。如果您在以后更改了显
微镜的安装方式,则需更改相应的硬件组件的配置,有时可能还需要重新校准它
们。
00159 07012015
43
配置系统
6.2. 配置系统
18B
本软件需要关于摄像头、物镜和显微镜摄像头接口放大倍率的信息,以便能够正
确地采集校准的图像。这就是为什么您需要配置系统。
先决条件
已安装本软件,摄像头已连接到计算机。MS-Windows 中已安装摄像头驱动程序。
配置指定硬件
1.
使用采集 > 设备 > 设备设置... 命令。
•
配置摄像头
保存硬件配置
2.
在排序列表中选定光路选项。
3.
在左侧的树状视图中,展开摄像头 > <摄像头名称> 选项 (如 Basler US
B3 Vision)。
4.
这时请选定摄像头转换接口选项。
5.
在右侧的放大倍率列表中选择摄像头转换接口的放大倍率。该放大倍率压
印在摄像头转换接口上。典型值将是 1.00 或 0.63。
6.
本软件预定义了典型的硬件配置。此硬件配置的名称为 BaslerDefault。
在配置组中,单击复制设备配置按钮。
7.
在复制设备配置对话框中输入新硬件配置的名称。
•
配置物镜转盘
8.
9.
10.
物镜转盘的当前配置显示在对话框的右侧。当您首次配置软件时,会
预设几个典型物镜。
检查预设物镜并在需要时调整值。
从右侧的放大倍率列表中选定物镜转盘当前配备的物镜。从最小的放大倍
率开始,然后使用更高的放大倍率,以此类推。放大倍率已打印在物镜
上。
•
完成系统配置
复制的硬件配置将添加到硬件配置列表。
在树状视图中选定常规 > 手动物镜转盘选项。
•
配置倍率变换器
在左侧的树状视图中,可以找到正确校准所采集图像需要的硬件组
件。
在描述字段中,将提供对物镜的描述。如果需要,则可以在描述字段
中对物镜描述进行更改。
11.
如果物镜不使用空气作为其折射介质,则从折射率列表选择中选择浸入介
质。在这种情况下,相应标签位于物镜上。
12.
选定树状视图中的常规 > 手动缩放选项。
13.
在放大倍率字段中输入其中一个倍率变换器的放大倍率,然后单击添加按
钮。
14.
•
显微镜控制工具栏上将提供所有已经输入的放大倍率。
•
如果显微镜没有倍率变换器,则进行您的默认设置。
单击确定关闭设备设置对话框。
•
15.
您可能获得一条要求您检查校准的消息。可以在此时或将来执行校
准。
使用视图 > 工具栏 > 显微镜控制命令可显示该工具栏。
•
显微镜控制工具栏包含的按钮提供了具有正确色彩代码的所有物镜。
00156 19042016
44
配置系统
6.3. 手动放大倍率校准
19B
通过软件采集的所有图像都会自动进行 X/Y 校准。如果该校准不够精确,请使用
手动放大倍率校准校准流程。要执行该校准流程,您需要使用标准样品。
如何确定预设的放大倍
率校准值?
通过软件采集的图像的 X/Y 校准可按像素大小和按总放大倍率进行计算。在采集
时所使用的总放大倍率通常是物镜放大倍率和摄像头转换接口放大倍率的组合。
如果您使用了倍率变换器,那么也会对总放大倍率产生影响。
预设的放大倍率校准值采用设备设置对话框中的硬件组件和摄像头的像素大小,
该像素大小可从摄像头驱动程序中读出。
启动手动放大倍率校准
使用采集 > 校准... 命令。选定校准对话框中的手动放大倍率校准选项。然后单
击校准... 按钮。
恢复为预设的放大倍率
校准值
如果已经对物镜进行了手动校准,则您可以在任何时候恢复预设值。选定校准对
话框中的手动放大倍率校准校准流程。然后单击编辑... 按钮。清除手动物镜校
准对话框中的使用手动校准复选框。
手动校准物镜
1.
将标准样品置于光学显微镜下。
2.
如果您使用了倍率变换器,请将其放大倍率设定为 1,并选定显微镜控制
工具栏上的放大倍率 1x。
3.
启动手动放大倍率校准校准流程。
•
校准物镜列表中列出了软件已注册的所有物镜。
•
所有已手动校准的物镜由复选标记
4.
选中您希望校准的每个物镜前的复选框。
5.
单击下一步 > 按钮。
•
标识。
本软件随即将自动切换到实时模式。
6.
将您要校准的物镜放入光路。对话框将显示该物镜的名称。
7.
对标准样品聚焦。
8.
单击下一步 > 按钮。
9.
单击设置参照距离按钮。
•
采集图像,关闭实时模式。
•
鼠标指针随即会出现在图像窗口中。
45
配置系统
10.
使用鼠标指针确定该校准参考距离的起点和终点,例如,距离为 800 µ
m。单击鼠标左键设置这两个点。
11.
单击鼠标右键,并在上下文菜单中选定确认输入命令。
•
12.
设置参照距离对话框随即打开。
。
首先,选择适合的单位
例如,如果您使用的标准样品长度为 1 mm 并具有 100 个刻度单位,那
么请选定单位 µm。
•
请注意: 如果在这里选定单位英寸,则该图像将按照英寸进行校准。
但是,这并不表示所有的图像现在都会采用基本单位英寸进行采集。
您可以在摄像头设置中的采图设置 > 采集 > 常规对话框中指定图像
采集的基本单位。
13.
在长度字段中输入要用于校准的标准样品的长度。例如,如果标准样品的
长度为 1 mm,而您希望将刻度 10 到 90 作为参考距离,则请在该字段
中输入 800。
14.
单击确定按钮确认校准。
15.
如果您希望继续校准其它物镜,请单击下一个 > 按钮;如果不想继续校
准更多物镜,则请单击结束按钮。
16.
对选定的其它物镜重复进行手动校准。
•
17.
查看结果,并单击确定关闭手动放大倍率校准对话框。
•
18.
在校准对话框中,手动放大倍率校准校准流程随即呈已校准状态。
关闭校准对话框。
•
19.
当完成最后一项放大倍率校准后,手动放大倍率校准对话框将会打
开。
当您随后采集图像时,图像的 X/Y 校准将使用新的放大倍率值进行计
算。请注意,在进行图像采集之前,您必须在显微镜控制工具栏中选
定要使用的物镜。如果您使用了倍率变换器,则还必须选定要使用的
放大倍率级别。
您可以随时查看手动放大倍率校准得到的实际物镜放大倍率。
选定校准对话框中的手动放大倍率校准校准流程。然后单击编辑... 按
钮。
2134 25092015
46
510_UMA_Basler-Camera-Software_01_ch_Quesnel_30052016
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement