Cygnal 集成开发环境用户手册

Cygnal 集成开发环境用户手册
Cygnal 集成开发环境用户手册
1.概述
Cygnal 集成开发环境(IDE)是一套完整
了用于开发和测试项目的所有工具
独立的软件程序
它为设计者提供
程序的主要特点包括
项目界面
全功能
窗口字体可配置的编辑器
调试器具有设置断点 观察点 单步等功能
工具链接集成支持汇编器
编译器和链接器
可定制的工具菜单用于集成其它编译器或开发工具
CYGNAL 配置向导可为指定的目标环境产生配置代码
2.系统需求
IDE 要求系统最低配置为:
不低于 16MB 内存的奔腾 166PC 机(或兼容机)
SVGA 视频视配器
硬盘驱动器(12MB 空闲磁盘空间)
CD-ROM 驱动器(如果可从网上下载 IDE 可不需要 CD-ROM 驱动
器)
RS-232 串行通讯端口
鼠标
微软"视窗"操作系统 95/98/ME/NT/2000
3. Cygnal IDE 入门
下面举例说明创建项目 生成程序目标代码和下载程序到目标硬件系统的必
要步骤 这些都是为调试作准备 如果你已经安装了完全版的 Keil 8051 工具 即
带有完整专业版的 C51 编译器
你就可以用它来汇编 编译和链接程序, 但你
必须在 Tool Chain Integration 工具链接集成 对话框中为 Keil 8051 工具重新
设置路径 关于这方面的详细信息请参考应用笔记 AN004―在 Cygnal IDE 中集
成 Keil 8051 工具
沈阳新华龙电子有限公司 电话
024
1
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
3.1 创建一个新项目
1) 打开 IDE 在 IDE 视窗左边的项目窗口中 在 New Project 新项目
项上点击鼠标右键 选择 Save project New Project 弹出 Save Workspace
保存工作区 对话框
2)
使用 Save Workspace 保存工作区 对话框选择一个适当的目录来保
存项目 键入项目文件名然后单击 Save 保存 按钮 这样 New Project
被你刚保存的项目名取代
3.2 配置项目
1) 缺省设置时 Keil 8051 汇编器和链接器适合大多数应用 改变工具配置
或配置 C51 编译器 选择 Project─>Tool Chain Integration 来选择和设置
汇编器 编译器和链接器
2) 选择 File─>New File 将打开一个编辑窗口 键入源文件并保存文件 如
果保存的文件扩展名为.c .h 或.asm 源文件中的关键字符将彩色加亮
显示
3) 在项目窗口中的项目名上点击鼠标右键 选择 Add files to project 添加
弹出 Add files to project 对话框 选定要添加的文件点击
文件到项目
打开 这样该文件就添加到项目中了
4) 在项目窗口的项目名上点击右键 选择 Add groups to project 添加组到
项目
弹出 Project Groups(项目组对话框) 选定文件夹名后点击 Add
Group 添加组 则添加所选文件夹到项目 选择 Remove Group 移出
组 则从项目中移出文件夹 或在 Create New Group 框中键入新组名
后点击 Add 添加 按钮 则在项目中添加新文件夹
5) 如果你想汇编 编译和链接项目窗口中的所有文件生成目标文件 你在
文件名上点击鼠标右键 并选择 Add file to build 所有文件将被汇编或
编译 按其扩展名不同 和链接生成绝对目标文件
沈阳新华龙电子有限公司 电话
024
2
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
3.3 为调试生成和下载程序
1.
一旦所有的源文件已被加到目标 Build 中 在工具栏中点击 Build(生成)
按钮 或选择 Project->Build/Make Project 生成程序代码
在 Projects->Target Build Configuration 对话框中 如果选择 Enable
automatic connect/download after build 选项 如果生成程序成功 IDE 将
自动与目标系统连接并下载程序到目标硬件 准备调试 如果在生成代
码过程中发生错误 就不会下载程序
2.
保存项目也就保存了当前 IDE 配置 如当前目标生成配置 编辑器设置
和所有已打开的调试窗口的位置等
4. IDE 界面组成部分
IDE 界面由如下几部分组成
Cygnal IDE 窗口
调试窗口
菜单和工具栏
编辑器
工具链接集成
调试器
沈阳新华龙电子有限公司 电话
024
3
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
4.1 Cygnal IDE 窗口
集成开发环境
IDE 用户界面由三个主要窗口组成
项目浏览窗口
编辑/调试窗口
输出窗口
4.1.1 项目浏览窗口
文件察看窗口 用于察看和管理与项目相关的文件
详细信息请参考项目界面一节
符号察看窗口 用于察看项目中使用符号的地址
的详细信息请参考符号窗口一节
关于项目管理的
关于符号观察窗口
4.1.2 编辑/调试窗口
编辑窗口―用于项目中所选文件的编写或编辑
息请参考编辑器组成部分一节
关于编辑器的详细信
调试窗口―代码下载后 在调试期间此窗口用于观察代码的执行
于调试命令的详细信息请参考调试器组成部分一节
沈阳新华龙电子有限公司 电话
024
4
23930366 23895360 传真
23940230
关
Cygnal 集成开发环境用户手册
4.1.3 输出窗口
输出窗口是由几个复选窗口组成
这些复选窗口用于显示开发过程中的信息
Build 选项窗口―显示由集成工具产生的输出 如果在汇编/编译过程
中出错 用户可以双击窗口中的一条错误信息 则在编辑器中就会显
示发生错误的代码行 有关集成工具的相关信息请参考工具链接集成
一节
List 选项窗口―用来显示最新编译或汇编所产生的列表文件
Tool 选项窗口 如果工具输出被重定向到 tool.out"文件名 此窗口将
显示自定义工具所产生的输出 有关自定义工具的相关信息请参看使
用定制工具菜单一节
4.2 调试窗口
集成开发环境包含很多调试窗口 在调试期间用它来察看和修改存储器和寄
存器的信息 关于如何修改存储器和寄存器的值请参看本节下面的叙述或选择相
应 你希望修改的部分 调试窗口 你可以通过 View"菜单进入调试窗口 也
可以点击工具栏中的图标按钮进入某些调试窗口
沈阳新华龙电子有限公司 电话
024
5
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
下面介绍调试窗口
观察窗口
SFR 特殊功能寄存器
RAM 窗口
外扩 RAM 窗口
代码窗口
反汇编窗口
符号窗口
堆栈窗口
寄存器窗口
窗口
修改存储器和寄存器值
可以在光标处键入数值来修改寄存器原值 修改后的值可以在执行用户代码 点
击"Go"或"Step"按钮 前下载到硬件 方法是用 Refresh"按钮 图 refreshbutton
强制写入 这样修改后的值被写入仿真器 寄存器窗口将重读仿真器 窗口将被
刷新 所有变化的值以红色显示
注意 修改寄存器的值只能在调试器处于停止状态时进行 目标处理器正在执行用户代码时
不允许写入
4.2.1 观察窗口
观察窗口
观察窗口显示变量名和数值
在生成和下载程序代码后可以将要观察的变量加到观察窗口 有两种方法可
将变量加到观察窗口
沈阳新华龙电子有限公司 电话
024
6
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
在符号观察窗口中找到要加入的变量 在变量上点击鼠标右键并选择变量
类型
在源程序代码中找到你要加入到观察窗口的变量 然后在变量上点击鼠标
右键 从弹出菜单选择 Add
变量名到观察窗口 并选择变量类型 窗口大
小是可调整的 在窗口中删除变量的方法是选定变量然后按下 Delete 键
沈阳新华龙电子有限公司 电话
024
7
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
4.2.2 SFR
特殊功能寄存器
窗口
SFR 窗口按功能又分为
8051 8051 寄存器 ADC 模数转换 DAC 数模转换 Flash 闪存 Interrupts
中断 PCA 可编程计数器阵列 Ports 端口 SMBus I2C 总线 SPIBus
串行外设总线 和 Timers 定时器 窗口
1
8051 窗口
8051 SFR 窗口
8051SFR 窗口包含有用来配置 8051 的特殊功能寄存器 窗口大小是可调整
的 可以在光标处键入所需的值来修改寄存器原值 修改后的值可以在执行用户
程序代码前下载到目标硬件 方法是用 Refresh"按钮
强制写入 这样修改
后的值被写入仿真器 寄存器窗口将重读仿真器 窗口将被刷新 所有改变的值
以红色显示
注意 只有当调试器处于停止状态时 寄存器的值可被修改 当目标处理器正在
执行用户代程序代码时 不允许写入
沈阳新华龙电子有限公司 电话
024
8
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
2
ADC
ADC SFR 窗口
ADC SFR 窗口包含模数转换功能块的配置和数据寄存器 窗口大小是可调
整的 可以在光标处键入所需的值来修改寄存器原值 修改后的值可以在执行用
户程序代码 点击"Go"或"Step"按钮 前下载到硬件 方法是用 Refresh"按钮
强制写入 这样修改后的值被写入仿真器 寄存器窗口将重读仿真器 窗口将被
刷新 所有改变的值以红色显示
注意 只有当调试器处于停止状态时 寄存器的值可被修改 当目标处理器正在
执行用户代程序代码时 不允许写入
3
DAC
DAC SFR 窗口
DAC SFR 窗口包含 12 位电压模式 DAC 功能模块的配置和数据寄存器
窗口大小是可调整的 可以在光标处键入所需的值来修改寄存器原值 修改后的
值可以在执行用户代码 点击"Go"或"Step"按钮 前下载到硬件 方法是用
Refresh"按钮强制写入 这样修改后的值被写入仿真器 寄存器窗口将重读仿
真器 窗口将被刷新 所有改变的值以红色显示
注意 只有当在调试器处于停止状态时 寄存器的值可被修改 当目标处理器正
在执行用户代程序代码时 不允许入写
沈阳新华龙电子有限公司 电话
024
9
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
4
Flash
Flash SFR 窗口
Flash SFR 窗口包含 Flash 存储器的配置和数据寄存器 窗口大小是可调整
的 可以在光标处键入所需的值来修改寄存器原值 修改后的值可以在执行用户
代码前下载到硬件 方法是用 Refresh"按钮
强制写入 这样修改后的值被
写入仿真器 寄存器窗口将重读仿真器 窗口将被刷新 所有改变的值以红色显
示
注意 只有当在调试器处于停止状态时 寄存器的值可被修改 当目标处理器正
在执行用户代程序代码时 不允许写入
5
Interrupts(中断)
中断 SFR 窗口
中断 SFR 窗口包含编程中断处理器的寄存器配置 窗口大小是可调整的
可以在光标处键入所需的值来修改寄存器原值 修改后的值可以在执行用户代码
前下载到硬件 方法是用 Refresh"
按钮强制写入 这样修改后的值被写入
仿真器 寄存器窗口将重读仿真器 窗口将被刷新 所有改变的值以红色显示
注意 只有当在调试器处于停止状态时 寄存器的值可被修改 当目标处理器正
在执行用户代程序代码时 不允许写入
沈阳新华龙电子有限公司 电话
024
10
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
6
PCA
PCA SFR 窗口
PCA SFR 窗口包含可编程计数器阵列的配置和数据寄存器 窗口大小是可调
整的 可以在光标处键入所需的值来修改寄存器原值 修改后的值可以在执行用
户代码前下载到硬件 方法是用 Refresh"按钮
强制写入 这样修改后的值
被写入仿真器 寄存器窗口将重读仿真器 窗口将被刷新 所有改变的值以红色
显示
注意 只有当在调试器处于停止状态时 寄存器的值可被修改 当目标处理器正在执行用户
代程序代码时 不允许写入
7
端口
Ports
端口 SFR 窗口
沈阳新华龙电子有限公司 电话
024
11
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
端口 SFR 窗口包含端口和交叉开关的配置和数据寄存器 窗口大小是可调
整的 可以在光标处键入所需的值来修改寄存器原值 修改后的值可以在执行用
户代码前下载到硬件 方法是用 Refresh"按钮
强制写入 这样修改后的值
被写入仿真器 寄存器窗口将重读仿真器 窗口将被刷新 所有改变的值以红色
显示
注意 只有当在调试器处于停止状态时 寄存器的值可被修改 当目标处理器正
在执行用户代程序代码时 不允许写入
8
SMBus
SMBus SFR 窗口
SMBus SFR 窗口包括系统管理总线功能模块的配置和数据寄存 窗口大小是
可调整的 可以在光标处键入所需的值来修改寄存器原值 修改后的值可以在执
行用户代码 点击"Go"或"Step"按钮 前下载到硬件 方法是用 Refresh"按钮
强制写入 这样修改后的值被写入仿真器 寄存器窗口将重读仿真器 窗口将被
刷新 所有改变的值以红色显示
注意 只有当在调试器处于停止状态时 寄存器的值可被修改 当目标处理器正
在执行用户代程序代码时 不允许写入
沈阳新华龙电子有限公司 电话
024
12
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
9
SPIBus
SPI SFR 窗口
SPI SFR 窗口包括串行外设接口总线的配置和数据寄存器 窗口大小是可调
整的 可以在光标处键入所需的值来修改寄存器原值 修改后的值可以在执行用
户代码前下载到硬件 方法是用 Refresh"按钮
强制写入 这样修改后的值
被写入仿真器 寄存器窗口将重读仿真器 窗口将被刷新 所有改变的值以红色
显示
注意 只有当在调试器处于停止状态时 寄存器的值可被修改 当目标处理器正
在执行用户代程序代码时 不允许写入
10
定时器
Timers
Timer SFR 窗口
定时器 SFR 窗口包含定时器的配置和数据寄存器 窗口大小是可调整的
可以在光标处键入所需的值来修改寄存器原值 修改后的值可以在执行用户代码
前下载到硬件 方法是用 Refresh"按钮强制写入 这样修改后的值被写入仿真
器 寄存器窗口将重读真器 窗口将被刷新 所有改变的值以红色显示
注意 只有当在调试器处于停止状态时 寄存器的值可被修改 当目标处理器正
在执行用户代程序代码时 不允许写入
沈阳新华龙电子有限公司 电话
024
13
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
4.2.3 RAM 窗口
RAM 窗口
RAM 窗口显示 256 字节内部 RAM 窗口大小是可调整的 当前可见的地址
范围可用滚动条来调整或在窗口的上部地址定位框键入一个地址来调整 可以在
光标处键入所需的值来修改存储器原值 修改后的值可以在执行用户代码前下载
到硬件 方法是用 Refresh"按钮
强制写入 这样修改后的值被写入仿真器
RAM 窗口将重读仿真器 窗口将被刷新 所有改变的值以红色显示
4.2.4 外扩 RAM 窗口
外扩 RAM 窗口
沈阳新华龙电子有限公司 电话
024
14
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
只有当器件具有外扩 RAM 时 该窗口才有效 窗口大小是可调整的 当前
可见的地址范围可用滚动条来调整或在窗口的上部地址定位窗口键入一个地址
来调整 可以在光标处键入所需的值来修改存储器原值 修改后的值可以在执行
用户代码前下载到硬件 方法是用 Refresh"按钮
强制写入 这样修改后的
值被写入仿真器 外扩 RAM 窗口将重读仿真器 窗口将被刷新 所有改变的值
以红色显示
4.2.5 代码窗口
代码存储器窗口
代码存储器窗口将显示 64K 代码存储器部分 窗口大小是可调整的 当前可
见的地址范围可用滚动条来调整或在窗口的上部地址定位窗口键入一个地址来
调整 可以在光标处键入所需的值来修改存储器原值 修改后的值可以在执行用
强
户代码 点击"Go"或"Step"按钮 前下载到硬件 方法是用 Refresh"按钮
制写入 这样修改后的值被写入仿真器 代码窗口将重读仿真器 窗口将被刷新
所有改变的值以红色显示
注意 如果在此窗口修改代码 源代码将不再是真实代码的反映 所以在调试过
程中必须使用警告
沈阳新华龙电子有限公司 电话
024
15
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
4.2.6 反汇编窗口
反汇编窗口
反汇编窗口将显示 64K 代码存储器部分 窗口大小是可调整的 当前可见的
地址范围可用滚动条来调整或在窗口的上部地址定位窗口键入一个地址来调整
可以在光标处键入所需的值来修改存储器原值 显示的反汇编源程序不能更改
修改后的值可以在执行用户代码前下载到硬件 方法是用 Refresh"按钮
强
制写入 这样修改后的值被写入仿真器 反汇编窗口将重读仿真器 窗口将被刷
新 所有改变的值以红色显示
注意 当代码在此窗口中修改后 源代码将不再是真实代码的反映 所以在调试
过程中必须使用警告
如果必要注意修改源代码
沈阳新华龙电子有限公司 电话
024
16
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
4.2.7 符号窗口
在项目窗口中按 Symbol 键即可看到符号观察窗口 前提是项目已经生
符号观察窗口要求下载文件类型为带有调试信息的
成且输出文件已下载
OMF-51 在符号窗口中显示项目中所有符号地址 符号按四级排列 Files
Function
Data Type 和 Symbol
Files 包括项目中的所有源文件
Function 包括在每个文件中的所有函数 Data Type 包括代表 Bit, Code, Data,
IData, XData, and Number 的标题 符号窗口主要用来查找变量的 RAM 地址 这
样符号可以在 RAM 窗口中观察或配置成观察点
沈阳新华龙电子有限公司 电话
024
17
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
4.2.8 堆栈窗口
堆栈窗口
堆栈窗口显示堆栈限制 堆栈数 下溢检测和溢出检测值 窗口大小是可调
整的
4.2.9 寄存器窗口
寄存器窗口
寄存器窗口包含 R0-R7 的值 窗口大小是可调整的可以在光标处键入所需的
值来修改寄存器原值 修改后的值可以在执行用户代码 点击"Go"或"Step"按钮
前下载到硬件 方法是用 Refresh"按钮
强制写入 这样修改后的值被写入
仿真器 寄存器窗口将重读仿真器 窗口将被刷新 所有改变的值以红色显示
注意 修改寄存器的值只能在调试器处于停止状态时进行 目标处理器正在执行
用户代码时不允许写入
沈阳新华龙电子有限公司 电话
024
18
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
4.3 菜单和工具栏
IDE 有四个默认的工具栏 在下表中描述了这四个工具栏 也可以使用
Toolbar Configuration dialog"来定制工具栏
工具栏
按钮
文件/编辑
生成代码
调试
调试窗口
书签
沈阳新华龙电子有限公司 电话
描述
新建
创建一个新文件
打开
打开一个文件
保存
保存当前文件
剪切
剪切选定文本到剪切板
复制
复制选定文本到剪切板
粘贴
粘贴剪切板到光标位置
打印
打印当前文件
汇编/编译
停止生成
汇编/编译当前文件
停止生成代码
生成代码
汇编/编译和链接文件
连接
断开
连接 IDE 和目标板
断开按钮释放串口
下载
下载代码到目标硬件 flash
运行/停止
开始/停止执行目标处理器
中的程序代码
复位
硬件和 IDE 返回调试初态
单步
执行一条用户代码程序
多步
执行 N 条用户代码程序
单步越过
越过当行执行下行代码
运行到光标
程序运行到光标处代码行
插入/移出断点
设置/清除光标处断点
移出所有断点
移出所有断点
允许/禁止断点
激活/禁止当前断点
禁止所有断点
禁止所有断点
内部观察点对话框
打开内部观察点对话框
刷新
IDE 改变数值后 强制写仿真器
SFR 寄存器察看窗
触发察看窗口
寄存器察看窗
触发察看窗口
RAM 察看窗
触发察看窗口
代码察看窗
触发察看窗口
反汇编察看窗
触发察看窗口
下一个书签
移动光标到下一书签位置
触发书签
设置/清除光标处书签
上一个书签
移动光标到前一书签位置
移出所有书签
移出所有书签
024
19
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
IDE 的各种功能都是通过菜单和工具栏实现的 一些 IDE 的功能既可以
通过菜单选项又可以通过工具栏选项实现 下表是所有菜单选项的描
述
菜单名
File 文件
Edit 编辑
View 观察
Project 项目
Debug 调试
Tools 工具
Options 选项
Window 窗口
Help 帮助
描述
提供标准文件操作命令 如打开 保存和打印
提供标准编辑器命令 如剪切 粘贴 查找和替换
通过选择可视窗口允许用户定制 IDE
提供项目命令 如打开和汇编
提供调试器命令 如下载和单步 此外还有断点和观察
点管理
包括配置向导程序 FLASH 操作及用户工具配置
IDE 配置选项 如串口 用户可以定制 IDE 的工具栏和
编辑器选项
包含标准的窗口显示命令 如层叠和平铺
在线帮助和 IDE 版本信息
文件菜单
菜单项
New File 新文件
Open File 打开文件
Close File 关闭文件
Save 保存
Save As 另存为
Save All 保存所有
Print Setup 打印设置
Print 打印
Recent Files 最近文件
Recent Projects 最近项目
Exit
退出
沈阳新华龙电子有限公司 电话
描述
创建新文件
打开文件对话框 打开所选文件
关闭当前打开的文件 如果打开的文件已被
编辑 则将弹出对话框询问是否存盘
保存当前激活的文件并更改备份版本
允许当前打开的文件换名存盘
IDE 将保存所有打开的文件
打开打印机对话框 选择打印机参数
打印当前文件
此菜单区将列出 IDE 最近编辑的文件
此区域提供一种快捷方式用以打开 IDE 的最
近打开的项目
推出 IDE
024
20
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
编辑菜单
菜单项
Undo 撤消
Redo 重做
Cut 剪切
Copy 复制
Paste 粘贴
Find 查找
Replace 替换
描述
此命令使编辑器退回到最近的编辑命令
此命令使编辑器退回到最近的 undo 命令
此命令使选定的文字 高亮 被删除 但将文字复制到
剪切板
此命令将选定的文字复制到剪切板
此命令将剪切板的内容粘贴到当前光标位置
此命令打开对话框 用户可键入查找的参数并在当前文
件查找
此命令打开话框允许用户在当前文件查找并替换字符
串
察看菜单
菜单项
Debug Windows
描述
此菜单包含有子菜单 在子菜单中列出
了所有存储器和寄存器窗口 这些窗口
只有在调试时才可见
此菜单项触发显示 IDE 项目观察窗口
此菜单项触发显示 IDE 输出窗口
此项目菜单允许用户选择工具栏是否
可见 也允许用户定制工具栏
此菜单允许用户触发显示 IDE 状态栏
此菜单项允许用户在正常和笔记本模
式之间选择
调试窗口
Project Window 项目窗口
Output Window 输出窗口
Toolbars 工具栏
Status Bar 状态栏
Workbook Mode 工作薄模式
沈阳新华龙电子有限公司 电话
024
21
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
项目菜单
菜单项
Add Files to Project
加文件到项目
Assemble/Compile Current File and Stop
Assemble/Compile Current File 汇编/
编译当前文件和停止汇编/编译当前文
件
描述
此菜单命令将加文件到现有项目
此菜单将汇编/编译当前文件 汇编器/
编译器输出将显示在输出窗口中的
build 窗 如果编译器/汇编器报告错误
输出窗口中将显示错误概要 用鼠标点
击错误 IDE 将显示相应发生错误的源
代码行
Build/Make Project 生成项目
此菜单命令将生成目标代码
Open Project 打开项目
调用浏览对话框搜寻项目文件并打开
Save Project 保存项目
保存当前打开的项目
Save Project As 另存项目为
以新名字保存项目
Close Project
关闭项目
关闭当前打开的文件和窗口
Tool Chain Integration 工具链接集成
调用工具链接集成对话框 来定义外部
汇编器 编译器和链接器
Target Build Configuration 目标生成配 调用目标生成配置对话框 用来定义生
置
成过程
沈阳新华龙电子有限公司 电话
024
22
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
调试菜单
菜单项
Connect 连接
Disconnect 断开
Download 下载
Go
描述
通过 EC2 将串口和硬件连接起来
将释放串口
将下载当前打开项目到 Flash 如果当
前无文件或项目打开 将弹出对话框允
许用户选择文件下载 但文件必须是
Intel Hex 或 OMF-51 格式
将释放调试中断信号 允许运行用户程
序代码
将发出调试中断信号使芯片停止运行
程序 并开始执行调试服务程序代码
单步执行用户程序代码
执行 N 步用户程序代码
允许用户程序代码越过当前代码行执
行下面的代码
将允许用户程序代码运行到光标所在
的代码行
调用断点管理对话框 显示当前所有断
点信息 断点可以加入/删除/允许/禁止
调用观察点管理对话框 显示当前所有
观察点信息 观察点可以加入/删除/允
许/禁止
当在 IDE 中修改某些值后 强制写仿真
器
复位按钮迫使 IDE 和硬件返回到调试
初始态
运行
Stop
停止
Step 单步
Multiple Step 多步
Step Over 越过单步
Run to Cursor
Breakpoints
运行到光标
断点
Watchpoints 观察点
Refresh
Reset
刷新
复位
工具菜单
菜单项
描述
Cygnal Configuration Wizard Cygnal 配 调用 Cygnal 配置向导 能快速生成带
置向导
有外设详细信息的配置代码
Memory Fill 填充存储器
此菜单包含有子菜单 调用填充存储器
器对话框 填充 RAM 代码或外 Mem
Erase Code Space 擦出代码空间
删除和复位整个 FLASH 代码空间
Output Memory to File 输出存储器到 调用输出存储器器到文件对话框
文件
Add/Remove User Tool 加入/移出用户 调用对话框管理 IDE 用户工具 可以添
工具
加 移出或修改工具
沈阳新华龙电子有限公司 电话
024
23
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
选项菜单
菜单项
Multiple Step Configuration 多步配置
Serial Port 串口
Serial Baud Rate 串口波特率
Toolbar Configuration 工具栏配置
描述
调用多步配置对话框
选择 RS232 口
选择串口波特率
调用对话框选择允许那些工具栏可见
工具栏按钮配置 还可创建新工具栏
Toolbar Extended Styles 工具栏扩展类 调用对话框允许选择各种工具类型
型
Editor Font Selection 编辑器字体选择 调用对话框允许设定编辑器字型大小
和颜色
Editor Tab Configuration
调用对话框允许 tab 键设置
Select Language
选择语言
强制编辑器使用特殊语言配置文件
Debug Window Font Selection 调试窗 调用对话框允许选择调试/编辑窗口的
口字体选择
字体
File Backup Settings 文件备份设置
调用对话框允许选择备份文件的数量
窗口菜单
菜单项
Cascade 层叠
Tile Horizontal 水平平铺
Tile Vertical 垂直平铺
描述
标准 windows 层叠格式.
标准 windows 水平平铺格式
标准 windows 垂直平铺格式
帮助菜单
菜单项
CYGNAL IDE Help
Keil Assemble/Link Manual
Keil Compile Manual
About CYGNAL IDE
沈阳新华龙电子有限公司 电话
描述
调用在线帮助程序
Keil 汇编/链接手册
Keil 编译手册
显示 IDE 版本信息
024
24
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
4.4 编辑器
CYGNAL IDE 包含一个完整的编辑器
它具有如下特点
对于 8051 汇编语言和 C 语言源文件中的关键字符具有彩色显示功能
用户可以在 Options 菜单中使用 Select Language 选项菜单来选择语言
如 C 或汇编语言
编辑器还可以根据文件的扩展名自动识别语言
剪切 复制和粘贴命令 有关详细资料参看编辑器菜单一节
撤消/重做操作 有关详细资料参看编辑器菜单一节
支持查找和替换
在 Options 菜单中使用"Editor Configuration"选项来定制字体和文字颜
色
4.5 工具链接集成菜单
在 Project 菜单中选择 Tool Chain Integration 项 弹出对话框 允许在
IDE 中使用外部汇编器 编译器和链接器
在 Tool Definition 部分允许你选择工具厂商 浏览工具的执行路径
择 A51 C51 和 BL51 并为你的工具定义命令行标记
选
请参看: 使用工具链接集成菜单, 目标生成配置菜单, 汇编器工具定义,编译器工
具定义, 链接器工具定义和项目管理
沈阳新华龙电子有限公司 电话
024
25
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
4.6 调试器
CYGNAL IDE 包括一个完整的调试器
器 而不是仿真器
它是在实际产品硬件上运行的调试
注意 在使用调试器之前 PC 机必须与 EC2 及目标板连接 同时代码必须下载
到目标处理器的 Flash 存储器 相关信息请参看 Connecting to the hardware 和
Downloading a file
调试器的特点
Go
Step
可设置的
和
Stop
按钮―开启和停止目标用户代码执行
按钮―单步执行程序代码
按钮―执行 N 步
多步
Step Over
包括中断服务程序
按钮和
运行到光标
按钮
断点
观测点
调试窗口允许检查/修改寄存器和存储器内容
5. IDE 指南
以下将以示例说明 IDE 的特性
创建和打开项目
工具链接集成
目标生成配置
编辑和生成项目
连接到硬件
下载文件
使用调试器
使用观察点
使用定制工具菜单
沈阳新华龙电子有限公司 电话
024
26
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
5.1 项目管理
创建和打开项目
5.1.1 创建项目
项目是用来保存文件 工具链接 目标生成和窗口配置信息的 可以使用
Project 菜单中的 New Project 选项或 Save Project As 选项来创建项目
如果使用 Save Project As 选项 将出现 Save Workspace 对话框来选择项目
名称和存放的位置
一旦项目被保存
将保存如下信息
当前所有打开的文件 如果创建了新文件 且未存盘 则 IDE 将弹
出对话框提示你保存文件
工具链接集成设置
目标生产配置
主 IDE 窗口及已打开的调试窗口的位置和大小
编辑器的设置如字体和文字颜色
5.1.2 重新打开项目
有两种不同的方法打开项目
1) 使用文件菜单中的 Recent Projects 子菜单区 子菜单中列出了最近打
开过的项目
2) 使用项目菜单中的 Open Project 命令 调用 Open Workspace 对话
框允许你浏览计算机中的项目文件 *.wsp 并打开所选文件
5.1.3 保存一个项目
保存项目用 Project 菜单中的 Save Project 选项 项目不必每次打开后
都保存 遇到下面的情况需保存项目
已打开新文件且将作为项目的一部分
已打开新窗口 且每次打开项目时都需要重新打开这些窗口
IDE 窗口的位置和/或大小改变了 且在下次项目重新打开时需保留
这种变化
沈阳新华龙电子有限公司 电话
024
27
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
5.1.4 加文件到项目中
可用下面的方法向已存在的项目中添加文件
A.在项目窗口的 File 选项窗口中添加文件到项目
1. 在项目或组上点击鼠标右键
2. 在弹出菜单点击 Add Files. 菜单选项
B.从 Project 菜单中加文件到一个打开的项目
1 打开项目
2 在 Project 菜单中用 Add Files to Project
C 从
选项
Build Button Definition 对话框中添加文件到项目
1 从 Project 菜单中打开 Target Build Configuration 对话框
2 点击 Customize 按钮
3 使用 Add Files to Project 按钮
5.1.5 从项目中移出文件
从已有项目中移出文件可用下面的方法
A 在项目窗口的文件窗口中在要移出的文件上点击右键
B 在项目窗口的文件窗口中选中要移出的文件按键盘上的 Delete 键
5.2 使用工具链接集成菜单
从 Project 菜单中点击 Tool Chain Integration 弹出对话框 允许你向开
发环境中集成外部汇编器 编译器和链接器
沈阳新华龙电子有限公司 电话
024
28
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
5.2.1
工具定义
a) 从 Select Tool Vendor 的列表中选择工具厂商
b) 选择你希望定义的 Assembler
Compiler 和 Linker 工具
c) 在
Executable
编辑框中键入可执行的文件名
如
A51.exe,C51.exe,BL51.exe 和路径 或点击浏览按钮找到可执行文
件名和路径
d) 如果知道所需的命令行标志 你可以直接在 Command Line Flags
编辑框中键入
5.2.2 复位默认按钮
Reset Defaults
次按钮是复位命令行标志到默认值
请参见
目标生产配置
和
项目管理
5.3 使用目标生成配置菜单
在 Project 菜单中选择 Target Build Configuration 弹出对话框 指定下
载文件产生过程和允许或禁止附加选项
沈阳新华龙电子有限公司 电话
024
29
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
5.3.1 下载文件产生
a) 在 Download file name 编辑框中键入输出文件名 如 Blinky
b) 如果你想使用一个已经生成的目标文件 选择 Execute batch or Make File
on Build Command 单选按钮 和在 Build filename 编辑框中键入 或
浏览 文件名
c) 另外 选择 Define Build Process
单选按钮 和点击 Customize 按
钮引出
Build Button Definition 对话框
5.3.2 附加选项
a) 如果选中 Enable automatic save for project files before build 框 那末当
按下 Build/Make project 按钮
后 项目中的所有文件将自动存盘
此前的文件版本将被保存到备份文件中
如果选中 Enable automatic connect/download after build 框
b)
Build/Make project
下
请参见
工具链接集成
和
按钮
后
那末当按
项目将自动下载到目标板
项目管理
5.4 编辑和生成项目
5.4.1 编辑文件
IDE 包括一个全功能的编辑器 可用文件菜单中的
New File 命令来新建
文件 或用文件工具栏中的 New 按钮
然后开始键入源程序 只有当文
件的扩展名为.asm 或 .c 时 才具有源程序关键字符彩色显示功能 可用文件保
存按钮
或用文件菜单中的 Save
辑器的详细信息请参考 编辑器 一节
沈阳新华龙电子有限公司 电话
024
30
或
Save As
命令保存文件
23930366 23895360 传真
关于编
23940230
Cygnal 集成开发环境用户手册
5.4.2 汇编/编译一个文件
可用生产工具栏中的汇编/编译按钮
或
Project
菜单中的
Assemble/Compile File 命令来汇编/编译一个文件 如果一个项目或文件是打
开的 那末当前活动的文件将被汇编/编译
当汇编/编译完成后 将在输出窗口的 Build 选项窗中显示汇编/编译结果
如果产生列表文件 那末将在输出窗口的 List 选项窗中显示
5.4.3 生成一个项目
或用项目菜单中的 Build/Make Project
可用生成工具栏中的生成按钮
命令来生成项目 如果没有打开的项目此命令是被禁止的 关于项目的更多信息
请参看 项目管理 一节
当汇编/编译和链接完成后 结果将显示在输出窗口的 Build 选项窗中
如果产生列表文件 文件将显示在输出窗口的 List 选项窗中
5.5 与硬件连接
在 IDE 与硬件连接之前
请执行下列步骤
a) 用串行电缆连接 PC 机和 EC2
b) 用 JTAG 扁平电缆连接 EC2 和目标硬件
c) 将电源接到 EC2 和目标硬件(目标板) 注意 EC2 不向目标板供电 但
目标板可向 EC2 供电
d) 在 IDE 的 选 项 菜 单 的 串 行 口 子 菜 单 中 选 择 适 当 的 串 行 口
COM1,COM2,COM3,COM4
e) 从 IDE 的选项(Options)菜单中选择适当的目标连接
如果是 C8051F3XX 器件选择 Cygnal 2-Wire
如果是 C8051 其它器件选择 JTAG
当所有的硬件已连接
连接
已在 IDE 中选择了串行接口
可用生成工具栏中的连接按钮
现在可将 IDE 与硬件
或使用调试菜单中的
Connect
命令
来完成连接 如果 IDE 不能访问串行口将报告出错 这可能是由于串口被其它
程序占用 如果是这种情况关闭其它应用程序重试连接
沈阳新华龙电子有限公司 电话
024
31
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
一旦与硬件连接
下载按钮
被使能
如何下载程序到目标硬件请参考
Download a program to hardware (下载程序到目标硬件)一节
注意
如果其它应用需要使用串口
的断开连接按钮
可以用
Disconnect
命令或生成工具栏中
来断开连接
5.6 下载程序到硬件
简单地按下生成工具栏中的下载按钮
或使用调试菜单中的
Download
命令 就可以下载程序到目标处理器的 flash 中 注意 只有在执行 Connect
命令后这些命令才有效
如果在调用下载命令时有项目或文件已打开 相关的
目标文件将被下载 如果当前无文件或项目打开 则将弹出一个对话框要求选择
需下载的文件
IDE 下载的文件格式为 Intel Hex 或 OMF-51 格式 如果下载的文件是 OMF-51
文件并带有调试信息 则 IDE 将尝试打开所有相关的源文件并开始源级调试
这一功能不支持不带调试信息的十六进制或 OMF-51 文件
一旦程序被下载 你就可以在目标硬件上调试和运行你的程序,而不是在仿
真器上 一旦程序被下载到目标硬件 所有的调试按钮 如 Go, Stop,和 Step 等
都将被允许 .关于调试功能的更多信息请参考 调试器 一节
5.7 调试器
CYGNAL IDE 包括一个完整的调试器
仿真器
注意
连接
硬件
它运行在实际的产品硬件上,而不是
在你使用调试器之前 你的 PC 机必须与 EC2 连接,而 EC2 必须与目标板
而且程序代码必须下载到目标处理器 flash 中 相关信息请参看 连接到
和 下载文件 部分
调试器的特点如下
Go
Step
和
Stop
按钮―开始和停止目标用户代码执行
按钮―单步执行代码
一次一条源级指令
包括中断服务
程序
沈阳新华龙电子有限公司 电话
024
32
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
可配置的
Multiple Step
按钮―执行 N 步
Step Over
按钮和 Run to Cursor
断点
观察点
调试窗口允许察看/修改存储器和寄存器信息
按钮
5.8 观察点的设置
如果想察看 SFR 存储单元跳到第二步 打开项目窗口的 Symbal 选项
窗 找到你想要观察的符号/变量
打开观察点对话框 在四个观察点位置选择 RAM 或 SFR 并复制 RAM
单元到相应的观察点地址框或从地址框中选择 SFR
注意 你可以按十六进制或十进制指定 RAM 地址
选择是在与你指定的值相匹配或不相匹配是停止
指定与符号/变量的比较值
注意
你可以按十六进制或二进制指定值
如果你只想观察某些位而忽略其它位 指定要屏蔽的位 逻辑 1 察看
反之逻辑 0 忽略 注意 可以按十六进制或二进制指定屏蔽位
在四个位置重复上述过程加入要观察的变量
在观察点配置框中选择你要观察的是 ANY 或 ALL 如果选择 ANY 当
四个观察点中有一个匹配时 IDE 将停止并显示观察点对话框 如果选择
ALL 当所有的四个观察点都匹配时 IDE 将停止并显示观察点对话框
在 Internal Watchpoint Control 中选择 Internal Watchpoints Enabled
点击 OK 按钮 现在你可以单步或运行代码
止运行并显示观察点对话框
当观察点匹配时 IDE 将停
一旦遇到匹配值 IDE 停止并显示观察点对话框 为了 IDE 能够继续运行
而 不 会 因 当 前 匹 配 而 再 次 停 止 匹 配 值 必 须 清 除 或 改 变 Internal
Watchpoints 对话框提供了 Clear All 和 Clear Matched 按钮 使清
除更加容易
沈阳新华龙电子有限公司 电话
024
33
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
Internal Watchpoints 对话框
5.9 使用定制的工具菜单
定制的工具菜单允许你向开发环境中集成你自己的外部开发工具
Menu Text 编辑框包含工具菜单中显示的文字 Tool Executable 编辑框
中为调用的相关可执行程序
Arguments 编辑框包含可执行程序的参数列表
Dir of execution 是执行目录
沈阳新华龙电子有限公司 电话
024
34
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
举例
如果用户有一个外部十六进制编辑器
他们能使用下面的 DOS 命令
行
C:\projects\my proj>c:\Utils\hexedit.exe 'flag 1' 'flag 2' 'flag 3'
Menu Text
为
Tool Executable
arguments 将是
Hex Editor
将是
c:\Utils\hexedit.exe
'flag 1' 'flag 2' 'flag 3'
Dir of Execution 中将是
C:\projects\my proj
注意 在输出窗口的 Tool 选项窗中显示输出 通过附加 > tool.out 到 Tool
Executable 中可简单地重定向输出到文件 tool.out IDE 将在执行目录中寻找
该文件名 如果找到 文件中的内容将在输出窗口的 Tool 选项窗中显示
6.Cygnal 配置向导
沈阳新华龙电子有限公司 电话
024
35
23930366 23895360 传真
23940230
Cygnal 集成开发环境用户手册
Cygnal 配置向导用来为一指定的目标环境产生配置代码 检验栏窗口(左边)
包含所有外设和它们的配置 当选择后配置文件中的代码将改变以完成指定的配
置 下面是配置向导的特性
每一个外设都有一个定义区 当该区被完全配置后 小方块颜色会改变
例如 在上面图示中 比较器 1 完全配置, 小方块填充为黑色 相反
比较器 1 未被配置 小方块将不填充
文件菜单执行标准的保存和另存命令 这样项目的多重配置会很快产生
复位特性允许用户将所有外设返回到复位状态
生成的代码是完全注释的并以彩色显示源程序关键字符 这样使代码更
易于理解和更改
7. 客户支持
沈阳新华龙电子有限公司客户支持
电话:(024)23895360 23930366
传真:(024)23940230
Email:[email protected]
网站
www.xhl.com.cn
沈阳新华龙电子有限公司 电话
024
36
23930366 23895360 传真
23940230
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement