Melanie QSM 20022008.fm
Melanie Quick Start 1
1
Melanie Quick Start
Melanie is a comprehensive software for visualizing, editing and
analyzing two-dimensional electrophoresis (2-DE) data.
The goal of this introduction is to familiarize you with the new and
improved interface. It is the fastest way to start exploring and working
with Melanie on your own.
More detailed and advanced information can be found in the User
Manual.
We assume several things at this point:
•
You are an experienced computer user.
•
You have already successfully installed Melanie.
•
You have knowledge of electrophoresis and staining techniques.
The image analysis workflow presented is idealized, i.e. editing is not
performed. In reality, gels often need to be refined to optimize
detection, matching and ultimately the results.
The sample gels used in the examples study protein expression
changes between four populations of gels. Cells were grown under
two different conditions (substrate A and substrate B) and underwent
one of two treatments (treatment 1 and treatment 2).
1.1
Population
Condition
Treatment
A_T1
Substrate A
Treatment 1
A_T2
Substrate A
Treatment 2
B_T1
Substrate B
Treatment 1
B_T2
Substrate B
Treatment 2
Launch the software
•
Double-click the Melanie 7.0 shortcut on your desktop.
•
Click Start > Programs > Melanie 7.0.
The first time you launch the software, pop-up windows prompt you
to enter a name for a new project and to open the gels to be studied.
Melanie 7.0 Quick Start Manual Edition AA
1
1 Melanie Quick Start
1.1 Launch the software
1
In the New Project window, enter a Project Name and click OK.
2
In the Open Files window, locate and select the image files. Click
Open.
3
In the Gel Properties window, verify the defaults and click OK.
In the example, every gel has the same stain, therefore Apply
2
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
Staining to All is selected to quickly load the images.
Workspace
Menu bar
Toolbars
Image Pool sheet
Status bar
The gel images are arranged in a tabbed sheet labelled Image Pool.
To open DIGE gels, the file names must contain “Cy2”, “Cy3” or
“Cy5”. In the Create DIGE Gel window, Melanie automatically
recognizes and proposes the correct combination of DIGE images
and the corresponding DIGE gel name.
Once opened, the two or three images in a DIGE gel are grouped in
a pane within the Image Pool sheet.
Melanie 7.0 Quick Start Manual Edition AA
3
1 Melanie Quick Start
1.2 Customize toolbars
1.2
Customize toolbars
The standard toolbars can be configured according to your
individual specifications.
1
To change the order, click the left edge of a toolbar and drag the
toolbar to the position you want.
The Image toolbar (rotate, flip, invert, etc.) is contextual, i.e. it is
only visible when there are gels in the Image Pool.
4
2
To add or remove buttons, choose Tools > Customize.
3
In the Customize window, under the Toolbars tab, click New to
create a toolbar.
4
Enter a Name for the toolbar (e.g. Custom 1). Click OK.
5
Click the Commands tab in the Customize window and select a
category.
6
Click the desired command in the list and drag it to the empty
toolbar that was just created in Toolbars. In the example, a button
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
for Detect from the Edit category was added to the custom
toolbar.
1.3
7
Repeat these steps to create a toolbar containing shortcuts to
commands such as Detect, Edit Enabled, Match Gels, Add
Match, Delete Match, and more.
8
Close the Customize window.
Work with gels
The tools in the Image toolbar are convenient if gels need to be
rotated, flipped, cropped, or their gray levels need to be inverted.
The operations are only applied to selected gels. To select a gel, click
the gel name. Click the sheet tab to select all gels. Use the Shift or Ctrl
keys to select a subset of gels.
Melanie 7.0 Quick Start Manual Edition AA
5
1 Melanie Quick Start
1.3 Work with gels
1.3.1
Adjust the contrast
1
Click Magnify in the toolbar:
2
Hold the Shift key and click in one of the images. All images are
zoomed with the same factor.
3
Click Region in the toolbar:
4
Hold the Shift key and define a region in one of the images. A
region of identical size appears in the other images.
5
Click Contrast in the toolbar:
6
To modify the contrast and brightness of the image and see the
effect on the selected regions, adjust the horizontal scroll bar
below the histogram and/or the vertical bending parameter.
7
To view saturated and background regions in the images,
change the palette in the Color drop-down list to
Gray+Saturation.
Note: You can redefine the preview regions to look at other
areas in the images.
6
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
8
To apply the contrast settings to all selected images, reset the
Color drop-down list to Gray and click Apply.
9
Close the Adjust Contrast window.
Modifications such as rotation, flip and crop are simultaneously
carried out on all the images in a single DIGE gel.
1.4
View the Workspace
1
To open the Workspace (if not already visible), click the
Workspace tab on the left side of the interface.
2
To pin the Workspace, click the Auto Hide button in the top right
corner of the window.
In the Workspace, each of the open gel images is listed in the Image
Pool. The two or three images in a DIGE gel are grouped in a folder
within the Image Pool folder. To view details about the gel images,
click the Expanded View button in the Workspace toolbar. To add
more gel images, right-click on Image Pool and select Add.
The project name is also listed in the Workspace. The Workspace
shows the hierarchical structure of files (gel images) and folders
(projects, match sets and classes). Using the Workspace, you can
display, copy, paste, move and rename files and folders.
1.5
Create a hierarchical match structure
It is recommended to use hierarchical match structures to compare
your images (i.e. find corresponding spots). A DIGE gel is an inherent
match set. An example of a match hierarchy is shown below.
Melanie 7.0 Quick Start Manual Edition AA
7
1 Melanie Quick Start
1.5 Create a hierarchical match structure
Gels or match sets with a red marker are used as the reference in
viewing or matching and appear first in the list. To change the
reference, drag the desired gel or match set onto the existing
reference so that it moves into the first position.
When a DIGE gel is opened for the first time, the reference image
needs to be selected. The Cy2 image is always proposed by default.
Bear in mind that not all gel images are matched equally. Images
from samples belonging to the same biological population or the
same experimental group (e.g. gels that have been run in the same
batch) are often easier to match. Working with a hierarchical
structure reduces the number of difficult matches (e.g. AT1 versus
AT2, or A versus B).
Furthermore, only spots matched with a spot in another gel are
included in Gel and Class Analysis Tables (all spots are of course
presented in a Spot Table). The likelihood of a spot being matched is
much higher when matching with a gel from the same biological
population. Spots that are represented in a single population (such as
a sub match set) are therefore included in the analysis, even if they
are not in the global match reference.
1
8
Select images (e.g. A_T1_Gel1, A_T1_Gel2 and A_T1_Gel3) in the
Image Pool folder in the Workspace.
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
2
Drag the images onto a project (e.g. Bacteria). In the Create
MatchSet window, enter a Name and click OK.
Alternatively:
1
Select images (e.g. A_T1_Gel1, A_T1_Gel2 and A_T1_Gel3) in the
Image Pool sheet.
2
Click the Add Files to Project button in the Image toolbar. In the
Add Files to Project window, select a project and create a match
set by selecting <New>. In the Create MatchSet window, enter a
Name and click OK.
In the example, these steps were repeated to create four match sets
AT1, AT2, BT1 and BT2. Match sets can be further combined.
Melanie 7.0 Quick Start Manual Edition AA
9
1 Melanie Quick Start
1.5 Create a hierarchical match structure
3
Select the match sets (e.g. AT1 and AT2), right-click and choose
Merge MatchSet.
4
In the Create MatchSet window, enter a Name and click OK.
In the example, the match sets AT1 and AT2 are merged into match
set A. BT1 and BT2 are merged into match set B. Finally, A and B are
merged to create the root match set AB. Root match sets contain the
folders Match and Classes.
10
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
5
To view the gels in a match set in a new sheet, right-click on the
match set name (or images) and select Display.
The gels are placed in a sheet labelled with the match set name. Gels
in sub match sets are grouped in panes labelled with the sub match
set name.
1.6
Change layout
You can change the layout of the Melanie interface in order to
optimize the available space.
•
To arrange your images, use the buttons in the top right corners
of the sheet or pane tabs.
Melanie 7.0 Quick Start Manual Edition AA
11
1 Melanie Quick Start
1.7 Detect spots
•
To resize the Workspace, drag its right border.
The Workspace is a dockable window, i.e. it can either be attached
to the interface window or be in a floating state. Report windows are
also dockable.
•
1.7
12
To dock, undock or close a dockable window, use the buttons in
the top right corners of the window. When docking a window,
blue arrows indicate where the window may be docked. By
moving the cursor over the arrows, a shaded blue box shows
where the window will reside once the left mouse button is
released.
Detect spots
1
To preview the spot detection results, click Region in the toolbar
to define a region in one or more selected gels in areas with
representative spots.
2
To display the Cursor Information window, click Cursor Info in the
toolbar.
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
3
Choose Edit > Spots > Detect or click Detect in the toolbar (if
present).
4
In the Detect Spots window, adjust the Smooth parameter to
detect all real spots and correctly split any overlapping ones.
5
Move the cursor over a few spots that you consider to be noise or
artifacts and look at their Saliency values in the Cursor Information
window. In the Detect Spots window, enter a Saliency value that
is just above that of the spots to be filtered out.
6
Sometimes, very small but intense artifacts like dust particles
cannot be eliminated with the Saliency parameter without
removing real spots. To get rid of such artifact spots, set an
appropriate Min Area value.
7
When the detection preview is satisfactory, click OK to detect all
spots in the selected gels.
Processing may take a few minutes to complete. The detected spots
are outlined in red.
Melanie 7.0 Quick Start Manual Edition AA
13
1 Melanie Quick Start
1.8 Add landmarks
TM
The DeCyder 2D co-detection algorithm is applied to DIGE gels. In
the DIGE Spot Detection window, enter an estimation of the Number
of Spots present in each image. Select Apply To All and click OK.
1.8
Add landmarks
To maximize the available space for viewing gels, you can close the
Cursor Information window and click Auto Hide to minimize the
Workspace.
1
Click Landmark in the toolbar.
2
Position the cursor over a known, well-defined spot in the
reference gel and click. A “Validated” landmark symbol (bold
orange circle) appears on the spot.
3
In the other images, drag the “Non-validated” symbols (green
circle with orange plus sign) onto the corresponding spots.
Validated
Non-validated
During positioning
In certain gels, the symbols will only become visible once the
landmark has been validated in the reference. In the example, the
landmark had to be validated in the image B_T2_Gel1 before any
14
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
landmark symbols would appear in the images B_T2_Gel2 and
B_T2_Gel3.
It is sufficient to place just one or two landmarks in gels with good
reproducibility.
1.9
Match gels
1
Choose Edit > Matches > Match Gels or click Match Gels in the
toolbar (if present).
2
Use the Ctrl or Shift keys to choose the match sets to be matched.
In principle, all of them can be selected. Click OK.
When the process is completed, the software gives the number of
matches created, and displays the match vectors in blue. Vectors link
the spot in a gel with the corresponding spot in the reference image
(imagine that the reference lies below). This reference image should
not be mistaken for the match reference. The vector pattern is proof
of consistency. If there is a mismatch, the vector has a different length
and/or orientation.
Melanie 7.0 Quick Start Manual Edition AA
15
1 Melanie Quick Start
1.10 Edit matches
When a gel is moved, the vectors become longer. Select Move in the
toolbar and double-click in the gel to recenter all the images,
including the reference, to the same position and therefore minimize
the match vectors.
A blue upside down triangle on a spot indicates that the spot was
matched to one or several spots in other gels, for which no
corresponding spot in the global match reference was found.
A spot with a triangle means that the corresponding position in the
reference lies outside the visible area.
1.10 Edit matches
1
Use the Select tool to click on a spot. The spot and any matches
are highlighted in green.
What can be done if all corresponding spots are not matched? In the
example, the selected spot was correctly matched throughout
match set A and within BT2. But due to spot splitting in gel B_T1_Gel1,
it was not matched within match sets BT1 and B.
16
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
Rather than merging the two spots in B_T1_Gel1 (spot edition should
be avoided whenever possible), the spots were both included in the
match and treated as a single entity in the spot quantification.
2
To add spots to a match, hold the Shift or Ctrl keys and select all
spots that should be part of the same match.
3
Choose Edit > Matches > Add Match or click Add Match in the
toolbar (if present).
In the example, the selected spots are now all matched. The two
spots in gel B_T1_Gel1 are treated as a single entity in the
quantification. This means that their combined quantification values
are compared to those of the spots in the other images.
To review matching, choose Select > Matches > All and specify the
hierarchical level at which you want to select the matches (e.g. AB
to select all spots matched to the global reference). Matched spots
are highlighted in green. The matching of any red spots should be
scrutinized. However, this can also be done during data analysis.
Melanie 7.0 Quick Start Manual Edition AA
17
1 Melanie Quick Start
1.11 Create classes
1.11 Create classes
In order to analyze gels or gel populations, it is necessary to define
classes. A class is a set of gels or gel populations with common
biological properties. Comparing classes enables you to find the
protein expression variations between different biological states.
1
Select a match set (e.g. AT1) in the Match folder and drag it into
the Classes folder.
2
In the Create Class window, confirm or modify the Name of the
class and click OK.
Alternatively:
1
In the Match folder, select all gels to be added to a new class.
The gels may be part of different sub match sets but must belong
to the same match hierarchy.
2
Right-click and select Add in Class.
3
In the Add Gels in Class window, enter a Name and click OK.
4
Repeat these steps until all classes are created.
5
Hold the Shift or Ctrl key to select several classes.
6
To open the images in a classes sheet, right-click and select
Display.
In the example, the Classes defined reflect the structure in the Match
folder. This is not always the case in other experiments.
18
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
You are now ready to create tables, graphs and apply statistics to the
spots, gels, annotations, matches, or classes. All of these features are
found in the Reports menu.
1.12 Data analysis
1
To decide which quantification value to use for your analysis,
choose Tools > Options.
2
In the Quantification tab of the Options window, specify the
quantification values. For non-DIGE analyses, the default is %Vol
Melanie 7.0 Quick Start Manual Edition AA
19
1 Melanie Quick Start
1.12 Data analysis
(relative volume). For DIGE analyses, Vol Ratio is highly
recommended. Click OK.
Differential analysis between populations of gels, i.e. classes, is
essentially based on the values found in the Class Analysis Table.
3
Choose Reports > Analyse Classes > Table.
4
To pin the Class Analysis Table window open, click the Auto Hide
button in the top right corner.
The title of the table indicates that the Center and Dispersion values
for each class (e.g. AT1, AT2, BT1 and BT2) correspond to the Mean
and M.S.D., respectively.
Click the Statistics drop-down list in the table toolbar to change the
statistical values displayed.
Note: The sliders in the Classes Statistics window allow you to remove
a percentage of outliers for the calculation of the Central
20
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
tendency and Dispersion. By default, no outliers are excluded.
You can also set the two classes to be used for the calculation
of the Student t, Mann-Whitney U, and Kolmogorov-Smirnov D
statistics.
The Center, i.e. mean value (including 100% of spots), is the default
display in each class column. The Max column lists the highest of
these values.
You can also show the Dispersion for each class in the table, or one
of Melanie’s Overlapping Measures between class intervals. Class
intervals are defined by the range [Central value - Dispersion, Central
value + Dispersion]. These intervals are more easily understood when
looking at the Class Analysis Histograms.
Melanie 7.0 Quick Start Manual Edition AA
21
1 Melanie Quick Start
1.12 Data analysis
5
Choose Reports > Analyse Classes > Histograms.
Each histogram displays, for a given spot, the quantification values in
the different gels as orange bars. To see what gel corresponds to
which letter, click the Settings button in the histograms toolbar and
select Show Labels. Alternatively, move your cursor over a letter to
view the gel name. Classes are separated by gray vertical lines.
The blue horizontal lines in the histograms represent the mean values
for each class. The red lines delimit the class intervals defined by
[Central value - Dispersion, Central value + Dispersion].
These notions relate to the Overlapping Measures that are calculated
by Melanie in the Class Analysis Table.
•
Gap: Maximum difference between the range of the current
class and the range of one of the other classes. Negative values
indicate overlapping intervals whereas positive values are nonoverlapping intervals.
•
Ratio: Maximum ratio between the lower limit of one of the other
classes and the upper limit of the current class. Absolute values
less than 1 indicate overlap, whereas absolute values greater
than 1 show that there is no overlap. If one class interval is
completely overlapped by another one, the Ratio is 0. Negative
values indicate that the spots in the current class are underexpressed compared to those in the other class.
Note: The default Ratio is not the widely-used ratio between the
mean values in two classes. To calculate this classical ratio,
you must set the Dispersion slider in the Classes Statistics
window (see above) to 0%.
22
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
•
Normalized: Maximum percentage of the current class range
not overlapping with the range of one of the other classes. A
value less than 1 indicates overlap. For example, 0.25 implies that
25% of the current class range is not recovered by one of the
other classes. In the same way, a value of 1.5 implies that there is
a gap equivalent to 50% of the current class range in
comparison to the farthest other class.
Overlapping Measures enable you to find significant protein
expression changes.
6
In the Class Analysis Table, click the Statistics drop-down list to
select Ratio.
7
Click Select by Value in the table toolbar.
8
In the Select by Value window, specify all spots with a Max ratio
greater than or equal to 1.5.
9
Click Annotate in the table toolbar and enter a new name for a
Spot Set to be created (e.g. “Ratio > 1.5”).
10 To limit the analysis to the currently selected spots, choose Edit >
Active Spots > Set.
Click the Select button in the main toolbars and then click anywhere
in one of the images, but not on a spot. All spots are deselected. The
red spots are active and appear in reports (tables, histograms, plots).
The yellow spots are inactive and therefore are not included in the
reports. To include or exclude spots from the active spot set, select
the spots in question and choose Edit > Active Spots > Add or Edit >
Active Spots > Remove.
11 In the Class Analysis Table, click the Statistics drop-down list to
select Gap.
12 Double-click the Max column. The maximum gap between any
of the classes is now sorted in descending order.
13 To select a spot in the gels, click the relevant row in the table.
Melanie 7.0 Quick Start Manual Edition AA
23
1 Melanie Quick Start
1.12 Data analysis
14 If the spot is expressed differently, click Annotate in the main
toolbar and enter a name for the Spot Set to be created (e.g.
“Validate”). The box in the corresponding row is automatically
checked.
15 Use the up and down arrow keys to move to the previous or next
row in the table.
24
Melanie 7.0 Quick Start Manual Edition AA
Melanie Quick Start 1
To look at 3D Views of spots, choose Reports > 3D View. The Tools
button in the 3D View window includes features such as rotate, zoom
and translate.
1.13 Export tables
1
To export a table in text, Excel or XML formats for use in another
software, click Save in the table toolbar.
2
In the Save Table window, browse to the desired location and
enter a File Name. Click Save.
1
To generate a pick list for a spot excision robot, choose Select >
Spot Sets.
2
Make a selection in the Select Spot Set window and click OK.
1.14 Pick lists
Melanie 7.0 Quick Start Manual Edition AA
25
1 Melanie Quick Start
1.14 Pick lists
3
26
Choose File > Export > Spots to Picker. Consult the User Manual for
more details about the different spot picker formats.
Melanie 7.0 Quick Start Manual Edition AA
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement