SIMIT SCE
s
SIMIT SCE
User Manual
s
Issue date
July 2009
Trademarks
SIMIT® is a registered trademark of Siemens AG.
The remaining trademarks in this publication may be trademarks whose use by third parties for their own purposes could violate
the rights of the owner.
Copyright © Siemens AG 2009 All rights reserved
Disclaimer of Liability
The reproduction, transmission or use of this document or its
contents is not permitted without express written authority.
Offenders will be liable for damages. All rights, including rights
created by patent grant or registration of a utility model or
design, are reserved.
We have checked the contents of this manual for agreement
with the hardware and software described. Because
deviations cannot be precluded entirely, we cannot guarantee
full agreement. However, the data in this manual are
reviewed regularly and any necessary corrections included in
subsequent editions. Suggestions for improvement are
welcomed.
Siemens AG
Industry Sector
Industry Solutions Division
SIMIT-HB-SCE-2009-07-en
© Siemens AG 2009
Subject to change without prior notice.
s
Content
1
PREFACE
6
2
SPECIAL FEATURES OF SIMIT SCE
7
3
4
5
2.1
Scope of SIMIT SCE
7
2.2
Limitations of SIMIT SCE
7
INSTALLING THE SOFTWARE
8
3.1
Prerequisites
8
3.2
Installing SIMIT SCE
8
3.3
Uninstalling SIMIT SCE
8
3.4
Installing SIMIT4Students
9
3.5
Uninstalling SIMIT4Students
9
INTRODUCTION TO SIMIT SCE
10
4.1 Gateways
4.1.1
Connecting to a real control unit via PRODAVE
4.1.2
Connecting to S7-PLCSIM
11
11
12
4.2
The user interface of SIMIT SCE
13
4.3
Simulation projects in SIMIT SCE
14
4.4
Building a simulation
14
4.5
Running the simulation
16
EXAMPLE OF USE “PRESS”
17
5.1
Automation assignment
17
5.2
Press control
17
5.3 Simulation
5.3.1
Creating a simulation project
5.3.2
Connecting to PLCSIM
5.3.3
Building an operator panel
5.3.4
Simulating the movable safety guard
5.3.5
Background image and labeling
5.3.6
Graphics and Animation
5.3.7
Simulating the plunger
6
PROJECT MANAGEMENT
Copyright © Siemens AG, 2009
Industry Sector
18
19
20
23
26
31
33
37
40
SIMIT-SCE – User Manual
Page I
s
6.1
Archived Projects
40
6.2
SIMIT4Students
41
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page II
s
List of figures
Figure 1:
Setup with real control unit (left) and simulated control unit (right)
11
Figure 2:
Access mode of the PRODAVE gateway
12
Figure 3:
User interface of SIMIT SCE
13
Figure 4:
Elements of a SIMIT SCE project
14
Figure 5:
Diagram with components and peripheral connectors
15
Figure 6:
Diagram with some controls
16
Figure 7:
STEP7 program of a press control
18
Figure 8:
Project dialog in SIMIT SCE
19
Figure 9:
Adding a new gateway
20
Figure 10:
Signal communication between SIMIT SCE and PLCSIM
21
Figure 11:
Exporting a symbol table
22
Figure 12:
Importing a symbol table
22
Figure 13:
Creating a new diagram
23
Figure 14:
Placing a control
24
Figure 15:
Signal connection of a control
24
Figure 16:
Signals tools window
25
Figure 17:
Resizing a binary indicator
25
Figure 18:
Operator panel
26
Figure 19:
New diagram named “Function”
27
Figure 20:
“Ramp“ component
27
Figure 21:
“Ramp”, “BConnector” and “NOTc”
28
Figure 22:
“Ramp” with inverted input
28
Figure 23:
Connected Ramp component
28
Figure 24:
Name of a component
29
Figure 25:
Complete connection
29
Figure 26:
Tab control for changing the working area
30
Figure 27:
Switch with image with its signal connection
30
Figure 28:
Defining images to be displayed
31
Figure 29:
Feedback signaling closed guard
31
Figure 30:
Background image
32
Figure 31:
Labeled operating panel
33
Figure 32:
Introducing the Safety Guard
33
Figure 33:
Selecting a fill color
34
Figure 34:
Safety guard
34
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page III
s
Figure 35:
Adjusting the line width
34
Figure 36:
Safety guard as grouped graphic
35
Figure 37:
Selecting an animation type
36
Figure 38:
Defining a movement
36
Figure 39:
Signal to control an animation
37
Figure 40:
Function enhanced with the plunger
37
Figure 41:
Plunger
38
Figure 42:
Animating the plunger
38
Figure 43:
Finished example of use “Press”
39
Figure 44:
Retrieving a SIMIT SCE project
40
Figure 45:
Passing a SIMIT SCE project in form of an executable simulation
41
Figure 46:
Creating an executable simulation
42
Figure 47:
Starting the executable simulation with password
43
Figure 48:
Executable simulation on a students computer
43
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page IV
s
List of tables
Tabelle 1:
The press controls symbol table
Copyright © Siemens AG, 2009
Industry Sector
17
SIMIT-SCE – User Manual
Page V
s
Preface
1 PREFACE
SIMIT SCE is a Siemens solution specifically designed for training of automation engineers
and used for the virtual commissioning of SIMATIC applications software. Thanks to the
functional simulation of technical equipment or plants and its visualization, your students can
test a PLC program under realistic conditions.
Students can understand the assignment faster and can focus on creating their PLC
program. They can test it on the simulation at any time and, thanks to the high-quality
display, are thus more motivated to find the correct automation solution.
The SIMIT SCE Campus License allows you to store a simulation project in form of an
“executable simulation”. Your students can launch such a simulation and use it for testing,
they cannot modify it however. As a precondition, the students computer needs to have the
SIMIT4Students software installed.
This manual shows you how to use existing simulations in class with SIMIT SCE. Beyond
that you learn how to use SIMIT SCE to create and use your own simulations.
Chapter 2 comments on special features of SIMIT SCE and depicts differences and
limitations compared to the SIMIT Software as it is used in automation solutions in an
industrial environment.
Chapter 3 guides you through the installation of SIMIT SCE.
Chapter 4 describes usage and general design of SIMIT SCE.
Chapter 5 provides a step-by-step instruction of how to build a simulation, using a simple
press as an example.
Chapter 6 finally shows how to handle SIMIT SCE projects, with special emphasis on how to
pass a simulation to your students.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 6
s
Special Features of SIMIT SCE
2 SPECIAL FEATURES OF SIMIT SCE
Keeping close contact between industry and education has a long tradition at Siemens.
“Siemens Automation Cooperates with Education”, short SCE, is the made-to-measure
solution for institutions of education around the world. In this environment SIMIT SCE
provides a reasonably priced way to use modern simulation techniques in training
automation engineers.
2.1 Scope of SIMIT SCE
SIMIT SCE contains modules as follows:
•
SIMIT BASIC is the basic system that comprises project management, graphical user
interface and a basic library of components and controls.
•
SIMIT DGE is the SIMIT graphics editor used for designing user defined diagrams.
•
SIMIT MCE is the macro editor used to build macro components from standard
components contained in the basic library.
•
SIMIT PLCSIM is a gateway that builds up a connection for signal exchange between
SIMIT SCE and an emulated Siemens control unit running in PLCSIM.1
•
SIMIT PRODAVE is a gateway that builds up a connection for signal exchange
between SIMIT SCE and a SIMATIC control unit of type S7-300 or S7-400.
•
You can create an “executable simulation”, which can be passed to students of your
own institution of education.
SIMIT SCE is a fixed configuration that cannot be enhanced by additional modules.
2.2 Limitations of SIMIT SCE
SIMIT SCE holds some restrictions:
•
•
The above mentioned PLCSIM and PRODAVE are the only gateways available.
Address scope is restricted to predefined ranges as follows:
o
32 binary inputs I0.0-I3.7,
o
8 analog inputs IW64-IW78,
o
32 binary outputs Q0.0-Q3.7 and
o
8 analog outputs QW64-QW78.
The number of components and controls that can be used in a simulation is limited to
250.
1 PLCSIM is not part of SIMIT SCE, but part of SIMATIC-Software
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 7
s
Installing the Software
3 INSTALLING THE SOFTWARE
Before using it, SIMIT SCE Software needs to be installed on your computer.
Please note that you need to be logged on as administrator in order to install the software!
3.1 Prerequisites
Your computer must meet some minimum requirements as follows:
Hardware
•
•
Standard PC
CD drive
•
One USB slot available, please do not use USB extensions or hubs.
Software
SIMIT SCE supports Windows Operating Systems as follows:
•
XP Professional SP3
•
Vista Professional
•
Vista Ultimate
3.2 Installing SIMIT SCE
For installation please launch Setup.exe on your SIMIT SCE installation CD in the SIMITfolder. If your computer does not have the required .NET framework installed, setup will first
install .NET framework version 3.5 SP1. There is no internet access required to install SIMIT
SCE.
After this, installation continues. If the installation does not proceed automatically, please
start Setup.exe again.
During installation of SIMIT SCE please follow instructions as provided by the installation
program.
3.3 Uninstalling SIMIT SCE
You can of course uninstall SIMIT SCE at any time. Just launch Programs | SIMIT 7 |
Uninstall from your Windows startup menu or uninstall SIMIT SCE in System Control via
Settings | System Control | Software.
During uninstallation all those files and registry entries will be removed which were created
during installation. Alternatively you can also delete your entire workspace. In this case
please make sure that your workspace does not contain any files you still might need!
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 8
s
Installing the Software
3.4 Installing SIMIT4Students
Before a student can launch an executable simulation, he or she needs to have the SIMIT
SCE Runtime Environment installed. You find the required Setup.exe on your SIMIT SCE
installation CD in the SIMIT4Students-folder. You are entitled to pass this file to your
students.
Please note that during runtime environment installation your license number will be asked,
hence you need to pass this 7 digit number to your students. You find the license number on
your certificate of license as well as on your dongle.
Your students can use executable simulations only if these simulations were created using
the SIMIT SCE Software with the corresponding license number.
3.5 Uninstalling SIMIT4Students
You can of course also uninstall the SIMIT SCE Runtime Environment at any time. Just
launch Programs | SIMIT 7 | Uninstall from your Windows startup menu or uninstall the SIMIT
SCE Runtime Environment in System Control via Settings | System Control | Software.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 9
s
Introduction to SIMIT SCE
4 INTRODUCTION TO SIMIT SCE
Studens who are to learn how to handle automation devices usually have a common
problem: the finest PLC program is without effect if you lack the plant to be controlled.
SIMIT SCE bridges this gap by making the plant available to your students in form of a
computer simulation.
When using SIMIT SCE the following issue is a matter of particular interest:
Linking on signal level
Define the gateway SIMIT SCE should use to communicate with your automation.
You can now set and read signals with SIMIT SCE without any further effort!
If you prefer an individually designed operating panel, proceed with the next step:
Operating
You can use diagrams with various controls placed upon them. You may automatically
create such a diagram using data that is available already, such as the data in your
gateway. You may also individually design your diagrams by manually creating them.
By simulating your plants behavior SIMIT SCE provides maximum benefit:
Simulation
In order to simulate your plant SIMIT SCE provides libraries which contain components
covering a large field of applications: ranging from simple arithmetic and logical
functions up to complex drive simulations or even process simulations.
You do not need any specialist knowledge to build up a simulation. The only thing you do is
to place and connect components as provided in the SIMIT SCE library on the graphic user
interface and parametrize them appropriately.
The remaining comments in this chapter provide you with a basic understanding of how to
use SIMIT SCE.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 10
s
Introduction to SIMIT SCE
4.1 Gateways
You may use SIMIT SCE in conjunction with a real control unit (SIMATIC S7-300 or S7-400)
as well as a simulated control unit (S7-PLCSIM). In the first case the PRODAVE gateway is
used via an MPI or Ethernet cable, in the latter case a pure software gateway is used (see
Figure 1).
Figure 1:
Setup with real control unit (left) and simulated control unit (right)
4.1.1 Connecting to a real control unit via PRODAVE
When connecting a real control unit to SIMIT SCE you have two options:
•
MPI
In this case you need either an MPI interface card in your computer or an MPI
adapter for use with a USB or serial port.
•
Ethernet
When using a control unit with ethernet access you may also use this cable to
connect to SIMIT SCE.
You choose the access mode in the properties dialog of your PRODAVE gateway as shown
in Figure 2.
The corresponding interface must be selected as “PC/PG-Interface” within the Simatic
manager.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 11
s
Figure 2:
Introduction to SIMIT SCE
Access mode of the PRODAVE gateway
4.1.2 Connecting to S7-PLCSIM
Instead of a real S7 control unit you can also use the control unit simulation PLCSIM. In this
case you do not load your STEP7 application program into the real SIMATIC control unit but
into PLCSIM.
You can launch PLCSIM directly from SIMATIC-Manager (
).
SIMIT SCE can be used with PLCSIM version 5.2 through 5.4 SP3. Any multi CPU
capabilities of PLCSIM as introduced with version 5.4 SP3 are not supported however.
Please note that the software S7-PLCSIM itself is not part of SIMIT SCE.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 12
s
Introduction to SIMIT SCE
4.2 The user interface of SIMIT SCE
The user interface of SIMIT SCE is divided into some major elements as shown in Figure 3:
•
•
The Menus along with the Toolbar provide easy access to the functions available in
SIMIT SCE. Additional functionality is available via context menus.
The Project view shows the currently used project in form of a tree view.
•
Diagrams and gateways are shown and edited in the Work area.
•
Library components, controls, graphic tools and the signals available in your project
can be found in the Tool window.
•
A currently selected object shows its properties in the Property view.
•
Use the Tab control at the bottom to switch between open diagrams and gateways.
Menus
Toolbar
Project view
Tool window
Gateway and diagram
(inside the work area)
Property view
Tab control and
status line
Figure 3:
Copyright © Siemens AG, 2009
Industry Sector
User interface of SIMIT SCE
SIMIT-SCE – User Manual
Page 13
s
Introduction to SIMIT SCE
4.3 Simulation projects in SIMIT SCE
Simulation projects are handled in the project view. A SIMIT SCE project contains different
elements as shown in Figure 4.
•
Gateways (
) establish a link between SIMIT SCE and a control unit. You can
create a new gateway by double clicking the tree entry “New Gateway” (
•
).
Diagrams (
) are placed in the “Diagrams” folder and contain the simulation built
with library components. You can create a new diagram by double clicking the tree
entry “New Diagram” (
).
•
Snapshots of your simulation are placed in the Snapshots folder.
•
You can Find & Replace signals, components and connectors in your project.
•
The Consistency Check will reveal formal errors in your project.
Project designator
Gateway
Diagram
Folder
Folder for
snapshots
Additional functions
Figure 4:
Elements of a SIMIT SCE project
4.4 Building a simulation
In SIMIT SCE you build a simulation using predefined components on diagrams (see Figure
5). You can add a new diagram to your SIMIT SCE project using the tree entry “New
Diagram”. When double clicked in the project view, an existing diagram is opened in the work
area.
Components offering various arithmetic and logical functions can be found in the standard
library. Based on these components a simulation is built on a diagram and then is connected
to the control unit using peripheral connectors (see Figure 5). Just drag and drop
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 14
s
Introduction to SIMIT SCE
components from the library onto the diagram, connect the connection points and specify the
components parameters.
In order to establish a connection between two connection points (i.e. input and output) place
the mouse above a connection point you want to use and click left. Note that the mouse
cursor changes when placed above a connection point and do not keep the left mouse button
pressed. Now move the mouse to the other connection point you want to use and click left
again. A connection is now established and you see a connection line. Alternatively you can
also drag and drop one connection point to another.
You can set a components parameters by using the blue input fields. To enter a value in an
input field double click the field and commit your input by pressing RETURN. Alternatively
you may use the components property view. You can open a components property view by
double clicking the component.
Component
Parameter
Peripheral connector
Figure 5:
Diagram with components and peripheral connectors
The control units input and output signals are managed in gateways. These signals are
displayed on the diagram as peripheral connectors: Output signals are represented as green
peripheral connectors, input signals as red peripheral connectors. You can place peripheral
connectors on a diagram via drag and drop from the gateway. For this purpose open the
gateway and split your work area using the menu “Window | Tile Horizontally” so that both
gateway and diagram are visible. Then drag the signal of interest onto the diagram by
gripping it within the gateways left border and keeping the SHIFT-key pressed. Finally
connect its connection point with a components connection point.
The so-called controls are divided into operating and display controls. In order to set values
when the simulation is running operating controls are made available, display controls are
used to show values. Controls can be placed on separate diagrams clearly laid out and
according to your requirements. Figure 6 shows an example of a diagram with operating
controls and binary display controls.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 15
s
Figure 6:
Introduction to SIMIT SCE
Diagram with some controls
4.5 Running the simulation
You can run the simulation using the toolbar or the project view (
) as well as the menu
“Simulation | Start”. A change in the SIMIT SCE color scheme from blue to orange indicates
that the simulation is running.
All changes to the simulation, be that on diagrams or in gateways, take effect automatically
when the simulation is run next time.
While the simulation is running you can open and close diagrams and select a component by
clicking it with the right mouse button. Opening the property view enables you to observe any
change of a selected components input and output values in a running simulation.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 16
s
Example of Use “Press”
5 EXAMPLE OF USE “PRESS”
The example of use “Press” shows how a simulation is built so that you can perform
simulation based testing. The PLC program is to be executed in PLCSIM and controls the
press that is simulated in SIMIT SCE.
You find the SIMATIC program as well as the complete SIMIT project on your installation CD
in the “Samples”-folder. If you wish to gain experience with a ready-to-use simulation first,
please continue with chapter 6.1.
5.1 Automation assignment
In this simplified example the press contains two movable parts only: a safety guard and a
plunger. The safety guard is moved directly with a switch on the operator panel. The control
unit receives a binary feedback only which indicates whether or not the safety guard is down.
Having lowered the safety guard the operator triggers the control unit with a pushbutton. The
control unit then checks if the grid is down. If this is the case the control unit will lower the
plunger until the limit switch is activated. Then the control unit will move the plunger back to
its initial position and signal the workpiece to be removed. Opening the safety guard will
delete this message.
The operator panel also contains an emergency stop switch. This switch being pressed the
control unit is to move up the plunger at once and signal the machine to be not operational
any more.
Summarized, signal exchange between control unit and (simulated) plant looks like this:
Signal name
Address
Type
Remark
F0
S1
B1
B2
B3
M1
P1
P2
P3
I
I
I
I
I
Q
Q
Q
Q
BOOL
BOOL
BOOL
BOOL
BOOL
BOOL
BOOL
BOOL
BOOL
Switch: Emergency Stopp
Pushbutton: Press
Feedback safety guard closed
Feedback Press up
Feedback Press down
Command lower plunger
Display machine ready
Display remove workpiece
Display safety guard open
Tabelle 1:
0.0
0.1
0.2
0.3
0.4
0.0
0.1
0.2
0.3
The press controls symbol table
5.2 Press control
Programming the press control in STEP7 is not subject of this manual. To make the
interaction between control device and simulation in SIMIT SCE more vivid, a simple
implementation is suggested here (see Figure 7). You find this control program in form of an
archived STEP7 program Press.zip on your SIMIT SCE-CD in the Samples folder.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 17
s
Figure 7:
Example of Use “Press”
STEP7 program of a press control
In order to use this control program along with the SIMIT SCE sample project, please
proceed like this:
•
Retrieve S7-project Press.zip with SIMATIC-Manager,
•
Launch PLCSIM and load the S7-Programm into PLCSIM and
•
Turn PLCSIM into state RUN or RUN-P.
PLCSIM now executes the control program.
A connection used for signal exchange between PLCSIM and SIMIT SCE will be established
automatically upon starting the simulation. The PLCSIM gateway in SIMIT SCE defines
which I/O signals are coupled between PLCSIM and SIMIT SCE.
5.3 Simulation
We now want to build a simulation with SIMIT SCE to test this press control program. The
simulation should perform several tasks:
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 18
s
Example of Use “Press”
•
An operator panel with switches, pushbuttons and display controls should be
available that enables operating of the safety guard and allows signal exchange with
the control unit.
•
The operator should be able to manually raise and lower the safety guard. A binary
input tells the control unit that the guard is closed.
•
The control unit uses an output signal to lower the plunger, which takes about one
second. Initial and final position are registered and communicated to the control unit.
•
All movement is to be visualized.
In the next steps we will see how to meet all these requirements using SIMIT SCE.
5.3.1 Creating a simulation project
After startup SIMIT SCE shows a project dialog. You can create new projects or open
existing ones here. Please select “New Project” and provide a folder in which to place your
data. As project name you may use “Press”.
If SIMIT SCE is running already, you can open this dialog using the menu “Project | New
Project”.
Figure 8:
Copyright © Siemens AG, 2009
Industry Sector
Project dialog in SIMIT SCE
SIMIT-SCE – User Manual
Page 19
s
Example of Use “Press”
Finally you click “Create”.
5.3.2 Connecting to PLCSIM
In this example of use the STEP7 program should not be loaded into a real control unit but
into PLCSIM instead. In case PLCSIM is not running already, please proceed as described in
chapter 5.2 to start PLCSIM, load the S7 project and turn PLCSIM into mode “RUN-P”.
By adding a gateway in SIMIT SCE you also define which signals are to be communicated
with the real control unit or with PLCSIM in this case. Please add a new gateway to your
project be double clicking the “New Gateway” entry in the project view. Select “PLCSIM” and
confirm by clicking “OK”.
Figure 9:
Adding a new gateway
You may change the gateways name “PLCSIM”. For your project to match this example
please confirm the default value by pressing “RETURN”.
In the work area you now see all available binary and analog signals which are
communicated between SIMIT SCE and PLCSIM. Please note that both range and
addresses of these signals are immutable in SIMIT SCE.
When starting the simulation you can immediately observe signal exchange. Just click the
-symbol in the tool bar. Alternatively you may double click the “Start” entry in the project
view or select the menu “Simulation | Start”. A change in the color schema from blue to
organge indicates that the simulation is now running. Also the project view switches to
simulation mode.
You may now set the output Q0.7 in PLCSIM and observe the reaction in SIMIT SCE.
Conversely you may set a control units input in SIMIT, e.g. I0.7 and observe the reaction in
PLCSIM.
Please note that the STEP7 program will set the outputs Q0.1 and Q0.3 to “1”, given that you
already have loaded the SIMATIC project “Press” into PLCSIM. In this case you cannot set
outputs Q0.0 through Q0.3 manually!
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 20
s
Figure 10:
Example of Use “Press”
Signal communication between SIMIT SCE and PLCSIM
Please end the simulation before proceeding. Just click the
Alternatively you may select the menu “Simulation | Exit”.
-symbol in the tool bar.
I/O signals can also be addressed symbolically in SIMIT SCE. Just enter appropriate names
in the gateways “Symbol Name” column or import a symbol table already created by
SIMATIC manager.
To do so you just need to export a symbol table in SIMATIC managers symbol editor.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 21
s
Figure 11:
Example of Use “Press”
Exporting a symbol table
Afterwards you can import the symbol table into the gateway editor in SIMIT SCE.
Figure 12:
Importing a symbol table
SIMIT SCE supports both ASC and SEQ files. In the “Samples” folder on your SIMIT SCE
CD you find an applicable symbol table.
By importing a symbol table you have modified the gateways configuration which is
visualized by an asterisk in the window title. Click the disk symbol
to save changes.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 22
s
Example of Use “Press”
5.3.3 Building an operator panel
You can observe and operate all I/O signals in the gateway editor as described above. You
may still want to access specific signals in form of an individually designed operator panel,
however. Please open the “Diagrams” folder and double click the “New Diagram” entry. Then
change the diagrams name from its default into “Panel”.
Figure 13:
Creating a new diagram
Your work area now shows an empty diagram. On the right hand side you see the tool
window containing the tabs “Components”, “Controls”, “Graphics”, “Projects” and “Signals”.
To build an operator panel we first need the “Controls” tab. Just drag and drop three “Binary
Indicators” from the tab onto your diagram.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 23
s
Figure 14:
Example of Use “Press”
Placing a control
Just like components, controls can be connected using signal lines. This is indicated by the
green triangle on the binary indicators left hand side. For an operator panel this is not useful
however. Please select the control and select the “Connector” section in its property view.
Click the
-symbol to make the connection point invisible.
Figure 15:
Copyright © Siemens AG, 2009
Industry Sector
Signal connection of a control
SIMIT-SCE – User Manual
Page 24
s
Example of Use “Press”
You can now enter the name of the signal to be visualized by this binary indicator. Please
enter the gateways name “PLCSIM” in the left hand field and the signals name “P1” in the
right hand field. If there were no symbol table imported, the signal name would have to be
the absolute address “Q0.1” instead of “P1”.
Alternatively you may open the “Signals” tab and drag and drop an I/O signal into the Signal
field.
Figure 16:
Signals tools window
There are several ways to filter signals in your simulation project. In the above image only
binary output signals are visible (Signal type: Output, Data type: BOOL).
Please note that the signal list is updated only when a diagram or gateway is saved!
Please complete all three binary indicators by entering signals “P1”, “P2” and “P3”.
If you wish you may also change the binary indicators shape. The property view will show a
choice named “Shape” in the “View” section which you may change to “Round”. You may
also change the binary indicators size directly on the diagram. Just select the control and
drag it to its favored size.
Figure 17:
Copyright © Siemens AG, 2009
Industry Sector
Resizing a binary indicator
SIMIT-SCE – User Manual
Page 25
s
Example of Use “Press”
Now add a “Switch” control to your diagram and parametrize it with Signal “F0”. Also place a
“Pushbutton” control with Signal “S1”.
If you wish to drag and drop signals from the “Signals” tab please make sure that filters are
set appropriately! You may reset all filters via “Reset Filter”.
When starting the simulation again, you can now access these signals directly on your
diagram.
Figure 18:
Operator panel
Please note again that the PLC program reacts to input “F0” and resets output “P1”.
Before proceeding please close the simulation again by clicking the
menu “Simulation | Exit”.
-symbol or using the
5.3.4 Simulating the movable safety guard
Our next step is to simulate the movable safety guard. This task consists of two assignments:
On the one hand we have the basic function that generates a delayed feedback “grid closed”
after activating a switch. On the other hand we need an appropriate visualization to show this
process.
For the pure function please add a new diagram and name it “Function”.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 26
s
Figure 19:
Example of Use “Press”
New diagram named “Function”
The safety guards movement is to be modeled using a ramp function that yields the grids
vertical position. You find an appropriate “Ramp” component in the tools windows
“Component” tab under “STANDARD | AnalogExtended”. Please drag and drop this
component onto your diagram.
Figure 20:
“Ramp“ component
This component computes a ramped value that runs from its lower limit “LL” to its upper limit
“UL” within an adjustable time “T”, provided that the input “UP (+)” is set to “TRUE”. If the
input “DOWN (-)” is set to “TRUE”, the values behave accordingly.
The components outputs indicate whether or not one of the limits is reached.
Since the safety guard is to be operated with one single switch, this switches signal needs to
have its original value as well as the inverted value processed. One way to realize this is to
use a “BConnector” component from the “CONNECTORS” library and a “NOTc” negation
from “STANDARD | BinaryBasic”:
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 27
s
Figure 21:
Example of Use “Press”
“Ramp”, “BConnector” and “NOTc”
Now place the NOTc in such a way that its red output triangle overlaps with the ramps green
input triangle. The two connection points are now connected. In order to move the NOTc
please take care to touch the component itself, not its connection points since you will not be
able to move it otherwise. You may want to zoom the diagrams display using the
from the tool bar.
Figure 22:
-symbol
“Ramp” with inverted input
We are still lacking two connections which you now can establish using signal lines. Just
click the BConnectors output and then the input to be connected or drag from one connection
point to the other:
Figure 23:
Connected Ramp component
Since the ramp is to be controlled via the BConnector, the latter should be assigned a
meaningful name, e.g. “Guard”. Just select the BConnector and overwrite its current name
“BConnector#1” with “Guard” in the components property views “General” section.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 28
s
Figure 24:
Example of Use “Press”
Name of a component
Now we want to inform the control unit about the safety guards state using signal “B1”. The
easiest way to establish this connection is using the tool windows “Signals” tab again. Just
drag signal “B1” onto the diagram without dropping, i.e. without releasing the mouse button!
You see that SIMIT SCE first offers you to place controls handling this signal. In this case we
need a peripheral connector. You can create a peripheral connector by pressing the SHIFTkey and then releasing the mouse button. Finally please connect the peripheral connector to
the ramp.
Figure 25:
Copyright © Siemens AG, 2009
Industry Sector
Complete connection
SIMIT-SCE – User Manual
Page 29
s
Example of Use “Press”
In the next step we set the ramps running time to two seconds. We do this directly on the
diagram by double clicking the blue input field of input “T” and overwriting with “2”.
Please add a switch to handle the safety guard on the operator panel. In case you still have
the diagram “Panel” open, you can get it back into your working area using tabs on the
bottom of the screen.
Figure 26:
Tab control for changing the working area
We are going to use a switch with freely designed images here. Please drag a “Switch with
Image” control from the tool window “Controls”. Again we want the signal connection to be
invisible and be linked to the input “IN” of our BConnector named “Guard”.
Figure 27:
Switch with image with its signal connection
Please select the images to be displayed in the “View” section (see Figure 28). The images
we use here as an example can be found on the SIMIT SCE installation CD in the “Samples”
folder.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 30
s
Figure 28:
Example of Use “Press”
Defining images to be displayed
Please take care to check the “Adapt to Image Size” box so that images are displayed in
their original size!
When starting the simulation you now see the feedback arriving in the control unit two
seconds after activating the switch with image.
Figure 29:
Feedback signaling closed guard
Before proceeding please close the simulation again!
5.3.5 Background image and labeling
You may want to make your operating panel more vivid and use a background image. To do
this, please open the property view and click any non-occupied area on the diagram to have
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 31
s
Example of Use “Press”
the diagrams properties shown. Then select the background image from the “Samples” folder
on your SIMIT SCE installation CD. Finally adapt the diagrams size to the images dimension,
e.g. you use 700 x 500 pixel.
Figure 30:
Background image
You may have noticed that the controls were already placed accordingly in the above image.
The only thing we are still lacking is some meaningful labeling. If you are not sure any more
which signal is displayed on which binary indicator, just select the control and check its
property view for the “Signal” entry.
Please open the “Graphics” tool window now and click the
-symbol. You can now
draw a selection frame on the diagram and input some text therein. Like this you can label
your operation panel as shown in Figure 31.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 32
s
Figure 31:
Example of Use “Press”
Labeled operating panel
Please take care to draw a large enough frame for each text to fit entirely into a single line
and not to overlay any controls!
5.3.6 Graphics and Animation
The next step is to visualize the safety guards movement. First we need to create an
appropriate graphic. Please select the tool window “Graphic” and choose the
symbol. On the diagram you draw a rectangle of about this size:
Figure 32:
-
Introducing the Safety Guard
For the guard to be “transparent” select the rectangle and select “No Color” as fill color.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 33
s
Example of Use “Press”
Figure 33:
Selecting a fill color
Now activate the grid using the
easier working.
-symbol and zoom your display with the
-symbol for
Please note that the background image is not visible as long as the grid is active!
Use the
-symbol in the tool window to indicate a guard with some diagonal lines.
Figure 34:
Safety guard
Select the outer rectangle again and assign it a line width of twp points (2,0 Pt).
Figure 35:
Copyright © Siemens AG, 2009
Industry Sector
Adjusting the line width
SIMIT-SCE – User Manual
Page 34
s
Example of Use “Press”
Since the safety guard is to be moved as a single unit, please group the rectangle and the
diagonal lines. To do this, just draw a selection frame around all graphic elements and click
the
-symbol in the tool bar.
After deactivating the grid your safety guard should look like this:
Figure 36:
Safety guard as grouped graphic
Finally this graphic is to be animated, i.e. moved depending on the ramps value. Please
select the safety guard and open the property view. Double click the topmost entry “New
Animation” and select “Movement”.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 35
s
Figure 37:
Example of Use “Press”
Selecting an animation type
In the mode you have just entered you can define direction and distance of the movement.
Press SHIFT to only allow horizontal and vertical movements and drag the safety guard
down a little.
Figure 38:
Copyright © Siemens AG, 2009
Industry Sector
Defining a movement
SIMIT-SCE – User Manual
Page 36
s
Example of Use “Press”
Now enter the output “Y” of the ramp component “Ramp#1” as the signal to control this
movement or drag and drop this signal from the tools window “Signals”.
Figure 39:
Signal to control an animation
To leave the animation mode click any non-occupied area on the diagram.
When starting the simulation now you can move the safety guard up and down using the
switch
!
Before proceeding please close the simulation again!
5.3.7 Simulating the plunger
We simulate the plunger in a similar manner. On the functional diagram we need an
additional ramp that is operated by the control unit in this case.
Figure 40:
Function enhanced with the plunger
Please note that you can easily copy components by dragging an existing component with
the Control-Key pressed.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 37
s
Example of Use “Press”
As a visualization of the plunger just draw some rectangles and group them.
Figure 41:
Plunger
The output signal of the second ramp is used to animate the plunger.
Figure 42:
Animating the plunger
Being the last element that was drawn, the plunger overlays the safety guard. To fix this,
please select the plunger and bring it to back using the
-symbol.
We have now completed with this example of use. You can now test whether or not your
control unit behaves correctly. You may check if the press is operable when the safety guard
is open!
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 38
s
Example of Use “Press”
Plunger
Safety Guard
Figure 43:
Copyright © Siemens AG, 2009
Industry Sector
Finished example of use “Press”
SIMIT-SCE – User Manual
Page 39
s
Project Management
6 PROJECT MANAGEMENT
6.1 Archived Projects
SIMIT SCE projects can be merged into a single file and thus be archived or transferred to
another computer.
You can save an open project using the menu “Project | Archive” in form of a SIMIT SCE
archive with the suffix “.simarc”.
In order to retrieve an archived SIMIT SCE project use the menu „Project | Retrieve“. You
can freely choose the target folder.
Figure 44:
Copyright © Siemens AG, 2009
Industry Sector
Retrieving a SIMIT SCE project
SIMIT-SCE – User Manual
Page 40
s
Project Management
6.2 SIMIT4Students
SIMIT SCE provides the special feature to build an “executable simulation” that can be
passed to students.
In such an executable simulation you have exactly one diagram from the underlying SIMIT
SCE project available. Hence it is useful to organize your project in such a way that all
information and controls are placed on one single diagram if they should be available to your
student.
In the project view open the diagrams context menu and select “SIMIT4Students”. The
resulting executable simulation has the suffix “.simit4S”.
Figure 45:
Passing a SIMIT SCE project in form of an executable simulation
Please note that before using this executable simulation, your student needs to install the
SIMIT SCE Runtime Environment (see chapter 3.4).
Your students can only use executable simulations that were created with a SIMIT SCE
installation with your license number.
When using SIMIT SCE in class the students computers may be connected via Ethernet to
the computer SIMIT SCE is installed on. In this case the student can launch the executable
simulation by double clicking it, provided that SIMIT SCE is currently running. In this case an
automatic check is performed whether or not a SIMIT SCE application with the
corresponding dongle is available.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 41
s
Project Management
If there is no network connection, a 12 digit password needs to be entered when launching
an executable simulation. This password is provided when creating the executable simulation
so please take care to note it down.
Figure 46:
Creating an executable simulation
Please note that these executable simulations are operable within the given period of six
months only. You can create a new executable simulation for your students at any time later
however and as often as you wish.
Only if the students PC is not able to connect to a computer that runs SIMIT SCE, the
simulation password is required (figure 47).
The executable simulation will be opened in a window that contains the before-selected
diagram only. The simulation will start automatically, just close the window to end the
simulation.
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 42
s
Project Management
Figure 47:
Starting the executable simulation with password
Figure 48:
Executable simulation on a students computer
Copyright © Siemens AG, 2009
Industry Sector
SIMIT-SCE – User Manual
Page 43
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement