TUTORIAL - Bio-Rad
PART V
TUTORIAL
16
TUTORIAL 1:
LOOKING AT GELS
Introduction
This section describes a simple session with the Melanie II software using the
gels provided on the distribution tape, in the directory Gels. You may read this
section and at the same time perform the described steps.The > sign indicates
the command prompt on the Sun workstation.
This tutorial explains how to open gels, then how to manipulate them in order to
improve their visualization. Tutorial 2: analyzing gels on page 17-1 presents
more advanced features of the Melanie II software.
Manipulating two gels.
PC / Macintosh
In Melanie II for PC or Macintosh:
• Go to the directory1 Gels, in which the sample gels are located.
• Double-click on the MelView icon.
Unix
In Melanie II for Unix:
• Go to directory Gels, in which the sample gels are located. (for example:
/usr/local/MelanieII/Gels):
1. On the Macintosh, a directory is called a folder.
The Melanie II User Manual
16-1
TUTORIAL 1: LOOKING AT GELS
16
> cd /usr/local/MelanieII/Gels
• Type the following command to run the MelView program:
> MelView &
• The & sign indicates that the MelView program has to run in the background.
Figure 16-1 shows the screen that appears when running MelView.
Figure 16-1. The MelView main screen
• Click on the Melanie II logo to get rid of it.
Opening two 2-DE images
PC
16-2
In Melanie II for PC:
The Melanie II User Manual
TUTORIAL 1: LOOKING AT GELS
• Click on the File menu and select the Open option. The Open window will be
displayed (Fig. 16-2). Hold down the Control key and click on gels 94-0002 and
Figure 16-2. The Open window allows the selection of the gels that will be
opened and loaded into MelView, PC release
94-0005 in the Files column. This selects the two gels. Click on the OK button.
The gels will be opened.
Unix
In Melanie II for Unix:
Click on the File menu and select the Open option. The Open window will be
displayed (Fig. 16-3) Hold down the Control key and click on gels 94-0002 and
Figure 16-3. The Open window allows the selection of the gels that will be
opened and loaded into MelView, Unix release
The Melanie II User Manual
16-3
TUTORIAL 1: LOOKING AT GELS
16
94-0005 in the Files column. This selects the two gels. Click on the OK button.
The gels will be opened.
Macintosh
In Melanie II for the Macintosh:
• Click on the File menu and select the Open option. The Open window will be
displayed (Fig. 16-4). Click on gels 94-0002 and 94-0005, and each time click
Figure 16-4. The Open window allows the selection of the gels that will be
opened and loaded into MelView, Macintosh release
on the Add button. This selects the two gels and adds them to the Open gel
box. Click on the Done button. The gels will be opened.
16-4
The Melanie II User Manual
TUTORIAL 1: LOOKING AT GELS
• In the Select menu, choose the Gels → Visible Gels option. This will select all
gels and draw a green line around each of them showing that they have been
selected (Fig. 16-5). In MelView the green color always indicates selected
objects.
Figure 16-5. The two opened gels.
Adjusting colors
• Select the Hand tool (the second tool from the top on the left hand side). Put
the cursor in one of the gels. Hold down the right mouse button1 and move the
gels until you see a region with many spots.
1. On the Macintosh, hold down the Command key(
) and the mouse button.
The Melanie II User Manual
16-5
16
TUTORIAL 1: LOOKING AT GELS
• Now select the Region tool (the third tool from the top in the tool bar) and draw
a small rectangle in one of the gels, using the mouse button. In the Select
menu, choose Select Mode → Adjust Colors. Select a logarithmic color function and adjust its parameter to the value 4. The change will directly be
reflected in the selected region (Fig. 16-6).
Figure 16-6. The Adjust Colors option. The modifications are directly
reflected in the selected region.
• Click on the OK button. The colors will be adjusted in the two selected gels.
16-6
The Melanie II User Manual
TUTORIAL 1: LOOKING AT GELS
Zooming
• With the Select tool active (first tool in the tool bar), select only one gel. Then, in
the Show menu, choose Gels → Selected Gels. Only the selected gel stays in
the MelView window. The other gel is hidden. In menu Select, choose Select
Zoom → 1/2. The gel is zoomed out by a factor of 2 and a larger part of the gel
can be seen (Fig. 16-7).
Figure 16-7. A gel after it has been zoomed out.
Stacking gels
• Choose Show Gels → All Gels, and Select Gels → Visible Gels, then Stack →
Stack Selected Gels. The two gels are now displayed on top of each other. To
switch from one gel to the other, choose Stack → Front To Back, or just Control1-F. By pressing Control1-F quickly several times, the differences between
the two gels can be observed visually.
1. On the Macintosh, use
instead.
The Melanie II User Manual
16-7
TUTORIAL 1: LOOKING AT GELS
16
Aligning gels
We are now going to align the two gels in order to correct their relative distortion. The first step consists in setting a few landmarks in the two gels. Each
landmark must correspond to the same feature in both gels. The landmarks
must be well distributed over the gel. Follow the next steps:
• Put gel 94-0002 in front. Select the Landmark tool (fourth tool in the tool bar).
•
Press Control1-F to toggle.
To add a landmark, double-click, in the center of the gel, on a spot that is also in
the other gel. The Create Landmark window pops up. Enter a landmark name
(for example L1). Click OK. The landmark now appears on the gel image
(Fig. 16-8).
Figure 16-8. The L3 Landmark
• Press Control1-F to toggle to gel 94-0005. To move the top gel so that a spot is
•
•
•
•
exactly above the corresponding spot in the other gel, follow these steps: with
the Landmark tool selected, put the cursor in the center of a feature (spot). Hold
down the middle mouse button2 and at the same time press Control1-F once
and move the cursor to the center of the corresponding spot in the other gel.
Release the mouse button.
Double-click on the same feature (spot) in gel 94-0005. The same landmark
name should already be shown in the Create Landmark window. Click OK. The
L1 landmark will be created on the second gel. Repeat this step four times, in
order to add four landmarks around each of the four corners of the gels.
Press Control1-R to unstack the gels. Press Control1-S to save the gels.
Now that both gels contain related landmarks we are going to perform the alignment. Choose Process → Align Gels → Align Gels. In the Align Gels window,
select gel 94-0002 as the reference gel. Click OK. Gel 94-0005 will then be
aligned relative to 94-0002.
Choose Stack → Stack Selected Gels to stack the gels again. To visually compare both gels, switch from one gel to the other by pressing Control1-F quickly
several times.
1. On the Macintosh, use
instead.
2. On the PC mouse with 2 buttons, hold down the Control key and the right mouse button. On the Macintosh, hold down the Option key (
) and the mouse button.
16-8
The Melanie II User Manual
TUTORIAL 1: LOOKING AT GELS
Magnifying glass
• Press Control1-R to unstack the gels. Select the Magnify tool (last tool in the
tool bar). Click the mouse button and move the cursor in one of the gels. A
small area under the cursor will be magnified. Now hold down the right mouse
button2 and move the cursor. The same region in both gels will be magnified at
the same time (Fig. 16-9).
Figure 16-9. The Magnify tool applied to aligned gels.
Exiting MelView
To exit MelView, do File → Quit. To try out more advanced features, such as
detecting spots and matching gels, you may proceed to Tutorial 2: analyzing
gels on page 17-1.
1. On the Macintosh, use
instead.
2. On the Macintosh, hold down the Command key(
) and the mouse button.
The Melanie II User Manual
16-9
16
16-10
TUTORIAL 1: LOOKING AT GELS
The Melanie II User Manual
17
TUTORIAL 2:
ANALYZING GELS
Introduction
This section describes a typical session with the Melanie II software using the
gels provided on the distribution tape, in directory1 Gels. You may read this
section and at the same time perform the described steps. The directory Gelsanalyzed contains the same gels after all the analysis described in this tutorial has been performed. You may therefore check what the result of this analysis should be. To do the complete analysis, perform the following steps. The >
sign indicates the command prompt on the Sun workstation.
Analyzing a set of three gels.
PC / Macintosh
In Melanie II for PC or Macintosh:
• Go to the directory Gels, in which the sample gels are located.
• Double-click on the MelView icon.
Unix
In Melanie II for Unix:
• Go to directory Gels, in which the sample gels are located. (for example:
/usr/local/MelanieII/Gels):
1. On the Macintosh, a directory is called a folder.
The Melanie II User Manual
17-1
TUTORIAL 2: ANALYZING GELS
17
> cd /usr/local/MelanieII/Gels
• Type the following command to run the MelView program:
> MelView &
The & sign indicates that the MelView program has to run in the background.
Figure 17-1 shows the screen that appears when running MelView.
Figure 17-1. The MelView main screen
• Click on the Melanie II logo to get rid of it.
Setting preferences
• This tutorial is also available on-line. To consult it on-line:
Unix
PC / Macintosh
On Unix, choose Preferences in the File menu. Set the Melanie Home directory
to the directory in which the man directory resides, usually the same as the
Melanie II binaries.
On the PC and Macintosh, make sure that the Help directory is located in the
same directory as the MelView application.
Then, in the Help menu, choose Tutorial. On-line user manual and index are
available too. To access the on-line tutorial and user manual, you must have the
Netscape Navigator® World-Wide Web browser installed.
17-2
The Melanie II User Manual
TUTORIAL 2: ANALYZING GELS
Opening 2-DE images
PC
In Melanie II for PC:
• Click in the File menu and select the Open option. The Open window will be
displayed (Fig. 17-2). Hold down the Control key and click on each of the three
Figure 17-2. The Open window allows the selection of the gels that will be
opened and loaded into MelView, PC release
file names in the Files column. This selects the three gels. Click on the OK button. The gels will be opened.
Unix
In Melanie II for Unix:
The Melanie II User Manual
17-3
TUTORIAL 2: ANALYZING GELS
17
• Click in the File menu and select the Open option. The Open window will be
displayed (Fig. 17-3). Hold down the Control key and click on each of the three
Figure 17-3. The Open window allows the selection of the gels that will be
opened and loaded into MelView, Unix release
file names in the Files column. This selects the three gels. Click on the OK button. The gels will be opened.
Macintosh
17-4
In Melanie II for the Macintosh:
The Melanie II User Manual
TUTORIAL 2: ANALYZING GELS
• Click in the File menu and select the Open option. The Open window will be
displayed (Fig. 17-4). Click on each of the three gels and each time click on the
Figure 17-4. The Open window allows the selection of the gels that will be
opened and loaded into MelView, Macintosh release
Add button. This selects the three gels and adds them to the Open gel box.
Click on the Done button. The gels will be opened.
• In the Select menu, choose the Gels → Visible Gels option. This will select all
gels and draw a green line around each of them showing that they have been
selected (Fig. 17-5). In MelView the green color always indicates selected
objects.
Figure 17-5. The three opened gels.
The Melanie II User Manual
17-5
TUTORIAL 2: ANALYZING GELS
17
Adjusting colors
• The 94-0002 and 94-0005 gels are raw, not yet analyzed images. ECOLI is an
•
•
already analyzed master 2-DE map of Escherichia Coli from the SWISS2DPAGE database. In the Show menu, choose Hide All to hide the already
detected and annotated features in the ECOLI image.
Select the Hand tool (the second tool from the top in the left hand side tool bar).
Put the cursor in one of the gels. Hold down the right mouse button1 and move
the gels until you see a region with many spots.
Now select the Region tool (the third tool from the top in the tool bar) and draw
a small rectangle in one of the gels, using the mouse and the button. In the
Select menu, choose Select Mode → Adjust Colors. Select a logarithmic color
function and adjust its parameter to the value 4. The change will directly be
reflected in the selected region (Fig. 17-6).
Figure 17-6. The Adjust Colors option. The modifications are directly
reflected in the selected region.
• Click on the OK button. The colors will be adjusted in all three selected gels.
1. On the Macintosh, hold down the Command key(
17-6
The Melanie II User Manual
) and the mouse button.
TUTORIAL 2: ANALYZING GELS
Reporting on gels
• Choose Show → Gels → Report On Gels. A window pops up giving basic
information about the selected gels, such as image size in pixels, minimum and
maximum grey levels, number of detected features (spots), etc. At this point,
only the ECOLI gel has detected features (Fig. 17-7).
Figure 17-7. The Report On Gels window.
Printing gels
• You first have to set the printer.
Unix
PC / Macintosh
In Melanie II for Unix, select File → Preferences. Make sure to define an existing printer (example: lp).
In Melanie II for the PC or Macintosh, select File → Page Setup and verify the
settings.
Then select File → Print → Print MelView Window. The image of the whole
MelView window is sent to the printer, it means to the Postscript® printer when
using the Unix release.
• Using the Select tool, now select two gels. To achieve this, click on one gel,
then hold down the shift key and click on another gel. Choose File → Print →
Print Selected Gels.
• In the pop-up window select Color Adjustment and click on the OK button. The
selected gels will be printed in full size.
The Melanie II User Manual
17-7
17
TUTORIAL 2: ANALYZING GELS
Setting pseudo colors
• Choose Select → Select Mode → Pseudo Colors. Choose one of the color
lookup table, for example FiveRamps. Click OK. The look-up table will be
changed accordingly (Fig. 17-8). Choose Select → Select Mode → Grey Levels to go back to normal grey level display.
Figure 17-8. The gels displayed using the FiveRamps color lookup table.
Detecting and quantifying features
• Select the gels that have not yet been analyzed (94-0002 and 94-0005) using
the Select tool and holding down the shift key. Choose Process → Detect Features. Click OK. Features (spots) will be detected using the default parameters.
17-8
The Melanie II User Manual
TUTORIAL 2: ANALYZING GELS
Now choose Process → Quantify Features to compute the optical density, area
and volume of the detected features (Fig. 17-9). Select File → Save → Save
Changes to save the features and their associated quantification values.
Figure 17-9. Features have been detected. The Quantify Features option
has been selected.
The Melanie II User Manual
17-9
TUTORIAL 2: ANALYZING GELS
17
Reporting on features
• With the Feature tool (fifth on the tool bar) select a few spots: click on one spot.
It will be displayed in green, showing that it has been selected. Then hold down
the shift key and click on a few other spots. Choose Show → Features →
Report On Features. This brings up a report window showing specific information on the selected features (Fig. 17-10).
Figure 17-10. Report on selected features.
Stacking gels
• Choose Select → Gels → Visible Gels, then Show → Hide All to hide the
•
detected features. This also has the side effect of displaying the images faster.
Select the ECOLI and 94-0002 gels. Choose Show Gels → Selected Gels,
then Stack → Stack Selected Gels. The two gels are now displayed on top of
each other. To switch from one gel to the other, choose Stack → Front To Back,
or just Control1-F. By pressing Control1-F quickly several times, the differences
between the two gels can be observed visually.
Aligning gels
This step is optional, but it is very useful when analyzing gels that are not completely superimposable. Gel alignment corrects gels pixelwise according to a
reference gel, in order to make all gels superimposable.
1. On the Macintosh, use
17-10
The Melanie II User Manual
instead.
TUTORIAL 2: ANALYZING GELS
The first step consists on setting a few landmarks in each of the three gels.
Each landmark must correspond to the same feature in all gels. Start with the
two currently stacked gels. The landmarks must be well distributed over the gel.
Follow the next steps:
• Put the ECOLI gel in front. Select the Landmark tool (fourth tool in the tool bar).
•
Press Control1-F to toggle.
To add a landmark, double-click, in the center of the ECOLI gel, on a spot that
is also in the other two gels. The Create Landmark window pops up. Enter a
landmark name (for example L1). Click OK. The landmark now appears on the
gel image (Fig. 17-11).
Figure 17-11. The L3 Landmark
• Press Control1-F to toggle to gel 94-0002. To move the top gel so that a spot is
•
•
•
•
•
exactly above the corresponding spot in the other gel, follow these steps: with
the Landmark tool selected, put the cursor in the center of a feature (spot). Hold
down the middle mouse button2 and at the same time press Control1-F once
and move the cursor to the center of the corresponding spot in the other gel.
Release the mouse button.
Double-click on the same feature (spot) in gel 94-0002. The same landmark
name should already be shown in the Create Landmark window. Click OK. The
L1 landmark will be created on the second gel. Repeat this step four times, in
order to add four landmarks near each of the four corners of the gels.
Press Control1-R to unstack the gels. Choose Show → Gels → All Gels. Then,
with the Select tool, select the ECOLI and 94-0005 gels. Press Control1-Z and
Control11-T to display the two selected gels in stack mode. Add the same five
landmarks to gel 94-0005.
Choose Show → Gels → All Gels, then Select → Gels → Visible Gels. Press
Control1-S to save the gels.
Now that all three gels contain related landmarks, we are going to perform the
alignment. Choose Process → Align Gels → Align Gels. In the Align Gels window, select the ECOLI gel as the reference gel. Click OK. Gels will then be
aligned relative to the ECOLI gel.
Once gels have been aligned, many tools and actions that work on one gel also
work on all gels at the same time. Instead of pressing the mouse button to use
a tool on one gel, press the right mouse button3. The tool will be applied to all
aligned gels.
1. On the Macintosh, use
instead.
2. On the PC mouse with 2 buttons, hold down the Control key and the right mouse button. On the Macintosh, hold down the Option key (
) and the mouse button.
3. On the Macintosh, hold down the Command key(
) and the mouse button.
The Melanie II User Manual
17-11
17
TUTORIAL 2: ANALYZING GELS
Defining regions
• Select the Region tool (third tool in the tool bar). In the ECOLI gel, hold down
the mouse button, and drag the mouse for about one inch. Release the button.
A small rectangle will be drawn, defining a region on the ECOLI gel. Now hold
down the right mouse button1, drag the mouse. Release the mouse button. The
same region will be defined in all gels.
Magnifying glass
• Select the Magnify tool (last tool in the tool bar). Click the mouse button and
move the cursor in any of the gels. A small area under the cursor will be magnified. Now hold down the right mouse button1 and move the cursor. The same
region will be magnified in all aligned gels at the same time (Fig. 17-12).
Figure 17-12. The Magnify tool applied to aligned gels.
1. On the PC mouse with 2 buttons, hold down the Control key and the right mouse button. On the Macintosh, hold down the Option key (
) and the mouse button.
17-12
The Melanie II User Manual
TUTORIAL 2: ANALYZING GELS
Matching gels
We will now compare the features (spots) in gels 94-0002 and 94-0005 with
those in the ECOLI gel. This process is called gel matching. It is going to pair
each feature in each of the two gels with the corresponding features in ECOLI.
The matching algorithm in Melanie II is able to automatically match features
without any manual intervention. Nevertheless, when gels are quite dissimilar,
or just to speed up the matching process, you may manually define starting feature pairs. As we have already defined landmarks in all three gels, we will use
these as starting pairs.
• Select all three gels, using the Select tool (or Control1-B).
• Choose Process → Match → Match Landmarks. This will perform pairwise
•
matches on the features containing landmarks (in our case landmarks L1 to
L5).
Choose Process → Match → Match Gels. The Match Gels window pops up,
asking for the reference gel, i.e. the gel the other selected gels will be matched
with. Choose ECOLI and click OK. This will now compare all features in gels
94-0002 and 94-0005 to the features in gel ECOLI. Depending on the type of
computer you are using, this might take a few minutes.
• After matching has been successfully completed, press Control1-S to save the
pairs.
• There are various ways of looking at the result. First choose Show → Gels →
Report On Matches. A window shows how many features have been paired
across the gels.
1. On the Macintosh, use
instead.
The Melanie II User Manual
17-13
17
TUTORIAL 2: ANALYZING GELS
• A second way of viewing results of the matching operation is to select a few features in the reference gel (ECOLI) using the Feature tool, then to choose Select
→ Pairs → For Features. This will select (and display) the paired features in
the other two gels (Fig. 17-13).
Figure 17-13. Selected paired features across the three gels.
• Thirdly, you may select two gels, then select a few features on them, then Show
→ Pairs → Report On Pairs to get the feature IDs of the pairs.
• Finally, select gel 94-0005 and ECOLI, then Control1-Z and Control1-T. The two
selected gels are now stacked. Choose Show → Pairs → Show Pairs. All the
paired features will be shown by small blue vectors (Fig. 17-14).
Figure 17-14. Matched gels: blue vectors indicate paired features.
1. On the Macintosh, use
17-14
The Melanie II User Manual
instead.
TUTORIAL 2: ANALYZING GELS
Creating a synthetic gel
Let us now create a synthetic gel by merging the three gels. Prior to the creation of a synthetic gel, pairwise matching has to be performed on all gels
involved. Therefore, we still have to match 94-0002 with 94-0005.
• Choose Show → Gels → All Gels, then select gels 94-0002 and 94-0005.
Choose Process → Match → Match Landmarks, then Process → Match →
Match Gels. Wait for the matching to finish.
• Press Control1-S to save the pairs.
• Choose Image → Create Gels → Create Synthetic Gels. Then choose ECOLI
as the reference gel. This means that the new synthetic gel will be based on
ECOLI, adding spots from the other gels.
• In the next pop-up window, give a name for the synthetic gel. We will just call it
Synthetic. Once created, the synthetic gel will be displayed. You might display it
in the full screen to have a better look at it (select the gel, then Control1-Z). See
Figure 17-15.
Figure 17-15. A part of the synthetic gel, displayed with GEColor.
Matching gels to the synthetic gel
We are now going to use the synthetic gel as a reference gel, because it contains most of the important features from the three other gels.
• Add the L1 to L5 landmarks to the synthetic gel (See Aligning gels on page 1710).
1. On the Macintosh, use
instead.
The Melanie II User Manual
17-15
17
TUTORIAL 2: ANALYZING GELS
• Match the three gels with Synthetic: Control1-B, then Process → Match →
Match Landmarks. Choose Synthetic as the reference gel. Then Process →
Match → Match Gels, and choose Synthetic as reference gel again. The three
gels should now be matched with Synthetic (Fig. 17-16).
Figure 17-16. Three selected pairs.
• Once the gels have been matched, you may unalign the gels, in order to work
with the original images. All pairs will be preserved: Process → Align Gels →
Unalign Gels.
Grouping features
When several gels have been matched with one reference gel, the paired features form so-called groups. A group is a set of features, all paired together.
Figure 17-16 shows three such groups. Groups may be visualized in reports
and in histograms. They may also be exported to files, in order to be used in
external programs such as Excel.
• To get a report on groups, choose Show → Groups → Report On Groups.
Select a gel as reference gel, for example ECOLI. If a master gel has already
been set, the latter will be taken as reference gel (See Using a master gel on
page 17-17). Select the value type, for example the optical density (OD) or the
feature area.
1. On the Macintosh, use
17-16
The Melanie II User Manual
instead.
TUTORIAL 2: ANALYZING GELS
• To get histograms on groups, choose Show → Groups → Histograms On
Groups. Figure 17-17 shows histograms for two of the selected features. The
Figure 17-17. Histograms for two feature groups.
•
IDs of the selected groups are shown on the reference gel.
To export the groups, choose File → Export. Select the export format. You may
export to Outgroups format (this is the Melanie 1 table format), Excel tables and
Excel lists.
Using a master gel
The ECOLI gel is a SWISS-2DPAGE master gel. This means that several proteins have been identified on the 2-DE map. Corresponding entries exist in the
SWISS-2DPAGE database on the Expasy World-Wide Web server. Each identified protein has a label associated with the corresponding feature.
• Choose Database → Set → Master. Select ECOLI. The ECOLI gel is now
defined as the master gel. Its name is printed with a red background.
• Select ECOLI with the Select tool, then Control1-Z, to have it alone on the
•
screen.
Choose Show → Labels → Show Labels. All existing labels will appear, showing the SWISS-2DPAGE accession numbers (ACs) of all identified proteins
(Fig. 17-18).
Figure 17-18. Labels showing the proteins’ accession numbers.
1. On the Macintosh, use
instead.
The Melanie II User Manual
17-17
17
TUTORIAL 2: ANALYZING GELS
• Choose Show → Labels → Show Name. The SWISS-2DPAGE short protein
names will be shown instead of the accession numbers (Fig. 17-19).
Figure 17-19. Labels showing the proteins’ short names (ID).
• Choose Show → Gels → All Gels to display all gels again, then Control1-B,
then Select → Features → All Features. Finally, choose Database → Labels
→ Add From Master. Labels will be propagated to paired features. If necessary,
choose Show → Labels → Show Labels (Fig. 17-20).
Figure 17-20. Labels propagated to other gels.
Using the Internet
If your computer is connected to the Internet, you may directly access the
SWISS-2DPAGE or SWISS-PROT databases on the Expasy server, as well as
other databases on various servers.
1. On the Macintosh, use
17-18
The Melanie II User Manual
instead.
TUTORIAL 2: ANALYZING GELS
• Choose Database → Set Master and choose ECOLI. In the Unix release,
choose Database → Set Browser and verify that the right name and path are
given for Netscape. Choose Database → Set Server. Enter www.expasy.ch
and finally, choose Database → Set Database and enter SWISS-2DPAGE.
• Using the Feature tool (fifth tool on the tool bar), select one feature corresponding to an identified protein. Then choose Database → Query Server. MelView
will remotely control Netscape Navigator® and request the corresponding entry
from the SWISS-2DPAGE database on Expasy.
Analyzing data
When gels have been matched with one reference gel, groups have been created, and statistical data analysis may be performed on sets of features.
Close all gels that you have been using so far by choosing File → Close and
restart with another set of already analyzed gels of Plasma. Perform the following steps:
In Melanie II for PC or Unix:
PC / Unix
• Click in the File menu and select the Open option. The Open window will be
displayed. Double-click in the Gels Analyzed directory to open it. Hold down the
Control key and click on each of the six gel files called 94-0613, 94-0614, 940616, 94-0622, 94-0623 and 94-0624, in the Files column. This selects the six
gels. Click on the OK button. The gels will be opened.
Macintosh
In Melanie II for the Macintosh:
• Click in the File menu and select the Open option. The Open window will be
•
•
•
displayed. Select the Gels Analyzed directory by double-clicking in it. Click on
each of the six gel files called 94-0613, 94-0614, 94-0616, 94-0622, 94-0623
and 94-0624 and each time click on the Add button. This selects the six gels
and adds them to the Open gel box. Click on the Done button. The gels will be
opened.
All six gels have already been analyzed. Gel 94-0623 was used as the reference map.
In the Select menu, choose the Gels → Visible Gels option. This will select all
gels and draw a green line around each of them showing that they have been
selected. In MelView the green color always indicates selected objects. In the
Show menu, choose Hide All to hide the already detected and annotated features in the gels.
Select the Hand tool (the second tool in the tool bar). Place the cursor in one of
the gels. Hold down the right mouse button1 and move the gels until you see a
region with many spots.
1. On the Macintosh, hold down the Command key(
) and the mouse button.
The Melanie II User Manual
17-19
TUTORIAL 2: ANALYZING GELS
17
Differential analysis with classes set
To use this analysis option, you need to create two classes of gels.
• To create the first class, pick the Select tool in the tool bar. Put the cursor in gel
•
•
•
•
•
94-0613 and click on the mouse button. Then hold the shift key on the keyboard
and select gels 94-0614 and 94-0616 by clicking on them. This will select the
three gels and draw a green line around each of them showing that they have
been selected.
Choose Analyze → Set Class. A pop-up window asks you to give a name to
this class. Accept the example name, class A, by clicking OK.
Now select gels 94-0622, 94-0623 and 94-0624, as described above.
Choose Analyze → Set Class and accept the example name, class B, by clicking OK.
Now select the Region tool (the third tool in the tool bar) and draw a small rectangle in one of the gels, using the mouse and the button.
To select groups in this region, choose Select → Groups → In Region. Select
gel 94-0623 as reference gel by choosing Database → Set → Master and picking up 94-0623 as reference gel.
• Choose Analyze → With Classes Set → Differential Analysis.
• Select the value type, for example the feature area.
• Accept the default ratio value (200) to be considered between the mean value
•
•
of one class for a given group and the mean value for the other class on the
same group (See Differential analysis with classes set on page 13-2).
If there aren’t any features selected, increase the rectangle size in one of the
gels.
To get a report on differential analysis results, choose Show → Analysis →
Report On Analysis. You may print or save the report.
Student T Test with classes set
To visualize the Student T Test results, keep the classes set, classes A and B,
and select all groups in the six visible gels.
•
•
•
•
•
Choose Select → Groups → All Groups.
Choose Analyze → With Classes Set → Student T Test.
Select the value type, for example the feature area.
Accept the default value of the T Test (0.95) to be considered between both
classes (See Student T Test with classes set on page 13-3).
To get a report on Student T Test analysis results, choose Show → Analysis →
Report On Analysis. You may print or save the report.
Differential analysis without classes set
For this analysis method, you have to unset the existing classes.
• Choose Analyze → Unset All Classes.
17-20
The Melanie II User Manual
TUTORIAL 2: ANALYZING GELS
• Now select the Region tool (the third tool in the tool bar) and draw a small rect•
•
•
•
•
angle in one of the gels, using the mouse button.
To select groups in this region, choose Select → Groups → In Region.
Choose Analyze → Without Classes Set → Differential Analysis.
Select the value type, for example the feature area.
Accept the default value of the ratio (200) to be considered between the highest
and the lowest values in groups (See Differential analysis without classes set
on page 13-4).
To get a report on differential analysis results, choose Show → Analysis →
Report On Analysis. You may print or save the report.
Correspondence analysis without classes set
• Keep the same region as in the preceding paragraph and select groups in this
region, choose Select → Groups → In Region.
• Choose Analyze → Without Classes Set → Correspondence Analysis.
• Select the value type, for example the feature area.
• Accept the default value of the number of significant groups that will be dis•
•
played in the results (See Correspondence analysis without classes set on
page 13-4).
To get a report on correspondence analysis results, choose Show → Analysis
→ Report On Analysis. You may print or save the report.
You can also visualize the results by displaying a projection of gels and features
in the 2-D factorial space. Choose Show → Analysis → Graphics on Analysis.
Choose to display gels and significant features.
Exiting MelView
To exit MelView, do File → Quit.
Other Melanie II features
Many other options and features are available in the MelView program, including:
•
•
•
•
•
Importing/exporting images from and to TIFF, GIF, PPM, etc.;
Filters for smoothing, contrast enhancement, background subtraction, etc.;
Managing gel images (flipping, scaling, duplicating, etc.);
Landmark, feature and label selection by various criteria;
Landmark, feature, label, pair and group editing.
The Melanie II User Manual
17-21
17
17-22
TUTORIAL 2: ANALYZING GELS
The Melanie II User Manual
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement