LPCXpresso

LPCXpresso
LPCXpresso
Getting started with NXP LPCXpresso
Rev. 11.1 — 1 December 2011
User guide
Document information
Info
Content
Keywords
LPCXpresso, LPC1100, LPC1200, LPC1300, LPC1700, LPC1800,
LPC2000, LPC2900, LPC3000, LPC3100, LPC3200, LPC4300
Abstract
LPCXpresso is a new, low-cost development platform available from
NXP. This document is a brief overview on how to get started with
LPCXpresso.
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Revision history
Rev
Date
Description
11.1
20111201
 Updated supported LPC products list.
11
20110614
 Updates for LPCXpresso 4- new screen shots
 Added 1.1 V4 new features section
 Updated comprehensive supported parts list
 Updated create new project process
10
20110407
 Added Fig 45 and Fig 46.
9
20110301
 Updated keywords and supported products throughout
 Updated Section 6.1
 Updated Section 6.2.6
 Updated Section 6.6.2
 Removed Fig 20
 Added Fig 42 and Fig 43
8
20110211
7
20100915
 Updated Section 3.1
6
20100712
 Added 7.1 Schematics for LPCXpresso LPC1768 target side
5
20100604
 Updated Section 3.2
 Added Fig 39, Fig 40, Fig 41, Fig 44
 Added 6.1 Installing Eclipse plugins
 Added new products supported to Introduction section: LPC2929, LPC3250
 Removed 6.1.6 Download performance
 Updated 6.4.2 Optimization section
4
20100419
 Updated Fig 47
3
20100315
 Updated Fig 38
2
20100311
1
20100111
 Added Fig 39
 Updated Section 3.1
 Added Section 6.2.6
 Initial version
Contact information
For additional information, please visit: http://www.nxp.com
For sales office addresses, please send an email to: [email protected]
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
2 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
1. Introduction
LPCXpresso is a new, low-cost development platform available from NXP. The software
consists of an enhanced, Eclipse-based IDE, a GNU C compiler, linker, libraries, and an
enhanced GDB debugger. The hardware consists of the LPCXpresso development board
which has an LPC-Link debug interface and an NXP LPC ARM-based microcontroller
target. LPCXpresso is an end-to-end solution enabling embedded engineers to develop
their applications from initial evaluation to final production.
The LPCXpresso IDE, powered by Code Red Technologies (www.code-redtech.com/lpcxpresso/), is based on the popular Eclipse development platform and
includes several LPC-specific enhancements. It is an industry-standard GNU toolchain
with an optimized C library that gives engineers all the tools necessary to develop highquality software solutions quickly and cost-effectively. The C programming environment
includes professional-level features. There is syntax coloring, source formatting, function
folding, on- and offline help, and extensive project management automation.
The LPCXpresso target board, jointly developed by NXP, Code Red Technologies, and
Embedded Artists (http://www.embeddedartists.com/products/lpcxpresso/), includes an
integrated JTAG debugger (LPC-Link), so there’s no need for a separate JTAG debug
probe. The target portion of the board can connect to expansion boards to provide a
greater variety of interfaces, and I/O devices. The on-board LPC-Link debugger provides
a high-speed USB to JTAG/SWD interface to the IDE and it can be connected to other
debug targets such as a customer prototype. Users can also use the LPCXpresso IDE
with the Red Probe JTAG adapter from Code Red Technologies.
Supported LPC products and board part numbers on the LPCXpresso platform:
 LPC1100: All part types supported
 OM11049: LPC1114/302
 OM13014: LPC11U14
 OM13012: LPC11C24
 LPC1200: All part types supported
 OM13008: LPC1227
 LPC1300: All part types supported
 OM11048: LPC1343
 LPC1700: All part types supported
 OM13000: LPC1769
 LPC1800: All part types supported
 LPC2000: LPC2109, LPC2109/01, LPC2134, LPC2142, LPC2362, LPC2929
 LPC3000: LPC3130, LPC3250
 LPC4000: All part types supported
LPCXpresso base board products:
 OM11083: Embedded Artists Base Board for LPCXpresso and mbed
 OM13009: Embedded Artists Motor Control Kit for LPCXpresso
 OM13016: NGX mbed-LPCXpresso baseboard
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
3 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
1.1 LPCXpresso 4 new features
 Support for CMSIS v2.0 included
 Based on eclipse Helios and gcc 4.5.1
 New part support
For more information on LPCXpresso 4 new features visit:
http://support.code-red-tech.com/CodeRedWiki/NewInVersion4
1.2 LPCXpresso IDE
LPCXpresso’s IDE is a highly integrated software development environment for NXP’s
LPC Microcontrollers, which includes all the tools necessary to develop high quality
software solutions in a timely and cost effective fashion. LPCXpresso is based on Eclipse
with many LPC specific enhancements. It also features the latest version of the industry
standard GNU tool chain with a proprietary optimized C library providing professional
quality tools at low cost. The LPCXpresso IDE can build an executable of any size with
full code optimization and it supports a download limit of 128 kB after registration.
LPCXpresso supports the full embedded product design cycle by moving beyond chip
evaluation boards and supporting development on external target boards.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
4 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Fig 1.
LPCXpresso IDE
1.3 LPCXpresso development board
Fig 2.
LPCXpresso
User guide
LPCXpresso development board
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
5 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
1.4 LPC-LINK JTAG/SWD debugger
The LPCXpresso board contains a JTAG/SWD debugger called the “LPC-Link” and a
target MCU. LPC-Link is equipped with a 10-pin JTAG header (highlighted on the above
image) and it seamlessly connects to the target via USB (the USB interface and other
debug features are provided by NXP’s ARM9 based LPC3154 MCU). Cutting the tracks
between the LPC-link and the target will make the LPC-Link a stand-alone JTAG
debugger. This enables the LPCXpresso platform to be connected to an external target
and used to develop for a wide variety of NXP’s Cortex-M0, Cortex-M3, and ARM7/9
based applications. Currently supported microcontroller products include LPC1700,
LPC1300, LPC1200, and LPC1100 series and specific members of the LPC2000 and
LPC3000 families.
1.5 Integrated evaluation target
The target includes a small prototyping area and easily accessible connections for
expansion. The LPCXpresso board with target can be used
 On its own for software development and benchmarking
 Connected to an off-the-shelf baseboard for rapid proof-of-concepts
 Connected to customer-designed board for a full prototype
1.6 LPCXpresso partners
NXP has partnered with Code Red Technologies and Embedded Artists for the
LPCXpresso platform. For added flexibility and higher memory configurations, the
LPCXpresso platform can easily be upgraded to include full-blown suites from Code Red
Technologies and more advanced hardware kits from Embedded Artists. Please visit the
LPCXpresso webpage for more information.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
6 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
2. Evaluate, explore and develop
Fig 3.
Product development stages
Users can envisage three stages from evaluation to product development. During
evaluation, features and peripherals of the target MCU can be easily tested with the
prototyping area and easily accessible connections on the target board. Complementing
the target board are also easy-to-use example projects and a handy Getting Started
guide. For rapid proof-of-concepts, users can get an off-the-shelf base board from
Embedded Artists and quickly explore the next level of applications. And finally
LPCXpresso users can seamlessly develop their final application by using the LPC-Link’s
10-pin JTAG connector to attach any JTAG-capable custom board. This way, users can
now enjoy the same user experience right from evaluation to product development.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
7 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
3. Installation
3.1 System requirements
Operating System
Microsoft® Windows - XP 32-bit (SP2 or greater)
Microsoft® Windows - Vista 32-bit or 64-bit
Microsoft® Windows - Windows 7 32-bit or 64-bit
Linux - Ubuntu 9, 10, and 11
Linux - Fedora 12 and 13
System RAM
512 MB minimum (1 GB recommended)
Hard Disk
300+ MB of available space.
Screen/Display Adaptor
1024x768 minimum recommended
Internet Connection
High-speed internet is recommended to download and register
the software
Note: LPCXpresso may install and run on other Linux distributions. However, only the
distributions listed above have been tested. Desktop virtualization tools supporting a linux
or Windows guest with USB support can be used to run LPCXpresso on other computing
platforms.
3.2 Installation process
LPCXpresso is installed into a single directory, of your choice. Multiple versions can be
installed simultaneously without any issues. The installation process is to double-click the
installer file after downloading. Then click “next” on the setup wizard. To install under
linux, the downloaded file should be marked as executable first using chmod +r.
Fig 4.
LPCXpresso
User guide
Setup wizard
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
8 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Fig 5.
Setup wizard
Read the license agreement then click next. There are a number of other screens on the
setup wizard, but generally the default options can be accepted. After the install, an
information file will be displayed. Click “Next.” Congratulations! Your LPCXpresso
installation is complete!
Fig 6.
LPCXpresso
User guide
Setup wizard
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
9 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
3.3 Activation
To activate your product from LPCXpresso, choose Help->Product activation->Create
serial number and register. Once the wizard is open, click “Copy to clipboard” to copy the
LPCXpresso serial number into the clipboard. This serial number is based on your
machine’s hardware and operating system configuration, but contains no personally
identifiable information. Now click the button to open the registration activation page. This
should display a web form. After completing the form, you will receive an activation code
via email within a few minutes. Highlight the activation code in your email program, and
select Copy to place it into the Windows clipboard. Now, choose select Help->Product
activation->Enter activation code from within LPCXpresso. Paste the product activation
code into the Product activation dialog by right clicking in the Activation code field and
choosing “Paste.” Then click the “OK” button. You should receive a dialog confirming
acceptance of the activation code. It is also possible to complete LPCXpresso activation
on a PC that is offline as long as another PC has access to the Internet. Refer to Fig 7 for
the process.
Fig 7.
LPCXpresso
User guide
LPCXpresso activation with offline PC
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
10 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
4. Getting familiar with the LPCXpresso IDE
LPCXpresso IDE is based on the Eclipse IDE framework and many of the core features
are described well in generic Eclipse documentation and in the help files found in the
help menu of the product. Further documentation and pointers to useful documents are
also available on the Code Red Technologies Wiki at http://support.code-redtech.com/CodeRedWiki.
4.1 Layout of the LPCXpresso desktop
LPCXpresso’s Desktop contains many windows. Each window is called a View, because
it displays a particular view of data in the LPCXpresso environment. This data could be
source code, hex dumps, disassembly, memory contents, or more. Views can be
opened, moved, docked, and closed, and the layout of the currently displayed Views can
be saved and restored. A specific configuration of Views is called a ‘Perspective.’
Typically, LPCXpresso operates in a single perspective under which both the code
development & debug sessions operate as shown on the next page. The single
perspective greatly simplifies the Eclipse environment and enhances the entire
LPCXpresso experience.
All Views in the Perspective can be moved around by dragging and dropping. If a View is
accidentally closed, it can be restored by selecting it from the Show View dialog. The
Show View dialog can be opened from the Show View Other... option in the Window
menu.
Fig 8.
LPCXpresso
User guide
Show view/other menu
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
11 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
4.1.1 Single perspective (code development)
1
2
4
3
Fig 9.
Single perspective (develop)
1. Project Explorer View: The ‘Project Explorer’ gives you a view of all the projects in
your current ‘Workspace’. A ‘Workspace’ is a collection of projects that are stored in
a single Workspace Directory on your computer.
2. Editor: On the upper right is the editor which allows modification and saving of source
code as well as setting breakpoints in debug mode.
3. Console and Problems Views: On the lower right are the Console and Problems
Views. The Console View displays status information on compiling and debugging,
as well as program output. The Problem View (available by changing tabs) shows all
compiler errors and will navigate the Editor View to the error location.
4. Quick Start View: Below, the ‘Quick Start’ view has fast links to commonly used
features. This is the best place to go to find options such as Build, Debug, and
Import.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
12 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
4.1.2 Single perspective (debug)
2
1
3
5
4
Fig 10. Single perspective (debug)
1. Core Register View: This shows all of the registers in the processor core. Registers
that have changed from step to step are highlighted in yellow.
2. Debug View: This shows you the stack trace and the debug toolbar. Using the icons
at the top of the view, you can step through code or execute at full speed. In the
‘stopped’ state, you can click on any particular function and inspect its local variables
in the right hand panel on the Variables tab.
3. Editor: In here you will see the code you are executing and can step from line to line.
By pressing the ‘i’ icon at the top of the Debug view, you can switch to stepping by
assembly instruction. Clicking in the left margin will set and delete breakpoints.
4. Console View: On the lower right is the Console View. The Console View displays
status information on compiling and debugging, as well as program output.
5. Quick Start View: Below, the ‘Quick Start’ view has fast links to commonly used
features. This is the best place to go to find options such as Build, Debug, and
Import.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
13 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
4.1.2.1 Peripheral views
LPCXpresso includes full, annotated and interactive debug views of all the peripherals.
Access to the views is found on the Peripherals View (click the Peripherals tab) behind
the Core Registers view. Each peripheral can be selected, and it is displayed in the
‘Memory’ view which is located behind the ‘Console’ view at the bottom of the
LPCXpresso desktop.
Fig 11. Display of peripheral view showing selection of ADC peripheral
Fig 12. Display of memory view showing detail of ADC peripheral registers
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
14 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
4.2 Connecting the target
To begin development, the LPCXpresso can be connected to a PC using a USB 2.0
A/Mini-B cable.
Fig 13. USB 2.0 A/Mini-B cable
If you are debugging a prototype board or a target containing a different MCU, see the
Appendix for a pinout to connect the debugger section of the LPCXpresso to an external
target.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
15 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
5. Examples: Download, build, download and debug
5.1 Downloading NXP sample code from the web
Fig 14. Quickstart panel
First, select “Import project(s)” from the Quickstart panel in the lower left corner of the
screen.
Fig 15. Import project(s) dialog
Next, select “Browse for more examples…” from the Import project(s) dialog.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
16 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Fig 16. http://www.nxp.com/lpcxpresso-support web site
The LPCXpresso-Support web page should appear. It has links to NXP sample code that
has been developed for LPCXpresso. Select the sample code that applies to your Target
Device and download it. Then, switch back to LPCXpresso and use the Browse button to
select the .zip file.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
17 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Fig 17. Zip file from LPCXpresso-Support web site selected for importing
Now click the Next button and then choose which projects to import from the .zip file.
Fig 18. Import projects(s):-Selecting which projects to import
Often, there will be references between projects in a .zip file so it is best to import all of
them.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
18 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Fig 19. Import projects: Progress indicator
 There is also a local LPCXpresso examples directory. This is often located at
C:\nxp\lpcxpresso\lpcxpresso\examples.
5.2 Debugging/running ‘blinky’ or another project on your LPCXpresso
board
In LPCXpresso, when you start to debug, your program will automatically download to
the target and be programmed into flash memory.
To start debugging on your target, simply highlight the project in the Project Explorer and
then in the Quickstart Panel select ‘Debug ‘Projectname’ [Debug].
Fig 20. Debug
You may also enter debug mode by clicking the bug icon on the top LPCXpresso toolbar.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
19 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Fig 21. Bug icon
You are then presented with the debug view and toolbar and have run control over the
code running on your target. The debug toolbar will pop up above the code window.
Fig 22. Debug toolbar
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
20 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
You can now do the following with the buttons towards the top of the ‘Debug’ view:
Run the program.
Step Over C/C++ line.
Step into a function.
Stop the debugger.
Pause Execution of the running program.
Instruction stepping mode (disassembly)
Fig 23. Debug buttons
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
21 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
6. LPCXpresso IDE tips and tricks
6.1 Installing Eclipse plugins
The LPCXpresso IDE contains many of the features of the Eclipse open-source IDE from
http://www.eclipse.org. The browse and install plugin function is present in the help
menu. To access it, choose Help -> Install New Software. This will display the Eclipse
Install Software dialog which will allow browsing and installing of Eclipse plugins.
6.2 Debugging tips
6.2.1 Debug features not enabled
All of the LPCXpresso features are context-sensitive. If features are disabled, doublecheck that you are navigated into a .c file in an open project on the Project Explorer
View, or some menu items and toolbar buttons may be disabled. If your workspace
contains projects that create libraries such as CMSIS, please note that debug features
will be disabled if you are currently editing a .c file that is part of a library project.
6.2.2 Error launching Debug\filename.axf
Fig 24. Error starting debug
LPCXpresso checks the target chip ID against the currently selected chip ID for the
project and will not start if there is not a match. Make sure that the correct NXP LPC
microcontroller part is selected in LPCXpresso. The current part number is displayed in
the status bar at the bottom of the LPCXpresso window. It can be changed by holding
down the Ctrl key and clicking. A dialog will appear allowing selection of the correct part
number.
Fig 25. Current part number
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
22 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Fig 26. Selecting correct part number
6.2.3 Optimization issues
When optimization is enabled, it will reorder code. What this means is that the code from
multiple C lines will be intermingled. In addition, assignments and initializations might be
pulled out of loops so they are only executed once. Changes like these will make the
code confusing to debug. Some symptoms you might see are breakpoints that only work
the first time through, or seeing the debugger’s current line indicator fail to advance or
even move backwards when you click step. It is best to always use –O0 for debugging.
Since optimization can make such a big difference in code size and performance, it is a
good idea to test your project with optimization and plan for a final build that is optimized.
6.2.4 Displaying assembly instructions
Click the i-> icon. This changes the Instruction Stepping Mode to step by processor
instructions, rather than source lines. This also shows the disassembly view around the
current instruction.
6.2.5 Exiting debug mode and stopping debugging
To stop debug press the ‘Stop’ button (red square) shown in the toolbar at the top of the
debug view.
6.2.6 Recovery of board
After playing around with the LPCXpresso board, especially when trying out new PLL
settings, reconfiguring the SWDIO/SWDCLK pin functions, disabling AHBCLKCTRL bits,
or trying power down modes, the board may be disabled and no longer enter debug
mode. This is caused by code on the on-board flash that incorrectly disables the system
clocks or the debug port soon after reset before the debugger can connect to the core.
The easiest solution to this is to load a working project into LPCXpresso, ground the ISP
pin (see the chip User’s Manual for details) and then try to enter debug mode.
Grounding the ISP pin during reset will put the target MCU into In-System Programming
(ISP) mode. It will wait for a command through the serial port or the USB port. This
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
23 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
temporarily prevents the troublesome code in flash from starting. Although ISP is
designed to enable serial and USB updates, while ISP is running, the LPCXpresso
toolchain is able to connect to the Cortex core and reprogram the flash. After the flash is
reprogrammed, disconnect the ISP pin (pull it high or allow it to float) and stop
debugging. Now you should be able to debug code again.
6.3 Datasheet browser
The LPCXpresso IDE comes with an integrated web browser that will direct viewers to
the datasheet of the device. Just click on the part number in the lower right border of the
LPCXpresso window to see the browser in action.
Fig 27. Integrated web browser
6.4 Code size
6.4.1 printf
When optimizing a project for size, if you are using printf, make sure that Redlib is
selected as the standard library in the Projects Properties dialog. This option can be set
using the Quick Settings dropdown box in the Quick Start panel.
Fig 28. Reconfigure library setting
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
24 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
The printf implementation in Redlib is about half the size of the implementation in Newlib.
A smaller printf library can be used in Redlib if floating point formatting strings are not
used. To select this smaller library, define the symbol CR_INTEGER_PRINTF to the
compiler (i.e. -DCR_INTEGER_PRINTF). To save even more space, avoid using printf or
any C standard library functions and select Redlib (none). Depending on your printf
settings and code, this could free up 10K to 20K of flash memory.
6.4.2 Optimization
Optimization can do a lot to save flash memory. It can be configured in the same dialog
as the C standard library. Choose “Optimization” under “MCU C Compiler” in the “Tool
Settings” tab. Higher levels of optimization will typically result in higher performance, but
may result in larger code size. It is best to use –O0 for debugging and higher levels for
Release. For best code size try –Os –mword-relocations. To further reduce code, add
--gc-sections to the project linker flags. This causes the linker to remove unused
functions from the compiled code. --gc-sections is enabled by default in new projects
created by the project wizard. If you are working with an existing project, you may need
to manually add this option to your project. --gc-sections is safe to use in both Release
and Debug builds. There are many optimization options available for GCC. Visit
http://gcc.gnu.org/onlinedocs/gcc/Optimize-Options.html to see all of them.
6.5 Showing hidden views
A view is an on-screen representation of something in the IDE. A view can be source
code, the project tree, or a debug window. If you accidentally close a view, you can open
it again by going to the Window menu and choosing Show View and Other. It is a good
idea to browse through the Show View window to see what is available.
Fig 29. Show view window
This will present a dialog allowing you to pick a view and display it.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
25 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
6.6 Creating a ‘skeleton’ project in a new Workspace
LPCXpresso includes several project Templates to help get started quickly.
6.6.1 Create a new Workspace
From the ‘File’ menu hover over ‘Switch Workspace’ and then select ‘Other…’ from the
bottom of the list. You will then see the ‘Workspace Launcher’ dialog shown below.
Enter or browse to the new path for your workspace. We have called our new workspace
‘NewWorkspace’.
Fig 30. Workspace launcher
Then click on OK to re-open LPCXpresso with this new workspace selected.
6.6.2 Create the ‘Skeleton’ project
 If you are using a Cortex-based part, first, import the CMSIS header files for the chip
family you are planning to work with. To do this, click “Import Project” and navigate to
the CMSIS<version/part>.zip. The CMSIS header files are installed with LPCXpresso
in C:\nxp\lpcxpresso\lpcxpresso\examples\nxp. Once this project is added to your
workspace, click “Build all projects (Debug)” in the Quickstart Panel.
 Click on ‘New project…” and select the NXP C project type for your architecture.
 Click “Next” and enter a project name. In this case we will use ‘MyProject’ then click
‘Next.’
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
26 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Fig 31. Enter project name
 The next section of the dialog will ask you to specify which chip in the family you are
using.
Fig 32. Enter project name

LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
27 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
 If you are using a Cortex-based part, the next step in the wizard will ask which
CMSIS project to use. CMSIS stands for Cortex Microcontroller Software Interface
Standard. CMSIS defines a common way to access peripheral registers and to define
interrupts. Please select the project that you imported into the workspace earlier and
click Finish.
Fig 33. CMSIS selection
Congratulations! You have created your first project!
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
28 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Fig 34. Project creation complete
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
29 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
7. Appendix
7.1 LPCXpresso target side schematics
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
30 of 48
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
31 of 48
© NXP B.V. 2011. All rights reserved.
Fig 35. Schematic for the LPCXpresso LPC1769 target side (1 of 3)
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
32 of 48
© NXP B.V. 2011. All rights reserved.
Fig 36. Schematic for the LPCXpresso LPC1769 target side (2 of 3)
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
33 of 48
© NXP B.V. 2011. All rights reserved.
Fig 37. Schematic for the LPCXpresso LPC1769 target side (3 of 3)
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
Design and layout compatible with LPC1343 version. Therefore, PIO2_4/5 and PIO3_4/5 swap. LPC1114 does not have USB, but LPC1343 does. Therefore R37/38.
LPC1114 does not have SWO, but PIO0_9 is connected (since LPC1343 has SWO there).
LPCXpresso
34 of 48
© NXP B.V. 2011. All rights reserved.
1.
Getting started with NXP LPCXpresso
Fig 38. Schematic for the LPCXpresso LPC1114 target side 1
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
35 of 48
© NXP B.V. 2011. All rights reserved.
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
Fig 39. Schematic for the LPCXpresso LPC1343 target side
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
36 of 48
© NXP B.V. 2011. All rights reserved.
Fig 40. Schematic for the LPCXpresso LPC11C24 target side, part 1
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
37 of 48
© NXP B.V. 2011. All rights reserved.
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
Fig 41. Schematic for the LPCXpresso LPC11C24 target side, part 2
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
38 of 48
© NXP B.V. 2011. All rights reserved.
Fig 42. Schematic for the LPCXpresso LPC1200 target side, part 1
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
39 of 48
© NXP B.V. 2011. All rights reserved.
Fig 43. Schematic for the LPCXpresso LPC1200 target side, part 2
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
40 of 48
© NXP B.V. 2011. All rights reserved.
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
Fig 44. Dimensioned drawing of LPCXpresso LPC1227, LPC1343, LPC1114/301, LPC1114/302, LPC11C24, LPC1769, LPC1768
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
41 of 48
© NXP B.V. 2011. All rights reserved.
Fig 45. Schematic for the LPCXpresso LPC11U14 target side, part 1
NXP Semiconductors
LPCXpresso
User guide
Rev. 11.1 — 1 December 2011
LPCXpresso
Getting started with NXP LPCXpresso
All information provided in this document is subject to legal disclaimers.
42 of 48
© NXP B.V. 2011. All rights reserved.
Fig 46. Schematic for the LPCXpresso LPC11U14 target side, part 2
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
7.2 LPCXpresso PCB pinout and dimensions
The schematics of the LPCXpresso Target and the LPC-LINK debug connector appear in
Fig 35 to Fig 46. The LPCXpresso board was designed to be pin compatible with NXP
mbed. LPCXpresso can be powered either through the debug mini-USB port, by 3.3 V
applied to the board, or by 5 V applied to the USB connector. A cable for the 10-pin mini
JTAG connector on the LPC-LINK debugger portion of LPCXpresso can be purchased
from Digi-Key, part number FFSD-05-D-06.00-01-N.
Dimensions: A dimensioned drawing of LPCXpresso can be found in Fig 44.
LPCXpresso LPC1343’s outer dimensions are 1.35x5.45 inches. It contains two rows of
holes 900 mil apart. Each row has 27 connections and holes are drilled at a 100 mil pitch.
Fig 47. LPCXpresso LPC-LINK JTAG/SWO pinout
7.3 Enabling USB connectivity “to LPC1343 target”
The LPCXpresso board is simple yet flexible. Here is a way to configure it to support the
development of USB devices using the LPC1343 or other USB-capable NXP
microcontroller. The LPC1343 has a USB phy on-chip. To connect the microcontroller to
a USB port, it is only necessary to add a USB connector and a pullup resistor.
Note: This simple connection does not implement NXP Soft-Connect to allow soft
disconnection and connection to the USB bus. Because of this, the USB connection must
be plugged into the PC near the time the USB peripheral is initialized, or after. If the USB
port is connected when the LPC USB peripheral is not initialized, the pullup resistor will
notify the PC that a USB device is present, yet the microcontroller will not respond
because it has not been initialized. This will trigger windows to generate an error
regarding a malfunctioning USB device. Unplug and re-plug the device to dismiss the
error.
Note 2: Rather than building a cable or wiring a USB Type-A connector, you could take
an existing A-B USB cable and cut off the B connector. Then the A side of the cable
could be stripped and soldered onto the LPCXpresso board.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
43 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
Fig 48. USB retrofit schematic
Fig 49. LPC1343 target connected to Type-A USB cable
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
44 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
7.4 Terminology
LPCXpresso
The Code Red Technologies IDE (Integrated Development Environment) based on
Eclipse with our own extensions for embedded development.
SWD
Serial Wire Debugging (Single Wire Debugging). This is a debug connection technology
available on the Cortex-M3 that allows debug through just 2-wires unlike 5 for JTAG.
ELF (Executable and Linking Format)
This is the object code file format used by our development tool chain and most
microprocessor tool chains.
Workspace
LPCXpresso organizes groups of projects into a ‘Workspace’. A workspace is stored as a
directory on your host PC and has subdirectories containing individual projects.
Project
An LPCXpresso project. A project contains all of the .c and .h files to build a single
microcontroller flash image.
Perspective
In LPCXpresso, a perspective is a particular collection of ‘Views’ that are grouped
together to be suitable for a particular use. For example the ‘C/C++ programming’
perspective and the ‘Debug’ perspective.
View
A ‘View’ is a window in LPCXpresso that shows a particular file or activity. A view could
be of a C source code file or something live such as a disassembly window or register
dump. A ‘Perspective’ is the layout of many ‘Views’.
Semi-hosting
The ability to use IO on your debugger host system for your target embedded system.
For example a ‘printf’ will appear in the console window of the debugger.
Debug Target
The system being debugged. LPCXpresso includes a target microcontroller on-board, but
can also be connected to external targets.
RedlibTM
The optimized Code Red Technologies C runtime library (non-GNU). LPCXpresso
includes both Redlib and Newlib libraries.
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
45 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
References
[1]
NXP LPCXpresso http://www.nxp.com/lpcxpresso
[2]
NXP LPCZone http://www.nxp.com/lpczone
[3]
NXP Microcontrollers http://www.nxp.com/microcontrollers
[4]
Code Red Technologies Wiki http://lpcxpresso.code-redtech.com/LPCXpresso/softwareknowledgebase
[5]
Code Red Technologies LPCXpresso page http://www.code-redtech.com/lpcxpresso
[6]
Embedded Artists AB http://www.embeddedartists.com
[7]
Harbison, S.P. & Steele, G.L. (2002). C: A Reference Manual (5th Edition). Prentice
Hall.
[8]
Yiu, J. (2007). The Definitive Guide to the ARM Cortex-M3. Oxford, UK: Newnes.
[9]
Yiu, J. (2011). The Definitive Guide to the ARM Cortex-M0. Oxford, UK: Newnes.
[10] ARM Cortex-M3 Technical Reference Manual. Revision: r2p0. (ARM DDI 0337G).
http://infocenter.arm.com/help/index.jsp
[11] ARM Cortex-M0 Technical Reference Manual. Revision: r1p0. (ARM DDI 0413D).
http://infocenter.arm.com/help/index.jsp
[12] ARMv7-M Architecture Reference Manual (ARM DDI 0403)
http://infocenter.arm.com/help/index.jsp
[13] ARMv6-M Architecture Reference Manual (Cortex-M0/LPC11)
http://infocenter.arm.com/help/index.jsp
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
46 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
8. Legal information
NXP Semiconductors products in such equipment or applications and
therefore such inclusion and/or use is at the customer’s own risk.
8.1 Definitions
Draft — The document is a draft version only. The content is still under
internal review and subject to formal approval, which may result in
modifications or additions. NXP Semiconductors does not give any
representations or warranties as to the accuracy or completeness of
information included herein and shall have no liability for the consequences
of use of such information.
8.2 Disclaimers
Limited warranty and liability — Information in this document is believed to
be accurate and reliable. However, NXP Semiconductors does not give any
representations or warranties, expressed or implied, as to the accuracy or
completeness of such information and shall have no liability for the
consequences of use of such information.
In no event shall NXP Semiconductors be liable for any indirect, incidental,
punitive, special or consequential damages (including - without limitation lost profits, lost savings, business interruption, costs related to the removal
or replacement of any products or rework charges) whether or not such
damages are based on tort (including negligence), warranty, breach of
contract or any other legal theory.
Notwithstanding any damages that customer might incur for any reason
whatsoever, NXP Semiconductors’ aggregate and cumulative liability
towards customer for the products described herein shall be limited in
accordance with the Terms and conditions of commercial sale of NXP
Semiconductors.
Right to make changes — NXP Semiconductors reserves the right to make
changes to information published in this document, including without
limitation specifications and product descriptions, at any time and without
notice. This document supersedes and replaces all information supplied prior
to the publication hereof.
Applications — Applications that are described herein for any of these
products are for illustrative purposes only. NXP Semiconductors makes no
representation or warranty that such applications will be suitable for the
specified use without further testing or modification.
Customers are responsible for the design and operation of their applications
and products using NXP Semiconductors products, and NXP
Semiconductors accepts no liability for any assistance with applications or
customer product design. It is customer’s sole responsibility to determine
whether the NXP Semiconductors product is suitable and fit for the
customer’s applications and products planned, as well as for the planned
application and use of customer’s third party customer(s). Customers should
provide appropriate design and operating safeguards to minimize the risks
associated with their applications and products.
NXP Semiconductors does not accept any liability related to any default,
damage, costs or problem which is based on any weakness or default in the
customer’s applications or products, or the application or use by customer’s
third party customer(s). Customer is responsible for doing all necessary
testing for the customer’s applications and products using NXP
Semiconductors products in order to avoid a default of the applications and
the products or of the application or use by customer’s third party
customer(s). NXP does not accept any liability in this respect.
Export control — This document as well as the item(s) described herein
may be subject to export control regulations. Export might require a prior
authorization from competent authorities.
8.3 Trademarks
Notice: All referenced brands, product names, service names and
trademarks are property of their respective owners.
Suitability for use — NXP Semiconductors products are not designed,
authorized or warranted to be suitable for use in life support, life-critical or
safety-critical systems or equipment, nor in applications where failure or
malfunction of an NXP Semiconductors product can reasonably be expected
to result in personal injury, death or severe property or environmental
damage. NXP Semiconductors accepts no liability for inclusion and/or use of
LPCXpresso
User guide
All information provided in this document is subject to legal disclaimers.
Rev. 11.1 — 1 December 2011
© NXP B.V. 2011. All rights reserved.
47 of 48
LPCXpresso
NXP Semiconductors
Getting started with NXP LPCXpresso
9. Contents
1.
1.1
1.2
1.3
1.4
1.5
1.6
2.
3.
3.1
3.2
3.3
4.
4.1
4.1.1
4.1.2
4.1.2.1
4.2
5.
5.1
5.2
6.
6.1
6.2
6.2.1
6.2.2
6.2.3
6.2.4
6.2.5
6.2.6
6.3
6.4
6.4.1
6.4.2
6.5
6.6
6.6.1
6.6.2
7.
7.1
7.2
7.3
Introduction .........................................................3
LPCXpresso 4 new features...............................4
LPCXpresso IDE ................................................4
LPCXpresso development board .......................5
LPC-LINK JTAG/SWD debugger .......................6
Integrated evaluation target................................6
LPCXpresso partners .........................................6
Evaluate, explore and develop ...........................7
Installation ...........................................................8
System requirements .........................................8
Installation process ............................................8
Activation..........................................................10
Getting familiar with the LPCXpresso IDE ......11
Layout of the LPCXpresso desktop..................11
Single perspective (code development) ...........12
Single perspective (debug)...............................13
Peripheral views...............................................14
Connecting the target .......................................15
Examples: Download, build, download and
debug .................................................................16
Downloading NXP sample code from the web .16
Debugging/running ‘blinky’ or another project on
your LPCXpresso board ...................................19
LPCXpresso IDE tips and tricks.......................22
Installing Eclipse plugins ..................................22
Debugging tips .................................................22
Debug features not enabled .............................22
Error launching Debug\filename.axf .................22
Optimization issues ..........................................23
Displaying assembly instructions .....................23
Exiting debug mode and stopping debugging ..23
Recovery of board............................................23
Datasheet browser ...........................................24
Code size .........................................................24
printf .................................................................24
Optimization .....................................................25
Showing hidden views......................................25
Creating a ‘skeleton’ project in a new Workspace
.........................................................................26
Create a new Workspace .................................26
Create the ‘Skeleton’ project ............................26
Appendix ............................................................30
LPCXpresso target side schematics ................30
LPCXpresso PCB pinout and dimensions ........43
Enabling USB connectivity “to LPC1343 target”
.........................................................................43
7.4
Terminology......................................................45
References........................................................................46
8.
Legal information ..............................................47
8.1
Definitions.........................................................47
8.2
Disclaimers.......................................................47
8.3
Trademarks ......................................................47
9.
Contents .............................................................48
Please be aware that important notices concerning this document and the product(s)
described herein, have been included in the section 'Legal information'.
© NXP B.V. 2011.
All rights reserved.
For more information, please visit: http://www.nxp.com
For sales office addresses, please send an please send an email to:
[email protected]
Date of release: 1 December 2011
Document identifier: LPCXpresso
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement