Equivalent Layer corrections (T36)

INTREPID User Manual
Library | Help | Top
Equivalent Layer corrections (T36)
1
| Back |
Top
Equivalent Layer corrections (T36)
The Equivalent Layer tool, now in beta release and supplied with INTREPID, can
perform
•
Height corrections for a survey, smoothing the undulations in the flight path, and
•
Reduction to the pole at any latitude.
Before using the Equivalent Layer tool, you must use the Wiener Kernels tool to
calculate a Wiener convolution kernel for the process you are carrying out.
Stages in the Equivalent Layer process
The Equivalent Layer tool can be used to correct a line dataset Z field or a grid
dataset.
There are three stages in the process
1
(Using the Wiener Kernels tool) Produce a Wiener kernel for the process.
2
(Using the Equivalent Layer tool) Create an equivalent layer grid corresponding
to the dataset and the corrections specified. This represents a smooth surface
located between the terrain and the flight surface.
3
(Using the Equivalent Layer tool) Use the equivalent layer grid created in stage 2
to produce a corrected line dataset Z field or grid dataset.
Using the Equivalent Layer tool
>> To use Equivalent Layer with the INTREPID graphic user interface,
including creating a Wiener kernel for the process
Stage 1—Calculating the Wiener kernel
Library | Help | Top
1
Choose Wiener from the Filtering menu in the Project Manager, or use the
command wiener.exe. INTREPID displays the Wiener Kernels tool window.
2
If you have previously prepared file specifications and parameter settings for
Wiener Kernels, load the corresponding task specification file using Load Options
from the File menu. (See Specifying input and output files for detailed
instructions.) If all of the specifications are correct in this file, go to step 9. If you
wish to modify any settings, carry out the following steps as required.
© 2012 Intrepid Geophysics
| Back |
INTREPID User Manual
Library | Help | Top
3
Equivalent Layer corrections (T36)
2
| Back |
These instructions for the beta version of this tool apply only to height corrections
and reduction to the pole corrections in magnetic datasets.
Choose Magnetics from the Options menu.
INTREPID displays the Magnetic Source Properties dialog box.
4
Specify the parameters according to your requirements.
Susceptibility Set this parameter to 1. You do not need to change Susceptibility for
height corrections or reduction to the pole.
Inducing field strength (nT) Set this parameter to the correct Earth's core
magnetic field intensity for the location of the dataset and survey date.
Inducing field azimuth (degrees) Set this parameter to the correct Earth's core
magnetic field azimuth (declination) for the location of the dataset and survey
date.
Inducing field inclination (degrees) Set this parameter to the correct Earth's core
magnetic field inclination for the location of the dataset and survey date.
5
Library | Help | Top
Specify the Geometry parameters. Choose Geometry from the Geometry menu.
© 2012 Intrepid Geophysics
| Back |
INTREPID User Manual
Library | Help | Top
Equivalent Layer corrections (T36)
3
| Back |
INTREPID displays the Geometry dialog box.
6
Specify the parameters as required and choose OK.
Output kernel—No of cells along side of filter kernel Use this to specify the size
of the Wiener kernel. The default size is 15 x 15 coefficients. Specify different
value if required.
Calculation grid—size of grid cell (m) Use this to specify the cell size for the
equivalent layer grid.
If you are processing a line dataset, specify the same or a slightly larger cell size
for the grid as you would if you were gridding the line dataset. The size you
choose has a major effect on the calculation time. We recommend that you make
it as large as is reasonable for the desired data resolution.
If you are processing a grid dataset, set the grid cell size the same as that of the
input grid.
Calculation grid—Height of grid above top of prism (m) Use this to specify the
distance of the equivalent layer grid below the original survey height. We
recommend a height 2/3 of nominal ground clearance.
Calculation grid—No of cells along side of grid Use this to specify the size of the
matrix within which the Equivalent Layer calculation takes place. For a 15 x 15
cell Wiener kernel we recommend a setting of 101. For different sized Wiener
kernels, modify the setting proportionally.
Known Prism—Prism width (m) Use this to specify the of the model used in the
generation of the Wiener kernel. It must be an odd multiple of the equivalent
layer grid cell size. We recommend a setting of three times the grid cell size.
Known Prism—Prism depth extent (m) Use this to specify the thickness of the
equivalent layer. We recommend a Prism Depth of 0.1 of the equivalent layer grid
cell size.
7
If you wish to save any intermediate results for checking the process, turn on the
check box(es) corresponding to the results you wish to save.
Save Auto-Correlation Matrix Use this to save the auto-correlation matrix used in
the process. INTREPID will save it as a text file called autocorr.obs.
Save Cross-Correlation Matrix Use this to save the cross-correlation matrix used
in the process. INTREPID will save it as a text file called croscorr.obs.
Library | Help | Top
© 2012 Intrepid Geophysics
| Back |
INTREPID User Manual
Library | Help | Top
Equivalent Layer corrections (T36)
4
| Back |
Save Filtered Known Input Use this to save the Filtered Known Input, a matrix of
size equal to the number of cells along side of calculated grid (See Step 6 above).
INTREPID saves the matrix as a text file called filt.obs. If the points above
the prism are close in value to the Susceptibility (See step 3 above) and the points
not over the prism are close to 0, this indicates that the filter response will be
close to your desired results.
8
Specify a file name for the Wiener kernel you have specified. Choose Save As from
the File menu and specify a name for the Wiener kernel. Save the kernel in the
project directory (the same directory as the input grid dataset or the input line
dataset marker (..DIR) file. INTREPID will automatically add the extension
.ker to the file name.
9
When you are satisfied that all specifications are as required, choose Apply.
10 If you wish to record the specifications for this process in a .job file in order to
repeat a similar task later or for some other reason, use Save Options from the
File menu. (See Specifying input and output files for detailed instructions.)
11 Exit from the Wiener kernels tool. Choose Quit from the File menu.
Stage 2—Calculating the equivalent layer grid
12 Launch the Equivalent Layer tool. Choose Equivalent Layer from the Filtering
menu in the Project Manager, or use the command slayer.exe. INTREPID
displays the Equivalent Layer window.
13 If you have previously prepared file specifications and parameter settings for
stage 2 or stages 2 and 3 of the Equivalent Layer process, load the corresponding
task specification file using Load Options from the File menu. (See Specifying
input and output files for detailed instructions.)
14 If all of the specifications are correct in this file, go to step 24. If you wish to
modify any settings, carry out the following steps as required.
Library | Help | Top
© 2012 Intrepid Geophysics
| Back |
INTREPID User Manual
Library | Help | Top
Equivalent Layer corrections (T36)
5
| Back |
15 Specify the grid dataset or line dataset Z field you wish to process using the
Equivalent Layer tool. Use Load Field as Line Dataset or Load Field as Grid
Dataset as required from the File menu. (See Specifying input and output files for
detailed instructions.)
16 If any of the following fields or grids are available for use with the process and you
wish to use them, choose the corresponding option from the File menu and specify
the grid band or line dataset field required. (See Specifying input and output files
for detailed instructions.)
•
Platform Height for Line Dataset
•
Ground Clearance for Line Dataset
•
Platform Height for Grid Dataset
17 The File menu currently contains a Specify Constant Platform Height option
which has an associated dialog box. The default value of this parameter is 0. We
recommend that you leave this option as it is.
18 Load the Wiener kernel for the process, using Load Wiener Kernel from the File
menu. (See Specifying input and output files for detailed instructions.)
19 Equivalent Layer requires an extrapolated edge region to be added around the
equivalent layer grid. You can specify the method INTREPID uses for
extrapolating data in the edge region. See "Creating the extended region for
filters" in INTREPID spatial and time domain filters and transformations (R13)
for a discussion of edge regions. Turn on the check box corresponding to the
method you require. We recommend that you use the Reflect Data Into Edges
method.
Extrapolate Smoothly Into Edge INTREPID extrapolates values for the edge
region from the original values in the grid.
Reflect Data Into Edges This method corresponds the Flipped Mirror Pad method
described in INTREPID spatial and time domain filters and transformations
(R13). We recommend this method for general use.
Taper to Zero at Edges INTREPID tapers the values at the edge of the grid so that
the values at the outside edge of the edge region are zero. We recommend this
method only for testing purposes.
20 Select the degree of detrending for the grid used in the process by turning on the
corresponding Detrend Degree check box. We recommend that you use detrend
degree 1 unless you have a specific reason for doing otherwise.
Library | Help | Top
© 2012 Intrepid Geophysics
| Back |
INTREPID User Manual
Library | Help | Top
Equivalent Layer corrections (T36)
6
| Back |
21 Specify the options for the process, using Options from the Options menu.
INTREPID displays the Source Layer Control Options dialog box.
22 Specify the options as required and choose OK
Number of Iterations Use this to specify the number of times for INTREPID to
apply the Wiener kernel to the grid. A larger number of iterations will produce a
smoother result.
Smoothing With each iteration of the Equivalent Layer process INTREPID
performs a moving average smoothing process. Use the Smoothing parameter to
specify the starting smoothing factor. INTREPID decreases this factor with each
iteration. We recommend a value of 11 for this parameter.
Field inclination to be used when recalculating Use this to specify the desired
field inclination for the results of the Equivalent Layer process.
If you are using the process to perform reduction to the pole, set the desired
inclination to 90.
If you are not performing reduction to the pole, set the desired inclination to the
correct Earth's core magnetic field inclination for the survey. This will be the
same setting that you specified for ‘Inducing field inclination (degrees)’ in the
Wiener Kernels tool above.
23 Specify the output layer grid using Specify Output Layer Grid from the File menu.
(See Specifying input and output files for detailed instructions.)
24 When you are satisfied that all input, output and parameter specifications are as
required, choose Apply.
25 If you wish to record the specifications for stage 2 of the process in a .job file in
order to repeat a similar task later or for some other reason, use Save Options
from the File menu. (See Specifying input and output files for detailed
instructions.)
Stage 3—Calculating the corrected grid or Z field (Recalculation)
26 If you loaded a task specification file in step 13 above and all of the specifications
are correct in this file for stage 3 of the process, go to step 30. If you wish to
modify any settings, carry out the following steps as required.
27 If you have previously prepared file specifications and parameter settings for
stage 3 of the Equivalent Layer process, load the corresponding task specification
file using Load Options from the File menu. (See Specifying input and output files
for detailed instructions.)
Library | Help | Top
© 2012 Intrepid Geophysics
| Back |
INTREPID User Manual
Library | Help | Top
Equivalent Layer corrections (T36)
7
| Back |
28 Specify the layer grid that you created in stage 2 (Specified in step 23), using Load
Layer Grid for Recalculation from the File menu. (See Specifying input and
output files for detailed instructions.)
29 Specify the Z field or grid for the corrected values resulting from the Equivalent
Layer process. Use Save Recalculated Values from the File menu. (See
Specifying input and output files for detailed instructions.)
30 When you are satisfied that all input, output and parameter specifications are as
required, choose Recalculate.
31 If you wish to record the specifications for stage 3 or stages 2 and 3 of the process
in a .job file in order to repeat a similar task later or for some other reason, use
Save Options from the File menu. (See Specifying input and output files for
detailed instructions.)
32 To exit from Equivalent Layer, choose Quit from the File menu.
___
To view the current set of specifications choose Show from the Equivalent Layer
window. INTREPID displays them in a separate window. (See Displaying options
and using task specification files for details and an example of a set of specifications.)
You can view Help information by choosing options from the Help menu (See Help
below).
You can execute Equivalent Layer as a batch task using a task specification (.job)
file that you have previously prepared. See Displaying options and using task
specification files for details.
Performing stages 2 and 3 in separate sessions
You can perform stages 2 and 3 in separate Equivalent Layer sessions. This may be
useful for line datasets, which require large quantities of processing time.
>> To perform stage 2 only
Exit from equivalent layer at the end of stage 2.
>> To perform stage 3 only in a separate session after successful completion
of stage 2
Library | Help | Top
1
Carry out (repeat) stage 2 omitting steps 23–25.
2
Carry out stage 3.
© 2012 Intrepid Geophysics
| Back |
INTREPID User Manual
Library | Help | Top
Equivalent Layer corrections (T36)
8
| Back |
Specifying input and output files
To use Equivalent Layer, you will need to specify some or all of the following files
File
Required/
Optional
Used in
stage 2
Used in
stage 3
Line dataset Z field or grid dataset for
correction
Required
YES
YES
Platform height line dataset field or grid
dataset
Optional
YES
YES
Ground clearance line dataset field (not
available for grid datasets process)
Optional
YES
YES
Wiener kernel
Required
YES
YES
Layer grid (output)
Required
YES
Layer grid (input)
Required
YES
Corrected line dataset Z field or grid dataset
(output)
Required
YES
Choose the options as required from the File menu.
In each case INTREPID displays an Open or Save As dialog box. Use the directory
and file selector to locate the file you require. (See "Specifying input and output files"
in Introduction to INTREPID (R02) for information about specifying files).
Line dataset note: INTREPID will need to obtain information from the dataset
aliases. The dataset must have aliases identifying appropriate field files as follows.
Alias
Field
X
X coordinate (location)
Y
Y coordinate (location)
See "Vector dataset field aliases" in INTREPID database, file and data structures
(R05) for more information about aliases.
Library | Help | Top
© 2012 Intrepid Geophysics
| Back |
INTREPID User Manual
Library | Help | Top
Equivalent Layer corrections (T36)
9
| Back |
Load Field as Line Dataset If you are correcting a line dataset, use this to specify
the Z field that is to be corrected. If you are using the Windows version, select a
field marker file with the extension ..LINE from inside the line dataset directory.
Load Field as Grid Dataset If you are correcting a grid dataset, use this to specify
the grid band that is to be corrected. If you are using the Windows version, select
a field marker file with the extension ..GRID.
Load Platform Height as Line Dataset If you are correcting a line dataset and a
height field is available (usually the GPS height data), use this to specify the
survey height field. If you are using the Windows version, select a field marker file
with the extension ..LINE from inside the line dataset directory.
Load Ground Clearance as Line Dataset If you are correcting a line dataset and a
ground clearance field is available (usually the Radar Altimeter data), use this to
specify the clearance field.
INTREPID will use this to detect places where the equivalent layer intersects the
terrain (out of bounds errors). It will report a list of equivalent layer grid cells
where this intersection occurs. The report is a text file called oobe.txt.
If you are using the Windows version, select a field marker file with the extension
..LINE from inside the line dataset directory.
Load Platform Height as Grid Dataset If you are correcting a grid dataset and a
survey height grid (e.g., GPS height) is available, use this to specify the grid. If
you are using the Windows version, select a field marker file with the extension
..GRID.
Load Wiener Kernel Use this to specify the Wiener kernel (.ker) file for this
process.
Specify Output Layer Grid Use this to specify a dataset name for the equivalent
layer grid which is the result of stage 2 of the process.
Load Layer Grid for Recalculations Use this to specify the equivalent layer grid
which resulted from stage 2 of the process, and becomes an input for stage 3 of the
process.
Save Recalculated Values Use this to specify the corrected line dataset Z field or
the corrected grid dataset which is the result of stage 3 of the Equivalent Layer
process
Load Options If you wish to use an existing task specification file to specify the
Equivalent Layer process, use this menu option to specify the task specification
file required. INTREPID will load the file and use its contents to set all of the
parameters for the Equivalent Layer process. (See Displaying options and using
task specification files for more information).
Save Options If you wish to save the current Equivalent Layer file specifications
and parameter settings as an task specification file, use this menu option to
specify the filename and save the file. (See Displaying options and using task
specification files for more information.)
Apply
After you have specified the Equivalent Layer task, choose Apply. INTREPID will
perform the task and save the results.
Help
You can use the Help menu to display help text.
Library | Help | Top
© 2012 Intrepid Geophysics
| Back |
INTREPID User Manual
Library | Help | Top
Equivalent Layer corrections (T36)
10
| Back |
Exit
To exit from Equivalent Layer choose Quit from the File menu.
Displaying options and using task specification files
Displaying options
>> To display the current file specifications and parameter settings
Choose Show in the Equivalent Layer window. INTREPID displays the current
options in a separate report window.
Using task specification files
You can store sets of file specifications and parameter settings for Wiener Kernels or
Equivalent Layer in task specification (.job) files.
>> To create a task specification file with the Wiener Kernels or Equivalent
Layer tool
1
Specify all files and parameters.
2
Preferably execute the task (choose Apply) to ensure that it will work.
3
Choose Save Options from the File menu. Specify a task specification file
(INTREPID will add the extension .job) INTREPID will create the file with the
settings current at the time of the Save Options operation.
For full instructions on creating and editing task specification files see INTREPID
task specification (.job) files (R06).
>> To use a task specification file in an interactive Wiener Kernels or
Equivalent Layer session
Load the task specification (.job) file (File menu, Load Options), modify any settings
as required, then choose Apply.
>> To use a task specification file for a batch mode Wiener Kernels or
Equivalent Layer task
Type the command wiener.exe or slayer.exe with the switch –batch followed by
the name of the task specification file.
For example, if you had an Equivalent Layer task specification file called
surv329.job in the current directory you would use the command
slayer.exe –batch surv329.job
Library | Help | Top
© 2012 Intrepid Geophysics
| Back |
INTREPID User Manual
Library | Help | Top
Equivalent Layer corrections (T36)
11
| Back |
Task specification file example
Here is an example of a Wiener Kernels task specification file.
Process Begin
Name = wiener
SaveKernel = height_eba
Parameters Begin
rho_air = 1.293
rho_ground = 2200.0
mu_air = 0.00526
mu_ground = 0.00528
xa = 1.0
eps = 1.0
N = 1.0
susc = 1.0
h = 55000.0
az = 0.0
inc = -55.0
xSize = 550.0
ySize = 550.0
zSize = 1000.0
dxGrid = 50.0
dyGrid = 50.0
htGrid = 70.0
nxGrid = 101
nyGrid = 101
xDimK = 15
yDimK = 15
Mode = Magnetic
Parameters End
Process End
Equivalent Layer task specification files will be available soon.
Library | Help | Top
© 2012 Intrepid Geophysics
| Back |
Download PDF