LifeView User Manual
Document Date: 2015-07-21
Author: M.H
Contents
Contents
1 INTRODUCTION ................................................................................................................ 2
2 FILES .................................................................................................................................. 3
2.1 LOAD/IMPORT................................................................................................................ 3
2.2 SAVE/EXPORT ................................................................................................................ 4
2.3 WORKING DIRECTORY ...................................................................................................... 5
3 GRAPH............................................................................................................................... 8
3.1
3.2
3.3
3.1
3.2
NAVIGATION .................................................................................................................. 9
CHANNELS ................................................................................................................... 10
MATH......................................................................................................................... 12
LAP MODE .................................................................................................................. 13
MULTIPLE FILES ............................................................................................................ 14
4 WORKSHEET ................................................................................................................... 15
4.1 GRAPHS ...................................................................................................................... 15
4.2 REPORTS ..................................................................................................................... 15
4.2.1 Lap Report ......................................................................................................... 15
4.2.2 XY Plot .............................................................................................................. 16
4.2.3 Histogram .......................................................................................................... 17
4.2.4 2D Histogram ..................................................................................................... 18
4.1 TRACK MAP ................................................................................................................. 18
5 OPTIONS ......................................................................................................................... 20
5.1
5.2
5.3
5.4
5.5
SESSION ...................................................................................................................... 20
TOGGLE OPTIONS.......................................................................................................... 21
CURSOR OPTIONS ......................................................................................................... 22
CONCATENATED FILE OPTIONS ........................................................................................ 22
GLOBAL OPTIONS.......................................................................................................... 23
6 DOCUMENT REVISION HISTORY .................................................................................... 24
© Life Racing Ltd
Page 1 of 24
Introduction
1 Introduction
LifeView is a data viewing application. Downloaded .LRD files can be analysed here with the
use of intelligent visual representation.
Due to continuous development, some features may change and this manual will update
periodically. Please ensure you have the latest version dated on the cover page of this
document.
Information Panel
The Information Panel is displayed at the bottom of the screen and can be toggled with the
<F1> key. It displays:
File location, name, time stamp and size
ECU serial number, Calibration and code levels
No of laps and fastest lap
Saved comments
Highlighted channel
name, frequency, unit
and unit group
Highlighted
channel
burst logging
state
Menu Shortcuts
Life Racing applications are intended for quick operation without the use of a mouse for
improved usability in the pit lane. All menu buttons can therefore be reached using keyboard
shortcuts. Each option has an underlined letter, identifying its shortcut key or the shortcut
displayed to the left. Dialogue boxes can be navigated with the arrow keys. The <Spacebar> can
be used to select while <Enter> and <Esc> are used as OK and CANCEL respectively.
© Life Racing Ltd
Page 2 of 24
Files
2 Files
2.1 Load/Import
.LRD
To load data, select File, Load and locate the chosen file. File name and size is displayed as well
as a time bar that shows the timing in comparison to other files in the same folder. Time bars
will alternate in colour for different sessions determined by the time difference between them.
Highlight a file to display further details including device details, lap details and any comments.
Multiple files can be opened at once and stitched together (concatenated) in the software with
or without time gaps. This is done using the <Shift> key to select consecutive files. A dashed
line in the graphical display indicates the beginning of a new data set.
Select File, Load anOther to overlay multiple files on the same display to allow comparisons.
Overlaid files can also be concatenated.
.CSV
LifeView can be used to view data from other sources by importing a comma separated .csv
file. This can be useful in instances such as comparing real data to imported simulation.
This is done under File, Import CSV. Select the file and define the ‘time’ field as well as all fields
that are to be imported. Imported files must have a time field to use as an x-axis reference. Files
are imported alongside currently open files to allow overlays.
There is some limited functionality as special channels cannot be configured outside of an LRD
file. Channels can however still make full use of math functions and graphical representation.
© Life Racing Ltd
Page 3 of 24
Files
.LB
LifeView can also be used to view and export .LB logbook files. To view these select File, Load
logbook and select the folder location. This will load all .LB files in the selected folder. These
can be viewed as an overall record or as a per run entry.
The Comment option is unavailable in LifeView as logbook comments cannot be edited once
the .LB has been downloaded. Comments can only be added to a logbook whilst it remains in
an ECU. This can only be done when connected in LifeCal or LifeData.
Select Export to save a text file containing the currently displayed information, whether it is
the overall record or an individual run.
Select exportAll for a text file including all runs and the overall record.
Select Run Sheet for a tab delaminated text file containing every run. This is the easiest
exportation for loading in another program.
Selecting change Units will change the units of the entire unit group. Note that this change will
also affect normal LifeView channels.
2.2 Save/Export
Save
Saving a file will allow concatenated files to be permanently saved as a single file and any
annotations or comments stored. To save, select File, Save, then CREATE for a new folder in the
current location or SELECT to confirm the current folder as the desired location and then enter
a new filename.
Select Rename to overwrite the current file with a new name. Default filename contains date
and time at engine start, plus time to beginning of logging, ECU serial number and working
directory stamp.
Select save as Logging conFig to retrieve an .LRL file with the original logging configuration.
This is useful when the original file is lost or unavailable.
© Life Racing Ltd
Page 4 of 24
Files
Export
Exporting a file will only export the selected channels in the visible time frame. Use zoom to
Selection to select this time frame. Select File, export To, to export data as a text file (.txt or .csv)
or as an LRD file under the same security as the original file or as an unprotected generic file.
Print
Select File Print to print the current display including cursor location and values.
2.3 Working Directory
The working directory is maintained across all Life Racing applications and can be edited in
LifeCal, LifeCfg, LifeData, LifeView and PduSetup. To change the current working directory
select Working directory under File. Use CREATE to create a new folder in the current location.
Use SELECT to select the current location as the new working directory. If the location has not
been used before, a .CFG file will be created. Selecting Working Dir Behaviour allows editing of
the .CFG file.
Devices that have been previously connected to are automatically added to the known devices
list. They can also be manually added or imported from another working directory with the
appropriate buttons. The ECU name will be used as a folder name if device directory is used.
The suffix is included in file names.
Directories can be altered individually for calibrations, downloaded data and logging setup
files. Tick Use directory per device to separate files by ECU. Tick Use directory per session to use
either the date sub directory or a custom sub directory. A date sub directory will automatically
update and add folders when new data is downloaded.
© Life Racing Ltd
Page 5 of 24
Working Directory
Working Directory
Files
Calibrations
Dash
.LB
DownloadedData
.LRD
LoggingSetup
PDUSetup
Calibrations
.LB
ECU #1
Dash
DownloadedData
LoggingSetup
.LRD
ECU #2
.LB
.LRD
PDUSetup
© Life Racing Ltd
Page 6 of 24
Working Directory
Files
Calibrations
Session Sub
Directory 1
Dash
DownloadedData
.LB
.LRD
Session Sub
Directory 2
LoggingSetup
.LB
.LRD
PDUSetup
.LB
ECU #01
.LRD
Working Directory
Session Sub
Directory 1
ECU #02
Calibrations
.LB
.LRD
Dash
DownloadedData
Session Sub
Directory 2
.LB
ECU #01
.LRD
LoggingSetup
ECU #02
.LB
PDUSetup
.LRD
© Life Racing Ltd
Page 7 of 24
Graph
3 Graph
The graph is the primary display tool. It plots selected channels across the duration of the
session by either distance or time (Toggled in the Options menu).
A cursor is used to navigate the data. Above the graph, numerical values at the current cursor
location are given for time, distance and the selected channel. Placing a marker will also give
delta values between the marker and cursor locations.
Optional visual aids include a crosshair at the highlighted channel data point, an average value
or the minimum and maximum values for the visible data and more. These can be toggled in
the Options menu.
Annotations will appear as dashed vertical lines at the selected sample location. Hover the
mouse over these to display the text.
© Life Racing Ltd
Page 8 of 24
Graph
3.1 Navigation
The graphical area is designed to allow quick and easy navigation of potentially large amounts
of data. Both the keyboard and mouse can be used individually or together to achieve this.
Mouse
Left Click
Right Click
Left Drag
Right Drag
Scroll
Ctrl Scroll
Double Click
Drag Y-Axis
Ctrl Drag Y-Axis
Shift Drag Y-Axis
Keyboard
<Left>
<Right>
[
]
<
>
<F6>
<F7>
<Ctrl> + <Left>
<Ctrl> + <Right>
<Shift> + <Left>
<Shift> + <Right>
<Plus>
<Minus>
<Ctrl> + <Plus>
<Ctrl> + <Minus>
<Tab>
<Space>
<Backspace>
Place cursor
Place marker
Move cursor
Zoom to selection
Zoom X-axis
Zoom Y-axis
Add/edit annotation
Move axis maximum
Move axis minimum
Move entire axis
Move accelerating cursor to left
Move accelerating cursor to right
Move cursor left to previous different value
Move cursor right to next different value
Move cursor to previous alarm position
Move cursor to next alarm position
Move cursor to minimum visible value
Move cursor to maximum visible value
Move cursor to left by 10% of screen
Move cursor to right by 10% of screen
Accelerating scroll to left
Accelerating scroll to right
Zoom in X-axis
Zoom out X-axis
Zoom in Y-axis
Zoom out Y-axis
Toggle graph focus when multiple graphs are open
Place marker
Remove marker
The Zoom menu can also be utilised with its shortcuts to Zoom To Selection, Zoom Previous or
Zoom Right Out.
Certain options such as cursor acceleration and right click zooming can be toggled, depending
on user preference when navigating.
© Life Racing Ltd
Page 9 of 24
Graph
3.2 Channels
Channels include all monitoring items and added math functions. These are displayed in the
‘Key’, to the right of the graphical display. The Key has two modes of operation, selectable in
the options menu. The normal mode shows all the channels in a data file. It gives the value of
each channel at the current cursor position. Channels that are shown in one of the graphs also
have a colour tab to show their respective trace colours. The alternative mode only shows those
channels displayed in the graphical display area. If more than one graph is displayed, there will
be separated lists for each. The information panel will display which file the highlighted
channel is from.
Key navigation uses a different set of shortcuts to graph navigation, allowing simultaneous use.
<Up>
<Down>
<Page Up>
<Page Down>
<Return>
<Right Shift>
<Delete>
Up one channel
Down one channel
Up page of channels
Down page of channels
Add/Remove channel on focus graph
Toggle between data files when more than one loaded
Remove math channel
The Channel menu displays the same options as right clicking a channel in the key:
Add
Add a channel to the active graph. Select from the list or begin typing the name of the desired
channel to shorten the list.
Remove
Remove the highlighted channel from the active graph.
Colour
Change the colour of the channels data trace. Tick remember to use the selected colour as
default for all files.
© Life Racing Ltd
Page 10 of 24
Graph
Scale
Auto scale sets the minimum and maximum scale values to the minimum and maximum found
in the data.
Set scale allows custom minimum and maximum values. Tick the remember box to set the new
scale as default. Remember current scale can also be used.
The Scale can also be edited by right clicking the y-axis in the graph area.
Filter
Add a new trace containing the filtered values of the highlighted channel. This will not be
available for channels logged at 1Hz.
AlarMs
Set thresholds for the selected channel. Thresholds will be displayed as dashed lines at the set
values. When these values are exceeded, the channel will flash in the key. Alarms are only
monitored in the visible time frame.
Sample Average Limits
Set the upper and lower limits of values to be used in Averaged Samples Mode calculations.
Change Units
Change the display unit of all items in unit group. If a single unit change is desired, a math
channel can be used to achieve this. Note that units are universal across files and applications.
Edit Math
Open the math window for the selected math item.
Delete Math
Remove the math channel from the display and key.
© Life Racing Ltd
Page 11 of 24
Graph
3.3 Math
Math can provide a wide range of further data manipulation varying from simple scaling to
complex, multi-function expressions. Choose a new or existing maths expression from the Math
menu to open the Math Window. The Math window enables the adding and editing of math
channels. Once added, the math channels behave the same as data channels with the additional
right click options of editing and removing. Delete a maths expression by highlighting it and
pressing the <Delete> key on the keyboard.
Name
Create a channel name for your maths channel. Must not contain these characters:
Full Stop
Forward slash
Back slash
Colon
© Life Racing Ltd
.
/
\
:
Less than
More than
Vertical bar
Quotation marks
<
>
|
”
Page 12 of 24
Graph
Expression
Type your maths expression here. Expressions can include any monitoring item or other maths
channel. Take care when adding channels as they are case sensitive. Error hints will appear
when the expression is invalid. Right click this box to cut, copy or paste.
Functions
This list contains all functions available in alphabetical order. Highlighting a function will
display an explanation. Double clicking or using the <Space> bar will paste the function into
your expression.
The full list of functions and details on how they are used can be found in the Math Manual,
available for download from www.liferacing.com under Support, User Manuals/Datasheets.
Units
Select the unit group and unit that the result will be outputted in. This will display on the y axis
label.
Auto Scaling
Tick box to enable auto scaling or type custom min max values for y axis. Auto scale will use
the max and min values of results as the scale max and min.
Dec Places
Type the number of decimal places to be displayed in results. This is a visual option only and
does not affect calculation accuracy.
Auto Sample Rate
Tick box for automatic sample rate. This will use the highest sample rate of the items used in
the expression. It will also follow burst logging rates. For custom sample rate, type in the box
how many times a sample should be taken in a second.
User Sample Offset
Maths channels can create delays when referencing multiple points. Sample offset allows the
shifting of data by the typed number of samples. Number of samples must be less than sample
rate.
3.1 Lap Mode
Lap mode causes the program to treat the selected lap as an entire file and will temporarily
display only the selected lap. Select any lap from the Lap menu to enter lap mode. From the
same menu, any other lap can be displayed or lap mode switched off. This is most useful when
multiple files are open. If properly overlaid, a lap can be selected from one dataset while the
other does not change, allowing easy lap comparisons.
© Life Racing Ltd
Page 13 of 24
Graph
3.2 Multiple Files
The load anOther option in the File menu allows multiple sets of data to be compared on the
same display. The key will display each data set in separate columns with a differing colour
assigned to all of its items by default (Can be switched off in Options). Hold the left <Shift> key
and drag on the graphical display to offset an added file. Return any additional open files to
their original positions by selecting Session, Reset Offsets. Multiple files are easier to compare
in distance mode rather than time to account for the differing lap times.
© Life Racing Ltd
Page 14 of 24
Worksheet
4 Worksheet
A worksheet is a saved layout design including graphs, track maps, reports and active channels.
These can then be used with any future set of data. Worksheets are saved and opened in the
Worksheet menu. Save a new worksheet with Save and type a name, or an existing worksheet
with Overwrite. The worksheet set as default will be automatically used when a file is opened.
Others can be selected in the same menu with its numerical shortcut.
4.1 Graphs
Additional graphs can be added to worksheets under the Graph menu. Multiple graphs are
displayed vertically so they can share the same x-axis. Graphs can be resized but as they share
an x-axis will remain equal width. Selecting Graph, Tile will evenly distribute allocated height.
The active graph and channel in the active key (alternative key style) will be highlighted and
can be switched between with the <TAB> key.
4.2 Reports
Reports are added from the Report menu. A separate window will be opened where the report
can be edited. From here, reports can be printed, exported or docked in the worksheet.
Reports will only display information form the currently visible data so ensure the graph is
zoomed to the data range desired.
4.2.1 Lap Report
Lap reports display max min and average values for either displayed channels or all channels
across each lap. Select Dump to save a text file.
.
© Life Racing Ltd
Page 15 of 24
Worksheet
4.2.2 XY Plot
An XY plot allows any channel to be assigned to either axis to produce a scatter graph. Selecting
Report, XY Plot will open a new window with a blank plot.
Assign each axis with the relevant button. The XY axes can be swapped under Options,
Swap XY. Colours appear darker where data is more concentrated. Numerical values can be
seen for each axis in the bottom left hand corner.
A second Y-axis or a Z-axis can also be added. The second Y-axis will use the same scale as the
first but be displayed in a different colour. A Z-axis utilizes colour banding to display different
values.
© Life Racing Ltd
Page 16 of 24
Worksheet
The same channels from different files can be overlaid under Options, Toggle Overlay Mode.
Each file will display in a different colour. Select Reverse Overlay Order to change which file is
viewed on top. Overlay mode only works for a single Y-axis and no Z-axis.
The plot can be resized by either zooming or moving the scales in the same way as the main
graph. Right click the scales for more precise control. When data is highly magnified or when
there are fewer data points it is recommended that intensity is increased for easier viewing
under Options, Intensity. Colour can also be changed to greyscale with the Toggle Colour/Grey
option. This cannot be toggled when overlay or multiple Y-axes are being used.
Save an XY plot layout as a favourite to quickly reload them when required.
Select Print to print report, Dock to add report to the worksheet and OK to close.
4.2.3 Histogram
A histogram shows the percentage of time an item is within certain value ranges. Added items
will be displayed in the colour set in the Key. Item ranges and the number of ranges can be
altered with the appropriate buttons. Select Print to print report, Dock to add report to the
worksheet and OK to close. Once docked, the active range at the cursor location will be
highlighted.
© Life Racing Ltd
Page 17 of 24
Worksheet
4.2.4 2D Histogram
A 2 Dimensional Histogram shows percentages like the normal histogram but measures two
parameters. Each parameter can have its ranges individually altered by selecting that item.
Save commonly used items and ranges as favourites to quickly reload them when required.
Colours are graded for easier visualization. Select Copy to place the table values in the
clipboard. This can then be pasted into another application such as Microsoft Excel. Select OK
to close.
4.1 Track Map
A track map can be displayed to show the vehicle position throughout the data. The vehicle
icon will follow the map as the cursor is moved on the graph. Alternatively, the same icon can
be dragged around the map and the cursor will follow. The icon will change its appearance
when the vehicle is off track such as in the pits.
To add a track map to the worksheet, it can either be loaded or made under the TrackMap
menu. Track maps can be created from GPS coordinates or from distance and lateral G. Using
the latter method will require some fine tuning of the various options. All recorded GPS
positions will be displayed with the chosen lap emphasised. Calculated position will display the
chosen lap only. By default, the fastest lap is used.
© Life Racing Ltd
Page 18 of 24
Worksheet
GPS (Latitude/Longitude)
Distance/Lateral G
Right click on the screen to bring up beacon options. This allows additional beacons to be added
for sector times or the adding of an END beacon if the route is not a complete circuit.
Once a track has been loaded it can be added to any other worksheet quickly using Add instead
of load. Close the map by either selecting remove after right clicking or Close in the menu.
Select Save to dock and store the created map. Select OK to dock without saving. Once docked,
right click the map area to access display options or use the TrackMap menu.
Dynamic Remap (1)
Redraw the map for each lap, using the new data. GPS only.
Change Datum
Select the lap that time slip uses as its reference lap. Fastest lap is used by default.
Colour by TimeSlip
Colour by time slip from datum lap.
Colour by Item Value
Colour the map by any other item value.
TimeSlip Emphasis
Change the colour shift emphasis on the amount of time slip.
Rotate
Use the scroll bar or type an angle in degrees to rotate the map.
Print
Print an image of the track map as currently displayed, including car locations and applied
colours.
TimeSlip Sync
With this box ticked, the TimeSlip item channel will be synchronised with the map time slip.
When unchecked, a new datum for the map must be chosen as the channel and the map datum
will now be independent. Channel datum can be changed in the Channel menu.
© Life Racing Ltd
Page 19 of 24
Options
5 Options
5.1 Session
The Session menu contains options for the current open files.
Open Windows Explorer
Open file location in windows explorer.
Comment
Edit the Logfile comment.
Reset Offsets
Return any offsets of overlaid files.
GPS Preferences
Alter GPS offset time and filter rate for either the open file only or as defaults for all files.
Special Channels
Choose what monitoring items will be used as special channels. It is these channels that are
used to calculate vehicle position. Tick Remember to set as defaults.
Beacons
Select where to take beacon information from; the track map or data. When a track is created,
it stores the beacon position from the data plus any beacon alterations done. It is these that are
used by default.
File beacons can also be edited. They can be added, moved or removed completely with the
appropriate menu options. Alternatively, select make beacons persistent to overwrite the file
beacons with the map beacons.
copy Info to clipboard
Copy specific file information so that it can be pasted in another programme. If more than one
file is open, the active file (shown in the information panel) is used.
© Life Racing Ltd
Page 20 of 24
Options
5.2 Toggle Options
Toggle options are found under Options, All Toggle Options.
Time of day on X-axis
Display time of day or time into session.
Distance Mode
Toggle the X-axis between time and distance. Distance is often more useful when comparing
multiple data sets.
Interpolate Mode
Toggle between displaying raw or interpolated data. Interpolation fills the space between
data points with estimated values, creating a smoother look, particularly for low logging rates.
Note that this also changes values displayed.
Minimum Key Style Mode
Toggle between displaying all channels and displaying only active channels.
Show Item Names
Show active items in the top left corner of the graph display in their line colours.
All Min Max Mode
Toggle whether to show just the select channel max and min values or all active channels.
Bright Key
With bright key deactivated, any unused channels on display in the key will be dimmed.
Bold Focus Trace
The selected channel is always brought to the front of the display. This toggle will also cause
the selected channel to have a bolder trace than the others for clearer viewing.
Shared channel colour per session
With this selected, whenever additional files are overlaid, each file will be assigned a single
colour to all of its channels. If unselected, each file will display the same defaulted colours for
each channel.
© Life Racing Ltd
Page 21 of 24
Options
Average on Focus
Show the average of the selected channel in the visible period.
Averaged Samples Mode
Average samples mode will display only the average value for each channel in the visible area.
The most commonly used toggles are also available directly under the Options menu to allow
quick key presses.
Time/Distance Toggle
Interpolate Toggle
Key Style Toggle
5.3 Cursor Options
Cursor options are found under Options, Cursor Options.
Enable Cursor Acceleration
Continuously speed up cursor movement the longer an arrow key is held.
Limit Cursor Acceleration
Limit the cursor to a finite speed chosen with the scroll bar.
Channel Info Tooltip
Display channel name and value at the point the mouse cursor is hovering over.
Right Mouse Zooming
Allow or disable selection zooming by dragging with the right mouse button.
Cursor Crosshair
Toggle the horizontal crosshair. This line will follow the value of the selected channel at the
cursor time position.
Manual Cursor Crosshair
Crosshair follows mouse pointer rather than data values.
5.4 Concatenated File Options
Concatenated file options can be found under Options, Concatenated File Options.
Enable default concatenation actions
Enable to skip dialogue options during concatenation.
Preserve time gaps
Keep gaps between log files automatically.
Collapse time gaps
Eliminates gaps between log files automatically.
© Life Racing Ltd
Page 22 of 24
Options
5.5 Global Options
Black-on-White colour scheme
Toggle the colour scheme of all Life Racing applications between a white background and a
black background. The best option will be dependent on screen quality, ambient lighting and
user preference.
Colour Blind (yellow/green)
Changes fixed yellows to purple to aid with yellow/green confusion.
Reverse Folder Order (in file menu)
Folders are ordered alphabetically in the file menu. Tick this box to reverse this order.
Floating Mouse Focus (in dialogs)
Causes whatever the mouse pointer is hovering over to be highlighted as if it was selected with
the keyboard.
© Life Racing Ltd
Page 23 of 24
Document Revision History
6 Document Revision
History
15-07-21 – MH
© Life Racing Ltd
V1.0 – Initial public release
Page 24 of 24
Download PDF