FlukeView Forms - RS Components International

®
FlukeView Forms
Documenting Software
Users Manual
September 2000
© 2000 Fluke Corporation, All rights reserved. Printed in USA
All product names are trademarks of their respective companies.
Table of Contents
Title
Introduction....................................................................................................................
Contacting Fluke ...........................................................................................................
FlukeView Documentation.............................................................................................
FlukeView Features.......................................................................................................
Installation .....................................................................................................................
System Requirements ..............................................................................................
Installing FlukeView Forms from the CD ..................................................................
Installing FlukeView Forms from Floppy Disks .........................................................
Copying the Setup Program to Floppy Disks .......................................................
Installing the Setup Program from Floppy Disks..................................................
Overview of FlukeView Forms.......................................................................................
Starting FlukeView Forms .............................................................................................
Selecting a Form Template ...........................................................................................
Getting Data from the Meter to the PC ..........................................................................
How Your Meter Communicates Data ......................................................................
Connecting the IR Cable to a PC .............................................................................
Changing the Communications Port .........................................................................
i
Page
1
1
2
2
3
3
3
4
4
5
5
8
8
8
9
9
9
FlukeView Forms
Users Manual
Logged Readings and Display Readings ..................................................................
Uploading Data .........................................................................................................
Interactive Logging....................................................................................................
Event Logging ......................................................................................................
Setting Up Your Logging Session ........................................................................
Viewing the Status of a Logging Session .............................................................
Single-Reading Copy to Form...................................................................................
Using Forms...................................................................................................................
Manually Adding User Data ......................................................................................
Formatting Data on an Existing Form .......................................................................
Printing a Form..........................................................................................................
Saving a Form...........................................................................................................
Placing Existing Meter Data in a New Form Template..............................................
Display Selected Readings .......................................................................................
Finding and Opening Saved Forms ...............................................................................
Opening a Saved Form .............................................................................................
Using the Find Button to Find a Saved Form ............................................................
Editing a Saved Form................................................................................................
Deleting Forms..........................................................................................................
Exporting Data From a Form to a CSV File ...................................................................
Virtual Meter ..................................................................................................................
Views.........................................................................................................................
Memory ................................................................................................................
Primary/Secondary Readings...............................................................................
Meter Display .......................................................................................................
Functions...................................................................................................................
Preview Uploaded Data........................................................................................
Export Data ..........................................................................................................
ii
10
10
11
14
15
17
17
18
18
19
19
20
20
21
21
21
22
22
22
22
23
23
23
23
23
24
24
24
Contents (continued)
Clearing Data from Meter Memory.......................................................................
Single-Reading Copy to Form..............................................................................
Managing the Database ................................................................................................
Opening Databases..................................................................................................
Creating a New Database ........................................................................................
Backup Procedures ..................................................................................................
Optimizing the Database ..........................................................................................
Program Options ...........................................................................................................
Changing Program Options ......................................................................................
FlukeView Forms Meter Functions ................................................................................
Clearing Data from Meter Memory ...........................................................................
Changing Meter Settings ..........................................................................................
Altering Form Templates ...............................................................................................
Altering an Existing Template...................................................................................
Creating a New Form Template................................................................................
Form Items ...............................................................................................................
Display Readings Form Items..............................................................................
Meter ID and Date Form Items ............................................................................
User Data Form Items..........................................................................................
Static Form Items.................................................................................................
Troubleshooting.............................................................................................................
Setting the Comm Port .............................................................................................
Testing the Cable Connection ..................................................................................
iii
24
24
25
25
25
26
26
26
26
27
27
27
28
28
28
29
31
31
31
32
32
32
33
FlukeView Forms
Users Manual
Fluke Corporation
®
FlukeView Forms License Agreement
BY USING THIS SOFTWARE PRODUCT IN ANY MANNER, YOU ARE AGREEING TO ACCEPT THE FOLLOWING
TERMS AND CONDITIONS.
Fluke Corporation (Fluke) grants you a non-exclusive right to use FlukeView Forms Documenting Software (Product) on a
single PC or workstation (node), or on multiple nodes, provided that a multi-use license is obtained from Fluke and the number of nodes does not exceed the number of nodes for which license fees are paid. This grand of license does not include
the right to copy, modify, rent, lease, sell, transfer or distribute the Product or any portion thereof. You may not reverse engineer, decompile, or disassemble the Product.
Fluke warrants that the Product will perform in its intended environment substantially in accordance with the accompanying
written materials for a period of 90 days from the date of license acceptance. Fluke does not warrant any downloading errors
or that the Product will be error free or operate without interruption.
FLUKE DISCLAIMS ALL OTHER WARRANTIES, EITHER EXPRESS OR IMPLIED, BUT NOT LIMITED TO IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TOT HE
SOFTWARE AND THE ACCOMPANYING WRITTEN MATERIALS. In no event shall Fluke be liable for any damages whatsoever (including, without limitation, indirect, consequential, or incidental damages, damages for loss of business profits,
business interruption, loss of business information, or other pecuniary loss) arising out of the use of or inability to use thi s
Product, event if Fluke has been advised of the possibility of such damages.
iv
FlukeView Forms
Documenting Software
Introduction
Contacting Fluke
FlukeView Forms Documenting Software lets you transfer
data from a supported digital multimeter directly to forms
on your computer. This automates your troubleshooting
or recording process, reduces the possibility for manual
error and allows you to collect, organize and display
meter data in a format that meets your needs.
To order accessories, receive assistance, or locate the
nearest Fluke distributor or Service Center, call:
USA: 1-888-99-FLUKE (1-888-993-5853)
Canada: 1-800-36 FLUKE (1-800-363-5853)
Europe: +31 402-678-200
Japan: +81-3-3434-0181
Singapore: +65-738-5655
Anywhere in the world: +1-425-446-5500
Address correspondence to:
Fluke Corporation
P.O. Box 9090
Everett WA 98206-9090
USA
Fluke Europe B.V.
P.O. Box 1186
5602 BD Eindhoven
The Netherlands
Visit us on the World Wide Web at: www.fluke.com
1
FlukeView Forms
Users Manual
FlukeView Documentation
FlukeView Features
The following documentation is available for use with
FlukeView Forms.
Acquires and documents readings from supported digital
meters through IR or standard serial communications.
•
Displays acquired results in graphs and tables.
Use For
•
Allows you to save and print results.
Installation, basic
operation
Installation, basic
and advanced
operation
Step-by-step
instructions for
each type of
meter
Step-by-step
instructions for
procedures
On-the-spot
application help
Detailed
troubleshooting
and technical
information.
•
Allows you to retrieve and view previously saved
results.
•
Allows real-time logging directly to a connected PC,
with meters that support interactive logging.
•
Allows you to transfer collected readings to other PC
applications.
•
Provides standard form templates to display results
professionally.
•
Includes FlukeView Forms Designer program for
creating customized form templates.
Table 1. Documentation Sources
Documentation
Getting Started
Guide
Users Manual
Format
Printed
CD/Online
Printable .pdf
Meter Connection
Pages
CD/Online
Printable .pdf
Tutorials
CD/Online
Printable .pdf
Online Help
Windows Help
Technical Notes
Web at
www.fluke.com
Available on the
FlukeView
Forms CD
2
Documenting Software
Installation
Installation
Installing FlukeView Forms from the CD
This section describes how to install FlukeView Forms and
FlukeView Forms Designer. Also, follow these instructions
to upgrade from an older version of the software.
If your PC does not contain a CD-ROM drive, skip to the
section, “Installing FlukeView Forms from Floppy Disks.”
System Requirements
1.
Insert the CD into your CD-ROM drive.
2.
A window appears that lists options on the CD.
Operating System: Microsoft Windows 95 or later,
Windows NT 4.0 or later, or Windows 2000.
If the window does not automatically appear:
Minimum recommended hardware: Pentium class
microprocessor, 32 MB RAM, and 70 MB hard disk space
(100 MB to install).
Note
To install the software on Windows NT and
Windows 2000, you must log in with
Administrator privileges.
a.
On the Windows taskbar, select Start, then Run.
b.
Type d:\viewer.exe (where d: is your CD
drive letter).
3.
Select Install Software.
4.
Select Install FlukeView Forms.
5.
Follow the installation instructions that appear.
3
FlukeView Forms
Users Manual
Installing FlukeView Forms from Floppy Disks
Copying the Setup Program to Floppy Disks
Have blank, formatted 1.44 MB floppy disks available.
1.
Insert the CD into a PC that has a CD-ROM drive.
2.
Browse to d:\floppy (where d: is the CD-ROM
drive letter).
3.
There are two subdirectories listed. Select
d:\floppy\useurope if you use English or a
European language, or d:\floppy\asia if you use
an Asian language.
4
4.
The subdirectory you select contains subfolders
named Disk1, Disk2,…
5.
Copy the files in subfolders Disk1, Disk2,…on the CD
to the floppy disks labeled Disk1, Disk2,…,
respectively.
6.
If you are installing FlukeView Forms on Windows 95,
create a blank formatted disk, label it DCOM95, and
copy the file d:\DCOM95\DCOM95.exe from the CD
to the DCOM95 floppy disk.
7.
Read the next section “Installing the Setup Program
from Floppy Disks.”
Documenting Software
Overview of FlukeView Forms
Installing the Setup Program from Floppy Disks
•
Transferring data from the meter to the PC
1.
Insert Disk1 into the floppy disk drive.
•
Managing forms to meet your needs
2.
On the Windows taskbar, select Start, then Run.
•
Saving and retrieving data
3.
Type a:\setup.exe (where a: is your floppy drive
letter).
•
Exporting data
•
Managing your database
4.
Click OK.
•
Troubleshooting
5.
Follow the installation instructions that appear. The
setup program prompts you to switch disks.
Overview of FlukeView Forms
The Getting Started Guide and Users Manual detail
processes you need to know to use FlukeView Forms.
They include:
•
Starting FlukeView Forms
•
Selecting a form template
Most users start FlukeView Forms, select a form template,
connect the meter to the PC, transfer data, add user data,
and then print and save the form. More advanced users
might spend time customizing form templates, retrieving
and exporting data, and managing the database.
5
FlukeView Forms
Users Manual
2
3
4
5
1
6
7
8
9
10
zk01f.eps
Figure 1. FlukeView Forms Screen
6
Documenting Software
Overview of FlukeView Forms
Table 2. Graphic User Interface Components
No.
Description
A
Active form template. Displays meter data and user-entered data.
B
FlukeView Forms menu.
C
Select a form drop-down list. Lists all form templates available in the open database. Identifies the active template
currently being displayed.
D
Saved forms drop-down list. Lists all forms you have saved with the active template. Displays the name of the saved form
you are viewing, or (untitled) if the form has not been saved.
E
Virtual Meter button. Opens the virtual meter window. The virtual meter displays the active meter readings and copies
single-readings to the active form. It also lists, summarizes, and exports uploaded data.
F
Get Meter Data button. Uploads data from meter memory and displays it in the active form.
G
Logging button. Begins set up and interactive logging from the meter. Displays logged data on the active form.
H
Find button. Helps you locate forms you have saved previously.
I
Clear, Save or Print the active form.
J
Meter connection icon tells you if a meter is connected and communicating with your FlukeView Forms software.
7
FlukeView Forms
Users Manual
Note
Starting FlukeView Forms
If you are working in an active form when you
open a new blank form template, FlukeView
Forms asks if you want to save changes you
have made to the original active form.
To start FlukeView Forms:
1.
From the Windows taskbar, select Start, Programs,
Fluke, then FlukeView Forms.
2.
Click the FlukeView Forms menu item.
Selecting a Form Template
FlukeView Forms templates are designed to display data
in different ways. After you select the appropriate form
template, it becomes the active form. When you transfer
meter data, it displays in the active form.
FlukeView Forms provides general-purpose form
templates. See online tutorials for more information on
using form templates.
Getting Data from the Meter to the PC
The meter communicates with a PC through an IR
(infrared) serial cable. FlukeView Forms transfers meter
data to the PC three ways:
1.
On the File menu, select New Blank Form.
•
Upload data from meter memory
2.
A New Blank Form dialog box appears. Double-click
a form template name in the Select a form list.
•
Interactive logging
•
Single-reading copy to the active form
The type of meter you have determines which transfer
methods can be used.
8
Documenting Software
Getting Data from the Meter to the PC
How Your Meter Communicates Data
Connecting the IR Cable to a PC
The following table shows how certain Fluke meters
communicate data to the PC.
1.
Attach the 9-pin serial connector of the IR serial
cable to the serial port on your PC.
2.
Attach the other end of the IR serial cable to the
meter. For more details or information on your
specific meter, see Meter Connection Pages on your
CD.
Table 3. Meter Communication Styles
Fluke Meter
Model
Uploading
87 IV / 187
89 IV / 189
X
53 / 54
X
Interactive
Logging
Single-Reading
Copy to Form
X
X
X
X
Changing the Communications Port
To change the communications port that FlukeView
Forms uses:
1.
Open FlukeView Forms.
2.
On the Tools menu, select Options. The Options
dialog box appears.
3.
Click the Communications tab.
4.
In the Port list, click the communications port you
want to use. The default communications port for
FlukeView Forms is COM1.
9
FlukeView Forms
Users Manual
Note
Logged Readings and Display Readings
Readings stored in meter memory are identified
variously as saved readings, stored readings or
memory readings in the meter manuals.
FlukeView Forms deals with two types of meter data,
logged readings and display readings.
Logged readings are taken during a logging session.
There are two ways to generate logged readings:
•
•
During interactive logging between a meter and a PC
running FlukeView Forms.
•
Some meters support logging directly to meter
memory. In this case, logged readings are stored in
meter memory and uploaded from meter memory to
FlukeView Forms at a later time.
Logged readings in a logging session always have the
same units. For example, results are all V ac, all V dc,
etc. However, display readings may be in different units.
Display readings are not graphed in FlukeView Forms,
but logged readings can be.
Display readings are taken one at a time, as opposed to
being recorded during a logging session. Display
readings are transferred to FlukeView Forms two ways:
•
10
When you upload individually saved readings from
meter memory.
When you perform a single-reading copy to form.
Uploading Data
If your meter has memory, the meter can record data
without a PC present and store it in meter memory.
FlukeView Forms then uploads data from the meter
memory to the PC. Data storage on the meter is limited
by the meter memory.
Meters that support uploading data are listed on Table 3.
Documenting Software
Getting Data from the Meter to the PC
To upload data:
5.
1.
Start FlukeView Forms.
2.
Select the form template you want to use by opening
the File menu and selecting New Blank Form.
Highlight the form template in the New Blank Form
dialog box and click OK.
3.
Connect the meter to the PC using the IR cable.
4.
Turn the meter on.
Note
If your meter has a PC/IR SEND button, you must
use that button to initiate communication with the
PC.
On the Meter menu, select Get Meter Data to
upload the meter data to the active form. The Get
Meter Data dialog box appears. In some cases, this
step is unnecessary. Instead, you are prompted with
the Get Meter Data dialog box automatically.
You can also press the Get Meter Data button to
access the dialog box.
6.
Data readings are copied directly into the active
form.
Interactive Logging
In interactive logging, readings are logged directly from
the meter and stored on the PC. This allows FlukeView
Forms to take advantage of the PC’s larger memory.
However, it requires the meter to be connected to the PC
while the logging session takes place; and the meter
must have sufficient battery power to run for the length of
the logging session.
Meters that support uploading data are listed on Table 3.
11
FlukeView Forms
Users Manual
To begin interactive logging:
7.
1.
Connect the meter to the PC.
2.
Select the form template you want to use by opening
the File menu and selecting New Blank Form.
Highlight the form template in the New Blank Form
dialog box and click OK.
The Setup and Status radio buttons in the Logging
window display settings for and provide information about
the logging session. Use them to:
3.
On the meter, choose the meter function and range
you want to use to measure the input.
4.
In FlukeView Forms, click the Meter button at the top
right-hand portion of the toolbar. Use the virtual
meter to confirm that the meter readings are correct.
5.
From the Meter menu, select Logging. The
Logging window appears. You can also press the
Logging button to access the Logging window.
6.
Set up your logging session using the on-screen
items on the logging window (or make no changes to
the setup, and use the default configuration).
12
Click Start or Stop to start or stop logging.
•
Change the default logging settings under Setup.
•
Use Example Log to examine the effects of your
logging settings on example data.
•
Manually Start and Stop a logging session, or set
Auto Start/Stop times for a logging session.
•
Examine the Status of the active logging session.
Documenting Software
Getting Data from the Meter to the PC
INTERVAL EVENTS
Hour: minute
14:00
14:10
14:20
14:30
14:40
5V
LOGGED READINGS
0V
Stable
Unstable
INPUT EVENTS
1
2
3
4
5
zk02f.eps
Figure 2. Interval Events and Input Events
13
FlukeView Forms
Users Manual
Event Logging
During interactive logging, FlukeView Forms compresses
the input being measured by the meter into a series of
events. Each event is represented by a duration, starting
time, ending time, and the highest, lowest and average
values detected during the event.
When you start logging, the meter readings are
monitored by FlukeView Forms and are classified by
event type. The two event types you will see most often
are:
•
For a more detailed discussion of all types of events, see
the FlukeView Technical Notes, available on your CD.
Input events are described as either stable or
unstable. Stable input events contain readings that
fall inside the user-defined settings. Unstable input
events contain readings that fall outside the userdefined settings. See Figure 2.
Each event is stored in an individual logged reading.
Note
If your meter supports the display of two
readings at once, and both are being displayed,
then both readings may be logged, depending
on the settings you have selected.
14
Input events are logged when the input reading
changes beyond the user-defined input event
settings. You define, in settings, which readings are
similar enough to constitute an input event.
•
Interval events are logged when the user-defined
logging interval is up. Interval events can be thought
of as a series of readings divided into sections by
time. See Figure 2.
Documenting Software
Getting Data from the Meter to the PC
Input events are useful for detecting anomalies in a group
of data, when monitoring a process or when
troubleshooting a problem. Interval events are useful if
the values you record are fairly stable in nature and your
main purpose is documentation for record keeping.
If the values you record are fairly stable, but monitoring
variance from the norm is critical, recording both interval
events and input events can be a valuable troubleshooting tool. The interval events serve as routine
documentation, while the input events record any
significant changes that occur during the intervals.
By default, FlukeView Forms logs both input and interval
events. You can view either or both on the form. If you
decide to record only input events or only interval events,
you lose this flexibility, but you reduce the number of
readings you take and save disk space on your PC.
Note
See the FlukeView Forms Technical Notes for a
more comprehensive description of how event
logging is performed and how to effectively use
it for your purposes.
Setting Up Your Logging Session
From the Meter menu, open the Logging window.
From the Logging window, set up your logging session
by selecting the Setup radio button. You can then
customize the default logging setup to collect your data.
Example Log
Example Log lets you view the effects of changing the
logging settings. It shows how an example input is
compressed into events with the current logging settings.
After you change the logging settings and click Apply,
the Example Log graph updates to reflect your changes.
15
FlukeView Forms
Users Manual
Select Change Example if you want to change the
example input data to approximate the inputs you are
expecting to measure.
Changing the Input Event Settings
Changing the Logging Interval
Changing the input event settings allows you to specify
what changes in the input are significant enough to begin
a new input event.
To change the logging interval, open the Logging
window, select the Setup view and make changes in the
Interval section. Changing the logging interval:
To change event settings, open the Logging window,
select Setup view and make changes in the Event
section.
•
Does not usually significantly change a graph of the
data. A very small interval (10 seconds or less) rarely
provides more significant data, especially if input
event data is also being recorded.
•
Does directly impact the number of records stored
(smaller interval means more records are recorded).
With Relative Threshold selected, you specify a
percentage change in the readings that begins a new
event. Relative thresholds work well when signal noise
(insignificant changes in the input signal) is proportional
to the expected signal value.
•
16
Does not change the number of times that
FlukeView Forms requests readings from the meter.
This is an internal value based on the type of meter
and the PC’s CPU speed and current performance.
With Fixed Threshold selected, you specify a fixed-value
change in the readings (in the units of measure that the
meter is using) that begins a new event. Fixed thresholds
work well when you want to capture a significant unit
change in the input you are measuring.
Documenting Software
Getting Data from the Meter to the PC
If the meter supports internal event logging, you can
choose to have the meter perform the input event
detection. When the meter is performing the input event
detection, the input change detection is noticeably faster.
Note
If your meter supports the display of two
readings at once, and both are being displayed,
you need to select whether the input event
thresholds are applied to the primary or
secondary display.
Viewing the Status of a Logging Session
Once logging starts, from the Logging window, select the
Status view to watch the current logging session as it
occurs. It shows number of events logged and current
high, low and average values for the event in progress.
The active form updates when an event closes.
Single-Reading Copy to Form
You can capture a single display reading from your meter
and copy it to a form for printing or saving. This is useful
when you only need the reading that appears on the
meter for your records.
To capture a single reading from your meter, the meter
must be connected to the PC. You may copy more than
one reading to the form, but the readings must be copied
one at a time.
The most common way to perform a single-reading copy
to form is to use the virtual meter window. Open the
virtual meter by clicking the Meter button at the top righthand portion of the toolbar.
17
FlukeView Forms
Users Manual
The drop-down list in the top left corner of the virtual
meter window gives you several options for viewing data.
The reading appears at the bottom of any display reading
table on the form, or in a testpoint reading form item.
•
The Primary/Secondary Readings option gives you
a small screen that reflects the meter display.
Using Forms
•
The Meter Display option simply gives you a largerscreen view of this data. Both views allow you to use
single-reading copy to form.
To perform a single-reading copy to form:
1.
Make sure the meter is connected to the PC. Check
the meter-connection icon on the lower-right corner
of the FlukeView Forms screen or the display on the
virtual meter.
2.
Open the virtual meter by clicking the Meter button at
the top right-hand side of the toolbar.
3.
Set the virtual meter view to either
Primary/Secondary Readings or Meter Display.
4.
When the virtual meter displays a reading you want
to copy, click on Copy Into Form.
18
The form is the primary element of FlukeView Forms
documenting software. Each online form contains form
items, which display meter data or user-entered data.
Once you have transferred data from the meter to the
active form, you can enhance the presentation of data in
a number of ways.
Manually Adding User Data
Most form templates have form items designed for
information that is manually entered by the user. If you
place your cursor in a field and the symbol appears, that
is a user data field. You can enter comments and
additional data in these fields.
Documenting Software
Using Forms
To retain user data when adding a new set of meter data:
Printing a Form
1.
Press the Clear button.
To print a form:
2.
Choose Meter data only from the Clear Form dialog
box.
1.
On the File menu, select Print. You can also use the
Print button.
3.
Get the new meter data.
2.
Sometimes, there is more meter data than the tables
on the form can display. Select Print tables at end
of print job to print all meter data in tabular form
immediately after the form is printed.
3.
Change printer, print range, or copy settings.
4.
Click OK.
Formatting Data on an Existing Form
You can change the way data appears on an existing
form by altering the graphs and tables.
To alter graphs or tables, place your cursor inside the
graph or table and right-click. A menu of options for that
form item appears.
For instance, when looking at a graph, you can zoom in
or out and print or save various views of the graph to suit
your needs. This lets you highlight relevant data.
19
FlukeView Forms
Users Manual
Saving a Form
Saving a form stores all data and formatting on the active
form so that you can view the form at a later time. If you
do not save the form, all the data on the form is lost when
you transfer new data from your meter, change the form
template, or exit FlukeView Forms.
To save a form, from the menu, select File, then Save.
You can also use the Save button. Save is disabled if
there is no new data to save.
Saved forms are identified by the form template and the
date and time they were first saved. You can also enter a
30-character remark to help identify the form. The remark
is displayed after the date and time in the Saved forms
list at the top of your screen. See “Finding and Opening
Saved Forms” in this manual for more information.
20
Placing Existing Meter Data in a New Form
Template
If you are in an active form that contains data, you can
display the same data in a different form template.
You can disable this feature in Program / Options.
User data must be re-entered when you move existing
data from one form template to another.
1.
Open the drop-down Select a form menu and select
a different form template.
2.
If you haven’t already saved the data, a Save dialog
box gives you the option to save the data in your
original form template.
3.
The data appears on your screen in the new form
template you have chosen.
Documenting Software
Finding and Opening Saved Forms
Display Selected Readings
Finding and Opening Saved Forms
Sometimes, you might not want to display or save all of
the readings you have taken from the meter. The Select
Readings dialog box allows you to:
If you save a form, you can access that form again at a
later time.
•
Delete unnecessary readings from the form.
Opening a Saved Form
•
Rearrange the order of display readings on the form.
If display readings are taken in the wrong order, they
show up in the wrong order on the display readings
table and testpoint readings form items. Select
Readings allows you to correct their order.
Note
You cannot edit the actual meter data. You can
only delete an entire reading, or you can change
the order of readings.
1.
From the menu, select Tools, then Select Readings
to display the Select Readings tool.
2.
Delete or reorder the readings.
3.
Click OK to save the changes.
To open a form that you have saved previously:
1.
Open FlukeView Forms.
2.
In the Select a form drop-down list, select the
template in which you saved the form.
3.
In the Saved forms drop-down list, browse to the
form and click to open.
It is important that you select the template in which your
data was originally saved. The Saved forms drop-down
list only displays those forms that were saved in the
selected form template. If you do not remember the
template in which you saved the form, search for it using
the menu. From the menu, select File, then Open Saved
Form. You can also use the Find button to locate the
saved form.
21
FlukeView Forms
Users Manual
Using the Find Button to Find a Saved Form
Deleting Forms
The Find button provides a more powerful way to locate
saved forms. Use it to list forms that match criteria you
establish.
If you need to delete a previously-saved form:
1.
Open FlukeView Forms.
2.
Click on the Find button.
3.
Fill in the criteria to search for forms. You can search
by form name, save date, or data type.
4.
Click the Find Now button.
Note
This action permanently deletes a saved form
and all the data it contains.
1.
Highlight the form in the Saved forms drop-down
list.
2.
From the menu, select File, then Delete Saved
Forms.
Editing a Saved Form
3.
Confirm your command to delete the saved form.
You can edit forms you have saved previously by opening
the saved form and changing user data. You can then
either perform a Save to overwrite the original form, or
Save As to create a new form with the edited material.
Exporting Data From a Form to a CSV
File
You can save meter data in a format that can be used by
other software applications. FlukeView Forms exports the
data to a comma-delimited file with a file name extension
of .csv.
1.
22
On the File menu, select Export Data. The Export
Data dialog box appears.
Documenting Software
Virtual Meter
2.
Assign a file name and click Save to copy the data to
the file.
Virtual Meter
The virtual meter is useful if you want to view meter data
before adding it to a form. It allows you to preview
uploaded data, to export and copy data, and to copy a
single reading to a form.
To open the virtual meter, click the Meter button on the
right-hand side of the toolbar.
Views
The virtual meter has three views for displaying data. The
display method(s) that are available depend on the meter
you are using.
Memory
This view shows the logged and display readings that
were last uploaded from meter memory. It shows meter
data in tabular form for you to view before placing it in the
active form. It also allows you to export uploaded meter
data to a .csv file, to manually copy the meter data to the
form, and to clear the meter’s memory.
Primary/Secondary Readings
Provides a compact, virtual representation of readings as
they occur on your meter’s display. If your meter displays
both primary and secondary readings, the virtual meter
shows both readings. You can perform a single-reading
copy to form in this view.
Meter Display
Provides a large-view, virtual representation of readings
as they occur on your meter’s display. You can perform a
single-reading copy to form in this view.
23
FlukeView Forms
Users Manual
Functions
Clearing Data from Meter Memory
Preview Uploaded Data
You can use FlukeView Forms to clear data from the
meter’s memory.
The virtual meter allows you to preview data in tabular
form before you place it in a form.
Export Data
You can export uploaded meter data as a .csv file by
doing the following:
1.
Transfer data from meter memory to FlukeView
Forms.
2.
To open the virtual meter, click the Meter button on
the right-hand side of your display.
3.
Select the Memory view.
4.
Click on the Export button.
5.
Assign a file name and click Save.
24
To find out how to do this, see this topic under the section
entitled “FlukeView Forms Meter Functions” in this
manual.
Single-Reading Copy to Form
You can capture a single testpoint reading from your
meter and copy it to a form for printing or saving.
To find out how to do this, see this topic under the section
entitled “Getting Data from the Meter to the PC” in this
manual.
Documenting Software
Managing the Database
Managing the Database
By default, FlukeView Forms databases have the file
name extension .fdb.
FlukeView Forms stores all meter data and forms in
FlukeView Forms databases.
Creating a New Database
You can change the active database in FlukeView Forms
and create new databases in FlukeView Forms Designer.
You should create new databases as your database
grows larger. Storing all the data you collect into a single,
large database can lead to poor performance. Instead,
store your data in several smaller FlukeView Forms
databases, with similar data stored together.
Opening Databases
To create a new database:
1.
Open FlukeView Forms Designer.
2.
On the menu, select File, then New Database.
3.
Name the new database and save it.
By default, FlukeView Forms databases have the file
name extension .fdb.
To open a different database:
1.
Open FlukeView Forms.
2.
On the File menu, select Open Database.
3.
Browse to the drive and folder containing the
database.
4.
Select the database you want to open and click OK.
25
FlukeView Forms
Users Manual
Backup Procedures
3.
Select the database to optimize and click OK.
To back up the database:
4.
On the menu, select Advanced, then Database
Maintenance.
5.
Select Optimize and follow on-screen instructions.
1.
Open FlukeView Forms Designer to a blank form.
2.
On the menu, select File, then Open Database.
3.
Select the database to back up and click OK.
4.
On the menu, select Advanced, then Database
Maintenance.
5.
Select Backup and follow the on-screen instructions.
Program Options
From the menu, select Tools, then Options to:
•
Change default program options for the active form.
•
Change communications options.
Optimizing the Database
Changing Program Options
To improve performance, optimize your FlukeView Forms
database.
You can change the default options for the active form,
as well as change some of the communications options.
1.
Open FlukeView Forms Designer to a blank form.
2.
On the menu, select File, then Open Database.
26
1.
On the Tools menu, select Options. The Options
dialog box appears.
2.
Use the General tab or Communication tab to
change the appropriate options.
Documenting Software
FlukeView Forms Meter Functions
FlukeView Forms Meter Functions
Changing Meter Settings
You can change some meter settings from FlukeView
Forms.
Clearing Data from Meter Memory
You can use FlukeView Forms to change some meter
settings, including synchronizing the clock, internal
logging settings and other meter functions that are
specific to the type of meter.
Use FlukeView Forms to clear data from meter memory.
1.
Turn on the meter.
On meters that allow you to save several types of meter
data to meter memory, FlukeView Forms prompts you to
select which type to clear.
2.
From the Meter menu, select Change Meter Setup.
3.
Make changes to the dialog box.
To clear data from meter memory:
4.
Click Send to change the meter settings.
1.
On the Meter menu, select Clear Meter Memory.
The Clear Meter Memory dialog box appears.
2.
Click OK to confirm.
27
FlukeView Forms
Users Manual
Altering Form Templates
You can alter the form templates provided by FlukeView
Forms or you can create new templates using FlukeView
Forms Designer.
Altering an Existing Template
6.
Change fonts, type colors and other form-item
characteristics by selecting the form item (click on
the form item in the template). From the menu select
Edit, then Properties.
7.
Make changes.
8.
1.
Open FlukeView Forms Designer.
Save the form template in one of the two following
ways:
2.
Open an existing form template.
•
3.
Click on any form item, then click and drag its border
to move it to a new location.
with a new template name by opening the File
menu, and selecting Save As; or
•
overwrite the active template by opening the File
menu and selecting Save.
4.
5.
28
Add new form items from the menu by selecting Edit,
then Insert Form Item. Highlight the form item name
and click Insert.
Delete an exiting form item by selecting it (click on
the form item in the form template). From the menu,
select Edit, then Delete Form Item.
Creating a New Form Template
1.
Open FlukeView Forms Designer. The screen should
be blank. If not, on the menu, select File, then New.
2.
Add new form items from the menu by selecting Edit,
then Insert Form Item. Highlight the form item name
and click Insert.
3.
Move the form item to its proper location on the form.
Documenting Software
Altering Form Templates
4.
Change font and type color from the menu by
selecting Edit, then Properties.
5.
Once the form template is complete, save it with a
new template name from the menu by selecting File,
then Save As.
Form Items
Each form template contains form items, which display
meter data or user data. The following is a list of available
form items. These are found in templates and can be
incorporated into designed forms.
Some form items can only be used by certain meters. Get
a list of form items for your meter by selecting the Edit
menu, then Insert Form Items. In the drop-down list for
Display Form Items for Meter, select your meter.
FlukeView Forms displays only the form items that your
meter can use.
Logged Readings Form Items
Logged Readings Graph
Provides a graphic representation of the logged readings
recorded during a logging session.
The horizontal axis shows the time and the vertical axis
shows a scale for the logged reading values.
Logged Readings Table
Displays logged readings in table format. Initially, this
table lists the logged reading values that are grouped in
the logged readings graph. Can display input event data,
interval event data, or both.
29
FlukeView Forms
Users Manual
Logging Summary
Displays the following information about a logging
session on the form:
Event Duration Histogram
Graphically shows the distribution of logged readings by
their duration (length).
•
Logging session information: start, stop, and elapsed
time; interval length; number of readings; and other
meter-specific data.
•
Summary information: the maximum, average, and
minimum logged readings.
Event Scatter Graph
Graphs the duration of logged readings against their
amplitude. Typical readings tend to plot together in a
cluster, whereas exceptional events are plotted away
from the typical ones. This can be useful when there is a
recurring event.
Event Amplitude Histogram
Graphically shows the distribution of logged readings by
their amplitudes (values). This is often useful when the
logged readings fall into several discrete levels.
30
Note
Some of the information displayed depends on
the type of meter you are using.
Documenting Software
Altering Form Templates
Display Readings Form Items
User Data Form Items
Display Readings Table
Presents display readings in table format. The display
readings table maintains the original unit of measure. Use
the description column to enter comments about
individual readings.
Memo
Provides a space (up to a maximum of 64,000 characters
and 1000 lines) for adding user comments and notes.
Testpoint Reading
Displays a single display reading on the form. The display
reading may be scaled. The row number of each display
reading in the display reading table corresponds to the
reading number associated with each testpoint reading
form item.
Meter ID and Date Form Items
Date Time Stamp
The time stamp is automatically updated to your
specifications the first time a form is saved, when meter
data is received, or when the form is modified.
Meter Identification
Displays the meter ID of the meter that was used to
transfer the meter data.
Check Box
Use the check box form item to record a yes or no
response. Selecting the check box form item signifies
Yes. Clearing the check box signifies No. You can use
the values in the check box when searching for forms
with the Find button.
Numeric Entry
Provides a space to type numeric values on the form.
Selection Box
Allows you to choose data from a list of predefined values
that are set up when you design the form template. You
can also add values to the selection box when you enter
data. You can use the values in the selection box when
searching for forms with the Find button.
31
FlukeView Forms
Users Manual
Static Form Items
Static form items are those items that can only be
modified in FlukeView Forms Designer.
Label
This item displays static text on the form.
Troubleshooting
Counter
The counter form item displays a unique incrementing
number on saved forms. Each time you save a form that
contains a counter form item, the counter form item is
incremented from the last time that form was saved.
For other troubleshooting issues and up-to-date
information, see the FAQ and technical notes at
www.fluke.com.
If a form contains a counter form item, saving it causes it
to increment or decrement as specified by you when you
create the form template.
To change the communications port:
Bitmap
A static graphic image, such as a company logo. Bitmap
image formats include:
•
Graphics Interchange Format (.gif) files
•
JPEG File Interchange Format (.jpg) files
•
Windows Bitmap (.bmp) files
32
Setting the Comm Port
1.
On the Tools menu, select Options. The Options
dialog box appears.
2.
Click the Communications tab.
3.
In the Port drop-down list, select the
communications port you would like to use.
4.
Click OK.
Documenting Software
Troubleshooting
Testing the Cable Connection
To test the meter connection:
1.
On the Tools menu, select Options. The Options
dialog box appears.
2.
Click the Communications tab.
3.
Press the Test button on the right-hand side to test
the cable connection.
33
FlukeView Forms
Users Manual
34
Download PDF