DomainBuilder User Manual Table of Contents

DomainBuilder User Manual
Table of Contents
Introduction ............................................................................................................................... 3
Logging In .............................................................................................................................................. 3
Becoming an Authenticated User.................................................................................................. 3
Opening DomainBuilder .................................................................................................................. 4
Create a New Knowledge Base .................................................................................................................4
Browse an Existing Knowledge Base .....................................................................................................4
Importing an Existing Knowledge Base ................................................................................................4
Exporting an Existing Knowledge Base ................................................................................................4
Deleting an Existing Knowledge Base....................................................................................................4
Using Menu Trees to Select Items ................................................................................................. 5
Locating Items in the Menu Tree .............................................................................................................5
Selecting an Item from the Menu Tree ..................................................................................................5
Case Tab ....................................................................................................................................... 6
Case Maintenance ............................................................................................................................... 6
Creating a New Case......................................................................................................................................6
Opening a Case ................................................................................................................................................7
Saving a Case ....................................................................................................................................................7
Importing a Case.............................................................................................................................................8
Exporting a Case .............................................................................................................................................8
Adding Clinical Report Information............................................................................................. 8
Importing a Report ........................................................................................................................................8
Cut/Copy/Paste in the Report ..................................................................................................................9
Spelling Suggestions .................................................................................................................................. 10
Using a Worksheet to Input Clinical Information .......................................................................... 10
Parsing the Report ...................................................................................................................................... 10
Adding Concepts to the Knowledge Base from the Report ........................................................ 10
Adding/Removing Knowledge Base Concepts to the Case................................................ 11
Getting Knowledge Base Concepts for a Case ........................................................................ 12
Loading Digital Slides ..................................................................................................................... 12
Navigating Digital Slides ............................................................................................................... 13
Move around Slide ...................................................................................................................................... 13
Zoom In/Out.................................................................................................................................................. 13
Refresh Digital Slide ................................................................................................................................... 14
Magnifier Window ...................................................................................................................................... 14
Navigator window ...................................................................................................................................... 14
Modifying Digital Slides ................................................................................................................. 14
Expand Digital Slide Area ............................................................................................................. 16
Annotating Digital Slides .............................................................................................................. 16
Modifying Shapes ........................................................................................................................................ 17
Cut/Copy/Paste Shapes............................................................................................................................ 17
Taking Example Pictures from a Digital Slide ....................................................................... 17
Tags....................................................................................................................................................... 18
1
Create a Tag ................................................................................................................................................... 18
Delete a Tag ................................................................................................................................................... 18
Organizing Annotations with Tags....................................................................................................... 18
Case Authoring for SlideTutor ITS ............................................................................................. 19
Locations Annotations .............................................................................................................................. 19
Linking Annotations with Knowledge Base Concepts ........................................................ 21
Case Concept Properties ............................................................................................................... 21
Viewing Case Concept Properties......................................................................................................... 22
Modifying Linked Annotations Using Case Concept Properties .............................................. 22
Asserted Concepts ........................................................................................................................... 22
Validating Knowledge Base Concepts for a Case .................................................................. 22
Adding Additional Pathologies to the Case ............................................................................ 22
Creating and Deleting Additional Pathologies ................................................................................ 23
Marking Unrelated Diagnoses with Respective Pathologies ..................................................... 23
Viewing Different Pathologies .................................................................................................... 23
Case Status.......................................................................................................................................... 23
Knowledge Tab ....................................................................................................................... 24
Hierarchy Builder Tab ......................................................................................................... 24
Adding Concepts............................................................................................................................... 24
Cut/Copy/Paste/Delete Concept Options......................................................................................... 25
Adding Concept Information ....................................................................................................... 26
Manually Adding Definitions and Synonyms ................................................................................... 27
Importing Definitions and Synonyms from the Terminology .................................................. 27
Diagnosis Builder Tab .......................................................................................................... 29
Adding Diagnoses ............................................................................................................................ 30
Adding Findings to Diagnoses ..................................................................................................... 30
Modifying Rules for Findings....................................................................................................... 31
Adding Multiple Patterns of a Diagnosis ................................................................................. 31
Cut/Copy/Paste Findings .............................................................................................................. 31
Align Findings ................................................................................................................................... 31
Import Findings from Spreadsheet ........................................................................................... 32
Find/Replace Findings Inside all Diagnostic Rules ............................................................. 32
Report Builder Tab ............................................................................................................... 33
Creating a New Template .............................................................................................................. 34
Deleting a Template........................................................................................................................ 34
Reportable Items ............................................................................................................................. 34
Adding Reportable Items ......................................................................................................................... 35
Deleting Reportable Items....................................................................................................................... 35
Reorder Reportable Items ....................................................................................................................... 35
Triggers ............................................................................................................................................... 35
Adding a Trigger .......................................................................................................................................... 35
Deleting a Trigger ....................................................................................................................................... 36
Search .................................................................................................................................................. 37
Preview Cases ................................................................................................................................... 37
Right Click Menu Options.............................................................................................................. 37
Glossary ........................................................................................................................................................... 38
Bookmark/Unbookmark.......................................................................................................................... 38
Open Option................................................................................................................................................... 38
2
Summary ............................................................................................................................................. 38
Introduction
DomainBuilder is a tool designed to create a Knowledge Base and annotate cases
that are used by an intelligent tutoring system to provide instruction within a
particular pathology domain. This process consists of creating/editing a Knowledge
Base, inputting all of the case information, and annotating/drawing shapes on the
digital images.
Logging In
When you first start DomainBuilder you have an option to log in. If you log in with
valid credentials for a selected institution you will be able to save all of your
authoring to the central curriculum server which will make your authoring available
to others.
If the system cannot authenticate you then you will become a not authenticated user
which means that all of your authoring will be done in your local cache and will not
be visible to others. In that case you will receive the warning message below.
Becoming an Authenticated User
Contact the DomainBuilder administrator to gain log in credentials.
3
Opening DomainBuilder
Once DomainBuilder loads, a popup will appear with several options.
Create a New Knowledge Base
To create a new knowledge base, click on
OK.
. Fill in the appropriate fields and click
Browse an Existing Knowledge Base
To browse the contents of an already existing Knowledge Base, select the
appropriate Knowledge Base and then click on
. A popup will appear with all of
the existing concepts within the Knowledge Base. To navigate through the concepts,
simply click on a parent concept to open the children concepts in a new column to
the right of the parent concept.
Importing an Existing Knowledge Base
To import an existing Knowledge Base in the .owl format, click on
.
Exporting an Existing Knowledge Base
To export an existing Knowledge Base in the .owl format, highlight the appropriate
Knowledge Base and click on
.
Deleting an Existing Knowledge Base
To delete an existing Knowledge Base, highlight the appropriate Knowledge Base
and click on
.
4
Using Menu Trees to Select Items
Throughout DomainBuilder, menu trees are used at various times for selecting
findings and diagnoses. Below is a screenshot of a sample menu tree.
Screenshot of Menu Tree for Findings with an Item Selected
Locating Items in the Menu Tree
There are two ways you can locate items in the menu trees: opening and closing the
tree, or typing in a string to search for in the tree. To expand the tree, click a
“branch” of the tree and that branch will open to display its contents. Branches that
can be opened are indicated by a triangle or rectangle on the right of the item. To
open another branch, click on the expandable item. Alternatively, you can have the
program search the tree for a particular string of letters by typing the string in the
search box, and clicking “Go” or pressing the enter key on your keyboard. The tree
will highlight in orange any items containing that string. To go back to the original
view of the tree, click the “Reset” button.
Selecting an Item from the Menu Tree
To select items from the menu tree:
1. Do one of the following:
1. Click on the item to highlight it and click the
button.
2. Right click the item.
3. Double click the item.
2. Repeat step 1 to add additional items to the selection list as desired.
3. Click OK.
5
Even if the item appears to be highlighted from using the search tool, you still need
to click the item to make sure it is selected.
To remove an item from the selection list:
1. Click on the item to highlight it. Make sure you are in the selection list in the
right portion of the menu tree screen.
2.
Click
to remove the selection.
Case Tab
The Case Tab is where you enter all of the information at the level of individual
cases. In this tab, you can load digital slides, add clinical report information,
annotate the digital image, and link annotations with knowledge base concepts. This
entire process is referred to as case authoring.
Knowledge Base Concepts Panel
Clinical Report
Panel
Digital Slide
Viewer Panel
Case Maintenance
When the Case Tab opens, it opens a new case. Previously saved cases can be
opened, and cases can be imported and exported.
Creating a New Case
To create a new case:
6
1. Click the
button OR select New from the File menu.
Opening a Case
To open a previously saved case:
1. Click the
button OR select Open from the File menu.
2. Select the case you want to open by clicking it. You can filter cases by selecting a
diagnosis. When a case is selected, its diagnosis is highlighted (if available) and a
preview of the report is shown. You can also search for a case by the case name by
typing in the "Search" field.
3. Click OK.
The cases are colored based on the Case Status (see Case Status section below).
“Incomplete” cases are displayed in red. “Complete” cases are displayed in blue.
“Tested” cases are displayed in green.
Saving a Case
If you are an authenticated user, saving a case will save the file in your local cache as
well as upload it to the curriculum server. If you are not an authenticated user, the
file will only be saved to the local cache.
To save a case:
1. Click the
button ( for authenticated users )OR select Save from the File
menu.
2. If the “Enter Case Name” popup appears, type in an appropriate name for the case
and click OK.
7
Importing a Case
Cases can be imported from previously saved case files stored locally on your
computer.
To import a case file:
1. Click the
button OR select Import from the File menu.
2. Select the file you wish to import.
3. Click Open.
Exporting a Case
Cases can be exported and saved locally on your computer.
To export and upload a case:
1. Click the
button OR select Export from the File menu.
2. If the “Enter Case Name” popup appears, type in an appropriate name for the case
and click OK.
3. Navigate to the folder where you want the case file to be saved.
4. Type in a file name for the case file to be saved as in the File Name box if you want
it saved as a different name.
5. Click Save.
Adding Clinical Report Information
The top right portion of the Case Tab is where clinical report information is added.
Reports can be added by either typing into the report area or importing a previously
saved text file.
Importing a Report
You can import an existing clinical report in a text format (.txt). Some clinical
reports may not follow the same conventions used by DomainBuilder. That is why
the Align Report to a Template dialogue pops up to help users import all relevant
clinical information into the format that is understood by the system.
To import a report:
1. Click the
button OR select Add Report from the Case menu.
2. Locate the file you want to import.
3. Click Open.
4. Use the Align Report to Template dialogue to select the sections that you want to
add to the Target Report (in case they were not extracted automatically).
8
Cut/Copy/Paste in the Report
Like a word processor, you can cut, copy, and paste text.
To cut or copy text:
1. Highlight the text you wish to cut or copy using your mouse.
2. Right click your mouse and select cut or copy.
To paste text:
1. Move your cursor to the location you wish to paste text.
2. Right click your mouse and select paste.
You may also use the standard keyboard shortcuts to cut, copy, and paste text.
9
Spelling Suggestions
A spell checker is available to provide spelling suggestions.
To spell check the report:
1. Click the
button.
2. For each misspelled word, select the correct spelling from the suggestions
provided and click “Change”.
Using a Worksheet to Input Clinical Information
Some clinical information may be added to a report using the worksheet button.
Using this button, information can be added by selecting the appropriate radio
buttons rather than typing it in. To create a worksheet of concepts please see the
creating a worksheet section.
To use a worksheet:
1. Click the
button.
2. If there are multiple worksheets available, select the appropriate tab at the top of
the popup window for the information you want to add.
3. Click the appropriate radio buttons to select values.
4. Repeat steps 2 and 3 as needed.
5. Click OK.
Your selections will be appended to the end of your report in the Final Diagnosis
section.
Parsing the Report
Once a report is entered (either typed in or imported) it can be processed by
clicking the
button. At that point, any report text that is matched with concepts
in the Knowledge Base will turn blue, and any Knowledge Base concepts found in
the report will be listed appropriately under Diagnosis, Findings, Report, Clinical
and/or Ancillary.
Adding Concepts to the Knowledge Base from the Report
If there are any concepts that did not parse in the report, you can add the concept
from the report text directly to the knowledge base..
To add report text to the Knowledge Base:
1. Highlight the text in the report.
2. Right click the highlighted text.
3. Choose Suggest Term from the drop down menu.
10
If the highlighted text is a synonym for an existing concept:
1. Highlight the text in the report.
2. Right click the highlighted text.
3. Choose Suggest Term from the drop down menu.
4. Select the existing concept from the tree. (The highlighted text from the report
will become a synonym of the existing concept).
5. Click OK.
If you would like to create a new concept in the Knowledge Base from a term in the
pathology report:
1. Highlight the concept in the report that you would like to add to the Knowledge
Base.
2. Right click on the concept and click on Suggest Term.
3. Select the parent concept in which you would like the new term to be created
under. If there is no parent concept that fits, you can create a new concept by
clicking
.
4. Click OK.
Adding/Removing Knowledge Base Concepts to the Case
In addition to pulling knowledge base concepts from a processed report, knowledge
base concepts can also be added and removed manually using the
and
11
buttons for the appropriate concept type (Diagnosis, Findings, Report, Clinical or
Ancillary).
To manually add knowledge base concepts:
1. Click the
button for whichever concept type you wish to add (diagnosis,
finding, or prognosis).
2. Select the desired item(s) from the menu tree that appears.
To remove knowledge base concepts:
1. Click the item you wish to delete to select it.
2. Click the appropriate
button for whichever concept type you are removing.
Getting Knowledge Base Concepts for a Case
You can have DomainBuilder look for missing concepts within the Knowledge Base
and have those concepts populated by clicking the
button in the appropriate
column (Diagnosis, Findings, Report, Clinical, and/or Ancillary).
AUTHORING NOTE:
For example, if you know that the diagnosis is Bullous Pemphigoid, you can utilize the “get
findings” button in the Findings column to look up all of the appropriate findings for Bullous
Pemphigoid in the Knowledge Base.
Conversely, if you have a set of findings {X, Y and Z}, you can infer the possible diagnoses for
that set of findings by clicking the “get diagnoses” button in the Diagnosis column.
Loading Digital Slides
To load digital slides:
1. Click the
button in the slides portion of the screen (lower righthand side of the screen), select Add Slide from the Case menu, or
click the
button in the center of the digital slide viewer panel.
2. Select a location from the drop down menu. The location is the
registered institution that hosts the digital slide images.
3. Browse for an appropriate digital slide, keeping in mind that some
slides can be organized within sub folders. You can search for slides in
the currently opened folder by typing text into the search field.
12
AUTHORING NOTE:
Multiple slides can be loaded at the same time by using shift-click (to select slides listed
consecutively) or control-click (to select slides not listed consecutively).
You can author digital slides from different locations (institutions) by using the location drop
down menu in the open slide dialog box.
3. Click OK.
All loaded slides will appear in the slide list on the right-hand side of the screen.
Click on a thumbnail to change slides.
Navigating Digital Slides
DomainBuilder incorporates a virtual microscope that has similar functions as a
regular microscope but operates using a mouse.
Move around Slide
To move around the slide, press and hold the left mouse button. Drag the mouse,
then release the mouse button. Repeat until the desired area is in view.
Zoom In/Out
To zoom in:
Left click the
To zoom out:
button OR click the mouse over the image.
13
Left click the
button OR right click the mouse over the image.
You can also zoom in and out using the scroll wheel on your mouse when your
mouse is over the image.
To return to the whole slide view, click the
button.
Refresh Digital Slide
If the viewer is not refreshing, allow a few seconds for the new view to appear. If
that does not help, click the
resetting the viewer helps.
button and try using the viewer again – sometimes
Magnifier Window
The Magnifier window provides a small window that shows a portion of the slide at
a higher magnification. To open the Magnifier window, click the
button. The
mouse cursor changes to a box. Move your mouse cursor over the slide to view
different areas of the slide in the Magnifier window or drag the magnifier window
itself over the area of the slide that you want to magnify. To close the Magnifier
window, click the
button again.
Navigator window
The Navigator window provides a smaller view of the entire slide that you can use
to see where you are on the slide and to control what is displayed in the main
window. To open the Navigator window, click the
button. The area of the slide
you are viewing has a box around it. You can move to a different area of the slide
using the Navigator window by clicking on a different area, or by dragging the box
around by pressing and holding the mouse button and dragging the mouse. To close
the Navigator window, click the
button again.
Modifying Digital Slides
The digital slides can be modified in the context of the case. They can be rotated,
flipped, or/and cropped. Users can also adjust the brightness and contrast. All of the
changes are not persisted on the original digital slide but are stored within the case
and only work within the context of the case.
To transform the orientation of a slide:
1. Click the
button.
2. Make sure that the Transform tab is selected and select the rotation that you
desire.
14
To change the brightness or contrast of a slide:
1. Click the
button.
2. Make sure that the Brightness/Contrast tab is selected and move the sliders
to set the desired brightness and/or contrast.
To crop a slide:
1. Click the
button.
15
2. Make sure that the Crop tab is selected.
3. Click the Crop Image button and set box to desired points to crop the image.
If at any time you want to go back to the original image click the
button at the bottom of the window. When this button is selected it will undo of all
the transformation that were made to the slide.
Expand Digital Slide Area
The viewer area can be expanded by clicking the
button or pressing Alt + W on
your keyboard. The viewer area will open in a popup window. To close the
expanded viewer area, click the
button again or press Alt + W on your keyboard.
Annotating Digital Slides
Various shapes are available for annotating slides. To draw an annotation on a slide:
1. Select the appropriate drawing button by either clicking the button or using the
appropriate keyboard shortcut.
2. Hold down the left mouse button over the slide and move the mouse to draw the
shape.
3. Release the mouse button.
Below is a table listing each type of shape available, a picture of the button used for
drawing it, and the keyboard shortcut for selecting the button.
Shape
Button
Shortcut
16
Arrow
Alt + A
Rectangle
Alt + R
Oval/circle
Alt + O
Polygon
Alt + P
Measuring tool
Alt + M
Annotations can also be added by choosing the appropriate option from the
Annotations menu.
Once a shape is drawn, it will be listed on the Shapes Tab on the right-hand side of
the screen. To delete a shape, right click the shape in the list of shapes and select the
Delete option.
Modifying Shapes
Shapes that are drawn can be modified using the black boxes that appear on the
edges and midpoint of each shape. Boxes on the edges can be used to resize or rotate
shapes, and the midpoint can be used to move the shape to a different area of the
slide. Simply hold down the left mouse over the appropriate box, and drag the
mouse to resize, rotate, or move the shape as desired.
Cut/Copy/Paste Shapes
You have the ability to cut, copy, and paste shapes. Cutting and pasting shapes under
a new tag will simply move the shape to that new tag. Copying shapes will duplicate
the shape which can then be pasted under a different tag.
To copy a shape:
1. Right click the shape and select Duplicate Shape or select the shape and
select Copy from the Edit menu.
To paste a shape:
1. Select the tag that you want to paste to and select Paste from the Edit menu.
To cut a shape:
1. Select the shape that you want to cut and select Cut from the Edit menu.
Taking Example Pictures from a Digital Slide
You have the ability to capture a region of a digital slide to be saved as an example
picture of any Knowledge Base concept.
To take a screenshot:
1. Click the
button.
2. Select the portion of the screen you want to take a screenshot of by holding down
the left mouse button and dragging the mouse. A shaded box will indicate what
region is selected.
17
3. Navigate to the folder where you want the screenshot to be saved.
4. Type in a file name for the screenshot to be saved as in the File Name box.
5. Click Save.
Tags
Tags can be created to group annotations together to keep them organized and to
simply linking annotations with concepts. For example, if you have drawn a lot of
shapes marking the area of a lymphocytic infiltrate, you might want to create a tag
called “lymphocytes” and put all of the lymphocyte shapes under this tag.
Create a Tag
To create a single tag:
1. Click the
button in the shapes tab, choose Add Tag from the Case
menu OR right click a particular shape and choose the Add Tag option
(NOTE: using the right click method will automatically move that shape
under the tag being created.)
2. Type in the name of the tag.
3. Click OK.
To create multiple tags at once:
1. Click the
button in the shapes tab.
2. Type in each name of a tag separated by a comma.
3. Click OK.
Delete a Tag
To delete a tag:
1. Select the tag you would like to delete
2. Click on the
button or Right click on the tag and select Delete.
Any shapes associated with that tag WILL NOT be deleted. They will be moved
underneath the default tag, “Untagged”.
Organizing Annotations with Tags
To associate untagged annotations to a single tag:
1. Select the shapes you would like to associate with a tag
2. Drag and drop (hold down the left mouse button and drag) shapes to the
appropriate tag.
If a shape(s) are already associated with a tag, they can also be copied to another
tag. To associate shapes to an additional tag:
1. Select the shapes you would like to associate with an additional tag
2. Click the
button
3. From the pop up window, select the additional tag you would like the
shape(s) to be associated
4. Click OK.
18
Case Authoring for SlideTutor ITS
The case authoring process for SlideTutor ITS is unique from the standard authoring
of digital slides. In order to ensure the case content will work properly in the ITS, it
is imperative that you first understand the ITS requirements.
Locations Annotations
The first annotation requirement is the list of Locations annotations. These
annotations must have an area(s) of the digital slide associated with them. Typically
freehand polygons, rectangles and circles are used as Locations. The Locations
annotations are used to monitor where a student can identify a particular
Knowledge Base concept and also provide assistance to the student on where
he/she should look for a particular concept. To learn how to add shape(s)/tag(s) as
a Location Annotation see the “Linking Annotations with Knowledge Base Concepts”
section below.
19
AUTHORING NOTE:
Using the concept authored above, the ITS provides a hint using one of the polygons
listed to provide a hint to the student where to look for “lymphocytes”. Therefore,
Locations should be use to point the student in the general area of where to look for
a concept.
Prime Example Annotations
The second annotation requirement is the Prime Example annotation. The prime
example annotation can be any type of shape. However, arrows are the most
common form of Prime Example annotation. The Prime Example annotations are
used to point to an exact location of a concept. To learn how to add shape(s)/tag(s)
as a Prime Example annotation see the “Linking Annotations with Knowledge Base
Concepts” section below.
20
AUTHORING NOTE:
Using the concept authored above, the ITS provides a hint using the Prime Example
annotation to show the student what a “lymphocyte” looks like.
Linking Annotations with Knowledge Base Concepts
Once annotations have been added to a case, they should be linked with knowledge
base concepts to establish what each shape’s purpose is. Each shape can be used for
multiple concepts; however, each shape must be linked with at least one concept.
Linking can be done in numerous ways:
Drag the shape or tag in the Shapes list up to the appropriate concept.
Drag the concept to the appropriate shape or tag in the Shapes list.
Right click the shape or tag and choose Link. Choose the appropriate concept from
the popup that appears.
Right click the concept and choose Link. Choose the appropriate shape or tag from
the popup that appears.
Concepts that have only Location annotations OR Prime Example annotation linked
with it, it will turn yellow. Once a concept has both a Prime Example annotation and
Locations annotations linked to it, it will turn green.
Case Concept Properties
Properties of concepts within a particular case include the annotations linked with
that concept, whether that concept is asserted (has all appropriate annotations
linked with it), and whether the concept is present or explicitly absent in the case.
21
Viewing Case Concept Properties
To view properties for a particular concept, double click that concept. A popup
window will appear showing the properties for that concept.
To view the properties of all concepts of a particular type (diagnoses, findings, or
prognosis), click the
button. Each concept will be listed as a tab at the top of the
popup window.
Modifying Linked Annotations Using Case Concept Properties
Additional annotations can be linked to a concept using the Case Concept Properties
popup window by dragging shapes or tags from the Shapes list to the appropriate
box in the popup, or by using the appropriate
button and selecting the shape or
tag from the popup window that appears.
Annotations can also be unlinked by clicking the annotation in the Case Concept
Properties popup window and clicking the appropriate
button.
Asserted Concepts
Asserted concepts are concepts that are true for that individual case. For example, if
the set of findings {X or Y} is associated with the diagnosis of Bullous Pemphigoid
and only Y is present in the case, then you would want to assert concept Y to inform
the ITS that Y is indeed part of the case. Asserted concepts have a green border
around them. Concepts that are parsed through the report or manually added to the
case will automatically be asserted. To manually assert a concept you can right click
the concept and choose Assert Concept from the menu.
Recommendations/Advice
In some tutoring systems it may be desirable to associate recommendations or
advice with a diagnosis or a finding in the tutoring case. For example, if
recommendation concept “use steroid cream” is associated with diagnosis “acute
burn” then the tutoring system may do additional tutoring incorporating that
recommendation if that diagnosis is observed.
Validating Knowledge Base Concepts for a Case
After completing the case authoring, click on the
button to check that the case
information is consistent with the Knowledge Base content for a disease. If the
information authored is NOT consistent with what is in the Knowledge Base,
DomainBuilder will add any missing concepts to your case OR it will give you a
warning message telling you what is inconsistent.
Adding Additional Pathologies to the Case
Some cases may have multiple unrelated diagnoses on one or several slides within
the same case. These instances should be marked so that the system can distinguish
between the unrelated diagnoses.
22
Creating and Deleting Additional Pathologies
Before you can add additional pathologies to unrelated diagnoses you must first
create it.
To create additional pathologies:
2. Click on the
button or select Other Pathology from the case menu.
3. Click on Add Other Pathology
4. Type a description of the pathology being added in the popup window.
5. Click OK.
Once you have added your additional pathologies they will be available for selection
the Other Pathology menu. You can remove unwanted pathologies by clicking
Remove Pathology and selecting the pathology that you want to remove from
the drop down menu and clicking OK.
Marking Unrelated Diagnoses with Respective Pathologies
Once new pathologies have been added you can mark the unrelated diagnoses with
their respective pathologies to tell the system that the case diagnoses are in fact
unrelated to each other and do not constitute a differential diagnoses.
To mark unrelated diagnoses with their respective pathologies:
1. Right click on a diagnosis.
2. Select Pathologies sub menu
3. Click to check off pathologies that apply to the diagnosis
AUTHORING NOTE:
When a pathology is added to a diagnosis all findings that are associated with that diagnosis
will automatically be marked with the same pathology. You can manually set pathologies for
individual findings by right clicking them and selecting or deselecting the appropriate
pathologies.
Viewing Different Pathologies
In order to view different findings and diagnoses that are associated with different
pathologies:
1. Click on the
button or select Other Pathology from the case menu.
2. Select a pathology description that you would like to view
Once a pathology is selected all findings and diagnoses that are not associated with
the selected pathology will be grayed out. To return to original display select the All
Pathologies option from the same menu.
Case Status
The case status is set for case management purposes so that the author will know
which cases are ready to be deployed, which cases still need to be tested, and which
cases still have authoring issues associated with them.
23
To mark the status of a case:
1. Select Case Status in the Case menu or Click the
button.
2. Select the appropriate status from the list (Incomplete, Complete, Tested).
Knowledge Tab
The Knowledge Tab is where all of the creating and editing of knowledge base
information is handled, and contains three sub-tabs:
Hierarchy Builder: This tab allows concept creation and the organization of
concepts into a tree-like structure.
Diagnosis Builder: This tab allows you to link diseases with its associated
findings and visualized the similarities and differences between them.
Report Builder: This tab allows you to create report templates to help guide a
student in writing a complete prognostic report.
Hierarchy Builder Tab
The first sub-tab is the Hierarchy Builder tab, where you create a hierarchy
containing all concepts that go into the knowledge base. In this tab, you can add
concepts to the knowledge base, edit/arrange concepts in the knowledge base, and
add/edit definitions, synonyms, and example pictures of concepts.
When creating a new knowledge base, certain concepts will already exist. The
various concept types (ACTIONS, ANCILLARY STUDIES, DIAGNOSES, FINDINGS,
LOCATION, MODIFIERS, and VALUES) will all be present. Additionally, specific
concepts will be listed under ACTIONS and VALUES.
Pre-existing concepts in Knowledge Base
Adding Concepts
To add concepts to the hierarchy:
1. Click the appropriate parent concept/concept type in the hierarchy to select it.
(NOTE: concepts will always be added beneath the selected concept.)
2. Choose the Add Concept option by either right clicking the selected concept OR
24
choosing Add Concept from the Builder menu.
3. In the popup window, you can add the concept(s) you would like to create. If you
would like to create a hierarchy of concepts, simply type the parent concept first and
then in the next line insert a tab before the child concept. For example, if you wanted
to create the following hierarchy under "MALIGNANT MELANOCYTIC LESION"...
You would insert the following into the popup window...
4. Click OK.
Cut/Copy/Paste/Delete Concept Options
In addition to adding new concepts, changes can be made to the knowledge base
hierarchy using the cut, copy, paste, and delete options. Below is a table listing each
option, a picture of the button used for that option, and the keyboard shortcut. The
keyboard shortcuts for cut, copy, and paste are the standard keyboard shortcuts for
these options.
Option
Button
Shortcut
Cut
Ctrl + X
Copy
Ctrl + C
25
Paste
Ctrl + V
Delete
Delete
These options are also available when you right click a concept.
Information that is cut or copied is displayed in the clipboard popup box displayed
in the lower left-hand area of the screen to allow easy viewing of this material.
When the delete option is selected, a confirmation box appears asking if you want to
delete the selected item.
Adding Concept Information
When a concept is selected in the hierarchy, information for that concept can be
added in the panel on the right-hand side of the screen. A definition can be added, as
well as synonyms and example pictures.
26
Manually Adding Definitions and Synonyms
It is important for definitions and synonyms of concepts to be included in the
knowledge base.
To add a definition:
1. Select the appropriate concept in the hierarchy by left clicking it.
2. Click the definition textbox to place your text cursor.
3. Type in the definition.
To add synonyms:
1. Select the appropriate concept in the hierarchy by left clicking it.
2. If there aren’t any empty rows in the synonyms table, click the
button to add a
row.
3. Click the first empty synonym textbox to place your text cursor.
4. Type in the synonym.
You can move your cursor to other synonym textboxes by using your mouse like in
step #2 above, using the Tab or Enter keys on your keyboard, or using the up and
down arrows on your keyboard.
Importing Definitions and Synonyms from the Terminology
Definitions and synonyms can also be imported from the terminology by clicking the
button. When this button is clicked, a popup window
appears listing possible matches found in the terminology. When a match is
selected, the terminology information will be displayed for that item. To import
information from the terminology into the knowledge base, select the appropriate
term and click OK.
27
Creating a Worksheet
Some clinical information may be added to a report using the worksheet button.
Using this button, information can be added by selecting the appropriate radio
buttons rather than typing it in.
To create a worksheet:
1. Click on PROGNOSTIC FINDINGS in the Knowledge tree.
2. Right Click on WORKSHEET
3. Click Add Concept
4. Type in the concept hierarchy for the worksheet that you would like to create.
Below is a screen shot of an example hierarchy of pathologic staging of
melanoma.
28
Once all the information is entered along with definitions the end result will look
something like this.
Diagnosis Builder Tab
The next sub-tab is the Diagnosis Builder tab, which allows you to say what findings
each disease has, and to compare findings in different diseases and see similarities
and differences between them. Diseases can have multiple distinct feature sets.
29
Adding Diagnoses
The Diagnosis Builder tab is empty when it is first opened. The first step is to add
the diagnoses you want to “build”.
To add diagnoses:
1. Click the
button.
2. Select the desired item(s) from the menu tree that appears.
AUTHORING NOTE:
If you would like to see all of your diagnoses that were previously worked on, you must
individually add each and every diagnosis that you would like to see.
Adding Findings to Diagnoses
Once diagnoses have been added, you can add findings to diagnoses, saying what
findings a particular diagnosis must have (or must not have).
To add findings:
1. Start typing already existing findings and selecting the appropriate finding from
the combo box.
OR
30
1. Right click and choose Add Finding.
2. Select the appropriate finding(s) from the tree.
3. Click OK.
Modifying Rules for Findings
When findings are initially added to a diagnosis, they indicate that this one finding is
present for that diagnosis. The default is for cells to be ANDed, meaning all of the
findings listed must be present. However, findings can be modified to mean other
things – you can indicate that a finding is not present for a diagnosis, and you can
indicate that you have to have either one finding OR another finding in that
diagnosis. These options are performed using the NO, OR, and AND options.
To add rules for findings:
1. Highlight the appropriate finding cell(s) by clicking and dragging your mouse.
2. Click the appropriate rule button OR right click and choose the appropriate
option.
Adding Multiple Patterns of a Diagnosis
Sometimes a diagnosis can present itself with multiple visualized patterns. In order
to create multiple patterns for a given diagnosis, make sure the diagnosis is added to
the panel and then select the diagnosis name (highlighted in yellow) and click the
OR button. Another column will be added to the panel with the same diagnosis,
which indicates that this disease has two different patterns of findings associated
with it.
Cut/Copy/Paste Findings
Findings can also be linked to a diagnosis using the cut, copy, paste, and delete
options. Below is a table listing each option, a picture of the button used for that
option, and the keyboard shortcut. The keyboard shortcuts for cut, copy, and paste
are the standard keyboard shortcuts for these options.
Option
Button
Shortcut
Cut
Ctrl + X
Copy
Ctrl + C
Paste
Ctrl + V
Delete
Delete
Align Findings
Findings can be aligned to make comparing findings across diseases easier. To align
findings, click the
possible.
button. Findings will then be aligned as much as
31
Import Findings from Spreadsheet
Findings can be automatically created and linked to a diagnosis by importing a
Comma Separated Value(.csv) file into DomainBuilder. Comma Separated Value files
can be created through applications, such as Microsoft Excel. To create a .csv file...
1. Create a spreadsheet with the first row of each column being the diagnosis and
each subsequent row the appropriate findings associated with the diagnosis.
COMPOUND MELANOCYTIC
NEVUS
lentiginous proliferation of
melanocytes OR junctional nest
of melanocytes
melanocytes in dermis OR nest of
melanocytes in dermis
NO cytologic atypia
NO pagetoid spread
maturation
INTRADERMAL
MELANOCYTIC NEVUS
melanocytes in dermis OR nest of
melanocytes in dermis
NO lentiginous proliferation of
melanocytes
NO junctional nest of
melanocytes
NO cytologic atypia
maturation
JUNCTIONAL
MELANOCYTIC NEVUS
lentiginous proliferation of
melanocytes OR junctional nest
of melanocytes
NO melanocytes in dermis
NO nest of melanocytes in
dermis
AUTHORING NOTE:
In order to create an OR-ed rule simply place "OR" (in caps) between the two features. In
order to create an absent finding simply place "NO" (in all caps) before the concept.
2. In the menu, click on File and then Save As. Enter in the name of the file and make
sure to choose CSV or Comma Separated Value as the file type.
3. Open DomainBuilder and create/open the appropriate Knowledge Base.
4. Click on the Knowledge Tab and then the Diagnosis Builder Tab.
5. Click on
and browse for the .csv file. Click OK.
NOTE: Please be patient! It can take several minutes to create and import all of the
concepts in the spreadsheet.
6. Once the tool is finished importing the concepts, you can click on the Hierarchy
Builder tab to find all of the newly created concepts.
The concepts are not automatically created in a hierarchy from this import process.
All of the diagnoses are simply added to the DIAGNOSIS class and all findings are
added to the DIAGNOSITC FINDINGS class. In the Hierarchy Tab, it is up to the user
to create the proper hierarchy from the added concepts or use the
organize the hierarchy automatically.
button to
Find/Replace Findings Inside all Diagnostic Rules
Sometimes it may be desirable to replace all occurrences of one finding from all
diagnostic rules with another or remove it all together. Often times this happens
32
when two findings are merged into a single finding due to a typo or new information
from a source.
To find/replace findings inside all diagnostic rule:
5. Click on the
button or
Find/Replace Finding from the Builder
menu.
6. Click the
button next to Search for Finding field to add a finding to search
for.
7. Click the
button next to Replace with Finding field to add a finding to
replace it with.
8. Click Find to open all diagnostic rules that contain the finding you are
searching for OR click replace to perform a replacement operation in all rules
that the finding is located in.
Below is a screen shot for the Find/Replace function:
Report Builder Tab
The last sub-tab in the Knowledge Tab is the Report Builder tab, which contains
templates for writing prognostic reports. In this tab, you can create and edit
templates, and assign individual prognostic findings to a template.
33
Creating a New Template
To create a new report template:
1. Click the
button in the Templates area of the screen OR right click in the
Templates list area and select the Add Template option.
2. Type in a name for the template.
3. Click OK.
Deleting a Template
Report templates can be deleted from the Knowledge Base.
To delete a template:
1. Click the template to select it.
2. Click the
button in the Templates area of the screen OR right click and select
the Remove Template option.
Reportable Items
Reportable Items are a list of concepts that you would like the ITS to monitor the
student’s ability to assess and include in a prognostic report.
34
Adding Reportable Items
To add a Reportable Item click on the
Add Reportable Items button either in the
middle of the template or on the menu bar at top. Select the appropriate concept(s)
in the order you would like the items to appear in the student’s report. Click OK.
Deleting Reportable Items
To remove a Reportable Item click on the remove link to the right of the concept you
would like to be deleted.
Reorder Reportable Items
After Reportable Items are added to a template, they can be reordered.
To increase the priority of a Reportable Item, click the “up” link at the right of the
concept to move the concept up one position. Continue clicking the “up” link until
the concept is in the desired position.
To decrease the priority of a Reportable Item, click the “down” link at the right of
the concept to move the concept down one position. Continue clicking the “down”
link until the concept is in the desired position.
You can also reorder reportable items by changing the order number to the left of
the item.
Triggers
Each template needs to be assigned triggers to indicate when the template should be
used.
Adding a Trigger
To add a trigger:
2. Click on the
button under Triggers in the Template heading.
3. Select the appropriate conditions that will activate this report
template
4. Select OK
The default is for triggers to be ANDed, meaning all triggers must be present for the
template to be triggered. You can also use the OR or NO to create more complex
triggers scenarios within the template.
35
AUTHORING NOTE:
Triggers are the conditions upon which a template is activated. For instance, if there is one
format for reporting about a needle core biopsy of adenocarcinoma and another format for
reporting about a resection of adenocarcinoma, you would create one template that has the
triggers “Adenocarcinoma” and “Needle core biopsy” and another template with the triggers
“Adenocarcinoma” and “Resection”.
Deleting a Trigger
To delete a trigger:
1. Select the trigger that is to be deleted
2. Click the
button.
Validation Tab
The Validation Tab allows you to verify information in the knowledge base and
individual cases. By mousing over a particular item, all items of other types
containing that item will by highlighted. For example, if you mouse over a finding, all
diagnoses and cases containing that finding will be highlighted. If you mouse over a
particular diagnosis, all findings that disease contains (according to the knowledge
base) and all cases with that diagnosis will be highlighted. If you mouse over a
particular case, all findings and diagnoses that case contains according to the
authoring will be highlighted. In this way, information in the knowledge base and
individual case authoring can be checked and validated before being used in the
tutoring system.
36
Search
A search tool is available at the top of the screen to make finding particular items
easier. Simply type in the word or string you wish to search for. Any items
containing the search string will be highlighted yellow.
Preview Cases
Cases can be previewed in the Validation Tab. When you double-click a case, a
popup window will appear containing a preview of the digital slides and the
pathology report assigned to that case during case authoring. You can open the case
using the Go To option described below.
AUTHORING NOTE:
Cases are colored based on the Case Status assigned from the Case Tab. Cases in red are
Incomplete cases. Cases in blue are Completed cases. Cases in green are Tested cases.
Right Click Menu Options
Several options are available when you right click a finding, diagnosis, or case in the
Validation Tab.
37
Glossary
The glossary option will display the definition of the selected finding or diagnosis.
For cases, the glossary will display the difficulty of the case, and whether the case is
ready to use. To view glossary information for an item, right click the item and select
the Glossary option.
Bookmark/Unbookmark
Bookmarks can be set to help with verification. When a bookmark is set, any items
linked with that item will be highlighted green. For example, if a bookmark is set for
a particular finding, all diagnoses and cases containing that finding will be marked.
If a diagnosis is bookmarked, all findings that diagnosis contains and cases with that
diagnosis will be marked.
To set a bookmark, right click the item and select the Bookmark option. A bookmark
that has been set can be removed by right clicking the item and selecting the
Unbookmark option.
Open Option
The Open option allows you to jump to a particular concept in the knowledge base
or open a case from the Validation Tab. To go directly to a concept or case from the
Validation Tab, simply right click the appropriate item and select the Open option.
Summary
A case summary is available that provides basic statistics of cases that are in
DomainBuilder. To access this case summary click on the
left hand corner of the Validation Tab.
38
button in the upper
39
Download PDF