User`s Guide - HREM Research

V3.6
STEM
for xHREM™
(WinHREM™/MacHREM™) Scanning
Transmission Electron Microscope Image
Simulation Program
User's Guide
STEM for xHREM
Scanning Transmission Electron Microscope
Image Simulation Program
User's Guide Contents n Introduction n Installation n Let's Start Tutorials Data Preparation Dynamical Scattering Calculation Gray-scale STEM Images Display n Topics
TDS Absorption
Required RAM Size
STEM
2
STEM for xHREM
n
Introduction This is a program to simulate a scanning transmission electron microscope
(STEM) image. This program is designed as an optional function of
xHREM™ (WinHREM™/MacHREM™), a program suite simulating a
high-resolution electron microscope image for Windows/Mac OS.
xHREM™ has the following features.
Concept of xHREM™
1. User Friendly Graphical Interface xHREM™ employs user friendly Data Generation Utilities based on the
Graphical User Interface for Windows or Mac OS.
xHREM™ is general-purpose software that can be used to simulate all the
images expected from any crystal systems, defect structures and interfaces.
Although data generation for such general-purpose software normally
becomes complex, a novice user can easily generate his/her data by using
the graphical Data Generation Utilities with minimum requirements for the
special knowledge.
2. Reliable and Efficient Algorithm
xHREM™ emerges from the HREM image simulation programs based on
FFT multislice technique developed at Arizona State University, USA (see
References). This is one of the most reliable and efficient HREM image
simulation programs.
3. High Quality Image Output
Numerical data such as projected potential, wave function propagating the
specimen, simulated image intensities could printed as high quality gray
scale maps (Bitmap) by using Output Graphic Utilities. Numerical value
of each pixel of the gray scale can be exported for further analysis with
other software.
Concept of STEM Extension
1. User Friendly Graphical Interface STEM Extension employs user friendly Data Generation Utilities based on
the Graphical User Interface for Windows or Mac OS.
.
STEM
3
STEM for xHREM
2. Reliable and Efficient Algorithm
Thermal Diffuse Scattering (TDS) is believed to be the main source of
signal for STEM-HAADF image. STEM Extension will efficiently treat
TDS using absorption potentials. Please consult the following paper for a
detailed description:
K. Ishizuka: A practical approach for STEM image simulation based on the FFT
multislice method, Ultramicroscopy 90 (2001) 71-83.
3. Efficient Computation (Multi-CPU Support)
STEM image simulation is number crunching, since scattering calculation is
necessary at each scanning point. Therefore, STEM Extension supports
multi-CPU (Core) to accelerate computation.
Note: From the next version (v3.6) the following two STEM Extensions
will be newly released: STEM Extension Cluster (a cluster support) and
STEM Extension Pro (64-bit OS support).
STEM
4
STEM for xHREM
n
Installation STEM programs and some sample data should be already installed into your
hard disk, when you have installed xHREM Simulation Suite.
When you purchase STEM program as an additional order, you have to
update your user key. This update can be done by using Remote Update
System (RUS). When you send current key information, then we will send
back information to update your key.
STEM
5
STEM for xHREM
n
Let's Start Tutorials Data Preparation
Most of the data for scattering calculation control will be prepared by using
"MultiGUI". A set of data specific to the STEM simulation will be specified
in the optional windows. Please consult xHREM User's Manual about the
general scattering calculation controls.
A sample data for SnO2 will be provided with the program.
In order to set up the optional data specific to the STEM simulation, click
"STEM" from the Options at the bottom of the MultiGUI WORKSHEET.
Then, the following window will open:
STEM
6
STEM for xHREM
1
2
3
1.
Optical Parameters
Input an aperture radius, aberration coefficients. The aperture radius
may be given in mrad (You have to select mrad in the Preferences
before open this window.)
You can perform calculations at multiple defocuses. Here, the center
defocus, defocus step and a number of defocuses at over- and
under-focus sides.
2.
Detector Parameters
Detector radiuses of the bright-field imaging and the dark-field imaging
will be specified here. These radii may be given in mrad (You have to
select mrad in the Preferences before open this window.)
STEM
7
STEM for xHREM
3.
Scan Control
Scan Mode:
Scanning scheme will be selected from the list shown
below.
Position:
Scanning position(s) will be specified here. The scanning
positions will be specified in different ways according to the
scanning mode.
Area:
The ranges of the scanning area and numbers of scanning
points along x and y will be specified for this mode.
Line:
The starting position and the ending position as well as the
number of scanning points will be specified for this mode.
Point:
A single position will be specified for this mode.
Whole Unit:
The whole unit area will be calculated assuming an
applicable symmetry. Thus, the two-dimensional symmetry
group and an approximate scanning step (interval) will be
specified. Integral number of scanning points will be
calculated internally according to the approximate sampling
interval.
Data Output Cycle: STEM
image intensity output interval in terms of the
slices.
List Output: the list output showing a scan progress. When a computing time
for each slice is very quick, the scan list output may control the overall
turnaround time. In this case, a simpler lit output is effective to shorten
the turnaround time.
STEM
8
STEM for xHREM
1
2
3
1.
High Order Aberration Coefficients
High order geometrical aberration coefficients up to 5th order can be
specified here. Although various definitions of the coefficients appear
in the literatures, we simply define them in terms of wave aberration as
Cnm (n +1)
α
cos m(φ − φ nm ) .
(n + 1)
2.
€
Super-cell Size
Super-cell size used in computation will be selected from the following
pull-down list. Normally, “Standard” can be selected here:
STEM
9
STEM for xHREM
The super-cell size in computation should be larger than the input
structure model. If the structure mode is smaller than the super-cell size,
the input model is repeated to fill the super-cell. Thus, the model size in
computation is a multiple of the input model.
3.
32bit/64bit Selector
If the 64bit module and/or Cluster module is not installed to Programs
folder, you cannot select it.
Super-cell size and sampling*
n
Model
Model size
(Approximate)
Sampling
points*
FT space interval
(Approximate)
1
Test
12.5 A
128
0.08 / A
2
Small
25
256
0.04
3
Standard
50
512
0.02
4
Large
100
1024
0.01
5
Huge
200
2048
0.005
6
Ultimate
400
4096
0.0025
*The number of the sampling points is estimated for a rectangular unit
cell assuming the calculation Range of 5.0/A (in d*). An approximate
number of the sampling points is 2xRange /(sampling interval).
The calculation limit in Fourier space is specified by “Range” at
Preferences/Dynamical calculation. The numbers of the sampling point
will increase proportionally with the Range. For an oblique system the
required number of pixels becomes larger than the number shown here.
TIPS:
Normally, the Range of 5.0/A is enough for calculation using
HAADF TDS absorption potentials.
TIPS:
For STEM image calculation the super-cell less than “Standard”
is not recommended in order to evaluate scattering profile.
TIPS:
NOTE
STEM simulation will use a large number of the sampling
points. Therefore, you will get a huge amount of the list
output, when you try to print out the whole area of the
potential distribution or the scattering distribution.
STEM 10
STEM for xHREM
Dynamical Scattering Calculation
1.
Create the general scattering calculation controls in the main WORKSHEET.
To calculate elastic scattering to high-angle, a calculation range
of s=1.5-2.0/A (d*=3.0-4.0/A) or higher will be set by Preferences ->
Dynamical calculation > Range. However, “Doyle-Turner“ cannot be
used above s=2.0/A. You have to select “Weikenmeier-Kohl” foa a
calculation over s=2.0/A.
TIPS:
Choose “Weikenmeier-Kohl Scattering Factor” from
Preferences/Atomic Scattering factor, and check “Including TDS
Absorption” box. However, when you want to ignore TDS absorption,
and obtain a STEM image using only elastic scattering, you don’t need
to check this box. Please note that including TDS absorption requires
a thermal factor (Debye-Waller factor) of each atom.
TIPS:
4.
Set up the optional data for STEM simulation.
5.
Launch STEM program by choosing "Execute STEM" from the File menu of
the MultiGUI.
6.
A window showing the progress of the calculation appears.
When an execution terminates normally, you will get the message
"Execution completed. Congratulation!"
Calculation of a STEM image by scanning many points will take
a long time. Thus, you can stop calculation and continue it layer. In
order to resume calculation, choose “Append” from MultiGUI ->
Multislice Calculation. When you stop calculation, a calculation will
resume from the following scan point on which a full propagation has
been completed.
TIPS:
7.
You can save the result window by choosing "Save As…" from the File menu
of the result window.
STEM 11
STEM for xHREM
Gray-scale STEM Images Display Gray scale STEM images will be generated by using the "STEMimage"
utility. The STEM data has been output to a .SD file.
To display a gray scale STEM image, do this:
1.
Launch STEMimage.
2.
Select a ".SD" file with your sample name in the file selection dialog.
(Windows) When you can not find your SD file, confirm that the file
type specification is "SD Data (*.SD)."
The following window will be appeared.
3.
Select "Display Mode"
Select a display mode from "STEM Image", "Thickness Map" and
STEM 12
STEM for xHREM
"Point." Selectable display mode is depending on the Scan Mode.
As in this case of a two-dimensional scan image, you have to select the
specimen thickness (slice number), a display area and a resolution
(Pixels/length).
When multiple defocus data is available, you can select a defocus value
(or a center defocus value of Defocus Spread).
When the Scan Mode is "Whole Unit," you can extend the display area
more than one unit cell.
4.
From "Image Mode" you can select the image type from "Bright Field" or "Dark
Field." In the case of the dark field image, you cal also select the image
signal(s) from TDS inelastic signal and/or coherent elastic signal.
5.
Click "Generate" to display a gray scale image.
You can select one of the two interpolation methods (Fourier
Transform/Bi-linear Interpolation) to estimate intensity between the
calculated points. Usually, an interpolation using Fourier transform gives
smoother image. Thus, a wider step (scan distance) can be used in
calculation and a computation time may be substantially decreased.
TIPS:
Partial coherency due to a probe size as well as a defocus spread can
be estimated. Here, Gaussian distributions are assumed for both the probe
size and the defocus spread, and a full width at 1/e value is specified.
TIPS:
In order to estimate partial coherency due to a defocus spread the
STEM images at multiple defocuses in a sufficient range should be
calculated.
NOTE:
Each pixel value of a gray scale map produced by STEMimage can
be output using “Save As…” command as you can do by using ImageBMP.
The original data used to produce the gray scale map can also be output
using “Save As…” command. Please consult “Numerical Data Output
Using ImageBMP” in the xHREM manual for more details.
TIPS:
STEM 13
STEM for xHREM
n Topics
In this section some useful functions as well as advanced topics will be
introduced. It is not necessary to read through all the topics at the first time.
You may want to study each topic when you need to use it.
Including TDS Absorption
You can include absorption of elastically scattered wave due to thermal
diffuse scattering (TDS) in your dynamical calculation. In this case,
however, thermal displacement parameter (temperature factor;
Debye-Waller factor) for each atom in your atomic model is required.
When you don’t know a corresponding parameter, an approximate value
may be specified.
To include TDS absorption in your dynamical calculation:
1. Launch MultiGUI
2. Choose “Preferences” from Edit menu.
3. Select “Weikenmeier-Kohl Scattering Factor” in “Atomic Scattering Factor”
section of the Preferences dialog, and check “Include TDS absorption.”
STEM 14
STEM for xHREM
Required RAM Size
For STEM image simulation, scattering calculation is necessary at each
scanning point. Then, we have to use all the phase gratings for each scan
point. A cotemporary operating system (OS) allows us to use many phase
gratings by using a virtual memory management.
However, when a main memory is short to store only a single-phase grating,
all the phase gratings should be read from an external memory as a result of
roll-in/roll-out. If an external memory is a hard disk, a significant time is
required to read the phase gratings into the main memory. Therefore, all the
phase gratings should be stored in the main memory for an efficient
computation.
Typically, each program can use a roughly 2GB using a 32-bit OS. If the
total phase gratings is bigger than this size, you have to use STEM
Extension Pro that supports a 64-bit OS.
TIPS: In the case of a Standard model with 512x612 pixels, each phase
grating requires the following memory:
(512x512) x 8 (complex) x 2 = 4MB.
A larger model uses more phase gratings of larger size, so the total phase
gratings will become more than 2GB.
STEM 15
Download PDF