DIGE tutorial
Tutorial, Part 2 – DIGE
Contents
Contents ....................................................................................... 42
2
Melanie DIGE Tutorial.......................................................... 43
2.1
2.2
2.3
2.4
The DIGE tutorial experiment ............................................... 43
A few words about experimental design ........................... 44
Open your images ................................................................ 44
Review your images ............................................................. 48
2.4.1
2.4.2
2.4.3
2.4.4
Layout ..................................................................................48
Basic operations .................................................................48
Adjust the contrast .............................................................49
Image toolbar.....................................................................50
2.5 Create a project and match set ......................................... 52
2.5.1
2.5.2
Creating the project..........................................................53
Displaying images in a match set sheet ........................54
2.6 Detect spots ........................................................................... 55
2.6.1
2.6.2
Detecting spots ..................................................................55
Reference confirmation....................................................60
2.7 Add landmarks ..................................................................... 61
2.7.1
2.7.2
Changing layout ................................................................61
Defining landmarks ............................................................62
2.8 Match gels ............................................................................. 63
2.8.1
2.8.2
Matching gels .....................................................................63
Edit matches .......................................................................64
2.9 Create and open classes ..................................................... 67
2.10 Data analysis ......................................................................... 70
2.10.1
2.10.2
2.10.3
2.10.4
2.10.5
Class Analysis Table ...........................................................71
Class Analysis Histograms..................................................72
Identifying protein expression changes .........................73
3D view ................................................................................75
Reviewing spots ..................................................................77
2.11 Pick list ................................................................................... 78
2.11.1
2.11.2
2.11.3
2.11.4
2.11.5
Adding the pick gel to the project .................................78
Detecting spots on the pick gel ......................................81
Annotating the reference markers .................................82
Matching the pick gel .......................................................84
Generate a pick list ...........................................................86
2.12 Export tables .......................................................................... 88
Melanie DIGE Tutorial 2
2
Melanie DIGE Tutorial
This tutorial will take you through the analysis of a DIGE experiment. The
tutorial takes about 45 min to complete and is therefore the fastest way
to start exploring Melanie on your own. More detailed and advanced
information can be found in the User Manual. Nevertheless, if you have
any questions or need assistance, please contact us at [email protected]
The Melanie Demo version is fully functional when analyzing the tutorial
images, but it does not allow spot detection and matching on other
gels. To analyze your own images, you may purchase a Full license or
request a Trial license by contacting us at [email protected]
Please note that there is another tutorial for the analysis of a
conventional, single stain gel electrophoresis experiment.
We assume several things at this point:

You are an experienced computer user.

You have already successfully installed Melanie.

You have knowledge of electrophoresis and staining techniques.
Note: In this DIGE tutorial, a distinction is made between the terms Gel
and Image. Gel is used to indicate the physical gel, whereas Image is
used for the separate Cy dye images that have been obtained from
the physical gel. One DIGE Gel comprises two or three DIGE Images.
2.1
The DIGE tutorial experiment
The sample gels used in this tutorial come from an experiment that aims
to study protein expression changes between control and treated
groups of bacterial cultures.
In this study, eight sample lysates were prepared; four were derived
from treated bacterial cultures and four were derived from un-treated
(control) bacterial cultures. Aliquots from each sample were taken and
pooled to prepare a standard sample (pooled internal standard). The
samples were run on four gels. The control and treated samples were
alternatively labeled with Cy3 or Cy5 (dye swap) to avoid dye-bias. The
standard was labeled with Cy2 and run on each gel in the experiment.
A preparative gel, including reference markers, was run on the pooled
sample and post-stained with a Fluor total stain to pick spots and
identify them by mass spectrometry (MS).
Melanie 7.0 Tutorial – Edition AB
43
2
Melanie DIGE Tutorial
2.2 A few words about experimental design
Gel
Cy2
Cy3
Cy5
Gel 01
Pooled internal standard
Control A
Treated A
Gel 02
Pooled internal standard
Treated B
Control B
Gel 03
Pooled internal standard
Control C
Treated C
Gel 04
Pooled internal standard
Treated D
Control D
To keep the tutorial simple and short, only six images belonging to the
gels Gel 01 and Gel 02 are included in the current analysis.
The complete set of 12 images, belonging to four gels, is available in
the software installation folder.
2.2
A few words about experimental design
For the purpose of this tutorial, only two biological replicates per
treatment group are included in the analysis. This is not to be taken as a
suitable number for a real-world experiment that aims to obtain
meaningful results. It is essential to understand that appropriate
experimental design and planning are critical if you want to draw
significant conclusions from your study. We recommend the following
articles to learn more on the subject:
Cairns, D. A. (2011). Statistical issues in quality control of proteomic
analyses: good experimental design and planning. Proteomics, 11(6),
1037-48. doi:10.1002/pmic.201000579
Karp, N. A., & Lilley, K. S. (2007). Design and analysis issues in
quantitative proteomics studies. Proteomics, 7 Suppl 1, 42-50.
doi:10.1002/pmic.200700683
Horgan, G. W. (2007). Sample size and replication in 2D gel
electrophoresis studies. Journal of proteome research, 6(7), 2884-7.
doi:10.1021/pr070114a
2.3
Open your images
1
44
The first time you launch the software, a pop-up window prompts
you to enter a name for a new project. If you get this message now,
ignore it by choosing Cancel.
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
2
Instead, select File > Open in the menu. In the Open Files window,
locate the Tutorials\Images folder in the Melanie installation folder
(by default, C:\Program Files\GeneBio\Melanie 7\Tutorials\Images)
and select the six .gel files belonging to Gel 01 and Gel 02. Click
Open.
3
In the Create DIGE Gel window, make sure that the images
belonging to each DIGE gel are properly grouped and click Add or
Add All (if the two or three images on every line in the list correctly
belong to the same DIGE gel).
Note: If the file names of your DIGE images do not contain the
strings Cy2, Cy3 or Cy5, you must enter the appropriate dye for
each image before you will see this window.
4
For each DIGE gel, confirm or change the suggested name and
click OK.
Melanie 7.0 Tutorial – Edition AB
45
2
Melanie DIGE Tutorial
2.3 Open your images
The software interface shows the Menu bar, the Toolbars, the
Workspace window, the Image Pool sheet in the Display region and the
Status bar at the bottom left.
Note: The toolbars can be customized. Consult the User Manual to
learn more about adding or removing buttons.
Workspace
Menu bar
Toolbars
Image Pool sheet
Status bar
The most common commands will be available in the toolbars. The full
set of features (except Workspace-specific commands) can be
accessed from the menus.
The Workspace displays the open gels in the Image Pool folder. To add
more gels, right-click on the Image Pool folder and select Add.
The Workspace also shows the hierarchical structure (see Section 2.4) of
your projects and their content (match sets, classes and gel images).
46
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
Using the contextual menus (right-click), the buttons, and drag and
drop in the Workspace, you can display, copy, paste, move and
rename files and folders.
The projects Tutorial and TutorialDIGE are automatically installed to give
you a quick view of what a project and detected and matched gels
look like. These projects are unfinished but can be completed with the
tutorial images.
The Status bar displays the number of selected Gels, Spots, Matches
and Annotations. Hovering the mouse over these items will also display
tool tips with additional information (e.g. total number of spots,
matches or annotations). The Status bar also displays the coordinates
and the raw intensity value for the pixel under your cursor (when
moving over a gel in the Image Pool sheet).
The gel images are arranged in a tabbed sheet labeled Image Pool.
The two or three images in each DIGE gel are grouped in a pane within
the Image Pool sheet.
5
You can drag the border of the Workspace window to the left in
order to gain space for viewing the images.
Melanie 7.0 Tutorial – Edition AB
47
2
Melanie DIGE Tutorial
2.4 Review your images
2.4
Review your images
2.4.1
Layout
You can change the layout of the interface in order to optimize the
available space:
2.4.2
1
To arrange images within a pane, use the buttons in the top-right
corner of the pane tab.
2
To arrange panes within a sheet, use the buttons in the top-right
corner of the sheet.
Basic operations
Basic operations such as moving and zooming in on images, and
defining a region of interest are carried out with the icons in the
toolbar.
Note: These operations will always be carried out concurrently on all
images from the same DIGE gel.
48
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
3
To move an image, select the Move tool, click on an image and
hold down the left mouse button while moving the cursor. The
image changes position. Release the button at the position you
want.
4
To rapidly move all gels in the current sheet to the same position
with the same zoom factor, double-click on one of the gels.
5
To view the complete gel image, click on the small gray rectangle
at the bottom-right of the image. The zoom factor will be
automatically adjusted so that the entire image becomes visible.
6
To zoom in, select the Zoom tool, left-click repeatedly in the area of
the gel where you want to zoom in. Right-click repeatedly on the
gel to zoom out.
7
You can also define a zoom area: with the Zoom tool selected,
place the cursor at the top left corner of the area, hold down the
left mouse button, and move to the bottom right position (a red box
is displayed). Release the mouse button at the end point.
8
To define a region of interest (for cropping, displaying the
corresponding region in 3D, and previewing contrast adjustment),
click the Region tool and place the cursor at the top left position of
the area you want to define. Hold down the left mouse button and
move the cursor to the bottom right position (a dashed box is
displayed). Release the mouse button at the end point.
Note: To simultaneously carry out the manipulations described above
on all gels in the current sheet, hold down the Shift key while moving or
zooming in on one gel, or defining a region.
2.4.3
Adjust the contrast
To improve the display of your images and identify any saturated
regions in your gels, you can adjust the contrast. Please note that
contrast adjustment is only a visual tool. It does not affect the
underlying raw data and will not influence the quantitation results.
9
Click Region in the toolbar.
10 Hold the Shift key and define a region in one of the images. A
region of identical size appears in the other images.
11 Click on the Image Pool sheet tab to select all images.
12 Click Adjust Contrast in the toolbar.
Melanie 7.0 Tutorial – Edition AB
49
2
Melanie DIGE Tutorial
2.4 Review your images
Adjust the horizontal scroll bar below the histogram and/or the
vertical bending parameter to modify the contrast and brightness
of the images and see the effect on the regions in the selected gels.
Note: You can redefine the regions of interest to look at other areas in
the images.
14 To view saturated and background regions in the images, change
the palette in the Colors drop-down list to Gray+Saturation.
15 To apply the contrast settings to all selected images, reset the Color
drop-down list to Gray and click Apply.
16 Close the Adjust Contrast window.
2.4.4
Image toolbar
The tools in the Image toolbar are convenient if gels need to be
rotated, flipped, cropped, or their gray levels need to be inverted.
These tools are only available as long as your images are in the Image
Pool. Once you add your images to a project, they can no longer be
altered.
50
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
Note: Any modifications made are only applied to copies of your
raw/source images. The original image files are never modified by
Melanie.
Note: The operations are simultaneously carried out on all images of
the same DIGE gel.
Note: The operations are only applied to selected gels. To select a DIGE
gel, click the pane tab (e.g. Gel 01). Click the sheet tab (e.g. Image
Pool) to select all gels. Use the Shift or Ctrl keys to select a subset of
gels. You can also select a single image by clicking on its name.
To consistently crop the same region on all images:
17 Click the Region tool and define a region around the area of the
gel you want to crop before further analysis. You can move the
crop area by clicking inside the box and dragging it, or change the
size of the area by dragging a corner or edge.
18 Identify a spot that can be recognized on all images in your
experiment, and hold the Alt key while clicking on it. A dark blue
circle will be centered on the spot. This so-called anchor may be
located inside or outside the crop area.
To change the position of the anchor, hold the Alt key and click
another spot. To remove the anchor, hold the Alt key and click on
the anchor.
19 Propagate the crop area to the other images in your sheet by
holding the Shift key while clicking in the crop area. Adjust the
Melanie 7.0 Tutorial – Edition AB
51
2
Melanie DIGE Tutorial
2.5 Create a project and match set
position of the crop area in each gel by moving it so that the
anchor is centered on the appropriate spot.
For this tutorial, no cropping is required. When cropping is necessary,
click the Crop icon in the Image toolbar. The software will ask you if you
want to create new images. Answer No to replace the existing images
(copies of your original files) with the cropped ones, or Yes to keep
both original-sized and cropped versions of the images.
20 Since the current images do not require cropping, double-click in a
gel while holding the Shift key to remove the regions from all gels.
Note: It is recommended to remove any gel borders and other artifacts
in the periphery in order to save disk space and memory. This will
improve processing speed and optimize performance, specifically
matching and normalization. You may want to retain molecular weight
(MW) ladders for pI/MW calibration.
2.5
Create a project and match set
With conventional single stain gel electrophoresis, all images in an
experiment are not equally easy to compare, even when the gels are
run in a highly controlled way. Typically, gels belonging to the same
treatment (biological condition) or analytical groups (e.g. technical
replicates) are easier to match than images from different groups.
Melanie supports hierarchical match set designs to exploit this
information and simplify and improve matching.
52
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
When running DIGE experiments with an Internal Standard on each gel,
generally hierarchical designs are not needed, as the Internal Standard
images of the different DIGE gels should enable easy gel-to-gel
matching.
Nevertheless, if you observe that not all gels – more precisely the
Internal Standard images – are equally easy to match due to different
running conditions, then you might want to try a hierarchical match
design. Please refer to the Non-DIGE Tutorial or the User Manual for
more information.
For this tutorial and for most DIGE experiments, the match structure
described below will work perfectly.
Note: If your experiment contains any bad gels that you do not want to
include in the analysis, you can remove them from the workspace by
right-clicking on them and choosing Remove, or simply not add them
to a project (see below).
2.5.1
Creating the project
To create a match set with all the DIGE gels:
1
Click on the Image Pool sheet tab to select all the DIGE gels.
2
Click the Add Files to Project button in the Image toolbar.
3
In the Add Files to Project window, select <New> in the Project drop
down. Enter the name DIGE Experiment as the new Project Name
and click OK.
4
Click <New> in the MatchSets field, enter the name All Gels as the
new MatchSet Name and click OK.
The project DIGE Experiment has now been created in the Workspace
and contains a match set All Gels. The DIGE gels Gel 01 and Gel 02
have been moved from the Image Pool to the Match folder in All Gels.
Each gel includes the corresponding Cy2, Cy3 and Cy5 images.
Melanie 7.0 Tutorial – Edition AB
53
2
Melanie DIGE Tutorial
2.5 Create a project and match set
Images or gels with a red marker are used as the reference in
matching. By default, the first gel (Gel 01 for this tutorial) is selected as
the reference gel and all other gels will be matched to it. This matching
will occur through matching of the corresponding reference images (in
principle, the Internal Standard images).
Note: At this point, the reference image of each gel has not yet been
set. This is done when the gel is displayed for the first time (see below).
The reference gel should be a representative gel with a nicely
separated spot pattern and the fewest possible artifacts. For DIGE
experiments with good reproducibility and including an Internal
Standard on each gel, the choice of the reference gel should not be
critical for the analysis. However, it is good practice to review the
Internal Standard images after spot detection to decide which gel to
use as the reference, before matching is carried out (see below).
5
To change the reference, drag the desired gel onto the Match
folder so that it moves into the first position.
Note: Changing the reference of a match set is only possible while the
match set is not displayed in a sheet and as long as matching has not
been carried out. Once the images have been matched, it is not
possible to change the reference without losing the matches.
2.5.2
54
Displaying images in a match set sheet
6
To view the gels and images in a match set, right-click on the match
set name (All Gels) and select Display.
7
For each gel, check that the correct reference image is selected
and click OK. The Cy2 image is always proposed by default. For the
tutorial, confirm the default Cy2 Standard images.
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
Images are grouped in panes labeled with the gel name (Gel 01, Gel
02). The gels are placed in a sheet labeled with the match set name
(All Gels).
8
Use the buttons in the top-right corners of the pane tabs and the
sheet to change the layout of the interface as shown below (see
Section 2.4.1).
2.6
Detect spots
2.6.1
Detecting spots
For detection of DIGE gels, the DeCyderTM 2D co-detection algorithm is
applied.
1
Select all gels by clicking on the match set (All Gels) sheet tab.
2
Choose Edit > Spots > Detect or click Detect in the toolbar.
3
In the DIGE Spot Detection window, enter an estimation of the
Number of Spots present in the images. It is recommended that this
value be overestimated to compensate for the detection of nonproteinaceous spots on the image (e.g. dust particles). Such spots
Melanie 7.0 Tutorial – Edition AB
55
2
Melanie DIGE Tutorial
2.6 Detect spots
can subsequently be excluded from the analysis using spot filtering.
Enter 10,000 as the estimated Number of spots for the tutorial
images.
4
Tick Apply to all and click OK.
Spot detection can take a few minutes to complete. When it is finished,
the spot outlines will be displayed on the images.
56
5
Use the Zoom tool to zoom in on a gel and note that the spot
shapes are identical for the three images of the gel.
6
Choose Selection in the toolbar and click on a spot. The
corresponding spots in the other images of the same gel are
automatically selected.
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
Clearly, too many spots were detected. To exclude the nonproteinaceous spots on the images, it is recommended that the spots
be filtered based on the volume. More precisely, spots that have a
maximum volume in the three images that is lower than a given
threshold can be deleted.
To exclude DIGE spots based on maximum volume:
7
Choose Tools > Options from the menu, go to the Quantification tab
and make sure the box Compute area and volume in mm2 is
ticked. Note that spot filtering will work equally well with this option
deselected (area and volume computed in pixels), but the volume
cutoff used below will be expressed in different units and this could
lead to confusion. Click OK.
8
Choose Reports > Spot Table to display a table with information
about each spot.
9
Click Select By Value in the toolbar of the table.
10 In the Select By Value window, select Vol in the displayed list. Make
sure the >= box is checked and enter a value to be used as the
cutoff for the volume. A value of 300 generally works well. Deselect
the <= box and click OK.
All spots with a volume higher than the given threshold are selected,
together with their matched spots (which may have volumes that are
smaller than the threshold). These are the spots that will be kept.
Zoom in on the images to verify that the deselected, red spots are not
real protein spots. If some of them are, filter again with a lower cutoff.
Melanie 7.0 Tutorial – Edition AB
57
2
Melanie DIGE Tutorial
2.6 Detect spots
11 Choose Select > Spots > Inverse Selection. The new selection
includes all spots for which the maximum volume in any of the three
DIGE images is lower than the given threshold.
12 Choose Edit > Spots > Delete or click Delete in the toolbar to
permanently delete the selected spots from your DIGE gels. Click
Yes when asked to confirm the deletion.
13 Close the Spot Table.
14 To view the entire images, hold Shift and click on the small gray
rectangle at the bottom right of one of the images.
58
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
Note: Except for deleting selected spots as described above, no spot
editing is allowed on DIGE images.
You may want to delete spots on the gel borders or on gel artifacts
(e.g. broken gel). To do so, you must select the spots first:
15 Click Select in the toolbar and click on a spot. Once selected, the
spot is highlighted in green.
16 To select all spots in an area, place the cursor at the top left position
of the desired area, hold down the left mouse button, and then
drag the cursor to the bottom right position. All spots in the
designated area are selected.
17 To select more than one spot, select the first one and then hold
down the Shift or Ctrl key while clicking on additional spots.
18 To select all spots in all images, make sure all gels are selected by
clicking on the sheet tab, and then choose Select > Spots > All or
use the Shift+A keyboard shortcut.
19 To deselect a spot, hold down the Shift or Ctrl key while clicking on
it.
20 To deselect all spots, click anywhere in the image (not on a spot).
Melanie 7.0 Tutorial – Edition AB
59
2
Melanie DIGE Tutorial
2.6 Detect spots
2.6.2
Reference confirmation
Before continuing with the matching process, it is a good idea to
carefully review your gels to confirm the matching reference.
Reference gels for matching should have nicely separated spots, no
gel distortions, a minimum number of streaks, and – all other things
being equal – the highest number of detected spots (real spots, not
artifacts).
21 To quickly see the number of spots detected on each gel, hover
over the Spots item in the Status bar at the bottom-left of the
program window. For each image, the number of currently selected
spots and the total number of spots is shown.
The tutorial gels have similar separation quality. However, Gel 01 has
more spots and can therefore be kept as the reference.
At this point, you can still change the reference gel in the Workspace,
based on the spot detection results. To be able to do so, you must
close the sheet first. Now drag the chosen gel onto the Match folder so
that it is placed in the first position. It will have a red marker. Display the
match set again to continue working, by right-clicking on the match
set name and selecting Display.
22 To maximize the available space for viewing gels, click Auto Hide at
the top right of the Workspace window to minimize the Workspace.
60
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
2.7
Add landmarks
2.7.1
Changing layout
The images of the same DIGE gel are automatically matched.
Therefore, it is only necessary to match the Internal Standard images of
the different gels to find the correspondences, i.e. matches, between
all images. Change the layout to focus on the Cy2 Standard images:
1
Set the layout of the pane tabs to Stacked.
2
Set the layout of the sheet to Tiled.
By default, the Cy2 Standard image appears on top of the stack in
each gel pane.
3
To switch between images in a gel stack, click repeatedly on the
right-most image tab at the bottom of the gel pane. The name of
the visible image always appears on top of the pane. Continue
clicking until the Cy2 Standard image is again on top (visible).
Melanie 7.0 Tutorial – Edition AB
61
2
Melanie DIGE Tutorial
2.7 Add landmarks
2.7.2
Defining landmarks
When gels are distorted or relatively different, you may need to help
the matching process by specifying a few landmarks. Landmarks are
points that relate corresponding spots in each of the gels to be
matched.
Try to match your gels with a single landmark or, if possible, none at all.
If the matching results are not satisfactory, you can repeat the
automatic matching procedure using additional landmarks.
The following rules should be considered when defining landmarks:

Keep the number of landmarks to a minimum.

Only define landmarks on clearly corresponding spots. Protein
variants should definitely not be used as landmarks.

Landmarks should be placed on small, sharp spots rather than on
large, diffuse ones (to reduce the error in the position).

Landmarks essentially correct global deformations of gels.
Therefore, it is recommended not to put landmarks on spots in
locally distorted regions. Rather place landmarks around such
regions.
4
On the reference gel, zoom in on a region with a clearly
recognizable spot pattern and move the other gels to show the
same area.
5
Click Landmark in the toolbar.
6
Position the cursor over a known, well-defined spot in the reference
gel (Gel 01 Cy2 Standard) and click. A “Validated” landmark
symbol (bold orange circle) appears on the spot.
In the next image (Gel 02 Cy2 Standard), drag the “Non-validated”
landmark symbol (green circle with orange plus sign) onto the
corresponding spot. Once the mouse button is released, the
landmark is validated and identified with a number.
If you put the landmark on the wrong spot, just drag it to the right
spot.
62
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
For the tutorial gels, only one landmark needs to be defined, and only
one gel needs to be matched. On your own experiments, repeat this
process for all gels and possibly for additional landmarks.
2.8
Match gels
2.8.1
Matching gels
1
Select all gels by clicking on the sheet tab.
2
Choose Edit > Matches > Match Gels or click Match Gels in the
toolbar.
3
When the process is completed, the number of matches created
appears. Click OK.
The match vectors are displayed in blue. Vectors link the spot in a gel
with the corresponding spot in the Sheet Display Reference image
(imagine that the reference lies below). This reference image should
Melanie 7.0 Tutorial – Edition AB
63
2
Melanie DIGE Tutorial
2.8 Match gels
not be mistaken for the match reference and can be changed with
View > Sheet > Set Reference. In general, it is most intuitive to keep the
default global match reference as the Sheet Display Reference.
If the matching performed well, the match vectors will point in the
same direction and have the same magnitude. If there is a mismatch,
the vector has a different length and/or orientation.
When a gel is moved, the vectors become longer. Select Move in the
toolbar and double-click in the gel to recenter all the images, including
the reference, to the same position and therefore minimize the match
vectors.
A spot with a blue triangle means that the corresponding position in the
Sheet Display Reference lies outside the visible area.
2.8.2
Edit matches
To review matching:
64
4
Use the Select tool to click on a spot. The spot and any matched
spots are highlighted in green.
5
Choose Select > Matches > All to highlight all matched spots. The
matching of any red spots should be scrutinized.
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
Match editing can be done at any time during data analysis. Even if it
is good practice to quickly review the match results at this point in
order to rematch with additional landmarks if necessary, it is more
efficient and convenient to edit matches during the results review
process.
To edit matches:
6
To easily locate the examples in the tutorial images, select View >
Global > Show Overview from the menu. In the small view of the
entire gel at the bottom right of each image, you will see a green
square that localizes the visible area of the gel.
In the example above, the spot in Gel 02 has been split. Due to the
resulting ambiguity, none of the two spots was matched with the single
spot in Gel 01. You can manually add a single or a multiple match to
allow spot comparison.
To add a single match:
7
Select the spot in the reference gel.
8
Hold the Shift or Ctrl key and select one of the two spots (resulting
from the spot splitting) in the second gel. If you have more gels,
Melanie 7.0 Tutorial – Edition AB
65
2
Melanie DIGE Tutorial
2.8 Match gels
continue holding the Shift or Ctrl key while selecting corresponding
spots in the other gels.
Choose Edit > Matches > Add Match or click Add Match in the
toolbar. All of the selected spots are now matched.
Note: It is important to understand that for DIGE experiments using an
Internal Standard and calculating the Volume Ratio as quantification
value (volume of current image spot/volume of DIGE reference image
spot), it does not really matter which of the two spots in Gel 02 is
selected for comparison with the spot in Gel 01. The Volume Ratios of
the two spots resulting from the spot splitting will generally be very
similar and can be directly compared with the Volume Ratio of the
single spot in Gel 01.
Alternatively, you can create a multiple match:
10 Select the spot in the reference gel.
11 Hold the Shift or Ctrl key and select the two corresponding spots in
the second gel. If you have more gels, continue holding the Shift or
Ctrl key while selecting all corresponding spots in the other gels.
Choose Edit > Matches > Add Match or click Add Match in the
toolbar. All of the selected spots are now matched.
66
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
In the analysis, the quantitation value of the single spot in Gel 01 (e.g.
on Gel 01 Cy3 Control) will be compared with the summed
quantitation values of the two spots in Gel 02 (e.g. on Gel 02 Cy3
Treated).
13 To delete matches, select matched spots and choose Edit >
Matches > Delete Match or click Delete Match in the toolbar.
2.9
Create and open classes
To analyze protein expression variations between different conditions
(e.g. treatment groups), it is necessary to define classes. A class is a set
of gels that includes all samples from a given condition (e.g. control
group or treatment group).
1
Open the Workspace window by clicking on its tab at the left side
of the program window and click the Auto Hide icon to pin it so that
it does not close automatically.
Melanie 7.0 Tutorial – Edition AB
67
2
Melanie DIGE Tutorial
2.9 Create and open classes
2
Hold the Ctrl key while selecting the images Gel 01 Cy3 Control and
Gel 02 Cy5 Control in the Match folder.
3
Right-click on the selection and choose Add in Class.
4
In the Add Gels in Class window, enter Control as the name for a
new class and click OK.
You can use an alternative approach to create the Treated class:
68
5
Hold the Ctrl key while selecting the images Gel 01 Cy5 Treated and
Gel 02 Cy3 Treated in the Match folder.
6
Drag the selection onto the Classes folder.
7
In the Create Class window, enter Treated as the Name and click
OK.
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
Repeat these steps until all classes are created. You can create as
many classes as required. Imagine that you have both Male and
Female subjects in the Treated and Control groups. You could create
the classes Control_Male, Control_Female, Treated_Male and
Treated_Female to compare the four conditions. You could also create
and compare classes Control and Treated to study the effect of the
treatment, or classes Male and Female to investigate the effect of the
gender.
8
Hold the Ctrl key to select the classes to be compared (Control and
Treated).
9
To open the images in a class sheet, right-click and select Display.
Melanie 7.0 Tutorial – Edition AB
69
2
Melanie DIGE Tutorial
2.10 Data analysis
A new sheet with the name Control - Treated opens in the display area.
You must be in such a Class sheet (indicated by the icon and the
tooltip when hovering over the sheet tab) to access the reports that
compare different conditions (Class Analysis Tables and Histograms).
10 Hide the Workspace by clicking on Auto Hide at the top right of the
window.
11 Choose View > Global > Show Overview to hide the small image
views.
12 Rearrange the Pane layouts so that the images are displayed in
One Column.
2.10 Data analysis
By default, Melanie uses the Volume Ratio for DIGE spot quantification.
This can be changed by choosing Tools > Options and going to the
Quantification tab. Please refer to the User Manual for further details.
The default Volume Ratio is highly recommended for this tutorial
experiment and for most DIGE data sets.
70
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
2.10.1 Class Analysis Table
Differential analysis between populations of gels, i.e. classes, is
essentially based on the values found in the Class Analysis Table.
1
Choose Reports > Analyse Classes > Table.
The title of the table indicates that the Central tendency and
Dispersion values calculated for each class correspond to the Mean
and M.S.D. (Mean Squared Deviation), respectively. Choose Center in
the Class Analysis Table drop down list to display the Central tendency
for each class (columns Control and Treated). When choosing
Dispersion in the list, the columns Control and Treated show the
Dispersion for the corresponding class.
2
Click Statistics in the Class Analysis Table toolbar to change the
statistical values displayed.
Note: The sliders in the Classes Statistics window allow you to remove a
percentage of outliers for the calculation of the Central tendency and
the Dispersion. As explained in the User Manual, this can be used in
combination with the other options to compute statistics that are less
sensitive to extreme values (outliers). Keep in mind that this is only useful
for experiments with sufficiently large sample sizes. By default, no
outliers are excluded, and the Mean and Mean squared deviation are
calculated.
Note: Only two classes can be compared when using the MannWhitney and Kolmogorov-Smirnov tests (indicated for data with nonnormal distributions). If you have more than two classes in a Class sheet,
Melanie 7.0 Tutorial – Edition AB
71
2
Melanie DIGE Tutorial
2.10 Data analysis
you can select the two classes to be used for the calculation of the
Mann-Whitney and Kolmogorov-Smirnov statistics in the section Classes
for Statistical Tests. This choice is not taken into account for the ANOVA
test, which allows the comparison of more than two classes.
3
Keep the default statistics (Mean, Mean squared deviation, both
sliders set at 100%) and click OK.
By default, columns Control and Treated in the Class Analysis Table
display the Center, i.e. mean value (including 100% of spots) for the
corresponding class. The Max column lists the highest of these values,
whereas the Fold column shows the fold-change between the classes.
Please note that when you compare three or more classes, the Fold
column displays the fold-change between the class with the lowest
mean value and the class with the highest mean value.
2.10.2 Class Analysis Histograms
4
For a visual representation of these values, choose Reports >
Analyse Classes > Histograms.
Each histogram displays, for a given spot, the quantification values in
the different gels as orange bars. To see which gel corresponds to
which letter, click the Settings button in the Class Analysis Histograms
toolbar and select Show Labels. Alternatively, move your cursor over a
72
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
letter to view the gel name. The quantification values for different
classes are separated by gray vertical lines.
The blue horizontal lines in the histograms represent the mean values for
each class. The red lines delimit the dispersion intervals defined by
[Mean value - M.S.D, Mean value + M.S.D].
2.10.3 Identifying protein expression changes
Generally, you will only want to review the most interesting protein
spots. You can do this for instance by limiting the analysis to spots that:


show statistically significant expression variations between groups
(e.g. ANOVA probabilities < 0.01)
show differences of a certain magnitude (e.g. Fold changes > 2)
To select all spots that satisfy such criteria:
5
Click Settings in the toolbar of the Class Analysis table.
6
Tick the Anova box and click OK to display a column with the
probabilities for the ANOVA test in the Class Analysis Table.
7
Click Select By Value in the toolbar of the Class Analysis Table.
8
In the Select By Value window, select Anova in the displayed list.
Make sure the <= box is checked and enter a value of 0.01 as the
cutoff. Deselect the >= box and click OK. All spots that show
statistically significant expression variation between Control and
Treated, based on the selected criterion, are now selected.
9
Click Create Spot Set in the Class Analysis Table toolbar.
10 In the Create Spot Set window, enter Anova < 0.01 as the name of
the new spot set and click OK.
11 Again click Select By Value in the toolbar of the Class Analysis Table.
Melanie 7.0 Tutorial – Edition AB
73
2
Melanie DIGE Tutorial
2.10 Data analysis
12 In the Select By Value window, select Fold in the displayed list.
Check the >= box and enter a value of 2. Deselect the <= box and
click OK. All spots that show a fold change larger than or equal to a
factor of 2 between the Control and Treated groups are now
selected.
13 Click Create Spot Set in the Class Analysis Table toolbar.
14 In the Create Spot Set window, enter Fold > 2 as the name of the
new spot set and click OK.
You have created two new columns in the Class Analysis Table.
Double-click on the right border of their headers to resize the columns
so that their name becomes visible. Spots that belong to a spot set
have the box in the corresponding column checked.
You can combine spot sets to select spots that satisfy both criteria:
15 Select Edit > Spot Sets > Combine in the menu.
16 In the Inputs lists, select the spot sets Anova < 0.01 and Fold > 2,
make sure And is selected as the Operator, and enter the name
Verify in the Output field in order to create a spot set with that
name. Click OK. A new spot set Verify is created.
74
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
17 Click twice on the header of the Verify column in the Class Analysis
Table to put all spots belonging to this spot set at the top of the
table.
18 Scroll to the top of the table and select the first spot in the list.
Matched spots will be automatically selected in all images.
2.10.4 3D view
To review the spots that you have just selected, it is convenient to have
the 3D View displayed in addition to the Class Analysis Table and
Histograms.
19 Choose Reports > 3D View in the menu to visualize the threedimensional views for the selected spot in all the images.
20 To rotate the images in the 3D View, left-click and move your
mouse.
21 Use the scroll wheel of your mouse to zoom in or out.
Note: You can explore the 3D views in more detail with the other
options in the 3D View toolbar.
The 3D View is displayed in the same window as the Class Analysis
Histograms.
22 To move the 3D View to a separate window, click on the 3D View
tab at the bottom of the window and drag towards the center of
the gel display area. Blue arrows will appear. By moving the cursor
over the arrows, a shaded blue box will show where the window will
appear once the left mouse button is released. Release the mouse
button over the arrow pointing to the right. The 3D View window will
be placed to the right of the gel display area.
Melanie 7.0 Tutorial – Edition AB
75
2
Melanie DIGE Tutorial
2.10 Data analysis
23 Similarly, click the Class Analysis Histograms title and drag the
histograms to the right of the Class Analysis Table.
24 Resize the windows to obtain the layout below.
76
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
2.10.5 Reviewing spots
You can now decide, for each spot marked Verify whether you want to
include or exclude it for further analysis (e.g. by mass spectroscopy).
25 As shown in the image above, the first spot in the Class Analysis
Table is clearly up-regulated in the Treated group compared to the
Control group.
26 Click Create Spot Set in the Class Analysis Table toolbar.
27 In the Create Spot Set window, enter Include as the name of the
new spot set and click OK.
28 Again click Create Spot Set in the Class Analysis Table toolbar.
29 In the Create Spot Set window, enter Exclude as the name of the
new spot set and click OK.
You have created two new columns in the Class Analysis Table.
Double-click on the right border of their headers to resize the columns.
You can now use these spot sets to include or exclude spots from the
analysis.
Melanie 7.0 Tutorial – Edition AB
77
2
Melanie DIGE Tutorial
2.11 Pick list
30 Deselect the Exclude box for the first spot (this spot automatically
became part of the Exclude spot set because it was selected when
the spot set was created).
31 Use the down arrow key to move to the next spot in the table.
Note: Using the up or down arrow keys to move from one spot to
another in a table will only work if the table is active (has a darker title
bar). To activate a table, just click on its title.
32 Use the information in the 2D and 3D views, as well as the Class
Analysis Table and Histograms, to decide if a spot should be
included or excluded in the analysis. Tick the corresponding box
(Include or Exclude) while working down the list. You can stop
reviewing when spots no longer satisfy the fixed criteria (i.e. belong
to spot set Verify).
Note: While reviewing your spots in this way, you can edit matches if
necessary. The quantification values are automatically recalculated.
When spots are sorted based on a numerical value (e.g. Anova, Fold)
rather than a spot set, this means that spots can move up or down in
the list. When this happens, just scroll back to the first non-reviewed spot
after ticking Include or Exclude.
Note: Do not spend time editing ambiguous or uninteresting spots (e.g.
saturated spots, spots in streaks, background artifacts). Just click to
Exclude them.
33 Close the Control - Treated sheet when you have finished reviewing
spots.
2.11 Pick list
In the current DIGE experiment, a preparative gel was run on the
pooled sample and post-stained with a Fluor total stain to allow spot
picking with the GE Healthcare Ettan spot picker and subsequent
protein identification by mass spectrometry (MS).
To create a pick list for this particular gel, spots must first be detected,
the reference markers annotated, the pick gel matched to the
analyzed DIGE images, and finally, the spots of interest must be
selected.
2.11.1 Adding the pick gel to the project
1
78
Click the Workspace tab and pin the Workspace window by
clicking on the Auto Hide icon in the top-right corner.
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
2
Select File > Open in the menu. In the Open Files window, locate the
Tutorials\Images folder in the Melanie installation folder (by default,
C:\Program Files\GeneBio\Melanie 7\Tutorials\Images) and select
the file Pick.gel. Click Open.
3
In the Gel Properties window, select Cy2, Cy3 or Cy5 if you want the
pick image to be detected with the DeCyder 2D co-detection
algorithm. If you used a fluorescent stain, this option will generally
give you a spot pattern and spot shapes that are very similar to
those on the analytical DIGE gels and this will facilitate matching.
Enter any other stain if you prefer to detect the pick image with the
default Melanie algorithm. For this tutorial, select Cy2 from the list
and click OK.
4
In the Create DIGE Gel window, click on Add.
5
Enter PickGel as the DIGE Name and click OK.
6
Adjust the contrast of the image as described in Section 2.4.3. When
finished, close the Adjust Contrast window.
Note: You will see two big black dots on the Pick image. These are the
two reference markers that will be used by the GE Healthcare Ettan
spot picker for the calibration of the coordinates between the
analyzed gel image and the actual gel located on the spot picker.
7
Select PickGel in the Image Pool folder in the Workspace and drag
it onto the match set All Gels. PickGel is added as the third DIGE gel
in the All Gels match set.
8
Select All Gels in the Workspace, right-click and choose Display to
show the match set in a sheet.
9
When asked to choose the Reference for match set PickGel, click
OK to accept the unique image in the match set, i.e. Pick.
Melanie 7.0 Tutorial – Edition AB
79
2
Melanie DIGE Tutorial
2.11 Pick list
10 Hide the Workspace by clicking on Auto Hide at the top right of the
window.
11 Select the panes Gel 01 and Gel 02 and change their layout to
Stacked. Change the layout of the sheet All Gels to One Row.
12 To view the entire images, hold Shift and click on the small gray
rectangle at the bottom right of one of the images.
Gel 01, Gel 02 and PickGel are displayed next to each other, with the
Internal Standard images of the DIGE gels on top (visible).
80
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
2.11.2 Detecting spots on the pick gel
13 Select PickGel only, by clicking on the pane header.
14 Choose Edit > Spots > Detect or click Detect in the toolbar.
15 Enter 10,000 as the estimated Number of spots and click OK.
Once detection is finished, you must exclude the non-proteinaceous
spots based on maximum volume:
16 Choose Reports > Spot Table to display the Spot Table.
17 Click Select By Value in the toolbar of the table.
18 In the Select By Value window, select Vol in the displayed list. Make
sure the >= box is checked and enter a value to be used as the
cutoff for the volume. A value of 300 works well for this pick gel.
Deselect the <= box and click OK.
All spots with a volume higher than the given threshold are selected.
Zoom in on the images to verify that the deselected, red spots are not
real protein spots. If some of them were, you could filter again with a
lower cutoff.
Melanie 7.0 Tutorial – Edition AB
81
2
Melanie DIGE Tutorial
2.11 Pick list
19 Choose Select > Spots > Inverse Selection. Make sure that only nonproteinaceous spots on the image Pick are selected (and no spots
on Gel 01 or Gel 02).
20 Choose Edit > Spots > Delete or click Delete in the toolbar to
permanently delete the selected spots from PickGel. Click Yes when
asked to confirm the deletion.
21 Close the Spot Table.
2.11.3 Annotating the reference markers
You will notice that many small spots were detected on the two
reference markers. It is recommended to delete these spots so that
they do not interfere with the annotation of the markers.
22 Zoom in on the image to better see the left reference marker.
23 Click Selection in the toolbar and select the spots on the markers, as
described in section 2.6.1. Delete the spots by clicking Delete in the
toolbar.
24 While still having the Selection tool activated, double-click on the
center of the left marker spot.
82
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
25 In the Create Annotation by Click window, choose the Comment
category and click OK.
26 Enter IR1 as the label text and click OK.
An annotation of category Comment and with label text IR1 is created.
If it is not in the center of the reference marker, you can move it to the
appropriate position. Do this by clicking on its basis (cross) and holding
down the left mouse button while dragging the annotation to its new
position. You can zoom in on the marker while doing this, to improve
the precision on the location.
27 Repeat the steps 22 to 26 for the reference marker on the right,
entering the label text IR2 this time.
Melanie 7.0 Tutorial – Edition AB
83
2
Melanie DIGE Tutorial
2.11 Pick list
2.11.4 Matching the pick gel
Zoom in on an area with a clearly corresponding spot pattern in all
three gels in order to define a landmark that will facilitate matching
between PickGel and Gel 01(the reference of the match set All Gels).
In this tutorial, we will use the same landmark as the one selected
previously to match Gel 02 with Gel 01. But any other small,
recognizable spot can be chosen as a landmark.
28 Click Landmark in the toolbar. Orange circles will appear on the
spots that were previously used as landmarks.
29 Click on the landmark labeled 1. A “Non-validated” landmark
symbol appears on the image Pick. Drag this symbol onto the
correct spot to validate the landmark (see Section 2.7.2). It may be
necessary to move the Pick image a little to see the destination
spot. When releasing the mouse button, the validated landmark is
identified with a number (1).
84
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
30 Select Gel 01 and PickGel by clicking on their pane headers while
holding the Ctrl key.
31 Click Match Gels in the toolbar.
32 When the process is completed, the number of matches created
appears. Click OK.
Review the match results as indicated in Section 2.8.2. From the small
vectors and correct spot correspondences in the upper part of your
image, you can conclude that the matching worked quite well in a
large part of the images. Nevertheless, there are many missing
matches and some doubtful matches in the lower molecular weight
region (bottom third of the image). This can partly be explained by dye
shifts that cause some low molecular weight proteins to appear with
multiple peaks in the DIGE images. If you want to pick spots in this
region, you must define additional landmarks in this area and rematch
Gels 01 and PickGel.
Melanie 7.0 Tutorial – Edition AB
85
2
Melanie DIGE Tutorial
2.11 Pick list
2.11.5 Generate a pick list
In principle, you will want to pick all the spots of interest, i.e. those that
you previously added to the spot set Include. When the images are
properly matched, selecting the spot set Include will automatically
select all corresponding spots on the Pick image. Nevertheless, it is
recommended to review the Include selection to make sure that you
will pick the right spots.
33 Choose Reports > Analyse Gels > Table.
In addition to the quantification value of each spot (row) for each
image (columns with the image names), the Gel Analysis Table also
shows the spot sets.
34 Click twice on the header of the Include column in the table to put
all spots belonging to this spot set at the top of the table.
35 Scroll to the top of the table and select the first spot in the list.
Matched spots will be automatically selected in all images.
36 Verify that the selected spot in the Pick image effectively
corresponds to the spot to be picked. If no spot is selected in the
Pick image, or if the wrong spot is matched, you can still edit the
matches at this point.
86
Melanie 7.0 Tutorial – Edition AB
Melanie DIGE Tutorial 2
Note: If no spot was detected in the corresponding position on the Pick
image, you will not be able to pick the spot. This is because it is not
allowed to add spots on a gel detected with the DeCyder 2D codetection algorithm, though a spot is needed for picking. If this
happens for too many spots, you can try to detect the pick gel as a
single-stain image (select any stain other than Cy2, Cy3 or Cy5). For
such images, it is allowed to manually add spots that you can then
match with the spots in the analytical gels.
Once all spots belonging to spot set Include have been reviewed, you
can generate a pick list for the GE Healthcare Ettan spot picker:
37 Choose Select > Spot Sets.
38 Select Include in the Select Spot Set window and click OK. All spots
belonging to the set Include are selected.
39 Select the image Pick by clicking on its name.
40 Choose File > Export > Spots to Picker > GE Healthcare Ettan.
41 Browse to select a location, enter a File name and click Save.
Note: Procedures for other spot excision robots vary. Consult the User
Manual for more details about the different spot picker formats.
Melanie 7.0 Tutorial – Edition AB
87
2
Melanie DIGE Tutorial
2.12 Export tables
Note: If your spot picker is not in the list of available spot excision robots,
try exporting a Spot Table by choosing Report > Spot Table, and edit
the generated file as necessary.
2.12 Export tables
88
1
To export the data in a table (e.g. Class Analysis Table, Gel Analysis
Table, Spot Table) in text, Excel or XML formats for use in other
software, click Save in the table toolbar.
2
In the Save Table window, indicate whether you want to export all
rows or only the selected ones.
3
Browse to select a location and enter a File Name. Select the type
of file from the Save as type drop-down list and click Save.
Melanie 7.0 Tutorial – Edition AB
This version of Melanie has been developed by the Swiss Institute of
Bioinformatics in collaboration with Geneva Bioinformatics (GeneBio) SA
and GE Healthcare. Melanie is powering the ImageMaster 2D Platinum
gel analysis software sold by GE Healthcare.
All intellectual property rights on this Tutorial, as well as on Melanie,
belong to the Swiss Institute of Bioinformatics. GeneBio owns the
worldwide exclusive distribution rights on this intellectual property. No
part of this Tutorial may be reproduced or transmitted in any form or by
any means, electronic or mechanical, including photocopy, recording
or any information storage or retrieval system, without permission in
writing from the Swiss Institute of Bioinformatics or GeneBio.
© 2014 Swiss Institute of Bioinformatics - All rights reserved.
First published March 2012
Swiss Institute of Bioinformatics
CMU, 1 Rue Michel-Servet, CH-1211 Geneva, Switzerland
Melanie provides access to several databases on the Internet. It is the
responsibility of the user to acquire the database licenses, if needed. In
particular, the PROSITE and SWISS-2DPAGE databases are copyright and
all commercial users of these databases are required to purchase a
database license from GeneBio. Please contact GeneBio at
[email protected] for more information.
Geneva Bioinformatics (GeneBio) SA
c/o Swiss Institute of Bioinformatics, CMU - 1 rue Michel Servet, 1211
Geneva, Switzerland
Melanie uses the DeCyder co-detection algorithm.
© 2008 General Electric Company - All rights reserved.
Melanie uses the TIFF library.
© 1988–1999 Sam Leffler and 1991–1999 Silicon Graphics, Inc – All rights
reserved.
Melanie uses software developed by the Apache Software Foundation
(http://www.apache.org).
© 1999–2007 The Apache Software Foundation – All rights reserved.
www.genebio.com
Cy, CyDye, DeCyder, Ettan, ImageMaster, Immobiline and
ImageScanner are trademarks of GE Healthcare companies. GE is a
trademark of General Electric Company.
Geneva Bioinformatics (GeneBio) SA
All third party trademarks are the property of their respective owners.
c/o Swiss Institute of Bioinformatics
CMU - 1, rue Michel Servet
1211 Geneva
Switzerland
All goods and services are sold subject to the terms and conditions of the
license agreement communicated to you by GeneBio. GeneBio reserves
the right, subject to any regulatory and contractual approval, if required,
to make changes in specifications and features shown herein, or
discontinue the product described at any time without notice or
obligation. Contact GeneBio at [email protected] for the most
current information.
Melanie 7.0 Tutorial – Edition AB
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement