Document Manager 6.0.70725

Document Manager 6.0 Users Manual
by Scanlon Associates
Version 6.0.70725
I
Document Manager 6.0.70725
Table of Contents
Part I Getting Started
2
1 Steps to a Successful
...................................................................................................................................
Implementation
2
2 Edit Document
...................................................................................................................................
Types
2
3 Edit File Types
................................................................................................................................... 3
4 Edit Key Types
................................................................................................................................... 4
Part II Using Document Manager
7
1 Scanning Documents
................................................................................................................................... 7
2 Acquiring Documents
................................................................................................................................... 7
3 Viewing Documents
................................................................................................................................... 8
4 Searching for ...................................................................................................................................
Documents
8
5 Annotation of
...................................................................................................................................
Documents
10
Part III Menus
12
1 File Menu
................................................................................................................................... 12
2 Preferences ................................................................................................................................... 12
3 Tools Menu ................................................................................................................................... 13
4 Help Menu ................................................................................................................................... 13
Part
I
2
Document Manager 6.0.70725
1
Getting Started
1.1
Steps to a Successful Implementation
Steps to a Successful Implementation
The purpose of this section is to provide a brief outline of the basic steps necessary to
quickly and successfully operate this software. Specific information on each item is detailed
throughout this reference manual.
1. Add document type codes.
2. Add key types, and enter any desired linking behavior.
3. Add required fields (if any) to the documents types.
4. If necessary, add additional file types.
Once the first four steps have been completed, the system is ready for data entry.
5. Scan and/or acquire documents.
6. Enter required fields (if any) to the documents.
Once a document has been linked to a DrugPak record (by entering the required field data),
you can see that document through DrugPak by pressing the camera button on the DrugPak
tool bar while viewing the linked record.
1.2
Edit Document Types
Edit Document Types
This window allows you to specify what sort of document you're adding to the database (via
scanning or acquiring). One example of a document type would be a chain of custody form.
To add a new document type, use the plus button on the navigation bar. Once the system is
in edit mode (signified by the large check mark and an X), give your document type a name
and press the check mark.
Document Type ID
This is an ID number automatically assigned by the system to each Document Type. It cannot be
changed by the user.
Document type name
Enter the name of the Document Type.
Key Type
This column displays the Key Types (if any) associated with this Document Type.
Required
For each Key Type, this column displays whether or not this Key Type is required for this document
type.
Add
Use this button to Add a Key Type to this Document Type. Pressing the Add button will open the Find
Key Type window, which will allow you to choose from the available Key Types. The Key Types are
Getting Started
3
can be added, edited, and removed via the Edit Key Types item under the File Menu.
Remove
To remove a Key Type, select the desired Key Type from the list, and press the Remove button. The
Key Types are can be added, edited, and removed via the Edit Key Types item under the File Menu.
Toggle Required
This function allows you to switch a Key Type from being required (Yes) to not being required (No),
and vice-versa. To switch the "required" status of a key type, select the desired key type, and press
the Toggle Required button. Pressing it again will revert it to the opposite value.
1.3
Edit File Types
Edit File Types
This window allows the user to specify what file types will be imported, and how to open
them.
File Type
This is usually the three or four digit Windows file extension. When adding a new file type, you must
add the correct extension (such as DOC for MS Word, or BMP for Bitmap). If you use an extension
that Windows does not recognize, Document Manager will not be able to open the correct document
type (unless you set a Specific Application). You may import a file whose type is not defined, but it will
not be viewable in the Document Viewer window.
Viewer
This option determines where and how the current file type is opened. There are four options:
· Image Viewer - Use this option to display image files using the built-in image viewer to view image
files. This option also allows annotation of documents.
· Internal Browser - Use this option to display documents using the built-in MS Internet Explorer. Only
file types that have the required MS Internet Explorer plug-in will open. This option does NOT allow
annotation of documents.
· Windows Default Handler - This option will use the default application for this file format. The default
application is the application that Windows uses to open files of this type.
· Specific Application- This option will allows the user to set a specific application to use to open files
of this type. Use this option if you want to use an application other than the default application.
Open Document Automatically
Check this box to have documents of this type open automatically when browsing in the Document
Viewer. Uncheck this box to have the Document Viewer not open the file of the above type
automatically. If the box is unchecked, the user will have to double-click the file icon to open the
document.
Application
When using a specific application (option above), press the browse button to navigate to the desired
application.
Quoted Parameters
Leave this box unchecked, unless otherwise directed by Scanlon Associates' support staff.
4
1.4
Document Manager 6.0.70725
Edit Key Types
Edit Key Types
The Document Manager allows you to "key" information for each document you scan. This
key information makes it easy to find documents once they've been entered into the system.
One example of a key category would be the Specimen ID on a chain of custody form. The
Key Types editor allows you to create keys and determine their behavior.
Key Type ID
This is an ID number automatically assigned by the system to each Key Type.
Key Type Code
Create a code for this key type.
Key Type Name
Enter a descriptive name for the key type.
Date Type
The Data Type box allows you to specify what sort of data you'll be keying. There are six options:
· The Text type specifies that you'll be entering plain text.
· The Date type specifies that you'll be entering a date when you use this key category.
· The Decimal type denotes a number with decimal places.
· The Integer type denotes a whole number (one with no decimal places).
· The Time type denotes a time of day.
· The Yes/No type specifies a true or false value.
Masking
If necessary, choose an appropriate masking type: if entering a Social Security number as the key,
choose SSN from the menu (entering 111225555 will become 111-22-5555.)
Select value from list below
When the data type is text, you can enter possible values to pick from. To enable this function, check
the "Select value from list" check-box, then, in the box below the "Select value from list" check-box,
enter the list of values that the program should present to the user when keying this key category.
Each value will appear on a separate line.
Linking
After creating a key type, you may link it to any DrugPak or MRO Management record. There are three
options:
· This key does not link to anything - Using this option will not link this key to any DrugPak record.
· When this key is entered, create a link - Using this option will create a link to a DrugPak table and
field. Once this option is chosen, two drop-down menus will appear, and require you to choose a
table name and a field name.
· When this key is entered, it updates a linked record - If a link already exists for a the table being
linked to in this key, this options will "push" this value to the chosen table and field. For example:
you have a key for specimen ID, and its linked to the specimen ID field of the tests table. Next, you
create a key for status, and link it (using this option) to the status field of the tests table. After the
specimen ID is entered, when you enter the status, this value is then "pushed" into the appropriate
field. If the specimen ID has not yet been entered, but the status has, the Document Manager will
hold on to the value. When the specimen ID is entered, the status value is then "pushed" to the
appropriate field.
Getting Started
5
If you choose "When this key is entered, create a link," or "When this key is entered, it updates a
linked record," a window appears that allows you to choose which table, and which field within that
table to link this key type to.
Part
II
Using Document Manager
2
Using Document Manager
2.1
Scanning Documents
7
Scan Documents
A document consists of one or more scanned pages. There are four ways to scan
documents into the system:
One Page
Use this tab to scan single-page documents, one at a time. Set the document type you are scanning
(if you know it) and click the Start button to scan a document. Each page you scan will be stored as a
separate document. The items in the "Document type being scanned" are created in the Document
Types window ( File | Edit Document Types).
Multiple Pages
Use this tab to scan multiple page documents, when you know how many pages will be in each
document. Set the document type (if you know it) and the number of pages to scan per document.
For example, if you have (5) 3-page documents to be scanned, you would set your "Number of pages
to scan per document" at 3. The program will automatically save the document and start a new
document after the specified number of pages have been scanned. You can also click the Save Now
button to save a document before the specified number of pages have been scanned.
Blank Separator
Use this tab to scan multiple page documents with blank pages as separators. This is a useful option
for ADF (automatic document feed) scanners. Place a stack of documents into your scanner, with a
blank page in between each document, and a blank page at the end of the document(s). After
specifying the document type, click the Start button to start scanning. Each set of pages (separated by
a blank page) will be saved as a separate document. You can also click the Save Now button to save
a document at any time, without a blank page being scanned.
Append Until Done
Use this tab to scan multiple page documents, manually indicating how many pages are in each
document. After indicating the document type being scanned, click the Start button to scan pages into
a document. Keep clicking the Start button for each page you would like to be included in the
document. Click the Save Now button to save the document with all of the previously scanned pages.
After you click the Save Now button, you can click Start to begin scanning pages into a new document.
2.2
Acquiring Documents
Acquire Document
This option will allow you to acquire documents already in your system, and add them to your
Documents Manager database.
· Navigate to the correct directory and select the document(s) that you want, and press the Open
button. This will add the documents to you Document Manager database.
· Once you have selected the document(s) that you want, the system will ask you the type of
document being imported. If they are all the same document type, you may enable the "Same for
all" check box. Otherwise, the system will ask for the file type for EACH file being imported.
8
2.3
Document Manager 6.0.70725
Viewing Documents
View Documents
This is the screen where you view and key the documents you've scanned into the system.
Initially, you will see only those documents that are incomplete (the "Only incomplete
documents" check box will be enabled). When there are documents in the system that have
required fields, and data for those required fields has not yet been entered, those
documents are considered "incomplete." In the sample below, there are no incomplete
documents, so the window is empty.
· After scanning documents that do require data entry, they will show up in the document viewer.
· Below the navigator bar is a series of fields that allow you to key in information for the document
you're viewing.
o Use the left-hand drop-down list to specify the document type being viewed. This will be filled out
automatically for you if you specified a document type during the scanning process. See Scan
Documents for more information.
o Use the middle drop-down list to enter information for a particular key type (See Edit Key Types for
more information). Required key categories are listed with an asterisk (*).
o Use the field on the right to set a value for the key category you just chose. Then, when you've
entered the key category information, click the Add button to key the information to the document
begin viewed. The system will automatically present you with each required key category. Once
the required data has been entered, the document viewer will display the next document requiring
data entry. You may also select a non-required key category from the middle drop-down list.
Add Button
Press this button once the required data has been entered (see above for more information on the
menus and data entry field).
Keys Button
Press this button to view all of the keys that have been entered for this document.
Save Pos Button
Press this button to save the current view (zoom and position) for the key category you're entering.
This makes it easier to find key information on a document image while you're entering information for
a particular key category. For example, perhaps the Specimen ID on your chain of custody form is
located in the bottom right hand corner of the Chain of Custody form. Select Specimen ID from the
middle drop-down list, then scroll and zoom the document image so that you can see the specimen ID.
Then click the Save Pos button. The next time Specimen ID is selected from the middle drop-down
list, the document image will scroll and zoom to wherever you were when you clicked the Save Pos
button.
· Below the Document Type and Key Category fields is a tool bar that lets you manipulate the image
being viewed. Use this tool bar to zoom in and out, rotate, and to save or print out the document
being viewed. Hold the mouse cursor over each button to see what it does.
2.4
Searching for Documents
Search Documents
Using Document Manager
9
This window allows you to search for document(s) based on your search criteria.
Search Terms
Enter your search criteria here.
Search document types
You may choose either "All documents types" or, by using the drop-down menu, pick a specific
document type (specified in File | Edit Document Types).
Search in
If you have chosen "All document types" above, you may choose "Keys," which will limit your search to
just the key types that you have created (specified in File | Edit File Types), or you may choose any of
the possible database tables (Results, MRO Work Area Results, Participants, Companies, Home
Bases, Labs, Collection Sites, and Third Parties). If you have chosen a specific document type (in the
"Search document types" field), you may choose either "Keys," which will limit your search to just the
key types that you have created (specified in File | Edit File Types), or any table to which your keys are
linked (see Linking, in Edit Key Types for more information on linking).
· The items available in the left-hand drop-down menu is determined by the combination of what is
chosen in the "Search document type" and "Search in" menus. When a table is chosen in the
"Search in" field, then this menu will display all possible fields in that table. If Keys is chosen, then
this field will show all available keys.
· The items available in the middle drop-down window allow you to enter a logical parameter - "is
equal to," "is not equal to," or "is one of." The right-hand field is where the value being searched
upon is entered.
These are best described with examples:
1. You want to search for a chain of custody document linked to a specimen ID of 1001. Assuming the
appropriate key type and document type have been added, you would choose Chain of Custody from
the "Search document types" menu, Keys in the "Search in" menu, Specimen ID in the left-hand
drop-down menu, "is equal to" in the middle drop-down menu, and enter 1001 in the right-hand field.
2. You want to search for all chain of custody forms that are linked to pre-employment tests and
random (RND) tests. Assuming the appropriate key type and document type have been added, you
would choose Chain of Custody from the "Search document types" menu, Results --- TESTS.DBF in
the "Search in" menu, Specimen ID in the left-hand drop-down menu, "is one of" in the middle
drop-down menu. You will now need to enter the two possible values by entering each test type (PRE
and RND), and pressing the Add button after each one. Each value entered, and added, will appear in
the box below. To remove an item from the list, select a value from the list, and press the Rmv button.
Once you have entered your search criteria and terms, press the Add button. This will place your
criteria in the bottom box labeled Condition. The Search button uses the criteria in this box to execute
the search. If you need to further specify your search criteria, you may add more search terms by
following the above steps, and pressing the Add button. If you choose to delete any of your search
criteria, select a condition, and press the Remove button. To remove ALL conditions, press the Clear
button.
When you have all necessary conditions in the Condition box, press the Search button, the the
program will display all result(s) (if any) meet your search criteria.
10
2.5
Document Manager 6.0.70725
Annotation of Documents
Annotation
The annotation tool bar allows you to add text, images and highlighting. When viewed
through the Image Viewer (see Edit File Types), and image can be annotated with additional
information, notes, and images.
Graphics Tool
This tool allows you to create a variety of shapes and lines. The color of the resulting item is
determined by the color chosen in the palette tool (in the middle of the tool bar - see below). The
pattern (solid, striped, empty, etc.) is determined by the pattern tool (to the right of the Sample Text
box), and the width of the line is determined by the number entered in the pen width box (far right end
of tool bar).
Text Tool
This tool allows you to create a text box, and note pad text box, or enter the system date. The
background color of the this item is determined by the color chosen in the palette tool (in the middle of
the tool bar - see below). The font, font style, point size, and color are determined by the the font tool
(to the left of the Sample Text).
Highlight Tool
This tool allows "highlighting" of any portion of the image. Highlighting enables the user to draw
attention to a portion of the image, by creating a transparent colored box. The background color of the
highlighted box is determined by the color chosen in the palette tool (in the middle of the tool bar).
Image Stamp Tool
This tool allows you to "rubber stamp" any image onto an existing Document Manager image. The
image that is rubber stamped is determined by the item chosen in the drop-down menu to the right of
the rubber stamp tool. To add images to this list, choose Tools | Add Rubber Stamps from the main
Document Manager screen, navigate to the desired image, then press Open. This tool assumes that
you have already have images to use as rubber stamps. If not, use any image editing software to
create them, or use the Document Manager to scan an image.
Color Palette
This tool allows you to set the color of any graphics, text or highlighting.
Font Tool
This tool allows you to set the font, font style (regular, bold, italic, etc.), point size and color of any text
entered using the text tool.
Sample Text
This window displays a sample of text using the font, font style, point size, font color, and background
color chosen.
Pattern Tool
This tool allows you to set background pattern (if any) of any shape created by the graphics tool.
Pen Width
Enter the line width for any non-solid graphic.
Part
III
12
Document Manager 6.0.70725
3
Menus
3.1
File Menu
File Menu
Overview
The File Menu is located at the top left of the software window. It provides quick access to
the main functions of Document Manager.
Scan Documents
Acquire Document
View Documents
Search Documents
Edit Document Types
Edit Key Types
Edit File Types
3.2
Preferences
Preferences > Global Settings
The Global Settings screen lets you specify how the Document Manager will behave in
various circumstances.
Do not prompt user for confirmation if only one specimen match found
This check box controls the behavior of the Document Manager's automated drug test results
matching. For example, when you enter a specimen ID, the Document Manager automatically looks in
the DrugPak system for a drug test that matches the specimen ID you entered. If it finds more than
one test that matches the specimen ID entered, it will present the user with a list of tests, and allow the
user to select the correct one. If this box is checked, the system will automatically select a test when
only one test matches the specimen ID, without presenting the user with a prompt. When this box is
unchecked, the system will present the user with a list of tests to choose from, even when this list
includes only one matching test. If no record exists in DrugPak with that specimen ID, it will link to the
test once it is entered.
Warn during key entry if no link was made
If you prefer not to be warned when no link is made during key entry, uncheck this box.
Examine results collected in the last # days
This setting allows you to specify how far back in time the Document Manager will look for matching
DrugPak test results. This may help reduce the number of tests the system will find for a given
specimen ID.
Wait for image after scan is complete # seconds
This setting allows for slower network connections to complete the creation of a scanned file before
moving to the next image (i.e., setting the number higher.). The default value is 2 seconds.
Pause after scanning is complete 'N' seconds
Enabling this function will force the scanner to pause for the desired number of seconds after each
Menus
13
scan. Leave this option disabled unless otherwise instructed by the Scanlon Associates' support staff.
Lock documents when viewing in the document viewer
Check this box to prevent other users from modifying the current image or its links.
3.3
Tools Menu
Tools Menu
Update Incomplete Status
If you add a required field to a document type, any documents of that type remain "complete." Use this
tool to set any documents that are complete, but that now require additional data entry. In this case,
set the appropriate start and ending Add dates, and press the OK button. All documents that are
complete and were scanned or added within the specified date range will now be set back to
"incomplete."
Purge Documents
Use this feature to remove old documents. Choose a cutoff date (documents acquired/scanned on or
before will be removed). You may also choose to remove all documents; only unlinked documents, or
only linked documents. Warning: use this feature with extreme caution. There is NO way to
"un-purge" documents.
Add Rubber Stamps
A rubber stamp is an image that can be "stamped" on any scanned or acquired image document.
Selecting this item will open the standard Windows file selection window. After this appears, navigate
to the desired image, and press the Open button. Any images chosen here will then be available for
use as a "rubber stamp" when using the annotation tool bar.
Enable Profiler
This is a diagnostic tool for the use the Scanlon Associates' support staff. Leave this tool DISABLED,
unless otherwise directed.
Delete Scanned Files
Enable this to delete scanned images from scan directory after they have been imported into the
database.
3.4
Help Menu
Help Menu
This menu provides various options to help you become familiar with the software. It offers several
options.
Contents
Takes you to the Contents section of the Help file.
Search
Takes you to the Search window of the Help file.
Print User's Manual
14
Document Manager 6.0.70725
Print the PDF version of the users manual. (Free) Adobe Acrobat reader is required:
http://www.adobe.com/products/acrobat/readstep2.html)
Register
Change your registration status. Call 800-321-7826 to receive your key.
Drugpak.com
This will launch your default web browser and automatically take you to the main DrugPak home on
the Internet.
Program Updates
This will launch your default web browser and automatically take you to the main DrugPak updates
page.
About
Check the version number of your software. Click the directory link on the About screen to open the
program folder in an Explorer window.
Download PDF