AlignAssist User`s Manual

AlignAssist User`s Manual
AlignAssist 1.0 User’s Manual
AlignAssist 1.0
User’s Manual
AlignAssist 1.0 User’s Manual
Features ........................................................................................................................ 1
System Requirements.................................................................................................. 1
Minimum System Requirements .................................................................................................................... 1
Recommended System Requirements ............................................................................................................ 1
Note About Version 1.0 .................................................................................................................................... 1
1 Installation ................................................................................................................ 2
Note About Installation.................................................................................................................................... 2
2 Uninstallation............................................................................................................ 2
3 Starting AlignAssist .................................................................................................. 2
4 Setup the files to be aligned ..................................................................................... 3
5 The alignment screen ............................................................................................... 4
6 Saving as an AlignAssist Intermediate File (Saving partially aligned projects) 5
7 Opening AlignAssist Intermediate Files (Opening partially aligned projects) .. 5
8 Closing AlignAssist and saving as a TransAssist translation memory................ 5
Menu Items ....................................................................................................................................................... 6
9 Aligning multiple files .............................................................................................. 7
10 Compatible file-types ............................................................................................. 7
AlignAssist 1.0 User’s Manual
Easily create valuable translation memory from previously translated materials!
AlignAssist is used to create and edit a TransAssist translation memory file from previously translated source and
translation documents. Using AlignAssist you can create a TransAssist memory without having to add each source
and translation segment in TransAssist manually.
Features
•
•
•
Simple interface which allows users to easily compare source and translation segments.
Partially finished files can be saved during the align process and continued later, or on a different pc.
File analysis is carried out in the background, so you can run other programs while AlignAssist analyzes the
file and performs preliminary alignment (please note: the amount of time required to switch between
AlignAssist and other programs is dependent upon the processor power and memory usage of the PC being
used).
System Requirements
Minimum System Requirements
Internet Explorer 5.5 or higher
128 MB RAM
Microsoft Windows 2000/XP
Recommended System Requirements
256 MB RAM
Microsoft Windows XP
Note About Version 1.0
AlignAssist version 1.0 is an evaluation version. This version is not a formal release and may still contain errors
and unimplemented features. If you have any comments, suggestions or bugs to report please contact us at:
[email protected]
Page 1
AlignAssist 1.0 User’s Manual
1 Installation
Note About Installation
Please be sure to install AlignAssist while logged in under a username with Administrator rights.
¾
¾
¾
¾
Download or copy AlignAssist_Setup.exe to a local hard disk.
Double click. AlignAssist_Setup.exe and the Setup Wizard will start.
Complete the installation process according to the on-screen instructions.
After installation is complete restart your computer.
2 Uninstallation
¾ Login under a username with administrator rights.
¾ Select [Start] > [All Programs] > [Assistant Suite] > [Tools] > [AlignAssist] > [Uninstall AlignAssist]
or select [AlignAssist] from the Windows control panel's [Add or Remove Programs] and select
[Remove].
¾ Complete the uninstallation process according to the on-screen instructions.
¾ After uninstallation is complete restart your computer.
3 Starting AlignAssist
¾ Double click the AlignAssist icon on the desktop or select [Start] > [All Programs] > [Assistant Suite]
> [Tools] > [AlignAssist] > [AlignAssist].
¾ The main AlignAssist window shown below will open.
Page 2
AlignAssist 1.0 User’s Manual
4 Setup the files to be aligned
¾ Select [Tools] > [Align Files…] from the menu or click the
¾ The [Align Files] dialog shown below will open.
¾
¾
¾
¾
¾
icon on the toolbar.
Click [Add Source…] and select the select the source document to be aligned.
Click [Add Trans…] and select the corresponding translated document to be aligned.
[Remove Source] and [Remove Trans] can be used to remove selected source or translation documents.
The [Up] and [Down] buttons can be used to change the order of the source and translation files.
Click [Align!] to begin the alignment process.
Page 3
AlignAssist 1.0 User’s Manual
5 The alignment screen
The source file segments are displayed on the left side of the window and the translation file
segments are displayed on the right side of the window.
¾ Check to make sure that the contents of the left source cells and the right translation cells are correctly
aligned, with source segment in the left cell corresponding to the translation segment in the cell directly
to its right.
¾ Click the [Merge] button between two cells that are above and below each other to merge the contents of
the cells.
¾ Click the [Swap] button between two cells that are above and below each other to swap the contents of
the cells.
¾ Select a segment of text in a cell and click the [S] (Split) button to move the selected segment to a new
cell directly below the original cell. The [S] (Split) button is located in the third row of the column of
buttons either to the left (for source cells) or right (for translation cells) of each cell.
¾ Click the [D] (Delete Cell) button to delete a cell and its contents. The [D] (Delete) button is located in
the third row of the column of buttons either to the left (for source cells) or right (for translation cells) of
each cell.
¾ Click the [E] (Edit) button to edit the contents of a cell. The [Edit Entry] dialogue will display. Clicking
on the [Source] displays the source information (font, font color, bold etc.) in an html tag format. The
[Format] > [Insert Symbol] menu item can also be used to insert an html code for a symbol. On the
[Editor] tab the [Format] menu can also be used to change the [Font] attributes and cell [Background
Color]. The [E] (Edit) button is located in the third row of the column of buttons either to the left (for
source cells) or right (for translation cells) of each cell.
¾ Click the [B] (Blank) button to create a blank cell immediately below the current cell. After creating a
Page 4
AlignAssist 1.0 User’s Manual
¾
¾
¾
blank cell use the [E] (Edit) button to edit the contents of the newly created blank cell or to copy and
paste from another source. The [B] (Blank) button is located in the third row of the column of buttons
either to the left (for source cells) or right (for translation cells) of each cell.
Click the <D> (Delete Row) button between two cells to delete the entire row (the source and translation
cells to either side of the <D> button).
Click the [1>], [5>], or [10>] buttons to the top or button right of the window to jump ahead by the
selected number of cells (1, 5, or 10 cells), or click the [>>] button to the top or bottom right of the
window to jump to the last cell in the project.
Click the [<1], [<5], or [<10] buttons to the top or button right of the window to jump back by the
selected number of cells (1, 5, or 10 cells), or click the [<<] button to the top or bottom right of the
window to jump to the first cell in the project.
6 Saving as an AlignAssist Intermediate File (Saving partially aligned
projects)
Saving a completed alignment as a TransAssist translation memory file creates and XML format translation
memory which can be used with TransAssist. However, when saving a partially aligned project please be sure to
use the procedure below to save the project as an AlignAssist Intermediate File and not as a TransAssist
Translation Memory.
¾ Select [File] > [Save As…] and the [Save] dialog will open.
¾ In the [Save as type] field at the bottom of the [Save] dialog select [AlignAssist Intermediate File] from
the drop-down box, type a name for the file, and save. AlignAssist Intermediate Files use the file
extension "aaif".
¾ For all subsequent saves, use the [Save] item to save over the same file, or again use [Save As…] (as
explained above) to save to a new file name.
7 Opening AlignAssist Intermediate Files (Opening partially aligned
projects)
¾ Select [File] > [Open] from the menu.
¾ The [Open] dialog will open.
¾ In the [Files of type] field at the bottom of the [Open] dialog select [AlignAssist Intermediate File]
(files using the file extension "aaif") and select a previously saved AlignAssist Intermediate File.
¾ The file will open in the same state that you saved it in and you can continue working on it immediately.
8 Closing AlignAssist and saving as a TransAssist translation memory
Please follow the procedure below to close AlignAssist and save your project as a TransAssist Translation
Memory.
¾ Select [File] > [Save As] from the menu.
¾ The [Save] dialog will open.
¾ In the [Save as type] field at the bottom of the [Save] dialog select [TransAssist Memory] from the
drop-down box, type a name for the file, and save. TransAssist Translation Memory Files use the file
extension "xml".
¾ For all subsequent saves, use the [Save] item to save over the same file.
Page 5
AlignAssist 1.0 User’s Manual
Menu Items
File New
Open
Edit
View
Tools
Help
This feature is not yet implemented.
Opens TransAssist Memory or AlignAssist Intermediate Files.
Save
Saves over the currently open file. When the currently open file has not yet been saved this
function acts as the [Save As…] function listed below.
Save
As…
Saves the currently open file with a user-specified file name, and as the file-type selected by the
user from the file type drop-down box.
Exit
Exits AlignAssist.
Undo
Cut
Copy
Paste
This feature not yet implemented.
Cuts the selected text.
Copies the selected text.
Pastes text that has been previously copied of cut
Toolbar
Displays/Hides the AlignAssist toolbar (top of the window).
Status Bar
Displays/Hides the AlignAssist status bar (bottom of the window).
Align Files…
Opens the [Align Files] dialog.
Preferences
Selects the default style (font, font color, bold, italic, underline etc.) for memory
entries. This feature does not function correctly in the current version.
Background
Color…
Sets the cell background color.
UI To
English/Japanese
Switches the user interface to the selected language.
Displays information about the current AlignAssist version.
Page 6
AlignAssist 1.0 User’s Manual
9 Aligning multiple files
AlignAssist can be used to align multiple files if the files are paired as shown below (for any two languages).
(Example)
English Part 1
Japanese Part 1
English Part 2
Japanese Part 2
English Part 3
Japanese Part 3
10 Compatible file-types
The following file-types can be aligned with AlignAssist 1.0.
¾ Microsoft Word Documents (.doc)
¾ Rich Text Files (.rtf)
¾ Plain Text Files (.txt)
Page 7
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement