Getting Started
Getting Started
Starting CADMAX
Once installation has been completed and you have completed Setup, CADMAX is ready to be started.
!
To start CADMAX from the Windows Task bar, click on Start, then click on Programs, locate
the program group that contains CADMAX and click on it, then click on CADMAX or the name
of the CADMAX product that you have.
!
To Start CADMAX from the Desktop, double click on the CADMAX icon. If you want to
change your Start In folder, right click on the CADMAX icon to display the pop up menu, click
on Properties, then click on the Shortcut tab. Click in the Start In text area and type the name
of a new start in folder.
Opening a CADMAX Drawing
CADMAX drawings created in any version of CADMAX can be opened through File > Open function.
The Open function can also be started by pressing F4. If a drawing is already loaded, CADMAX prompts
you to save the current drawing. See Saving a CADMAX Drawing below in this section.
Complete details on the Open function are available in the File Management and Utilities section of this
manual. Details on loading AutoCAD drawings are in the Import/Export section of this manual.
CADMAX User's Manual
Getting Started / 1
To Load an Existing Drawing
1.
Click on File > Open or press F4. The Open Drawing dialog box appears.
2.
A default list of files to load are displayed, based on the last file specification that was used.
Previous file specifications can be obtained by clicking on the arrow in the File Path combo
box.
Use the Folders box to locate the folder that contains the drawing. Sample drawings are
located in the /SAMPLES subfolder under the folder that CADMAX was installed.
CADMAX also includes ANSI, ISO, and Architectural starter drawings for all paper sizes in
the /STARTERS subfolder.
3.
Once the drive and directories are selected, a list of files is displayed. Highlight a file to load
by clicking on it, then click on OK. Also a double-click will load the file automatically.
Files may also be selected by pressing the first letter of the file.
2 / Getting Started
CADMAX User's Manual
The CADMAX Interface
Before you begin using CADMAX, this section will help you to become familiar with CADMAX’s userinterface.
CADMAX’s Main Window
The following figure shows CADMAX’s main window and its various components. CADMAX is based
on Microsoft Foundation Classes making its user-interface consistent with most other Windows products.
If you are already familiar with other Windows products, then you already know how to work with
CADMAX’s user-interface.
Menu bar
Tool bar
Ribbon
bar
Function box
Short cut bar
Function bar
History tree
Floating tool bar
Status bar
How to Execute Functions
Most CADMAX functions can be accomplished in at least two different ways. Some functions, those that
are frequently used, may be executed in more than two ways. Let’s start with the example of a Center
Diameter Circle as a typical geometry construction case. You can construct the circle starting from the
Menu Bar or by clicking on the specific icons to start the circle.
CADMAX User's Manual
Getting Started / 3
How to Insert Geometry using Center Diameter Circle as an Example:
1.
On the Menu bar, click on the Draw menu. Position
the cursor over Circle until the Circle submenu pops
up or click on Circle to display the submenu.
2.
In the Circle submenu, click on Center, Diameter.
or
1.
In the Draw Tool bar, click on the Circle icon.
2.
The Circle Function bar displays vertically along the
left edge of the screen. Click on the Center,
Diameter icon.
3.
Once a function has been chosen, its Function box is
displayed. It contains the modifiers that relate to the
selected function. Function boxes are modeless. You
can change its settings any time before you complete
the function.
4.
In addition to the modifiers in the Function box, there are additional modifiers that relate to
the active function in the Ribbon bar.
4 / Getting Started
CADMAX User's Manual
Like the Function box modifiers, these modifiers can also be changed at any time. If a
modifier is not available for the current function it will be grayed out.
5.
Click in the work to insert the circle.
Menu Bar
All CADMAX functions can be executed from the Menu bar. Commands are selected by using the left
mouse button to click on the menu name. The menu appears, showing all of the function choices that are
available. Functions that are unavailable will be grayed so that you cannot click on them. In addition, the
actual choices that are available in the menus will vary depending upon the current operating mode. You
can set the operating mode in the Edit menu or by clicking on the appropriate mode in the Ribbon bar.
Menus and functions can also be executed using the keyboard. If you look at the functions on the Menu
bar, you will notice they have a character underlined. Hold down the <Alt> key and type the underlined
letter to open the menu. Once a menu is opened, type the underlined character in the menu to execute the
function in the menu. For example, to start the Line function, type <Alt>+d to open the Draw menu, then
type “l” to start the Line Point to Point function.
CADMAX User's Manual
Getting Started / 5
Along with the name of the function in the menu, CADMAX also displays its icon if
one has been assigned to the function. As will be discussed below, many functions can
be executed from icons. The icons are placed in the menus to help users associate an
icon to the function that it represents. The figure to the right shows the Dimension
menu along with the icons that represent each function. Showing the icons helps users
learn them. This makes using tool bars and functions easier.
Many functions can be executed using short-cut keyboard operations. Keyboard shortcuts are displayed to the right of a function in the menu. Keyboard short-cuts can also
be assigned by users.
Menus can cascade through multiple levels. Whenever a menu contains a < right arrow
at the right of a function, another cascading menu will appear when the mouse hovers
over the entry. Slide the cursor over to the next level to choose a function in that menu.
Menu levels are expressed in the documentation using the convention Draw > Arc > 3 Points as an
example. This means click on Draw, slide the cursor to hover over Arc, wait into the Arc cascade menu
displays, and then click on 3 Points.
Whenever a “...” is displayed to the left of a function, it means that this function will display a dialog box.
The menus that are available will reconfigure automatically depending on the current mode. Functions
are grouped into the following menus:
File
• Accessing or creating files such as drawings, plots, merge, packages, exit
Edit
• Undo, Redo, Cut/Copy and Paste, Mode
View
• 2D Viewing functions such as Zoom, Pan, Show World
3DView
• 3D Viewing functions such as Zoom, Dynamics, View Edit, and Make Hidden
CPL
• Functions regarding the 3D Construction Plane
Draw
• All functions which create objects such as Lines, Arcs, Symbols, etc
Dimension
• All dimension functions
ParaDraft
• 2D Parametrics, if you have purchased this upgrade
Select
• All select and unselect functions
Features
• Used in Sketch and Modeling mode for parametric modeling features
6 / Getting Started
CADMAX User's Manual
Plane
• Used in Sketch mode for functions that control the sketch plane.
Modify
• All functions which change objects such as Transform, Fillet, or Modify Text
Query
• All functions which inquire about objects such as Measure and Quick Look
Tools
• A variety of miscellaneous functions like Symbols, Attributes, Preferences
Help
• Access to the on-line HELP
Tool Bar
The CADMAX Tool bar is located directly below the menu bar. It contains icons for a variety of
CADMAX’s different operations. In the default configuration, there are actually five different tool bars
and the available icons will vary depending on the operating mode. When one of the Tool bar icons are
clicked on, one of three different actions can take place:
• A dialog box will be displayed for the icon. For example, if you click on the
Open icon, the
File Open dialog box will be displayed. This would be the same as clicking on File > Open.
• A Function bar will be displayed. A Function bar is actually a Tool Bar that contains additional
functions that relate to the Tool bar icon that was chosen. For example, if you click on the
Line icon, the Line Function bar
will be displayed.
The default position for a function bar is vertical along the left side of the screen. They can be
positioned anywhere on the screen. Then any of the icons in the Function bar can be clicked on
to execute the specified function. The function at the top of the Function bar is the default
function. Whenever a Function bar is displayed the top function is automatically executed. The
default function in a Function bar can be changed at any time.
• A specific action will take place. For example, if you click on Clear, then any geometry that
is selected will be unselected. No additional action will take place.
Use Tool Tips to see the name of a function. Hold the cursor over a function and a tool tip will display
showing the name of the function.
CADMAX User's Manual
Getting Started / 7
Any Tool bar may be moved around separately by picking it up on a spot where there is no button and
dragging it elsewhere. Tool bars may float anywhere on the screen, or may be docked to any edge of the
screen.
Any Tool bar can be fully customized. In addition, new custom Tool bars may be created with any
combination of icon buttons. See the section on customization.
The standard CADMAX Tool bars are:
File
• Mostly the commands from the File, Edit and Help menus. Note that the UNDO and
REDO buttons in this tool bar also can display a scrolling list of UNDO locations to
jump to.
Draw
• The top most commands from the Draw menu.
Select
• Some of the commands from the Select menu.
Modify
• Some of the commands from the Modify menu.
Query
• Some of the commands from the Query, 3DView and CPL menus.
Ribbon Bar
CADMAX has a special tool bar called the Ribbon bar. It is located directly below the main Tool bar at
the top of the display. The Ribbon bar must always be displayed because it contains a variety of settings
and operations that are important to CADMAX’s operation.
The standard functions on the Ribbon bar are:
Mode
8 / Getting Started
• CADMAX has four different modes of operation: 2D, 3D, Sketch, and Modeling.
Sketch and Modeling modes are only available with CADMAX Solid Master. To
change a mode, click on the appropriate mode icon to make it the active mode. The
mode can also be set in the Edit menu.
CADMAX User's Manual
When is a mode is activated, CADMAX changes the menus, tool bars, and
operations for that mode. Using modes makes operating CADMAX easier. For
example, when you are in 2D mode, only 2D geometry can be added to the drawing
and only 2D functions are available.
Text Entry
• The keyboard echo area is here. Unless you are typing into a modifier in a Function
Box, all keystrokes will automatically go to this area.
Note that the keyboard area displays a down arrow where all previously entered
keystrokes may be found in a scroll window, optionally modified and reused.
Levels
• There are three Level features in the Ribbon bar:
First, the current level for new geometry is shown in a scrolling combo box. You
may change the level at any time while in a function that uses levels. Only editable
levels are shown.
Second, the Levels Control icon displays the complete Levels dialog box where all
capabilities are available. When the Levels Control icon is clicked on, any active
function will be aborted.
Third, Nested Levels can be accessed by holding the Ctrl key and then clicking on
the Levels icon. It displays the levels dialog box with only those functions that can
be changed within a command. This dialog may be displayed at any time and any
operation in the dialog box can be performed without interrupting the current
function.
Nested Levels and Levels Control can also be accessed from the Tools menu.
Attributes
• There are four Attribute features in the Ribbon bar:
First, the current Geometry attribute is shown in a scrolling combo box. You may
select another attribute at any time while in a function that uses geometry attributes
as one of its modifiers.
Second, the Attribute Control icon displays the complete Attribute dialog box where
all capabilities are available. When the Attribute Control icon is clicked on, any
active function will be aborted.
Third, the Nested Attribute icon can be accessed by holding the Ctrl key and then
clicking on the Levels icon. It displays the Attribute dialog box with only those
functions that can be changed within a command. This dialog box may be
displayed at any time and any operation in the dialog box can be performed without
interrupting the current function.
CADMAX User's Manual
Getting Started / 9
Fourth, the current Text attribute is shown in a scrolling combo box. You may
select another attribute here at any time while in a function that uses text attributes
as one of its modifiers.
Note that functions which do not require geometry or text attributes will gray out
these items. Nested Attributes and Attribute Control can also be accessed from the
Tools menu.
Auto Select • Click on the Auto Select icon to turn -Auto Select? “on” or “off”. When -Auto
Select? is “on”, new geometry will automatically be selected when it is inserted into
the drawing.
Use Filters
• Click on the Use Filters icon to set -Use Filters? to “yes” or “no” during select
operations. When Use Filters icon is depressed, geometry will be selected according
to the current User Filters settings. The Use Filters settings can be changed by
clicking on the select arrow next to the Use Filters icon to display the Use Filters
dialog box shown below.
The User Filters dialog box shows each geometry type and its current status. When
a geometry type is clicked, that means that it is available to be selected. When it is
not checked and the Use Filters icon is depressed, then that geometry type will not
be selected.
One setting may be changed at a time or use the Edit button to make multiple
changes.
Variables
10 / Getting Started
• CADMAX ParaDraft and Solid Master users will have a Variable icon. Click on
this icon to display the Variables dialog box.
CADMAX User's Manual
Function Boxes
When a function is executed from the Function bar or from a Menu and it has modifiers
associated with it, a small dialog box appears called a Function box. The Function box
displays the modifiers that may be set for the specified function. Function boxes are
modeless. This means you can go back and forth between the work area and Function
box without restriction. Simply click into this area and use the various radio buttons,
check boxes and combo boxes to set the modifier options. The graphic to the left shows
the Function box for Linear Dimension.
Combo box modifiers retain a history of the last 12 values entered for the modifier. You
can select from the list by clicking on the down arrow. This history is saved across
sessions in a file called "CXMODMRU.DAT". This file may not be edited outside of
CADMAX, but may be removed to get rid of the history, or may be moved to another
machine to acquire the modifier history.
Additional combo box modifier history can be obtained by clicking on the Smart Modifier right arrow
icon located next to the combo box down arrow. When you click on this button, a smart modifier dialog is
displayed. It contains a complete user-editable history of previously entered values, functions to help
calculate a value, and a calculator.
Some Functions boxes have special buttons:
Continue
• This is used to enter the next phase of a multi-phase function such as Stretch.
Finish
• This is used by functions which have modifiers but which do not require work area
clicks. Click this button after you have set any modifiers for the function to
complete.
You may pick up a Function Box and place it somewhere else on the screen by dragging its title area. The
next Function Box will appear at this location. If you click the 'X' to kill the Function Box, the command
will continue to run and the next Box will appear in the default screen location again.
Smart Modifier Dialog Boxes
The right arrow at the end of each modifier in a function box is used to display a Smart Modifier dialog
box relating to that modifier. Depending on the type of modifier, a dialog box will contain the following:
!
!
!
A list of user-defined modifier settings
A field for typing new modifier settings
A calculator
CADMAX User's Manual
Getting Started / 11
! Button boxes that have additional features for generating modifier values
! Buttons for adding, removing, reordering, and clearing the modifier list
Following is an example of a number/integer dialog box for angle.
The available options in a number/integer dialog box will vary depending on the particular modifier that
is selected. Following is a list of options:
OK
Click on OK to insert the currently highlighted setting into the modifier in the
detail menu. Double clicking on a modifier in the list will insert it into the
modifier. Lastly, pressing Enter will also insert the currently highlighted
modifier setting.
Cancel
Click on Cancel to close the current box without changing the currently
highlighted modifier setting.
Clear History List
Clear all entries in the History List.
Sort
New entries are added to the list sequentially. The list can be sorted
alpha/numerically. Once the list has been sorted it cannot revert back to a
sequential list. Although, if Sort is turned back off, then any new entries are
added to the list sequentially from that point forward.
Auto Update
When Auto Update is active, any value in the user entry field is automatically
added to the list when it becomes the active modifier setting by clicking on OK.
List Manager
At the top of the list are a series of icons that you can use to edit the History
List. Use the icons to add, delete entries or to move entires up or down the list.
First highlight the entry to be edited.
12 / Getting Started
CADMAX User's Manual
Calculator
Click on the Calculator icon, which is located at the end of the text entry field
of the Smart Modifier dialog box. The results of using the calculator are
inserted into the modifier field and also into the dialog box list if Auto Update
is active. When the Calculator icon is clicked on, the value in the user entry
field is placed in the calculator. After a calculation is complete, click on ‘=’ to
update the modifier setting.
Pick 2 Points
The Pick 2 Points function will calculate the distance between any two points
and insert the result in the modifier field and also into the dialog box list if
Auto Add is active. When Pick 2 Points is clicked on, the dialog box clears so
that the drawing can be viewed. Since this is already a nested function,
another nested function such as WINDOW or SNAP may not be used.
However, keyboard snap operations and coordinate entry are supported.
Pick 3 Points
The Pick 3 Points function calculates a modifier value from clicking on any 3
points in the drawing and calculating the angle. The answer is inserted into the
modifier field and also into the dialog box list if Auto Add is active. When
Pick 3 Points is clicked on, the dialog box clears so that the drawing can be
viewed. Since this is already a nested function, another nested function such as
Window or Snap may not be used. However, keyboard snap operations and
coordinate entry are supported.
Pick 4 Points
The Pick 4 Points function is identical to Pick 3 Points, except the angle is
calculated by clicking on two vectors and calculating the angle at intersection.
Pick Arc/Line
The Pick Arc/Line function will calculate the angle of a line from 0E or the
angle of an arc from start point to end point when it is an angle modifier.
When it is a distance, the radius of the arc or length of the line are used. Click
on the Pick Line/Arc function, the dialog box clears, then click on the line or
arc. The geometry will turn yellow in 2D and red in 3D indicating the element
that was touched. Since this is already a nested function, another nested
function such as Window or Snap may not be used.
Quick Tool Bars
Along the right side of the screen are several tool bars for performing popular
2d viewing, 3d viewing and snapping operations. The viewing functions are
nested and can be used any time. Use the snapping options in place of slash
snap codes or displaying the Snap dialog box. Any snap function executed in
the Quick Tool bar are for one snap only. After you click to use the snap on
geometry, the snap settings return back to their previous setup.
CADMAX User's Manual
Getting Started / 13
Pop-Up Menus
Pop up menus can be accessed at any time by clicking on the right mouse button. The
pop-up menu, shown at right, provides quick access to a variety of frequently used
functions. The advantage of using the Pop-Up menu is that it permits you to use a variety
of functions without having to locate their menu or icon. Additionally, when a function in
a Pop-Up menu is used the current Function bar is not changed. This permits you to easily
return back to the current function without having to return to the Menus or Tool bars.
Feature Tree
The Feature Tree is available to CADMAX Solid Master users in Sketch and Modeling
modes. It is located on the left-hand side of the display. The Feature tree contains a
list of each feature in a modeling session. The tree shows the type of modeling
operation. Some modeling operations have multiple levels. You can show the levels
by clicking on the + to expand the levels or - to compress the levels.
The Feature can be activated by clicking on Tools > Feature Tree. You can expand
or compress the width of the tree by placing the cursor on the right edge of the tree
until the
symbol appears at the cursor. Click and hold the cursor until the Feature
is at the desired width.
From the Feature Tree, a number of different functions can be performed. By clicking
on a feature in the tree, the geometry associated with the feature will also highlight
showing the relationship of the feature to the geometry. A feature can be edited or its
sketch edited from the tree. In addition, by right clicking, you can move, rename,
hide, condemn, and suppress features.
Status Bar
At the bottom of the screen is the status bar. The leftmost area of this bar serves two purposes. First, it
displays a small helpful description of any menu item or tool bar item which is under the mouse. Second,
this is where the standard CADMAX prompt appear.
The second area of the bar is where short informational messages appear. If a message is longer than the
informational area, you can click in the message and scroll through the text. In addition, you can copy
and paste the text in the message area.
The rightmost area of the Status bar shows the current mode and drawing scale.
14 / Getting Started
CADMAX User's Manual
Saving a CADMAX Drawing
The current drawing can be Saved as a CADMAX drawing. The Save As function can also be started by
pressing F3.
Complete details on the Save and Save As functions are available in the File Management and Utilities
section of this manual. Details on saving AutoCAD drawings are in the Import/Export sections of this
manual.
To Save a Drawing Using the Same Name
1.
Click on File > Save or press <Alt+F12>.
To Save a Drawing Using a New Name
1.
Click on File > Save As or press F3. The Save dialog box appears.
2.
Set the folder in the tree and type in the name of file to save the current drawing as.
Optionally, you can type in the full path.
Drawing summary information can be modified by clicking on the Properties box.
Use Preferences to edit the drawing history and set additional file preferences.
3.
Once the file name and folders are specified, click on Save As.
CADMAX User's Manual
Getting Started / 15
Exiting CADMAX
CADMAX prompts you to save your work before you exit CADMAX. You can exit CADMAX using any
of the following methods:
•
•
•
Click File > Exit.
Press F2.
Click on the X icon at the top right corner of the CADMAX screen.
Starting a Drawing from Scratch
In most cases, you'll find it best to start with an existing CADMAX drawing and then modify it to create a
new drawing. Use these instructions to start a CADMAX drawing from scratch and to learn about many
of the settings that you will want to configure in a starter drawing. This exercise will be helpful in
starting to use CADMAX for the first time. You will learn how to establish text and geometry attributes,
levels, draw a simple title block and establish 3D views (if working in 3D). Of course, CADMAX comes
with a number of sample starter drawings that you can use as a basis for making your own starter
drawing.
Starting a New Drawing
There are five simple steps to take before you begin a new CADMAX drawing:
1.
Load a "blank" drawing.
2.
Set style characteristics ("attributes") for text and geometry both for the screen display as well as
for plotting.
3.
Establish system preferences such as scaling preferences through Tools > Preferences and
Query > System.
4.
Set up a title block.
5.
If it is to be a 3D drawing, locate where the 3D views are to be plotted, and set up a 3D view
layout.
16 / Getting Started
CADMAX User's Manual
Opening a Blank Drawing
When you first start CADMAX, there is a blank drawing in memory. This allows you to rename the
drawing and save it as a new file. In the Sample Drawings that came with CADMAX, there is also a
drawing called BLANK which you can use.
1.
Start CADMAX.
2.
Press F3 or click on File > Save As to open the Save As dialog box.
3.
Specify a folder to save the drawing in, then type a name for the new drawing. All
CADMAX drawings have a default .CXD extension.
4.
Optionally, edit the Properties for Description, Type, Author, and Revision.
5.
Click on OK to save the drawing.
Setting Text and Geometry Attributes
The next step in setting up a new CADMAX drawing is to define the style characteristics of text and
geometry for the screen display and the plotter. We call these characteristics Text and Geometry
Attributes.
Geometry attributes determine color and line style for geometry displayed on the screen and pen number
and line style for geometry when it is plotted. Text attributes determine the width, height, font and
spacing for text when it is displayed on the screen and plotted.
Text and geometry attributes are set from Tools > Attributes or from the Attributes icon on the Ribbon
bar. The name you assign to each attribute should give some information about the style.
For example, the geometry attribute "object" could indicate that geometry created with this style will be
object lines in the drawing and the plot.
After you assign an attribute name, you must choose the style characteristics to be associated with that
name.
After you name and assign characteristics to an attribute, it is ready to be used as a modifier. Nearly all
drawing and text commands as well as some editing commands use the -Attribute Name? modifier. The
attribute name to use with each function is set in the ribbon bar. First start the function, then set the
appropriate attribute name. If a function does not use an attribute, then the attribute field in the Ribbon
bar will be grayed out.
CADMAX User's Manual
Getting Started / 17
Text and geometry attribute names, together with their characteristics, are stored with the current drawing
file.
For complete instructions for setting text and geometry attributes, see your CADMAX Reference Manual.
To define a new geometry attribute:
1.
Click on Tools > Attributes or Nested Attributes.
2.
Type the name of the new attribute and click on New.
3.
Using the select arrows, choose a Line Style, Color, and Pen for the new attribute.
4.
Click OK.
To define a new text attribute:
1.
Click on Tools > Attributes or Nested Attributes, then click on the Text tab.
2.
Type the name of the new attribute and click on New.
3.
Using the select arrows, choose a Width, Height, Spacing and Font. If the desired font is a
TrueType font, select one of the Custom fonts from the list, then click on TrueType.
Otherwise skip to Step 5.
18 / Getting Started
CADMAX User's Manual
4.
The Windows Font dialog box is displayed. Choose a Font and Font Style. It is not
necessary to choose a Size because CADMAX controls the size. Then click OK.
5.
Click OK.
Repeat this process as many times as you like to define each of the geometry and text styles you want to
establish for your drawing. Most users establish geometry attributes for object, hidden, center,
construction, and dimension geometry. For text, a number of attributes are established for dimensions,
notes, and title block text.
Setting Levels
Whenever geometry or text is added to a drawing, it is always placed on the current level. A level, often
referred to as a layer in other CAD products, is like a separate sheet of paper that can be used to construct
the drawing, model, or associated geometry. Various individual drawing levels can be utilized for
drawing formats, bills of material, dimensions, construction tool grids, drawing summary, or for any other
drawing level separation desired.
Each level has a status of either editable, referenced or invisible. The level that geometry is added on is
called the current level and it must be editable. The current level can be specified by the -Level Name?
modifier in the Ribbon bar.
New levels can be created at any time during the drawing process. When organizing your levels, choose
your level names carefully and consistently between drawings. This will help assure uniformity across
your entire engineering database. CADMAX displays the list of levels alphabetically. Use common
prefixes to name levels with related drawing components, so they are listed together.
To Create a new level:
1.
Click on Tools > Levels, or if a new level must be created within another command Tools >
Nested Levels. The Level Control dialog box appears.
CADMAX User's Manual
Getting Started / 19
2.
The cursor is blinking in text box. Enter a new level name, then click on New or press
Enter.
The level name can be up to 40 characters. Level names can contain letters, numbers, and
special characters such as comma (,), dollar sign ($), hyphen (-), underscore (_), and spaces.
3.
Click on OK to return to the drawing.
New geometry is placed on the current level. The current level is the name highlighted under the -Level
Name? modifier on the Ribbon bar or the Current Level text area of the Levels dialog box. Once the
current level name is changed, any new geometry is now associated with this level.
To make a level current:
1.
On the Ribbon bar click on the Level select arrow to display a list of levels in the drawing.
2.
Scroll through the list and click on the desired level.
or
1.
Click on Tools > Levels or Nested Levels.
2.
From the Level Name list, make a level current using one of these methods:
!
!
3.
Click on a level, click on Current, then click on OK.
Double click on a level.
The Level Control dialog box closes and the specified level name becomes the current level.
20 / Getting Started
CADMAX User's Manual
Drawing a Title Block
To create a title block that matches your drafting standards, you'll use 2D rather than 3D drawing
commands. Since it is a new drawing, you will have to create a new level, and then make that level
"editable" so that geometry can be added to it.
Typically title blocks consist of 2D rectangles and lines and some text. The one illustrated here is very
simple, but the same principles of construction apply to even the most complex title block. We're going to
place our title block on Level Title_Block of the drawing.
1.
Click on Edit > 2D Mode to draw in 2D.
2.
Click on Tools > Levels.
3.
Create a new level called Title Block.
4.
Make Title Block editable.
5.
Click on Draw > Rectangle > 2 Corners.
6.
On the Ribbon bar set the -Level? to Title Block.
7.
Set the Geometry
Attribute to one of the
attributes that you
defined.
8.
Click on the first point of
the rectangle in the upper
left corner of the drawing
area.
9.
Drag the cursor
diagonally, and click on
the second point in the
lower right corner of the
drawing area.
CADMAX User's Manual
Use Rectangle > 2 Corners to draw the perimeter of the title block.
Getting Started / 21
Next we'll draw two smaller rectangles in the lower right corner.
10. Click on the lower right corner
point of the large rectangle.
Then type:
Ctrl+74, Ctrl+81
Then press Enter.
11. Now click on the lower left
corner point of the new
rectangle. Then type:
Ctrl+72, Ctrl+8.5
Then press Enter.
Draw two connecting rectangles in the lower right corner of the large
rectangle.
Now we'll use Line to divide each of the two connecting rectangles into four quadrants. But first we'll set
Snap to Midpoint so we can easily find the midpoints of the lines that form the rectangles.
12. Click on Tools > Snaps.
13. Set -In Effect? to ‘until changed’. Click on Midpoint, then click on OK.
14. Click on Draw > Line.
15. Set -Connect? ‘off’.
16. Now draw vertical lines
from the top to the bottom of
each rectangle. Your click
points snap to the midpoints
dividing the rectangles in
half.
17. Draw horizontal lines across
each of the rectangles.
Again, the click points snap
to the midpoints dividing
the rectangles in half again.
Divide each of the rectangles into four quadrants.
18. Click on the Tools > Snaps, reset snap to default by clicking on the Default icon in the
lower left corner of the Snap dialog box. Then click OK.
22 / Getting Started
CADMAX User's Manual
Let's add some text!
19. Use View > Zoom to zoom in on the larger rectangle.
20. Click on Draw > Text.
21. Set the text and geometry
attributes on the Ribbon bar.
Make sure the text attribute you
specify has a height and width
of 1/8".
22. Click on a point in the upper
left quadrant of the rectangle to
locate the text.
23. Type Drawing Manager, then
press Enter twice to place the
text.
Enter text to complete the title block.
On your own: Complete the remaining three quadrants with this text:
Author
Revision
Approval
Now try this!!! Enter text in one of the quadrants of the smaller box. You will need to
change the text attribute to a smaller text size or modify the text scale to complete the title
block.
Once your title block has been finished, set the level on which it was created to Referenced. As you
remember, Referenced levels are displayed but cannot be edited.
24. Click on Tools > Levels. Make sure level Title Block is highlighted.
25. Click on Referenced, then click on OK.
If you are working in 2D, then setup is complete. If you are working in 3D, the next step is to create the
3D view layout.
CADMAX User's Manual
Getting Started / 23
Selecting a 3D View Layout
CADMAX includes starter drawings that already have 3D Views established, but you might want to set up
your own views. You can set up views using 3DViews > New View, Direction or Inherit or Easy View.
You can find additional instructions for the New View functions in CADMAX Help or the CADMAX
Users Manual. The following instructions show you how to use Easy View.
Easy View makes easy work of setting up 3D views for a new drawing. There are eight view layouts from
which to choose. Each of them includes at least one orthographic view and at least one isometric view.
See CADMAX Help for the complete listing of available layouts.
Use Easy View to select the layout of views and to set the view/model scale as well as the outline and
reference box levels. In addition to choosing a view layout, you'll need to define the 3D largest
coordinate, the 3D view-to-model relationship and how 3D geometry will relate to 2D geometry.
Before you start Easy View, create two new levels which will be used for the -Reference Point Level? and
the -Outline Level?. Follow these basic instructions for using the View Wizard:
1.
Create two new levels using the instructions shown to you earlier, then
click on 3DView > View Wizard.
2.
Set the -View Layout? modifier to any one of the eight layouts. Layout 3 is
a standard front, top, side, and isometric 4 view layout.
3.
Set the -Drawing Units? to either ‘English’ or ‘Metric’.
4.
Set the -Outline Level? modifier using one of the levels you created in
Step 1 above.
The Outline Level is where 2D view outlines are placed. No other
geometry should be placed on this level. This level is set to be
"referenced" so the outline is not selectable and, therefore, cannot be
modified. A geometry attribute called "EASY_VIEW_OUTLINE" is
created with lt blue, solid, and pen 1 for the view outlines.
5.
Set the -Ref Pnt Level? modifier using one of the levels you created in
Step 1 above.
The Reference Point Level is where a 3D rectangle which exactly surrounds each view is
placed. This level is set to be "invisible," and no other geometry can be placed on it. A
geometry attribute called "EASY_VIEW_REFERENCE" is created with lt blue, solid, and
no pen for the Ref Box.
24 / Getting Started
CADMAX User's Manual
6.
Set the -View Scale? modifier to either ‘Automatic’ or to or ‘As Below’. If you choose ‘As
Below’ to compute the view scale, then you must also set the -Drawing? and -Model? scales.
We recommend that you set -View Scale? to ‘As Below’ and you set -Drawing? and -Model?
scales to ‘1'.
7.
Set the -Origin Where? modifier.
Finally, you must set the origin of the view (0,0,0). CADMAX gives you five choices:
Lower Left, Lower Right, Upper Left, Upper Right or Center.
8.
Click on Finish. CADMAX takes you to a text screen and asks you to answer different
questions depending on how you set the modifiers.
9.
You must determine whether you want CADMAX to match the size between geometry
drawn in 2D and 3D. The default response is No, but you should respond Yes if you'll be
transferring geometry between 2D and 3D. To accept the default, press Enter. Or, to match
geometry size, type Y, then press Enter.
10.
CADMAX returns you to the drawing screen. Now you're ready to locate the view layout
within the title block. You'll use a dynamic rectangle to define the area within the title block
where the layout will display.
Click on a point within the upper left corner of the title block.
12.
Drag the cursor diagonally across the screen and click on a point in the lower right corner of
the title block. CADMAX displays the view layout you chose within that space.
We recommend that when you have followed these procedures to set up a drawing that meets your
drafting standards, save the drawing in a folder that you have reserved for your drawings. Open this file
whenever you're starting a new drawing. Your geometry and text attributes, title block, levels and other
style elements are already set up for you! Use this drawing in the future to start any new projects or
drawings.
CADMAX User's Manual
Getting Started / 25
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement