Melanie 3 – Frequently Asked Questions 1/17 • Does

Melanie 3 – Frequently Asked Questions 1/17 • Does
Melanie 3 – Frequently Asked Questions
1/17
INSTALLATION / SYSTEM REQUIREMENTS
•
Does Melanie 3 run under Windows 2000?
Yes, Melanie 3 runs on the Microsoft Windows 95, 98, NT, 2000 and XP
platforms. To our knowledge, no compatibility problems of Melanie 3 with any of
these systems exist. However, if you encounter any problems, please inform us
and we will fix them as soon as possible. Please note that, if you are installing
Melanie 3 on a Windows NT, 2000 or XP environment, you MUST log on as local
administrator of the PC before installing the software.
•
How can I check the exact version/release of Melanie I’m working with?
Click on the Help menu in the main Melanie window. The exact version number is
mentioned after the “About Melanie” item. The Melanie Technical Support team
will ask for this number when you report particular problems or bugs with your
version.
SCANNING
•
When I scan my gels at 600 dpi, their file size is around 25 MB. I import the
gels in Melanie with a reduction factor of 4, which reduces the size to 2.5
MB. Does this affect the quantitative analysis if I use the same factor for all
gels? What do you recommend? Can I use a higher reduction factor?
Your reduction factor of 4 seems a good choice. It allows you to obtain reasonably
sized files and should normally do without a significant loss of analysis quality.
Using a slightly higher reduction factor might not be recommended (2.5 MB is a
very reasonable file size), but everything depends, of course, on the physical size
and resolution of your gels. The final resolution at which you work (600/4=150 dpi
in your case) should clearly be higher than the spot resolution. Also keep in mind
that we recommend an image depth of at least 12-16 bit (should be standard for
most scanners currently in use).
•
How can I check the image resolution of my gels? What is the ideal
resolution for scanning my images?
The image resolution of your gels is given by the PixWidth and PixHeight. These
values can be found in the Gels Report (Report -> Gels Report) and are given in
micrometers. So a PixWidth of 200 in the Gels Report specifies that each pixel
has a width of 0.200 mm. This also means that you have 5 pixels per mm, or 50
pixels per cm, or 127 pixels per inch.
For the scan resolution, a lot depends on the quality of the gels and the detection
level required/desired. The larger the scan resolution, the better the image.
However, the larger the scan resolution, the larger the image, which means that
you can quickly slow down any kind of manipulation/analysis of the gel! A good
compromise is about 200 dpi, as this gives good quality images without resulting
in huge image files. Most scanners that are now available scan way above this
level, and you can adjust the resolution when you actually scan the image. Also
keep in mind that the image depth has to be sufficient (12-16 bit).
Melanie 3 – Frequently Asked Questions
2/17
OPENING FILES / IMAGE FORMATS
•
In the import function of Melanie 3, users can select TIFF, GIF, and Biorad
SCAN. When attempting to import a file from one of the Bio-Rad software,
the Biorad SCAN option is grayed out in the import function. Why?
The reason the Biorad SCAN option is grayed out in the import function is that
Melanie 3 doesn't find the file 'read_scnfile.dll' in Melanie\plugins. One possibility
is that the file is really absent; the other is that you installed an older version of
Melanie AFTER Melanie 3. In the latter case, the program will look for the
directory structure of the latest installed (oldest) version and will not find the
appropriate folders (the 'Help' option shouldn't be working either in that case). The
solution is therefore to reinstall Melanie 3 (after uninstalling it first).
•
What is the file extension of images that the Biorad SCAN option imports?
The file extension of the Biorad SCAN images should be ‘.gsc’.
•
Is it possible for Melanie3 to import files from any other analysis programs
(such as PDQuest), retaining spot-identification information
Melanie can only read the raw PDQuest image from files with the extension '.gsc'.
(with the 'Import -> Bio-rad scan' function). But no spot-identification information is
retained. No files from other programs can be imported. The reason for this is that
each program uses its own proprietary file format.
•
I understood that when opening .tif files in Melanie, such files contain data
only in gray levels, even if they were obtained from a scanner with OD
calibration capacity (The scanner I’m using contains a built-in density
calibration film to convert gray levels in OD). Is it really impossible to use
files where gray levels would be transformed in OD?
Normally, there shouldn’t be any problem for opening and using such .tif files in
Melanie. Melanie takes into account the conversion tables (obtained from a
scanner with OD calibration capacity) stored in the .tif file, and should therefore
give values that correspond to the ODs. However, if you have difficulties with the
reading or the interpretation of these files, you can send them to us ([email protected]), and we’ll look at the problem.
SPOT DETECTION / QUANTIFICATION
•
When I use the auto-detect option, I get SO many spots. It is difficult to tell
whether they are really spots or not. I think the computer is picking up any
dark areas and considering them to be spots. Any suggestions on how to
manipulate the system?
Do you obtain 100, 500, 2000, 5000 spots? These numbers may all be normal,
depending on the type of organism, tissue, and the size of gel you’re studying. Of
course, you have to optimize the spot detection parameters (see page 40 in the
Melanie 3 User Manual) in such a way that you only detect real spots. Please
note that the Saturation and Peakedness Increase parameters shouldn’t normally
be changed, so there are only 4 parameters left to be modified. Optimizing these
for your particular set of gels may need a little time, but it is really worth it in order
to get good and reproducible results. If you have some artifacts left, you can edit
Melanie 3 – Frequently Asked Questions
3/17
or delete these manually. You can also do a spot filtering (Choose Select -> Spots
-> Restrict by Value in the menu, page 47 in the User Manual) in order to delete
spots that are too small (or too large) in terms of Area, OD, Volume, etc.
•
I would like to know when and why I should use the “Fit with Gaussians”
option for spot detection.
Some people consider that spot contours, and thus spot quantitation, should be
approximated by Gaussian shapes. Some programs only provide this possibility.
We, on the other hand, think that detecting the shapes as they are, using the
Laplacian (default in Melanie), is more adequate. However, we want to leave the
choice to the user. We know that most of our customers use the default option
and that it gives very good results. It is up to you to decide which of the 2
detection options you find most adequate.
•
If spots are fitted by Gaussians - does this influence the quantification of
the spots or is it rather cosmetics, just to have a nicer looking interpretation
of what a spot is supposed to be?
Spots fitted by Gaussians have different quantification values (described on page
44 in the Melanie 3 User Manual), since they have different forms. It is not just a
cosmetic function.
•
Could you please explain the meaning of the various parameters of the spot
detection window?
If you want to know what the different parameters represent, you should take a
look at the explanations on page 40 in the Melanie User Manual. If you are
interested in the mathematical background, you can find more information in the
following article:
Melanie II - a third-generation software package for analysis of two-dimensional
electrophoresis images: II. Algorithms.
Appel, R.D. (1997) Electrophoresis, 18, 2735-2748.
Please note that spot detection has not changed from Melanie II to Melanie 3. But
it will be improved in the forthcoming version (Melanie 4), and will require less
parameters to be set!
•
I have some performance problems with Melanie 3. In particular spot
detection and saving of the spots is very slow (more than a minute for
detection and about 2 minutes for saving spots of a 2-3 MB gel, on a
Pentium III). Is this normal?
No, it is not. On a Pentium III, 700 MHz, with 256 MB RAM, about 2 to 4 seconds
are needed for detection (depending on whether image data was loaded or not),
and half a second for saving spots for a gel that’s approximately 2-3 MB in size.
Therefore, if spot detection and saving are slow, you should check the following:
á Are the gels on a local hard disk (on the same PC than the one Melanie is
running on), or are they on a networked disk? Disk access could play an
important role during detection, especially when image data has to be loaded.
When saving the spot data, the only operation is the disk access. Since this
really takes a lot of time at your location, there might be a disk access or
network problem.
Melanie 3 – Frequently Asked Questions
4/17
á Make sure you do not saturate your memory (by using loaded images or too
high image depth, i.e. true color)? This could be a problem.
•
In order to make the proper calculations and to compare our results with
previously interpreted values, we need to know which one of Melanie’s
quantification measures, i.e. %Vol, OD, Area, etc., or combination of
measurements can best be used to describe the amount of protein in a spot.
This question is delicate to answer, since everything depends on what you really
want to do and on the type of problem you’re treating. If you want to compare your
values with previously interpreted values, you should employ the quantification
measure used in the past.
If you use Melanie to re-evaluate any previously obtained gels, you should
consider the following: The %OD and %Vol are probably best because they
normalize the spot values with respect to the overall intensities or volumes,
respectively, in the gels. This is particularly important if you want to compare spot
values from different gels. As to the choice between the two, the %Vol should
normally be better, because it represents the total amount of protein in a spot.
However, since it depends on the spot boundary (Area), spot detection
differences (e.g. use of different detection parameters) and errors can
considerably influence the results. In certain cases, the %OD may therefore
perform better. To get an idea, you might display the scatter plots using the %Vol
(and the %OD), and see how well the values correlate between the different gels.
GEL ALIGNMENT
•
What can I do when I align gels using landmarks and the error message
reads that the "landmarks are poorly distributed”?
This message is usually generated when the landmarks are not well distributed
over the entire gel, and when the alignment function didn’t find a unique solution
for interpolation of the landmarks. One of the following operations might help to
solve the problem:
á Add one or several landmarks, in regions of the gel where no landmarks were
defined previously.
á Select “View -> Align Gels -> Other Alignment” in the menu. Choose the
reference gel in the upcoming dialog box. In the displayed "Align Gels"
window, change the alignment polynomial degree, for example to "First
degree".
á Move one of the landmarks just slightly.
•
When aligning or matching a larger set of gels, how does Melanie cope with
the situation that a landmark is not present in all of the gels?
The landmarks do not have to be present in all gels. Melanie will only align or
match the landmarks that have the same name (between the reference gel and
the matched, or aligned gel). There is no problem if you have one or several
landmarks missing in a gel. Melanie will just not take these into account when
aligning or matching. In cases where the spots for the landmarks have been lost,
because of technical problems (sometimes happens to border spots) it is better
not to add the landmark than putting it in a hypothetical spot position.
Melanie 3 – Frequently Asked Questions
•
5/17
I would like to match two gels, but as the spots do not superimpose exactly,
I used some landmarks to align the gels. Still, in some regions of the gels,
spots that should align because they are the same do not align perfectly.
How can I match my gels?
It is very important to understand that the alignment is nothing else than a visual
deformation (which doesn’t modify the underlying data) of a gel that aims to
minimize the distances between corresponding landmarks in 2 gels, in a general
way. The superimposition of landmarks will never be perfect (just as a regression
line doesn’t pass perfectly through the points).
Aligning your gels is just a visual method that can help you find the corresponding
spots in two gels. In the current version of Melanie (Melanie 3) it can also help the
matching process in difficult cases. But it is not necessary to align the gels
perfectly before doing the matching! You could just put a few (correctly
distributed) landmarks on your gels and immediately do the matching (without
aligning). Or even try to match the gels without putting any landmarks! (Obviously,
the spots have to be detected first.)
You also have to be sure to only put landmarks on spots for which you are 100%
sure that they should be matched, otherwise you may introduce matching errors.
Once you have matched the gels, you can (re-)do an alignment, based on the
pairs that have been found. In this case, the visual overlap of the gels may be
better, although this is not always the case. In stacked mode, pairs can be
visualized by displaying the pair vectors (View -> Stack -> Show pairs).
•
How can I, after successful alignment of the gels, retrieve a list of all spots
with their original X and Y coordinates (before alignment) in addition to the
new X and Y positions (after alignment)?
You should be aware that the gel alignment function is a purely visual tool. This
means that the gel is visually deformed in order to better superimpose the
landmarks or pairs with those in the reference gel. But the numerical values are
not influenced by the alignment!
•
I think there is a problem with the alignment function. Sometimes, when
aligning gels, the landmarks are not correctly superimposed. In those
cases, only a “double-click” allows correct alignment.
It is very important to understand that the alignment is nothing else than a visual
deformation (which doesn’t modify the underlying data) of a gel that aims to
minimize the distances between corresponding landmarks in 2 gels, in a general
way. The superimposition of landmarks will never be perfect (just as a regression
line doesn’t pass perfectly through the points).
Moreover, the alignment doesn’t change the relative positions (translation) of the
gels (if you moved or zoomed some of your gels for a particular reason, you may
prefer not to loose that information/work). In order to reposition your gels so that
corresponding regions are superimposed, you therefore have to use the “doubleclick” on the region in question. This is entirely normal. By using the Shift key at
the same time, you can carry out this operation on all visible gels.
Melanie 3 – Frequently Asked Questions
•
6/17
After aligning a group of gels, is there a way to conduct a save function so
that when this group of gels are reopened together, there is no need to realign them?
Gel alignments imply relationships between different gels (A gel is aligned relative
to one specific other gel). This is the reason why the gel alignments are not saved
in the current version of Melanie. Indeed, the next time you open a gel you may
want to align it with another gel. So, each time you re-open your gels, you should
redo the alignment. This shouldn't be much of a problem if you defined a sufficient
number of annotations in each of your gels (regularly distributed over the entire
gel), or have saved pairs between the gels. You can use the pairs or annotations
for aligning your gels, and the process is almost immediate.
GEL MATCHING
•
I tried to auto-match gels I have downloaded from the ExPASy web server. It
is unsuccessful because the auto-match entry does not seem enabled.
To use the auto-match function (Edit->Pairs->Auto-Match Gel), make sure that
you have selected the gels you would like to match. A first gel can be selected by
clicking on its selection banner (on top of the gel). The gel will be highlighted in
green indicating that it has been selected. To select the next gel, hold down the
‘Shift’ or 'Ctrl' key and click on the banner of the additional gel. Now both gels
should be highlighted in green and the auto-match function should be enabled.
The only prerequisite for matching the gels is that the spots have already been
detected (Edit->Spots->Auto-detect). However, for the master gels downloaded
from the ExPASy server, this should not be necessary. Please note that the gels
you would like to match should be in the same directory on your PC.
For getting familiar with the Melanie software, it might be easier to use the sample
gels that come with the program (Program Files/Melanie-Trial/Gels_Ecoli). The
Master Gels found on the ExPASy server are quite dissimilar to each other and it
can therefore be difficult to match them automatically.
•
I would like to compare my gels with those found on the ExPASy server.
However, the gel sizes are quite different. Is it possible to change the size of
the imported gels so that their dimensions will be the same as my gels?
First of all, it is important to know that you can compare gels of different sizes.
You should just define a sufficient number of landmarks (put identical landmark
annotations on corresponding spots in the different gels, see pages 53-55 in the
Melanie 3 User Manual) and align the gels so that they visually overlap (pages
31-32). You can then match (pages 79-84) and compare the gels.
You can also reduce or enlarge a gel by choosing “Tools -> Gels -> Scale by”
from the menu. When matching the gels, you might get the warning “The pixel
widths differ”, but you can ignore this message.
•
What can I do when getting the error message “not enough input pairs”
while matching? I already matched 70 landmark annotations in my gels.
When Melanie 3 does a matching, it will look for spots that can be used as
anchors. That is, it looks for spots with sufficient intensity and that have an
environment that is very similar to the one for a (corresponding) spot in the other
Melanie 3 – Frequently Asked Questions
7/17
gel. The program needs to find a certain number of these anchor points before it
can go on matching the rest of the pairs. When you define landmarks and use
them for the matching, Melanie will first try to use these as anchor points, but if
the program considers that these points are ambiguous (have ambiguous
environments), it will just ignore them and try to find anchor points by itself. What
is important, and what takes time, is finding the anchor points. So, when you get
the message "not enough input pairs", this does not necessarily mean that you
didn't define enough input pairs. It might just mean that the program didn't find
enough anchor points to continue the matching process. This can be the case for
very dissimilar or distorted gels. In these cases, it is very important to align your
gels first (careful, the reference gel for alignment and matching should be
identical). Indeed, although the alignment is optional, it can speed up or improve
the matching step for distorted or very dissimilar gels.
REFERENCE GEL / GROUPS
•
Why, while working with the same set of gels, do I obtain a different number
of groups each time I choose a different reference gel?
The reference gel is the central node of spot groups. All spots in selected gels
that are paired with the same spot in the reference gel form so-called groups, an
essential concept in the Melanie software. This means that, when looking for all
existing groups, the program only takes into account the spots that are present in
the reference gel. Any spot absent in the reference gel will not be considered,
even if present in all other gels!
Therefore, the use of different reference gels may give different analysis results.
For example, when you choose a new reference gel, the program will only
consider the spots in this new reference gel and look if they are matched with
spots in other gels (look if a group exists). Since the number of spots (and
matches) are generally different from gel to gel, this will give a different number of
groups.
The quality of your reference gel is therefore very important: it should be
absolutely representative of the gels to be analyzed and contain all spots (or at
least most of the spots) common to the other selected gels.
In order to prevent getting very different numbers of groups when choosing
different reference gels, you should carefully check your results at each step of
the analysis process, and especially at the level of detection and matching. Before
doing an automatic matching, you should verify if spot detection was done
correctly and add/delete spots where necessary. After the automatic matching
you should again check your results and look if pairs have to be removed or
added.
PI AND MW CALIBRATION
•
How can I obtain approximated pI and MW values for the spots in my gel? I
have a reference gel with pI/MW standards.
The principle of the Pi_Mw calibration in Melanie 3 is as follows. First you have to
define Pi_Mw annotations for a certain number of spots (the more spots, the
better, of course) in your reference gel (page 54 in the User Manual). To do so,
Melanie 3 – Frequently Asked Questions
8/17
you have to open your reference gel (for which you know the pI and MW values)
as any other gel, detect your spots, and then add Pi_Mw annotations on different
spots (well distributed over the whole gel) by:
á
á
á
á
Choosing the annotation tool.
Clicking on a spot for which you know the pI and MW values.
Selecting the Pi_Mw category in the Create Annotation window.
Entering the known pI and MW values, separated by a space (a value of -1
means that no value is set).
á Clicking OK.
Do this for a sufficient number of spots.
Subsequently, you have to match your gel to this reference gel. That is, you have
to find the pairs between the corresponding spots in your 2 gels. Melanie can do
this (semi-) automatically (page 79 and further in the Melanie 3 User Manual).
Nevertheless you may speed up and improve the matching process by defining a
few landmark annotations (pages 53, 55) and then automatically pairing the
identical annotations (pages 79-81). This can be followed by a gel alignment
(visual deformation of one of the images in order to best superimpose the
landmarks, pages 31-32), and finally the automatic matching (page 80).
Once this is done, the calculated pI and MW values for all spots in the gel
matched to the reference gel are automatically available from the spot report
(pages 49-50 in the User Manual), and pI and Mw grid lines can be displayed over
the gel (page 31 in the User Manual).
You can take a look at the example gels in the Program Files/GeneBio/Melanie
3/Analyzed_Ecoli folder. The reference gel ECOLI.mel contains annotations from
the Pi_Mw category, and the spots from gels 94-0002.mel and 94-0005.mel have
associated pI and MW values because these gels were matched with the
reference gel.
•
I have a question about the pI and MW calibration functions in Melanie 3. It
is not clear to me exactly how the calculations are being performed to
determine the pI and MW of all proteins in a 2D gel pattern, and I would like
to know more about the algorithms used for the calibration.
The algorithm does the following: In case of the pI, it looks up the two closest
landmarks at the left and at the right of the spot for which the pI has to be
determined, and it then interpolates between these 2 points. Since the program
doesn't have any information about the experimental (non linear) pI scale, the
calculated values can only be approximate. In case of the MW of the spots, the
procedure is very similar, except that the program searches for the closest spots
above and below the spot for which the MW has to be determined, and that it
makes a logarithmic interpolation (the MW scale is logarithmic).
Extrapolating pI and MW values is a bit more complicated. For example, if the pI
of a spot on the very right side of your gel has to be determined, the program
looks for the two closest spots on the left of the spot in question. Provided that
these two spots are sufficiently distant from each other (in order to decrease the
error), the value for the spot in question can then be extrapolated.
Melanie 3 – Frequently Asked Questions
•
9/17
I have input several pI and MW values on landmarked protein spots. The pI
and MW values for all protein spots in the pattern are then calculated. The pI
and MW values that I entered for the landmarks do not stay the same in the
spot report. How can possible disagreement between input and output pI
and MW values be corrected?
Normally, the pI and MW values in the spot report should be the same as in the
landmarks. However, this is only the case if you have attached your landmarks to
actual spots and not just to pixel positions in the gel. If the landmark is attached to
a pixel, the pI and MW values for the spot that lies close to it will be slightly
different from that of the pixel (to which the landmark was attached). To link a
landmark annotation to a spot, select the annotation and then choose Edit ->
Annotation -> Link with Spot in the menu. You may also move the annotation onto
the spot: Select the annotation and drag it to the desired location. You will then be
asked if you want to link the annotation with the spot.
NORMALIZATION / INTENSITY CALIBRATION / BACKGROUND SUBTRACTION
•
Upon group analysis, I observed that the intensity ratios of spots between
gels didn’t match my visual estimates. This seems to be due to failure to
correct for background intensity. I’m figuring out how to perform this
correction. Should I use calibration annotations?
First of all, you should be careful when making visual estimations. Image analysis
programs have been designed to prevent this. But, it might indeed be necessary
to correct your gels for background intensity. However, no calibration annotations
are needed. You can use the "Filter Background" option in the “Tool->Gels->Filter
Image” menu and select one of the background subtraction methods in the
upcoming window. Since the program will create a copy of the gel after filtering,
you are asked to give the filtered gel a new name. Note that the original image
remains unaffected.
•
Is there a way to normalize gels?
Melanie not only calculates the OD, Area, and Vol for spots that have been
detected. It also calculates the normalized values %OD (OD divided by the total
OD over the whole image) and %Vol (Vol divided by the total Vol over the whole
image). The latter takes into account differences due to staining, for example, at
least for gels with very similar spot patterns. All spot quantification values are
automatically included in the "Spots Report" (select spots of interest and then
choose Reports -> Spots Report -> Current). The %OD and %Vol can also be
considered for the statistics on groups.
•
I want to calibrate a set of gels, in order to correct the pixel intensities for
scanning, protein loading and staining differences. How to proceed?
There are different ways to calibrate gels. Please note that calibrating is not
always necessary. If you look at %OD or %Vol values, you already normalize your
spot values with respect to the total OD or Vol of your gel. This may be largely
sufficient to get good results when comparing gels with a very similar spot pattern.
Anyway, the major possibilities for calibration are:
á You display scatter plots first, between your gels and the reference gel (taking
into account all the groups, and choosing the OD as value type), as explained
Melanie 3 – Frequently Asked Questions
10/17
on page 88 in the Melanie User Manual. Such a scatter plot can give an idea
on the relationship between the spot values from two gels by searching the
linear dependence between the spot values from one gel and the values taken
from another gel. In most cases, only relatively few protein expression
changes are observed between gels (only a limited number of proteins is
differently expressed due to different experimental conditions, or due to
disease, ...), so most of the values in the two gels should be similar, and
therefore the fitting line should be close to identity. If your slope is very close
to 1 and your offset close to 0 (when you look at OD values, a value of 50
might be very low, if maximum ODs in your gels correspond to 2000 for
example, this is only 2.5 %) then calibrating makes no sense. If this is not the
case, you can do a calibration of your gel: In the scatter plot window (obtained
with OD as value type), choose the 'Fitting report' option in the Report icon,
and save this fitting report (text file). Then select the gels to be calibrated and
import a calibration by choosing File -> Import -> Calibration (select the saved
fitting report). Each selected gel is now calibrated. To check this, you can
display the new scatter plots. All slopes should be close to 1 and all offsets be
close to 0.
You should be very careful when using this method, because if there are a lot
of proteins that are differently expressed you might introduce errors and get
identical values for corresponding spots that are in fact up or down regulated!
Such a calibration should essentially be restricted to gels that belong to the
same population or that represent the same sample.
á Another possibility is to use calibration annotations. This works in the following
way. You pick some spots (or pixels) that are present in all of your gels, and
that should be unaffected by the different conditions you use (in terms of
protein expression). Note that one should try to cover the entire raw value
range. You define calibration annotations for the reference gel (you have to
give values that correspond to optical densities for example, or counts, or
other real world values). When you select the other gels, and choose Edit ->
Gels -> Calibrate intensity, Melanie will first ask you the name of the label
category that contains the calibration values, and then if you want to use the
calibration values from the reference gel. If you say yes, the calibration values
from the reference gel are propagated to your gel via the paired spots.
á You can also do a calibration of the image capture device, using calibration
step wedges or calibration strips. Such step wedges or strips have known
intensity values assigned to it by the manufacturer of the scanning device. If
you scan such a strip at the same time as your gels, you can assign the known
intensity values to the different gray scales of the strip (as if it were a gel), use
these values to calibrate the intensity (Edit -> Gels -> Calibrate intensity) and
then use the slope and offset values to pass on the calibration to all gels
captured at the same time (Edit -> Gels -> Edit calibration).
•
After calibration, do the values in the reports and histograms correspond to
the raw data or the calibrated data?
Once a gel has been calibrated using Melanie, the program will consider and
display the calibrated values in the analyses. To get back to the raw data, you
have to choose the option “Edit -> Gels -> Reset Calibration” in the menu.
Melanie 3 – Frequently Asked Questions
•
11/17
Why can I only use the intensity (OD) for calibration?
The main goal of the calibration function is to compensate for intensity variations
caused by the scanner or by staining differences. This is the reason why, at least
in Melanie 3, only the OD is used for calibration and not the other quantification
values such as the volume. However, intensity-based calibration also affects the
volume, as can be seen from the following equations used for the calibration.
The new intensity values are calculated with the formula:
New_Intensity = Gray_Slope * Intensity + Gray_Offset
Therefore, the new volume will be:
New_Volume = New_Intensity * Area
= (Gray_Slope * Intensity + Gray_Offset) * Area
= (Gray_Slope * (Volume/Area) + Gray_Offset) * Area
= (Gray_Slope * Volume + Gray_Offset * Area
SYNTHETIC GELS
•
Can I create a synthetic gel from 3 (or more) gels run on the same sample,
repeat the process for several samples, and then compare the different
synthetic gels?
It is indeed possible to create synthetic gels. This option allows you to merge all
spots from 2 or more gels into one synthetic gel image. When based on several
gels run on the same sample, the synthetic gel is in fact an average gel, which
should contain all the spots that are representative of that sample.
To create such a synthetic gel, you should first match all your gels. Ideally, you
should do a pairwise matching. That is, if you have 3 gels called 1, 2 and 3, the
following matches should be performed: 1-2, 2-3 and 1-3. However, in practice
this can become very time consuming and the set of gels is therefore often
matched to a single reference gel. Note that the choice of the reference gel is very
important because it will be used as a basis for the creation of the synthetic gel.
You should therefore choose the gel with the best quality image and the highest
spot resolution as the reference gel.
Once you have matched your gels, you should select all the spots and gels that
you would like to include in the synthetic gel. Gels can be selected by clicking on
their selection banner (on top of the gel). To select more than one gel, you can
hold the 'Ctrl' key and click on the banner of the additional gels. If you want to
select all gels in the window you can also choose “Select->Gels->All” in the menu.
To select all spots in the highlighted gels, choose “Select->Spots->All”. Other
selection criteria for spots are also available (see Chapter 3 of the User Manual,
page 46). Selected gels and spots are highlighted in green.
You can also first select spots in each individual gel. This allows you to use
different selection criteria for each gel. This option is useful if you want to remove
some spots or artifacts from a particular gel. To do so, highlight only one gel and
select the spots of interest (see also Chapter 3 of the User Manual, page 46).
After you have selected the spots for each gel, you can select all gels to be used
for the synthetic gel as described before.
Melanie 3 – Frequently Asked Questions
12/17
When creating an average gel that should only contain spots representative of the
sample (spots present in all gels run on the same sample, or almost all the gels),
it is useful to select only groups (choose Select -> Groups -> All). Thus, you will
eliminate isolated spots that are just artifacts. You can also restrict your selection
to the groups that contain a minimum number of spots, for example, by selecting
groups that have the corresponding spot in at least 4 out of the 5 gels (see page
87 in the User Manual). Please note that you should check your results carefully,
since detection or matching problems may cause the exclusion of spots that are in
fact present in all gels, or include spots that are only present in one or two gels
(but wrongly matched with other spots). In addition, when selecting groups, the
program only takes into account the spots that are present in the reference gel.
Any spot absent in the reference gel won’t be considered, even if present in all
other gels!
After you made sure that all gels and spots you would like to include are
highlighted (green), select "Tools -> Create Synthetic Gel" in the menu bar, select
the reference gel from the upcoming dialog box, and specify a file name for the
synthetic gel in the “Create Synthetic Gel” window. The resulting synthetic gel,
that contains all selected spots, will be created and displayed. If spots belong to a
group, only one spot per group will be present in the synthetic gel.
If you select 3 gels or more you will be asked whether you would like to keep only
"triple pairs". In this case only spots that form a triangle of pairs will be included in
the synthetic gel. This means a spot S on gel 1 has to match a spot S on gel 2
and spot S on gel 3. The spot S on gel 2 also has to match spot S on gel 3. This
"triangle" is illustrated on page 120 of the User Manual. Please note that to use
the "triple pairs" option the gels have to be matched pairwise before creating the
synthetic gel. More information about synthetic gels can be found in Chapter 10 of
the User Manual (page 119).
Synthetic gels can be matched against each other or against any other gel in the
usual way (see description in Chapter 6 of the User Manual, page 79).
•
After a synthetic gel has been created, can more spots be added to it?
Yes. To do so, use the menu item “Edit -> Spots -> Copy from Gel”. However,
these spots will be isolated ones (neither matched, nor grouped).
•
I have problems when creating a synthetic master gel from 3 synthetic gels
(each one of the latter being representative of about 30 gels). A certain
number of spots, although correctly visualized, detected and matched, are
not present any more in the final synthetic gel that should be a standard for
the quality control.
There is only one reason why certain spots have not been included in your final
master gel: these spots were not selected when creating this master gel. Indeed,
the user has to select the spots that he wants to add to the synthetic gel. This
allows the use of specific criteria for inclusion. For example, when 10 gels were
matched for the creation of a synthetic gel, one could select all groups that have
the corresponding spot in at least 8 out of the 10 gels (see page 87 in the Melanie
3 User Manual), and only include these groups in the synthetic gel. Therefore, you
should check if you correctly selected all interesting spots and groups (in all gels)
before creating the synthetic gel.
Melanie 3 – Frequently Asked Questions
13/17
REPORTS
•
When several gels have been matched with a reference gel, how can I
prepare a report/list that includes all spots of the reference gel and all
matching spots on the other gels?
Any Groups Report will only contain the matched spots, and therefore unmatched
peaks won’t show up. This isn’t the case if you display a Spot Report, which will
contain all selected spots, matched or not. The trick is therefore to make the
adequate spot selection: first you should select all groups in all gels, and then
select all spots only in the reference gel. Then re-select all your gels and display
the Spot Report. The latter will contain both the matched spots in all the gels and
the non-matched spots in the reference gel. You can customize your Spot Report
by including the desired fields (Spot ID, spot value types, pixel coordinates, etc.,
both for the gel and reference gel). If you finally sort your data according to the
R:SpotID (i.e. the GroupID), you will get a nice report where all matched spots are
grouped together.
•
I obtain strange results while generating spot reports: the volume
calculations don’t seem correct since the same spot doesn’t give the same
results in two reports (one on all spots, the other on a few spots only).
Be careful, you should be aware of the fact that each report is an instantaneous
view of the gel and that at each modification (adding, splitting, suppressing,
modifying spots) you should display a new report in order to get the updated
values. Also, if you suppress or add spots in Melanie 3, all the spots are
renumbered, and so a new report has to be created because the old one is not
automatically updated. This means that you should always do any spot editing,
filtering, or matching before starting your final data analysis.
Please note, the problem with the changing spot IDs will be solved in the
forthcoming Melanie 4. In the next version of the program, all spots will have a
unique identifier, which won’t change when the spot is edited (the number of a
suppressed spot won’t be used again, and each new spot will get a new number).
ANALYSIS
•
How can I get statistics (such as median, etc.) for a group?
You have to select your groups (see the options in the Select -> Groups menu,
and page 87 in the Melanie 3 User Manual) and display a groups report (Analyze
-> Groups Report). When you do this, you're asked for the type of statistics
(mean, midrange, etc...). A complete description can be found in the User Manual,
from page 90 onwards.
•
I have run 5 gels on the same sample, and already did spot detection using
the same parameters in all gels. How can I simultaneously clean up my 5
gels, that is, filter out all staining and scanning artifacts and nonrepresentative spots?
Once you have detected spots, you can do a first type of filtering that consists of
selecting (and possibly eliminating) spots that do not satisfy certain criteria of size,
volume, and so on. To apply such a spot filtering, select all gels (Select -> Gels ->
All) and all spots (Select -> Spots -> All), then choose “Select -> Spots -> Restrict
Melanie 3 – Frequently Asked Questions
14/17
by Value”. You will be asked for the value type (Vol, Area, etc.) you would like to
use for filtering, and the thresholds to be employed. Only spots verifying the
conditions (e.g. with an area smaller than 0.3 mm2) will be kept. You can decide
to delete these spots, or just exclude them from your analysis.
A second filter could be applied at the group level. In this case, you should first
match your gels. That is, you should find the pairs between corresponding spots
in the different gels. Detailed descriptions about the matching procedure can be
found on pages 79-88 in the Melanie User Manual. If you have very similar gels,
you can try to do a completely automatic matching by selecting your 5 gels,
picking a reference gel (the best quality gel) and choosing “Edit -> Pairs -> AutoMatch Gels” in the menu. If you don’t find pairs, it might be necessary to define a
few landmark annotations and align your gels prior to matching (see the Manual).
Once your gels have been matched, you can select groups (spots) that are
representative of your sample. Spots that are only present in one of the five gels,
for example, are not representative of the sample and could be excluded from the
analysis. You can select groups by the number of spots they contain. For
example, you can select all groups that have at least 4 or 5 spots (that is, select
spots that are present in at least 4 (or 5) gels). To do so, select all groups (Select
-> Groups -> All), choose “Select -> Groups -> Restrict Selection” in the menu,
and select the option “Keep the groups whose number of selected spots is >= 4
(or 5)”. This type of filtering is described on page 87 of the User Manual. Next,
you can choose “Select -> Spots -> Inverse Selection” to obtain all spots that
don’t satisfy this criterion.
Please note that you should check your results carefully, since detection or
matching problems may cause the exclusion of spots that are in fact present in all
gels, or include spots that are only present in one or two gels (but wrongly
matched with other spots). Also, when selecting groups, the program only takes
into account the spots that are present in the reference gel. Any spot absent in the
reference gel won’t be considered, even if it is present in all other gels!
•
How do I get Melanie to display "potential differences" among 2-DE gels?
It is difficult to give an easy and complete answer to this question, because
Melanie offers so many possibilities. If you just want to compare a few gels and
you are looking for proteins that might be differently expressed, you should use
the tools described in Chapter 7 of the Melanie 3 User Manual (pages 88-100):
á First you can do a visual inspection by displaying the 'histograms on groups'.
We recommend that you play around with some of the functionalities such as
'Sorted values', 'Sort histograms by similarity' and so on. This already allows
you to see some tendencies in your analysis.
á You can then display a report on groups, while selecting the 'Separability' and
'Correspondence Analysis' as additional values to be computed (see page 96).
The 'Separability' option will give the highest gap between two consecutively
sorted spot values (note that the values in a column can be sorted by clicking
in the column header!). This is useful for splitting the group values in two
classes (different populations of gels). Please note that groups selected as
histograms or report entries can be re-selected on the gels.
Melanie 3 – Frequently Asked Questions
15/17
á Choose the correspondence analysis icon in the Group Reports toolbar to
display a 2-dimensional graph in which similar gels might be clustered
together. Spots close to those gels are generally characteristic of the gels.
á The Heuristic clustering utility allows you to automatically classify gels, and the
heuristic clustering report will give the group IDs of the spots that are
characteristic (different between each class/population of gels) for each class.
All these tools are complementary, and should be used together. Once you know
that there are 2 or more populations, either by using the tools mentioned above or
based on the experimental setup, you can define classes and use the tools
described in Chapter 8 of the User Manual (pages 101- 110):
á Again, the 'histograms on classes' and 'histograms on classes+groups' options
are very useful for this type of analysis.
á The classes reports allow classifying the groups according to their overlapping
value (it measures the difference between the values in two classes).
á Finally, we recommend using the statistical tests described on page 108. They
are quite powerful and indicate which differences are most significant.
•
I’m comparing two gels and would like to find the protein spots that are over
or under expressed by more than 2-fold in one gel with respect to the other
gel. How to proceed?
1) First match your gels (see Chapter 6, page 79 in the Melanie 3 User Manual).
2) Select all groups by choosing “Select -> Groups -> All” from the menu (you will
be asked to select one gel as the reference gel). All spots that are present in
both gels will be selected (green).
3) Display a groups report (Analyze -> Groups Report).
4) Choose the value type to be displayed (%Vol, for example).
5) Choose the statistics (mean 100% and M.S.D. 100%), as well as the additional
values (especially the Range ratio).
6) Melanie will display the Groups Report (different statistical values for each of
the groups, see pages 90-99) in which you can sort your data (see page 74 in
the Manual). In your case, the most interesting column is the one named
'Ratio' (This Range Ratio is the maximum value divided by the smallest value
in the sample specified by the percentage slider. Since you only have 2 gels,
this is the ratio between the protein quantities in the two gels). Click twice in
the label of the 'Ratio' column to sort the values in descending order. Now, all
the spots that have a Range Ratio > 2 are differently expressed by more than
2 times in one of the gels.
7) You can select these spots (lines of the table) by clicking on them and
visualize the corresponding spots on the gels by using the navigation tools
described in the User Manual (pages 72-73).
8) You can also display the histograms for the spots with Range Ratio > 2. To do
this, select the corresponding lines in your Groups Report, and click on the
histogram icon in the Groups Report window.
Melanie 3 – Frequently Asked Questions
•
16/17
I would like to use Melanie 3 for a rather large study aimed at identifying
disease-related proteins. To do so, I have to compare a set of 60 gels
prepared from patient samples with three different diseases (20 gels per
disease). I have planned the following experiment:
1. Filter the background and detect spots in all gels.
2. Define landmark annotations, pick a reference gel, align and match all
the images to this reference.
3. Merge all the images into one synthetic gel.
4. Set the synthetic image as a new reference, align and match all gels to it.
5. Assign each gel to a disease class (disease A, B or C).
6. Analyze the reports (Classes, Statistical tests) and the histograms on
Classes + Groups (looking at the %Vol), and detect interesting spots or
groups.
Can you tell me if this scheme is appropriate?
The general principle of the above scheme is indeed appropriate. We would just
like to add a few remarks and suggestions. We will describe a rather ideal way of
doing things, but you can of course make more approximations and simplify some
things in order to speed up your analysis.
First of all, making a single synthetic gel to which you can match all the others is a
very good idea. However, you might proceed a little differently.
á You could first make a reference gel for each disease class. That is, a
synthetic gel for disease class A, a synthetic gel for disease class B, and a
synthetic gel for disease class C. In each of these gels, you should filter out
the noise. You can do this by using criteria for the inclusion of spots in your
synthetic gel. You could for example only include spots that are present in at
least 10 out of the 20 gels that you have in a class (see page 87 in the Melanie
3 User Manual).
á Once you have done this, you can make one final synthetic gel (master gel)
out of these three synthetic gels. This time, you should include ALL the spots
that are present in any of the three gels.
á Finally, you can match all gels to this master gel (which will act as a kind of
spot position index/reference) and do a statistical analysis with the tools
available in Melanie (Chapter 8, pages 101-110, in the User Manual). Be
careful: you need this master gel for matching your other gels to it, but you
shouldn't normally include it in one of your classes during the analysis!
Second, within a class, you could calibrate the spot intensities in your gels with
respect to one particular gel in the class. To do this, we would suggest the
following (taking the gels of disease A as an example).
á Select the best quality gel in disease class A. Match all the other gels to it, and
display the scatter plots (with OD values). If the data show high correlations
and if all the fitting lines are close to identity (1.0 x + 0), then it might not be
necessary to calibrate your gels.
á If this is not the case, then, by looking at the values in the groups report, try to
find out which of the gels is most representative of disease class A in terms of
spot values (which of the gel has most spots with intensities close to the mean
for the class). You can use the procedures described on page 98 in the
Melanie 3 – Frequently Asked Questions
17/17
Manual to find the representative spots in a group. Choose the gel that has
most of these representative spots.
á Once this is done, you can match all gels in class A with the latter gel, and
display the scatter plots (with OD values) of all gels in the population (against
this gel). In the Scatter plot window, select the fitting report from the report
icon and save this report (filename.txt).
á Select all gels (if they got deselected in the meantime) and choose File ->
Import -> Calibration. If you now display again the new scatter plots, the fitting
lines should have the form 1.0 x + 0 (or something very close to it). So the
overall intensities of the gels of the Disease A class should now be
comparable.
á Be careful, you should only use this type of calibration to normalize your spot
intensities for gels that belong to the same population!
EXPORT
•
Can Melanie 3 export coordinates to spot excision robots?
Yes, Melanie 3 allows the export of spot coordinates to the Amersham
Biosciences Ettan spot picker and the Genetix GelPix spot picker. Moreover, in
principle, the spot coordinates generated by Melanie can be used with any robot
that accepts input files with coordinates.
•
I am looking for a solution to put the data generated by 2-D gel analysis
software on the Internet. Is there a software associated with / built into
Melanie that can make the data stored with Melanie available on the
Internet?
Yes, with Make2ddb (free) you can make your own database available on the
Internet using Melanie gels. More information can be found on the following site:
http://www.expasy.org/ch2d/make2ddb.html
ERROR MESSAGES
•
"Beware - something strange has occurred..."
This message appears when there is some kind of internal system error, an error
that has not been foreseen. Normally, you shouldn't get such messages. If you can
reproduce them, you should definitely send us ([email protected]) a
detailed description of the problem as well as a list of the different operations you
carry out before getting the error message, so that we can try to understand the
problem and find a solution.
•
"Bad image for the gel"
This indicates that there is something with the TIFF file. This may just be a tag
that is not recognized, or be something more serious, which prevents you from
opening the file. When you get this message, you should send us ([email protected]) one of the problematic TIFF files, so that we can look into
it and try to find a solution.
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement