User Manual Dr. GPS Raghava and the MycoTB team May 13, 2010

User Manual Dr. GPS Raghava and the MycoTB team May 13, 2010
INSTITUTE OF MICROBIAL TECHNOLOGY
BIOINFORMATICS CENTRE
DR. G.P.S RAGHAVA LAB
www.imtech.res.in/raghava/
Mycobacterium Tuberculosis Database
Management Software (MycoTB)
User Manual
Dr. G.P.S Raghava and the MycoTB team
May 13, 2010
i
Contents
1.
Welcome Page ......................................................................................................................... 1
2.
Login Page ............................................................................................................................... 2
3.
User Category .......................................................................................................................... 4
3.1
Simple Query.................................................................................................................... 4
3.2 Browse Table ........................................................................................................................ 5
4
3.3
Complex Query ................................................................................................................ 6
3.4
Display Record By Set ..................................................................................................... 7
3.5
Display & Delete Set ........................................................................................................ 8
3.6
Change Password ............................................................................................................. 9
Admin Category .................................................................................................................... 10
4.1
Create Table ................................................................................................................... 11
4.2
Insert Record .................................................................................................................. 12
4.3
Browse Table.................................................................................................................. 14
4.4 Manage Record ................................................................................................................... 15
5
4.5
Manage Table ................................................................................................................. 16
4.6
Manage Organism Name ................................................................................................ 18
4.7
Manage User .................................................................................................................. 19
4.8
Manage Database & Connection .................................................................................... 20
Operator Category ................................................................................................................. 21
5.1
Insert Record .................................................................................................................. 22
5.2
Manage Record .............................................................................................................. 24
5.3
Change Password ........................................................................................................... 25
ii
1. Welcome Page
MycoTB Database software has successfully installed in your computer. Then “MycoTB
Shortcut” in your computer‟s Desktop. Double click on the “MycoTB Shortcut” and
welcome Page will come.
a) Simple Search:- „Simple Search‟ is use for Demo of „Advance Search‟. when you does
not have the user name and password for this project.‟Simple search‟ is simiarly to the
„advance search‟ but user can not store his query permanently for the future use.when
user generate query then we give the name to that query is call 'SET'.
b) Advance Search:- When you have user name and password then use the „Advance
Search‟.user can store their „SET‟ for future use and generate further single „SET‟
between two or more than two „SET‟. Click on the „Login‟ menu and fill the user
name,password,select category and do login.
c) Administrator:- Administrator have the full control on the database. Admin can
Manage table,Manage table‟s record,Manage user and backup & restore database etc.But
Admin do Login first with his user name, password and category admin.
1
d) Operator:- Operator have the limitation control on the database. He can only insert and
update the record in table.But opearator do Login first with his user name, password and
category operator.
e) Login:- ‘Login‟ menu is use for security purpose. only Register admin,user and operator
can use this database.
f) Help:- If you have not user name and password. you are contact to Administrator and
take his user name and password.
g) Exit:- if you want to exit this software then click on the „Exit‟ menu.
2. Login Page
When you click on the „Login‟ Menu. This window will come and user is fill his user name,
password & category and click on the „Login‟ button.
2
Default login names:
By Default Administrator Name: admin
Password: a4321
Category: Admin
By Default Operator Name: entry
Password: e4321
Category: Operator
By Default User Name: mycotb
Password: m4321
Category: User
Important:
You can change their password when you will do login.
3
3. User Category
3.1 Simple Query
When User has login and Click on the „Simple Query’ Menu. This window will come. You
can filter the record from one or more than one table in single Organism Name.
Firstly you will select the organism name then all tables will come in „Select Table‟
dropdown list according to the organism name. When you select table then table‟s field will
coming in „Select Field‟ dropdown list. If table‟s field type is character then „equal to (=)‟
and „not equal to(!=)‟ operator will come in the „Select Operator‟ dropdown list otherwise
„equal to(=)‟,„not equal to(!=)‟,‟less than(<)‟,‟less than equal to(<=)‟,‟greater than(>)‟ and
„greater than equal to(>=)‟ operator will come in the „Select Operator‟ dropdown list. When
you select table field then first value of this field will come in the „Value‟ textbox. You
change the value of „Value‟ textbox to their according. If you find the record according to
this query then click on “search” button otherwise you want merge new query to this query
then click on the „Add‟ button and repeat above process and so on.
If you click on the „Search‟ button means your query is complete. We gives name to
that query is ‘SET-1’.Query name cannot be repeat and change.
„AND‟ operator have higher priority to „OR‟ operator means if single „SET‟ have more
than one „AND‟ & „OR‟ operator then „AND‟ operator between two query execute first to
„OR‟ operator between two query.
4
3.2 Browse Table
Click on „Browse Table’ Menu. This window will come. You can display the table‟s record.
Select the organism name then table will come in „Select Table‟ dropdown list then click
on the “Search” button. Table‟s record will come below in table format.
You can increase and decrease width of table‟s cell, when mouse over on the join of
header cell(according to screenshot orfid and Pattern1) then mouse‟s hand change to arrow,
then mouse drag left or right ,then width of cell will decrease and increase.
5
3.3 Complex Query
Click on „Complex Query’ Menu. This window will come. You can merge two or more than
two „SET‟ into single new „SET‟.
When you want merge two „SET‟ then firstly select the organism name. All „SET‟ will
come in the „Select Set‟ dropdown list according to organism name. If you find the record
according to two SET then click on the „Search‟ button, otherwise merge more „SET‟ then
click on „Add‟ button and so on. New SET is combination of two SET or more than two
„SET‟.
6
3.4 Display Record By Set
Click on the „Display Record By Set’ Menu. This window will come. When you generate
the „SET‟ then result come in the form of the „orf’ for Example Rv0001. you can display
record from one or more than one table according to the „SET‟.
Firstly select the SET then all table come in the „Whole Table‟ list box. When you select
one or more than one table then table‟s field come in the „Table‟s Field‟ list box. You can
choose the table‟s field that you want to display and click on the „Display‟ button. Table‟s
field come in the below.
7
3.5 Display & Delete Set
Click on the „Display & Delete Set’ Menu. This window will come. You can see the details
of the „SET‟ and delete the „SET‟.
You can delete the „SET‟. When you checked the „Delete‟ field and click on the “Delete”
button then corresponding „SET‟ will be deleted.
8
3.6 Change Password
Click on the ‘Change Password’ Menu. This window will come. You can change your
password.
9
4
Admin Category
When you click on the ‘Login’ Menu. This window will come and Administrator is fill
his user name, password and Category and click on the „Login‟ button.
By Default Administrator Name: admin
Password: a4321
Category: Admin
Important:
Admin can change his password when you will do login.
10
4.1 Create Table
Click on the ‘Create Table’ Menu. This window will come. You can create the new
table in organism name.
Enter table name and give the number of table‟s field, click on „Go‟ button then give the
value of field‟s name and data type and click on the „Save‟ button then table will create.
11
4.2 Insert Record
Click on the ‘Insert Record’ Menu. This window will come. You can insert the record in the
table by two operation first is file and second is row by row.
If you are insert the record by file. File should be in WordPad or excel format. Select the
table name for insert the record and click on the „File‟ button. Browse the file by click on the
„Browse‟ Button. If you want replace the existing data from the table then check the „Replace‟
checkbox. Your file has special character between table‟s fields that special character fill in the
“Field terminate by” textbox. If you want to insert the record for particular column then insert
the column name and click on the „Submit‟ button.
12
If you are insert the record by row by row. Choose the table name from the „Select Table‟
drop down list and click on the „Row‟ button then fill the value of table‟s field. If you want insert
another row then click on the „Add Row‟ button and fill the value in another row and last click
on the „Insert Record‟ button.
13
4.3 Browse Table
Click on the ‘Browse Table’ Menu. This window will come. You can display the table‟s
record.
Select the organism name then table will come in „Select Table‟ dropdown list then click
on the “Search” button. Table‟s record will come below in table format.
14
4.4 Manage Record
Click on the ‘Manage Record’ Menu. This window will come. You can update and
delete the record in the table.
Firstly search the record for delete or update by click on the „Search‟ button then record
come in the table‟s row format. If you want update the record then enter the modify value in the
table‟s row and click on the „Update‟ button. If you want delete the record, check the „Delete‟
Column‟s check box and click on the “Delete” button.
15
4.5 Manage Table
Click on the ‘Manage Table’ Menu. This window will come. You can edit the table‟s
field, insert new field and delete the table from the organism name.
Select the table then table‟s field come in the below. If you want modify the table‟s field
name or change the „Type‟ then check the corresponding table‟s field by „Select‟ column check
box and click on the „Edit‟ button. Change the table‟s field or data type and last click on the
„Update‟ button.
If you want delete the table‟s field then check the “Select” column check box and click
on the „Delete Field‟ button.
If you want delete the table from the organism name then select the table and click on the
„Delete Table‟.
16
If you want add new field in the table then click on the „Add Field‟ button and display
this window. Enter the new field value, choose the data type and set the position then click on the
„Save‟ button.
17
4.6 Manage Organism Name
Click on the „Manage Organism Name’ Menu. This window will come. You can insert
new organism name and edit the existing organism name.
If you want insert new organism name in the database then enter the new organism name
in the „New Organism Name‟ text box and click on the „Save‟ button. New organism name is
come in the below table list.
You can edit the organism name when you select the organism name and type new
organism name and click on the „Update‟ button. You can delete the existing organism name.
When check the „Delete‟ column check box and click on the „Delete‟ button.
18
4.7 Manage User
Click on the „Manage User’ Menu. This window will come. You can create new user, delete
existing user, reset the password of existing user and change the category of the existing user.
If you want create the new user then enter the new user name in the „Creat User‟ Box and
enter the password and select the category for the user and last click on the „Save‟.
If you want reset the password of existing user then select the user name from the „Reset
Password‟ box and enter the new password and conform password and last click on the „Reset
Password‟.
If you want delete the existing user then select the user name and click on the „Delete‟
button.
If you want the change the category of user then select the user name from the „Change
Category‟ box and select the another category and last click on the „Update‟ button.
19
4.8 Manage Database & Connection
When click on the ‘Manage Database & Connection’ Menu. You can take the backup
of mtb database from the web server and restore database in the local wamp server. You can
update the connection information.
You can switch the connection to web server or local wamp server, if you have server
name or ip address, user name and password. If you want stable connection to the web server
then fill the some information such as
Server Name (IP): 172.141.121.22
User Name: mtb
Password: Mtbimt22
If you want stable the connection to local wamp server then fill the some information
such as
Server Name (IP): localhost
User Name: root
Password:
And last click on the „Connection Update‟ button.
If you want take the mtb database backup from the web server then firstly your
connection is stables from the web server (see above connection update) then after click on the
„Database Backup‟ button and dialog box will come for saving the database file location. You
give the backup file name and click on the “save” button. Then your database will successfully
backup.
If you want restore backup database in the local wamp server then click on the „Restore
Database‟ button and dialog will come and double click on the database backup file.
If you want export the tables then check the table and click on the „Table Export‟ button.
After this dialog box will open for saving the file. You can give the file name and click on the
„save‟ button.
If you want import the tables then click on the „Table Import‟ button. After this dialog
box will open for taking the file‟s path. You can select the file and click on the „open‟ button.
20
5
Operator Category
When you click on the ‘Login’ Menu. This window will come and Operator can fill his
user name, password and Category and click on the „Login‟ button.
By Default Operator Name: entry
Password: e4321
Category: Operator
Important:
Admin can change his password when you will do login.
21
5.1 Insert Record
Click on the ‘Insert Record’ Menu. This window will come. You can insert the record in
the table by two operation first is file and second is row by row.
If you are insert the record by file. File should be in WordPad or excel format. Select the
table name for insert the record and click on the „File‟ button. Browse the file by click on the
„Browse‟ Button. If you want replace the existing data from the table then check the „Replace‟
checkbox. Your file has special character between table‟s fields that special character fill in the
“Field terminate by” textbox. If you want to insert the record for particular column then insert
the column name and click on the „Submit‟ button.
22
If you are insert the record by row by row. Choose the table name from the „Select Table‟
drop down list and click on the „Row‟ button then fill the value of table‟s field. If you want insert
another row then click on the „Add Row‟ button and fill the value in another row and last click
on the „Insert Record‟ button.
23
5.2 Manage Record
Click on the ‘Manage Record’ Menu. This window will come. You can update and
delete the record in the table.
Firstly search the record for delete or update by click on the „Search‟ button then record
come in the table‟s row format. If you want update the record then enter the modify value in the
table‟s row and click on the „Update‟ button. If you want delete the record, check the „Delete‟
Column‟s check box and click on the “Delete” button.
24
5.3 Change Password
Click on the ‘Change Password’ Menu. This window will come. You can change your
password.
25
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement