Basic AnalySIS tutorial

Basic AnalySIS tutorial
AnalySIS® Tutorial part 1
Written by Daniel Øyan
Thanks to Sveinung Lillehaug and Jan Bjålie for input.
AnalySIS® basics
Click on the table of contents to jump to selected page.
Important notes! .........................................................................................................1
Introduction to AnalySIS® .......................................................................................2
AnalySIS® interface at a glance...........................................................................2
Getting around the interface...................................................................................2
Using AnalySIS® to acquire an image from the microscope:..................................4
Part 1: Calibration of microscope: Koehler illumination.......................................4
Part 2: Camera; calibration and image acquisition ................................................4
Multiple image alignment ..........................................................................................5
Part 1: Acquire an image series without using a motorized table..........................5
Part 2: Acquisition using a motorized table...........................................................5
Part 3: Align acquired images................................................................................6
Add text, arrows and lines (Overlay).........................................................................7
Part 1: Possible necessary configuration: ..............................................................7
Part 2: Overlay bar icons at a glance: ....................................................................7
Part 3: Editing: .......................................................................................................7
Creating and using a database....................................................................................9
Part 1: Create database and define fields ...............................................................9
Part 2: Arrange fields: (see part 3 for usage) .........................................................9
Part 3: Add/ view/ edit/ search records:...............................................................10
Using the image analysis features............................................................................11
Image enhancement tools: Improve signal strength and reduce noise.................11
Analysing: Vocabulary and tools.........................................................................13
Particle division tools...........................................................................................15
Using results in Micro3D.....................................................................................16
Example 1: Cluster...............................................................................................16
Important notes!
1. Some notation: menus are underlined, dialog box options in italics.
2. The undo function doesn’t work very well; remember to protect important
images in the image buffer to prevent deletion (right click on the image in the
buffer and select protect image, a padlock icon should appear). It’s also a good
idea to check destination buffer and to save regularly to prevent data loss.
1
Introduction to AnalySIS®
AnalySIS® interface at a glance
Menubar
Toolbars
Screen
tools
Image window
Image
buffers
Status
bar
Database window
/w database toolbar
Currently selected Input
Getting around the interface
1. While parts of AnalySIS® functions like standard windows programs, the
overall interface is different and complex for a newcomer.We’ll start with the
parts of the interface that resembles a standard windows interface.
2. A bit about the menus (contents hidden inside them etc.)
• File: contains some standard file tools here, in addition, options to send
images, databases etc. via email and create reports
• Edit: standard editing tools, including a dysfunctional undo function. Also
some tools to edit sheets and diagrams, add bookmarks + some
search/replace functions.
• Database: Open/create/edit/query database…
• Image: Acquire, copy, delete, protect, align image. Also tools to configure
camera. Additional tools for staging, fluorescence etc may be added.
• Oper: Loads of tools to enhance the image; change brightness, contrast,
add various filters, change image bit depth, separate colours, edit image
etc.
• Measure: measuring tools, horizontal/ vertical/ arbitrary length, angles,
area, pixel value, histogram etc.
• Analysis: Image analysis tools.
• C-module: add/remove/create modules. Pretty much an “experts only”
menu.
2
•
Special: Contains all the setup/preferences menus you need to streamline
analysis for your needs, record/edit macros, add/remove modules, edit/
create menus, button bars etc. Very useful menu to return to when you get
the hang of the program, and feel like personalizing your version. Just
remember to save the old configuration before you do any changes, and
then save the new configuration under a new filename afterwards. The
save/ load/ reset configurations menu is found here: SpecialÆ
Configuration
• Window: standard window tools; change window, remove tool windows
etc.
• ?: Why they use ? instead of writing Help is beyond me. Anyway, you’ll
find some help files. As analysis is a piece of software that is under
development, the help files are far from complete though. You can also
access updated manuals from the web with this menu (? Menu Æ SIS on
the web Æ Product news). This will open a web browser. Select the
“analySIS® documentation download page” link, then software version.
3. Toolbars: Some of these are standard, but several are AnalySIS® specific. To
get a glimpse of their function, let the mouse hover over the icon for a few
seconds. For more info on what they do, read the manual.
4. Status bar. Shows currently selected input(i.e. camera), some info about
currently selected tool etc.
5. The image buffer: Images are put in buffers while you use them…
Shows current buffer source, destination buffer (i.e. the buffer
where the processed image will end up), secondary source and
mask. Read the manual for in-depth info no how to use these
functions.
Image buffers. The folder shows buffer number, the computer
screen symbolizes image type; true color, grayscale etc. The
text shows buffer name and image resolution.
Drag buffers to delete/save/print/add to database. If you click
last icon, it will open current database.
Switch between buffer listing (like this), and thumbnail view
6. viewport manager
Divide screen into subscreens
Display properties
Zoom
Image window. Shows the current buffer(s).
Note the thin red frame around the image. You
can reduce the size of this frame with the
mouse, and use the frame for zooming.
Display config
Toggle navigator
These tabs allow you to change
currently active screen, if you are
using a dual screen system
3
Using AnalySIS® to acquire an image from the microscope:
Part 1: Calibration of microscope: Koehler illumination
(Courtesy of Carl Zeiss, www.zeiss.com/micro)
For optimum results in light microscopy, precise control of the light path should start
before the light reaches the specimen. Prof. A. Koehler of Carl Zeiss was the first to
apply exact control of the light path in the illuminating beam, a method known as
"Koehler illumination."
Equipment specifications
The microscope must have a vertically adjustable, centerable condenser and iris
diaphragm.
Procedure
1. Rack up condenser with top lens swung in.
2. Focus on specimen with 10X objective.
3. Close down lamp field stop (diaphragm in base) while viewing.
4. Lower condenser slightly until diaphragm image is in focus.
5. Center image using condenser centering screws.
6. Open diaphragm to edge of field, fine focus and open further to just clear field.
7. Adjust contrast using condenser diaphragm.
8. Remove eyepiece and check to see that 75% of visible aperture is filled with
light.
BENEFITS
• Evenly illuminated image.
• Brilliant image without reflection or glare.
• Minimum heating of specimen.
Part 2: Camera; calibration and image acquisition
1. After the microscope has been properly calibrated, select an empty image
buffer, and open this image, preferably on the 2nd screen if the computer is a
dualscreen system. Then press the Livecam (/Acquire) button
, which will
give live images in the selected viewport. Refocus microscope for optimum
save an image
screen sharpness. When done press the snapshot button to
to the image buffer.
• Note: when you press the livecam/snapshot buttons a dialog box may
prompt you to select magnification.
2. Other camera controls:
•
Select camera (
): Allows you to choose between several different
inputs. Useful if the computer is connected to different cameras. Also
allows you to change camera setup/ add a new camera.
•
Camera control (
): Opens a dialog box that allows you to change the
cameras exposure time, colour etc. You also have access to a “sharpen”button which enhances image contrast and detail during live acquisition.
4
Multiple image alignment
Part 1: Acquire an image series without using a motorized table
1. Define image series Î How many images do you need?
Image menu Æ Image series Æ Define…
Select a folder to save the images in, then fill in fields in the right side of the
window;
• Begin at series image: What is the number of first image in this series? Set
to 1 if it is the first image of a series, if you are continuing an image series,
set to the appropriate value.
• Number of images: how many images are stored when series are saved?
• Number/ acquisition: # of images acquired1
• Delay/ acquisition: Time between each acquisition. 2
2. Ready to acquire: Image menu Æ Image series Æ Acquire
The camera will now acquire the images. Depending of camera setup
additional dialog boxes may appear
• Remember to calibrate microscope and camera before you start acquiring
an image series, as there is no elegant way to calibrate the camera during
acquisition.
• When using a non-motorized table must be moved manually, and it is
necessary to perform a “first pass aligning” manually, i.e. look in the
microscope and at the screen and move the tablet so that the sequence
overlap each other partially.
3. Load images into buffer Image menu Æ Image series Æ Load…
Select the folder you chose in step 1, images will now be loaded into the
image buffer.
Part 2: Acquisition using a motorized table
1. The first, and in many ways most difficult, part is to initialise the equipment.
Special menu Æ Preferences, select the stage tab. Choose your stage from the
list, click the Properties… button. A new window opens, click the Search
button, and cross your fingers. With some luck the pointer changes into an
hourglass within a couple of seconds and the stage is ready to use, if not click
cancel, and check the following:
• Is the stage controller turned on? There is a green light on the front that
lights up if the equipment is on. If not, turn it on (the on/ off button is
conveniently hidden on the backside).
• Check the position of the front switch, it should be “A”/”Auto”.
• Check position of dipswitches on the back of the stage controller; set both
in the lower position.
• Check connections, is the right cable connected to the stage?
• Try the procedure again, if it still doesn’t work, turn off stage and reboot
the PC. Start AnalySIS® , turn on the stage and try the procedure again.
2. Click the Limits button, to set stage limits.
3. Image menu Æ Multiple image alignment Æ Acquire… This opens up a
dialog where you set the number images you want to acquire. Use the joystick
to move the specimen, it’s position should be roughly in the centre of the area
1
2
Number of images & Number/ acquisition. Unless you know what you are doing, use identical values.
Useful if using a computer controlled tablet
5
you want to acquire. Click Acquire to start acquisition, and then click Align to
start image alignment. You can skip the first paragraph of part 3 if you use this
method.
Part 3: Align acquired images
1. The images should now be in the image buffer. Left click on the start image in
the buffer, then Image menu Æ Multiple image alignment Æ Arrange
Image tiles: Select the number of horizontal and vertical tiles you recorded.
Arrangement: Use these options to arrange the images
Correlation: How well does the image tiles correlate? Useful values 0.8 – 1.0
If necessary, it is possible to change arrangement manually.
Hit Ok, and wait for the software to align images
• Short description on the various types of arrangement:
Combing + Vertical:
Combing + horizontal:
Menader + Vertical:
Meander + Horizontal:
2. Next dialog box: Check if the software has managed to align the images,
manual corrections are possible by dragging images to desired position. If
manual corrections are necessary, the original size checkbox is useful.
The Overlap area option allows you to chose how the program mages
overlaps from one sub-image to another, side by side gives a sharp line
between the images if they don’t match well, the other options tries to blend
the images.
Hit ok, the image is now ready
• Note: If the image sequence has a “staircase look” i.e. the images in a
horizontal sequence are not aligned vertically; it will look something like
this:
If so the camera is not properly aligned with the
microscope Æ manual realigning of camera-microscope angle is
necessary.
6
Add text, arrows and lines (Overlay)
Part 1: Possible necessary configuration:
1. The overlay bar looks something like this:
If it bar isn’t available: Special menu Æ Edit button bars… Find
“overlay” in the button bar list, and select it. Note: when you exit
AnalySIS® after the session, choose yes when it asks you to save the
configuration.
Part 2: Overlay bar icons at a glance:
1. Edit overlay (
): Edit the overlays.
2. Select none (
): Deselects currently selected object(s). If no objects are
selected, it changes function to select all.
3. Object properties (
): Opens a dialog box which enables you to change
object properties (text size, line weight, colour etc.)
4. Layer (
): Changes which layers that are visible (image, overlay, both etc)
5. Burn overlay (
): “Burns” overlays into the image/ merges the original
image and the overlay to a bitmap, i.e. it will no longer be possible to edit the
overlays, but it will be possible to share the images in your database (including
overlays) with people who don’t have access to AnalySIS®
6. Delete layers (
): Deletes selected objects.
7. Load objects (
): Loads previously saved objects.
8. Save object (
): Saves objects for later use.
9. Cut, copy and paste objects (
): …
10. Arrange object order; bring to front/back etc (
): Creates a text overlay.
11. Text (
12. Rectangle (
13. Ellipse (
14. Line (
): …
): Draws a rectangle.
): Draws an ellipse.
): Draws a line.
15. Arrow ( ): Draws an arrow. Use the Object properties button to change the
direction of the arrow.
16. Polyline (
): Draws a polyline.
17. Polygon (
): Draws a polygon
18. Highlighter (
): Highlights parts of an image, i.e. draws a rectangle with a
transparent colour. Also useful to invert colours in an image
Part 3: Editing:
1. The drawing tools:
•
): Click on the shape you want to create, the
Rectangle and ellipse (
mouse pointer will then be moved to the image. Use the mouse to place the
7
object, then hold down the left mouse button to change object size. Use
Object properties (
•
) to change line weight, colour and fill colour.
Line tools (
): Click on the shape you want to create, the mouse
pointer will then be moved to the image. Place mouse where you want the
line to start, left click and move the mouse to the ending point then left
click again. Right click to end a polyline. Use Object properties (
change line weight and colour and optionally arrow direction.
•
) to
Polygon (
): Click on the shape you want to create, the mouse pointer
will then be moved to the image. Place mouse where you want the object
to start, move mouse to next position, left click again. Right click to finish.
The software will then draw a line connecting start and endpoint. Use
Object properties (
) to change line weight, colour and fill colour.
2. Text (
): Creates a text overlay. Usage is quite clumsy;
• When you click on the text tool it opens a red rectangle in the image. This
rectangle is your text box. Move mouse around to place the rectangle.
While keeping the left mouse button down, you can move the mouse to
change rectangle size. When text rectangle size and placement is correct,
right click.
• Right clicking will bring up the object properties dialog box. Enter your
text, then use the options under Font and Colors and Lines to change font
size, font colour, background colour etc. Click Apply to preview, then
change values if necessary. Click Ok/ Close when satisfied.
3. Edit overlay ( ): When you click this icon the mouse pointer is transported
to the image. To change size and placement of an object click on the object.
To change the objects properties, double-click on the object.
As long as this tool is active it is not possible to move the mouse pointer
outside the image. To deselect this tool right-click To undo actions press Esc
on keyboard before you right click.
4. Object properties (
): Opens a dialog box which enables you to change
object properties (text size, line weight, colour etc.)
8
Creating and using a database
Why create a database: There are several reasons to create a database. It helps
organizing images, it also allows you to search a set of images according to various
search criteria etc.
Part 1: Create database and define fields
1. New database: Database menu Æ New… Enter database name, and if
necessary where you want to save the database and files.
2. Define fields: AnalySIS® will automatically add technical info about the
images you put into the database. Other info must be defined first. Database
menu Æ Define fields…
Hit the New button to add a new field (e.g. staining method, specimen etc) and
fill out the “Current field“ field. From the dropdown list beneath (Data type)
select the type of info (e.g. Text= a short text, Long & Double = numbers,
memo = text of any length). Use the required checkbox for mandatory fields.
It might be useful to simplify data entry by making a list the user can choose
from when entering new data. If you want this functionality, hit Edit in the
picklist subwindow and enter the values a user may select from. Hit Add after
each value entered. Hit Ok when finished. After this is done use the options in
the picklist subwindow to choose how you want the picklist to work. Expand
picklist on input is generally the best choice.
When you have defined all the fields you need, hit Ok. A dialog box will
appear and ask if you want to arrange fields now. Choose yes, and continue to
next part.
3. Notes:
• Remember to hit New before you define a new field. If you receive weird
error messages like “Item not found in this collection” there is something
wrong with the user-defined fields.
• If you need to add fields to the database, and the new button is greyed out:
close the database, open it again (Database menu Æ Open) and select
Exclusive in the dialog window.
Part 2: Arrange fields: (see part 3 for usage)
1. To start arranging the info you want to collect and display in your database;
Database menu Æ Arrange fields… Generally; this dialog box allows you to
choose what data to collect and display. Use Add>> and <<Remove to choose
fields. Use the up and down arrows (
) to arrange the order of selected
fields.
2. Insert tab: Here you select what info you want to enter manually into the
database, and it’s order.
3. Info window tab: The info window is a small “Post-it note”. Max 7 fields of
data.
4. Form View tab: The form view displays a single image with a list of fields
from the database.
5. Table view tab: The table view gives you a list of database fields without
images in a table.
6. Print tab: what to print when using the print database function (File menu Æ
print… choose database in the page layout field)
7. Query by example field: A list fields for searching the database.
8. The database setup should now be complete. Hit Ok to finish. You can now
add records to the database
9
Part 3: Add/ view/ edit/ search records:
1. Add a record:
• From image buffer: simply drag an image from the buffer to the database
window. A dialog box will open and prompt you to fill out the fields you
previously selected (Insert tab under arrange fields).
• From a different database: Drag records from one database to the other.
Unless the fields in the two databases match, you will have to fill out the
fields required for the target database.
• From a file: Right click in the database window and chose Insert
Document File from the pop-up menu, chose the image files you want to
add, then fill out the fields.
2. View record:
• “Post-it” info: select the image whose info you want to view, then press
Alt + Enter on the keyboard. To make the info stay visible, use the
•
button in the “post it” window.
Other views (Icons from database window toolbar)
(1) Thumbnail view (
): Gives a thumbnail list of images in the
database, the only additional info shown is the Record name.
(2) Form view (
database
): displays a single image with a list of fields from the
(3) Table view (
): a list of database fields without images ordered in a
table.
3. Edit record:
• Select the image whose record you wish to change, then press Enter on
keyboard or use the Edit record (
) icon in the database window toolbar.
4. Search database(Database menuÆ Query): There are several ways to search
the database; the simplest is to use the Query by example option. It is also
possible to search database by SQL or Free filter.
• Query by example: right click in the database window or use the query
•
•
button in the toolbar (
), fill out fields to match your search criteria.
Then click search. Data matching your criteria should now be displayed.
Free filter/SQL: Consult the AnalySIS® manual, pages 173 and 177, if
you want to use these query options.
To restore the full list of images in the database: Query again, and remove
text in all fields, then click search.
5. Sort database: Click
order you want.
in the database window toolbar and select the sort
10
Using the image analysis features
Time to start image analysis. The first parts of this chapter will teach you some of the
used tools to analyse the image, starting from an acquired image. The rest will list
examples of previous/current project pilots, and show how AnalySIS® was used to
solve various tasks.
Note: spend some time getting used to image acquisition before you start this chapter.
Final results depend very much on the image quality of the source image. Images
shown in this tutorial are far from perfect, and this will lead to artefacts during image
preparation and analysis.
Image enhancement tools: Improve signal strength and reduce noise.
Histological material from “Rat somatosensory cerebropontocerebral pathways…” by
Trygve B. Leergaard et al 2000.
A selection of the starting image shows part of pons and peduncle. The dark
cluster to the right is a group of fibres labelled with the antegrad tracer BDA.
1. First step; improve quality:
• First attempt: As the background and the marked fibres have different grey
values (grey gradients in the background vs. black and near black marked
fibres), the simples way to differentiate is to increase brightness and
contrast (Oper menu Æ Intensity Æ Modify grey values…) Use the
brightness and contrast slides to make background as bright as possible,
while losing as little as possible data from the image. Useful values are
between 60-70% for both brightness and contrast. Functions like “Square
root” and “Hyperbola” also works well in this image3. Try some of the
functions while checking the results. Click Change when done. The result
Examples:
Hyperbola function
Logarthim function
will end up in selected destination image buffer.
As you can see, these images have lost some info, but background and
3
More advanced users are advised to read the AnalySIS manual for additional tips.
11
•
marked fibres have now been separated. Consider for yourself whether the
result is acceptable or not for the task you are trying to solve.
Second attempt: trying once again to improve image while losing as little
data as possible. Starting off with a slight adjustment in brightness and
contrast (approx 65% for each) gives this image to work further with:
Some data is lost, and the background can still give some problems. The
next part will therefore be to use filters to enhance the image. The filters
are available under the Oper menu. Some filters have “interactive”
features, i.e. they allow the user to change their variables. These filters also
have a useful preview function4. The preset filters are located in Oper Æ
Filter, the interactive filters are found in OperÆ Define filters. Try some
of the filters to find one that separates the background as much as possible
from the marked fibres. Useful ones are: Edge enhance and DCE5
2. Second step; Thresholds: Now the grey values in the background should differ
enough from the marked fibres to separate fibres and background. Go to
Image menu Æ Set threshold… to set grey values that separate background
and fibres. This opens up a window. Choose the Manual tab, then press Delete
until it turns grey. AnalySIS® window should now look something like this:
A Phase is a range of grey values.
You can create as many ranges as
you want by pressing the new
button. It is however a good idea
to keep the number of phases as
small as possible.
•
The Preview radio buttons allows
you to change what area
AnalySIS colours artificially
Using thresholds: Chose All in Preview subwindow. Then change the high
and low values of the selected phase, either by using the red and blue lines
4
To use this function: press the Window button in the Preview subwindow, then select a part of the
image you are working on
5
Useful values: bandwidth around 20, enhancement around 65, quality on.
12
in the histogram subwindow or by entering values in the high and low
fields. Try to select high and low values so that the phase colour covers the
parts of the image that you are interested in, while covering as little as
possible of the surroundings. Try changing between All and Background in
the Preview field to select ideal threshold values. Click Ok when done.
This will cause the artificial colours to disappear. Set the destination image
buffer to an empty buffer, then binarize the image: Oper menuÆ
Binarize…. This will create an image that only contains two “colours”,
black and white, and this is the ideal image for the software to analyse. It
should look something like this:
Analysing: Vocabulary and tools
1. AnalySIS analyses an image by looking for particles. A particle can be
virtually anything; a red blood cell, a neuron, or whatever else you want the
program to detect in an image. It’s your job to specify what the particle looks
like. Part of your job involves separating the background from the particles by
using the techniques described earlier. Other parts of the separating job will be
described later.
2. The tools:
• Define classification. It is not necessary to use this tool. It will, however,
often improve the final result, as it enables you to differentiate detected
particles according to size/shape etc. The tool is located here: Measure
menuÆ Define classification…
Name of new classification.
Enter a name and press New.
Currently selected
classification
A table where you
enter sizes or other
values to
differentiate the
particles
Click here and
enter classification
unit, e.g. um2 if
you are going to
differentiate
particles after their
area
•
Set range of interest (ROI). Again a tool that isn’t really necessary, but it is
nonetheless useful, as it enables you to divide particles into various groups
depending on their location, e.g. create groups as pontine nuclei,
trigeminus nuclei etc. It can also limit the area where AnalySIS® will
search for particles. The tool is located here: Analysis menu Æ Define
13
ROIs…
Name of current ROI.
To start using a ROI enter
a name here, then choose
a drawing tool. This will
cause this box to
disappear. Draw your
ROI, rightclick when
done. This box will then
reappear. Click close
when done.
The drawing tools. The
upper left tool is the
most useful one.
•
Particle filter, set
minimum size to
remove small artifacts
Pixel connectivity.
Describes how pixels are
connected in order to
consider them a particle.
Consider the following three
pixels:
Adjacent borders option will
describe this as two
particles, one that is 2x1
pixels large, the second 1x1
pixels.
The Include diagonals
option will consider this a
single particle however, as
they are connected
diagonally
Load and save
buttons. It’s a good
idea to save the ROI
when done, as this
allows you to use
the same ROI in
different images and
to use the ROI the
next time you start
analysis.
Finally… Define detection. Analyse menu Æ Define detection… This
dialog box has three tabs:
Detection tab:
Border particles: How are
particles located at the border of
the search area treated?
Truncate: Particles are counted,
but only the part inside the search
area. Area, size and shape are thus
reduced
Include: All particles at the border
are included, their shape and size
left unchanged
Include 50%: particles on the top
and left are counted, bottom and
right are excluded.
Exclude: excludes border particles
Limits the search area,
Frame limits search to the area
inside the red and white frame
ROIs limits search to ROIs etc
14
Classification tab:
Classification
criterion; Area, size,
x/y coordinate etc
How are particles
shown? Filled/outline/
only labelled
Allows you to label
particles over a
minimum pixel size
Click this button to
select particle
measurements. Gives
you the ability to
exclude particles
depending on their
shape, size etc. See
manual for details
Results tab has some options on how results are described.
• This is just a rough outline of AnalySIS® particle detection function. Consult
Example 2 for an example of usage and consult the user manual for detailed
information.
Particle division tools
• Divide particles: Sometimes particles are clustered, and this makes it difficult for
the program to differentiate between particles. To separate clusters there are
several tools;
• Dividing large particles; marked neurons etc: I advise trying the morphological
filters first. The manual gives in-depth information concerning the various filters,
and how they can be defined to enhance their functionality further. This is beyond
the scope of this manual, so I’ll only briefly discuss the filters used so far. The
filters are here: OperÆMorphological filter.
(1) Separate particles: Separates connecting particles in a binary image. This is
the primary particle separation filter. Try this first, and check the results. If
this filter creates too many particles, try using morph. open and morph. close
first. They will smooth the structures and give better results. If the filter
creates too few particles, you can try a grid.
(2) Morph. open: Erosion Æ Dilation; removes noise, smoothes edges, some
particle separation.
(3) Morph. close: Dilation Æ Erosion: Fills holes and separates particles.
• Dividing small clustered particles; entwined fibres etc: The morphological filters
are not ideal tools to separate a tight cluster of small particles, and a different
approach can be used, a grid. To use a grid select Grid from the Measure menu,
and enter a grid size. To break up a cluster of several small particles, use the
smallest possible grid size. AnalySIS® will then add the grid as an overlay, but
this wont be visible for the particle detection tools. To make it visible for these
tools, select burn overlay from the overlay button bar.
15
Using results in Micro3D
• Create outlines: Creating outlines of various anatomical features helps aligning
the results in Micro3D. If you want to create an outline select pixel value from the
Measure menu and set points to mark necessary features. This will result in a
sheet with X and Y coordinates + colour/greyscale information. Currently there is
no easy way to convert this sheet to something Micro3D can read, so save the
table as both Excel (*.xls) and SIS-sheet (*.sfs).
Example 1: Cluster
• A pilot using old histological material from “Rat somatosensory cerebropontocerebral pathways…” by Trygve B. Leergaard et al 2000.
• Fibres in the pontine nuclei were labelled with the antegrad tracer BDA. The first
problem: Differentiate labelled fibres from the background. The second problem:
Divide the resulting particles allowing density and population analysis using
micro3D.
• Having show some of the steps from acquisition to analysed image and the
necessary tools, it’s time to get on with the real job of image analysis:
(1) Acquire an image/image series
(2) If you want to create an outline of various anatomical features to help aligning
later on, it’s a good idea to do it now. It’s also a good idea to save your image,
either as a single file or in a database
(3) Select your Regions of Interest (ROI), and save these.
(4) If you have saved your image, select Delete overlay (found in the
drawing/overlay button bar) to remove the pixel value numbers and crosses. If
you don’t, these may create troubles later on.
(5) Enhance image to strengthen signal, select relevant threshold values, then
binarize the image. Particles should now be white on a black background.
(6) Add a grid to separate particles, then burn the overlay into the image.
(7) Finally: detect particles. Take a look at the result, if necessary use
classification criterions to improve results, and measurement options
(AnalysisÆ Define measurements) to exclude artefacts and add useful
measurements such as coordinates, size, shape etc.
(8) Select Particle results in the Analysis menu to get a result sheet. No
conversion filters here so save this too as in Excel and SIS formats.
• Notes: This pilot had the advantage of previously plotted data, and this was useful
for aligning data and comparing manual and automatic approaches. Some ideas to
improve results:
) to improve
(1) Acquisition: Use the “Manually adjust fixed scaling” option (
contrast. See manual for details of this tool.
(2) Thresholds and ROIs: This pilot tried to acquire data from two ROIs at once,
marked areas of the pontine nuclei and peduncle. As long as the various ROIs
are relatively similar when it comes to data and colour, they can use the same
threshold and be analysed together.
In this pilot I tried to analyse the pontine nuclei and the peduncle at the same
time. This is not ideal as the unmarked area in the pontine nuclei is grey, while
the peduncle background is nearly white. The fibres in the peduncle were
generally thin, while the marked fibres in the pontine nuclei were clustered.
Clusters tend to be black, while fibres often end up dark grey. Attempting to
get data from both areas at once resulted in artefacts in the pontine nuclei, as
16
the background here had the same grey value as single marked fibres in the
peduncle.
17
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement