Guide to using Mentor Graphics for 3BA4

Guide to using Mentor Graphics for 3BA4
Getting Started with IC Design in Mentor
Graphics
Andrew Butterfield
February 18, 2005
Contents
1 Configuring Mentor
2 Running Mentor
2.1 Running IC Station
2.2
2
. . . . . . . . . . . . . . . . . . . . . . . . .
3
3
Running Design Manager . . . . . . . . . . . . . . . . . . . . . .
3
3 Using Mentor
3.1 Notation . . . . . . . . . . . . . . . .
3.2 Getting Help . . . . . . . . . . . . .
3.2.1 Reporting Errors . . . . . . .
3.3 Editing Cells . . . . . . . . . . . . .
3.3.1 Edit Reservations . . . . . . .
3.3.2 Working Layers and Process .
3.3.3 Shape Selection . . . . . . . .
3.3.4 Command Modes . . . . . . .
3.4 How to . . . ? . . . . . . . . . . . . . .
1
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
4
4
5
5
5
6
6
6
6
7
1
Configuring Mentor
Before running Mentor, you should check that the following environment variables are defined as follows:
variable
value
MGC HOME
/mentor/idea
MGC LOCATION MAP
/mentor.idea/etc/mgc/mgc location map
MGLS LICENSE FILE [email protected]
These should have been setup automatically for you. You need to set the following environment variables yourself:
variable
value
MGC TMPDIR /tmp or or anywhere you have write access and space
MGC WD
/users/ug/username/mgc
Here username should be replaced with your own username. Note that you are
being requested to use a subdirectory called mgc of your main UNIX directory
as the place were Mentor stores your work. This is to facilitate automatic
coursework submission later on.
You can do this with setenv commands or similar, in your .login file:
setenv MGC TMPDIR /tmp
setenv MGC WD /users/ug/username/mgc
2
2
Running Mentor
2.1
Running IC Station
The application you will mainly be running is called IC Station.
This is started as follows:
1. Log onto a Sun Workstation, and set a Window Manager running.
2. From the Unix prompt, type xterm & to set a new x-term window running.
You want to do this because Mentor Graphics writes a transcript of user
activity into the window from which it was launched.
3. From the new x-term window, enter ic. If all is well, a new window called
“IC Station”should open, after a short delay.
4. It is recommended that the IC Station window is maximised while working
in it.
Possible errors that can arise include:
ic not found The ic application is not in your $PATH. Your $PATH should include the directory /mentor/idea/bin.
Licensing Problems You may be unable to “connect to license server” or otherwise unable to obtain a license. Contact [email protected] for assistance
in this case.
To exit from IC Station, you can use the Exit option under the MGC Menu.
2.2
Running Design Manager
To run the Design Manager utility, the unix command required is dmgr ic. All
other steps are the same as for running IC Station.
3
3
Using Mentor
When IC Station runs, the window looks like:
IC Station v8.9_8.1 (IC Flow 2002.4)
MGC File Setup Report ....
Process:...
Session
working area
F1
F2
F3
F4
message window ....
The “Session” palette to the right of the working area can be moved and resized
to suit. Most other regions are fixed in pace.
Working sub-windows appear in the working area. These are typically associated
with individual cells that are being edited or viewed.
3.1
Notation
We shall use the following notation as shorthands for parts of the display and
user interface actions:
• M: the top menu-bar.
• W: the working area (and any windows opened in there).
• P: the palette.
• L: left mouse-button.
• L: right mouse-button.
4
We indicate actions as per the following example:
M(L):Help > Open Bookcase > IC Station Bookcase
This means: go to the Menu, then use the Left button to select item Open
Bookcase followed by IC Station Bookcase.
For the palette, we often indicate sub-sections after a period, so P.Cell refers
to the section of the palette entitled “Cell”.
3.2
Getting Help
The Help menu is (usually) the rightmost one. This allows you to access the
manual “bookcase”, and in particular the one dealing with IC Station:
M(L):Help > Open Bookcase > IC Station Bookcase
This will open up Acrobat Reader and load up the relevant documentation.
(You may need to repeat this action to get the document to load)
It is recommended that you select the “IC Station User’s Manual”, and the
following parts of this are the most relevant:
• Chapter 9 : Design Management in IC Station
• Chapter 11 : Cell Related Operations
— in particular the sections on “Saving A Cell” and “Saving A Cell Keeping the Edit Reservation”.
• Chapter 12 : Full Custom Editing Operations
The Mentor documentation can also be accessed directly from
/mentor/idea/shared/pdfdocs/, although it can be tricky to identify documents by their filenames.
3.2.1
Reporting Errors
If you get error messages that you don’t understand, then email to
[email protected]
with subject line starting
3BA4 ic error :
giving details of the problem, and the last few lines of the transcript being
generated by IC Station in the xterm window from which it was launched, at
the point in time when the error occurred.
3.3
Editing Cells
The main activity you will be doing is creating and editing layout “Cells”. The
following is a brief guide to doing this.
5
3.3.1
Edit Reservations
In order to edit a cell, it is not sufficient to simply have it open in a window in
the working area. You must also “reserve” it for editing. Often, after saving, a
cell will cease to be so reserved. In order to (re-)reserve a cell for editing do
M(L):File > Cell > Reserve > Current Context.
3.3.2
Working Layers and Process
When entering shapes, the manufacturing layer (nDiff, Poly, Metal1, etc) associated with that shape is known as the “working layer”. The available working
layers and their appearance is determined by the “Process” information loaded
with the Cell.
The process used for this course is
/users/Public/BAICT/3BA4/CMOS-3BA4
3.3.3
Shape Selection
When a shape is selected, it is usually highlighted in white. You can select
shapes by left-clicking anywhere in the Cell window. If you mouse is not over
a shape, then the nearest shape is selected. If you keep left-clicking, more and
more shapes get selected — adding to what is called the “selection set”.
You can un-select all shapes by pressing F2.
You can also select shapes by left-dragging the mouse around them.
3.3.4
Command Modes
Many editing command require additional information which the request via
(usually small) brown dialogue boxes, which usually appear near the bottom
left of the screen. As it is possible to mix commands up, either deliberately, or
inadvertently, it is useful to know how to escape from these dialogues — this
is achieved by hitting the escape key (Esc) one or more times until all these
dialogues have disappeared.
6
3.4
How to . . . ?
If you get stuck, try typing Escape (Esc) several times, followed by
F2.
All clicks are left-clicks unless otherwise stated.
1. . . . create a new cell called “mycell”:
(a) Do (P.Cell)L:Create
(b) In Cell Name enter mycell
(c) In Process enter /users/Public/BAICT/3BA4/CMOS-3BA4 (exactly as
shown)
(d) Close dialogue box by clicking Ok or hitting the Return key.
For Cell Name and Process is it also possible to click on the button marked
Navigator... and use the resulting dialogue box to select the desired object.
2. . . . select editing palette:
Do (P)L:Expert Edit— the palette changes.
Despite its name, the expert edit palette is the best one to use!
3. . . . select a “working layer”:
(a) Invoke layer change operation: (P.Add)L:LAY
(b) Click on a layer name to select it.
(c) Type Return or click OK.
Note that you can change layer in the middle of some of the operations
described below.
4. . . . add a rectangle/polygon on working layer:
(a) Invoke add shape mode: (P.ADD)L:SH+. Note how this palette
item changes to >SH.
(b) Place pointer at one corner of rectangle/polygon, in the working area.
Click, then move to the next point, and click again. Keep clicking
until you have reached the last point, then double-click.
(c) Continue making shapes (notice that the >SHstill stays). The working layer can be changed in between shapes. Note also that all the
shapes add are added to the current selection set.
(d) To exit from Add Shape mode: type Esc.
5. . . . unselect all shapes: type F2
6. . . . select a shape: click near shape edge — it will highlight when selected.
7. . . . delete a shape:
7
(a) Select it
(b) Do (P.Edit)L:DEL
8. . . . move a shape:
(a) select it
(b) Do (P.Edir)L:MOV+(note change to >MOV)
(c) move to new position
(d) click to drop shape at new location
(e) type Esc to exit from moving mode
(f) type F2 to unselect moved items
9. . . . exit the program: do (M)L:File > Exit Session > Save
If you get stuck, try typing Escape (Esc) several times, followed by
F2.
8
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement