User Manual - Houston Radar

User Manual - Houston Radar

Advanced Stats Analyzer

User Manual

Houston Radar LLC

12818 Century Drive, Stafford, TX 77477

Http://www.Houston-Radar.com

Email: [email protected]

Contact: 1-888-602-3111 Rev 4, March, 2014

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Note: Specifications may change without notice.

Note: Not liable for typographical errors or omissions.

Page 2 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Table of Contents

INTRODUCTION............................................................................................................. 5

CONNECTING TO A LOCAL RADAR TO RETRIEVE DATA ............................... 6

STEP1: Connect to the RadarWindow ........................................................................ 6

STEP2: Select the COM port ...................................................................................... 6

STEP3: Ensure radar is found .................................................................................... 7

DOWNLOADING DATA FROM THE RADAR .......................................................... 8

STEP 1: Create (or Open) a project to import your data into .................................... 8

STEP 2: Name your project or Open Existing Project ............................................... 9

Step 3: Import Data From Your Connected Radar ................................................... 10

ANALYZING DATA AND GENERATING REPORTS ............................................ 13

G

ENERATING

M

ONTHLY

, W

EEKLY AND

D

AILY

C

OUNTS AND

S

PEED

R

EPORTS

............. 13

Option 1: Run report over one complete data set (import) ...................................... 13

Option 2: Run report over a specified period of time including multiple data sets.. 14

INTERPRETING THE ANALYSIS REPORT ........................................................... 15

Intrepreting the Monthly Counts/Speed Avgs tab: .................................................... 15

Interpreting the Weekly Counts/Speed Averages tab ................................................ 16

Intrepreting the Charts:Average Weekly Speeds tab ................................................ 17

Comparing multiple charts ....................................................................................... 18

Printing and exporting tables or charts .................................................................... 18

E

XPORTING

S

UMMARY

R

EPORT

D

ATA

T

O

E

XCEL

.......................................................... 19

GENERATING INTERACTIVE CHARTS ................................................................ 21

Average Speed Interactive Chart .............................................................................. 21

Total Counts (Volume) Interactive Chart ................................................................. 23

Histogram Chart ....................................................................................................... 23

Percentile Vs. Speed Interactive Chart ..................................................................... 24

HOUSTON RADAR ARMADILLO SPECIFIC FUNCTIONALITY ...................... 25

B

IDIRECTIONAL

A

NALYSIS OF

D

ATA

............................................................................. 25

V

IEWING

R

AW

I

NDIVIDUAL

L

OGGED

V

EHICLES

............................................................ 26

A

NALYZING

V

EHICLE

C

LASSES

..................................................................................... 27

P

LOTTING

B

ATTERY

S

TATUS AND

A

MBIENT

T

EMPERATURE

.......................................... 28

DOWNLOADING DATA FROM ARMADILLO WITH GPS OPTION ................. 29

SETTING UP REMOTE TCP/IP RADAR CONNECTIONS ................................... 30

ASSOCIATING A RADAR WITH A PROJECT FOR AUTOMATED DATA

IMPORT .......................................................................................................................... 32

Page 3 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

ACCESSING A COMMON DATABASE FILE FROM MULTIPLE COMPUTERS

BY DIFFERENT USERS ............................................................................................... 34

APPENDIX A .................................................................................................................. 35

I

NSTALLING A

COM

PORT TO A

MS W

INDOWS COMPUTER AND DEBUGGING PROBLEM

WITH

USB

TO

RS232 COM

PORT ADAPTERS

................................................................. 35

Page 4 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Introduction

Many of the Houston Radar traffic sensors offer our Advanced In-Radar traffic statistics collection option. When this feature is enabled, the radar collects vehicular traffic data and saves it to internal memory. A user may then download this data at a later convenient time and generate traffic statistics reports from it.

The Houston Radar Advanced Traffic Stats Analyzer Windows® software is a full featured data retrieval and analysis tool used to connect to the radar, configure it, retrieve collected data, organize this data into user projects and generate comprehensive reports.

Some of the features of this software are:

1. One common data retrieval and analysis tool for Houston Radar Armadillo and other Houston Radar OEM products

2. Access the radar via local Windows COM ports including Bluetooth

3. Access the radar via TCP/IP (Internet) connection

2

1

4. Automatically search for a connected radar on all local ports at all baud rates

5. Create unlimited projects to organize data from multiple sites, signs or traffic studies

6. Unlimited data import into projects and ability to analyze data across multiple data sets

7. Generate interactive charts of speed vs. time, counts vs. time, speed vs. percentile, number of vehicle vs. speed for investigating traffic patterns

8. Generate hourly, weekly and daily reports of counts, average and 85 th

percentile speeds and pace.

9. Compare traffic pattern changes over days, weeks or months by generating comparative charts

10. Export raw data or hourly, daily and weekly summary data to Excel

11. Copy and paste or print all charts and reports

12. Auto connect to multiple radars periodically and automatically import data into pre-assigned projects in batch mode

13. View data location visually on satellite maps and import via drag and drop into different projects

3

1

External Bluetooth module required on radar RS232 port to allow wireless Bluetooth connection except for Houston Radar Armadillo that has built-in Bluetooth modem.

2

External cellular modem with TCP/IP functionality required on radar RS232 port to allow remote Internet connection

3

GPS option required in Armadillo traffic collectors. Not available in OEM radars. Internet connection required to retrieved Google or Bing satellite maps

Page 5 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Connecting To a Local Radar to Retrieve Data

To connect to a Houston Radar Armadillo traffic collector, simply plug it into your PC’s

USB port and turn it on. To connect to any other local radar you must have an RS232

COM port installed on your computer. If your computer does not have a built-in COM port, you may purchase an external USB to RS232 adapter. Such adapters are commonly available in the market at a nominal price or may be purchased from Houston Radar. Our

USB-RS-P1 adapter is also capable of providing power to the radar.

Once you plug an adapter or the Armadillo into your computer’s USB port, Windows will add a COM port to your computer. Please see Appendix A for more details on debugging COM port problems.

STEP1: Connect to the RadarWindow

Click on File->Connect To Radar…

STEP2: Select the COM port

Then click on “Connect To Radar”.

If you selected “Auto Detect Port”, the program will search all ports in parallel (so there is no penalty for selecting “Auto Detect Port”).

Otherwise it will only search on the port you selected.

If the radar is not being detected, it is sometimes advantageous to select the actual port the radar is connected on, as this is the only case where

Windows connection errors are shown to the user.

These errors are helpful to deduce the reason for

Page 6 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

the connection problems (e.g. if the port is already open or inaccessible).

STEP3: Ensure radar is found

Two windows are popped up when the radar is found. The first indicates which COM port the radar is attached to and what baud rate is used. The second indicates some details about the connected radar. At this time, you should click “OK” on both windows to proceed.

Adjust the radar clock if it is off from your computer.

Page 7 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Downloading Data From The Radar

All data that needs to be analyzed must be first downloaded into a project. A project is simply a place to organize different sets of data together.

The user is the best judge of how they want to organize their data.

Some possibilities are:

1. Fixed location sign or data taken at various times from the same location.

If the sign is in a fixed location, or you return to the same location over different periods of time of the month or year, you may create a project for that location.

Then you can import data at different times from the same location into the same project

This will allow you to analyze different sets of data from that location together and even run comparison over time to see how traffic patterns are changing.

2. Speed studies at various locations.

In this case, you may want to create a project per speed study, or by date. There are pros and cons to each approach.

Project Per Speed Study: In this case, you may end up with a lot of projects. There is no inherent limitation to the number of projects allowed, but projects are created and displayed in a single level view and a lot of projects may get difficult to navigate after many studies.

Project per date:

You may create a project date named by “year-month”. This will allow easy navigation if you track your speed studies by date.

The software allows you to label each individual import of data from the radar.

The project name and import label is printed on each report and chart. Thus, even if you collect your data by “Year-Month” format, you can easily have multiple speed studies in the same project even if they are from different sites.

Note: If you have the Armadillo with the GPS option,

please refer to the section

“Downloading Data From

Armadillo With GPS” to take advantage of the GPS

location information.

STEP 1: Create (or Open) a project to import your data into

Page 8 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

STEP 2: Name your project or Open Existing Project

Page 9 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Step 3: Import Data From Your Connected Radar

Ensure the project you wish to import is selected. Data will be imported into this project.

If this is an existing project, previously imported data will be shown here and the new data will be imported separately and a summary shown as another line in the table as shown below.

Select Data then Import Stats Data From Radar… as shown below:

Page 10 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

If you connected to the radar in the section “Connecting to a local radar to retrieve data” or “Connecting to a remote radar to retrieve data”, you will now be prompted to save a

“.dat” file. We suggest that you accept the default path and file name and simply click on

“Save” button.

All imported data is saved in the .dat file on your computer in addition to being imported into the project database. This file may then be emailed to a colleague and/or imported into a project. We suggest that you simply accept the suggested filename and click

“Save”.

The .dat file will be placed in a folder with the same name as the project in the “My

Documents\My Radar Stats” directory. This allows you to find .dat files later.

Once you click Save, the program will download the data from the radar. You will see the download progress in the following box.

Page 11 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Once all data has been read from the radar and stored into the .dat file, you will be presented with “Import Comment” box. This is the opportunity to label this data import.

The label will show up in the project data window and will be printed on all reports and graphs.

If you are organizing the data into projects created by year-month, we suggest that you label your import by location name and traffic direction (e.g main and dartmouth-NB).

If you are organizing your projects by location name, we suggest you simply use the traffic direction as the import label (e.g. incoming or north bound or NB etc.).

You may also insert a comment to be attached to this import.

Both the label and comment are easily editable later via the project data window.

Click on OK button when you are done with your label and comment. At this point you will see a progress bar as the data is being imported into the SQL server.

Once the import is complete, a new entry summary will be shown in the project window as shown below.

You have now successfully imported data from the radar into the database project.

Page 12 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Analyzing Data and Generating Reports

The Houston Radar Advanced Traffic Stats Analyzer program is a powerful tool to analyze the traffic data and generate reports.

Generating Monthly, Weekly and Daily Counts and Speed Reports

STEP 1: Open the project and select the data set you want to analyze

Refer to the section Step 3: Import Data From Your Connected Radar to create and

import data into a project. Once your project is open you have two choices to select your data set.

Option 1: Run report over one complete data set (import)

You would choose this option if this is the only data set you have from this one study or the time period of your interest lies completely within this data set and the dataset is from the same location.

The start/end times of records in a dataset are listed in the summary window as shown below.

You should not proceed with this option if this data set contains data from different locations or for some reason you do not wish to run a combined report over all this data.

If your dataset contains data from more than one location, and you know the start/end date for your data from your different locations, you should import the same file multiple times and trim the data for each import to correspond to the different traffic studies.

Once you have selected the data set to analyze, simply ensure the Generate Analysis

Report checkbox is selected and then click on the Analyze button.

Page 13 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Option 2: Run report over a specified period of time including multiple data sets

The software allows you to specify start/end period to run the analysis. Using this option automatically includes all data in all import sets in this project that are within the specified timeframe.

You may not want to use this option if you have data from different locations in this project.

This is a great way to run a complete analysis that gets filled out as more and more data is available. In this case import all available data (as and when available) into the same project and run a user defined date range study across the entire time frame as shown below:

Ensure the User Defined Date Analysis tab is selected before you proceed.

After you have selected the filter you want (default or created your own), click the

“Analyze User Range” button and the reports window will pop up. We will next discuss the report and the type of analysis it performs.

Page 14 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Interpreting the Analysis Report

Once you click the Analyze or Analyze User Range button, the program selects the data you need analyzed, runs an analysis and returns the results in the following window.

Intrepreting the Monthly Counts/Speed Avgs tab:

As you can see, the report title bar contains the project name and location and this information is also repeated within the report window as well.

All analysis is done on an hourly basis and reported by the day of the week.

For example, if you select the Monthly Counts/Speed Avgs tab, you are presented with an option to view the average hourly speeds by hour of day for each day of week.

If you selected 85 th

percentile speeds for the month of June on this tab, the value in the 1 cell (hour = 0-1, Day = Monday) is the average of the 85 th

percentile speeds from the st midnight hour to 1am on all Mondays in June (where there is data). And so on and so forth for all the cells.

Page 15 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

The Week Day 85

th

% Avg Speed (last) column contains the average of that row excluding the weekends. So the 1 st

cell in the last column is the average 85 th

percentile speed during the weekday in June for the midnight to 1am time slot.

Similarly, the average speed and counts selector on this tab shows the average of the average speeds and average counts for the specified hour for the specified day of the week in June.

If data for more than 1 month is available, you can select it on the top right.

Interpreting the Weekly Counts/Speed Averages tab

Click on the Weekly Counts/Speed Averages tab to show the data by actual week.

When viewing counts, the cells in this tab contain actual count data for the selected week by hour of the day.

When viewing average or 85 th

percentile speeds, the cells contain the average or 85 th percentile speed data for the selected week by hour of day.

If the analysis has more than one week of data available, you may select it on the top right as shown below.

Page 16 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Intrepreting the Charts:Average Weekly Speeds tab

Click the Charts:Average Weekly Speeds tab to show a hourly graph of the average

weekday speeds by hour for the week selected as shown below.

When you select a week on any of the weekly tabs, the selection is maintained when you click over to another tab. This way, you can simply select a week (say) on the Weekly

Counts/Speed Averages tab and then click over to the Charts:Average Weekly Speeds or

Charts:Average Weekly Volumes tab to examine the data in different views for the same week.

Page 17 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Comparing multiple charts

The charts also allow you to compare data from multiple weeks to see if traffic patterns are changing over time. Click the “Enable Comparison” checkbox and select more or more weeks to compare to. To select more than one week, hold down the CTRL key while clicking to make your selection. th

percentile speeds by checking the “Plot 85 th

You may also plot the 85 Percentile

Speeds” checkbox found next to the week selector box as shown by the red circle in the image above.

Printing and exporting tables or charts

All tables or charts may be printed or copied to the “Windows Clipboard” for pasting into another document.

Select the tab page you wish to print or copy. To print it, click File->Print… and to copy click Edit->Copy Graph/Spreadsheet to Clipboard…

Once you copy a graph or a spreadsheet to the Windows clipboard, you may then open another application (e.g. Word) and paste it into a document.

Graphs are pasted as images whereas tables (spreadsheets) are pasted as text data in a

Word document and numbers in Excel.

Page 18 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Exporting Summary Report Data To Excel

The software also allows you to export 15, 30 or 60 minute and daily summary data to

Excel. For this to work, you must have MS Excel already installed on your computer.

Check the Export Summary Data To Excel checkbox, select the data you want to analyze either in the individual import tab or the User Defined Data Analysis tab and then click on Analyze button. You will get the Excel summary report as shown below.

Page 19 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

You may specify a summary time interval of 15, 30 or 60 minutes and pace speed interval to be used during the summary export.

Additionally, for data collected with the Houston Radar Armadillo Tracker, you may specify the software to regroup speeds in speed bin ranges and a minimum and maximum speed bin you wish to see in the report.

To change these settings please go to the File->Settings menu item. You will be presented the following window where you may make your selections. These settings are applicable to all projects and may be changed at any time and another analysis run with the new settings.

Page 20 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Generating Interactive Charts

The stats analyzer software has a powerful feature where the user may generate interactive charts of raw data and navigate through the entire dataset easily and quickly.

This feature provides a bird’s eye graphical view of the entire data set.

You may generate interactive graphs via the individual checkboxes circled below.

Average Speed Interactive Chart

The average speed interactive chart plots all the vehicle speeds vs. time. Depending on the amount of data being plotted in the selected dataset, the data is automatically aggregated in optimal time bins.

Page 21 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

For example, in the chart shown above, the entire data contains over four months of data for 58012 vehicles. This is so much data, that the software has automatically reaggregated it in 4 hour intervals. Aggregation level is shown on the left side via selected

“4 Hr” radio box as well as printed on the y axis.

The above selection means that the count values (shown as gold circles) and the average speeds (shown as blue circles) are count totals and average speeds over 4 hours.

Also from the bird’s eye view it becomes apparent that there is a large gap in the data from around the 16 th

of October through the 7 th

of November.

There are a few ways to navigate around this data. To examine a smaller time period, click the left mount button at the start date you want to examine and then click the left mouse button again at the end date. The graph will automatically zoom to this range.

Once you zoom in, you can easily click another aggregation period on the left pane and the data will redraw with higher resolution (e.g. 30 minute or 15 minute as you choose).

If you want the software to automatically pick the best resolution automatically, select

“Auto Zoom” on the left pane. Now the software will automatically determine the optimal aggregation period based on how much data can be displayed on the screen without too much clutter.

As you zoom around in the data, the total number of vehicles in the view is automatically recalculated and displayed on the top in the legend area. This is a great way to get vehicle totals across different or non-standard time periods.

You can also use the arrow keys and mouse wheel to zoom in/out and scroll the chart left or right. Click on the “Zoom Help” button in the chart area to get a help screen on the keys supported. This window is reproduced below.

Page 22 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Total Counts (Volume) Interactive Chart

Check the Generate Vehicle Volume Chart checkbox to get an interactive chart of vehicle counts (volumes) vs. time. An example is shown below:

Selecting the 60 minute aggregation option is a great way to get a bird’s eye view of the hourly volume of traffic throughout the dataset.

Just as with the average speed chart, this chart is completely interactive and you can navigate around in it by mouse clicks, mouse scroll wheel and arrow keys. Click on the

“Zoom Help” button in the chart area for instant help.

Histogram Chart

Click on the Generate Volume by Speed Histogram Chart to generate the following chart.

This chart plots the number of vehicles in the data set vs. the speed bin they were recorded in.

Page 23 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Percentile Vs. Speed Interactive Chart

Determining the 85 th

percentile speed of traffic on the road is an important requirement for a speed study. As is well known , studies have shown that the 85 th

percentile speed is an appropriate starting point to determine the optimal speed limit.

The software allows you to automatically calculate the 85 th

percentile speed on the road.

Additionally, it also calculates the speed associated with all percentiles of vehicles from 0 to 100. This information is plotted as a well known “S” chart.

Check the Generate Percentile Vs. Speed Chart checkbox and click the Analyze button to generate the following chart.

This chart plots the total percentile counts of vehicles on the road traveling at every speed up to the maximum speed in the dataset.

The 85 th

percentile speed is also automatically marked by the red crosshairs.

For example, in this data set, the 85 th

percentile speed is 28mph.

You may also click anywhere on the chart and obtain the percentile value and speed at that point.

Page 24 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Houston Radar Armadillo Specific Functionality

The Houston Radar Armadillo Tracker traffic collector has certain additional features not found in our OEM based Advanced In-Radar traffic statistics. These are:

1. Simultaneous bi-directional data logging

2. Individual vehicle logging with 1 mph (or 1 Km/h) speed resolution

3. Vehicle Classification into 3 vehicle size bins

4. Hourly logging of: a. Battery charge status (mAh of battery capacity remaining) b. Battery voltage c. Ambient Temperature

5. GPS option to automatically tag data location and allow splitting of data into location chunks during importing into the Stats Analyzer.

The Houston Radar Stats Analyzer supports these features as described below:

Bidirectional Analysis of Data

The Houston Radar Armadillo can log bidirectional traffic. When you import data that has bi-directional information present, you will be presented with an import dialog that allows you to input location (or direction) name and comment for the outgoing direction as shown.

The data is imported separately for both directions. You can select the analysis for the appropriate direction by first selecting the desired direction tab as shown below and then clicking on the

“Analyze” button. Alternatively select the

“Bidirectional Data Analysis” tab to run both analysis in one go. Separate windows will be generated for each direction.

Page 25 of 35

The traffic direction is always listed at the bottom as shown.

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Viewing Raw Individual Logged Vehicles

You may view and filter raw individually logged bidirectional data. Select the

“Bidirectional Data Analysis” tab and then click on the “View Radar Data” button. You will be presented with the raw data window. You may also select to filter this data by date range and speed threshold. After making your selection, click the “Apply” button and the data window will update after applying your filter settings.

Page 26 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Analyzing Vehicle Classes

Click on the Analyze button. In Addition to the analysis result, a “Filter Data” window pops up. You may click the “Generate Excel Tally Report” button to get a detailed Excel output of raw data including vehicle sizes and where you may filter the results by speed limit and vehicle class.

Excel report allowing filtering by vehicle class size and violator speed. Complete raw data is also available in the Raw

Data tab. User provided Excel installation is required and not provided with the Stats Analyzer.

Page 27 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Plotting Battery Status and Ambient Temperature

The Armadillo logs the remaining battery capacity, battery voltage and ambient temperature hourly. If these records are detected during data import, they are placed in a tab called “Advanced Info”. You can then plot all three in the Stats Analyzer to get graphical view of these values. This can be of a great benefit to validate a solar powered installation (you would ensure that the solar panel can keep the battery capacity above 0

“Amp Hours Remaining” over time). Alternatively, you may want to simply view the ambient temperature changes during the time the data was being collected.

To select data over multiple imports, select multiple entries by pressing the CTRL key and then click the desired rows. Then click the “Plot Vin And Ambient Temperature” button to plot them all together in one graph. An example plot is shown below.

Page 28 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Downloading Data from Armadillo With GPS Option

Step1: Connect to the radar. Please refer to the section Connecting To a Local Radar to

Retrieve Data .

Step 2: Click on Data->Data Import Wizard… as shown.

Step 3: Select Radar or File to import data (typically Radar if you need to import data from the radar you just connected to). Simply accept the suggested file name and the data will be first read into a .dat file on your computer. This file may also be emailed to a colleague who can then import from a file into his program.

Step 4: You will see all the different locations your data was collected in. Clicking on the rows will place a pin on the map. You may zoom in or out by using the scroll bar on the right.

To import into an existing project, simply select the data chunk and drag it to one of the existing projects on the left. You may create a new project by right clicking on the left pane.

To finish the export, you must click the “Import” button at the bottom.

Page 29 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Setting Up Remote TCP/IP Radar Connections

The advanced stats analyzer software can communicate directly over TCP/IP (Internet and Intranets) to a radar at a remote location connected to a cellular modem or a TCP/IP to serial server. A cellular connection option will be available in the Armadillo in the future. Please contact us if you have this requirement.

An example of an Ethernet TCP/IP to Serial port server that will allow remote connection to a radar over an Ethernet network is the Lantronix xDirect .

An example of a GPRS modem that will allow remote cellular access to the radar is

Teltonika G10 .

Both these methods provide an IP address or host name of the modem with TCP/IP port number and allow you to forward connections from this TCP/IP port to the local serial port of the radar.

To communicate with a radar in such a setup, you first need to setup a Remote Radar

Connection. Once the connection is configured, connecting to the radar and downloading data works exactly the same way as with a local serial port.

To setup the remote radar connection, click on File and then Setup Remote Radar

Connections…

This will bring up the window shown below.

Note that the IP address or the host name should be reachable from the computer. In most cases you need an external world routable IP address with the address preferably being static in nature. If you get a dynamic IP address, your modem should support dyndns so

Page 30 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual that you may address the remote modem by name. In this case dyndns will do the mapping between host name and current dynamic IP address of the modem.

Once you have setup the remote radar connection, click OK. Then go to File->Connect

To Radar… to bring up the radar connection screen, just like with the local radar connection.

Now your remote radar connections is listed along with your local COM ports.

Select the desired connection and click on Connect button.

The “Auto Detect Port” option only searches for the radar on the local serial ports. That includes Bluetooth and USB to serial adapters. The program does not search on remote

TCP/IP radar connections. You must manually select the radar you wish to connect to if it is on a remote TCP/IP link.

Page 31 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Associating a Radar with a Project for Automated

Data Import

You may associate a radar with a project and import data, synchronize radar clock and erase radar data automatically after successful import by just one click of the mouse.

This is very convenient option when importing from remote radars, especially when multiple remote radars exist, where there is a chance that a user may select wrong remote radar accidently, thus importing data from wrong remote radar.

To use this feature, associate the correct remote radar connection at time of initial setup.

For subsequent imports, the user simply goes to the project and imports the data from the pre-associated remote radar.

Setup the remote radar connection first, then create a project (or open an existing project), and then click on the Associated Radar tab as highlighted below.

Then enable this functionality by marking the Associate a radar with this project checkbox. Select a radar connection from the dropbox and if this radar is currently online, you can test communication via the Test Connection button.

Select the additional functionality you require from the After Successful Import… group of checkboxes. Be sure to click on the Save Settings button once you are done.

Whenever you are ready to import the data, click on the Connect And Read Stats Now button and the data will be imported into the project.

Page 32 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

You may choose to have the program double check the unique radar id before it starts to import the data. This will ensure during future imports that you are not accidently importing data from a different radar.

To enable this feature click on the Link This Radar button after you have tested the

connection to the radar. This will link the unique id of the radar to this project.

To automatically import the data from the associated radar on a periodic basis, you may

check the Auto Import Every (hrs) checkbox. The program will automatically connect

and import the data at the specified intervals. The project window must remain open for this feature to work. Multiple project windows may be open simultaneously which will allow you to import data from multiple radars.

Page 33 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

Accessing a Common Database File from Multiple

Computers by Different Users

The Houston Radar Stats Analyzer program keeps all imported data and settings in a database file on the computer. By default this database file is kept on the same computer running the stats analyzer program.

For multi-user situations requiring multiple users to access the same data or to put data in a common location, it is possible to install a common database file on a “shared drive” and then access it simultaneously from multiple computers running the Stats Analyzer program.

You may do this as follows:

1. Install the Houston Radar Stats Analyzer program version 8.01.0009 or later on all computers requiring access to the data. It is advisable to install the same version on all computers and keep the versions up to date. You may request the latest version from us if you have an older version. Upgrades are offered for no extra charge.

2. From one computer (preferably the computer with the most data on it), relocate its database file from the local drive to the designated “shared drive” on the network as follows: a. Click on “File->Database Location…” menu b. Click on “Select New Database Location” button. c. Pick a designated folder on the “shared drive” on the network. d. Select “Yes” if the program asks you if you want to move or copy your database to this new location.

3. For all other computers/users wanting access to the above common database file follow the above steps except choose “No” when asked if you want to overwite the existing database file.

Now all computers will access a common database file and all users may access projects/data created by other users.

Note: If one user has a project or data window open and a change is made to the data behind the scenes by another user, the user with the open project will not be notified.

You may also chose to locate the program’s “Data Directory” for all users on a common folder on the “shared drive”. You can do that by going to File->Settings menu and picking a common folder by clicking on the “Change…” button in the “Default Data

Save/File Export Directory” section.

It is highly advisable that periodic backup’s be made of the database file on the “shared drive”. The program does not make automatic backups. This will minimize the disruption

in the case of data corruption or user error.

Page 34 of 35

Houston Radar Advanced Traffic Statistics Analyzer User Manual

APPENDIX A

Installing a COM port to a MS Windows computer and debugging problem with USB to RS232 COM port adapters

If your computer does not include a built-in RS232 COM port you may easily add a

COM port by using an external USB to RS232 COM port adapter.

The Houston Radar Armadillo traffic collector has a USB Interface built-in which shows up as a COM port on the PC when you plug it in. Thus you may use this section to debug connection issues for the Armadillo as well.

Plug in the USB end of the dongle (or Armadillo) into the USB port of the computer.

Windows should automatically recognize the adapter and either install a driver for it or prompt you for a driver disk. If Windows prompts you for a driver disk, insert the driver disk that came with your adapter and follow the instructions provided. The Armadillo

USB drivers are provided on the supplied CD ROM. Windows will also automatically find these drivers on-line if your computer is connected to the Internet.

To ensure that the COM port was successfully installed, you can check in the “Device

Manager” by using the following procedure:

Click on “Start” button and then “Run” and type in devmgmt.msc

You should see the following window pop up. Check that you have a USB Serial Port

Entry under “Ports (COM & LPT)”. You are now ready to connect to the radar.

Page 35 of 35

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project