Chapter 6 - AutomationDirect

Chapter 6 - AutomationDirect
DOCUMENTATION
CHAPTER
6
In This Chapter
Turn Documentation On and Off . . . . . . . . . . . . . . . . . .6-2
Using the Documentation Editor . . . . . . . . . . . . . . . . . .6-4
Documenting and Assigning Nicknames . . . . . . . . . . . .6-6
Entering Rung Comments . . . . . . . . . . . . . . . . . . . . . . .6-9
Entering Stage Comments . . . . . . . . . . . . . . . . . . . . .6-12
Importing and Exporting . . . . . . . . . . . . . . . . . . . . . . .6-14
Prevent Documentation Loss . . . . . . . . . . . . . . . . . . .6-28
Chapter 6: Documentation
Turn Documentation On and Off
1
2
3
D
5
6
7
8
9
1
11
2
13
4
A
B
C
D
6-2
Documentation is the text associated with the components and
structure of a DirectSOFT 6 program which is added for greater
clarity. It may refer to the elements, wiring, rungs or stages. All
documentation options are turned ON by default when the Options
dialog is first opened.
The Options Dialog
DirectSOFT 6 allows the programmer to turn ON/OFF the
documentation in each available view. A quick way to open the
Options dialog is to place the mouse cursor in the displayed view
and right click the mouse. A pop-up window will appear with Options
as one of the selections. Select Options and the dialog will appear
like the one shown below. When the dialog opens, the Ladder tab is
in view by default. The other views can be selected by clicking on
the tab at the top of the dialog.
The Ladder tab is showing all of the documentation types checked.
Leaving each selection checked turns ON that documentation type
to be shown in the program. Unchecking the documentation type
will turn it OFF in the program. Most of the Options dialog features
have been discussed in Chapter 4. For turning the documentation
ON/OFF, only the Ladder, Stage, XRef and Data View (under Doc
tab) options need to be accessed.
DirectSOFT 6 User Manual, 1st Edition
Documentation Selections
Chapter 6: Documentation
Most documentation refers to individual elements, therefore, it is
specific in nature. Listed below are four types of documentation
• Elements Ҁ the references for the individual elements, ie. X1, Y10,
etc.
• Nicknames Ҁ these are alpha-numeric names that are used for the
various types of program elements. It is usually easier to remember the
name Start Switch than it is to remember that X1 is the input for the
switch.
• Descriptions Ҁ detailed description of an element. This can also be
used to add brief trouble-shooting steps, etc.
• Wiring Ҁ this can be used to identify panel wiring for the project.
Description
Wiring Info
Nickname
Element
General Documentation
Comments are general descriptions that are best suited for
descriptions of a program rung, or a section of the program.
• Rung Comments Ҁ rung comments are assigned to an individual rung.
• Stage Comments Ҁ if you are using the Stage instructions, you can
also add comments that describe the contents of any stage.
Stage
Comments are
in this area
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
Rung
Comments
DirectSOFT 6 User Manual, 1st Edition
6-3
Chapter 6: Documentation
Using the Documentation Editor
Nicknames, wiring information and descriptions for program
elements are entered using the Documentation Editor. The editor
can be accessed using Tools > Documentation Editor on the
Menu bar, Ctrl + D or by pressing the Documentation button on the
Tools toolbar.
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
Using the Scroll Buttons
6-4
There are scroll command buttons (arrowheads) located at the top
of the editor. They are shown (both directions) as , , R, 앚앚,
etc. Each button has a different function:
Ҁ Moves one element forward.
Ҁ Moves one page forward.
R Ҁ Moves to the beginning of the next data type (X, Y, C, etc.)
앚앚Ҁ Moves to the last documentable type.
Ҁ Moves one element back.
Ҁ Moves one page back.
R Ҁ Move to the beginning of the previous data type.
앚 Ҁ Moves to the beginning of the first documentable point.
DirectSOFT 6 User Manual, 1st Edition
Chapter 6: Documentation
Copying Documentation Between Elements
If it becomes necessary to use the Documentation editor, all of the
familiar Windows keyboard shortcuts (copy, cut, paste, etc.) can be
used within the editor. For example, if there is a lengthy description
for a point, and other points are similar, the information can be
copied. The following example will demonstrate how this is
accomplished.
1. Position the cursor in the cell to be copied.
2. Double click to highlight the information.
3. Press Ctrl + C to copy the information in the cell.
4. Move the cursor to the element cell where the information is to be
copied to. (Use the Find button, Ctrl + F shortcut or scroll).
5. With the cursor in position to paste the information, press Ctrl + V.
NOTE: When copying a nickname, the new nickname will have a “?”
before and after the newly pasted entry. This occurs because each
nickname must be unique.
DirectSOFT 6 User Manual, 1st Edition
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
6-5
Chapter 6: Documentation
Documenting and Assigning Nicknames
Create an Unassigned Nickname
Element nicknames are used more often than any other type of
documentation. As a program is developed using nicknames,
element references do not have to be entered when a contact, coil,
etc. is entered. Wiring information and descriptions can also be
entered without knowing the actual element reference.
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
Unassigned nickname
is entered (red
indicator remains on).
Click OK
The nickname is
accepted without
being linked to an
element.
Dialog appears when
a nickname is entered
without being linked
to an element.
Assign the Nickname to an Element
If unassigned nicknames have been used in the program, element
references must be assigned before the program can be written to
the PLC (the PLC does not recognize nicknames, only element
references). The Assign Nicknames dialog is used to assign
nicknames to element references. A quick way to open the dialog is
to either press F9 (hotkey) or the Assign Nicknames button (if the
Tools toolbar is displayed). Another way is to use Tools > Assign
Nicknames from the Menu bar. Also, if the Element Browser is
open, nickname information can be assigned by clicking on the
Assign Nicknames button in the Element Browser and the Assign
Nicknames dialog will appear as shown on the facing page.
Tip: Nicknames can be compiled and saved to disk--and then assigned
later, just before downloading to the PLC.
6-6
DirectSOFT 6 User Manual, 1st Edition
Chapter 6: Documentation
Open the Element Browser
1
Click here to open the Assign Nicknames dialog.
The Assign Nickname dialog will appear with the list of
unassigned nicknames appearing in the Source Nickname
column. Select the nickname in the list and enter the element
reference for the nickname in the Source Element Column.
The reference will be duplicated in the Result column to help avoid
accidental entries. Press Assign and and the following dialog will
appear as a confirmation of the element entry.
DirectSOFT 6 User Manual, 1st Edition
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
6-7
Chapter 6: Documentation
2
3
If the reference entered is correct, click OK. The Element Browser
will be in view again so that wiring information and a description, if
any, can be added. Pressing Exit will close the browser and the
program will have the new element in the program as shown below.
5
6
7
8
9
1
11
2
13
4
A
B
C
D
6-8
DirectSOFT 6 User Manual, 1st Edition
Entering Rung Comments
Chapter 6: Documentation
Each rung in a DirectSOFT 6 program can have associated
comments. Unlike some programming packages from other
vendors, the comments are not tied to the outputs. Instead, the
comments remain with the rung where the comments are added
regardless if other rungs are deleted before a commented rung. To
edit a comment, the cursor must be on the rung to where it is to be
added. Now, either press the keyboard shortcut Ctrl + K, Tools >
Comment Editor on the Menu bar or press the Comments button
on the Tools toolbar if it is displayed. The Edit Comments dialog,
shown below, will appear.
Rung
Comment
Comments are Free-form
The appropriate comment can be added as necessary. The Ladder
view is a full screen editor, therefore, backspacing the entire
comment is not necessary to fix a spelling error. Instead, position
the cursor over the word to be edited and double-click the left
mouse button to highlight the word, then type in the corrected
word.
Selecting Rungs for Comments
Once you have edited a rung comment you can use the Page Up
and the Page Down keyboard buttons to scroll to another rung
comment to edit. A specific rung can be found by using the Goto
button on the editor dialog.
DirectSOFT 6 User Manual, 1st Edition
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
6-9
Chapter 6: Documentation
Using the Scroll Buttons
There are scroll command button (arrowheads) located at the
bottom of the dialog. They are shown for both directions as , ,
앚앚, etc. Each button performs a different function:
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
Ҁ Moves to the next rung comment.
Ҁ Moves ahead five rung comments.
앚앚Ҁ Moves to the comment for the last rung.
Ҁ Moves to the previous rung comment.
Ҁ Moves back five rung comments.
앚 Ҁ Moves to the comment for the first rung.
Click on the OK button after entering the rung comments.
Use the Editing Keys
6-10
The keyboard shortcut keys can be used to copy, cut and paste
comments between rungs.
1. Position the cursor at the beginning of the text to be copied or cut.
2. Press and hold the left mouse button and move the cursor to highlight
the text, then release the button. The Shift + Arrow keys can also be
used to highlight the text.
3. Use the Ctrl + C keys to copy the text or the Ctrl + X keys to cut the
text.
4. Locate the rung where the information is to be pasted (Use Previous,
Next or Goto).
5. Position the cursor where the text is to be pasted and click the left
mouse button, then press Ctrl +V to paste the text.
6. The Delete key can also be used to delete text.
DirectSOFT 6 User Manual, 1st Edition
Move Rung Comments
Chapter 6: Documentation
Rung comments can easily be moved from one rung to another
with DirectSOFT 6. This feature is useful after one or more rungs
have been inserted by a handheld programmer or by another
computer which did not have the documentation files available. The
Move comment feature can be used to match the comment(s) with
the correct rung(s). Comments can be moved for a single rung or a
group of rungs. To move comments, click on the Move button on
the dialog. The window will appear within the dialog.
Fill in the appropriate fields to specify the source and destination
for moving a comment.
• Source Ҁ This is the beginning of the group of comments to be moved.
Enter the rung number (or address) of the rung with the comments to
move.
• Destination Ҁ Enter the rung number (or address) of the rung to move
the comments to.
• Number to Move Ҁ Chose All or enter the number of comments to
move from the source to the destination.
• Units Ҁ Select either Rung Number or Address.
Press OK to complete the move or Cancel to exit without
performing the operation.
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
NOTE: You can overwrite existing rung comments with this feature.
DirectSOFT 6 always provides a confirmation prompt before it completes
the move. The message reminds you that any overlapping comments will
be changed. This message will appear even if there are no overlapping
rungs. It is a reminder that existing rungs can be overwritten.
DirectSOFT 6 User Manual, 1st Edition
6-11
Chapter 6: Documentation
Entering Stage Comments
Use Stage View
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
6-12
If you are using Stage instructions, comments can be entered for
each stage. The Stage View must be displayed in order to enter the
comments. With a Ladder View open, the Stage View is opened by
clicking on View > Stage View on the Menu bar.
Stage
Comment Area
In order to enter Stage comments, the cursor must be positioned in
either of the upper quadrants of the Stage view. To open the
comment editor, either click on the keyboard shortcut Ctrl + K,
Tools > Comment Editor on the Menu bar or press the Comments
button on the Tools toolbar if it is displayed. The Comment editor
can also be opened by double-clicking the left mouse button with the
cursor positioned in the stage comment area. Note that the
comment editor is for Stage comments.
Stage
Comments
DirectSOFT 6 User Manual, 1st Edition
Comments are Free-form
Chapter 6: Documentation
A new comment can be edited immediately. The appropriate
comment can be added as necessary.
Selecting Stages to Comment
1
2
Once you have edited a rung comment you can use the Page Up
and the Page Down keyboard buttons to scroll through the Stages. 3
A specific Stage can be found by using the Goto button on the
editor dialog. After the comments have been entered, press the OK D
button to save the comments and close the editor.
5
Editing the Comments
6
The keyboard shortcut keys can be used to copy, cut and paste
comments between stages.
7
1. Position the cursor at the beginning of the text to be copied or cut.
2. Press and hold the left mouse button and move the cursor to highlight
8
the text, then release the button. The Shift + Arrow keys can also be
used to highlight the text.
9
3. Use the Ctrl + C keys to copy the text or the Ctrl + X keys to cut the
text.
0
4. Locate the stage where the information is to be pasted (Use Previous,
Next or Goto).
1
5. Position the cursor where the text is to be pasted and click the left
mouse button, then press Ctrl +V to paste the text.
2
6. The Delete key can also be used to delete text.
3
NOTE: All documentation edits are written to the documentation files
when they are entered/edited.
4
A
B
C
D
DirectSOFT 6 User Manual, 1st Edition
6-13
Chapter 6: Documentation
Importing and Exporting
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
DirectSOFT 6 can import and export ladder programs, element
documentation (nicknames, wiring info and descriptions) and rung
comments from a project. The Import/Export data is expected to be
in CSV format (comma-separated variables) which is a popular
import/export text format for applications like Microsoft Excel and
AutoCAD. For example, Microsoft Excel can be used to generate an
element documentation file to be imported directly into a
DirectSOFT 6 project. The existing element documentation can be
exported to a CSV file that can be used in diagrams in an AutoCAD
program.
Exporting Program Documentation
6-14
The project must be open in order to export program documentation.
Three export options are available to choose from, Program,
Element Documentation and Rung Comments. The following steps
will show how to export a program. There are two ways to export a
program, either select File > Export > Program from the Menu bar
or select the Export button on the File toolbar if it is displayed.
Either method used will open the Export Program dialog shown on
the facing page.
File Toolbar
File Export
Options
DirectSOFT 6 User Manual, 1st Edition
Chapter 6: Documentation
In the Export Program dialog, select where the program is to be
exported to, enter the program name and click the Save button.
The following dialog will appear so options can be selected and
saved.
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
Click the OK button to save the program to a text file.
DirectSOFT 6 User Manual, 1st Edition
6-15
Chapter 6: Documentation
The text file can be opened with Notepad or equivalent word
processor. The Notepad example below shows what can be
exported. Note the Rung Comments and the Element
Documentation.
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
Export Element Documentation
Element information can be exported from a project to a .csv file.
The following illustrations will show the steps to use to export the
documentation. Press the Export Element Documentation button on
the File toolbar or select File > Export > Element Documentation
to export the documentation.
There are three different formats to select from to export. Standard,
C-more and KEPDirect Server formats. All formats generate a .csv
file in spreadsheet form.
6-16
DirectSOFT 6 User Manual, 1st Edition
Chapter 6: Documentation
This is a standard format showing an Excel spreadsheet with the
element reference in column A, the nickname in column B, wiring
information in column C and description in column D.
The illustration below is the C-more format showing an Excel
spreadsheet with the tagname (element) in column C, the data
type in column D and element reference (Address) in column G.
NOTE: If unassigned nicknames are exported, they will appear in the
resultant text as the following types:
UB - unassigned bit
UBY - unassigned byte (useful only for R memory in the DL305)
UW - unassigned word
UDW - unassigned double-word
UU - unassigned unknown (used for uninitialized types, should never be
used)
DirectSOFT 6 User Manual, 1st Edition
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
6-17
Chapter 6: Documentation
Export Rung Comments
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
6-18
The program rung comments can be exported from a project to a
text file and a printout can be obtained using Microsoft Notepad or
equivalent word processor. The following dialog will appear when
either pressing the Export Comments button on the File toolbar if it
is displayed or by pressing File > Export > Rung Comments.
Select where the file is to be saved, then name the text file and
press the Save button.
The illustration below is an example of an exported comment text
file shown with Microsoft Notepad.
DirectSOFT 6 User Manual, 1st Edition
Chapter 6: Documentation
Importing a Program
There may be a time when it is necessary to import a DirectSOFT
6 program which has been previously edited and exported as a
text file. This could be an entire program or just a few rungs with
element nicknames and comments. Use the following illustrated
steps to guide you through the import procedure.
File Toolbar
File Import
Program
1
2
3
D
5
6
7
8
9
0
1
2
3
4
Begin by opening the New
Project dialog from the
A
DirectSOFT 6 Launch window
(page 3-4). Cancel the New
B
Project dialog, then either
select File > Import >
C
Program or press the Import
button on the File toolbar if it is D
displayed.
DirectSOFT 6 User Manual, 1st Edition
6-19
Chapter 6: Documentation
The Import Program dialog will appear so the program text to be
imported can be selected. Select a previously exported DirectSOFT
6 program to import. Choose the program text file and click Open.
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
6-20
The complete imported program will appear as shown below. In this
example, all elements, element descriptions, nicknames and rung
comments appear in the program along with the cross reference.
DirectSOFT 6 User Manual, 1st Edition
Chapter 6: Documentation
Exported programs, element documentation and rung comments
can be imported using the DirectSOFT 6 programming window if it
has been opened to edit another program. This is done by first
saving and closing the current program. Next, either select File >
Import > Program or press the Import button on the File toolbar.
The program to be imported is selected and opened as shown in
the previous example.
DirectSOFT 6 User Manual, 1st Edition
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
6-21
Chapter 6: Documentation
Importing Element Documentation
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
6-22
To import program documentation, a project must be open. This
project can be the one currently open. The typical method for
importing element documentation is to import a .csv file which has
been previously exported. It is possible to generate element
documentation using a spreadsheet such as Microsoft Excel, but it is
important to follow the correct import format. The standard format is
in spreadsheet form which should be setup in columns similar to the
the example below: element reference in column A, the nickname in
column B, wiring information in column C and element descriptions
in column D.
To import element
documentation, select
File > Import >
Element
Documentation or
press the Import Doc
button on the File
toolbar. The window
shown here will
appear.
DirectSOFT 6 User Manual, 1st Edition
Chapter 6: Documentation
Select the folder and the .csv file to be imported. Notice the Import
Method box located on the right side of the window.
There are three import methods to select: Merge (.PRJ priority),
Merge (.CSV priority) and Delete existing. Selecting one of the
three methods will determine the course of action which will be
taken if the currently open project and the imported file have
duplicate nicknames.
If .PRJ priority is selected, the nicknames in the imported file will be
added to the project file. If there are duplicates, the nickname in the
project file will be kept.
If .CSV priority is selected, the nicknames will be added to the project
file. If there are duplicate nicknames, the import file will overwrite the
ones in the project file.
If Delete existing is selected, all of the element documentation of the
open project will be deleted, then it will be rebuilt with the contents of the
.csv file.
Press the Open button to execute the import.
NOTE: If the following element types are imported, they will appear in the
DirectSOFT 6 documentation editor with “
“ under the element type
column:
UB - unassigned bit
UBY - unassigned byte (useful only for R memory in the DL305)
UW - unassigned word
UDW - unassigned double-word
UU - unassigned unknown (used for uninitialized types, should never be
used)
Once the element documentation is imported, the Documentation
editor will be updated with the imported information. This can be
verified by opening the Documentation editor from Tools on the
Menu bar, the Documentation Editor button on the Tools toolbar if it
is displayed or use Ctrl + D. When the elements are created or if
they are already used in the program, the element will be updated
with the new information.
DirectSOFT 6 User Manual, 1st Edition
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
6-23
Chapter 6: Documentation
Importing Program Comments
Exported program comments are imported like the element
documentation as described on the previous two pages. To do this,
select File > Import > Rung Comments on the Menu bar or press
the Import Comments button on the File toolbar. The following
window will appear. Select the folder and the .txt file to be imported.
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
Also select the Import Method to use. Merge (.PRJ priority) if the
current project is to remain in place when the import is executed. If
comment matching occurs, a message will appear asking which one
to update, the imported file or the existing file. Selecting Merge
(.TXT priority) will allow the imported comments to overwrite the
existing ones. Delete Existing will delete the current comments and
update with the imported comments.
Insert Instructions
The Insert Instructions From File feature will allow the insertion of
mnemonic text files as instructions within an open project.
Mnemonic instructions can be inserted one time or several times
within a program. To
Rung Comment
use this feature, there
PLC type
must be an existing
text file, such as, a file
Ladder mnemonics
written with MS
“Wire number”
Notepad. This file must
be written in mnemonic
text form like the
example on left. Note
that rung comments,
“Nickname”
“Element Description”
element descriptions,
“Reference”
6-24
DirectSOFT 6 User Manual, 1st Edition
Chapter 6: Documentation
element nicknames and wiring information can be edited within the
text file to be inserted. The text file needs to be edited in the same
format as shown, with a PLC type at the beginning, #BEGIN, the
documentation and #END. Quotation marks are placed around
each line of rung comments. Of course, the ladder mnemonics are
also edited with the text file. The element documentation must be
in this form: “element reference”, “element nickname”, “wire
number”, “description”. Quotation marks must be used with each
entry followed by a comma. If an entry is to be left blank, the
quotation marks must not be omitted.
The mnemonics text which is to be inserted can also be edited
without comments like the example below. Note the PLC type is at
the beginning of the text.
To insert the mnemonic text in a program being edited (Edit Mode),
either use the Tools > Insert Instructions From File on the Menu
bar or press the Insert Instructions button on the Tools toolbar if it
is displayed.
DirectSOFT 6 User Manual, 1st Edition
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
6-25
Chapter 6: Documentation
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
6-26
The Insert Instructions dialog will appear. Select the folder where
the text file is located, then select the text file to be inserted. Next,
choose either Insert at Beginning, End or Before Rung Number.
How the element documentation can be imported involving
“collisions” with existing program documentation can also be
chosen. Select Merge (.PRJ Priority) if the existing project
documentation is to remain unchanged. Select Merge (.TXT
Priority) if the new documentation is to overwrite the existing
documentation in the program. If the program element
documentation is not to be changed, select Ignore Element
Documentation. Press the Open button to execute the instruction.
The DirectSOFT 6 Ladder view now displays the inserted
instructions and documentation.
DirectSOFT 6 User Manual, 1st Edition
Restore
Chapter 6: Documentation
One option which the Insert Instructions function has that can be
useful is the Restore feature. Each time the Insert Instructions is
executed, a backup copy of the entire program is made before the
insert occurs. If an error is made, i.e. wrong code, just press the
Restore button and the program will be restored to its original
state.
DirectSOFT 6 User Manual, 1st Edition
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
6-27
Chapter 6: Documentation
Prevent Documentation Loss
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
The documentation which is created with DirectSOFT 6 is stored on
disk. Each time a project is opened with DirectSOFT 6, there are
multiple project files opened. Apply the same precautions to your
project as you would with any other database package to avoid data
loss.
Backing up the project files is the best insurance to prevent loss.
Any time changes are made to a project, make a copy of the project
before starting. If something goes wrong, the original will remain
intact and unchanged. There are four different methods to preserve
a project as a program is created and after the project has been
completed. The four methods are: Save Project (to disk), Save
Project As, Backup Project and Export Program.
Save Project
Save Project to Disk should be used to save your project often. Your
entire project, i.e., program and all documentation will be saved to
the drive that is being worked from, usually the C: drive. From the
Menu bar, select File > Save Project > to Disk or press Ctrl + S
(keyboard shortcut).
To save a project to a different folder than the one being worked
from, select File > Save Project As from the Menu bar. The save as
window will appear so the folder can be selected where the project
is to be saved. Name the project, press the Save button and the
entire project will be saved.
NOTE: The Write to Disk button on the Offline toolbar only saves
the ladder logic program.
6-28
DirectSOFT 6 User Manual, 1st Edition
Backup Project
Chapter 6: Documentation
The backup feature is another way to save your project. Selecting
File > Backup Project on the Menu bar or pressing the Backup
button on the Offline toolbar will open the following dialog asking if
the project is to be saved. Press the OK button to save the project.
The following Backup Project dialog will appear, the project can
be saved with the default date/time stamp or rename the folder. A
different drive can also be selected to save the project.
Date and Time Stamp
The last backup method is to use the export program feature as
explained previously. This method will save a program to a text file.
One advantage of the text file is that the program or comments can
be edited without using DirectSOFT 6.
Close all other applications that may be running to allow as much
free RAM as possible. This not only lessens chances of memory
conflicts, but also allows DirectSOFT 6 to run much faster.
Consider printing a hard copy of the program at longer intervals. If
your computer breaks down or you lose all of the data due to a disk
crash, you will at least have a hard copy of the program.
DirectSOFT 6 User Manual, 1st Edition
1
2
3
D
5
6
7
8
9
0
1
2
3
4
A
B
C
D
6-29
Chapter 6: Documentation
Notes:
2
3
5
6
7
8
9
1
11
2
13
4
A
B
C
D
6-30
DirectSOFT 6 User Manual, 1st Edition
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement