New RAMMS Version 1.6

New RAMMS Version 1.6
New RAMMS Version 1.6
Content
1
2
3
4
General ............................................................................................................................. 2
1.1
Restart RAMMS ......................................................................................................... 2
1.2
Additional Preferences ............................................................................................... 2
Edit the input file................................................................................................................ 2
2.1
Draw new polygon shapefiles .................................................................................... 2
2.2
Delete points of a polygon when drawing .................................................................. 2
2.3
Change color of polygon shapefiles ........................................................................... 3
2.4
Convert polygon shapefile to calculation domain ....................................................... 3
2.5
Import line shapefiles ................................................................................................. 4
2.6
File tree – remove visualization button ...................................................................... 4
Running a simulation......................................................................................................... 5
3.1
Improved numerical scheme ...................................................................................... 5
3.2
Curvature effect implemented .................................................................................... 6
3.3
Obstactle / NoFlux feature implemented .................................................................... 6
3.4
Cohesion implemented .............................................................................................. 7
Visualization and analysis of the results ........................................................................... 9
4.1
Automatic export of ASCII files after a simulation ...................................................... 9
4.2
Generation of ASCII files from multiple output files ................................................... 9
4.3
Velocity arrows......................................................................................................... 10
4.4
Summary of moving mass ....................................................................................... 11
4.5
Time plots and line profile plots ............................................................................... 12
5
RAMMS::Viewer .............................................................................................................. 13
6
References ...................................................................................................................... 13
1
1 General
1.1 Restart RAMMS
Restart RAMMS with the menu ‘Track  Restart RAMMS’.
Note: Don’t use this function after a RAMMS update when asked to restart RAMMS. After an
update close RAMMS via ‘Track  Exit’, Ctrl+Q or the general window close button and start
RAMMS again.
1.2 Additional Preferences
Open the additional preferences with the button
(tooltip “Additional Preferences”). The
button is located in the vertical toolbar and has formerly been used to open the colorbar
properties. It’s also possible to open them with ‘Help Advanced… Additional
Preferences Edit’’. Colorbar properties may still be opened via the menu ‘Edit 
Colorbar Properties’.
2 Edit the input file
2.1 Draw new polygon shapefiles
To draw a new polygon shapefile use the “Draw New Polygon Shapefile” button
or the
menu ‘Input  Polygon Shapefile…  Draw New Polygon Shapefile’. The menu ‘Input 
Polygon Shapefile…’ offers as well an option to load an existing polygon shapefile. This
functionality is useful to draw noflux features like dams or houses, additional MuXi areas or
the outline of the event.
2.2 Delete points of a polygon when drawing
When drawing a release area, a forest area (::AVALANCHE only), a polygon shapefile or a
calculation domain it is possible to delete the last created point. By pressing the mouse
wheel (middle mouse button) always the last created point is deleted. Example: Delete the
last three points by pressing the mouse wheel three times.
(1)
(2)
(3)
Fig. 1: (1) Draw the release area (in this case counterclockwise), (2) delete the last created point by pressing the
mouse wheel and (3) continue drawing the release area.
2
2.3 Change color of polygon shapefiles
Change the color of imported or drawn shapefiles in the ‘Additional Preferences’. Open the
‘Additional Preferences’ window with the button
in the vertical toolbar or via the menu
‘Help  Advanced…  Additional Preferences…  Edit’. The SHAPEFILE_COLOR
variable holds values from 0 to 255 (standard value = 100).
Fig. 2: Change the color of the shapefile in the ‘Additional Preferences’.
The numbers correspond to the currently selected color table and range from 0 (lower limit)
to 255 (upper limit). Regarding the standard color table “Rainbow” (no. 34) colors range from
violet (0) to red (255).
0
50
100
150
200
255
Fig. 3: Shapefile color numbers considering the standard color table "Rainbow".
The color table may be changed as well in the ‘Additional Preferences’ via the variable
COLORTABLENR. Color table numbers and names are listed at the end of the additional
preferences and may be viewed via the menu ‘Help  Advanced…  ColorTables… 
View Available ColorTables’.
2.4 Convert polygon shapefile to calculation domain
Convert a shapefile that has been created for example in GIS into a calculation domain with
the menu ‘GIS  Convert Polygon Shapefile…  to RAMMS Domain Shapefile’. An Open
File dialog pops up. Choose the polygon shapefile that should be converted into a calculation
domain and name it accordingly. RAMMS converts the polygon shapefile into a calculation
domain file, saves the file with the given name in the project folder and loads the calculation
domain into the project.
3
2.5 Import line shapefiles
Import line shapefiles with the ‘Import Polygon Shapefile’ button
, via the menu ‘Input 
Polygon Shapefile…  Load Existing Polygon Shapefile’ or via the menu ‘GIS  Import
Polygon Shapefile’.
Fig. 4: Small blue dots indicate the points of the imported line shapefile.
2.6 File tree – remove visualization button
At the right side of the file tree two buttons can be found. The ‘Refresh Tree’ button
updates the tree view. The ‘Remove Visualization’ button
removes the currently
displayed visualization. Select the desired entry in the tree view to reactivate the
visualization.
Fig. 5: File tree with the two buttons ‘Refresh Tree’ and ‘Remove Visualization’.
4
3 Running a simulation
3.1 Improved numerical scheme
In all RAMMS versions up to now, an ENO (Essentially Non-Oscillatory) scheme was used to
numerically solve the governing differential equations (Christen et al., 2010). However, the
numerical solution was implemented on strictly orthogonal grids. This improves
computational speed, but introduces numerical instabilities especially in steep terrain. The
new version of RAMMS uses the same second order ENO scheme, but now on general
quadrilateral grid. This new scheme improves numerical stability, but slows the
computational speed somewhat. The introduction of this stable ENO scheme allows us to
use lower H_cutoff values minimizing mass loss during calculations. The standard value of
H_cutoff is 0.000001 m.
Fig. 6: The Params tab of the Run Simulation window holds the H Cutoff value (standard value = 0.000001 m).
5
3.2 Curvature effect implemented
In the new version, the normal force N now includes centrifugal forces arising from the
terrain curvature. We use the method proposed by Fischer et al. (2012) which was
specifically developed for RAMMS. The centrifugal acceleration f is both a function of the
avalanche velocity and terrain curvature. The acceleration is calculated according to
 
f  u Ku T


where u is the vector u  (u , v) , consisting of the avalanche velocity in the x  and y 
directions. The matrix K describes the track curvature in all directions, including the track
“twist”. The centrifugal force is then
F  hf
which is added to the normal force N . Typically this increases the friction, causing the
avalanche to slow down in tortuous and twisted flow paths. It can change the location of the
deposition once the flow leaves the gully.
Curvature may be activated/deactivated via the menu ‘Help  Advanced…  Curvature’.
See http://www.sciencedirect.com/science/article/pii/S0165232X12000183#.
3.3 Obstactle / NoFlux feature implemented
Draw areas where the event should not flow through, e.g. dams or houses. The flow will be
deflected. Draw the required objects with the ‘Draw New Polygon Shapefile’ function and add
the obstacles/noflux features in the Params tab (Obstacle/Dam File:) of the Run Simulation
window.
Fig. 7: Add obstacles and noflux features (e.g. dams) in the Params tab.
6
Fig. 8: The event is deflected by the noflux obstacles (violet polygons).
3.4 Cohesion implemented
It is well known that flowing snow and muddy debris are “cohesive” materials. In the first
versions of RAMMS, the frictional properties of the flowing material were governed by a
simple, but robust, Voellmy-type flow law without cohesion:
S  N 
gU 2
.

RAMMS has several possibilities to select the  and  values (see sections 4.2 and 4.5 in
user manual). In the new version the basic Voellmy equation has been modified to include
cohension:

S  N  (1   )C  (1   )C exp  N
 gU
C
2
where C is the cohesion of the flowing material. Unlike a standard Mohr-Coulomb type
relation this formula ensures that S  0 when both N  0 and U  0 . It increases the
shear stress and therefore causes the avalanche or debris flow to stop earlier, depending on
the value of C .
This formula has been established using chute experiments with flowing snow (Platzer et al.,
2007) and real scale experiments with debris flows in Illgraben (VS). Snow has different
cohesive properties depending on snow temperature. Wet snow avalanches have higher
cohesion values; dry snow avalanches have lower cohesion values.
Cohesion can help reduce spurious numerical diffusion in runout zones, providing a clearer
delineation of the deposition zone.
7
Cohesion values (unit Pascal) may be entered in the Mu/Xi tab of the Run Simulation
window. Recommended values may be found in the following table.
Tab. 1: Recommended values of cohesion.
::AVALANCHE
::DEBRIS_FLOW
dry
0 – 100 Pa
wet
100 – 300 Pa
0 – 2000 Pa
Fig. 9: Run Simulation window with value field for cohesion (Pa).
See http://www.sciencedirect.com/science/article/pii/S0165232X07000808 and
http://onlinelibrary.wiley.com/doi/10.1029/2006GL028670/abstract for more details.
8
4 Visualization and analysis of the results
4.1 Automatic export of ASCII files after a simulation
When RAMMS finishes a simulation and automatically opens the results for visualization four
ASCII files are exported:




<project_name>_MaxHeight.asc:
<project_name>_MaxVelocity.asc:
<project_name>_MaxPressure.asc:
<project_name>_Deposition.asc:
Maximal flow height
Maximal flow velocity
Maximal flow pressure
Deposition (at the last dump step)
The four ASCII files are exported to the project folder which may be opened via the menu
‘Project  Open Project Folder (Windows Explorer)’.
4.2 Generation of ASCII files from multiple output files
To export the above listed ASCII files (maximal flow height, maximal flow velocity, maximal
flow pressure and deposition) for one or more simulations select the menu ‘Track  New…
 Export ASCII Files From Multi Simulations (Batch)’. Choose the simulation output files for
which the ASCII files should be generated, multiple selections are possible.
Fig. 10: Selection of simulation output files for which the ASCII files should be generated.
After the simulation output files of a folder have been selected, RAMMS asks if the selection
shall be continued in other folders.
Fig. 11: Press Yes if you want to continue the selection of simulation output files for the generation of the ASCII
files.
9
4.3 Velocity arrows
Display velocity arrows with the ‘Show Velocity Arrow’ button
or the menu ‘Show 
Show Velocity Arrow’. The arrows show the direction (in x- and y-direction) and the velocity
intensity (length of the arrow, no absolute velocity values are displayed) of the flow in a cell.
The arrows change in size and lengths when zooming into the visualization. Visualization is
best with high zoom levels. Velocity arrows are only displayed in 2D-view.
Fig. 12: Velocity arrows show velocity direction and intensity (zoom level 800 %).
Color, head-size, thickness and length can be changed in the ‘Additional Preferences’ with
the keywords




ARROW_COLOR (black, red, green, yellow, etc.)
ARROW_HEADSIZE
ARROW_LENGTHSCALE
ARROW_THICK
Use ARROW_FACTOR, if you want to reduce the number of arrows. ARROW_FACTOR = 1
displays every single arrow, ARROW_FACTOR = 2 only every second arrow, etc. (default
value is 1.0).
Use ARROW_MINVALUE to define the minimum velocity value of the velocity arrows
(default value is 0.1 m/s).
10
4.4 Summary of moving mass
The menu ‘Results  Summary of Moving Mass’ opens the summary of moving mass. Two
windows pop up: a table with flow volume (m3), maximal momentum (m2/s), flow momentum
(m2/s) and percent of moving mass (%) per time step(s) as well as a plot with the two graphs
moving momentum and flow volume over time.
Fig. 13: Table with mass flow per time step.
Fig. 14: Graphs with moving momentum and flow volume over time.
11
4.5 Time plots and line profile plots
The design of time plot and line profile plot windows changed. Title (simulation name) and
legend (name of the plotted result) are created automatically for the graph.
Fig. 15: Time plot window.
With the buttons at the left bottom of the window it’s possible to print, save and edit the
graph:

Print the graph with the “Print…” button

Save the graph in different formats with the “Save as…” button

Open the the properties window of the plot with the “Properties…” button
modify the property values if desired.

The “Reset axis range…” button
displayed result values.

Edit the graph with the options offered by the “Edit” button

Add text, forms or a legend to the graph with the “Insert” button
.
.
and
resets the axis range according to the currently
.
.
In addition to the result values (gray) the line profile plot displays the terrain elevation along
the line profile (green curve) and the result values added to the terrain (red curve).
12
Fig. 16: Line profile plot window.
5 RAMMS::Viewer
New RAMMS::Viewer available now! Did your RAMMS license expire? Do you need to look
at some old RAMMS results? This is now possible with the new RAMMS::Viewer.
Download the Viewer from our website:
http://ramms.slf.ch/ramms/index.php?option=com_content&view=article&id=53&Itemid=70
You are able to look at results, export images, GIF animations, ASCII files and shapefiles.
You are not able to run new simulations. Please order a new license, if you need to do new
simulations for a project.
6 References
Fischer, J.T., Kowalski, J. and Pudasaini, S.P., 2012. Topographic curvature effects in
applied avalanche modeling. Cold Regions Science and Technology, 74-75: 21-30.
Platzer, K., Bartelt, P. and Kern, M., 2007. Measurements of dense snow avalanche basal
shear to normal stress ratios (S/N). Geophysical Research Letters, 34(7).
Platzer, K.; Bartelt, P.; Jaedicke, C., 2007: Basal shear and normal stresses of dry and wet
snow avalanches after a slope deviation. Cold Reg. Sci. Technol. 49: 11-25.
13
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement