SIMDevIDE USER MANUAL

SIMDevIDE USER MANUAL
SIMDevIDE USER MANUAL
A PART OF SIMCOM EMBEDDED AT DEVELOPMENT KIT
PDF created with pdfFactory Pro trial version www.pdffactory.com
INTRODUCTION
SIMDevIDE is an IDE tool developed by SIMCom to integrate its core Embedded AT environment with
customer application development process. SIMDevIDE allows customers to edit, compile, link core
libraries and download MOT file effortlessly. SIMDevIDE works with all versions of Windows.
GETTING STARTED
INSTALL SIMDEVIDE
Follow the instruction to install SIMDevIDE to the desired location, click the icon on your desktop to start
SIMDevIDE.
Set Compiler Environment
1.
Before install SIMDEVIDE If you have not installed the arm compiler, you need install the arm
compiler tool or you want to change the arm compiler path, you need set the correct path of arm tool
in Options->Compiler otion.
PDF created with pdfFactory Pro trial version www.pdffactory.com
2, Select the correctly compiler tool by click this “…” button.
PDF created with pdfFactory Pro trial version www.pdffactory.com
CREATE A NEW PROJECT
1. Create a new project by click File->New
PDF created with pdfFactory Pro trial version www.pdffactory.com
2. “New” window pops open, add your project name here and select example project based on the type
of module used for the project. Click OK when done.
PDF created with pdfFactory Pro trial version www.pdffactory.com
A new project is now created. Two folders are automatically created for the project; “Code Files” and
“Header Files” for .c and .h files respectively.
PDF created with pdfFactory Pro trial version www.pdffactory.com
3. Add files to the project, by select File->New, “New” window opens again, and select Files tab to add
files.
PDF created with pdfFactory Pro trial version www.pdffactory.com
Add source file according to its type(header/code), and select its location appropriately. Click OK when
done.
4. The added file is now ready to be edited:
PDF created with pdfFactory Pro trial version www.pdffactory.com
PDF created with pdfFactory Pro trial version www.pdffactory.com
BUILD AN EXISTING PROJECTS
1. Open an existing project
2. Project Test2 opened
PDF created with pdfFactory Pro trial version www.pdffactory.com
PDF created with pdfFactory Pro trial version www.pdffactory.com
3.Select Build->build all from drop down menu
PDF created with pdfFactory Pro trial version www.pdffactory.com
4. Build finish successfully, with build information (marked by the red square) displayed in the build
information window
5. Download your application to SIMCom modules by select Build->download, it opens the flash download
tool window.
PDF created with pdfFactory Pro trial version www.pdffactory.com
Click Start Download when all files are located.
FIX YOUR PROJECT
1.For build Time Error
PDF created with pdfFactory Pro trial version www.pdffactory.com
Build time error is reported, you can scroll back the build information window to find the errors, or
Use the EDIT->FIND IN FILES, to search for errors in *.txt and *.ini files in the project.
2.Debug Process
For debugging your project, your code has to enable debug first, see Embedded AT Development Guild
4.11 Debug API on how to enable debug in your program.
Set your debug port by selecting Project->COM setting…
While your program is running on SIMCom modules, select Build->Debug Start menu to start receiving
debug information from the debug port set above.
PDF created with pdfFactory Pro trial version www.pdffactory.com
Debug information is printed to Debug window, to view the information by selecting the Debug tab.
PDF created with pdfFactory Pro trial version www.pdffactory.com
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement