Labscan Manual
LabScan
TM
User Manual
for version 5.0
CHAPTER 1: (Edition AB)
This version of LabScanTM has been developed by the
Swiss Institute of Bioinformatics in collaboration with
GeneBio and Amersham Biosciences.
Notice
All intellectual property rights on this User Manual, as well as on the LabScan software, belong
to the Swiss Institute of Bioinformatics. No part of this User Manual may be reproduced or
transmitted in any form or by any means, electronic or mechanical, including photocopy,
recording or any information storage or retrieval system, without permission in writing from the
Swiss Institute of Bioinformatics.
Copyright © 1992-2003 Swiss Institute of Bioinformatics, Geneva, Switzerland. All rights reserved.
LabScan uses the TIFF library.
Copyright © 1988-1999 Sam Leffler and 1991-1999 Silicon Graphics, Inc.
LabScan includes software developed by the Apache Software
(http://www.apache.org).
Copyright © 1999-2000 The Apache Software Foundation. All rights reserved.
Foundation
TIFF is a trademark of Aldus Corporation. Microsoft Excel, Microsoft Word, Microsoft Internet
Explorer, Windows 95, Windows 98, Windows ME, Windows NT, Windows 2000, and Windows
XP are trademarks of Microsoft Corporation. Netscape Communications, Netscape and
Netscape Navigator are trademarks of Netscape Communications Corporation.
LabScan, ImageScanner and ImageMaster are trademarks of Amersham Biosciences Limited.
Amersham is a trademark of Amersham plc.
Copyright © Amersham Biosciences UK Limited 2003 – All rights reserved.
Amersham Biosciences AB Björkgatan 30, SE-751 84 Uppsala, Sweden. Amersham
Biosciences UK Limited Amersham Place, Little Chalfont, Buckinghamshire HP7 9NA, United
Kingdom. Amersham Biosciences Corp 800 Centennial Avenue, PO Box 1327, Piscataway, NJ
08855 USA. Amersham Biosciences Europe GmbH Munzinger Strasse 9, D-79111 Freiburg,
Germany. All goods and services are sold subject to the terms and conditions of sale of the
company within the Amersham Biosciences group that supplies them. A copy of these terms
and conditions is available on request.
Technical Support
Amersham Biosciences provides technical support for LabScan in accordance with the terms of
the License Agreement. For technical support issues, please contact us at [email protected]
Support phone numbers:
Asia Pacific Tel: +852 2811 8693 Fax: +852 2811 5251 Australasia Tel: +61 2 9894 5152 Fax:
+61 2 9899 7511 Austria Tel: 01 576 0616 20 Fax: 01 576 0616 27 Belgium Tel: 0800 73 888
Fax: 03 272 1637 Canada Tel: 1 800 463 5800 Fax: 1 800 567 1008 Central, East, South East
Europe Tel: +43 1 982 3826 Fax: +43 1 985 8327 Denmark Tel: 45 16 2400 Fax: 45 16 2424
Finland Tel: 09 512 3940 Fax: 09 512 1710 France Tel: 0169 35 67 00 Fax: 0169 41 9677
Germany Tel: 0761 4903 401 Fax: 0761 4903 405 Italy Tel: 02 27322 1 Fax: 02 27302 212
Japan Tel: 81 3 5331 9336 Fax: 81 3 5331 9370 Latin America Tel: +55 11 3667 5700 Fax: +55
11 3667 87 99 Middle East and Africa Tel: +30 (1) 96 00 687 Fax: +30 (1) 96 00 693
Netherlands Tel: 0165 580 410 Fax: 0165 580 401 Norway Tel: 2318 5800 Fax: 2318 6800
Portugal Tel: 01 417 7035 Fax: 01 417 3184 Russian Federation Tel: +7 (095) 232 0250,956
1137 Fax: +7 (095) 230 6377 South East Asia Tel: 60 3 724 2080 Fax: 60 3 724 2090 Spain
Tel: 93 594 49 50 Fax: 93 594 49 55 Sweden Tel: 018 612 19 00 Fax: 018 612 19 10
Switzerland Tel: 01 802 81 50 Fax: 01 802 81 51 UK Tel: 0800 616 928 Fax: 0800 616 927
USA Tel: +1 800 526 3593 Fax: +1 800 329 3593
iii
CONTENTS
Preface.................................................................................. v
1. What is LabScan?........................................................................................... v
2. About this document ....................................................................................... v
3. Getting assistance ......................................................................................... vi
Chapter 1: Introduction ....................................................... 1
1. Installing LabScan........................................................................................... 1
System requirements ................................................................................. 1
Software installation................................................................................... 1
2. On-line user manual........................................................................................ 2
3. Running and exiting LabScan ......................................................................... 2
4. The graphical interface ................................................................................... 2
Menu bar.................................................................................................... 3
Toolbar....................................................................................................... 3
Chapter 2: Image Scanning ................................................ 5
1. General procedure .......................................................................................... 5
2. Scanner settings ............................................................................................. 5
Scanning .................................................................................................... 5
Calibration.................................................................................................. 6
Internet....................................................................................................... 7
3. Intensity calibration ......................................................................................... 7
Display calibration...................................................................................... 9
Control calibration ...................................................................................... 9
4. Preview ......................................................................................................... 10
5. Scanning ....................................................................................................... 15
6. Undo.............................................................................................................. 16
7. Saving and printing ....................................................................................... 17
Index ................................................................................... 19
iii
PREFACE
1. What is LabScan?
LabScan is an easy to use software application specifically designed for acquiring
images from two-dimensional electrophoresis gels and blots, using the ImageScanner.
This version of LabScan was developed by a team of top researchers from the Swiss
Institute of Bioinformatics (SIB) in collaboration with Geneva Bioinformatics (GeneBio)
S.A. and Amersham Biosciences.
2. About this document
Before getting started with LabScan, you should have a working knowledge of your
computer's operating system and its conventions, including how to use a mouse and
standard menus and commands. You need to be able to adeptly open, save, and
close files. If you wish to review any of these skills, please refer to the documentation
that came with your computer.
The following types of text conventions describe specific commands or functions:
File → Exit
Choose the Exit command under the File menu.
Ctrl+A
Hold down the Control key while typing the letter A.
Left click
Click the left mouse button.
Right click
Click the right mouse button.
Double click
Click the left mouse button twice.
Dragging
Position the cursor on an object and hold down the left mouse
button while subsequently moving the mouse.
Window or icon names appear in italics. Boldface items generally denote different
parameters to be set in a dialog box or different options under a certain menu.
v
PREFACE
The following icons highlight items of special interest:
This icon appears next to anything you need to remember for later use. It also draws
your attention to an important issue that should be considered while striving to obtain
correct and exploitable results.
The aim of this manual is to provide useful information in a straightforward format.
Therefore, the items marked with this symbol are especially noteworthy, be it a
valuable hint, a practical option, or a way to simplify and speed up a process.
Passages marked with this icon enumerate the successive actions to be undertaken
when carrying out the specified operation, including the corresponding object
selections, menu options and parameters to be set.
3. Getting assistance
Amersham Biosciences provides technical and scientific support for the LabScan
software. Please contact us if any problems arise with the installation or use of the
program. Our support team is happy to help you.
How to contact us
•
•
E-mail us at [email protected]
Call us at one of these numbers. Asia Pacific Tel: +852 2811 8693 Fax: +852
2811 5251 Australasia Tel: +61 2 9894 5152 Fax: +61 2 9899 7511 Austria
Tel: 01 576 0616 20 Fax: 01 576 0616 27 Belgium Tel: 0800 73 888 Fax: 03
272 1637 Canada Tel: 1 800 463 5800 Fax: 1 800 567 1008 Central, East,
South East Europe Tel: +43 1 982 3826 Fax: +43 1 985 8327 Denmark Tel:
45 16 2400 Fax: 45 16 2424 Finland Tel: 09 512 3940 Fax: 09 512 1710
France Tel: 0169 35 67 00 Fax: 0169 41 9677 Germany Tel: 0761 4903 401
Fax: 0761 4903 405 Italy Tel: 02 27322 1 Fax: 02 27302 212 Japan Tel: 81 3
5331 9336 Fax: 81 3 5331 9370 Latin America Tel: +55 11 3667 5700 Fax:
+55 11 3667 87 99 Middle East and Africa Tel: +30 (1) 96 00 687 Fax: +30 (1)
96 00 693 Netherlands Tel: 0165 580 410 Fax: 0165 580 401 Norway Tel:
2318 5800 Fax: 2318 6800 Portugal Tel: 01 417 7035 Fax: 01 417 3184
Russian Federation Tel: +7 (095) 232 0250,956 1137 Fax: +7 (095) 230 6377
South East Asia Tel: 60 3 724 2080 Fax: 60 3 724 2090 Spain Tel: 93 594 49
50 Fax: 93 594 49 55 Sweden Tel: 018 612 19 00 Fax: 018 612 19 10
Switzerland Tel: 01 802 81 50 Fax: 01 802 81 51 UK Tel: 0800 616 928 Fax:
0800 616 927 USA Tel: +1 800 526 3593 Fax: +1 800 329 3593
Sending E-mail
To provide us with the essential technical and customer information when mailing to
[email protected], please proceed as follows:
Choose Help → Online Support from the program menu.
Enter your personal information in the pop-up window. Please note that this data is
used to update our customer database. In this way, we can contact you with
certainty when it is time to send new patches or installation files.
In the next window, specify whether you want to ask a question, make a
suggestion, or report a bug. Depending on your choice, the software asks you
subsequent questions that help us to supply you with an appropriate answer.
vi
GETTING ASSISTANCE
Click on the E-mail button. A new message is created with your preferred e-mail
software, automatically directed to [email protected]
Highlight the <Paste clipboard> text with your mouse and then Edit → Paste the
contents of your clipboard into the mail message. The E-mail now contains your
questions and contact information, as well as useful data about your LabScan
version, work session and computer system. If the problem is file-specific, then
attach any relevant files. Send us this message. Alternatively, you can print the
clipboard contents and send it to us by fax.
System and product information
To quickly obtain product and system information, for your own benefit or during a
technical support call, choose Help → System & Product Information from the program
menu. A window shows the useful data about your LabScan version and computer
system.
You can also get information about your LabScan version by looking at the release
number given under About LabScan in the Help menu. Selecting Help → About
LabScan displays the program splash page.
Amersham Biosciences listens
The Amersham Biosciences staff is attentive to your suggestions. Many of the new
features and enhancements in this software are a direct result of conversations with
our customers. We highly appreciate any comments, criticisms or ideas that would
help us to improve the software. Please do not hesitate to contact us by E-mail at
[email protected]
vii
CHAPTER 1: INTRODUCTION
1
1. Installing LabScan
System requirements
The minimum system requirements for installing and running the software are:
••• Any of the Windows 98 / ME / NT / 2000 / XP operating systems.
••• Administrative privileges to install LabScan on Windows NT / 2000 / XP.
••• At least 128 MB RAM (256 MB is recommended).
••• A high display quality, with a color resolution set to 24 bit (16.7 million colors) and a
screen resolution of at least 1024 x 768 pixels.
••• Internet Explorer 5 (Microsoft Corporation), Netscape Navigator 6 (Netscape
Communications Corporation) or Mozilla 1.4 (Mozilla Foundation) installed on your
computer to print reports.
Software installation
The software can either be installed on a PC from a CD-ROM or from a setup file
downloaded from the Internet. When you insert the CD-ROM into the appropriate drive
on your computer, the installation program starts automatically and guides you
through a series of screens. Alternatively, you can double click on the icon of the
setup file (for example LabScan_v500.exe) to launch the installer.
The LabScan installer creates a default directory tree on your hard disk, called
Program Files\Amersham Biosciences\LabScan, in which the application files are
placed. If this default file path is not suitable, browse for an alternative path before
continuing the installation.
Once the installation is complete, it is recommended to restart your computer.
1
1
INTRODUCTION
2. On-line user manual
This User Manual is also available on-line from within the LabScan program. To
consult the on-line manual:
Choose Help → User Manual from the menu.
LabScan opens the on-line document.
Click on the desired section in the Bookmarks.
You immediately find the related text.
If you have trouble referring to the on-line manual, please make sure you have Adobe
Acrobat Reader installed. Acrobat Reader is freely available from the following site:
www.adobe.com/products/acrobat/readstep2.html.
3. Running and exiting LabScan
LabScan is started like any other software by selecting the LabScan icon (Figure 1-1)
from the Programs folder in your Windows Start menu. The LabScan splash page
appears while the software is loading. Click on the page to make it disappear.
Figure 1-1. LabScan icon.
Select File → Exit in the menu to close the program. You can also click on the close
button in the upper right corner of the program window. LabScan lets you choose to
save unsaved gel images before exiting.
4. The graphical interface
By reading through the following pages, you will become acquainted with the LabScan
program window. It is divided into three main parts, shown in Figure 1-2, which are the
Menu bar, the Toolbar and the Image display zone. The Menu bar and Toolbar are
discussed in more detail below.
1
2
3
Figure 1-2. The LabScan program window. (1) Menu bar, (2) Toolbar, and (3) Image
display zone.
2
THE GRAPHICAL INTERFACE
1
Menu bar
Different actions may be chosen from the Menu bar to be performed on the scanned
image. This is done by picking the appropriate menu header and moving the cursor to
the desired function while holding down the mouse button. Certain menu options have
additional sub-options. You can choose one of these by moving the mouse over the
small arrow found on the right hand side of the menu item.
The following menus are used to:
File ............
Save or print a scanned image. You can also preview a scanned
image, carry out the final scan, or exit LabScan.
Edit ............
Undo the previous action(s), and set the scanning (mode, resolution,
color filter), calibration (step tablet) and Internet settings.
Image ........
Obtain information about the scanned image, modify its display (flip,
rotate, contrast adjustment) or display saturation.
Calibration
Create, save, load or display a calibration.
Help ...........
Get information about the software, access the user manual, and
contact technical support.
Toolbar
Various options from the LabScan menu can also be accessed via the toolbar:
The Preview tool is used to do a rapid first scan in order to define the right
settings and scan region for the final scan.
The Scan icon is used to initiate the final scan of the object on the glass
plate.
The Calibration tool lets you create a new calibration.
The Save As icon allows the user to save the scanned image.
In certain modes (such as Preview, Scan, Calibration), some additional icons may
appear:
When the Hand Tool is activated, you can move your image in order to
show other parts of it.
The Zoom Tool lets you repeatedly zoom in (left click) or out (right click) on
the whole image each time by a factor of two.
The Region Tool is useful to get a preview of the changes made during
contrast adjustments.
The Crop Tool allows you to select a rectangular area on a preview of the
scanned image. The crop zone can be saved, edited and deleted.
3
1
INTRODUCTION
The Step Tablet Tool is used to place the rectangles corresponding to the
different gray levels on the tablet image.
The Rotation Tool is used to rotate the grid that guides you when turning an
image.
4
CHAPTER 2: IMAGE SCANNING
2
1. General procedure
To capture an image with the ImageScanner, for subsequent analysis with twodimensional (2-D) image analysis software, you need to:
Choose the settings for the scanner.
Carry out a scanner calibration (once a month).
Preview the image to be scanned.
Do the final image scan.
Save the scanned image. Alternatively, you can send it to ImageMaster 2D
Platinum for direct image analysis.
Please note that the gray level calibration must be performed on a regular basis (once
every 31 days). When the previous calibration becomes obsolete, there is a reminder
that lets you know that it is necessary to recalibrate the scanner using a step tablet.
2. Scanner settings
First of all, you need to choose the settings for the scanner. To do so:
Choose Edit → Settings from the main program menu.
Adjust the desired settings under the Scanning (Mode, Resolution, Color) and
Calibration (various file paths) tabs. Further details about these settings are found
below.
Click OK when finished.
Scanning
Mode
Choose between two different scanning modes:
••• Reflective mode: Used to scan opaque objects.
••• Transparent mode: Used for transparent objects. 2-D gels should generally be
scanned in Transparent mode.
5
2
IMAGE SCANNING
Resolution
You must choose the scanning resolution, which is expressed in dots per inch (dpi).
You have five possibilities, between 100 and 600 dpi. A resolution between 150 and
300 dpi is generally sufficient for gel analysis. Higher resolutions (for example 600 dpi)
significantly increase the file size, and may slow down the analysis process.
Color
You must choose the appropriate filter type to scan your image. Four color filters are
available within LabScan:
•••
•••
•••
•••
Blank: None of the colors is filtered.
Red: The red channel is filtered.
Green: The green channel is filtered.
Blue: The blue channel is filtered.
The rule is that the scan filter color must be complementary to the sample color. You
should never use the same color filter as the sample color. For example, never use a
blue filter for a Coomassie stained gel or red for a silver stain.
The following table gives some suggestions for commonly used stains:
Coomassie stained gels
Red or green.
Silver stained gels
Blue or green.
Autoradiography
Blank or green.
Membranes
A color totally different from the spots or band colors.
Calibration
The following file paths need to be entered. Please note that at least the first two ones
should be correctly set during installation of the program.
••• Calibration Tablet File: Contains the step tablet definition for the calibration strip
(normally the Kodak Step Tablet no. 2).
••• Control Tablet File: Contains the step tablet definition for the control strip
(normally the Kodak Step Tablet no. 3).
••• Save Calibration Between Sessions: Contains the name of the file where the
active calibration is saved when closing the current work session. This is also the
file where the software reads the calibration from at the start of each new work
session. Any calibration created or used during the session that should not be used
as default must be saved in a separate file.
The Calibration Tablet File and Control Tablet File should contain the appropriate
information for your particular step tablets: the OD values for the step tablet, the height
and width of the tablet, the number of steps and a few other details. You can edit the
files with tools such as Windows Notepad. The Kodak Step Tablet no. 2 uses default
OD values and therefore the provided Calibration Tablet File can be used as is. The
Control Tablet File for the Kodak Step Tablet no. 3, on the other hand, should be
edited so that the OD values reflect those of your calibrated tablet. As the intensity
values supplied with your step tablet are generally expressed in diffuse density (DD),
6
INTENSITY CALIBRATION
2
you have to convert them to OD values. For this purpose, the manufacturer of the step
tablet should provide the appropriate relationship. For the Kodak Step Tablet no. 3,
this is OD = 1.4 DD.
Internet
Printing of tabular reports in LabScan is managed through an Internet browser.
Therefore you have to set the default browser to be used for this purpose (Internet
Explorer, Netscape or Mozilla).
3. Intensity calibration
The first time you use your scanner, you will have to do a calibration using the step
tablet that was provided. Afterwards, you only need to perform this intensity calibration
every 31 days. If you do not calibrate, darker material may not be measured in the
correct proportions to the lighter material.
Follow these steps to perform a calibration:
Choose Calibration → Calibrate from the menu or click on the Calibration icon in
the program toolbar.
You are asked to position the step tablet (no. 2). Place it vertically on the 0 position
of the scanner with the light end against the scanner border, and the glossy side
against the glass.
Click OK to continue the calibration process.
The image of the scanned step tablet appears in the main window, together with
the red calibration step overlay. The Create Calibration window is also displayed
(see Figure 2-1).
Select the Calibration Tool in the main program toolbar and adjust the position of
the steps by dragging the overlay while holding the left mouse button. To help you
differentiate the darkest steps, you can adjust the contrast (see below).
At the left of the Create Calibration window, you see the theoretical optical density
(OD) values of the different steps in the tablet. LabScan may automatically
deselect some of the steps (grayed out) because of their non-reliable values, and
you can deselect additional ones if you estimate that they should be excluded from
the calibration process. At the right of the Create Calibration window you see the
calibration curve between the logarithmic transmittance values on the X-axis, and
the OD intensities on the Y-axis. Note that the measured intensity values for each
step are calculated as median intensities over all the pixels in the small rectangle
area for each step (on the step overlay). The horizontal dispersion intervals in blue
(or gray for deselected spots) represent the intensity ranges when 10% of the less
intense and 10% of the most intense pixel values are removed. The calibration
formula and error are given below the graph.
You can additionally display some reports to judge the quality of your scanner
calibration (see below for more details).
Once you are satisfied with the calibration, close the Create Calibration window.
The software asks whether you want to validate the calibration. If you answer Yes,
LabScan automatically saves the calibration in the default folder indicated in the
LabScan Settings (see above).
Note that when you select a point in the step tablet list (in the Create Calibration
window), the corresponding step becomes automatically highlighted in green on the
7
2
IMAGE SCANNING
step tablet overlay and in the calibration graph. This makes it very easy to correlate
the three sources of information (point in tablet list, point in graph and step rectangle).
Figure 2-1. Image of the step tablet with the red calibration step overlay. The Create
Calibration window shows the calibration curve and the OD values for the different
steps (on the left).
Please note the various icons in the toolbar of the Create Calibration window. These
are used to:
Open another tablet definition.
Save the calibration under a different name (Save As).
Print the calibration graph.
Copy the calibration graph to the clipboard.
Display related Reports.
Two reports are available from the Reports icon in the Create Calibration window:
••• The Fitting Report displays the coefficients of the regression function, the error
and the number of correlated points.
••• The Calibration Report displays for each step: the step number, the experimental
averaged gray level, the theoretical intensity value, and the fitting error (difference
between the curve and the point).
The Fitting and Calibration reports can be saved, printed and copied to the clipboard:
Save a report. Enter the File name in the displayed window and choose the
desired format in the Save as type field. The reports can be saved in the
LabScan report format (XML file carrying the extension .rpt), in text format with
8
INTENSITY CALIBRATION
2
tabulations separating the columns (.txt), or as a Microsoft Excel Workbook
(.xls).
Print a report. The report table to be printed is first displayed in the default
browser. This is because the XSL stylesheet located in the Template\Reports
folder of the LabScan installation directory is used to transform the XML report
into an attractive table. You can subsequently use the print option in your
browser to get a paper printout.
Copy to Clipboard. You can export your table directly into another program,
such as spreadsheet software (Excel). To do so, select the desired lines in your
table, using the Shift or Ctrl keys. Then copy the selection to the clipboard by
choosing the Copy to clipboard button in the toolbar or the Copy to clipboard
option in the contextual menu (available by clicking the right mouse button).
Directly paste into the desired software.
Display calibration
Normally, once you do a calibration, it remains valid for 31 days and you need not
worry about it during that time. Occasionally, it may be useful to display the current
calibration. For example, in order to verify that you are using the correct one. You can
do this with the Calibration Display mode, which cannot be used for editing a
calibration, only for viewing existing calibrations.
To open a Display Calibration window:
Choose Calibration → Display from the menu.
A Display Calibration window opens, showing your current calibration.
The Display Calibration window is very similar to the Create Calibration window. It
uses the same type of graphics and toolbar icons. The only differences lie in the fact
that the calibration cannot be edited (no possibility to deselect any calibration steps)
and that the Open Tool allows you to open other calibration files. A step tablet
definition cannot be selected as is the case in the Create Calibration mode.
Control calibration
The Control Calibration mode allows you to verify whether you are using a correct
calibration. It requires a different step tablet (Kodak Step Tablet no. 3, for instance),
which you compare to your previous calibration results. To do such a control:
Choose Calibration → Control from the program menu.
You are asked to position the appropriate step tablet (for example no. 3).
Remember that the path to this tablet definition file is set in the LabScan Settings.
Again, this tablet is placed vertically on the 0 position of the scanner with the light
edge against the scanner border, and the glossy side against the glass.
Click OK to continue the calibration process.
The image of the scanned step tablet appears in the main window, together with
the red calibration step overlay. The Control Calibration window is also displayed.
Select the Calibration Tool and adjust the position of the steps.
You should now verify that the calibration curve is passing through the data points
correctly and with minimum dispersion intervals. If this is not the case, try to find
out why your current calibration does not seem to work properly.
9
2
IMAGE SCANNING
4. Preview
Preview allows you to rapidly inspect the object to be scanned and to delimit the zone
you really want to capture. Please note that a preview image cannot be saved.
To display a preview of your image, just choose File → Preview from the menu or click
on the Preview icon in the toolbar. The software displays a preview of the image to be
scanned. In the preview mode, various tools are available. Most of these also function
in scan mode.
Image information
To obtain information on the image size and resolution, choose Image → Info in the
menu. This opens a window (Figure 2-2) containing data such as the sizes of the full
image and the crop zone (final size of the scanned image), both in terms of pixel
dimensions and memory (KB). The resolution for both the full image and the crop zone
is expressed in dots per inch (dpi).
Figure 2-2. Future scanned image information window displaying the sizes (in terms of
pixels and memory) of the full image and the crop zone, as well as image resolution.
Hand tool
The Hand Tool is a straightforward means to move your image in the Image display
zone, enabling you to look at a specific part of the image that may have been hidden
before.
To move an image:
Pick the Hand icon in the LabScan toolbar.
Put the cursor inside the image and hold down the left mouse button while moving
the mouse. The image follows your movement.
Release the mouse when you reach the desired position.
Zoom
The Zoom Tool lets you repeatedly zoom in or out on the whole image:
Pick the Zoom Tool icon from the toolbar.
To zoom in, click on the image in the desired region.
To zoom out, right click on the image.
10
PREVIEW
2
Contrast mapping
Because typical computer screens are only able to display 256 gray levels, mapping
has to be undertaken between the calibrated pixel gray levels in the image (65536 for
a 16-bit image), and the 256 screen gray levels. By default, LabScan uses a linear
mapping function for this, where the lightest point in the image is mapped to 0 (white)
and the darkest point is mapped to 255 (black).
This is illustrated with the gray level histogram in Figure 2-3. The histogram displays
the frequency with which each gray level (from 10605 to 65327) occurs in the image.
The red line on your screen indicates that the minimum and maximum gray levels are
remapped by the default linear mapping. Indeed, the vertical axis for the red remapping graph corresponds to the 256 screen gray levels.
Figure 2-3. Adjusting the contrast of displayed colors.
However, you can choose other mapping functions to highlight small light spots.
LabScan offers two ways to change the default gray level mapping and thus improve
the visual display of the images.
You can define the minimum and maximum gray levels. That is, you can look at only
the light or the dark regions of the images. Do this by decreasing the size of the gray
level range to be linearly remapped to the screen gray levels. To accomplish this,
move the left or right borders of the slider that is found below the histogram function.
Once the size (interval) of the slider is decreased, you can also displace the interval
by moving your cursor to the middle of the slider, holding down the mouse button, and
shifting to the left or right (Figure 2-4).
11
2
IMAGE SCANNING
Figure 2-4. Remapping of the gray levels.
Another way to change the default gray level mapping is to use a non-linear mapping
function. The Bending parameter expands or compresses the contrast range at the
dark or light ends of the range. When bending is positive, the image is lighter. When
the bending parameter is negative, the image is darker (Figure 2-5).
Figure 2-5. Region of a gel showing a contrast adjustment: The left image shows the
original image; the central and right images show the same gel area after setting the
bending parameter to -2 and 2, respectively.
To adjust the image contrast:
Choose Image → Adjust Contrast from the menu bar.
Select the Region Tool in the toolbar, and draw a region in the image to get a
preview of the contrast mapping modifications.
Select the units you would like to use from the Unit list (see below) and indicate
whether you want to modify the contrast mapping as a function of the complete
image range, or only that of the selected region (see below).
In the Image Display Settings window, change the minimum and maximum gray
levels by displacing the slider borders, or typing in the desired numbers in the
12
PREVIEW
2
boxes at the lower left and right corners of the histogram. You can also use the
bending slider.
If you are happy with your choice, click OK to apply the changes to the whole
image. This does not modify the raw pixel data. The change is only visual.
In some cases, you may want to save a specific mapping function so that it can be
later applied to other images with similar gray level properties. To do this, click on the
Save icon in the Image Display Settings window and enter a file name as well as the
desired destination folder. LabScan saves the mapping function with the extension .glt
(Gray Levels Transformation).
UNITS
Two different units are used for displaying the gray level minimum and maximum:
••• Value uses the raw pixel counts as displayed in all the reports. When a calibration
has been done, these correspond to the calibrated pixel values.
••• Percentage (%) allows you to choose the range as a percentage of the total gray
level range in the histogram.
ONLY IN REGION
By checking the Only in Region box in the Image Display Settings window, LabScan
only considers the gray levels that are present in the selected region.
The Only in Region option is very useful in combination with the % Units and the
choice of a relatively small region. Under these conditions, you enter an adaptive
mode that allows you to adjust to the local gray levels. The result is a local increase in
contrast that effectively enables you to look for very faint spots. This mode can also be
combined with the Saturation palette in the Colors list.
Pseudo colors
You may want to use a particular color palette instead of the standard gray levels in
your gel. LabScan offers color palettes such as Coomassie Blue, Silver Stain, Hot
Iron, Spectrum, etc. A palette that is particularly useful is the Gray+Saturation palette.
It corresponds to the standard Gray option, except for the maximum value that is
displayed in red, and the minimum value that appears in blue. It is helpful when you
would like to visualize saturated spots (red) or the background (blue). Of course, you
can modify the minimum and maximum gray levels, as explained above, to decrease
the stringency of what is considered as saturation or background. Finally, you can just
inverse the gray levels by checking the Invert box.
To display (part of) a gel with pseudo colors:
Choose Image → Adjust Contrast from the menu.
Select the Region Tool in the toolbar, and draw a region in the image.
Select one of the color palettes in the Colors list and/or invert the gray levels by
checking the Invert box. You can also adjust the contrast as indicated above.
To go back to the default gray levels, choose the Gray option from the Colors list.
Please note that the color palettes cannot be permanently applied to the image. When
you click OK to close the Image Display Settings window, only the contrast
adjustments are applied. The color settings are no longer visible.
13
2
IMAGE SCANNING
Cropping
The Crop Tool (Figure 2-6) allows you to define the zone you are to scan.
Figure 2-6. Crop Tool.
To use the Crop Tool:
Select the Crop Tool and draw a rectangle on the image corresponding to the
region you want to scan. To modify the rectangle size, click on one of the rectangle
handles (small black squares) and drag it while holding down the left mouse
button.
If you have a clear visual landmark (spot or marker) on your image, you can double
click on its position to define an anchor (red circle) that can be used to reposition
the crop zone in a similar way on the next gel to be scanned.
Move the crop zone by clicking in it and dragging it to another position.
You can also use the Edit option under the Crop Tool in the toolbar. This opens an
Edit Crop Tool window as shown in Figure 2-7. Directly modify the values for the
anchor and the box dimensions in this window. You can also check the option
called Move also the box relatively that allows you to change the box position by
moving the anchor, while maintaining the same separation distance.
To define a new crop zone, the old one should be removed. This is automatically
the case if you reduce the size of your box so that it is less than 5 pixels large. You
can also use the Delete option under the Crop Tool in the toolbar.
14
SCANNING
2
Figure 2-7. Edit Crop Tool
Once you have set the crop area, you can save it to reload later, by selecting the Crop
Tool in the toolbar and choosing Save. In any event, the crop box and anchor are
passed on (same position) to the next gel preview. You can then move the anchor to
the same visual landmark. Since the box moves with the anchor, you easily scan the
corresponding region.
5. Scanning
Once you have set the crop area in the preview, scan the selected part of the image
by choosing File → Scan or by clicking on the Scan icon in the toolbar. The resulting
scanned image is displayed in its entirety with the maximum possible zoom. The
scanned image is then manipulated and modified with the tools mentioned above (in
the Preview section) and those described hereafter.
Crop tool
As with Preview, the Crop Tool is used to define a new area in the acquired image for
final saving. When you use Save As, you are asked whether you want to save only the
selected area. If you answer Yes, the image is reduced to the crop zone and saved
with the new file name. Please note that this new crop area is independent of the one
defined in Preview mode. However, it is similarly maintained for the next scanned
image.
Displaying saturation
You can visualize the saturated pixels in your image. Saturated pixels have OD values
higher than a threshold that is defined as the OD of the step in the calibration curve
that is just above the last activated one. To view saturated pixels (spots):
Choose Image → Display Saturation from the menu.
The saturated pixels are displayed in orange on the image.
Choose Image → Display Saturation again to deactivate the function.
15
2
IMAGE SCANNING
Flipping images
Sometimes, images are scanned in the wrong direction, and you may have to flip them
to create their correct mirror image. With LabScan, you can flip images horizontally
and vertically:
Choose Image → Flip from the menu and select the desired option (Horizontally or
Vertically).
The image flips.
Rotating images
When images are scanned in the wrong orientation, they can be rotated to correct for
this. You can typically rotate your gels by 90° clockwise (90 CW), 180° and 90°
counterclockwise (90 CCW). But free rotation can also be applied.
To rotate an image:
Choose Image → Rotate from the menu and select the desired rotation angle.
Alternatively you can choose Image → Free Rotate.
The image appears with a grid on it. The bold horizontal grid line plays the role of
landmark to help you visualize the rotation. It becomes the new horizontal in your
rotated image.
Click on any position in the scanned gel and rotate the grid while holding down the
left mouse button. Release the button when you obtain the desired rotation angle.
You can also manually enter a rotation angle in the Rotation Tool dialog box.
Press OK in the dialog box to confirm your rotation, or Cancel to return to the initial
orientation of the gel.
6. Undo
LabScan allows you to cancel any unwanted modifications. You can return to an
earlier state of settings simply by using the Undo option.
Each Action Descriptor in the Undo list is preceded by the time at which the action
was carried out. This information can help you to identify the particular sequence of
actions that you would like to cancel.
To undo the last action performed:
Choose Edit → Undo from the menu.
The last action is selected by default.
Click OK.
In order to cancel several successive actions:
Choose Edit → Undo from the menu.
Select a prior action to be undone.
When you answer OK, the selected action and all following actions are undone
automatically.
It is not possible to undo operations such as saving and printing files.
16
SAVING AND PRINTING
2
7. Saving and printing
Save image
To save a scanned image:
Choose File → Save As from the menu or click on the Save As icon on the toolbar.
Choose the destination folder and name for your image. Also select the desired
output format (TIFF or ImageMaster format).
If a crop area was selected in the Scan mode, LabScan asks whether you want to
save only the selected area. Answer Yes or No.
Click OK when finished.
Send image to ImageMaster
Directly send a scanned image to the ImageMaster 2D Platinum software for
immediate gel analysis. To do so:
Choose File → Send to ImageMaster from the menu.
You are asked to save the file in .mel (ImageMaster) format.
Your gel automatically opens in the ImageMaster 2D Platinum software for
subsequent analysis.
Print images
To print scanned images:
Choose File → Print from the menu.
If a crop area was selected in the Scan mode, LabScan asks whether you want to
print only the selected area. Answer Yes or No.
The image prints in full size.
Please note that the image prints as it is displayed on the screen, retaining properties
such as contrast mapping and pseudo colors, etc.
17
INDEX
A
autoradiography ................................. 6
B
bending............................................. 12
blank filter ........................................... 6
blue filter ............................................. 6
browser............................................... 7
C
calibration ...................................3, 6, 7
control ............................................ 9
create ............................................. 7
display ............................................ 9
expiration........................................ 5
export graph ................................... 8
menu .............................................. 3
open ............................................... 8
print graph ...................................... 8
report.............................................. 8
reports ............................................8
save............................................6, 8
step tablet.......................................7
tablet file .........................................6
color filters ..........................................6
color palettes ....................................13
contrast mapping ..............................11
bending.........................................12
only in region ................................13
units..............................................13
control
calibration .......................................9
tablet file .........................................6
Coomassie..........................................6
copy to clipboard ................................9
create calibration ................................7
crop tool ........................................3, 14
cropping ............................................14
D
display calibration ...............................9
display saturation..............................15
dpi .......................................................6
19
INDEX
E
edit menu ........................................... 3
exiting LabScan ................................. 2
F
file menu............................................. 3
fitting report ........................................ 8
flip..................................................... 16
free rotate......................................... 16
G
gels
flipping ......................................... 16
rotating......................................... 16
general procedure.............................. 5
gray levels ........................................ 11
green filter .......................................... 6
H
hand tool ...................................... 3, 10
hardware requirements ...................... 1
help
menu.............................................. 3
on-line ............................................ 2
user manual ................................... 2
I
image
file size......................................... 10
information ................................... 10
menu.............................................. 3
print.............................................. 17
resolution ..................................... 10
save ............................................. 17
send to ImageMaster................... 17
size .............................................. 10
ImageMaster .................................... 17
installation .......................................... 1
intensity calibration ............................ 7
interface ............................................. 2
internet ............................................... 7
M
membranes ........................................ 6
menu bar ............................................ 3
mode .................................................. 5
P
percentage ....................................... 13
preview......................................... 3, 10
20
crop tool ....................................... 14
printing................................................ 7
pseudo colors................................... 13
R
red filter .............................................. 6
reflective mode................................... 5
region tool........................................... 3
reports
exporting ........................................ 9
printing ........................................... 9
saving............................................. 8
resolution............................................ 6
rotate ................................................ 16
rotation tool ........................................ 4
running LabScan ................................ 2
S
saturation.......................................... 15
save as ............................................... 3
save image ....................................... 17
scan.................................................... 3
scanner settings ................................. 5
scanning ........................................... 15
color ............................................... 6
crop tool ....................................... 15
mode .............................................. 5
resolution ....................................... 6
settings ............................................... 5
silver ................................................... 6
software requirements........................ 1
step tablet
control ............................................ 9
tool ................................................. 4
system requirements.......................... 1
T
tablet file ............................................. 6
toolbar ................................................ 3
transparent mode ............................... 5
U
undo ................................................. 16
units.................................................. 13
V
value................................................. 13
Z
zoom tool...................................... 3, 10
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement