CADMAX Solid Master

CADMAX Solid Master
Detailing Tutorial
Introduction
The CADMAX Solid Master Tutorial is a great way to learn about the benefits of feature-based
parametric solid modeling with CADMAX. In this tutorial, you will learn how to set up detail views and
add dimensions and notes to the drawing.
The tutorial assumes that you already have some familiarity with CADMAX. If you are unfamiliar with
CADMAX, review the Getting Started section first in CADMAX Help or in the CADMAX Users Manual.
Here are several additional suggestions before getting started:
!
In the tutorial, there are several conventions that are used with text. The text Draw > Circle >
Center Radius means to click on the Draw menu, hold the cursor over the Circle function until the
Circle sub-menu pops, then click on Center Radius.
!
Most functions are available through drop-down menus and icon tool bars. Throughout the
tutorials the written instructions tell you how to do things from the drop-down menus and the
icons to the left show you how to accomplish the same operation using icons. The first icon is the
icon to click on the main tool bar, and the second indented icon is the icon on the vertical function
bar.
< Locate this icon on the top tool bar and click on it.
< Then click on this icon on the vertical tool bar that pops up on the left side.
!
When you see a statement that starts with the word “set”, this means you are to set a modifier
value in the currently displayed Function box. For example, in the Line function box, you will see
a -Connect? modifier. When you see the statement, “Set -Connect? to off”, this means you
should set it off by clicking on the word Connect if it isn’t already off.
!
Sometimes you will be asked to set a specific value for a modifier. For example, in the Circle
Function box you will see a modifier called -Radius? with a combo box below it and a history
arrow. When you see the statement, “Set -Radius? to .25”, you should click in the -Radius? text
field and type in the value or use the history arrow to select previous value.
!
When an instruction includes an arrow key (6 7 8 9) followed by a number, hold down the Ctrl key
before pressing the specified arrow. For example, <Ctrl+6>1 means hold down the Ctrl key and
press 6, then release the keys and press 1. After you type in the value, press Enter.
!
Context sensitive prompts are available for each function in the message area at the bottom of the
screen. Help is available buy pressing F1.
CADMAX User's Manual
Solids Tutorial / 1
!
In the tutorial, we recommend when you should zoom in or out on the drawing to get better views
of your work. In addition to our recommendations, you should feel free to use the View menu or
the Quick View tool bar to zoom around the drawing as you feel is appropriate. Press F10 to go to
previous zooms or F11 to make a new zoom.
!
To load a specified drawing, press F4 to Open a drawing or click on File > Open. The drawings
that you will be asked to open are located in the \SAMPLES sub-folder under the folder that you
installed CADMAX.
2 / Solids Tutorial
CADMAX User's Manual
Detailing the Bracket
In this tutorial, you will learn how to set up orthogonal, isometric, sectional and partial detail views of
the bracket that was made in the first tutorial. Once the views have been established, you will learn how
to add horizontal, vertical, baseline, radial, angular dimensions and leaders to the views. You will also
learn how to make changes to the model and apply the revisions to the detail views.
CADMAX User's Manual
Solids Tutorial / 3
Establish Orthogonal and Isometric Views
In the following steps, you are going to set up
front, top, side, and isometric views for the
bracket.
1.
Open the drawing BRACKET.CXD
from the /SAMPLES folder which is a
subfolder under the folder you installed
CADMAX. This was the file you saved
in the first Solid Master tutorial. If you
didn’t save the file, you can also open the
drawing BRACKET_01.CXD.
2.
Click on Edit > Detailing or click on the
Detailing icon on the Ribbon bar.
This starts Detailing mode. The tool bars
and menus reconfigure themselves for
detailing operations.
We have already prepared this drawing
for detailing by including a border and
title block.
3.
Click on View > Show Window. Set the
-Windows Number? to ‘2' and click on
Finish. This displays a saved border and
title block.
One of the distinguishing features of
CADMAX Solid Master is that you can
maintain the model and detail drawings
in the same file. Of course, CADMAX
supports the more traditional method of
maintaining separate files for models and
details (not yet available in this beta
release), but we believe that for most
applications this approach adds a level of
complexity that isn’t necessary.
4 / Solids Tutorial
CADMAX User's Manual
4.
Click on 3DView > New to open the
Detail View function box. It contains all
of the settings you will need to establish
new view for detailing a model.
The first view is called a Base view, and it
can have any orientation. CADMAX
defaults the Relative Orientation to
Front since this is typically the first view
that is placed in a drawing.
5.
Drag the cursor into the work area. You
will see an echo of model which is
obviously too large for the border. In
the Detail View function box, set the
-Drawing Scale? to ‘.25'. Position the
view in the lower left and click to place
it.
Place the front view in
the lower left corner
Actually, the front view -Hidden Line
Mode? should have been set to
‘Hidden dashed’. We’ll fix this in a
couple of steps.
6.
First, add the top and side views. These
views will be based on the front view and
aligned to it. In the Detail View function
box, set:
• View Type to ‘Relative’
• Relative Orientation to ‘Top’
-Parent View? automatically defaults to
‘By Touch’ and -Aligned to Parent? is
checked. The By Touch setting permits
you to click on the view that the next
view will be related to. Or, you can select
the Parent View from the drop down list.
CADMAX User's Manual
Solids Tutorial / 5
7.
Wave the cursor over the front view.
You will see its outline echo. Click
anywhere in the view to identify it as the
Parent View.
8.
Drag the cursor up. Since -Aligned to
Parent? is checked, the top view stays
vertically aligned to the Parent View.
Click to place the top view.
9.
Set -Relative Orientation? to ‘Right’.
Drag the cursor to the right. Since
-Aligned to Parent? is checked, the right
view stays horizontally aligned to the
Parent View. Click to place the right
view.
Top and right views
are aligned to the front
Note: It wasn’t necessary to identify the
parent view again. Once the top view
was placed, the -Parent View?
automatically updated to the view name
for the Front view.
10. In the final step, add the isometric view
and make it larger than the orthogonal
views. Set:
• Relative Orientation to ‘Iso Top-Right’
• Hidden Line Mode to ‘Hidden Line’
• Drawing Scale to ‘.4'
Note: -Aligned to Parent? grays since an
isometric can’t be aligned. The -View
Name? automatically increments for each
new view, or you can assign your own
view name.
6 / Solids Tutorial
CADMAX User's Manual
11. Drag the cursor to the upper right.
Click to place the isometric view.
12. In the next step, fix the Hidden Line
Mode for the Front view. Click 3DView
> Edit View. Leave -View? set to ‘By
Touch’ and click on the front view to
open the Edit View function box.
13. The Edit View function box shows the
properties of the front view. Those
settings that cannot be changed are
grayed. Set -Hidden Line Mode? to
‘Hidden dashed’ and click Finish to
update the front view to be Hidden
dashed.
14. Edit View can also be used to change
the view scale. The front view is part of
a family of related views. When its scale
is changed the scale for any related
views will also change.
When one view is changed,
the drawing scale changes
for all related views
Click on the front view to open the Edit
View function box. Set -Drawing Scale?
to ‘.4' and click Finish. The scale for the
top and right views also changes along
with the front view.
15. Use Edit View to set the -Drawing Scale?
back to ‘.25' or use Undo.
CADMAX User's Manual
Solids Tutorial / 7
Create a Sectional View
In the following steps, you are going to set up
a sectional view which will be based off of the
top view.
1.
Click File > Save or press Ctrl + F12 to
save your work.
2.
Zoom in on the top view.
3.
Click Edit > Sketch. When a sketch is
started in detailing mode, a reference
point must be defined by clicking a point
on the geometry in the view in which
geometry is added. The reference point
creates a relation between the model and
the sketch. If the model is changed, the
sketch geometry will maintain its
relationship to the model.
4.
Click Center snap on the Quick Snap tool
bar then click on one of the .5 radius
circles on the top of the object. Notice
that the full screen cross-hair snaps to the
center of the circle before you click.
5.
Click on Draw > Sketch Line. Wave the
cursor over one of the circles, once a
horizontal construction line pops up,
draw a line through the model as shown.
8 / Solids Tutorial
CADMAX User's Manual
6.
Click on Draw > View Arrow. The View
Arrow function box contains a series of
modifiers that can be used to set the
appearance of the section line arrow. In
this demonstration you will use the
default settings.
7.
Wave the cursor over one side of the
section line. If the view arrow is in the
up direction, click to place the arrow.
You can change the view arrow direction
by clicking on the other side of the
section line first or by checking
-Right Side Arrow? in the View Arrow
function box.
8.
Click on the other side of the line to add
the other view arrow.
9.
Use Previous in the Quick View tool bar
or press F10 to zoom out to the full
border. Click on 3DView > New. The
New View function box opens and
defaults to ‘Sectional’. Check -Align to
Parent?.
10. Click on Hatch Pattern to set the crosshatch. Set:
• Angle to ‘45'
• Spacing to ‘.5'
• Pattern to ‘Normal’
• Cross Attribute isn’t used when
-Pattern ? is set yo ‘Normal’
11. Click Return to return back to the New
View function box.
CADMAX User's Manual
Solids Tutorial / 9
12. Click above the top view to place the
sectional view.
Insert sectional view
above top view with
Align to Parent
checked
Create a Partial Detail View
In the following steps, you are going to set up
a detail view which will be based off of the
isometric view.
1.
Click File > Save or press Ctrl + F12 to
save your work.
2.
Zoom in on the isometric view.
3.
Click Edit > Sketch. When a sketch is
started in detailing mode, a reference
point must be defined by clicking a point
on the geometry in the view in which
geometry is added. The reference point
creates a relation between the model and
the sketch. If the model is changed, the
sketch geometry will maintain its
relationship to the model.
4.
Click on the point shown in the figure as
the reference point.
10 / Solids Tutorial
CADMAX User's Manual
5.
Click on Draw > Rectangle > Two
Corners. In the Ribbon bar set the
-Attribute Name? to ‘phantom’. Click on
a corner point for the rectangle, drag the
cursor diagonally and click on the
opposite corner point as shown in the
figure.
6.
Use Previous in the Quick View tool bar
or press F10 to zoom out to the full
border. Click on 3DView > New. The
New View function box opens and
defaults to ‘Partial’. Set -Drawing Scale?
to ‘1'.
7.
Click below the isometric view to place
the partial detail view.
Partial detail view
8.
Use the remaining open area to add your
own views. Then save your work.
CADMAX User's Manual
Solids Tutorial / 11
Adding Dimensions
CADMAX supports linear, radial, angular, baseline (ordinate), skewed and chained
dimensions. You can set dimension modifiers as you work by changing settings prior to
anchoring the dimension in the work area. Each dimension includes two function boxes of
modifiers. You can switch between each function box by clicking on Page 1 or Page 2 at the
bottom of the function box. As you make modifier changes, the dimension automatically
echoes these changes. In addition to the modifiers in the function boxes, you can also set
-Level?, -Geometry Attribute?, and -Text Attribute? in the Ribbon bar.
Shown below are the function boxes for Horizontal Linear dimensions. The modifiers that
change most frequently are displayed in the initial function box that appears when the
dimension is started. The initial function box is similar for all dimension types with minor
variations for the type of dimension. The second function box is identical for all dimension
types. You can get a complete explanation of each modifier in CADMAX Help under
Dimension Modifiers.
12 / Solids Tutorial
CADMAX User's Manual
Adding Horizontal and Vertical Linear Dimensions
The following steps will show you how to add
several linear dimensions to the front view.
Then you can go ahead and add additional
dimensions on your own.
1.
Zoom in on the front view allowing
enough room around the view to add
dimensions.
2.
Click on Dimension > Horizontal. Set
the following modifiers:
• Centered to checked
• Arrow Position to ‘Inside’
• Line Type to ‘Broken’
3.
As shown in the figure, click on points P1
and P2 or click on the lines near the
points. A dimension point will pop-up on
the display showing which location will be
snapped to. Drag the cursor to position
the text and click to place the dimension.
4.
As shown in the figure, click on points P3
and P4 or click on the lines near the
points. As you drag the cursor to
position the text you’ll notice that the
text and arrows are too large for the
measured area. In the Horizontal
function box, set:
P4
P3
• Centered to unchecked
• Arrow Position to ‘Outside’
Position the text and click to place the
dimension.
CADMAX User's Manual
Solids Tutorial / 13
5.
Click on Dimension > Vertical and add
the dimensions shown in the figure,
adjusting the modifiers as needed.
6.
In the next vertical dimension, only one
extension line is needed. Use the
-Extension Lines? modifier to control
which extension lines are displayed.
When it is set to ‘1st’, this means that
only the first extension line will display.
The first dimension line is defined by the
first dimension point that is clicked.
P1
P2
As shown in the figure, click on points P1
and P2. Set -Extension Lines? to ‘1st’.
Drag to position the text and click to
place the dimension.
7.
In the next vertical dimension, the text is
going to be aligned to the dimension. Set
-Text Alignment? to ‘Aligned’ and add
the dimension shown in the figure.
Remember to make use of the Extension
Lines setting.
14 / Solids Tutorial
CADMAX User's Manual
8.
The dimension line of the 2.00 horizontal
dimension interferes with the dimension
just inserted. One of the dimensions has
to be moved.
Right-click to display the pop up menu
and click on Move Dimension. Wave the
cursor over one of the dimensions until it
highlights and click on the dimension.
Drag the dimension to a new location
and click to place it.
Adding Radial Dimensions
1.
Zoom in on the top view allowing enough
room around the view to add
dimensions.
2.
Click on Dimension > Radial. Set the
following modifiers:
• Type to ‘Radius’
• Make Centered unchecked
• Arrow Position to ‘Outside’
• Text Alignment to ‘Horizontal’
3.
As shown in the figure, add the three
dimensions. Wave the cursor over the
arc until the dimension echo pops up,
then click on the arc. Drag the cursor to
position the text and click to place the
dimension.
4.
Click on Previous in the Quick View tool
bar or press F10 to zoom out to the full
detail drawing. Then zoom in on the
isometric view and click on Resume to
return back to Radial dimension.
CADMAX User's Manual
Solids Tutorial / 15
5.
In the Radial Dimension function box,
make -Use View Plane? unchecked.
When -Use View Plane? is unchecked,
then the plane of the radius is used to
calculate the radius and the dimension
geometry is placed on the plane of the
radius. When -Use View Plane? is
checked, the radius must be parallel to
the view, otherwise, no dimension will be
calculated.
6.
As shown in the figure, add the five
dimensions to the isometric view. Wave
the cursor over the arc until the
dimension echo pops up, then click on
the arc. Drag the cursor to position the
text and click to place the dimension.
When you are ready to insert the 2.20
radius arc, set -Text Alignment? set to
‘Aligned’. This places the text on the
plane of the arc.
Adding Linear Dimensions to Isometric Views
Linear dimensions in orthogonal views
calculate distance using the plane of the view
on which the dimension is placed. In
isometric views, the work plane for the
dimension must be defined in order to
calculate the correct distance.
1.
Click on Work Plane > Set Method. In
the Work Plane function box, set the
-Method? to ‘3 Points’ and -Adjustment?
to ‘None’. You will use 3 points to
define the work plane. Click on point P1,
P2, P3 to set the origin, a point on the X
axis and then a point on the Y axis.
Notice that the view axis changes based
on the 3 points.
16 / Solids Tutorial
P3
P2
X
Y
P1
CADMAX User's Manual
2.
Click on Dimension > Horizontal. Set
the following modifiers:
P2
• Centered to checked
• Arrow Position to ‘Inside’
• Line Type to ‘Broken’
• Text Alignment to ‘Aligned’
• Extension Lines to ‘None’
• Use View Plane to unchecked
In linear dimensions, when -Use View
Plane? is unchecked, the dimension is
calculated from the current work plane.
3.
As shown in the figure, click on points P1
and P2 or click on the lines near the
points. A dimension point will pop-up on
the display showing which location will be
snapped to. Drag the cursor to position
the text and click to place the dimension.
4.
The next dimension is going to be aligned
to the back plane, which is parallel to the
front view. Click on Work Plane > Set
Method. In the Work Plane function
box, set the -Method? to ‘Front’ and
-Adjustment? to ‘None’. Click anywhere
on the geometry to set the work plane
origin point and orient the plane parallel
to the front view.
5.
P1
Y
X
Click on Dimension > Horizontal and
leave the modifiers as they were set. As
shown in the figure, click on points P1
and P2 or click on the lines near the
points. Drag the cursor to P3 and click
on the arrowhead of the 10.00 dimension
to place the dimension aligned to the
10.00 dimension.
CADMAX User's Manual
Solids Tutorial / 17
6.
The next dimension is going to be aligned
to the bottom plane, which is parallel to
the top view. Click on Work Plane >
Set Method. In the Work Plane function
box, set the -Method? to ‘Top’ and
-Adjustment? to ‘None’. Click anywhere
on the geometry to set the work plane
origin point and orient the plane parallel
to the top view.
7.
Click on Dimension > Horizontal and
change -Extension Lines? to ‘Both’. As
shown in the figure, click on points P1
and P2 or click on the lines near the
points. Drag the cursor and click to place
the dimension.
P1
P2
18 / Solids Tutorial
CADMAX User's Manual
Adding Baseline Dimensions
Baseline dimensions require a 0,0 point.
Before starting a baseline dimension, use the
Set Base Point function to define the origin
point. Then use Horizontal and Vertical
dimensions to calculate distances from the
0,0 point.
1.
Click on Previous in the Quick View tool
bar or press F10 to zoom out to the full
detail drawing. Then zoom in on the side
view.
Here’s another way you can zoom to the
full detail view. Click View > Show
Window, set the -Window Number? to ‘2'
and click Finish.
2.
Click on Dimension > Set Base Point.
Click on the lower left point of the side
view.
3.
Click on Dimension > Vertical, check
-Baseline? and -Use View Plane?. As
shown in the figure, add the five baseline
dimensions. Start with the 0.0 dimension
by clicking on the 0,0 point, drag the
cursor to position the text and click to
place the dimension. For each
succeeding dimension, click on the
dimension point then click on the
extension line endpoint of the previous
dimension to make the text line up
vertically.
CADMAX User's Manual
Solids Tutorial / 19
4.
Click on Dimension > Horizontal and set
-Text Alignment? to ‘Aligned’. As shown
in the figure, add the five baseline
dimensions. Start with the 0.0 dimension
by clicking on the 0,0 point, drag the
cursor to position the text and click to
place the dimension. For each
succeeding dimension click, on the
dimension point then click on the
extension line endpoint of the previous
dimension to make the text line up.
Adding Angular Dimensions
Angular dimensions are calculated by clicking
on two lines to measure the angle from.
Calculations are performed counterclockwise.
Sometimes it may be necessary to add
construction geometry to calculate and angle.
1.
Click on Dimension > Angle. Check
-Centered? and set -# Decimal Places?
to ‘0'.
2.
Click on the two lines indicated in the
figure in a counterclockwise direction
and click to place the dimension.
In angular dimensions, it usually isn’t
necessary to set the -Extension Lines?.
CADMAX automatically calculates
which dimension lines are required.
20 / Solids Tutorial
CADMAX User's Manual
Updating Detail Views
Detail views and dimensions update when
changes are made to the model. Use the
following steps to change the model and then
update the detail views.
1.
Click on Show Window in the Quick
View tool bar. Set -Window Number? to
‘1' and click Finish.
In this drawing, Window Number 1 was
defined to be the model views. Windows
2, 3, and 4 are setup as borders, so detail
views may be added to them.
2.
Click Edit > Feature Modeling or click
on 3D at the bottom of the feature tree.
3.
Make a change to the model. For
example, double-click on Base1 to display
the variable table for the feature.
Change the value of D1 from 16.00 to
20.00.
4.
Click Feature > Rebuild to rebuild the
model using the new value for D1.
5.
Click Edit > Detailing or click on 2D at
the bottom of the feature tree.
6.
Click on Show Window in the Quick
View tool bar. Set -Window Number? to
‘2' and click Finish to switch to the detail
views.
7.
Click on the Update Detail Views icon on
the main tool bar.
CADMAX User's Manual
Solids Tutorial / 21
Inserting Leaders
Leaders are placed in the drawing using the
Leader command. There are many different
options for the type of leader to construct. It
supports standard leaders, balloons, prefix
and suffix text, automatic text increments,
and user notes. The prompts for Leader vary
depending on the type of leader and options
specified.
The following leader types are available:
•
Simple Leader - Leader with a single
elbow.
•
Advanced Leader - Leader with optional
multiple leader lines and more control
over the arrow and extension.
•
Leader - Typed Notes - Leader with text.
Text is entered by the user once the
leader has been defined.
•
Balloon - Leader with balloon. Text is
centered inside the balloon with prefix,
suffix, and automatic increments.
22 / Solids Tutorial
CADMAX User's Manual
•
Balloon with Bar - Leader with balloon
and bar with two lines of text. The top
line contains a prefix, suffix, and
automatic increments. The bottom line
is fixed text.
•
User text - Text only, no leader.
•
Standard Notes - Text only of standard
notes from a list of user-defined notes.
•
Leader - Std Notes - Leader with
standard notes from a list of user-defined
notes.
The type of leader is set in -Leader Style?
Additional user-defined leaders can be
added. See CADMAX Solid Master Help.
1.
Zoom in on one of the views.
2.
Click on Dimension > Leader. Set
the-Leader Style? to ‘Simple Leader’.
Leave the other modifiers at their default
settings.
3.
Click on geometry in the view, then click
on the leader elbow point, then click on
the extension line point to form the
leader.
CADMAX User's Manual
Solids Tutorial / 23
4.
If the start point of the leader is not on
geometry, then a reference point is
required in order to position the leader
relative to the geometry.
Check -Ask for Reference?. Click on
geometry to define a reference point,
then click the arrowhead, elbow and
extension line point. In this example, the
leader will maintain its position relative
to the reference point.
5.
Set -Leader Style? to ‘Balloon’. The
function box dynamically reconfigures for
the Balloon style leader. Set the
modifiers as follows:
• Arrow Size to ‘.3'
• Number of Lines to ‘1'
• Balloon Style to ‘Circle’
• Number of Balloons to ‘1'
• Balloon Size to ‘.75'
• Balloon Fit Method to ‘adjust_text’
• Label to ‘B1-1'
• Text Geom Attribute to ‘object’
• Text Attribute to ‘½' (on Ribbon bar)
• Make Ask for Reference unchecked
6.
As you position the cursor in the work
area, you will see an echo of the balloon.
Since -Ask for Reference? is unchecked,
click on geometry for the arrowhead,
drag the balloon and click to place the
leader.
24 / Solids Tutorial
CADMAX User's Manual
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement