Table With Excel – TWE 2.0 User Manual

Table With Excel – TWE 2.0 User Manual
Table With Excel – TWE 2.0
User Manual
COPYRIGHT © 2005-2009, ZHANSHAN DONG
-i-
TABLE OF CONTENTS
INTRODUCTION TO TWE 2.0............................................................................................................ 1
Main features ...............................................................................................................................1
SOFTWARE INSTALLATION ............................................................................................................... 2
Hardware and software requirements ..........................................................................................2
Install TWE from setup file .........................................................................................................2
Microsoft .Net Framework Redistribution Package ....................................................................2
QUICK START................................................................................................................................... 3
Start the application .....................................................................................................................3
Context menu ...........................................................................................................................3
An overview of the TWE functions .............................................................................................4
Splitting and merging tables ....................................................................................................4
Transposition of tables.............................................................................................................4
Working with duplicates, column format and worksheet name ..............................................4
Other functions.........................................................................................................................5
An overview of a typical TWE dialog .........................................................................................5
WORKING WITH DATA FORMAT ........................................................................................................ 8
Overview......................................................................................................................................8
Convert data format to numeric ...................................................................................................9
Convert data format to text ..........................................................................................................9
Convert data format to date........................................................................................................10
MANIPULATION OF DUPLICATE ROWS ............................................................................................ 11
Overview....................................................................................................................................11
Mark duplicate rows ..................................................................................................................12
Extract unique rows ...................................................................................................................13
Extract duplicate rows................................................................................................................14
MERGING AND SPLITTING TABLE ................................................................................................... 16
Split table ...................................................................................................................................16
Overview................................................................................................................................16
Example .................................................................................................................................17
Extract table ...............................................................................................................................18
Overview................................................................................................................................19
Example .................................................................................................................................20
Stack tables ................................................................................................................................21
Overview................................................................................................................................21
Example 1: Simple stack........................................................................................................23
Example 2: Stack by matching column titles.........................................................................25
Join tables...................................................................................................................................27
Overview................................................................................................................................28
Example: Match one column and copy a different column ...................................................29
TABLE TRANSPOSITION .................................................................................................................. 31
Table to list ................................................................................................................................31
Overview................................................................................................................................31
Example .................................................................................................................................32
-iiList to table ................................................................................................................................33
Overview................................................................................................................................34
Example .................................................................................................................................34
List to counts..............................................................................................................................36
Overview................................................................................................................................36
Example .................................................................................................................................37
ADDITIONAL FUNCTIONS................................................................................................................ 40
Show Excel status ......................................................................................................................40
Open Excel files.........................................................................................................................40
Rename worksheets in batch......................................................................................................41
Help............................................................................................................................................41
About TWE................................................................................................................................41
Q&A.............................................................................................................................................. 43
Software version ........................................................................................................................43
Report bugs ................................................................................................................................43
-1-
INTRODUCTION TO TWE 2.0
Microsoft Excel is very popular spreadsheet software. It is widely used in education,
in scientific research, in managing financial activities. Nowadays, the common
versions of Microsoft Excel are version 2000 and 2003. The functions of these
versions are very powerful and include enormous functions and possibilities.
Scientists and engineers use Microsoft Excel to record and keep observed data. And
further use Excel to summarize and analyze these data. During the data processes
manipulation of tables, such as merging tables, splitting tables, eliminating duplicates,
format conversion and so on, is an indispensable activity.
And more, Excel users in financial institutions use Excel to hold financial information
in addition to their central database. Even they use Excel to do some financial
analyses, risk evaluation and so on. All in all, Excel is one of common software
package used daily in financial institutions. The users also encounter the table
manipulation problem.
Table manipulation is a common issue for all Excel users. So, how to help Excel
users automate the table manipulation? How can we release Excel users from the
tedious activities? This is the initial motivation to develop Table with Excel (TWE).
The goal is to create a running fast, easy to use, and flexible Windows .NET
application.
Table with Excel (TWE) can help Excel users at all levels to deal with tables. The
functions TWE provides can be broken to four groups. The first group includes four
functions related to merging and splitting tables. They are Split a table, Extract a
table, Stack tables and Join tables. The second group includes functions related to
transposition of tables, that is, conversion of horizontal tables to vertical tables and
vice versa. They are Table to list, List to table, and List to counts. The third group
includes a function to handle duplicates, format columns and rename worksheets in
batch. The forth group includes all other functions related to open Excel files, display
Excel status, open the TWE PDF help file, show TWE version and copyright
information, and quit the application.
TWE is developed based on Microsoft .NET Framework. It is a standalone Windows
application. TWE application icon stays in the Windows system tray once it starts.
All functions will be explained in detail in this manual. Most time one or two
examples will be presented to demonstrate the functionality of each function.
Main features
•
Format tables
•
Split/Merge tables
•
Transpose tables
•
Manipulate duplicates
•
Other auxiliary functions
-2-
SOFTWARE INSTALLATION
Hardware and software requirements
Hardware:
1) IBM Compatible PC
2) Intel Pentium 4 and equivalent
3) Hard disk space: 5 MB
Software:
1) OS: Windows 2000/XP/Vista or later version
2) .NET: Microsoft .Net Framework redistribution package up to version 3.5
3) Microsoft Excel 2000/2003/2007 or later version
Install TWE from setup file
TWE is a green software, all files are packed into a zip file. After you download the
zip file, all you have to do is to unzip the file to a folder you choose and then make a
shortcut to point to twe.exe file in the folder. Then you can use it with no problem. To
put a shortcut to Desktop, select the twe.exe first and right click the mouse to open
the context menu and select “Send To” -> “Desktop (create shortcut)”. You are all
set now.
Microsoft .Net Framework Redistribution Package
This application is a .Net application. It needs Microsoft .Net to run. After you install
the program, you should make sure that your machine has Microsoft .Net Framework
Redistribution Package installed. If not, please go to www.microsoft.com to
download the Microsoft .NET Framework Redistribution Package latest version.
If this link does not work, please visit www.microsoft.com and search for ".Net
Framework" and follow relevant link(s) to download Microsoft .Net Framework
redistribution package.
-3-
QUICK START
Start the application
To start TWE, you can
Click the TWE icon
on your desktop;
Once TWE is started, a dialog window (Figure 1) shows the software version,
copyright, web address, and license information of the TWE application. If you have
registered your copy and have a license code, please enter your license code by click
“Enter” button in this window. If you do not have a license code, please click
“Register” button to visit http://www.sunfinedata.com/twe/register.html and register
your copy of TWE based on your needs.
Figure 1
If an instance of TWE is running, you will get a message say: The application is
already running! (See Figure 2)
Figure 2
Context menu
When TWE is running its icon
stays in the Windows system tray. In Figure 3 the
first application icon on the left is the TWE icon. A context menu (see Figure 4) pops
up by right clicking the icon. From the context menu you can access all TWE
functions. An overview of the TWE functions is provided in the next sections.
Figure 3
-4-
Figure 4
An overview of the TWE functions
Splitting and merging tables
All four functions in this category are related to splitting large tables into small tables
or merging small tables into a large one.
Split a table: Split a large table to small ones according to criteria you create.
Extract a table: Extract rows from a large table based on criteria you create and form
a new table.
Stack tables: Stack (merge) as many tables as you want to a large table. You can
choose to simply stack tables and stack tables by match column titles.
Join tables: Join (merge) data from two tables based on match criteria you create.
Transposition of tables
All three functions in this category are related to reshape the Excel tables.
Table to list: Transpose a horizontal table into a vertical list by straightening selected
columns.
List to table: Transpose a vertical list to a horizontal table by splitting a selected
value column based on a selected title column.
List to counts: Transpose a vertical list to a horizontal table filled with counts of
items appearing in a selected column.
Working with duplicates, column format and worksheet name
Handle duplicates: Mark and extract duplicate or unique rows based on a set of
selected columns or all columns in a table.
-5Format columns: Convert data format of the selected columns in batch. The function
is more powerful and convenient than “Text to columns” in the Tools menu of
Microsoft Excel.
Rename worksheets: Rename worksheets in batch. It largely improves the worksheet
rename function that Microsoft Excel provides.
Other functions
Open Excel files: It is similar to the Excel open file function.
Excel information: It simply shows the current status of Microsoft Excel.
Help: It opens the TWE help files.
About: It shows information of the TWE application. You can use this dialog
window to enter your license code.
Quit: By clicking this menu item, the TWE application will quit completely.
An overview of a typical TWE dialog
Most of the TWE dialog windows share similarities. To avoid redundant description
of TWE dialog windows, a general description of a typical TWE dialog window is
given below. Figure 5 is a typical TWE dialog window that includes four functional
areas.
A
B
C
D
Figure 5
Functional area A (Worksheets Area) is used to select workbooks, worksheets, and
column title row and selected range and display currently selected data range
information.
-6If an instance of Microsoft Excel is not running before a function is executed, a new
instance of Microsoft Excel will be started and a blank Excel window will pop up. If
an instance of Microsoft Excel is already running, the workbook dropdown list(s) is
filled with all available workbooks. The active workbook is selected automatically.
The worksheets dropdown list is filled with all available worksheets of the current
selected workbook. The active worksheet is selected in the worksheets dropdown
box.
By default, the two check boxes are not selected. Based on your situation, you can
select one or both of them. By selecting “Without head row” check box, TWE fills
corresponding column list boxes with column titles in “Column A” format (see Figure
6).
Figure 6
By default, TWE automatically use the used range in the selected worksheet as data
range. You can manually select a range and check the “Selected range” check box.
Then TWE will use the range you select (see Figure 7). This dramatically increases
the flexibility of the software.
There is a “Refresh” button in this area. If there are workbooks created or opened
after the dialog window is opened, you have to click this button to update the
“workbook” dropdown list. Otherwise TWE does not know there are new workbooks
available or workbooks closed. So you should click the “Refresh” button whenever
available workbooks changes.
In addition, some dialog windows include a textbox that allows users to enter a sheet
name. The user-provided name will be used to name the new sheet created by the
function.
-7-
Figure 7
Functional area B (Column Area) is used to select copy columns, filter columns,
matching criteria and so on. There are a lot of variations in this area. Most dialog
windows have copy columns. Some dialog windows have filter columns. We will
give detail description of this area when we introduce individual functions.
Functional area C (Time Area) is used to display data processing time. It shows start
and end time in HH:MM format and total time duration in seconds. Once data process
is complete, processing time will show in this area. Therefore, it tells you that the
program has completed data process when all three fields are filled. This is one way
to know whether the program is processing data.
Functional area D (Button Area) includes buttons. It usually includes “Ok” and
“Close” buttons. Click the “Ok” button to trigger the data processing. Click the
“Close” button to close the dialog window.
TWE has several message windows. Figure 8 shows a very popular one. It will pop
up whenever there are not enough data rows in the selected data range. What you can
do is to either select a different worksheet with enough data or select a large range of
data in the current worksheet. TWE will not allow you do any thing if you do not
select enough data. Other message windows only show up in specific situations. We
will describe them in appropriate sections.
Figure 8
-8-
WORKING WITH DATA FORMAT
It is not uncommon that Excel files include data in text format even though the values
are numeric. The text format of numeric values is usually generated by applications
other than Microsoft Excel. If you want to manipulate these data numerically, Excel
does not have any response. In these situations, you have to turn to the “Text to
column” function in the “Data” menu of Microsoft Excel. You can use this function
convert your data in text format into numeric format column by column. Of course, it
is easy to write a VBA subroutine to do the tedious, repeated work. However, VBA is
relatively slow comparing with other compiled executable applications. TWE
provides a complete solution to solve the issue. You can convert the data format from
text to numeric and vice versa.
Overview
Click “Format columns” menu item in the TWE context menu to open the Format
columns dialog window (see Figure 9).
Figure 9
Worksheets area allows you to select a workbook from available workbook list and
a worksheet from the selected workbook. It also allows you optionally to select
“Without head row” and “Selected range”. The available data range in the A1 format
is shown at the bottom of the Worksheets area. There is a “Refresh” button in this
frame. If there are workbooks created or opened after the dialog window is opened,
you have to click this button to update the “workbook” dropdown list.
Column area includes two parts: “Columns to be formatted: and “Format to”.
“Columns to be formatted” list box allows you select columns that you want to
convert their format. You can select one or more columns. That totally depends on
your needs. The “Format to” frame includes three exclusive options: Numeric, Text
and Date and a dropdown list box. The dropdown list box is only enabled when the
-9“Text” option is selected. The dropdown list includes three items: Do nothing, Upper,
Lower. It provides a way to convert any text in the selected columns to the upper or
lower case.
If the column(s) you select has merged cells that span more than one column, you
could receive the following error message (Figure 10). Just simply click the Ok
button to continue your work.
Figure 10
Convert data format to numeric
To convert data format to Numeric format, the detailed steps are the following. The
completed “Format columns” dialog window is similar to Figure 9.
1) Right click the TWE icon in the system tray area
2) Click “Format columns” from the TWE context menu to open the “Format
columns” dialog window
3) Select a workbook and a worksheet that you want to work with
4) Select one or more columns in the “Columns to be formatted” list box
5) Choose the “Numeric” option in the “Format to” frame
6) Click the “Ok” button to convert the selected columns to numeric format
Convert data format to text
To convert data format to Text format in upper case, the detailed steps are the
following. The completed “Format columns” dialog window is similar to Figure 11.
1) Right click the TWE icon in the system tray area
2) Click “Format columns” from the TWE context menu to open the “Format
columns” dialog window
3) Select a workbook and a worksheet that you want to work with
4) Select one or more columns in the “Columns to be formatted” list box
5) Choose the “Text” option in the “Format to” frame
6) Select “Upper” in the letter case dropdown list
7) Click the “Ok” button to convert the selected columns to text format in upper case
-10-
Figure 11
Convert data format to date
To convert data format to Date format, the detailed steps are the following. The
completed “Format columns” dialog window is similar to Figure 12.
1) Right click the TWE icon in the system tray area
2) Click “Format columns” from the TWE context menu to open the “Format
columns” dialog window
3) Select a workbook and a worksheet that you want to work with
4) Select one or more columns in the “Columns to be formatted” list box
5) Choose the “Date” option in the “Format to” frame
6) Click the “Ok” button to convert the selected columns to Date format.
Figure 12
-11-
MANIPULATION OF DUPLICATE ROWS
A large number of people use Microsoft Excel to manage their database. They keep a
lot of information in different spreadsheets. Since Excel does not have appropriate
mechanisms to avoid redundant data in a spreadsheet. It is not uncommon that there
are duplicate rows in a spreadsheet. If a spreadsheet only includes dozens of rows, it
is easy to eliminate redundant rows by carefully check and compare values in
different rows. But when a spreadsheet includes thousands of rows, the job becomes
tedious and prone to errors. TWE provides a powerful tool to deal with problems
related to duplicate rows.
Overview
From the TWE context menu click “Handle duplicates” to open the “Handle
duplicates” dialog window, see Figure 13.
Worksheets area lets you select a workbook and a worksheet from the selected
workbook. You also have the flexibility to select with or without column title row and
current used range or selected range as data for processing. Once you make all these
choices, the data range will show in the A1 format.
Column area includes two parts. The “Copy Columns” list box on the left allows you
select columns to be copied to the new worksheet. The “Filter Columns” list box on
the right allows you select columns serving as filters. In other word, only will the
selected columns in the “Filter Columns” list box be used to find duplicate rows. If
there are data rows available in the selected worksheet, the columns in the “Copy
Columns” list box and the “Filter Columns” list box will be automatically selected.
Output area has three check boxes: mark duplicate rows, extract duplicate rows and
extract unique rows. Depending what you want to pursue, you can select one or more
of three options.
-12-
Figure 13
Mark duplicate rows
Figure 14 is a contact list. There are duplicate names in the list. We want to highlight
the duplicate entries in the list.
Figure 14
Here are the steps:
1) Right click the TWE icon in the system tray area
2) Click “Handle duplicates” from the TWE context menu to open the “Handle
duplicates” dialog window
3) Select the “Table_Examples.xls” workbook in the workbook dropdown list box
4) Select the “DuplicateRows” worksheet in the worksheet dropdown list box
5) Select all columns in the “Copy Columns” list box;
6) Select “Name” and “Phone” columns in the “Filter Columns” list box. That means
we consider a row is duplicate row if its values in the “Name” and “Phone”
column are identical to those of another row appearing before it
7) Select “Mark duplicate rows” and deselect other checkboxes in the Output frame.
The completed dialog window looks like Figure 15.
8) Click the “Ok” button to proceed. After the all fields in the time area filled, the
contact list looks like Figure 16.
-13-
Figure 15
Figure 16
You should be aware that the values in the mobile column are different for the two Julie entries.
Even though the second Julie entry was still highlighted. The reason for that is we only used the
first two columns (Name and Phone) as the filter columns. If we use all columns as filter
columns, we will not find any duplicate rows.
Extract unique rows
Very often is it necessary to extract all unique rows from a table with duplicate rows.
TWE provides a complete solution for this purpose. Here are the detailed steps:
1) Right click the TWE icon in the system tray area
2) Click “Handle duplicates” from the TWE context menu to open the “Handle
duplicates” dialog window
3) Select the “Table_Examples.xls” workbook in the workbook dropdown list box
4) Select the “DuplicateRows” worksheet in the worksheet dropdown list box
5) Select all columns in the “Copy Columns” list box;
6) Select “Name” and “Phone” columns in the “Filter Columns” list box;
7) Select “Extract unique rows” and deselect other checkboxes in the Output frame.
The completed dialog window looks like Figure 17.
8) Click the “Ok” button to proceed. After the all fields in the time area filled, the
newly generated unique contact list looks like Figure 18.
-14-
Figure 17
Figure 18
Extract duplicate rows
If you want to know exactly what information is redundant in a table, the best way is
to extract all duplicate information and put into a new table. Then you can check them
in detail. TWE provides a complete solution for this purpose. Here are the detailed
steps:
1) Right click the TWE icon in the system tray area
2) Click “Handle duplicates” from the TWE context menu to open the “Handle
duplicates” dialog window
3) Select the “Table_Examples.xls” workbook in the workbook dropdown list box
4) Select the “DuplicateRows” worksheet in the worksheet dropdown list box
5) Select all columns in the “Copy Columns” list box;
6) Select “Name” and “Phone” columns in the “Filter Columns” list box;
7) Select “Extract duplicate rows” and deselect the other check boxes in the Output
frame. The completed dialog window looks like Figure 19.
8) Click “Ok” button to proceed. After all fields in the time area filled, the newly
generated duplicate list looks like Figure 20.
-15-
Figure 19
Figure 20
Some other software requires that tables with duplicate rows should be sorted first. TWE can
handle duplicates efficiently in an unsorted table. So it is not necessary to sort tables you are
working with first and then apply appropriate TWE functions to it.
-16-
MERGING AND SPLITTING TABLE
When we use Excel to process data we often come across the following situations.
For example, large tables need to be broken into several small tables according to a
set of rules or criteria. And furthermore, merging two or more tables together to
generate a large one is also very common. Microsoft Excel does not provide
appropriate tools to solve these difficult situations. What can we do now? Many Excel
users usually turn to VBA macros. The problem related to VBA macros is slow
speed, limited control, and so on. TWE provide a suite of solutions to solve all these
situations. TWE provides two functions related to splitting tables and other two
related to merging tables.
Split table
This function provides a solution for splitting a large table to many small ones based
on a set of user-defined criteria.
Overview
From the TWE context menu click “Split a table” to open the “Split table” dialog
window, see Figure 21.
Figure 21
Worksheets area allows you select a workbook and a worksheet from the selected
workbook. You also have the flexibility to select with or without column title row and
current used range or selected range as data for processing. Once you make all these
choices, the data range will show in the A1 format.
-17Column area includes two parts. The “Copy Columns” list box on the left allows you
to select columns to be copied to the new worksheet. The “Filter Columns” list box
on the right allows you select columns serving as filters. If there are data rows
available in the selected worksheet, all columns in the “Copy Columns” list box and
the first column in the “Filter Columns” list box will be automatically selected when a
worksheet is selected. If you select more than one column in the “Filter Columns” list
box, TWE will split table based on the unique combinations of values in all selected
columns.
Example
Figure 22 shows a table including 8 columns. Now we want to split the table into
small ones in which each table only includes data from one location. That is, the large
table will be splitted by the “Location” column.
Figure 22
Here are the detailed steps:
1) Right click the TWE icon in the system tray area
2) Click “Split a table” from the TWE context menu to open the “Split table” dialog
window, see Figure 23
3) Select the “Table_Examples.xls” workbook in the workbook dropdown list box
-184) Select the “FullList2” worksheet in the worksheet dropdown list box
5) Select all columns in the “Copy Columns” list box;
6) Select “Location” column in the “Filter Columns” list box. The completed dialog
window looks like Figure 23
7) Click the “Ok” button to proceed. After the process is done, there are three new
tables (Figure 24) generated. Each of them includes data from one location.
Figure 23
Figure 24
If the columns you select as the filter columns have a lot of unique combinations of values, there
will be a large number of new tables generated by TWE. It might take a fairly long time to
generate all the tables. Once all tables are generated, you may have difficulty to handle them.
So, you have to be clearly aware what you are going to do when you split a large table.
Extract table
This function provides a solution for extracting a subset of rows from a large table by
applying a set of user-defined filter criteria.
-19-
Overview
From the TWE context menu click “Extract a table” to open the “Extract table”
dialog window, see Figure 25.
Figure 25
Worksheets area lets you select a workbook and a worksheet from the selected
workbook. You also have the flexibility to select with or without column title row and
current used range or selected range as the data for processing. Once you make all
these choices, the data range will show in the A1 format. There is a new sheet name
textbox in this area. You can optionally enter a sheet name for the extracted data
table.
Column area includes two parts. The “Copy Columns” list box on the left side
allows you select columns to be copied to the new worksheet. If there are data rows
available in the selected worksheet, all columns in the “Copy Columns” list box will
be automatically selected when a worksheet is selected.
The “Filter Columns” frame on the right side allows you create filter criteria. This
frame includes a filter criteria list box at the top, three buttons in the middle, and three
drop-down list boxes at the bottom. You can use the three drop-down list boxes to
create criteria. The first drop-down listbox on the left holds all available columns.
You can select a column you want to create a criterion based on it. Then you can
select a comparison operator from the drop-down list box in the middle. TWE
provides 6 comparison operators, that is, =, >, >=, <, <=, and <>. Finally, you select a
value from the drop-down list box on the right. TWE automatically generated a value
list whenever you select a column from the drop-down list box on the left. After you
complete the above steps, click the “Add” button in the middle of the frame. A
criterion will be added to the filter criteria list box. Since TWE does not validate the
criteria you add, you have to make sure the added criteria are valid by yourself. If a
criterion is not valid, you can select it in the filter criteria list box, and click the
-20“Delete” button to erase it. You can always erase all added criteria by clicking the
“Clear” button.
Example
Figure 26 shows a table including 8 columns. Now we want to extract a subset of
rows based on a filter criterion created on the “Location” column.
Figure 26
Here are the detailed steps:
1) Right click the TWE icon in the system tray area
2) Click “Extract a table” from the TWE context menu to open the “Extract table”
dialog window, see Figure 27
3) Select the “Table_Examples.xls” workbook in the workbook dropdown list box
4) Select the “FullList2” worksheet in the worksheet dropdown list box
5) Select all columns in the “Copy Columns” list box
6) Select the “Location” list item in the column dropdown list box at the bottom left
of the “Filter Columns” frame
7) Select the “=” operator in the operator dropdown list box in the middle of the
“Filter Columns” frame
-218) Select “1” in the value dropdown list box in the bottom right of the “Filter
Columns” frame
9) Click the “Add” button to add the filter criterion to the list box above it. The
completed dialog window looks like Figure 27
10) Click the “Ok” button to proceed. After the process is done, there is a new table
(Figure 28) generated that includes all data from the Location 1.
Figure 27
Figure 28
Stack tables
This function provides two solutions to combine a large number of small tables into a
large table.
Overview
From the TWE context menu click “Stack tables” to open the “Stack tables” dialog
window, see Figure 29. This dialog window has more unique elements. Worksheets
-22area is at the top of the dialog window and Output area in the middle. There is no
separate Column area.
Worksheets area includes a workbook dropdown list at the top, a worksheet list box
and a column list box on the left, two check boxes and three buttons and a selected
range list box on the right.
You can use the workbook dropdown list to select a workbook from all available
workbooks. You can use “Refresh” button on the right side to update workbooks
dropdown list. Once a workbook is selected, all worksheets of the selected workbook
are shown in the worksheet list box. The active worksheet is automatically selected in
the worksheet list box. All columns of the selected worksheet are also listed and
selected in the column list box.
To add data tables to the selected range list box, you have to select a worksheet and
select consecutive columns you want to be copied to the large table. Then, click the
“Add” button in the middle to add the selected data range to the selected range list
box. For some tables, you might want to use a selected data range other than all
available data in the worksheet. In that case, just check the “Selected range” option
before you click the “Add” button.
By using the “Delete” and “Clear” buttons to delete selected data ranges or erase all
data ranges in the selected range list box.
Output area includes a textbox for entering new sheet name and two option buttons.
If you’d like to provide a sheet name for the new worksheet, you can optionally enter
the sheet name in the text box. If you leave it empty, TWE will create a new
worksheet by using the Excel default sheet name. The two option buttons are
“Simple stack” and “Stack by matching column titles”. If you select “Simple stack”
option, all selected data ranges will simply stack one over another into the new
worksheet. If you select “Stack by matching column titles” option, all selected data
ranges will stack one over another by matching their column titles. To be aware that
the total number of unique columns in the resultant table is limited by Microsoft
Excel itself. The current limit of total number of columns is 255.
-23-
Figure 29
If you did not add any data range to the selected data range list box, you will get a
message box like Figure 30 after you click the Ok button.
Figure 30
Example 1: Simple stack
Figure 31 and Figure 32 are two tables including observed data from two locations.
Of course, we can merge two tables by copying one table and pasting it to another.
This is easy because we only have two tables. How about we have dozens of tables. It
will be a tedious and error prone procedure. The Simple stack method TWE provides
can easily merge many tables just like a breeze. For demonstration purpose, the
detailed steps are given below.
Figure 31
-24-
Figure 32
1) Right click the TWE icon in the system tray area
2) Click “Stack tables” from the TWE context menu to open the “Stack tables”
dialog window, see Figure 33
3) Select the “Table_Examples.xls” workbook in the workbook dropdown list box
4) Select “Location1” in the worksheet list box and click the “Add” button to add
available data range in this sheet to the selected range list box
5) Select “Location2” in the worksheet list box and click the “Add” button to add
available data range in this sheet to the selected range list box. Now the selected
range list box has two data ranges
6) Make sure the “Simple stack” option selected
7) Click the “Ok” button to proceed. After the process is done, a new table (Figure
34) is generated. This table simply stacks the two selected tables one over
another.
-25-
Figure 33
Figure 34
Example 2: Stack by matching column titles
Figure 35 and Figure 36 are two tables including observed data from two locations.
The first table has two observed variables and the second one has three observed
variables different from the two variables in the first table. We do not want to mix up
different variables into same columns and also do not want to lose location
information. Stacking tables by matching column titles that TWE provides can easily
merge them together. For demonstration purpose, the detailed steps are given below.
-26-
Figure 35
Figure 36
1) Right click the TWE icon in the system tray area
2) Click “Stack tables” from the TWE context menu to open the “Stack tables”
dialog window, see Figure 37
3) Select the “Table_Examples.xls” workbook in the workbook dropdown list box
4) Select “Location1” in the worksheet list box and click “Add” button to add
available data range in this sheet to the selected range list box
5) Select “Location2” in the worksheet list box and click “Add” button to add
available data range in this sheet to the selected range list box. Now the selected
range list box has two data ranges
6) Make sure the “Stack by matching column titles” option selected
7) Click the “Ok” button to proceed. After the process is done, a new table (Figure
38) is generated. You can see the two tables stacked together without messing
variables up
-27-
Figure 37
Figure 38
Join tables
This function provides a solution to combine information from two tables
horizontally. It is different from the “Stack tables” function because the “Stack
tables” function combines tables vertically. The “Join tables” function combines two
tables by matching values of the selected columns in each row. You can match as
many columns in two tables as you want and copy selected or all columns from one
table to the other table. It can be used in the following situations:
Fulfill the match and lookup worksheet functions Excel provides
-28Combine information from two different tables to generate a large table
Check if particular entries in one table are exist in the other table
Overview
From the TWE context menu click “Join tables” to open the “Join tables” dialog
window, see Figure 39. This dialog window has more unique elements.
Worksheets area is at the top of the dialog window. There are two sets of worksheet
selection controls. The set on the left side is for selection of the source worksheet and
the set on the right side for selection of the destination worksheet. To be aware that
the two tables are not necessarily within one workbook or Excel file, they can be in
two different Excel files. TWE provides total flexibility to your work.
Columns area includes a “Copy Columns” list box and a “Match Columns” frame.
All copy columns are from the source worksheet. The selected columns in the “Copy
Columns’ list box will be copy to the destination worksheet based on the match
columns you select in the “Match Columns” list box.
In the “Match Columns” frame, you can select a column of the source worksheet in
the bottom left drop-down list box and a column of the destination worksheet in the
bottom right drop-down list box. Once you select both columns, you can click the
“Add” button right above the drop-down lists. A match column entry will be inserted
into the match columns list box. You can add as many as match columns criteria as
you want as long as they are not conflict with each other.
Figure 39
If you do not create any match criteria before you click the Ok button, you will get
the following error message (Figure 40). The message just reminders you to create at
least one matching criteria.
-29-
Figure 40
Example: Match one column and copy a different column
We have two tables. The first table (T1, see Figure 41) includes individual
observations of experimental subject that is the combination of the first three columns
(ID, Location and Block). The second table (T2, see Figure 42) includes lookup table
of ID and name. Now we want to insert name in T2 into T1 based on ID values in
both tables.
Figure 41
Figure 42
Here are the detail steps:
1) Right click the TWE icon in the system tray
2) Click the “Join tables” menu item in the TWE context menu to open the “Join
tables” dialog window, see Figure 43
3) Select “Table_Examples.xls” for the source workbook and “ID” (T2) for the
source worksheet
4) Select “Table_Examples.xls” for the destination workbook and “FullTable” (T1)
as the destination worksheet
5) In the “Copy Column” list box, select “ID:Name”
-306) Add a match columns as “ID:ID = Full Table:ID” in the “Match Columns” frame
(see Figure 43)
7) Click the “Ok” button to proceed. Once the job is complete, the joined table
shown in Figure 44 has one more column on the right side of the table.
Figure 43
Figure 44
-31-
TABLE TRANSPOSITION
Microsoft Excel provides a transposition function. If you use special paste dialog
window, you can select “Transpose” at the bottom of the window. By using this
function, you can transpose selected range from vertical to horizontal or vice versa.
However, if you want to keep partial information of a table untouched and transpose
several data columns, such as Columns D-M, in a table like Figure 46, Excel cannot
really help you. TWE table transposition functions are designed for this purpose.
Table to list
This function provides a solution to transpose a horizontal table (we call it a table
here and thereafter) to a vertical table (we call it a list here and thereafter).
Overview
From the TWE context menu click “Table to list” to open the “Table to list” dialog
window, see Figure 45. Worksheets area is at the top of the dialog window and
Column area in the middle.
Figure 45
Worksheets area allows you to select a workbook from the available workbook list
and a worksheet from the selected workbook. It also allows you to optionally select
“Without head row” and “Selected range”. The available data range in the A1 format
is shown at the bottom of the Worksheets area. There is a “Refresh” button in this
area. If there are workbooks created or opened after the dialog window is opened, you
have to click this button to update the “workbook” dropdown list. Otherwise TWE
does not know there are new workbooks available or workbooks closed. So you
-32should click the “Refresh” button whenever available workbooks changes. In
addition, there is a new sheet name textbox. You can optionally enter a name for the
new sheet.
Column area includes two parts: “Copy Columns” and “Transpose Columns”. “Copy
Columns” list box allows you select columns that you want to copy to the destination
sheet and they will be repeated as same number of times as the number of selected
transpose columns. By default, only is the first column selected in both “Copy
Columns” and “Transpose Columns” list boxes. You usually select two sets of
columns without overlap in these two list boxes unless you want bizarre results. The
column titles of selected transpose columns will be transposed to vertical and
repeated again and again, you should give this column a name by filling the index
title textbox. The values of selected transpose columns will be straightened vertically.
You can give this column a name by filling the value title textbox.
Example
Figure 46 is a table including up to ten recorded dates for each subject (a combination
of the first three columns). What we want to do is to transpose the recorded dates into
a vertical column for each subject. Microsoft Excel does not provide a way to do that
easily. By using TWE’s table to list function, the process is pretty simple.
Figure 46
1) Right click the TWE icon in the system tray area
2) Click “Table to list” from the TWE context menu to open the “Table to list”
dialog window, see Figure 47
3) Select “Table_Examples.xls” from the workbook dropdown list box
4) Select “FullTable” from the worksheet dropdown list box
5) Select the first three columns, that is, “ID”, “Location” and “Block”, in the “Copy
Columns” list box
6) Select the next 10 columns following “Block”, that is, “1”…“10” in the
“Transpose Columns” list box
7) Enter “Samples” in the index title text box
8) Enter “Dates” in the value title text box
-339) Click the “Ok” button to proceed. After the process is done, a new table (Figure
48) is generated. It includes five columns. The first three columns were copied
from the original table. The fourth column includes column titles of Columns
“1”…“10” in the original table. The fifth column includes values from the
Column “1”… “10” in the original table
Figure 47
Figure 48
List to table
This function provides a solution to transpose a vertical list to a horizontal table. It
exactly does a reverse operation of the “Table to list” function described in the
previous section.
-34-
Overview
From the TWE context menu click “List to table” to open the “List to table” dialog
window, see Figure 49. Worksheets area is at the top of the dialog window and
Column area in the middle.
Worksheets area allows you to select a workbook from all available workbooks and
a worksheet from the selected workbook. It also allows you optionally to select
“Without head row” and “Selected range”. The available data range in the A1 format
is shown at the bottom of the Worksheets frame. There is a “Refresh” button in this
area. If there are workbooks created or opened after the dialog window is opened, you
have to click this button to update the “workbook” dropdown list. Otherwise TWE
does not know there are new workbooks available or workbooks closed. So you
should click the “Refresh” button whenever available workbooks changes. In
addition, you can optionally provide a name for the new worksheet by entering it in
the new sheet name textbox.
Column area includes three list boxes: “Copy Columns”, “Title Column” and “Value
Column” list boxes. “Copy Columns” list box allows you select columns that you
want to copy to the destination sheet. As default, only is the first column selected in
“Copy Columns”, “Title Column” and “Value Column” list boxes. You can select a
set of columns in “Copy columns” list box and one column from both “Title Column”
and “Value Column” list boxes. TWE does not validate your selection of columns.
You have to make sure that the selection of columns in the list boxes makes sense.
Figure 49
Example
Figure 50 is a table including six columns in which there are two recorded dates for
10 samples of each subject (a combination of the first three columns). What we want
to do is to transpose the recorded dates into horizontal columns for each subject. For
demonstration purpose, we pick the column with “Date1” as its column title to
-35transpose to horizontal columns. So here the title column is the “Subsample” column
and the value column is the “Date1” column. The first three columns will be copied to
the new table to identify a subject.
Figure 50
1) Right click the TWE icon in the system tray area
2) Click “List to table” from the TWE context menu to open the “List to table”
dialog window, see Figure 51
3) Select “Table_Examples.xls” from the workbook dropdown list box
4) Select “FullList1” from the worksheet dropdown list box
5) Select the first three columns, that is, “ID”, “Location” and “Block” in the “Copy
Columns” list box
6) Select “Subsmaple” column in the “Title Column” list box
7) Select “Date1” column in the “Value Column” list box
8) Click the “Ok” button to proceed. After the process is done, a new table (Figure
52) is generated.
Figure 51
-36-
Figure 52
List to counts
This is an advanced function. It provides a comprehensive solution to transpose a
vertical list to a horizontal table. The differences between this function and “List to
table” are that it count the frequency of each value appears for each subject and report
the frequency or accumulative frequency to a horizontal table. The title row of the
transposed counts is a set of all unique values in the value column.
Overview
From the TWE context menu click “List to table” to open the “List to table” dialog
window, see Figure 53. Worksheets area is at the top of the dialog window and
Column area in the middle.
Worksheets area allows you to select a workbook from all available workbooks and
a worksheet from the selected workbook. It also allows you to optionally select
“Without head row” and “Selected range”. The available data range in A1 format is
shown at the bottom of the Worksheets frame. There is a “Refresh” button in this
area. If there are workbooks created or opened after the dialog window is opened, you
have to click this button to update the “workbook” dropdown list. Otherwise TWE
does not know there are new workbooks available or workbook closed. So you should
click the “Refresh” button whenever available workbooks changes. In addition, you
can optionally provide a name for the new sheet by filling the new sheet name
textbox.
Column area includes “Copy Columns” list box, “Value Column” dropdown list
box, data format dropdown list box, and three check boxes. The “Copy Columns” list
box allows you select columns that you want to copy to the destination sheet. As
-37default, only is the first column selected in the “Copy Columns” list box. You can
select a set of columns in the “Copy columns” list box and one column from the
“Value Column” list box. Then you can select data format of the value column. There
are four choices: String, Numeric, Time and Date. The three check boxes are
optional. If you do not want any values equal to zero shown in the final table, select
“Non-zero value”. You also have a choice to calculate cumulative counts (the counts
accumulate from the left to right in the final table). To do that, simply select
“Cumulative counts” check box. Once the “Cumulative counts” check box is selected,
the “No duplicates” check box becomes enabled. If you select it, the final table does
not include duplicate values in each row.
Figure 53
Example
Figure 54 is a table including six columns in which there are two columns of recorded
dates for 10 samples of each subject (a combination of the first three columns). What
we want to do is to transpose the recorded dates into frequency of dates horizontally.
The first three columns will be copied to the new table to identify a subject. And the
“Date1” column will be the “Value column”.
-38-
Figure 54
1) Right click the TWE icon in the system tray area
2) Click “List to table” from the TWE context menu to open the “List to table”
dialog window, see Figure 55
3) Select “Table_Examples.xls” from the workbook dropdown list box
4) Select “FullList1” from the worksheet dropdown list box
5) Select the first three columns, that is, “ID”, “Location” and “Block”, in the “Copy
Columns” list box
6) Select “Date1” column in the “Value Column” dropdown list box
7) Select “Date” from the data format dropdown list box
8) Select all three check boxes
9) Click the “Ok” button to proceed. After the process is done, a new table (Figure
56) is generated.
Figure 55
-39-
Figure 56
-40-
ADDITIONAL FUNCTIONS
TWE provides some additional functions as described below in detail.
Show Excel status
Figure 57 is an example of the Current Status of Excel dialog window. In this dialog
window, the number of open workbooks, the name of the active workbook, the
number of worksheets in the active workbook, the active worksheet in the active
workbook and active cell in the active worksheet are shown. If there is no open
workbook, the number of open workbooks will be zero and all other properties show
as not available (N/A).
Figure 57
Open Excel files
Figure 58 is a typical Open Excel File dialog window. It is used to open Excel files if
you like. Since the TWE application can be started even Microsoft Excel is not
running, you may like open Excel files before you use other functions. This function
is provided for your convenience.
Figure 58
-41By using this open file dialog, you can open files with file extensions of *.XLS,
*.CSV and *.TXT. All data files will be opened in Microsoft Excel. Some extra work
may be needed when you open text file in Microsoft Excel.
Rename worksheets in batch
If you rename worksheets very often or have a large number of worksheets needed to
be renamed, you may already feel tired of the Excel default way. There are more
clicks and types. TWE provides a convenient solution to achieve an easy and fast
way. Figure 59 shows the Rename Worksheets dialog window. At the top of the
window, you can select a workbook that you want to work with. Once a workbook is
selected, all worksheets in the workbook will be shown in the middle panel of the
window. There are a check box and a text box related to each worksheet. You can
directly change a worksheet name by modifying text in text boxes. Once text in a text
box is changed, the checkbox will be automatically checked. Of course, you can
deselect the check box even if you change the text in the text box. After you change
the names of the worksheets you want, you can simply click “Ok” button to rename
worksheets. Is that simple? Again click “Refresh” button to reflect the current
available workbooks in the workbook dropdown list.
Figure 59
Help
Click “Help” menu item in the TWE context menu to open TWE user manual in a
separate window.
About TWE
Directly click “About” menu item in the TWE context menu or click the TWE icon
in the system tray, the “About TWE 2.0” dialog window will open. If you already
purchased a license and entered it, the “About TWE 2.0” dialog window looks like
Figure 60. If you are trying the software, you will get a dialog window like Figure 61.
-42-
Figure 60
Figure 61
You can click “Buy” button in this window to go to TWE website and buy a license
directly. Once you get your license code through email, you can click the “Enter”
button in this window to enter the license code. When you open the “About TWE
2.0” dialog window next time, it will look like Figure 60.
-43-
Q&A
Software version
1. How can I upgrade to a new version?
From time to time, we will have new updated version of TWE released. You can visit
our website (www.sunfinedata.com) to check if there is one available for you. You
can directly download it from our website to your computer and install it.
2. Do you have version in my language?
Currently TWE is only available in English language. If there are a lot of requests in
your language, we will consider translating TWE to your language. Please let us
know if you are interested in TWE in a different language.
Report bugs
1. What should I do when an error window pops up?
If you encounter an error unexpected error message, please press Alt+PrtScr to copy
the error message dialog window and send it along with the data set to us
([email protected]). Please describe the situation in detail in your email.
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement