LXNAV LX Styler User Manual

Add to My manuals
40 Pages

advertisement

LXNAV LX Styler User Manual | Manualzz

USER MANUAL

LX Styler

Customization Tool for LX80xx/90xx

Version 8.10

May 2021 www.lxnvav.com

Rev #17 LX Styler version 8.10

1 Introduction

1.1

What is LX Styler

1.2

System Requirements

1.3

Installing and Uninstalling

1.4

Starting LX Styler

1.5

Contacting us

2 Getting Started

2.1

LX Styler Windows

2.2

Managing Configurations

2.2.1

Protected Profile

2.3

Managing Navigational Pages

2.4

Navigation Page Editor

2.4.1

Toolbar

2.4.2

Global Styles

2.4.3

Symbols Lists

2.4.4

Message Overlay

2.4.5

Property Editor

2.4.6

Device Screen

2.5

Checklists

3 Commands

3.1

Main Window

3.1.1

New Configuration

3.1.2

New Checklists

3.1.3

Open

3.1.4

Save

3.1.5

Import

3.1.6

Exit

3.1.7

Convert

3.1.8

Profile Editor

3.1.9

Remote Actions Editor

3.1.10

Edit Page

3.1.11

Add Page

3.1.12

Remove Page

3.1.13

Copy Page

3.1.14

Paste Page or Style

3.1.15

Set as Thermal

3.1.16

Enable/Disable Mode

3.1.17

Home Mode

3.2

Navigational Page Editor

3.2.1

Toolbar

3.2.2

Symbols

Map Symbol

Aircraft Symbol

3D Map

Battery

Orientation Symbol

Final Glide Symbol

Wind Symbol

GPS Symbol

Zoom Symbol

AHRS Symbol

Radar Symbol

Page 2 of 40

May 2021

10

11

11

12

8

8

9

10

6

7

7

7

14

18

18

19

19

19

19

19

16

17

17

17

18

18

19

19

19

16

16

16

16

15

16

16

16

14

14

14

14

14

15

15

15

5

5

5

5

5

5

6

Rev #17 LX Styler version 8.10

Altitude Tape Symbol

Airspeed Tape Symbol

Flaps Tape Symbol

History View Symbol

Side View Symbol

Wind Profile Symbol

Picture Symbol

Compass and HSI Symbols

Wi-Fi Symbol

Vario Symbols

Thermal Symbol

Gauges Symbol

Meteogram

FLARM Indicator

Forecast Legend

Data Symbols

3.2.3

Message Symbol

3.2.4

Colour Editor

3.2.5

Font Style

3.2.6

Text Alignment

3.2.7

Ranges

4 LXNAV Connect Integration

4.1

Uploading Files

4.2

Downloading Files

4.3

Automatic file synchronization

5 Profile Collection Integration

5.1

Upload Modes

5.2

Settings

5.3

Uploading

5.4

Browsing

6 Updating LX Styler

7 Polar Designer

7.1

Getting Started

7.2

Toolbar Commands

7.2.1

New Document

7.2.2

Open Polar

7.2.3

Save

7.2.4

Open Image

7.2.5

7.2.6

Exit

Show Grid

7.2.7

Select Image

7.2.8

Crop Image

7.2.9

Rotate Image Right 90°

7.2.10

Rotate Image Left 90°

7.2.11

Flip Image Vertical

7.2.12

Flip Image Horizontal

8 Glider Presets

8.1

Toolbar Commands

8.1.1

New

8.1.2

Open

8.1.3

Save

8.1.4

Add Glider

Page 3 of 40

May 2021

32

32

32

32

33

34

35

35

36

36

36

36

36

34

35

35

35

35

35

35

37

37

37

37

38

38

27

28

30

31

32

20

20

20

21

21

21

20

20

20

20

19

19

20

20

21

21

25

25

26

26

26

Rev #17

8.1.5

Remove Glider

8.1.6

Rename Glider

8.1.7

Polar Designer

9 Revision History

LX Styler version 8.10 May 2021

38

38

38

39

Page 4 of 40

Rev #17

1 Introduction

LX Styler version 8.10 May 2021

1.1

What is LX Styler

LX Styler is a customization tool for the LX8000, LX8080, LX9000, LX9050 and LX9070 navigation systems. It will help you to modify existing navigational pages or add new navigational pages. It will also help you to choose from more than 120 different data symbols to suit your needs. You can also change the shape and size of an airplane, a glider, or remove unnecessary elements.

The following symbols will appear in this manual.

Parts of the manual which should be read very carefully will appear with this symbol.

This bulb icon will appear when a useful hint is given to the reader.

1.2

System Requirements

LX Styler is written for the Microsoft Windows operating system. The minimum requirements are simple:

Operating system: MS-Windows 10

Display resolution: 1920x1080

.NET Framework 4.6 or newer

• 120 MB of free disk space

1.3

Installing and Uninstalling

Download the installation program from our webpage gliding.lxnav.com

, then run it and follow the on-screen instructions to complete the installation.

To uninstall the program, navigate to the "uninstall icon" in the LX Styler group and run it. You can also open the "Control panel", select "Add or Remove Programs", find the LX Styler line and press the Remove button.

1.4

Starting LX Styler

After successful installation a program group named LX Styler is created and an icon is placed on your desktop. Double click on the icon to run it.

1.5

Contacting us

In case you have difficulties understanding or running your LX Styler, or you discovered a bug, please send us an email to [email protected]

, or call us +386 592 33 400.

Visit our webpage regularly for free updates and new help files.

Page 5 of 40

Rev #17

2 Getting Started

LX Styler version 8.10 May 2021

2.1

LX Styler Windows

Once you start a program, the main window will show the last configuration that was opened, or it will be empty.

The main window consists of a menu, a toolbar and a general view, where all the seven navigational modes are shown, namely airport mode, waypoint mode, task mode, statistics mode, setup mode, info mode and near mode.

You will notice that the last four modes are in shaded grey colour, which means that it is not possible to modify them.

In each mode, all the relevant pages are displayed. If you left click twice on any navigational page, the "Navigation Page editor" will be opened. You can use it to define all small details of that selected page.

There are more details about the "Navigation Page Editor" in Sections 2.4 and 3.2.

Global properties Toolbar

List of symbols

Navigational page

Property editor

Page 6 of 40

Rev #17 LX Styler version 8.10 May 2021

2.2

Managing Configurations

We store the complete "look and feel" display of the navigational pages in a configuration file with the .lxprofile extension. You can create a new "Configuration file", or it can also be downloaded from the device.

To download a "configuration file" from the device, enter the "Setup mode" and select the

Profile and Pilots menu item. Since the display is small you have to press MORE>> to see other pages until you see TO SD. Then press the TO SD button in order to copy the selected profile to the inserted SD card.

You can now load stored configuration files into LX Styler through File->Open, or pressing the open icon in the toolbar.

To create a new configuration press File->New Configuration, or select a new configuration icon in the toolbar.

The "configuration file" also consists of other essential settings for the device.

Variometer setting, pilot information, files in use, and glider polar are also stored in the configuration file. One can also modify most of these settings with the LX

Styler, however some settings can be changed only on the device itself.

If you create a new profile, the whole settings will be set to default values and you will have to modify them on the device.

Once the configuration that suits your needs has been created, you can save it with File-

>Save, or by clicking the save icon in the toolbar.

You can also test your configuration via LX Sim, which you can find on gliding.lxnav.com.

Protected Profile

You can protect a profile with a pin. A protected profile cannot be opened or modified on the device without entering the pin. A prompt for opening an unprotected copy of the profile is shown when you enter a wrong pin while opening the profile on the device.

A padlock on the top right corner of the main window indicates the current protection status of the profile. You can modify pin for the profile with a single left click on the padlock. A pin can only consist of numbers between 1 and 9. Setting empty pin will remove the protection.

2.3

Managing Navigational Pages

You can easily move, copy or remove any "Navigational page" via the mouse. A double left click on a selected navigation page will open the "Navigation Page Editor". Press the right button of the mouse and a pop-up menu will open.

Page 7 of 40

Rev #17 LX Styler version 8.10 May 2021

Select the appropriate menu item to add, remove, copy, or edit a page. You can also drag a page to another location – just press the left mouse button and while holding it down, drag the selected navigational page to the desired location. A red line will indicate the new position of the page. Release the mouse button to place the page.

2.4

Navigation Page Editor

If you left click on any of the "navigational pages" or you select "Edit page" on the popup menu a "Navigation Page Editor" will be opened. It is divided into four sections:

• Toolbar : contains all the symbols which can be put on a navigational page.

• Global properties : defines the global styles for the symbols on it and lists of all the symbols on the page.

• Property editor : displays all the properties of the selected symbols.

• Graphical representation: shows the device and its navigational page.

Select one or more items from a list, or pick them on the device screen. They will be highlighted on the list and a blue rectangle will be drawn around them. "Property editor" will fill in the properties for the selected item. If more than one element is selected "property editor" will show only the common properties.

Once you have finished editing a page press the "Apply button" in the toolbar to accept the changes and return to the main window. Press "Cancel" to abandon all changes and return to the main window.

Toolbar

Select a desired item from the toolbar to place it on the page. Some items will be greyed if they are already on the page, or they are unavailable.

Page 8 of 40

Rev #17 LX Styler version 8.10 May 2021

A left click on an item will automatically place it in the top-left corner of the page. If you select

Data Symbol, a new dialog will open in which you can then select the desired symbol.

Data symbols are grouped in seven groups: aircraft parameters, outside parameters, target parameters, task parameters, optimization data, FES/JDU and misc tab. More details about

the data symbols of each tab are available in Section 3.2.2.

You can also find appropriate symbol via the search field. A search tab containing matched data symbols will appear whilst typing.

The toolbar also displays a delete button with which one can delete the currently selected item. You can also delete an item by pressing the delete key.

Global Styles

When you want to change the colour for all the symbols on the page in one move you should use global styles. There are four different items in this category:

• "Background colour" defines the background colour of a page. The default colour is black

• "Title style" defines the font, the background colour, the border colour and the text colour of data symbol titles

• "Data style" defines the font, the background colour, the border colour and the text colour of a data value

• "Single line symbol style" defines the font, the background colour, the border colour and the text colour of single line data symbols.

Page 9 of 40

Rev #17 LX Styler version 8.10

Single line symbol

May 2021

Symbol title

Symbol data

If you change the colour or the font of any of the global styles, it will be applied only to the data symbols with the property "Use Global Style" set to yes.

Symbols Lists

The "symbol list" shows all the elements of a page. A left click on an item selects it. It will highlight it, a blue rectangle will be drawn around it in a graphical view and the properties for a selected item will appear in the "property editor". You can also select multiple elements at once by holding down the CTRL button, or select a range of elements using your SHIFT button.

Once selected, you can change the common properties for all of them.

Message Overlay

When "message overlay" is selected a demo message will appear and you will be able to edit its size, where it is located and whether a FLARM radar is displayed next to it. There are three different messages, Warning , Critical and Info . The overlay for each of them can be edited separately.

Page 10 of 40

Rev #17 LX Styler version 8.10 May 2021

Property Editor

The "property editor" shows all the properties of a selected element that can be modified. The

"property editor" is a table with two columns.

The left column displays the property name; and the right column displays the property value.

Click on the property value to modify it. Press down the arrow on the right side and an additional dialog for the selected property will be displayed.

At the bottom of the "property editor" there are more detailed description for a selected item.

Device Screen

The "device screen" is a graphical representation of the "navigational page".

Page 11 of 40

Rev #17 LX Styler version 8.10 May 2021

Point to a symbol and select it with a mouse left click. If you hold the left mouse button on a symbol you can drag it around and place it into the desired position. If you click, hold and move small white squares around a selection you can resize the symbol.

To select multiple symbols at once, hold down the Ctrl button on your keyboard and then click on the next symbol you wish to select. Now you can move or resize them together. To deselect it, click again on the selected item while holding down Ctrl.

When resizing or moving, the borders of a selected symbol are snapped to the borders of other symbols; which is indicated with an orange line. If you wish to move or resize a symbol, freely hold down the Shift key while moving the mouse.

You can also move a selection by 1 screen pixel with the arrow keys of the keyboard. To move only the top-left corner, hold down Ctrl while pressing the arrow keys. To move only the rightbottom corner, hold down Shift while pressing the arrow keys.

2.5

Checklists

It is possible to open and create "checklist pages" with the LX Styler. Checklists are saved in file with a checklists extension. You can activate them on your device in Setup > Files and

Transfer > Checklists.

When editing a "checklists page", two additional buttons are present in the toolbar. The "check item button" inserts one checklist item on the page. These are special items that you can check, uncheck and scroll on the device.

The "checklist button" opens a new dialog where you can create multiple checklist items faster.

After selecting the " Create button" the items are generated and added to the page. Now you can reposition them on the page, or make additional changes and change the style of individual rows.

Page 12 of 40

Rev #17 LX Styler version 8.10 May 2021

After a checklist is created you can still add other items to the checklist page. You do this the same way you would do it on a normal page.

You can create more than one checklist page. To add additional pages click on the left-hand side of the screen and select add. Here you can also remove, copy and paste pages or change the order in which they appear by dragging them up or down.

Page 13 of 40

Rev #17

3 Commands

LX Styler version 8.10 May 2021

3.1

Main Window

The "Main window" commands are as follows; new configuration, new checklists, open or save, recent files, import and exit. Recent files are displayed only if some previous configurations were already opened.

In the "Convert menu" there is a list of other devices that you can convert to the profile. If you have a LX8000 and you want to use the same profile on the LX9000... you have to press

CONVERT and select 9000.

The "tools menu" consists of other useful features used to modify a profile. It is possible to edit settings and change the order of the remote action buttons.

In the "help menu" you can open a PDF manual to see the program version.

New Configuration

When you select a "new configuration option" a dialog for device selection opens. Here you can select the device you want to create for navigational pages. For some devices you have two options which are portrait and landscape. After the selection is made, a new configuration is created with default navigational pages and default settings.

The "configuration file" also consists of other settings essential for the device.

Variometer setting, pilot information, files in use and glider polar are also stored in the configuration file. Most of these settings can also be modified with LX Styler, while others can only be changed on the device itself.

If you create a new profile, all settings will be set to default values and you will have to modify them on the device.

New Checklists

When clicking on the "New configuration command" a device picker dialog will open. After selecting it an "empty checklists editor" will be displayed with pages on left side and a familiar

page editor in centre. For more details about checklists, please refer to Section 2.5

Open

The "Open option" opens an existing configuration file or checklists. If you have already used a program for editing you can open some of the recently opened files from the list in the "File menu".

Save

The "Save command" saves all current configurations, or checklists file.

Page 14 of 40

Rev #17 LX Styler version 8.10 May 2021

Import

You can import pages from an existing open profile. You can manually select which modes and pages you want to import, or simply click select all. If you also wish to import all the setting saved in the profile (such as map settings, opened waypoints, units settings, sound and graphics settings…) then check the "Import all settings" option.

Exit

The "Exit command" will close the LX Styler. Make sure you saved your configuration before exiting the program. You may also exit the program by pressing the Alt+F4 key combination.

Convert

The "Convert command" opens current profiles for use on other devices. If there are any settings in profile they are preserved. If the screen sizes are not the same on the current and target device the program will try to resize and move the symbols on all the pages to fit the target screen size.

Profile Editor

You can access the "Profile Setting Editor" from the Tools menu. Once there, you can select one of the many profile groups and then edit individual settings.

You can only edit settings that the device has already saved to a profile file. Hence if you just created a new profile in the LX Styler you cannot edit it because it does n’t exist yet.

Page 15 of 40

Rev #17 LX Styler version 8.10 May 2021

Remote Actions Editor

From the "Tools menu", you can access the editor with which you can reorder navigation buttons for the remote stick. This customization is available for airport mode, waypoint mode and task mode. You can enable or disable the custom order of buttons in the mode by toggling the corresponding checkbox. When enabled, you can reorder the buttons by clicking and dragging them up or down inside the list.

Edit Page

When you make a right click on a page, a popup menu will appear. Select the "Edit Page item" and then the "Navigation Page Editor" will open.

Add Page

Select this option to add a blank page. A page can be added before selecting a page or after doing it.

Remove Page

Select "Remove page" to delete a page.

Copy Page

A page can also be copied. Select a page and copy it to a local clipboard. It can subsequently be pasted.

Paste Page or Style

This will create a copy of a page from the clipboard. It will be placed after the selected navigation page. You can also paste global styles from a copied page into a selected page.

Set as Thermal

This will set the current selected page as the thermal page. When this feature is enabled on the device the selected page will appear when circling. By default the first page in every mode is set as the thermal page.

Enable/Disable Mode

If you do not need to use one or more navigation modes, you can disable them by unchecking the checkbox in the mode header.

Page 16 of 40

Rev #17 LX Styler version 8.10 May 2021

Home Mode

Click on the "house icon" on the mode header bar to set it as the "home mode". When you start the device the "Home mode" will open first.

3.2

Navigational Page Editor

The "Navigation Page Editor" is divided into four major sections.

• "Toolbar" contains all the symbols which can be put on a navigational page.

• "Global properties" defines the global colours for the page symbols; below it there is a list of all the symbols on the page

• "Property editor ” is used to display the properties of the selected symbols

• "Graphical representation" is for the device and the navigational page.

Toolbar

The toolbar contains the different symbols which can be placed on a navigational page. Most symbols can be placed only once on a page and will be disabled if they are already on that page.

Some of the symbols can be placed on a page only in combination with others and will be disabled if a symbol is missing (e.g. a zoom symbol can be placed on a page only if the map and the aircraft symbols are already on the page.)

When you click on the data symbol selector a dialog will open.

Data symbols are grouped in seven logical groups: aircraft parameters, outside parameters, target parameters, task parameters, optimization data, FES/JDU and misc tab. Specific symbols will be depicted in the next chapter.

On the toolbar, you will also find a delete button used to remove a symbol from a page and the buttons "Apply and Cancel" to exit from the editor.

Page 17 of 40

Rev #17

Symbols

LX Styler version 8.10 May 2021

Map Symbol

You can add a map to a page. By default, it will be scaled to the whole screen. Select edge points to resize it, or to move it around. A Map symbol is always added along with the aircraft symbol.

After clicking on map, you will see many additional options. Here you can set how any element of the map looks like, including, but not limited to, Flarm objects, map objects, glider and track and weather layers. If some options cannot be edited at first glance, you must click on an arrow on the left-hand side to expand down the menu.

Aircraft Symbol

The "aircraft symbol" shows the current position of the aircraft on the map. The aircraft symbol will automatically be added to the map.

You will notice that there are two aircraft symbols shown. The one drawn as a shadow shows the position of an airplane when "Track Up", "Goal Up" or "Heading Up" map orientation is selected on the device (see the manual of the device for more details about map orientation).

In the "property editor", this position is referred as "Track" and the other position is referred as "North". There are several types of aircraft available. Change the style to select a different aircraft symbol.

You can also show a wind vector which will rotate around the symbol.

3D Map

A symbol shows the map with a 3D terrain. This feature is not available on some older LX8000 and LX9000 devices.

Page 18 of 40

Rev #17 LX Styler version 8.10 May 2021

Battery

Battery will display visually the current level of the battery. Green indicates that the battery is ok. It will first turn yellow and then red when the battery is almost empty.

Orientation Symbol

The "Orientation symbol" always points towards the true north. It can be placed on a page only when the map symbol is already on that page.

Final Glide Symbol

The "Final glide symbol" is very complex symbol, and you are highly recommended to have it on the page. It will display the current MacCready value, the arrival altitude at goal and many other features which are very important to start the whole task procedure.

If you fly a SGP task there is a special symbol next to the FG. For more details please refer to the device manual.

Wind Symbol

The "Wind symbol" shows the wind direction. It is useful to combine it with the wind data symbol in order to see the wind strength. While circling you can have the thermal assistant around the wind symbol. Enable or disable this feature with the "Has Thermal" property.

GPS Symbol

The "GPS symbol" shows the status of the GPS. A green colour indicates that the GPS is acquiring a 3D position; a yellow colour stands for a 2D position fix. When the colour is red, no position is calculated by the GPS. Each bar represents two visible satellites.

Zoom Symbol

The "Zoom symbol" shows the current map zoom. You can use it only when the "map symbol" is already on the page. The zoom can be presented in two ways: a number on the symbol indicates the length of the zoom symbol or a number indicates its length in the whole screen.

Use the "Full" property to switch between the two different styles of the symbol.

AHRS Symbol

This symbol will display an artificial horizon. You can also set it to see the compass direction.

It is available in 3 different "display styles", circle, round, or rect.

Radar Symbol

The "FLARM radar symbol" will display a radar screen showing FLARM targets at a predefined zoom. If on the device there is no map symbol on the page, you can also change the visible range with the ZOOM button wheel.

Altitude Tape Symbol

It shows the altitude band with the current altitude in the middle. You can customize it to see different information on the top and the bottom of the symbol. These data are QNH, MSL, height above ground, and flight level.

Airspeed Tape Symbol

It shows the current aircraft indicated speed. You can fully customize the band colours to match your aircraft speeds. You can also set it to display true airspeed, groundspeed, or outside temperature.

Page 19 of 40

Rev #17 LX Styler version 8.10 May 2021

Flaps Tape Symbol

This displays the current and the required flaps position. You can centre on any of these two positions or you can display the full tape range. In this case all the flaps position ranges are spaced equally, regardless of their values. In "Tape colour" you can edit the colours of every even and every odd flap position and the colour of the current flaps position.

History View Symbol

This shows the past aircraft altitude and terrain elevation. The circling direction is also visible.

You can specify how many minutes of flight should be shown via the "Shown Minutes property". The value by default is zero which shows the history of the whole flight.

Side View Symbol

This one symbol shows the lateral view of your position toward a selected goal, or aircrafts bearing. It also displays airspaces along your way, which you can customize on the device inside the "Airspace graphics dialog" in the setup mode.

Wind Profile Symbol

This symbol displays information about the wind profile. It is very similar to the tape in the

"Wind dialog".

Picture Symbol

This symbol displays photos tied to selected waypoints or airports. You can edit these pictures with the "LX Asapt editor" which you can find on gliding.lxnav.com.

Compass and HSI Symbols

These two symbols display the magnetic rose. The compass is always attached to a plane symbol and can be added only when the map symbol is already on the page. The HSI symbol can be added and moved freely at any time. The "compass tape" is another symbol with similar functionalities that always centres on the plane heading.

Wi-Fi Symbol

This shows the status of your Wi-Fi connection. Note that Wi-Fi functionality does not work on some older LX8000 devices with serial number 25001-25699, or 28000-28199.

Vario Symbols

The "vario gauge" is a representation of the variometer. You can change which values the needle is pointing to. The " Vario tape symbol" shows a vario value on the vertical tape.

There is also a separate " SC Vario indicator" that displays the current vario mode.

Thermal Symbol

This is a thermals graph from the "Statistics mode" in a symbol form. It displays the last four thermals. The thermal average is shown below each thermal column. Thermals are coloured according to the MacCready value. A red colour means that the thermal average was 0.5 m/s or more above the current MacCready setting. A blue colour means that the thermal average was 0.5 m/s or less below the current MacCready setting. An orange colour indicates that the thermal average matches the Mac Ready setting.

On the left side there is an altitude scale. On the right side there is a display of the average of the last four thermals.

Page 20 of 40

Rev #17 LX Styler version 8.10 May 2021

Gauges Symbol

Here you can find a gauge of the current g-load value . It also shows the lowest and highest recorded values. You can set it to be visible only when it is over a certain g-load. FES

Gauges is a set of gauges designed for glider equipped with FES system. One can find the following gauges: Voltage , minimum Voltage , maximum Voltage , Current , Power ,

RPM , Throttle , Engine temperature , Controller temperature , Battery temperature and Battery level .

Meteogram

This symbol shows all weather information for a selected target. It requires a Wi-Fi connection in order to download the image. Note that Meteogram does not work on some older LX8000 devices with serial number 25001-25699 or 28000-28199.

FLARM Indicator

The indicator shows the direction and the vertical position of other aircraft.

Values written in data symbols inside the LX Styler are purposes.

totally useless

, and are not correlated to each other. These values in DEMO are only for demonstration

Forecast Legend

This symbol represents a generic legend for forecast map layers. The type of data the symbol actually displays depends on the forecast service used (e.g. rainfall amount). You can only add this symbol if the page contains a map.

Data Symbols

There is a variety of data symbols available. A "data symbol" is a numerical representation of different parameters. A data symbol consists of a title field, which stores the name of a data symbol and a data field which is shown as the parameter. The title can be omitted if the

"Show title property" is set to No. When the "Use Global Style" property is set to Yes the data symbol will follow the global page style properties. Disabling the "Use Global Style" property allows the full customization of a selected data symbol.

There are more than 120 different data symbols. They are grouped into seven groups.

Page 21 of 40

Rev #17 LX Styler version 8.10 May 2021

Aircraft Parameters

Date

UTC Time

LON/LAT

Battery

IAS thE

VarioFL

AltGain reqFlaps curFlaps g-load g-min g-max

Circ.Flt

Circ.Tsk

Circ.60

Sp.60’

FlIGC

GS

TAS

STF reqSTF

Trk

Hdg

E

Th.E

Emc

Mc

Time

Title

Vario

VarA

Thermal

Netto

Alt

AltIGC

RawIGC

AltGps

Gnd

Agl

Height

FL

Description

Current vertical speed

Averaged vertical speed (the average time can be set on the device)

Last thermal vertical speed

Current netto vertical speed

Altitude above MSL

Altitude from the IGC pressure sensor

Raw IGC altitude

GPS Altitude

Terrain elevation

Height above the ground

Height above takeoff

Flight level

Flight IGC altitude

Groundspeed

True airspeed

Speed to fly

Speed to fly for a required MacCready (used for Pirker final glide)

Ground track

Heading

Current glide ratio

Thermal glide ratio

MacCready glide ratio

Sets MacCready value

Local time

Local date

Current UTC time

Current longitude and latitude position

Battery voltage

Indicated airspeed

Theoretical glide ratio

Average vario for the flight

Gained altitude in a thermal

Requested flaps position

Current flaps position

Current g-load

Minimum g-load

Maximum g-load

Flight circling

Task circling

Circling in the last 60 minutes

Last 60 minutes speed

Page 22 of 40

Rev #17 LX Styler version 8.10

FltTime

Ballast

Radius revT

Avg.sp

XC sp

Time of flight

Current ballast

Circling radius

Circling revolution time

Average speed

XC speed

QNH

FES/JDU

Pressure QNH

Batt.Left[min] Displays the remaining battery level in minutes

Batt.Left[%]

Misc

Title

Displays the remaining battery level in percent

Description

Label An arbitrary text label. You can type any text you like in there.

Location name

Nearest location

Airspace name

Distance to the nearest airspace

Airport name

Nearest airport

Wpt. name

tmDist

Nearest waypoint

Team partner distance tmBrg tmVario tmAlt tmName tmRelAlt tmTo tmCode tmWptCode

Eng.TT

Eng.FT

Flarm

COM

STBY

Team partner bearing

Team partner vario

Team partner altitude

Team partner name

Relative altitude of the teammate

Relative bearing of the teammate

Team code of your position

Waypoint team code

Engine total time

Engine flight time

Flarm RXTX

Active Frequency

Passive Frequency

XPDR

Rain Status

Rain Age

XPDR Transponder

Rain data status

Age of the displayed rain image

TkOff Take off time

Weather Info Timing information about active weather layers

Optimization Data

Title

Opt

OptHome

Tri

OLC.Sp.60’

OLC.Sp

Sp.150’

Alt.150’

Description

Optimized distance

Optimized distance to home

Optimized FAI triangle distance

OLC 60 minutes speed

OLC speed

Last 150 minutes speed

Altitude 150 minutes ago

May 2021

Page 23 of 40

Rev #17 LX Styler version 8.10 May 2021

Outside Parameters

Title

Wind cWind

WindX

OAT

Humidity

Description

Current wind with its direction and strength

Head/Tail wind component. There are two values displayed. The first is a calculation based on track and wind direction; the second is the difference between TAS and GS.

Side wind component. It displays its strength and direction.

Outside temperature

Relative humidity (a special sensor must be attached to the device).

Dew.Temp

Pot.Temp

Dewpoint temperature (a special sensor must be attached to the device).

Potential temperature

Target Parameters

Title

Dis

Arrival

ArrMc0

ReqAlt

Brg

Radial

To

ETA

ETE reqE

Target

Req.Mc

Elevation

Rwy.Dir

Rwy.Len

Frequency

Sunrise &

Sunset

Description

METAR

TAF toWind

Description

Distance to target

Arrival altitude at target

Arrival altitude at target with the MacCready setting at 0

Required altitude to reach the target

Bearing to target

Radial from target

Steering course to target

Estimated time of arrival

Established time en route

Required glide ratio to target

Target name

Required MacCready value to target, taking into account the wind.

Target elevation

Target runway direction

Target runway length

Target frequency

Sunrise and sunset times at the target location

Additional description of target

Raw or parsed target METAR data

Raw or parsed target TAF data

Head/tail wind to the target. There are two values. The first is a calculation based on the bearing and the wind direction and the second is the difference between TAS and GS.

Target code Code

VMG

Task Parameters

Velocity made good

Page 24 of 40

Rev #17

Title tDis tMinDis tMaxDis

Fin.Elev tArr tArrMc0 tETA tETE tRemain tDelta tskE

Tsk.Sp tReq.Sp tSp.60’ tReq.Mc trqSTF

T.Start Alt xTrk tVario sDis sBrg xsDist tunAlt

LX Styler version 8.10 May 2021

Description

Remaining task distance

Minimum task distance

Maximum task distance

Task finish elevation

Arrival altitude on task finish calculated through all remaining task points

Arrival altitude on task finish calculated through all remaining task points with MacCready set to 0

Task estimated time of arrival

Task established time

Task remaining time

Task delta time. A difference between tETA and tRemain

Required task glide ratio

Task speed so far

Task required speed calculated from tRemain and tDis

Task speed for the last 60 minutes

Required MacCready value towards the next task point, taking into account the wind.

Required "speed to fly" calculated from the required MacCready

Task start altitude

Current leg cross track distance

Average vario for task

Distance to zone centre

Bearing to zone centre

Cross distance to zone centre

Task uncompensated arrival altitude

Message Symbol

This is a "special symbol" which represents notifications visible on your device. You can not change a symbol for each page separately, but only for every mode (airport, waypoint and task). It is displayed after you select it from a list of symbols. It is now possible to resize and move the symbol. If you want to hide the message symbol you need to deselect it, or select some other symbol from the list on the left side.

Colour Editor

The "colour editor" is used to define a colour for a selected property. The "colour dialog" will open if you click on the down arrow in the "property value cell".

The colour can be selected from a grid of predefined colours on the left side of the dialog.

Alternatively you may change red, green and blue values with sliders, or enter numerical values. The colour can also be set with hexadecimal values.

Page 25 of 40

Rev #17 LX Styler version 8.10 May 2021

It is also possible to define the opacity for a selected colour. Slide the opacity slider towards zero to make a selected property transparent.

Font Style

If you click on the "font style property", a "font style dialog" will open.

You can select different font styles there as well as an optional text outline.

Text Alignment

The "text alignment popup dialog" is used to define how the text is aligned horizontally and vertically inside a symbol.

Ranges

Items like G-meter and Data symbol can use "ranges" for their display. With the "ranges editor" you can modify their appearance when the "symbol value" changes.

In the centre there are series of value and colour controls. Edit "value" to constrain ranges and select "colour" to change the appearance of a range. On some symbols, a text can start blinking when the value enters a specified range. Press on the " " button after a colour selector on ranges to specify where you want the blinking to occur. The preview of ranges is displayed on the left side of the list.

You can add a new range, or remove it with the "+ and – buttons" on the bottom left. After pressing the button, hover over the tape on the left side and click on the range to remove it or split it in two. If you press "add new" you can also select the up or down arrow to add a new range on the top, or on the bottom of the scale. On the bottom right side it is possible to select the unit in which the values will be written.

If the "range previews" are drawn in diagonal lines while editing, it means that the written values are invalid, or are not defined in an ascending order.

Page 26 of 40

Rev #17 LX Styler version 8.10 May 2021

Copy/Paste

You can copy any element and paste it in a different page. This is particularly useful when you want to add one specific element to multiple pages. To copy element first select it, then press

Ctrl+C and then Ctrl+V in the page you with to have it copied.

Page 27 of 40

Rev #17 LX Styler version 8.10

4 LXNAV Connect Integration

May 2021

LX Styler supports uploading and downloading of lx profiles and checklists from your LXNAV

Connect data services.

To use any of the functionality offered by LXNAV Connect from LX Styler, you must be signed in into your Connect account, you can do this by clicking on the " " button in the top right corner of the Main window. If your name is displayed alongside it, that means you are already singed in. You can also ignore this step and LX Styler will prompt you for your credentials once required.

In order to log out of your account press the same button again and a menu will appear; click the "Log out" menu item.

4.1

Uploading Files

To upload your currently opened checklists or lx profile either click the " " button in the toolbar or go to the “File” menu in the main window, select “LXNAV Connect” and then click

"Upload". If you are not logged into your Connect account already you will be prompted to do so.

Choosing Services

Next you will be prompted to select what services to upload the file to. You select a service by clicking its checkbox. The file will only be uploaded to the selected services. To continue click "OK", to cancel the upload click "Cancel".

Page 28 of 40

Rev #17 LX Styler version 8.10 May 2021

Please note that if a service is greyed out this is either because the service is unavailable, discontinued, an error occurred or you simply are not signed into it.

You can solve the latter by going to your LXNAV Connect Dashboard and singing in with that service.

File Name

The name of the file will be the same as it is displayed in LX Styler.

If one or more of the services you selected already has a file with the same name in the

"profiles" folder, you will be prompted what to do.

You may choose a different name for the file to be uploaded, overwrite the files with the same name, or cancel the upload.

Tracking Progress

You can track the progress of the upload by looking at the status bar that appears on the bottom of the main window.

Page 29 of 40

Rev #17 LX Styler version 8.10 May 2021

When the upload completes for all of your selected services, you will be notified. If uploading to any service failed you will be shown the details of the error.

4.2

Downloading Files

You can download files from your own data services by clicking on the " " button in the top right corner, or by clicking on “File” menu then selecting “LXNAV Connect” and finally

"Download". A new window will appear listing your services on the left. You can view files on a service by clicking its row, after that LX Styler will query the service and display the files on the right-hand side. You then download a file by selecting it and clicking the "Download" button or simply by double clicking the row. Once the download completes, the download window will close and your file will be opened for editing.

Page 30 of 40

Rev #17 LX Styler version 8.10 May 2021

Please note that if a service appears greyed out, this is either because the service is unavailable, discontinued or you simply are not signed into it. You can solve the latter by going to your LXNAV Connect Dashboard and signing in with that service.

You can cancel the download before it completes by clicking the "Cancel" button.

4.3

Automatic file synchronization

Files downloaded from your LXNAV Connect services can be automatically synchronized with

LX Styler. This means that whenever you open a file you downloaded from LXNAV Connect you will receive a warning if the remote file has changed and when you close LX Styler it will automatically update the remote file for you.

In order to enable this feature, open the "Settings" menu and make sure "Automatically synchronize edited profiles to my private storage via LXNAV Connect" is checked. You can toggle the option by clicking on it.

When you open a file with enabled synchronization LX Styler will check if the remote file has changed and if the file you just opened has been modified outside of LX Styler. In case only one of the files was modified the one that was modified will be loaded, if both were modified you will be prompted which one you would like to load.

Page 31 of 40

Rev #17 LX Styler version 8.10

5 Profile Collection Integration

May 2021

LX Styler also supports uploading to LXNAV Profile Collection where pilots may upload their profiles in order to share them with the rest of the world.

5.1

Upload Modes

Both manual and automatic uploading of profiles to Profile Collection is supported.

When uploading in either mode you will be prompted to sign in to your LXNAV Connect account

(if not already signed in) before the upload begins. Your name will also appear alongside the uploaded profile.

5.2

Settings

To change the current settings, select "Settings", then click on "Automatically upload my profiles to LXNAV Profile Collection (public)". If the option is checked LX Styler will automatically upload the open profile when you save it.

5.3

Uploading

To upload your profile, click on the " " button, or go to the “File” menu, select "Profile

Collection" and then click "Upload". If you are not signed into your LXNAV Connect Account you will be prompted to do so. Then you will be prompted to name your profile once you have done that the upload will begin.

If automatic mode is enabled the application will automatically upload your profile to Profile

Collection when you save it on your local computer.

5.4

Browsing

To open the Profile Collection web page, click on the " " button in the toolbar, or go to the

"File" menu, then "Profile Collection" and finally click "Browse". The web page should open in your default web browser.

Page 32 of 40

Rev #17

6 Updating LX Styler

LX Styler version 8.10 May 2021

Every time LX Styler starts it will automatically check for a newer version. If a newer version is available you will be prompted to install it. If you choose to do so the application will close and installation will automatically begin.

It is also possible to manually check for updates,you do this by selecting the "help" menu in the main window and clicking the "Check for updates" option.

Page 33 of 40

Rev #17 LX Styler version 8.10 May 2021

7 Polar Designer

The polar designer is a tool for calculating glider polar parameters. Additionally, you can enter glider name and other characteristics of a glider such as competition class, max. weight, etc.

Polar parameters with the glider characteristics will be automatically added to the existing profile or you can manually insert the calculated parameters on the device.

The "Profile designer" tool can be opened from the Tools menu from the Main window.

Toolbar

Property editor

Points editor

Grid

7.1

Getting Started

You can enter a new glider or select a glider from a preset glider list. Polar parameters will be calculated when there are at least three points inserted on the grid. With the additional points you can refine the resulting polar.

Points can be inserted via the Points editor or with a single left click directly on the Grid. A single right click on the point will remove the point. You can also move points by moving the mouse while pressing the left button.

A good practice is to load a polar image to the Grid. Through the toolbar you can modify the image to exactly align the horizontal and vertical coordinates. The coordinates must be exactly aligned with the image in order to obtain accurate results. In the Property editor you can change each coordinate unit and range. Add a few points to exactly match the polar line in the image.

Page 34 of 40

Rev #17 LX Styler version 8.10 May 2021

7.2

Toolbar Commands

New Document

You can reset all changes by clicking on the "New document" command. If unsaved changes exist the prompt for saving the current settings to a lxpolar file will be shown.

Open Polar

All previously saved settings can be loaded from the lxpolar file with the "Open polar" command.

Save

The "Save" command saves the current settings including polar image to an lxprofile file.

Open Image

With the "Open image" command you can load an image to the grid as a helping tool for defining a polar.

Exit

The "Exit" command closes the polar designer tool. If unsaved changes exist the prompt for saving the current settings to a lxprofile file will be shown. All glider parameters will be automatically stored to a profile if a glider exists in the profile.

Show Grid

Clicking on the "Show grid" command will toggle between hiding and showing the grid lines.

Select Image

When clicking on the "Select image" command enables or disables the image selection tool.

You should align each image corner with the coordinates and then press Crop Image.

Page 35 of 40

Rev #17 LX Styler version 8.10 May 2021

Crop Image

The "Crop image" command crops image according to the selected image corners.

Rotate Image Right 90°

Click on the "Rotate Image Right 90°" command to rotate the image clockwise.

Rotate Image Left 90°

Command "Rotate Image Left 90°" rotates polar image counter clockwise.

Flip Image Vertical

Command "Flip Image Vertical" flips image vertically.

Flip Image Horizontal

Command "Flip Image Horizontal" flips image horizontally.

Page 36 of 40

Rev #17

8 Glider Presets

LX Styler version 8.10 May 2021

Glider Presets is a tool for defining the important polar and glider parameters. The tool corresponds to the "Polar and Glider" Setup menu on the device.

With the tool you can generate or edit an existing Glider Presets file with the .lxg extension.

The file can contain more than one glider.

You can access Glider Presets tool from the Tools menu from the Main window.

8.1

Toolbar Commands

New

When clicking on the "New" command, all gliders will be cleared. If there are unsaved changes the message for saving changes will pop up before clearing all gliders.

Open

The "Open" button opens an existing configuration (*.lxg) file. A configuration file can be opened directly from the file explorer or with the "Open" command from the Main window screen. If you have already used a tool for editing, you can open some of the recently opened files from the list in the "File menu" from the Main window.

Page 37 of 40

Rev #17 LX Styler version 8.10

Save

The "Save command" saves all current configurations into *.lxg file.

Add Glider

The "Add Glider" command opens the dialog with the Glider name will pop up.

May 2021

Remove Glider

The command "Remove Glider" removes the glider from the list.

Rename Glider

The dialog with the Glider Name is shown. The Glider Name must be unique in the list.

Polar Designer

The polar parameters A, B and C can be determined with the help of the Polar Designer tool.

To transfer the parameters back from the Polar Designer you need to click the "Apply” button

from the top right corner of the Polar Designer Refer to Chapter 8 Glider Presets for the the

instructions regarding the Polar Designer Tool.

Page 38 of 40

Rev #17

9 Revision History

LX Styler version 8.10 May 2021

4

5

6

7

Rev Date

1 December 2009

Comments

Initial release of the manual

2

3

May 2015 Described new symbols, dialogs and functionality

September 2016 New checklists file format and new symbols; Updates and typo fixes

January 2017

February 2018

March 2018

June 2018

Updated range editor described 2 new symbols

Updated Sections: 2.5, 3.3.2

English correction done by JR

Updated Section 2.5

8

9

January 2019

February 2019

10 April 2019

11 May 2019

Added description for Forecast legend symbol, updated data symbols

Added Chapter 6

12 September 2019

Added Chapter 7 (Polar Designer)

13 January 2020

14 February 2020

15 March 2020

16 April 2021

17 May 2021

Added instructions for LXNAV Connect and Profile Collection

Updated Section: 4, 5; Added instructions for automatic file synchronization

Added Chapter 8 (Glider Presets), updated data symbols

Updated Section 1.2

Corrections to English language text.

Style update, Added chapter 3.2.8

Minor fixes

Page 39 of 40

Rev #17 LX Styler version 8.10 May 2021

Page 40 of 40

advertisement

Related manuals

Download PDF

advertisement