XMAP Quick Start Guide
Manual: XMAP Quick Start Guide
XMAP-QSG-0.7.1
1. XMAP Quick Start Guide
This short document is intended to assist you in getting your XIA xMAP Digital Spectrometer PXI
system up and running. The xManager software operates on Windows 2000/XP machines. The xMAP
software and firmware is under continuing development, as is the documentation. A more thorough
Getting Started Guide and a User's Manual will be provided in the near future. Meanwhile, refer to
Chapters 4-6 of the Saturn User's Manual (http://www.xia.com/Manuals/Kepler_Saturn_Manual_4.0.2.pdf)
for more thorough discussion of the DXP spectrometer architecture. All updates will be posted online at:
http://www.xia.com/DXP-XMAP.html
1.1. Software Installation
Please close all applications that are currently running, then double-click on the file "Setup.exe"
included with the installation package. Follow the steps as directed on-screen. We recommend that all
users install all included components. The xManager 0.7 installation will create a new directory:
"C:\Program Files\xia\xManager 0.7". A new Start Menu > Program group will also be created. Do not
attempt to run xManager until the xMAP hardware has been installed and the PXI system has been
configured as described below.
1.2. Hardware Installation
XIA recommends using National Instruments PXI instrument crates, and this document assumes
this recommendation has been followed. In any case, please follow the instructions provided with your
crate and controller.
Note: XIA PXI modules are NOT hot-pluggable. Never attempt to install or remove an
xMAP Digital Spectrometer module while the instrument crate is powered on. Such action can
irreparably harm the module.
Turn off the host computer and PXI crate power. Install xMAP modules in the PXI crate, making
sure that the cards are fully inserted and each card's handle is secured such that it protrudes horizontally.
Connect your detector outputs to the xMAP SMA input connectors. We recommend using a moderateintensity x-ray source with easily identifiable spectral lines. Turn on the power for your detector and PXI
crate.
1.3. xMAP Driver Installation
Restart the host computer. Windows should automatically find the new hardware and start the
Found New Hardware Wizard.
1. Press "Next" to proceed to the "Install Hardware Device Drivers" page.
2. Select "Search for a suitable driver for my device (recommended)" option and press
"Next" to proceed to the "Locate Driver Files" page.
3. Select "Specify a location" and press "Next".
4. Browse to, or type "C:\WINNT\inf" for Windows 2000, or "C:\Windows\inf" for
Windows XP, and press "OK"
5. Windows should find the file "xmap9054.inf" in the specified directory. Press "Next" to
complete the driver installation.
6. Repeat steps 1-5 for each xMAP module installed.
9/6/2005
1
Manual: XMAP Quick Start Guide
XMAP-QSG-0.7.1
1.4. PXI System Configuration
In order to properly identify slots in the crate, xManager parses the PXI system configuration file
"pxisys.ini". National Instruments provides software for creating this file called "Measurement and
Automation Explorer", or MAX. If you have not already done so, follow the instructions provided with
your crate and controller to generate the system configuration file. Verify that the file exists in
"C:\WINNT" directory for Windows 2000, or "C:\Windows" directory for Windows XP.
1.5. xManager System Configuration
1.5.1. Initialization Files
xManager uses an initialization, or INI, file to store system information, such as the number and
slot location of xMAP modules in the system, detector characteristics and spectrometer settings. In order to
start properly, at minimum xManager needs to know:
The location of the xMAP firmware file (DSP and FPGA code that runs on the board,
included in the installation package).
The number of xMAP modules in the system.
The type of detector preamplifier used, i.e. reset or RC decay.
The polarity of the detector preamplifier.
The gain of the detector preamplifier in [mV/keV].
The reset time period for reset type detectors, or the RC decay time for RC type detectors.
INI files can be updated at any time, i.e. after the spectrometer settings have been optimized, by
selecting "Save Configuration", or "Save Configuration As…" from the "File menu. Existing INI files can
be loaded at any time by selecting "Load Configuration…" from the "File" menu. If you have previously
run with xManager, your registry settings will point to the most recently used INI file, and xManager will
automatically run with these settings upon startup.
1.5.2. Creating an INI file using the Configuration Wizard
Start xManager via the Start menu: Start > Programs > xManager 0.7 > xManager. The first time
xManager 0.7 starts up, an "xManager Configuration File Error" will be generated. Check the box
"Generate a new configuration file" to launch the "Configuration Wizard", which guides the user step-bystep to create an INI file. Note that the "Configuration Wizard" can also be launched at any time from the
"Tools" menu in xManager.
1. Welcome to the xMAP Configuration Wizard:
Press "Next" in the xMAP Configuration Panel.
2. Starting Template:
Select "<default blank template>" and press "Next". Note that if you have an existing
INI file you can select it instead to use as a template such that some data entry steps
below are skipped.
3. Firmware:
Press the "FDD File…" button to browse, or type " C:\Program Files\xia\xManager
0.7\firmware\xmap_revb.fdd" and press "Next".
4. Detector Configuration:
Select the appropriate detector type. Currently only reset detectors are supported. Enter
the reset time period. This is the time in microseconds that the preamplifier takes to reset
and settle, and should be set conservatively to prevent associated voltage transients from
9/6/2005
2
Manual: XMAP Quick Start Guide
5.
6.
7.
8.
XMAP-QSG-0.7.1
entering the spectrum. If you don't know the reset time enter 100 (microseconds). Press
"Next".
Detector Element Property:
Check the box "Apply to All Detector Elements", and enter the number of detector
elements in your system. Note that each xMAP Digital Spectrometer can process four
independent detector elements. Enter the polarity: "-" if xray steps generate a negative
voltage step; "+" if xray steps generate a positive voltage step. If you don't know the
polarity, keep the default (negative) setting. Enter the gain in [mV/keV]. If you don't
know the gain, keep the default of (3 mV/keV). Press "Next".
PCI Configuration:
If you selected "<default blank template>" in step 2 above, or you have changed the slot
configuration or number of modules in your system, select "Use current system
information". This option will result in the parsing of the PXI system configuration file
"pxisys.ini" described in section 1.4 above, such that xMAP modules located in the crate
are organized from left to right. If you selected an existing INI file in in step 2 above,
and would like to use the slot configuration or number of modules stored therein, select
"Use the values from template file". Press "Next".
xMap PCI Configuration:
This panel displays all located xMAP modules, ordered from left to right. In the future
this panel will allow for arbitrary slot reordering. Press "Next".
Save Completed Configuration:
The INI file you have created can now be saved. Select a unique name for the file, e.g.
"C:\Program Files\xia\xManager 0.7\xmap_32module.ini". Press "Finish" to save the INI
file and exit the Configuration Wizard.
1.5.3. Loading an INI file
Select "Load Configuration" from the File menu. Browse to and select the file that you just
created and press "Open". xManager will download firmware and initialize the xMAP modules in your
system.
1.5.4. Saving an INI file
INI files can be updated at any time, i.e. after the spectrometer settings have been optimized, by
selecting "Save Configuration", or "Save Configuration As…" from the "File menu. You may find it useful
to maintain several INI files, e.g. for operating with different detectors, or with different spectrometer
settings.
1.6. Verifying the Detector / Preamplifier Settings
Before taking a spectrum, it's a good idea to first verify that the preamplifier polarity and gain
have been set properly. Your detector should be powered, and moderate-intensity x-rays should be present,
i.e. ~ 10,000 counts per second per channel. Note that under these conditions the xMAP front-panel LEDs
adjacent each input should be flashing green. If they are not, this is a good indication that your
preamplifier signal polarity is incorrect.
1.6.1. Viewing the X-ray Signal
Select the "Traces" tab at the bottom of the main plot window. Select "ADC" from the drop down
list at the top of the main plot window, and enter "1" microsecond in the "Sampling Interval" text box.
Press the adjacent "Get Trace" button to display 4000 points, or 4 milliseconds, of ADC data. To zoom,
9/6/2005
3
Manual: XMAP Quick Start Guide
XMAP-QSG-0.7.1
hold the Ctrl key and click-and-drag in the plot window. To pan, click-and-drag on the plot axes. To reset
the display, right-click in the plot window and select "Full Scale".
The plot window should display positive x-ray steps, i.e. with a rising edge, 'riding' on a
negatively sloped baseline. These steps should be between 50-500 ADC units in height. You may also see
much larger 'tracking' steps that recover the ADC signal to midrange (~8192 ADC units) after it has drifted
out of range, or after the preamplifier reset has occurred. If your signal matches this description, proceed to
section 1.7 below.
1.6.2. Changing Detector / Preamplifier Settings
Select the "Detector" tab at the bottom of the left-hand settings panel. Change the polarity and
preamplifier gain as necessary and press "Apply". When the signal looks as described above, press "Save"
to update your INI file. You are now ready to acquire a preliminary spectrum and calibrate the gain.
1.7. Spectrum Acquisition and Calibration
Select the "MCA" tab at the bottom of the main plot window. Press "Start Run". If the
"Continuous" checkbox is selected the spectrum display will automatically update. Otherwise press the
"Update" button to manually refresh the display. After you have collected sufficient data, press the "Stop"
button. Note that run statistics, including realtime, livetime, input and output count rates and the total
number of events are displayed above the plot window. Note also that MCA data for the current channel
can be saved to a file by pressing "Save Run".
1.7.1. Selecting a Region of Interest (ROI)
In order to calibrate the gain, you must first select a region of interest. Right-click in the plot
window and select "Place Cursor 1". Drag the cursor to the center of an identifiable peak. Right-click on
the cursor itself and select "Auto ROI". Notice that a region of interest around the peak has been created.
The ROI table below the plot window displays the upper and lower limits of the region, the number of
events enclosed, the output count rate, the Guassian mean and full-width-half-maximum (FWHM)
resolution. If insufficient data has been collected the Auto ROI function may fail to properly select the
peak. Note that the ROI limits can be edited graphically by selecting and dragging the limits in the plot
window, or by editing the limit fields in the ROI table.
1.7.2. Gain Calibration
Enter the energy in kilo-electron-volts (keV) of the selected peak in the "Calib. (keV)" field of the
ROI table. Press "Calibrate ROI" to automatically adjust the xMAP analog gain. Acquire a new spectrum
to verify that the gain has been calibrated. Repeat until the peak centroid matches the specified energy to
your satisfaction. You may want to save you INI file again at this point.
1.8. Spectrometer Settings and Optimization
1.8.1. Channel Selection
Note that data is only displayed for the currently selected processing channel, i.e. detector element.
The channel selection control is located in the upper lef-hand corner, below the File, Tools and Help
menus. In most cases we recommend selecting the "Apply to All" checkbox such that settings changes are
applied to all channels.
9/6/2005
4
Manual: XMAP Quick Start Guide
XMAP-QSG-0.7.1
1.8.2. Automatic Gain Matching
If you select another channel you will likely find that the spectrum on that channel is not
calibrated. We have seen detector gains vary by 30% from element to element, and many detectors drift
significantly with temperature and time. xManager allows for the calibrated gain of each channel to be
saved and restored via the INI file. Nonetheless, because of drift, you may need to recalibrate the system at
regular intervals. The gain matching function facilitates this task by automatically calibrating all selected
channels simultaneously.
By default all channels are selected for gain matching. To de-select a channel, click the
"Channels" settings tab and click in the "Skip" field. Now select the "GainMatch" tab below the main plot
window. Enter conservative upper and lower limits in the "Lower" and "Upper" fields of the "Calibration
Peak Range (KeV)". For example, if searching for a 5.9keV peak, enter 3 and 9. Press "Start Gain
Matching" to start the iterative process. Use a higher "Number of Iterations", smaller "% of Calibration
Energy" and longer "Acquisition Time (s)" to increase the precision. When you are satisfied with the
results, save your INI file!
1.8.3. Decimation and Peaking Time
As with all DXP spectrometers, the XMAP decimates the ADC signal to extend the peaking time
range, i.e. 2N ADC samples are averaged to produce a single data point at the digital filter input, where N is
the decimation. The ADC sampling period is 50ns. Currently:
Decimation 0 (4 samples/point):
100ns <
Peaking Time
<
500ns
Decimation 2 (4 samples/point):
500ns <
Peaking Time
<
8.00µs
Decimation 4 (16 samples/point):
8.00µs <
Peaking Time
<
32.0µs
Decimation 6 (64 samples/point):
32.0µs <
Peaking Time
<
128.0µs
The peaking time is set in the "Configuration" settings tab of the left-hand settings panel. To
change the peaking time (and decimation), simply enter the new value in the "Peaking Time" text box and
press "Apply". If the new peaking time crosses a decimation boundary, you will hear relays clicking as
xManager downloads new firmware to the xMAP modules.
1.8.4. Thresholds
As with all spectrometers, proper threshold settings are key to optimum results. The DXP
employs up to three (3) digital filter paths, each with it's own triggering threshold, running simultaneously
on the input signal. Generally speaking, a longer filter length produces better noise reduction but worse
time resolution.
The "Trigger" filter has a very short length, typically fixed at 50ns – 100ns, and is used solely
to identify the time of occurrence of incident x-rays. The Trigger threshold is typically set
between 750 and 2000 eV.
The "Baseline" filter runs at exactly one fourth the peaking time. This filter is used both for
soft x-ray detection and for generating the baseline average, the smoothed baseline value that
is subtracted from the pulse peak sample to yield the pulse height, or energy.
The Baseline threshold can typically be set significantly lower than the Trigger filter,
however, the precise setting depends on the peaking time. For high resolution detectors, and
at longer peaking times the Baseline threshold can usually be set to 150–300 eV.
Note: There is no Baseline filter present for peaking times at or below 500ns, i.e. for
decimation 0.
The pulse peak sample is acquired at the "Energy" filter output. This filter is the longest of
the three, and corresponds to the specified peaking time. In rare cases this filter can be used
for the detection of very soft x-rays, but in nearly all cases the threshold should be disabled by
setting it to zero.
9/6/2005
5
Manual: XMAP Quick Start Guide
XMAP-QSG-0.7.1
Thresholds are set in the "Configuration" settings tab of the left-hand settings panel. Edit a
threshold and press "Apply" to try a new setting. Be aware that thresholds set too low, i.e. at or below
noise levels, can produce very poor performance. A large noise peak near 0 eV in the spectrum, and
reduced output count rate are sure signs that one of the threshold settings is too low. It is best to acquire a
spectrum after each threshold adjustment, monitoring the noise peak and the output count rate. Be sure to
save the INI file after thresholds have been optimized.
1.9. Going Further
There are many features and settings available in the current release that have not been
documented yet:
The number of bins and MCA bin width can be changed in the Configuration settings tab.
The "Dynamic Range" setting along with the detector gain setting control the xMAP analog
gain. Assuming the detector gain is set properly, an x-ray with energy equal to the dynamic
range setting will produce a step spanning 40% of the ADC input range. X-rays with energy
greater than the dynamic range setting will not be processed efficiently. Setting the dynamic
range too low will produce a dead region at the high end of the spectrum; setting it too high
may result in degraded energy resolution, if noise is not properly digitized. Typically we
recommend using a setting of approximately 40keV.
Baseline display and optimization. Varying the number of "Baseline Average" samples in the
Configuration settings tab can improve performance.
The "Preset Run" control above the plot window allows for various types of fixed-length runs.
The SCA settings tab contains controls for SCA data acquisition. We recommend first
selecting and ROI (as described in 1.7.1 above) for each desired SCA output, then inserting
them into the SCA table: First click the desired ROI to make it active, the press the "Insert
Active ROI" button.
1.10. Support
Please email xManager software support questions to: [email protected] , and hardware
support questions to: [email protected] .
xManager can save most types of system information and data to external files to aid in the
support process.
The xManager log file "xManager.log" is located in your xManager directory. The file
contents can be viewed at any time by selecting the "Log" tab in the main plot window.
DSP settings can be viewed by selecting "DSP Parameters" from the Tools menu. Press
"Export to File…" to create a complete DSP parameter settings file.
ADC, Baseline and MCA data can be very useful when debugging a system. To create these
files simply press the "Save…" button in the upper right-hand corner of the respective plot
window tab.
9/6/2005
6
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement