Micro Drivven Combustion Analysis Tool (µDCAT) User`s Manual

Micro Drivven Combustion Analysis Tool (µDCAT) User`s Manual
Micro Drivven Combustion Analysis Tool
(µDCAT)
User’s Manual
Version 1.86
April 2009
Drivven, Inc. • 12001 Network Blvd, Bldg E, Suite 110 • San Antonio, Texas 78249 • USA
Phone : 210.248.9308
Web : www.drivven.com , E-mail : [email protected]
Drivven, Inc.
µDCAT
Table of Contents
Introduction ......................................................................................................................... 3
Installing and Activating µDCAT ......................................................................................... 5
DCAT Hardware Setup ....................................................................................................... 6
USB-6251 / USB-6259 (M-Series) ................................................................................. 7
CompactDAQ.................................................................................................................. 9
Running µDCAT................................................................................................................ 11
Starting µDCAT ............................................................................................................ 12
Measurement and Engine Setup .................................................................................. 13
Measurement Setup ................................................................................................. 13
Engine Setup............................................................................................................ 15
Motoring, TDC Alignment and Pegging........................................................................ 17
Filtering ......................................................................................................................... 19
Viewing All Waveforms................................................................................................. 20
Calculation Setup and Results ..................................................................................... 21
Pressure Metrics ...................................................................................................... 21
Heat Release............................................................................................................ 22
Pressure Ratio.......................................................................................................... 23
Viewing Trends and Summary Data............................................................................. 24
Trends ...................................................................................................................... 24
Summary .................................................................................................................. 25
Saving Data .................................................................................................................. 26
Post Processing Data Files............................................................................................... 28
Opening TDMS Files in Excel....................................................................................... 29
Post Processing (Summary Files) ................................................................................ 30
Opening a Raw Data File ............................................................................................. 32
Post Processing (Raw Files) ........................................................................................ 33
Expected Performance ..................................................................................................... 34
Calculations ...................................................................................................................... 36
Frequently Asked Questions............................................................................................. 37
© Drivven, Inc. 2009 • µDCAT • Version 1.86
2
Drivven, Inc.
µDCAT
Introduction
The micro Drivven Combustion Analysis Tool (µDCAT) is a combustion analysis
application built from the Drivven Combustion Analysis Toolkit (DCAT). While the DCAT is a
toolkit for programming custom engine control and analysis applications using LabVIEW, µDCAT
is an installed executable which interfaces automatically to USB DAQ and CompactDAQ devices
from National Instruments. Furthermore, µDCAT does not require installation of LabVIEW
development tools in order to run. Instead, µDCAT only requires installation of the free LabVIEW
run-time engine and DAQmx device drivers. µDCAT is designed as a low-cost, easy-to-use,
portable engine combustion analysis tool.
µDCAT was designed to work with the USB-6251/USB-6259 and CompactDAQ devices.
However, it is compatible with any device that is fully compatible with the National Instruments
DAQmx device driver. While monitoring combustion analysis parameters, µDCAT allows
streaming of raw data or summary data to file continuously, by cycle count, time, or file size. Raw
data files are stored in National Instrument’s popular TDMS format and include all channel
configurations, engine geometry and custom test data to allow complete reconstruction of the test
environment at a later date. Cycle by cycle summaries of analysis parameters can also be logged
to TDMS files for later review. TDMS files may be opened and analyzed in Excel using a free
TDMS file plug-in.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
3
Drivven, Inc.
µDCAT
DCAT Features
Channel Configuration and Engine Geometry
• Supports 1 M-Series device for multiplexed sampling of signals engine-synchronously
(cylinder pressure, etc.)
• Individual channel scaling features
o Cylinder Assignment
o Gain
o Gain + Offset
o Polynomial
o Table Lookup
• Any channel may be assigned to all cylinders as a pegging reference
• Complete set of engine geometry inputs for cylinder volume calculation
• Online motoring test assists with engine geometry verification
Pre-Processing
• Cylinder alignment of data
• Data scaling to engineering units
• Broad range of signal filtering options
• Cylinder pressure pegging options
Pressure Metrics
• Peak Pressure and Location
• Polytropic coefficients of compression and expansion
• Maximum Rate of Pressure Rise and Location
• Pressures at IVO and EVC
• Gross MEP, Pumping MEP, Net MEP
Heat Release Analysis
• Methods include
o Single Zone
o Single Zone Dual Transducer (for pre-chamber engines)
o Single Zone + Heat Transfer
o Single Zone Dual Transducer + Heat Transfer
o Modified Rassweiler and Withrow
• Locations of Mass Fraction Burned (5%MFB, 25%MFB, 50%MFB, 75%MFB, 90%MFB,
Custom)
• Maximum Heat Release Rate and Location
• Variety of heat transfer correction methods
• In-cylinder temperature estimation
© Drivven, Inc. 2009 • µDCAT • Version 1.86
4
Drivven, Inc.
µDCAT
Installing and Activating µDCAT
Recommended System
CPU:
1.6 GHz Dual Core or Greater
OS:
Windows XP, Windows Vista
Memory: 1024MB
HDD:
2 GB Free Disk Space
USB:
2.0 (for USB devices)
Software: DAQmx 8.8, LabVIEW Run-Time 8.6, CalVIEW 1.86
Display:
15” wide screen, 1280 x 800 dpi
DAQmx 8.8
LabVIEW Run-Time 8.6
CalVIEW 1.86
µDCAT 1.86
http://joule.ni.com/nidu/cds/view/p/id/1085/lang/en
http://joule.ni.com/nidu/cds/view/p/id/1244/lang/en
http://www.drivven.com/visitor_download/Software/CalVIEW1.86.zip
http://www.drivven.com/visitor_download/Software/uDCAT1.86.zip
It is assumed that users of µDCAT are familiar with internal combustion engine concepts,
common practice for acquiring combustion-related data, as well as combustion analysis methods.
However, the µDCAT is designed so that users with no LabVIEW experience can run the
application.
µDCAT requires Drivven’s CalVIEW (Calibration toolkit for LabVIEW) to operate.
CalVIEW must be installed and licensed before µDCAT will operate. To license CalVIEW, a
computer ID, found in the CalVIEW help menu under activate, must be e-mailed to
[email protected] An activation key will be provided. Please reference the CalVIEW User’s
Manual for details on setting up CalVIEW.
µDCAT must also be activated in order to enable its components. The device serial
number is used for activation. It may be located in the National Instruments Measurements and
Automation eXplorer (MAX). The serial numbers are typically displayed in hex (represented by a
“0x” in front of the number). Please indicate if the number is in a different radix. The device serial
number must be e-mailed to [email protected] along with your name, company name,
address and telephone number. Please allow 1-3 business days to validate your account and
generate a key. An activation key (32 Characters ex. 9DCJ-RN79-QBEE-TPKW-BBAB-GT3ZRXYC-CFCW) will be generated by Drivven and sent to the customer via reply email. The key
will contain only the following characters A B C D E F G H J K L M N P Q R S T W X Y Z 3 4 7 9.
The activation key may expire at a specific time if generated for evaluation purposes.
The activation key must be place in a text file called “uDCAT.dat” in the “c:\ni-rt\system”
directory. The directory may not exist and may need to be created by the user.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
5
Drivven, Inc.
µDCAT
DCAT Hardware Setup
µDCAT is configured to utilize a USB M-Series Devices (USB-6251 BNC and USB-6259
BNC) or the USB CompactDAQ chassis (with up to 4 NI-9215s and a NI-9401 or NI-9411). Any
fully DAQmx compatible card may work but only the listed devices have been tested.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
6
Drivven, Inc.
µDCAT
USB-6251 / USB-6259 (M-Series)
The USB-6251 and the USB-6259 are M-Series DAQ devices available in a BNC formfactor that provides a simple interface to many combustion and test cell sensors.
Figure 1: USB-6251 BNC
The instrumentation signals should be connected to the USB-6251 / USB-6259 according
to Table 1. The crankshaft optical encoder may be optionally powered by the USB-DAQ device
+5V and DGND screw terminals. The maximum current draw is 1A. If the encoder is externally
powered, then the encoder Z and A signals must have their BNC connectors properly connected
to the encoder ground. Shielded BNC cables are recommended. The USB DAQ device
When using the DAQ device with µDCAT, only the terminals listed in Table 1 should be
used. In order to take full advantage of certain hardware features, µDCAT makes programmatic
internal connections. Connecting signals to other terminals or running other programs which
interact with the same DAQ device is not prohibited, but Drivven cannot guarantee compatibility
between µDCAT and such programs.
The National Instruments Measurements and Automation eXplorer (MAX) should be used
to discover (or change, if desired) the name of the DAQ device and its physical channels. The
names of the device and physical channels will be used on the measurement configuration tab of
the user interface.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
7
Drivven, Inc.
µDCAT
Table 1: Instrumentation connections to USB-6251 / USB-6259
Instrumentation Signal
Encoder +5V (optional)
Encoder Ground (optional)
Encoder Z
Encoder A
Measurement 1
Measurement 2
Measurement 3
Measurement 4
Measurement 5
Measurement 6
Measurement 7
Measurement 8
Measurement 9
Measurement 10
Measurement 11
Measurement 12
Measurement 13
Measurement 14
Measurement 15
Measurement 16
USB-6251/USB-6259 BNC Terminals
Externally Supplied or +5V Screw Terminal
Externally Supplied or D GND Screw Terminal
PFI 1 / P1.1
PFI 0 / P1.0 or APFI 0
AI 0
AI 1
AI 2
AI 3
AI 4
AI 5
AI 6
AI 7
AI 8 (USB-6259 only)
AI 9 (USB-6259 only)
AI 10 (USB-6259 only)
AI 11 (USB-6259 only)
AI 12 (USB-6259 only)
AI 13 (USB-6259 only)
AI 14 (USB-6259 only)
AI 15 (USB-6259 only)
© Drivven, Inc. 2009 • µDCAT • Version 1.86
8
Drivven, Inc.
µDCAT
CompactDAQ
The CompactDAQ chassis may be used with µDCAT if the proper hardware configuration
is provided. The CompactDAQ chassis should be configured with the first four slots filled with
one to four NI-9215 modules and the fifth slot should have a NI-9401 or NI-9411 digital input
module, as shown in Table 2.
Figure 2: CompactDAQ System
Table 2: Module placement in the CompactDAQ chassis
CompactDAQ Slots
Slot 1
Slot 2
Slot 3
Slot 4
Slot 5
Slot 6
Slot 7
Slot 8
CompactRIO Modules
NI-9215 (required)
NI-9215 (optional)
NI-9215 (optional)
NI-9215 (optional)
NI-9401 or NI-9411 (required)
Empty
Empty
Empty
When using the NI-9401 digital I/O module, the crankshaft optical encoder must be
powered externally and a ground reference from the encoder must be connected to a COM pin of
the NI-9401 module. The encoder should be connected to the NI-9401 module according to Table
3. Shielded cabling is recommended. By default, all NI-9401 DIO pins are configured as inputs.
Table 3: Crankshaft optical encoder connections to the NI-9401 module
Encoder Signal
Encoder Ground (required)
Encoder Z (required)
Encoder Z (required)
Encoder A (required)
NI-9401 DB25 Connector Pin
Slot 5 NI-9401 Pin 1 (COM)
Slot 5 NI-9401 Pin 16 (P0.1/PFI 1)
Slot 5 NI-9401 Pin 22 (P0.5/PFI 5)
Slot 5 NI-9401 Pin 14 (P0.0/PFI 0)
When using the NI-9411 digital input module, the crankshaft optical encoder may be
optionally powered by the module. If the encoder is powered from the module, power (5 to 30
VDC) must be supplied to the Vsup and COM screw terminals of the module. Vsup is internally
reduced to +5V and available from the D-Sub connector. The encoder should be connected to the
NI-9411 module according to Table 3. Please note that the NI-9411 module inputs are optionally
single-ended or differential pairs. Some optical encoders provide complimentary/differential
signal outputs which enable greater noise immunity when connected with differential digital
inputs. Table 4 shows the connections to be made for single-ended or differential operation. If
© Drivven, Inc. 2009 • µDCAT • Version 1.86
9
Drivven, Inc.
µDCAT
single-ended operation is required, then the “b” pin of each input should be left unconnected.
Shielded cabling is recommended.
Table 4: Crankshaft optical encoder connections to the NI-9411 module
Encoder Signal
Encoder +5V (optional)
Encoder Ground (optional)
Encoder Z (required)
Encoder Z Compliment (optional)
Encoder Z (required)
Encoder Z Compliment (optional)
Encoder A (required)
Encoder A Compliment (optional)
NI-9411 DB15 Connector Pin
Externally Supplied or Slot 5 NI-9411 Pin 4 (+5Vout)
Externally Supplied or Slot 5 NI-9411 Pin 12 (COM)
Slot 5 NI-9411 Pin 2 (P0.1+/PFI 1 (DI 1a))
Slot 5 NI-9411 Pin 10 (P0.1-/PFI 1 (DI 1b))
Slot 5 NI-9411 Pin 7 (P0.4+/PFI 4 (DI 4a))
Slot 5 NI-9411 Pin 14 (P0.4-/PFI 4 (DI 4a))
Slot 5 NI-9411 Pin 1 (P0.0+/PFI 0 (DI 0a))
Slot 5 NI-9411 Pin 9 (P0.0-/PFI 0 (DI 0a))
The analog instrumentation signals should be connected to the NI-9215 analog inputs
according to Table 5. The BNC version of the NI-9215 is recommended for ease of connection.
Shielded BNC cables are recommended.
Table 5: Analog instrumentation connections to the NI-9215 modules
Instrumentation Signal
Measurement 1
Measurement 2
Measurement 3
Measurement 4
Measurement 5
Measurement 6
Measurement 7
Measurement 8
Measurement 9
Measurement 10
Measurement 11
Measurement 12
Measurement 13
Measurement 14
Measurement 15
Measurement 16
NI-9215 Input
Slot 1 AI 0
Slot 1 AI 1
Slot 1 AI 2
Slot 1 AI 3
Slot 2 AI 0 (optional)
Slot 2 AI 1 (optional)
Slot 2 AI 2 (optional)
Slot 2 AI 3 (optional)
Slot 3 AI 0 (optional)
Slot 3 AI 1 (optional)
Slot 3 AI 2 (optional)
Slot 3 AI 3 (optional)
Slot 4 AI 0 (optional)
Slot 4 AI 1 (optional)
Slot 4 AI 2 (optional)
Slot 4 AI 3 (optional)
When using the DAQ device with µDCAT , only the terminals described above should be
used. In order to take full advantage of certain hardware features, µDCAT makes programmatic
internal connections. Connecting signals to other terminals or running other programs which
interact with the DAQ device may cause unexpected behavior.
The National Instruments Measurements and Automation Explorer should be used to
discover or change the name of the DAQ device and its physical channels. The names of the
device and physical channels will be used on the measurement configuration tab of the user
interface.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
10
Drivven, Inc.
µDCAT
Running µDCAT
This section of the manual covers the basics of starting, setup, and running µDCAT.
Before beginning, the latest versions CalVIEW and µDCAT should be installer and activated.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
11
Drivven, Inc.
µDCAT
Starting µDCAT
1.
Make sure CalVIEW is closed.
2.
StartProgramsDrivvenµDCATLaunch µDCAT Target and CalVIEW
3.
CalVIEW should automatically start in Mini Mode.
4.
µDCAT Target application launches. This program must run in the background
while using µDCAT.
5.
Make sure that the InitOK and Activated lights are green on the target
application.
Figure 3: µDCAT Target Program
a. If the InitOK light remains red, please contact Drivven.
b. If the Activated light remains red, a dialog box will appear asking you to
connect your hardware and retry activation. If the activated light continues
to fail, please contact Drivven.
6.
Press the Ok button on the CalVIEW dialog box indicating that the target
application is running.
7.
The µDCAT user interface starts running.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
12
Drivven, Inc.
µDCAT
Measurement and Engine Setup
Before collecting and analyzing data, the Measurement Setup and Engine Setup tabs
must be configured. While on these setup tabs, no data is collected or processed. Data
collection and processing will automatically begin when the user is on any of the following tabs.
To see a description of a control or indicator, hover over the parameters with the mouse
cursor to see the tip strip or context-help window message. The context help window may be
accessed by pressing ctl-H.
The µDCAT user interface also provides a sidebar of information to the right of the tabs
that is always visible. The sidebar shows status information such as engine speed and data
queue statistics that are useful at all times.
Measurement Setup
The Measurement Setup tab, shown in Figure 4, contains all of the configuration
information for each measurement channel and the crankshaft encoder. The total number of
measurement channels (SyncChannelCount) should be specified first. For each measurement,
a physical channel, type, scaling, and associated cylinder should be set. The
PhysicalChannel_SyncX is the device and channel name recognized by DAQmx. Ex.
“Dev1\ai0”. The MeasurementType_SyncX allows the program to separate the specific
measurements that are used for the calculations. A type of “undefined” should be used if the
measurement type is not listed. Several options are available for the scaling of a measurement.
Many of the defined measurement types require that the scaling factors be in terms of a specific
engineering unit. The AssociatedCylinder_SyncX check boxes determine which cylinders the
channel should be associated with. Some measurements, like cylinder pressure, should only be
associated with a single cylinder. Others may be associated with multiple cylinders, such as
manifold pressure. Please note that associating measurements with multiple cylinders may slow
down the system. The MeasurementName is used to store the data in the file and for display.
The units of undefined measurement types may be set to a text string that is used for display.
The Filter_SyncX refers to 1 of 16 filters that are defined on the Filtering tab. Each
measurement may be set to the same filter or to its own filter.
Each measurement may be disabled with the Disable_SyncX button. When disabled, no
data is recorded on that measurement and the configuration information for that measurement is
not included in the saved files.
The EncoderResolution and TDC_Offset must be defined for the µDCAT to function
properly. TDC_Offset must be in terms of whole encoder pulses between the Z pulse and TDCcompression of cylinder 1. Positive values mean that TDC is after the Z pulse. Please note that
TDC_Offset is a user specified value and the Actual_TDC_Offset is the closest possible value.
To set a partial encoder pulse TDC offset, use the TDC_Fine_Adj on the motoring tab.
The DAQmx device sample triggering must be setup for the Encoder A signal. The rising
or falling edge of the Encoder A signal should be selected with the A_Edge parameter. This
determines the edge of the Encoder A signal where the analog measurement is sampled. If the
Encoder A signal is connected to PFI0 input, then select PFI0 for the A_Trigger parameter, and
no further configuration is required for the Encoder A signal. If the Encoder A signal is connected
to the analog APFI input, then A_Threshold and A_Hysteresis voltages must be set.
A_Threshold is the Encoder A signal voltage at which the internal digital trigger signal goes high.
A_Hysteresis is the Encoder A signal voltage at which the internal digital trigger signal goes low.
The DAQmx start triggering and gating must be setup for the Encoder Z signal. The
rising or falling edge of the Encoder Z signal should be selected with the Z_Edge parameter.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
13
Drivven, Inc.
µDCAT
This determines the edge of the Encoder Z signal where the Encoder A sampling begins. If the
encoder is mounted to the crankshaft then press the Z_1/rev button. If the encoder is mounted to
the camshaft then leave the Z_1/rev button depressed.
The combustion analysis calculation sets may be enabled and disabled depending on the
specific requirements of the testing program. Please note that some of the calculations from one
group may be required as inputs to another group. For example, heat release with heat transfer
requires the cylinder temperature calculations.
PressureMetrics: Enables the calculations contained in the Pressure Metrics tab.
PressureRatio: Enables the calculations on the Pressure Ratio tab.
MEP: Enables calculation of Mean Effective Pressures (GMEP, PMEP, NMEP). The
MEP calculations are displayed on the Summary tab.
CylTemp: Enables the calculation of estimated cylinder temperature for the heat-transfer
calculations. This group must be enabled if heat release is calculated with heat transfer.
HeatRelease: Enables the calculations contained on the Heat Release tab.
Misfire: Enables the calculations related to misfire detection. Misfire detection is
reported on the Summary tab.
Figure 4: Measurement Setup Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
14
Drivven, Inc.
µDCAT
Engine Setup
The Engine Setup tab, shown in Figure 5, is a collection of engine geometry parameters.
The EngineName, ProjectName, and Operator are strings that are saved in the output file for
reference. They are not use in the program.
The CylinderCount should be set for the number of cylinders that are being analyzed.
The CylinderTDC array will show only the number of elements for the specified CylinderCount.
Each element of the CylinderTDC array should be specified with the relative CAD offset of each
cylinder at TDC-compression with respect to the first cylinder. Typically the first cylinder will have
a CylinderTDC of 0 and the other cylinders will have positive values spaced throughout the
engine cycle. Recall that the TDC_Offset parameter on the Measurement Setup tab specifies
the global TDC offset of the first cylinder with respect to the encoder Z pulse.
The engine geometry and valve timings are used throughout the program for various
calculation sets and should always be fully specified. HeadArea and CrownArea parameters are
entered as percentages of the bore area. For example, HeadArea and CrownArea set to 100%
assumes that the head portion of the combustion chamber and piston top are flat, and meet at
TDC. HeadArea and CrownArea set to 120% assumes that those surfaces have 20% more
surface area than the bore area. These parameters should only be adjusted above 100% if heat
release is calculated using heat transfer.
Misfire detection monitors the absolute peak combustion pressure or the NMEP. The
misfire calculations must be enabled by pressing the MisFireCalcs button on the Measurement
Setup tab. Each option for MisfireMethod is described below:
Peak Pressure (Absolute): Misfire is detected when the measured peak pressure falls
below the specified PressureThreshold.
NMEP (Absolute): Misfire is detected when the calculated NMEP falls below the
specified PressureThreshold.
Peak Pressure (% of Historic): Misfire is detected when the measured peak pressure
falls below a PercentThreshold of a rolling average of the measured peak pressure.
HistoryLength specifies the number of cycles to use for the rolling average.
NMEP (% of Historic): Misfire is detected when the calculated NMEP falls below a
PercentThreshold of a rolling average of NMEP. HistoryLength specifies the number
of cycles to use for the rolling average.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
15
Drivven, Inc.
µDCAT
Figure 5: Engine Setup Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
16
Drivven, Inc.
µDCAT
Motoring, TDC Alignment and Pegging
The motoring tab, shown in Figure 6, provides a place to check some of the key motoring
parameters to ensure that the day to day variation of the engine is within acceptable ranges.
Various motoring pressure metrics are displayed here. When the Motoring tab or any other tab to
the right of the Engine Setup tab is selected, data acquisition begins according to the
configuration of the first two tabs.
MotoringCylinder should be set to the cylinder number to be monitored. A
MotoringAverageSize may be used to average a specified number of cycles for performing the
calculations on this tab. Increasing this value will reduce the rate of updates.
The motoring polytropic coefficients of compression and expansion (PolyC_motor and
PolyE_motor) are calculated here. The crank angle ranges to be used for calculating these
parameters are entered on the Pressure Metrics tab. PolyC_motor and PolyE_motor are
displayed graphically on the PV diagram. Tolerance ranges may be set for these parameters as
a quick check of engine geometry and TDC setup.
When motoring, the TDC_Check method may be set to “Peak_Pressure”, “Spline
Interpolation”, “Half Peak Pressure”, or Most Probable”. The CalculatedTDCOffset is displayed
and the TDC_Fine_Adj parameter may be adjusted to achieve a CalculatedTDCOffset of zero.
TDC_Fine_Adj may be use to correct partial encoder pulse offsets. However, setting
TDC_Fine_Adj to a non-zero value may reduce the overall performance of the system because it
causes a re-sampling of the measurement signals by linearly interpolating the arrays of data.
µDCAT provides several methods for pegging the cylinder pressure measurements.
Pegging refers to dynamically adjusting the cylinder pressure offset. It is useful when using
sensors that measure a dynamic pressure instead of an absolute pressure. Each selection of
PeggingMethod is described below:
None: No pegging method is implemented and the measured pressure wave form, as
calculated from the specified scaling parameters on the Measurement Setup tab, is used.
Constant: The average cylinder pressure (PressureAvg, not displayed) over a specified
crank angle range is calculated. The center of the averaging range is specified by
PegLocation in CAD. The PressureAvg is calculated over a range before and after
PegLocation specified by PegAverage in CAD. The total angular range used to
calculate PressureAvg is twice PegAverage. The difference between the specified
PegPressure and PressureAvg (PegPressure – PressureAvg) is displayed in the
PeggingValue table for each cylinder and is added to the entire pressure wave form for
each cylinder.
Synchronous MAP: Synchronous MAP is identical to Constant except that a Manifold
Absolute Pressure (MAP) sensor is sampled engine synchronously and averaged over
the same angular range (MAPAvg, not displayed). MAPAvg is used instead of the
Constant-mode user-specified PegPressure. PegPressure is not used. This method
requires that a MAP sensor be connected to one of the measurement channels and
configured on the Measurement Setup tab. It should be assigned to all relevant cylinders
using the AssociatedCylinders_SyncX check boxes.
Polytropic: Uses the change in volume and pressure to determine the absolute pegging
offset. This method calculates the pegging offset over the window specified for
calculating the PolyC values on the Pressure Metrics page. The user must enter an
accurate value for the polytropic coefficient of compression in PegPolyC. Please note
that the TDC offset will effect the calculations because the cylinder volume is used.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
17
Drivven, Inc.
µDCAT
Figure 6: Motoring Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
18
Drivven, Inc.
µDCAT
Filtering
The Filtering tab, shown in Figure 7, allows configuration of up to 16 filters. The filter
number specified in the Measurement Setup tab for each measurement corresponds to the filter
number configuration on this tab. There are several types of filters that may be selected with the
FilterMethodX drop-down, including “Rolling N Cycles”, “Forward and Reverse IIR”, “FIR Filter
with Rollback”, and “Boxcar”. A comparison of these filters is beyond the scope of this manual.
When a filter type is selected, only the configuration parameters for that filter type will be shown.
The filters are applied to the measurements before being displayed on all other plots.
An ensemble average of each measurement may also be used by pressing the
EnsembleEnable button. When using the ensemble average, a specified number of cycles
(EnsembleSize) are averaged at each crank angle and the averaged results are used in the
calculations. Increasing EnsembleSize will reduce the rate at which the calculations are
performed.
Figure 7: Filtering Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
19
Drivven, Inc.
µDCAT
Viewing All Waveforms
The Data tab, shown in Figure 8, displays all the measurements associated with a single
cylinder specified in DisplayCylinder. The data is aligned with TDC, scaled, and filtered. The
undefined measurement types (selected by MeasurementType_SyncX on the Measurement
Setup tab) are displayed on this tab according to the selected associated cylinder. This is the
only tab where undefined measurement types are displayed.
Figure 8: All Data Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
20
Drivven, Inc.
µDCAT
Calculation Setup and Results
Many of the combustion analysis calculations require additional setup. The additional
setup parameters may be found on the following tabs. The individual numerical results are
displayed in the tables, having columns for each cylinder. The arrays of angle-based data are
displayed in plots. Each calculated table value has rolling statistics associated with it. The
displayed statistics may be turned off by un-checking the control next to the table. Each
individual plot can be configured for auto-scaling or manual scaling of the Y axis, by right-clicking
on the scale and checking or un-checking the “AutoScale” menu item. There are three
parameters on the bottom right side bar for configuring the Crank Angle Degrees (CAD) scale.
Pressure Metrics
The Pressure Metrics tab, shown in Figure 9, displays the results of basic analysis of
each cylinder pressure wave form. The angle parameters at the top of the tab are required for
calculating each pressure metric. The table-based calculated parameters are as follows:
PP [kPa]: Peak Pressure
LocPP [CAD]: Location of Peak Pressure
PolyC: Polytropic Coefficient of Compression
PolyE: Polytropic Coefficient of Expansion
MPR [kPa/CAD]: Maximum Pressure Rise
LocMPR [CAD]: Location of Maximum Pressure Rise
Intake [kPa]: Average pressure during intake valve opening
Exhaust [kPa]: Average pressure during exhaust valve opening
Figure 9: Pressure Metrics Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
21
Drivven, Inc.
µDCAT
Heat Release
The Heat Release tab, shown in Figure 10, displays in table and plot format the Heat
Release Rate (HRR) and Mass Fraction Burn (MFB) percentages. The dropdown menu
HeatReleaseMethod selects one of several heat release methods. Different configuration
parameters will be shown for each heat release method. The StartMethod and EndMethod
define how the start and end of combustion are determined. For more details on the heat release
calculations, please refer to the Calculations section of this manual.
Figure 10: Heat Release Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
22
Drivven, Inc.
µDCAT
Pressure Ratio
The Pressure Ratio tab, shown in Figure 11, shows calculations which are a form of heat
release based on the ratio of the calculated motoring pressure and the actual pressure.
Figure 11: Pressure Ratio Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
23
Drivven, Inc.
µDCAT
Viewing Trends and Summary Data
Trends
The Trends tab, shown in Figure 12, displays charts for a quick view of the historic data.
Any calculated parameter can be selected to see the historical trends. The available values are
displayed in the list box to the left of the trend. Holding Shift or Ctrl allows for selecting multiple
values to trend. Changing the selection will reset the trends. The listed available trends may be
filtered using the controls below the list box. Please note that trends are updated periodically.
Therefore, not every cycle of data will be displayed in the trend.
Figure 12: Trends Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
24
Drivven, Inc.
µDCAT
Summary
The Summary tab, shown in Figure 13, displays a single table of all calculated values and
associated rolling statistics. The values in the summary table are a collection of the same table
values from the previous tabs. Please note that the Mean Effective Pressure (MEP) results and
the misfire results are only displayed in the Summary tab table. Below is a definition of the MEP
calculations:
IMEP: Indicated MEP over the firing portion of the cycle defined as -180 to 180 CAD.
PMEP: Pumping MEP over the portions of the cycle defined as -360 to -180 and 180 to
360 CAD. PMEP is a negative value.
NMEP: Net MEP resulting from IMEP + PMEP. NMEP is effectively over the complete
cycle defined as -360 to 360 CAD.
Figure 13: Summary Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
25
Drivven, Inc.
µDCAT
Saving Data
The Save Files tab, shown in Figure 14, provides configuration parameters for saving two
types of data sets. The left side of the tab is used for saving raw data. “Raw Data” consists of
the absolute voltages measured directly from each channel. The raw data is streamed to disk
without any processing. Therefore, the data is not scaled or aligned to the cylinder. However,
every configuration parameter from the setup and calculation tabs is also saved to the raw data
file so the test environment can be recreated in post processing.
The right side of the tab is used for saving summary data. “Summary Data” is the set of
values calculated every cycle, such as pressure metrics and heat release. The statistics are also
calculated and saved in the file. The ensemble average of the scaled and aligned waveforms is
also saved with the summary data.
Raw data and summary data may be recorded simultaneously. The cycle number and
time stamp, which is recorded in both file types, can be used to align the summary data with the
raw data.
Both raw data and summary data types have identical file saving configurations. The raw
data file saving parameters will be described below.
Raw_Path: Defines the full path to the directory for storing the file
Raw_Filename: Defines the name of the raw data file. A suffix of XXX tells µDCAT to
append a file number to the end of the name. The file number will be assigned and
incremented according to Raw_StartCounter, Raw_Counter and Raw_ResetCounter.
Raw_SaveMethod: Selects the method for determining the end of saving raw data to file.
The options are as follows:
Continuous: Continuously save data while the Start/StopRawFile button is
pressed.
N-Cycles: Saves data for number of cycles specified by Raw_MaxCycles.
Timed: Saves data for a time specified by Raw_MaxTime.
Size: Saves data until a file size specified by Raw_MaxSize is reached.
Raw_Comments: String inserted into the raw data file.
Raw_StartCounter: Specifies the starting file number to be filled in for “XXX” in the
filename.
Raw_ResetCounter: Resets the file number to Raw_StartCounter
Start/StopRawFile: Starts and stops the file saving process.
EnableRawCMD: Enables execution of a command line when file-save finishes.
RawCMD: Command line that executes when enabled and a file-save finishes. The
following variables may be used within the RawCMD text string:
%PATH%: Used within the RawCMD text string. This variable will be replaced
by Raw_Path\Raw_Filename before RawCMD is executed.
µDCAT includes a command line utility called FileConverter.exe. This utility opens and
converts the tdms file to a cvs file. When used as a raw data file converter, the data is aligned to
the cylinder TDC offset and each column is a different measurement. The flags and arguments to
the utility are listed below in Table 6. A flag letter must be preceded with a – (dash) and
immediately followed by = (equal). For example, –r=%PATH% defines the raw data file path
using the %PATH% variable. Please note that the arguments should be enclosed in quotations if
it contains spaces.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
26
Drivven, Inc.
µDCAT
Table 6: FileConverter.exe Flags
Flag
-p
-q
-r
-s
Argument
n/a
n/a
Raw Data File Path
Summary Data File Path
Description
Commands FileConverter to write raw data to cvs
Commands FileConverter to write summary data to cvs
Defines the raw data file path
Defines the summary data file path
Example RawCMD string:
C:\Program Files\Drivven\uDCAT\FileConverter.exe -r=%PATH% -p
µDCAT also includes the LabVIEW project and source code that was used to generate
FileConverter.exe. The name of the project is Custom File Converter.lvproj and can be opened
from the Start->Drivven->uDCAT menu. The LabVIEW development tools are required to open
and modify the project. Users may use this project as a starting point to create a custom file
converter or post processing utility. Additional command line options may be added or the utility
may be operated using front panel. If an .exe utility is desired, then the LabVIEW Application
Builder toolkit is required as a plug-in to the LabVIEW tools.
Figure 14: Saving Data Tab
© Drivven, Inc. 2009 • µDCAT • Version 1.86
27
Drivven, Inc.
µDCAT
Post Processing Data Files
µDCAT saves data in National Instruments’ standard TDMS file format. TDMS files
provide a powerful and flexible way to store and retrieve data. National Instruments provides
many resources on their website to edit and view TDMS files outside LabVIEW in programs such
as MatLab and Excel. The µDCAT tool contains several VIs used to stream data from the TDMS
files.
Post Process
Configure
Re-Acquire
Preprocess
Process
Save to TDMS
File
Stream from
TDMS File
Figure 15 - Post Processing Overview
© Drivven, Inc. 2009 • µDCAT • Version 1.86
28
Drivven, Inc.
µDCAT
Opening TDMS Files in Excel
National Instruments provides a free excel plug-in that imports TDMS files. Importing a
file creates a multi-page spreadsheet with all the data stored in the file, shown in Figure 16. The
first page contains a summary of all the groups and channels. Each group has a page where
each column is a channel of data. Please note that Excel 2003 is limited to 256 columns and
65536 rows. Therefore, the custom properties (displayed in the first 2 rows on the main page)
which contain all the calculation configuration information may need to be turned off. Raw data
channels may also be too long and will be truncated.
Figure 16: Summary File Import to Excel
© Drivven, Inc. 2009 • µDCAT • Version 1.86
29
Drivven, Inc.
µDCAT
Post Processing (Summary Files)
The µDCAT Post Process Summary File example, shown in Figure 17 and Figure 18, is
set up to display all of the configuration information and allow the user to easily insert their own
post processing code. The front panel contains a tab control and several buttons to load and
view files. The slider controls the cycle displayed in the graphs and tables. The buttons labeled
for processing and saving do nothing in the example but are set up to allow the user to easily add
processing and saving code for their specific needs. The example is not set up to allow the user
to change the setup parameters because the properties have already been applied to all the
calculated values.
Figure 17: Summary Post Processor Example Front Panel
© Drivven, Inc. 2009 • µDCAT • Version 1.86
30
Drivven, Inc.
µDCAT
1
2
4
5
3
6
Figure 18: Summary Post Processing Example Block Diagram
1.
2.
3.
4.
5.
6.
Initialize the tables and plots.
Open the TDMS combustion data file.
Load the configuration data from the file.
Load the summary data from the file and populate the table and plot.
Area available for user-defined processes.
Area available for user-defined saving.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
31
Drivven, Inc.
µDCAT
Opening a Raw Data File
The µDCAT Open Raw Data File VI, shown in Figure 19 and Figure 20, is a simple
example which opens the raw data file and then allows the user to display a single cycle for a
single cylinder. The plot automatically formats to show the measurement names originally saved
with the data. Note that all the setup clusters are available and may be used for post processing
or they may be modified before post processing.
The example can easily be modified to run all the cycles for all the cylinders in order to
process an entire file. To automatically process the entire file, replace the While Loop with two
For Loops that run for each cycle and for each cylinder, respectively.
Figure 19: Open Raw Data File Front Panel
Figure 20: Open Raw Data File Block Diagram
© Drivven, Inc. 2009 • µDCAT • Version 1.86
32
Drivven, Inc.
µDCAT
Post Processing (Raw Files)
The µDCAT Post Process Raw File program, shown in Figure 21, displays and processes
the raw TDMS data file into a new summary TDMS data file. The configuration settings can be
changed and the statistics recalculated. The front panel has a similar look as that of the µDCAT
user interface. It also contains several controls related to loading files, scrolling through cycles of
data and processing the data to a new summary TDMS file.
To begin, load a raw data file using the Load File button in the lower left corner. After
loading, all setup information is placed into the appropriate controls and indicators and a single
cycle may be viewed along with the calculated values for that cycle, based on the setup
information originally provided. Ay setup parameter may be changed to see the resulting
calculation updates. The slider at the bottom of the screen determines which cycle is displayed
and processed. Keep in mind that the cycle number does not necessarily start from 0, but is
referenced to the start of data collection within µDCAT. Therefore, the first cycle within the raw
data file may be much larger than 0.
To process a range of cycles, select the Process File tab and set the two sliders on the
Process Range control to specify the range of cycles to be included in the results. Then press
the Process File button to begin processing and visualize the results in table and chart formats.
The user may save the summary data by specifying a file name in the Results File Path control
and pressing the Save Results button.
Figure 21: µDCAT Post Process Raw File Front Panel
© Drivven, Inc. 2009 • µDCAT • Version 1.86
33
Drivven, Inc.
µDCAT
Expected Performance
The data processing performance of µDCAT will vary depending on the following factors:
CPU speed
RAM size and speed
Hard drive speed
Operating system and additional running applications
DAQ hardware limitations (sampling rate, response times)
Engine speed
Encoder resolution
Cylinder and measurement channel count
Calculation configurations
Figure 22 shows the limitations of the USB-6251 and USB-6259 DAQ hardware. These
devices use a multiplexed analog to digital converter and therefore share the maximum sample
rate among the enabled measurements. Therefore, the number of cylinders (measurements)
reduces the maximum engine speed that can be recorded. The resolution of the encoder also
affects the maximum engine speed. The following charts only account for the DAQ hardware and
not the computer processing capability. Actual performance will vary based on the computer
hardware used to calculate the results and stream data to disk.
Maximum Speed [rpm]
30000
360ppr
720ppr
1440ppr
3600ppr
25000
20000
15000
10000
5000
0
1
2
3
4
5
6
7
8
9
10 11 12 13 14 15 16
Cylinder Count []
Figure 22: Maximum Engine Speed (USB-6251 & USB-6259)
The following formula can be used to estimate the performance of a multiplexing DAQ
hardware device.
Speed =
60,000 * MSR
N * ER
Where:
Speed = Maximum Engine Speed [rpm]
MSR = Maximum Sample Rate of DAQ device (aggregate kS/s)
N = Number of Measurements
ER = Encoder Resolution [ppr]
© Drivven, Inc. 2009 • µDCAT • Version 1.86
34
Drivven, Inc.
µDCAT
Figure 23 shows the CompactDAQ hardware limitations. The CompactDAQ system uses
simultaneous sampling cards. Therefore, the DAQ hardware limitations are constant for any
number of cylinders.
Maximum Speed [rpm]
35000
30000
25000
20000
15000
10000
5000
0
0
500
1000
1500
2000
2500
3000
3500
Encoder Resolution [ppr]
Figure 23: Maximum Engine Speed (CompactDAQ)
The following formula can be used to estimate the performance of a simultaneous DAQ
hardware device.
Speed =
60,000 * MSR
ER
Where:
Speed = Maximum Engine Speed [rpm]
MSR = Maximum Sample Rate of DAQ device (kS/s)
ER = Encoder Resolution [ppr]
© Drivven, Inc. 2009 • µDCAT • Version 1.86
35
Drivven, Inc.
µDCAT
Calculations
The µDCAT calculations are described in detail in the DCAT User’s Manual. The manual
may be downloaded from the Drivven website at:
http://www.drivven.com/visitor_download/Manuals/DCAT%20User's%20Manual.pdf
© Drivven, Inc. 2009 • µDCAT • Version 1.86
36
Drivven, Inc.
µDCAT
Frequently Asked Questions
How do I add my own calculations to µDCAT?
o
µDCAT is a fixed application. However, the open-source post-processing
examples can be used to build a custom post processing program which
implement custom calculations. This requires LabVIEW development tools
and custom programming.
o
Please contact Drivven about the Drivven Combustion Analysis Toolkit which
provides full-featured open-source LabVIEW example implementations of the
toolkit. The toolkit allows a customized combustion analysis application to be
built from scratch, or integrated with full-authority engine control applications
using National Instruments PXI controllers and DAQ cards.
How do I add a diesel injector current probe trace (or any other signal) to my
display?
o
To display and save any signal, simply add it to the measurement setup and
associate it with the appropriate cylinder. It will be displayed on the data tab
and saved in the raw data file. The MeasurementType should be set to
undefined. The signal will be sampled engine-synchronously according to
the encoder resolution.
How do I save the current configuration of µDCAT?
o
To save the current µDCAT settings, use the CalVIEW “Save Current
Calibration as Default” (purple) or the “Save Calibration As…” (blue) buttons
on the CalVIEW interface. This saves a file to the LabVIEW default data
directory. (This is typically under “.\My Documents\LabVIEW Data”)
Calibration files have a .cdl extension.
o
To load a previous µDCAT calibration which was given a unique name and
path, copy the desired calibration file into the LabVIEW default data directory
and rename it to µDCAT.cdl. Then start the µDCAT target application. Please
note that the calibration file is only read when the µDCAT Target Program
starts.
How do I customize the user interface?
o
The user interface is a standard LabVIEW VI. It may be modified with
LabVIEW development tools to meet user requirements. The file should be
saved in a new location so that updating µDCAT installation does not
overwrite the changes. A new CalVIEW .cvsf may be created to
automatically start µDCAT with the new user interface. Please see the
CalVIEW user’s manual for details about the .cvsf file.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
37
Drivven, Inc.
µDCAT
Why doesn’t µDCAT start correctly?
o
Verify that the appropriate version of DAQmx and LabVIEW Run-Time are
installed. The installers are available on National Instruments website and
listed at the beginning of this manual.
o
Verify that CalVIEW is installed and activated. Please see the CalVIEW
user’s manual for details on installation and activation of CalVIEW.
o
Verify that µDCAT is activated. Check the µDCAT Target Program front
panel to verify that it is activated correctly.
o
Manually start the application. Please see the CalVIEW user’s manual for
more details.
1. Launch the µDCAT Target Program. It cam be started from the start
menu or found at “C:\Program Files\Drivven\µDCAT\µDCAT.exe”
2. Open CalVIEW
3. Within CalVIEW, define the Target IP address as “127.0.01” or your
computer IP address.
4. Within CalVIEW, set the Host VI to “C:\Program
Files\Drivven\µDCAT\User Interface\µDCAT User Interface.vi”.
5. Within CalVIEW, set the pairing file to “C:\Program
Files\Drivven\µDCAT\µDCAT Pairing.par”.
6. Within CalVIEW, start the Host VI.
Why am I getting DAQ errors?
o
Make sure that the hardware is set up properly in the Measurements and
Automation Explorer and that the Measurement Setup tab has the proper
physical channel names.
o
Verify that the device is not being used for other DAQ tasks.
Why are the buffers or queues overflowing?
o
The buffers fill when the computer system hardware is not able to keep up
with the program demands. A combination of faster CPU, faster hard drive
or additional RAM will alleviate the problem.
o
Raw Queue: This buffer fills when data cannot be streamed to file as fast as
the DAQ Loop rate. Try saving less data or allow the queue to empty before
saving more data.
o
RT Queue or NC Queue: These buffers fill when the combustion analysis
calculations cannot be completed as fast as the DAQ Loop rate. Try disabling
some of the calculations or reducing the encoder resolution.
o
RT Align Buffer or NC Align Buffer: These buffers will fill when the
combustion analysis calculations cannot be completed as fast as the
combustion events. The calculation time must be less than (60 * N) / (RPM *
Ncyl) seconds. (N=Strokes per Cycle, RPM = Engine Speed in RPM, Ncyl =
Number of Cylinders) Ex. 4-storke @ 10000RPM and 16 cylinders = 750us.
Try disabling some of the calculations or reducing the encoder resolution.
© Drivven, Inc. 2009 • µDCAT • Version 1.86
38
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement