CUCM SIP Trunking Configuration
PROPRIETARY & CONFIDENTIAL
SIP Trunking Configuration Guide
for
Cisco Unified Communications Manager
v7.1.3
© 2010, Cox Communications, Inc. All rights reserved.
This documentation is the confidential and proprietary intellectual property of Cox
Communications, Inc. Any unauthorized use, reproduction, preparation of derivative works,
performance, or display of this document, or software represented by this document is strictly
prohibited.
PROPRIETARY & CONFIDENTIAL
TABLE OF CONTENTS
Audience ................................................................................................................................................ 5
Introduction ............................................................................................................................................ 5
Network Topology .................................................................................................................................. 6
System Components.............................................................................................................................. 7
4.1
Hardware Components................................................................................................................ 7
4.2
Software Requirements ............................................................................................................... 8
5 Features................................................................................................................................................. 8
5.1
Supported Features ..................................................................................................................... 8
5.2
Unsupported Features ................................................................................................................. 8
6 Caveats and Limitations......................................................................................................................... 8
7 Configuration.......................................................................................................................................... 9
7.1
CUCM SIP Trunk Call Flows ....................................................................................................... 9
7.2
SIP Trunk IP Address Assignments .......................................................................................... 10
7.3
Cisco Unified Border Element (CUBE) Configuration ............................................................... 11
7.4
Configuring the Cisco Unified Communications Manager (UCM) Overview ............................. 15
7.4.1
Voice Services....................................................................................................................... 15
7.4.2
Call Processing...................................................................................................................... 15
7.4.3
Voicemail Services ................................................................................................................ 15
7.4.4
Quality of Service .................................................................................................................. 15
7.4.5
Detail Communications Manager Configurations.................................................................. 16
7.5
SIP Message Trace Examples .................................................................................................. 57
7.5.1
Incoming SIP INVITE – PSTN (E-SBC) to Cisco CUBE ....................................................... 57
7.5.2
Outgoing SIP INVITE – Cisco CUBE to PSTN (E-SBC) ....................................................... 57
7.5.3
Transfer SIP UPDATE – Cisco CUBE to PSTN (E-SBC) ..................................................... 58
7.5.4
Call Forward SIP INVITE – Cisco CUBE to PSTN (E-SBC) ................................................. 59
7.6
Full Detail IOS Configurations ................................................................................................... 59
1
2
3
4
Table of Figures
Figure 1 – Cox Fiber Network ....................................................................................................................... 5
Figure 2 – Reference Network Architecture.................................................................................................. 6
Figure 3 – SIP Trunk Lab Reference Network .............................................................................................. 7
Figure 4 – Geo-Redundant CUCM Network ................................................................................................. 9
Figure 5 – Originating Call Flow Overview.................................................................................................... 9
Figure 6 – Terminating Call Flow Overview ................................................................................................ 10
Figure 7 – Geo-Redundant Signaling Paths ............................................................................................... 14
Figure 8 – Device Pools .............................................................................................................................. 16
Figure 9 - Cisco Unified CM's ..................................................................................................................... 16
Figure 10 - Cisco Unified CM Groups ......................................................................................................... 17
Figure 11 – Regions.................................................................................................................................... 17
Figure 12 - Physical Locations .................................................................................................................... 18
Figure 13 - Enterprise Parameters Configuration ....................................................................................... 19
Figure 14 - Enterprise Parameter Configuration – Continued .................................................................... 20
Figure 15 - Enterprise Parameters Configuration – Continued................................................................... 21
Figure 16 - Enterprise Parameters Configuration – Continued................................................................... 22
Figure 17 - Enterprise Parameters Configuration – Continued................................................................... 23
Figure 18 - Enterprise Parameters Configuration – Continued................................................................... 24
Figure 19 - Enterprise Phone Configuration ............................................................................................... 25
Page 2 of 71
PROPRIETARY & CONFIDENTIAL
Figure 20 - SIP Trunk Security Profiles....................................................................................................... 26
Figure 21 - Two Route Groups ................................................................................................................... 26
Figure 22 - Route Lists................................................................................................................................ 27
Figure 23 - Route Patterns.......................................................................................................................... 27
Figure 24 - Route Patterns.......................................................................................................................... 28
Figure 25 - Line Groups .............................................................................................................................. 28
Figure 26 - Hunt Lists.................................................................................................................................. 29
Figure 27 - Hunt Pilots Numbers................................................................................................................. 29
Figure 28 - Time Period .............................................................................................................................. 30
Figure 29 - Partitions................................................................................................................................... 31
Figure 30 - Calling Search Spaces ............................................................................................................. 32
Figure 31 - Client Matter Codes.................................................................................................................. 33
Figure 32 - Forced Authorization Code....................................................................................................... 33
Figure 33 - Translation Patterns ................................................................................................................. 34
Figure 34 - Call Park Numbers ................................................................................................................... 34
Figure 35 - Call Pickup Group..................................................................................................................... 35
Figure 36 - Directory Numbers.................................................................................................................... 35
Figure 37 - Route Plan Report .................................................................................................................... 36
Figure 38 - Route Plan Report - Continued ................................................................................................ 36
Figure 39 - Route Plan Report - Continued ................................................................................................ 37
Figure 40 - Route Plan Report - Continued ................................................................................................ 37
Figure 41 - Route Plan Report - Continued ................................................................................................ 38
Figure 42 - Route Plan Report - Continued ................................................................................................ 38
Figure 43 - Route Plan Report - Continued ................................................................................................ 39
Figure 44 - Route Plan Report - Continued ................................................................................................ 39
Figure 45 - Route Plan Report – Continued................................................................................................ 40
Figure 46 - Route Plan Report - Continued ................................................................................................ 40
Figure 47 - Route Plan Report – Continued................................................................................................ 41
Figure 48 - Route Plan Report - Continued ................................................................................................ 41
Figure 49 - Route Plan Report – Continued................................................................................................ 42
Figure 50 - Route Plan Report - Continued ................................................................................................ 43
Figure 51 - Cisco Unity Voice Mail Ports Setup .......................................................................................... 43
Figure 52 - Message Waiting Numbers ...................................................................................................... 44
Figure 53 - Voice Mail Pilot ......................................................................................................................... 44
Figure 54 - Voice Mail Profile ...................................................................................................................... 45
Figure 55 - CTI Route Points ...................................................................................................................... 45
Figure 56 - Detail Telephone Status Page.................................................................................................. 46
Figure 57 - SIP Trunks ................................................................................................................................ 46
Figure 58 - IP Phone Services .................................................................................................................... 47
Figure 59 - SIP Profiles ...............................................................................................................................47
Figure 60 - Common Device Configuration................................................................................................. 47
Figure 61 - Attendant Console User ........................................................................................................... 48
Figure 62 - Detail Phone Configuration....................................................................................................... 48
Figure 63 - Detail Phone Configuration - Continued................................................................................... 49
Figure 64 - Detail Phone Configuration - Continued................................................................................... 50
Figure 65 - Detail Phone Configuration - Continued................................................................................... 51
Figure 66 - Detail Phone Configuration - Continued................................................................................... 52
Figure 67 - Detail Phone Configuration - Continued................................................................................... 52
Figure 68 - Directory Number Services Configuration - Continued ............................................................ 53
Figure 69 - Directory Number Services Configuration - Continued ............................................................ 54
Figure 70 - Directory Number Services Configuration - Continued ............................................................ 55
Figure 71 - Directory Number Services Configuration - Continued ............................................................ 56
Page 3 of 71
PROPRIETARY & CONFIDENTIAL
Table of Tables
Table 1 – IP Addresses...............................................................................................................................10
Table 2 – SIP Trunk Failover Timers .......................................................................................................... 14
Page 4 of 71
PROPRIETARY & CONFIDENTIAL
1 Audience
This document is intended for the SIP Trunk customer’s technical staff and Value Added Retailer (VAR)
having installation and operational responsibilities.
2 Introduction
This Configuration Guide describes the configuration steps for Cox SIP Trunking with the Cisco Unified
Communications Manager (CUCM) 7.1.3(b) and the Cisco Unified Border Element (CUBE) for
connectivity to Cox’s SIP Trunking service. Cox’s SIP Trunking provides both inbound and outbound call
services replacing traditional ISDN PRI services.
Cox SIP Trunking is a scalable and efficient IP trunking telecommunication solution for your business that
provides all the traditional services such as Direct Inward Dialing, Hunting, Calling Name, Calling Number,
Local/Long Distance and Business Continuity options, including:





Burstable Trunk Capacity – Dynamically increases call capacity during peak busy periods so your
customers never receive a busy signal.
Call Forward Always – On the trunk group pilot number for all calls in case of an outage (flood,
fire, power outage, etc.).
Call Forward Not Reachable – On the trunk group pilot number that operates on a per-call
contingency basis to forward the call to any PSTN number (i.e., call center or alternate office
location) during temporary call completion impairments.
Route Exhaustion – Automatic reroute of trunk group calls to any PSTN phone number (i.e., a call
center) if calls can’t be completed to the PBX.
Support for geo-redundant PBX deployments and automatic reroute of SIP Trunks to the backup
customer data center.
All calls are routed over Cox’s national fiber network with guaranteed Quality of Service (QoS); calls never
traverse the Internet.
Figure 1 – Cox Fiber Network
Page 5 of 71
PROPRIETARY & CONFIDENTIAL
3 Network Topology
The high level Cox SIP Trunk network architecture is depicted below. The key network elements are:




IP PBX – Customer PBX for terminating SIP Trunks.
Cox Enterprise Session Border Controller (E-SBC) – The E-SBC is a smart service demarcation
device and SIP Application Layer Gateway (ALG) installed and managed by Cox.
Core Session Border Controllers and Broadsoft SIP Call Server for maximum survivability and
reliability.
PSTN Gateway for connections to the Public Switched Telephone Network (PSTN).
Figure 2 – Reference Network Architecture
This SIP Trunk network architecture is replicated across the Cox operating regions for scalability and
operational autonomy.
Cox will deploy one or more Enterprise Session Border Controllers (E-SBCs) to meet call capacity,
customer data center geo-redundancy and trunk group requirements. The E-SBC is owned and managed
by Cox and is the service demarcation point. The E-SBC performs SIP ALG, SIP normalization, NAT,
security, traffic shaping/prioritization, performance reporting and remote diagnostic functions.
Page 6 of 71
PROPRIETARY & CONFIDENTIAL
4 System Components
The lab network for the SIP Trunk reference configuration is illustrated in Figure 3 below and is
representative of a CUCM network.
VPN
Catalyst 3750 SERIES
1
SYST
RPS
MASTR
STAT
DUPLX
SPEED
STACK
MODE
2
3
4
5
6
7
8
9 10
11 12
13 14
15 16
17 18
19 20
21 22
Catalyst 3750 SERIES
23 24
1
1X
11X
13X
23X
2X
12X
14X
24X
1
2
3
4
SYST
RPS
MASTR
STAT
DUPLX
SPEED
STACK
MODE
2
3
4
5
6
7
8
9 10
11 12
13 14
15 16
17 18
19 20
21 22
23 24
1X
11X
13X
23X
2X
12X
14X
24X
1
2
3
4
Catalyst 3750 SERIES
1
SYST
RPS
MASTR
STAT
DUPLX
SPEED
STACK
MODE
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
1X
15X 17X
31X 33X
47X
2X
16X 18X
32X 34X
48X
1
3
2
4
Figure 3 – SIP Trunk Lab Reference Network
4.1
Hardware Components






Cisco IOS gateway running CUBE 1.2 (IOS image version 12.4)
Cisco Unified Communications Manager cluster with two Cisco MCS 7800 Series servers
Cisco 2811 router
Cisco IP Phones. The topology diagram in Figure 3 depicts the 7960 and 7940, but any Cisco IP
phone model may be used.
Cisco VG202 Analog Voice Gateway
EdgeMarc 6400 E-SBC
Page 7 of 71
PROPRIETARY & CONFIDENTIAL
4.2
Software Requirements





Cisco Unified Communications Manager 7.1.3(b)
Cisco Unified Border Element (CUBE) version 1.2 IOS version 12.4
Cisco GW IOS Release 12.4
Cisco VG202 IOS Release version 12.4
EdgeMarc 6400LF2 Release 9.12.0
5 Features
5.1
Supported Features







5.2


Basic Calls with G.711ulaw CODEC
Calling Party Number Presentation and Restriction
Call Transfer
Call Forwarding
RFC2833 transcoding
Calling party number presentation and privacy (P-Asserted-Identity)
SIP UPDATE for call transfer support
Unsupported Features
Codec negotiation of G.729, G.726 and others
T.38 Fax relay
6 Caveats and Limitations

A SIP header manipulation rule is required in the Cisco CUBE in for SIP Calls to proceed
properly. A SIP profile was used to inject “user=phone” into the SIP INVITE and SIP RE-INVITE
message headers that included: SIP Request-URI, Contact, To, and From header.
Please refer to Section 7.3 for the SIP header rule definition.

Cisco Analog Gateway(s) must be configured to support modem pass through for analog modem
tones to work properly.
Page 8 of 71
PROPRIETARY & CONFIDENTIAL
7 Configuration
SIP
SIP
The geo-redundant CUCM SIP Trunking lab network is illustrated in the figure below. The CUCM PBX at
each site is assumed to be identically configured to carry the full call load in the event of a network failure
at either location.
Catalyst 3750
1
SYST
RPS
MASTR
STAT
DUPLX
SPEED
STACK
MODE
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45 46
47
SERIES
48
1X
15X 17X
31X 33 X
47X
2X
16X 18X
32X 34 X
48X
1
3
2
4
Catalyst 3750
1
SYST
RPS
MASTR
STAT
DUPLX
SPEED
STACK
MODE
2
3
4
5
6
7
8
9
10
11
12
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
31X 33X
47X
16X 18X
32X 34X
48X
Figure 5 – Originating Call Flow Overview
SERIES
48
15X 17X
CUCM SIP Trunk Call Flows
Page 9 of 71
14
2X
Figure 4 – Geo-Redundant CUCM Network
7.1
13
1X
1
3
2
4
PROPRIETARY & CONFIDENTIAL
The conceptual outgoing call flow is:
CUCM  CUBE  Cox E-SBC  Cox’s SIP Network  PSTN
The same SIP Trunks are utilized for all voice types calls between CUCM and CUBE as shown above. All
outgoing calls are routed from the CUCM to CUBE through the E-SBC to Cox’s SIP Network and directed
to the PSTN.
Figure 6 – Terminating Call Flow Overview
The Incoming call flow is:
PSTN  Cox’s SIP Network  Cox E-SBC  CUBE  CUCM
In the lab example, a test account DID ranges were created for Cisco Unified Communications Manager
interoperability certification:
Site 1: 678.239.1xxx
Site 2: 678.239.2xxx
All incoming calls are routed to CUCM Site 1 if the Called party number begins with 678.239.1xxx. Calls
678.239.2xxx are routed to CUCM Site 2.
7.2
SIP Trunk IP Address Assignments
To help organize your work, the IP addresses listed in Table 1 should be recorded for your deployment
and referenced in the configuration steps described in this document.
Table 1 – IP Addresses
Component
Cox Lab
Cisco CUBE
 Site 1 CUBE Gateway IP Address
 Site 1 CUBE Gateway IP Address
172.16.1.5
172.16.2.5
Cox E-SBC EdgeMarc 6400’s
 LAN IP Address Site 1
 LAN Subnet Mask Site 1
 LAN IP Address Site 2
 LAN Subnet Mask Site 2
172.16.1.1
255.255.255.0
172.16.2.1
255.255.255.0
Your Value
Page 10 of 71
PROPRIETARY & CONFIDENTIAL
7.3
Cisco Unified Border Element (CUBE) Configuration
Cisco Unfied Border Element (CUBE) routers are utilized to hand off SIP calls to the Cox E-SBC. The
CUBE feature set allowed for modification of key sip headers using manipulation rules to format both SIP
INVITE and SIP RE-IVNITE SIP messages to proceed properly.
The following sip profile was used to inject “user=phone” into the INVITE and REINVITE headers.
voice class sip-profiles 1
request INVITE sip-header SIP-Req-URI modify " SIP/2.0" ";user=phone SIP/2.0"
request REINVITE sip-header SIP-Req-URI modify " SIP/2.0" ";user=phone SIP/2.0"
request INVITE sip-header Contact modify ">" ";user=phone>"
request REINVITE sip-header Contact modify ">" ";user=phone>"
request INVITE sip-header To modify ">" ";user=phone>"
request REINVITE sip-header To modify ">" ";user=phone>"
request INVITE sip-header From modify ">" ";user=phone>"
request REINVITE sip-header From modify ">" ";user=phone>"
The SIP-SIP calling, interface binding, in-call signaling and sip profile activation was enabled using the
following commands.
voice service voip
allow-connections sip to sip
fax protocol pass-through g711ulaw
sip
bind control source-interface Loopback0
bind media source-interface Loopback0
min-se 2000
header-passing
asserted-id pai
privacy pstn
midcall-signaling passthr
sip-profiles 1
Detail description:
1. fax protocol pass-through g711ulaw - Fax pass-through takes place when
incoming T.30 fax data is not demodulated or compressed for its transit through the packet
network. The two endpoints (fax machines) communicate directly to each other over a
transparent IP connection. The gateway does not distinguish fax calls from voice calls.
2. asserted-id pai - To enable the translation to PAID headers in the outgoing header at a
global level.
3. privacy pstn – To support of User privacy policy on the UCM, this flag is set on CUBE to
preserve the P-Asserted-Identity and Privacy header on the outgoing SIP INVITE.
Dial-Peers are used to provide both inbound and outbound call legs. Each call utilizes two peers. The
following shows the Site 1 dial peers. In the event that the primary path is not available, preference 1 dial
peer is used. Preference 0 is the default and therefore does not show in Cisco IOS.
dial-peer voice 1 voip
destination-pattern 6782392...
session protocol sipv2
session target ipv4:192.168.200.20
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
Page 11 of 71
PROPRIETARY & CONFIDENTIAL
!
dial-peer voice 2 voip
preference 1
destination-pattern 6782392...
session protocol sipv2
session target ipv4:192.168.100.20
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 10 voip
translation-profile outgoing calling-mask
destination-pattern 1[2-9]..[2-9]......
session protocol sipv2
session target ipv4:172.16.2.1
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 11 voip
translation-profile outgoing calling-mask
preference 1
destination-pattern [2-9]..[2-9]......
session protocol sipv2
session target ipv4:172.16.2.1
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 12 voip
translation-profile outgoing calling-mask
destination-pattern 011T
session protocol sipv2
session target ipv4:172.16.2.1
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 13 voip
translation-profile outgoing calling-mask
destination-pattern 911
session protocol sipv2
session target ipv4:172.16.2.1
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 3 voip
destination-pattern 6782391...
session protocol sipv2
session target ipv4:192.168.200.20
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
Page 12 of 71
PROPRIETARY & CONFIDENTIAL
!
dial-peer voice 4 voip
preference 1
destination-pattern 6782391...
session protocol sipv2
session target ipv4:192.168.100.20
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
Redundant call paths for inbound calls require the following statement. The IOS default is too large and
allows for a timeout before searching for the second peer (preference 1).
sip-ua
retry invite 3
timers trying 100
Redundant call paths for outbound calls are handled by the Communication Manager. Communications
Manager will route outbound calls based on the calling phones Calling Search Space (CSS). Each
device assigned CSS provides for a primary and secondary path for outbound calls. The times that
identify the primary path as unavailable were modified on the Communications Manager. The following
values were modified in the Communications Manager Service Parameters.
Page 13 of 71
PROPRIETARY & CONFIDENTIAL
Figure 7 – Geo-Redundant Signaling Paths
Table 2 – SIP Trunk Failover Timers
Parameter
Retry Count for SIP Invite
SIP Trying Timer
Default
6
500
Set
1
100
See the following Cisco documentation for more information:
Failover Timer on SIP Trunks with CallManager Configuration Example:
http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_configuration_example09186a0
08082d76a.shtml
Page 14 of 71
PROPRIETARY & CONFIDENTIAL
7.4
Configuring the Cisco Unified Communications Manager (UCM) Overview
7.4.1 Voice Services
Site Call Processing, Voicemail Services as well as InterLATA and IntraLATA SCCP and SIP voice
calls are provided as defined here.
7.4.2 Call Processing
Cisco Unified Communications Manager 7.1.3(b) was deployed using the distributed model.
Communications Manager Server, which provides primary call processing and telephony services,
can be deployed at one or two sites that maintain their own databases that are synchronized with
each other. In the event that the local Communications Manager server becomes unavailable, IP
Phones will attempt to register with the remote sites Communications Manager.
Both
Communications Manager servers share the same database and are fully aware of devices and
phones registered to each other.
7.4.3 Voicemail Services
Site 1 utilizes a Cisco Unity Connection server for voicemail services. Unity Connection is integrated
with Communications Manager and provides voicemail and auto attendant services for Site 1.
Site 2 has access to the Unity Connection server, but instead uses a local Cisco Unity Express
Network Module (CUE) for voicemail and auto attendant services. The CUE module is located within
the Cisco 2811 router.
Voicemail services are independent of each other and are not “networked” together. This means
that they are unable to forward messages to each others mail store and are unaware of users
configured outside their system.
7.4.4 Quality of Service
Quality of Service (QOS) is provided at both, layer 2 and layer 3 boundaries using the Cisco Auto
QOS feature. Both, RTP and signaling packets are tagged and passed on to the Cox’s IP Core
Network for proper differential treatment.
Page 15 of 71
PROPRIETARY & CONFIDENTIAL
7.4.5
Detail Communications Manager Configurations
Figure 8 – Device Pools
Device pools are used to define sets of common characteristics for devices. The above screen shows a
list of device pools
Figure 9 - Cisco Unified CM's
Two Communications Managers – Happy and Bashful. Happy serves as both Publisher and Subscriber
for Site 1, while Bashful acts as a Subscriber only for Site 2
Page 16 of 71
PROPRIETARY & CONFIDENTIAL
Figure 10 - Cisco Unified CM Groups
There are two CM Groups in this configuration and there are: Site 1 and Site 2 as shown above
Figure 11 – Regions
There are four Regions defined: Default, CUBE, Site 1, and Site 2
Page 17 of 71
PROPRIETARY & CONFIDENTIAL
Figure 12 - Physical Locations
Two Locations – Site 1 and Site 2
Page 18 of 71
PROPRIETARY & CONFIDENTIAL
Figure 13 - Enterprise Parameters Configuration
Enterprise Parameters Configuration – relates to IP Phone Service
Page 19 of 71
PROPRIETARY & CONFIDENTIAL
Figure 14 - Enterprise Parameter Configuration – Continued
Enterprise Parameters Configuration – relates to IP Phone Services
Page 20 of 71
PROPRIETARY & CONFIDENTIAL
Figure 15 - Enterprise Parameters Configuration – Continued
Enterprise Parameters Configuration – relates to IP Phone Services
Page 21 of 71
PROPRIETARY & CONFIDENTIAL
Figure 16 - Enterprise Parameters Configuration – Continued
Enterprise Parameters Configuration – relates to IP Phone Services
Page 22 of 71
PROPRIETARY & CONFIDENTIAL
Figure 17 - Enterprise Parameters Configuration – Continued
Enterprise Parameters Configuration – relates to IP Phone Services
Page 23 of 71
PROPRIETARY & CONFIDENTIAL
Figure 18 - Enterprise Parameters Configuration – Continued
Enterprise Parameters Configuration – relates to IP Phone Services
Page 24 of 71
PROPRIETARY & CONFIDENTIAL
Figure 19 - Enterprise Phone Configuration
Enterprise Phone Configuration
Page 25 of 71
PROPRIETARY & CONFIDENTIAL
Figure 20 - SIP Trunk Security Profiles
We Defined a Cox Business Security Profile for SIP Trunking
Figure 21 - Two Route Groups
Defined are two route groups
Page 26 of 71
PROPRIETARY & CONFIDENTIAL
Figure 22 - Route Lists
Two site list are defined. One from Site 1 to Site 2 and the other from Site 2 to Site 1
Figure 23 - Route Patterns
Defined Route patterns examples include: Local, Long Distance, International, etc.
Page 27 of 71
PROPRIETARY & CONFIDENTIAL
Figure 24 - Route Patterns
Defined Route Patterns include: Local, Long Distance, International, etc. – Continued
Figure 25 - Line Groups
Page 28 of 71
PROPRIETARY & CONFIDENTIAL
Figure 26 - Hunt Lists
Figure 27 - Hunt Pilots Numbers
Page 29 of 71
PROPRIETARY & CONFIDENTIAL
Figure 28 - Time Period
Defined Time Period for services, for testing we selected All the time.
Page 30 of 71
PROPRIETARY & CONFIDENTIAL
Figure 29 - Partitions
Page 31 of 71
PROPRIETARY & CONFIDENTIAL
Figure 30 - Calling Search Spaces
Page 32 of 71
PROPRIETARY & CONFIDENTIAL
Figure 31 - Client Matter Codes
Figure 32 - Forced Authorization Code
Page 33 of 71
PROPRIETARY & CONFIDENTIAL
Figure 33 - Translation Patterns
Figure 34 - Call Park Numbers
Page 34 of 71
PROPRIETARY & CONFIDENTIAL
Figure 35 - Call Pickup Group
Figure 36 - Directory Numbers
Page 35 of 71
PROPRIETARY & CONFIDENTIAL
Figure 37 - Route Plan Report
Figure 38 - Route Plan Report - Continued
Page 36 of 71
PROPRIETARY & CONFIDENTIAL
Figure 39 - Route Plan Report - Continued
Figure 40 - Route Plan Report - Continued
Page 37 of 71
PROPRIETARY & CONFIDENTIAL
Figure 41 - Route Plan Report - Continued
Figure 42 - Route Plan Report - Continued
Page 38 of 71
PROPRIETARY & CONFIDENTIAL
Figure 43 - Route Plan Report - Continued
Figure 44 - Route Plan Report - Continued
Page 39 of 71
PROPRIETARY & CONFIDENTIAL
Figure 45 - Route Plan Report – Continued
Figure 46 - Route Plan Report - Continued
Page 40 of 71
PROPRIETARY & CONFIDENTIAL
Figure 47 - Route Plan Report – Continued
Figure 48 - Route Plan Report - Continued
Page 41 of 71
PROPRIETARY & CONFIDENTIAL
Figure 49 - Route Plan Report – Continued
Page 42 of 71
PROPRIETARY & CONFIDENTIAL
Figure 50 - Route Plan Report - Continued
Figure 51 - Cisco Unity Voice Mail Ports Setup
Page 43 of 71
PROPRIETARY & CONFIDENTIAL
Figure 52 - Message Waiting Numbers
Figure 53 - Voice Mail Pilot
Page 44 of 71
PROPRIETARY & CONFIDENTIAL
Figure 54 - Voice Mail Profile
Figure 55 - CTI Route Points
The CTI Route has three route points listed, they are Unity Express (Voice Mail), Unity Express AutoAttendant, and Unity Connection Auto-Attendant.
Page 45 of 71
PROPRIETARY & CONFIDENTIAL
Figure 56 - Detail Telephone Status Page
Figure 57 - SIP Trunks
Page 46 of 71
PROPRIETARY & CONFIDENTIAL
Figure 58 - IP Phone Services
Figure 59 - SIP Profiles
COX Business SIP Profile
Figure 60 - Common Device Configuration
Page 47 of 71
PROPRIETARY & CONFIDENTIAL
Figure 61 - Attendant Console User
Figure 62 - Detail Phone Configuration
Page 48 of 71
PROPRIETARY & CONFIDENTIAL
Figure 63 - Detail Phone Configuration - Continued
Page 49 of 71
PROPRIETARY & CONFIDENTIAL
Figure 64 - Detail Phone Configuration - Continued
Page 50 of 71
PROPRIETARY & CONFIDENTIAL
Figure 65 - Detail Phone Configuration - Continued
Page 51 of 71
PROPRIETARY & CONFIDENTIAL
Figure 66 - Detail Phone Configuration - Continued
Figure 67 - Detail Phone Configuration - Continued
Page 52 of 71
PROPRIETARY & CONFIDENTIAL
Figure 68 - Directory Number Services Configuration - Continued
Page 53 of 71
PROPRIETARY & CONFIDENTIAL
Figure 69 - Directory Number Services Configuration - Continued
Page 54 of 71
PROPRIETARY & CONFIDENTIAL
Figure 70 - Directory Number Services Configuration - Continued
Page 55 of 71
PROPRIETARY & CONFIDENTIAL
Figure 71 - Directory Number Services Configuration - Continued
Page 56 of 71
PROPRIETARY & CONFIDENTIAL
7.5
7.5.1
SIP Message Trace Examples
Incoming SIP INVITE – PSTN (E-SBC) to Cisco CUBE
INVITE sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP 172.16.1.1:5060;branch=z9hG4bKm3d0m89bite5c408406o4rdqk7
Record-Route: <sip:[email protected];lr>
From: "PSTNLINETEST1" <sip:[email protected]:5060;user=phone>;tag=SDjcurc011438275345-1273243620664To: "6782391001 6782391001" <sip:[email protected]:5060>
Call-ID: SDjcurc01-5ad26d17fa988ebc728d8b51189bf9ea-vrvvfv3
CSeq: 966650525 INVITE
Contact: <sip:172.16.1.1:5060;transport=udp>
Supported: 100rel
Max-forwards: 69
Allow: ACK, BYE, CANCEL, INFO, INVITE, OPTIONS, PRACK, REFER, NOTIFY, UPDATE
Content-Type: application/sdpAccept: multipart/mixed, application/media_control+xml, application/sdp
Content-Length: 247
v=0
o=BroadWorks 89489 1 IN IP4 172.16.1.1
s=-c=IN IP4 172.16.1.1
t=0 0
m=audio 17468 RTP/AVP 0 101
a=rtpmap:0 PCMU/8000/1
a=sqn: 0
a=cdsc: 1 image udptl t38
a=mptime:20
a=ptime:20
a=rtpmap:101 telephone-event/8000/1
a=fmtp:101 0-15
7.5.2
Outgoing SIP INVITE – Cisco CUBE to PSTN (E-SBC)
INVITE sip:[email protected]:5060;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.16.1.5:5060;branch=z9hG4bK2531301
From: "James Dean" <sip:[email protected];user=phone>;tag=56E64F88-35E
To: <sip:[email protected];user=phone>
Date: Fri, 07 May 2010 14:50:06 GMT
Call-ID: [email protected]
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE: 1800
Cisco-Guid: 2832845825-1495142879-3215567434-905020787
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY,
INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1273243806
Contact: <sip:[email protected]:5060;user=phone>
Expires: 180
Allow-Events: telephone-event
Page 57 of 71
PROPRIETARY & CONFIDENTIAL
Max-Forwards: 69
Session-Expires: 2200
P-Asserted-Identity: "James Dean" <sip:[email protected]>
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 241
v=0
o=CiscoSystemsSIP-GW-UserAgent 3969 9006 IN IP4 172.16.1.5
s=SIP Callc=IN IP4 172.16.1.5
t=0 0
m=audio 18982 RTP/AVP 0 101
c=IN IP4 172.16.1.5
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=ptime:20
7.5.3
Transfer SIP UPDATE – Cisco CUBE to PSTN (E-SBC)
UPDATE sip:172.16.1.1:5060;transport=udp SIP/2.0
Via: SIP/2.0/UDP 172.16.1.5:5060;branch=z9hG4bK25B1BF9
From: "6782391001 6782391001" <sip:[email protected]:5060>;tag=56E796F4-22DB
To: "PSTNLINETEST1" <sip:[email protected]:5060;user=phone>;tag=SDjcurc01-14382753451273243620664Date: Fri, 07 May 2010 14:51:33 GMT
Call-ID: SDjcurc01-5ad26d17fa988ebc728d8b51189bf9ea-vrvvfv3
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Route: <sip:[email protected];lr>
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Timestamp: 1273243911
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY,
INFO, REGISTER
CSeq: 101 UPDATE
Contact: <sip:[email protected]:5060>
Remote-Party-ID: <sip:[email protected]>;party=called;screen=no;privacy=off
Content-Length: 0
UPDATE sip:172.16.1.1:5060;transport=udp SIP/2.0
Via: SIP/2.0/UDP 172.16.1.5:5060;branch=z9hG4bK25CC1D
From: "James Dean" <sip:[email protected]>;tag=56E7CDA0-48E
To: <sip:[email protected]>;tag=SD3po2899-1307487053-1273243634795
Date: Fri, 07 May 2010 14:51:43 GMT
Call-ID: [email protected]
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Route: <sip:[email protected];lr>
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Timestamp: 1273243911
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY,
INFO, REGISTER
CSeq: 103 UPDATE
Page 58 of 71
PROPRIETARY & CONFIDENTIAL
Contact: <sip:[email protected]:5060>
Remote-Party-ID: "INFOSYSTEST" <sip:[email protected]>;party=calling;screen=yes;privacy=off
Content-Length: 0
7.5.4
Call Forward SIP INVITE – Cisco CUBE to PSTN (E-SBC)
INVITE sip:[email protected]:5060;user=phone SIP/2.0
Via: SIP/2.0/UDP 172.16.1.5:5060;branch=z9hG4bK26125E2
From: "PSTNLINETEST1" <sip:[email protected];user=phone>;tag=56E8B114-27C
To: <sip:[email protected];user=phone>
Date: Fri, 07 May 2010 14:52:42 GMT
Call-ID: [email protected]
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE: 1800
Cisco-Guid: 98417594-1495208415-3218123338-905020787
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY,
INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1273243962
Contact: <sip:[email protected]:5060;user=phone>
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 66
Session-Expires: 2200
P-Asserted-Identity: "PSTNLINETEST1" <sip:[email protected]>
Diversion: <sip:[email protected]>;privacy=off;reason=unconditional;screen=yes
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 240
v=0
o=CiscoSystems
SIP-GW-UserAgent 5232 531 IN IP4 172.16.1.5
s=SIP Callc=IN IP4 172.16.1.5
t=0 0
m=audio 16636 RTP/AVP 0 101
c=IN IP4 172.16.1.5
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=ptime:20
7.6
Full Detail IOS Configurations
! Site 1 – Grumpy -- CUBE IOS Configurations
!
Current configuration : 6683 bytes
!
! Last configuration change at 11:30:27 EST Mon Jun 7 2010 by admin
! NVRAM config last updated at 11:30:28 EST Mon Jun 7 2010 by admin
!
Page 59 of 71
PROPRIETARY & CONFIDENTIAL
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname Grumpy
!
boot-start-marker
boot system flash c2800nm-ipvoice_ivs-mz.124-24.T2.bin
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/0
logging message-counter syslog
logging buffered 1000000
no logging console
!
no aaa new-model
clock timezone EST -5
!
ip source-route
!
!
ip cef
!
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
voice service voip
allow-connections sip to sip
fax protocol cisco
modem passthrough nse codec g711ulaw
sip
bind control source-interface Loopback0
bind media source-interface Loopback0
min-se 2000
header-passing
asserted-id pai
privacy pstn
midcall-signaling passthru
sip-profiles 1
!
!
voice class sip-profiles 1
request INVITE sip-header SIP-Req-URI modify " SIP/2.0" ";user=phone SIP/2.0"
request REINVITE sip-header SIP-Req-URI modify " SIP/2.0" ";user=phone SIP/2.0"
request INVITE sip-header Contact modify ">" ";user=phone>"
request REINVITE sip-header Contact modify ">" ";user=phone>"
request INVITE sip-header To modify ">" ";user=phone>"
Page 60 of 71
PROPRIETARY & CONFIDENTIAL
request REINVITE sip-header To modify ">" ";user=phone>"
request INVITE sip-header From modify ">" ";user=phone>"
request REINVITE sip-header From modify ">" ";user=phone>"
!
!
voice translation-rule 39
rule 2 /^1\(...\)$/ /6782391\1/
!
!
voice translation-profile calling-mask
translate redirect-target 39
translate redirect-called 39
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
username admin privilege 15 secret 5 $1$xscF$snZsx7K1jcqGNK6nW5PZn/
archive
log config
hidekeys
!
class-map match-any AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-any AutoQoS-VoIP-Control-Trust
match ip dscp cs3
match ip dscp af31
!
!
policy-map AutoQoS-Policy-Trust
class AutoQoS-VoIP-RTP-Trust
priority percent 70
class AutoQoS-VoIP-Control-Trust
bandwidth percent 5
class class-default
fair-queue
!
interface Loopback0
description SIP Interface
ip address 172.16.1.5 255.255.255.252
!
interface FastEthernet0/0
description Internal Interface
no ip address
duplex full
speed 100
auto qos voip trust
service-policy output AutoQoS-Policy-Trust
!
interface FastEthernet0/0.1
Page 61 of 71
PROPRIETARY & CONFIDENTIAL
description Management VLAN 1
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.2
description SIP Trunk Access
encapsulation dot1Q 10
ip address 172.16.10.2 255.255.255.252
!
interface FastEthernet0/1
description Edgemark
ip address 172.16.1.2 255.255.255.252
duplex auto
speed auto
auto qos voip trust
service-policy output AutoQoS-Policy-Trust
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.10.1
ip route 192.168.0.0 255.255.0.0 172.16.10.1
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
rmon alarm 33333 cbQosCMDropBitRate.18.3164929 30 absolute rising-threshold 1 33333 fallingthreshold 0 owner AutoQoS
!
!
sccp local FastEthernet0/0.2
sccp ccm 192.168.200.20 identifier 2 version 7.0
sccp ccm 192.168.100.20 identifier 1 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 2 register TRAN-SITE-1
associate profile 1 register MTP-SITE-1
!
dspfarm profile 2 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
maximum sessions 24
associate application SCCP
Page 62 of 71
PROPRIETARY & CONFIDENTIAL
!
dspfarm profile 1 mtp
codec g711ulaw
maximum sessions software 100
associate application SCCP
!
!
dial-peer voice 1 voip
destination-pattern 6782391...
session protocol sipv2
session target ipv4:192.168.100.20
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 2 voip
preference 1
destination-pattern 6782391...
session protocol sipv2
session target ipv4:192.168.200.20
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 10 voip
translation-profile outgoing calling-mask
destination-pattern 1[2-9]..[2-9]......
session protocol sipv2
session target ipv4:172.16.1.1
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 11 voip
translation-profile outgoing calling-mask
preference 1
destination-pattern [2-9]..[2-9]......
session protocol sipv2
session target ipv4:172.16.1.1
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 12 voip
Page 63 of 71
PROPRIETARY & CONFIDENTIAL
translation-profile outgoing calling-mask
destination-pattern 011T
session protocol sipv2
session target ipv4:172.16.1.1
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 13 voip
translation-profile outgoing calling-mask
destination-pattern [2-9]11
session protocol sipv2
session target ipv4:172.16.1.1
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 3 voip
destination-pattern 6782392...
session protocol sipv2
session target ipv4:192.168.100.20
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 4 voip
preference 1
destination-pattern 6782392...
session protocol sipv2
session target ipv4:192.168.200.20
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 14 voip
translation-profile outgoing calling-mask
preference 1
destination-pattern [2-9]......
session protocol sipv2
session target ipv4:172.16.1.1
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
Page 64 of 71
PROPRIETARY & CONFIDENTIAL
no vad
!
dial-peer voice 15 voip
translation-profile outgoing calling-mask
preference 1
destination-pattern 101....1[2-9]..[2-9]......
session protocol sipv2
session target ipv4:172.16.1.1
dtmf-relay rtp-nte
codec g711ulaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
!
sip-ua
retry invite 3
timers trying 100
!
!
gatekeeper
shutdown
!
!
line con 0
login local
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
line vty 5 15
access-class 23 in
privilege level 15
login local
!
scheduler allocate 20000 1000
ntp peer 192.168.100.20
ntp server 192.168.100.20
end
! Cisco Unified Express Voice Mail System
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Sneezy
!
boot-start-marker
boot-end-marker
Page 65 of 71
PROPRIETARY & CONFIDENTIAL
!
! card type command needed for slot/vwic-slot 0/0
logging buffered 51200 warnings
!
no aaa new-model
clock timezone EST -5
dot11 syslog
!
!
ip cef
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
crypto pki trustpoint TP-self-signed-1016059772
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1016059772
revocation-check none
rsakeypair TP-self-signed-1016059772
!
!
crypto pki certificate chain TP-self-signed-1016059772
certificate self-signed 01
3082023E 308201A7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 31303136 30353937 3732301E 170D3130 30313237 32303334
30315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 30313630
35393737 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100E4EE B43F3ED3 3F4945EF 8E8C2B3D 1B2587FB 4D19964F 7AA27DAA A8B53433
42A036DE A1FEFDD9 9F07FA3A AC94E2AE 8A76F86B E8CF4698 0E310A3C 74BC2114
FD7777DE 362E21BC 01F71893 E30D4508 0026EDB0 EFB6B51F 1A4B277F BF24C995
606081A2 5F51F91B 35A9A0B6 E4E0E224 62241BE5 371795C2 2750643F B6A23DD6
FD550203 010001A3 66306430 0F060355 1D130101 FF040530 030101FF 30110603
551D1104 0A300882 06536E65 657A7930 1F060355 1D230418 30168014 BE359A93
2BC11314 24B68728 D1D66A03 44FB3607 301D0603 551D0E04 160414BE 359A932B
C1131424 B68728D1 D66A0344 FB360730 0D06092A 864886F7 0D010104 05000381
81005AD2 35E7F709 BC1D6CC8 FDA98BBA D52B78D4 50AAC2A6 BC5CA16C 32DDC65E
BE9C729C CC43BC39 2E926AF8 22A80A89 EDCDEA7C 7DFB42F7 461551AF 4B541731
700D0F12 361D887C 7D1B04BA 9DB4D67B 154EFCCB 8EEB6234 834516CC E153989F
44AF91FF 80DF56FE 3EDAFA6A B5D427FA 0018A8B1 9F57C21E 243A76B6 0462EE55 E8F7
quit
!
!
username admin privilege 15 secret 5 $1$Qfk7$cwTNvyLG9jxGfXrAatbyc1
archive
Page 66 of 71
PROPRIETARY & CONFIDENTIAL
log config
hidekeys
!
!
class-map match-any AutoQoS-VoIP-RTP-Trust
match ip dscp ef
class-map match-any AutoQoS-VoIP-Control-Trust
match ip dscp cs3
match ip dscp af31
!
!
policy-map AutoQoS-Policy-Trust
class AutoQoS-VoIP-RTP-Trust
priority percent 70
class AutoQoS-VoIP-Control-Trust
bandwidth percent 5
class class-default
fair-queue
!
!
interface FastEthernet0/0
description Internal Network
no ip address
duplex auto
speed auto
auto qos voip trust
service-policy output AutoQoS-Policy-Trust
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.5 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.2
encapsulation dot1Q 220
ip address 192.168.220.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1
description connection from COX Network
ip address 10.100.50.200 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
auto qos voip trust
service-policy output AutoQoS-Policy-Trust
!
interface FastEthernet0/1/0
!
Page 67 of 71
PROPRIETARY & CONFIDENTIAL
interface FastEthernet0/1/1
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
!
interface Integrated-Service-Engine1/0
ip unnumbered FastEthernet0/0.2
service-module ip address 192.168.220.30 255.255.255.0
service-module ip default-gateway 192.168.220.1
no keepalive
!
interface Vlan1
no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.100.50.1
ip route 172.16.0.0 255.255.0.0 192.168.220.2
ip route 192.168.0.0 255.255.0.0 192.168.220.2
ip route 192.168.220.30 255.255.255.255 Integrated-Service-Engine1/0
!
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source static 192.168.1.2 10.100.50.201
ip nat inside source static 192.168.100.20 10.100.50.202
ip nat inside source static 192.168.200.20 10.100.50.203
ip nat inside source static 192.168.100.30 10.100.50.204
!
control-plane
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" owner AutoQoS
rmon alarm 33333 cbQosCMDropBitRate.18.3164929 30 absolute rising-threshold 1 33333 fallingthreshold 0 owner AutoQoS
rmon alarm 33334 cbQosCMDropBitRate.34.5364641 30 absolute rising-threshold 1 33333 fallingthreshold 0 owner AutoQoS
!
!
line con 0
login local
line aux 0
line 66
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
access-class 23 in
Page 68 of 71
PROPRIETARY & CONFIDENTIAL
login local
length 0
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp clock-period 17180827
ntp peer 192.168.100.20
!
end
/** Cisco Analog Voice Gateway VG202 configuration **/
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VG202
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$T8KF$UdA4F3MFMFxAMzEMBLnZu1
!
no aaa new-model
ip source-route
!
ip cef
no ipv6 cef
!
stcapp ccm-group 1
stcapp
!
stcapp feature access-code
!
stcapp feature speed-dial
!
!
voice service voip
modem passthrough nse codec g711ulaw
!
!
voice-card 0
!
Page 69 of 71
PROPRIETARY & CONFIDENTIAL
username admin privilege 15 secret 5 $1$OTG6$gmEKkbulgXiSRXA9Tqskg.
archive
log config
hidekeys
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
!
control-plane
!
voice-port 0/0
timeouts initial 60
timeouts interdigit 60
timeouts ringing infinity
!
voice-port 0/1
timeouts initial 60
timeouts interdigit 60
timeouts ringing infinity
!
ccm-manager fax protocol cisco
ccm-manager config server 192.168.100.20
ccm-manager sccp local FastEthernet0/0
ccm-manager sccp
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
sccp local FastEthernet0/0
sccp ccm 192.168.200.20 identifier 1 version 7.0
sccp ccm 192.168.100.20 identifier 2 version 7.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
!
!
dial-peer voice 999000 pots
service stcapp
port 0/0
Page 70 of 71
PROPRIETARY & CONFIDENTIAL
!
dial-peer voice 999001 pots
service stcapp
port 0/1
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
privilege level 15
login local
length 0
!
end
Page 71 of 71
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement