Tissue Studio® 4.2

Tissue Studio® 4.2
Definiens
Tissue Studio 4.2
®
Tutorial 3: Metadata Import, Manual ROI
Selection and Vessel Detection
Tutorial 3: Metadata Import, Manual ROI Selection and Vessel Detection
Imprint and Version
Copyright © 2015 Definiens AG. All rights reserved.
This document may be copied and printed only in accordance with the terms of the
Frame License Agreement for End Users of the related Definiens software.
2
Contents
Contents
Introduction.................................................................................................................................................5
Load Solution ..............................................................................................................................................7
ROI Detection..............................................................................................................................................9
Cellular Analysis....................................................................................................................................... 11
Export ......................................................................................................................................................... 15
Run and Review....................................................................................................................................... 17
3
Tutorial 3: Metadata Import, Manual ROI Selection and Vessel Detection
4
Introduction
Introduction
This tutorial will guide you through the steps required to perform an analysis using
the manual ROI detection functions of Definiens Tissue Studio® in combination with
the Vessel Detection function. You will learn how to manually select regions of interest
(ROIs) based on an initial segmentation step. We will then submit the detected ROIs to
a general vessel detection that identifies vessels and classifies them according to size.
In addition, we will show you how to import metadata along with your images into the
workspace – it is often necessary to have additional image information in order to set
up an analysis. For instance, you might want to select your training data so that it spans
images from all experimental conditions.
Importing metadata into Tissue Studio® is straightforward – all metadata must be in a
CSV file called metadata.csv and be in the same folder as your image files. In order to link
images and metadata, metadata.csv must contain a column with the heading ‘image’ ,
which contains the unique image names (without file extensions).
1
Start Tissue Studio® in the Tissue Studio® portal.
2
Select the Load tab and click the Import Folders button. The image files you need
are located in 2B_BF_Slides_Vessels\images. Select Aperio ScanScope – with resolution as the scanner type.
3
Type a name for the workspace and browse to the location where you want to
save it (use the prefix WS_ to distinguish the workspace folder easily from other
folders in the same directory). Press Finish.
The metadata contained in the file metadata.csv are automatically loaded
into the workspace. This is highlighted by the link in the Project Properties
window.
4
Select all four slides in the root Workspace folder and create a training data set
with the Training Data button.
NOTE: This book assumes you have already worked through tutorial #1 (Composer and
Nuclear Markers) and are familiar with the basic functions and workflow of Tissue Studio®. You may also want to read chapters 1–3 of the Tissue Studio® User Guide.
This tutorial is intended to be an example and will not explain every aspect of the software. For more information refer to the User Guide.
5
Tutorial 3: Metadata Import, Manual ROI Selection and Vessel Detection
6
Load Solution
Load Solution
We now want to manually define the ROIs to be analyzed with an initial segmentation
step. The manual classification result must first be defined (and saved) for every image
individually; we can later execute this solution in batch mode.
1
In the Workflow window switch to the Configure tab.
2
Press the Load Solution button.
3
In the Load Solution dialog box, select the solution Draw Polygons > Vessels and
confirm with OK.
However, we would like to use the action Manual ROI Selection (Select
Segments) instead of Manual ROI Selection (Draw Polygons).
4
Delete the action Manual ROI Selection (Draw Polygons) by clicking on the minus sign.
5
Click on the plus sign of the red group and add action ROI Selection (Select
Segments).
7
Tutorial 3: Metadata Import, Manual ROI Selection and Vessel Detection
8
ROI Detection
ROI Detection
For training purposes, we want to select the central tissue region in all four images.
1
Click on the General Settings action (Figure 1) to activate its widgets (the active
action is indicated by a yellow frame).
2
Configure the settings according to the analysis task: Use
metadata from file should be
active, and select IHC Brown
chromogen and Cytoplasm
under Staining Information.
3
Change to the Manual ROI Selection (Select Segments) action. Set the Segmentation
Scale to 8 and press the Segmentation button (see Figure
2 on page 10).
You can modify individu- Figure 1: General Settings action
al objects through resegmentation or manual cutting.
4
To achieve a finer segmentation scale, click the Resegment Object button, reduce
the Segmentation Scale and click on the object to be resegmented.
5
Alternatively, you can simply cut out your region of interest in a larger object by
using the Cut Manually button and using the mouse to cut out an object from a
larger object (for more details see the Tissue Studio® User Guide).
6
Activate one of the ROI buttons and click on the objects you want to select (see
Figure 3 on page 10, left).
7
Activate another ROI class and press Classify Remains to classify remaining objects within their respective classes – you can edit class names and colors using
the Edit Classes buttons.
8
Press the Merge button to merge all objects of the same class (see Figure 3 on
page 10, right).
9
Press the Confirm button to save the selection.
NOTE: You can also apply manually selected regions inside other workspaces. Copy your
workspace using File > Save Workspace to another location and copy the ManualClassifications folder to the new workspace folder. The classification is used when the Load button in the Manual ROI Selection action is pressed.
9
Tutorial 3: Metadata Import, Manual ROI Selection and Vessel Detection
Figure 2: Segmentation result. CD_34 (bottom, right) has been segmented using the Cut
Manually function
The manual annotations are saved in the workspace folder and can be reapplied to the images with the Load button in the Confirmation section
(in case you close the program before the configuration of your solution is
finished).
Figure 3: Results for manual classification (left) and final classification (right)
10
Cellular Analysis
Cellular Analysis
1
Activate the Initialize Cellular Analysis
action.
2
Select the classes you have used to create
the polygons – to be submitted to the
analysis – by deselecting classes you don’t
need.
3
Set the Magnification to 5x.
4
Activate the Select button and choose
eight subsets on all slides (see Figure 5).
Figure 4: ROI selection for cellular
analysis
Up to 12 subsets can be selected.
5
Switch to the Vessel Detection action.
6
Set the IHC Threshold to 0.35, Min Stain Area and Gap to close to 0 and press Preview Settings to see the vessel stain region (see Figure 6 on page 12, left).
On closer inspection, you may notice that some lumen areas are not yet recognized – this is because these lumina are not entirely enclosed by the vessel wall. You may also want to exclude small bits and pieces that should not
count as vessels.
7
Set the Gap to close to about 5µm to close small holes in the vessel wall (see Figure 6, right).
8
Set Min Stain Area to a value larger than zero to exclude stain fragments of the
specified size.
Figure 5: Subset selection
11
Tutorial 3: Metadata Import, Manual ROI Selection and Vessel Detection
Figure 6: Preview of vessel settings with Gap to close set to 0µm (left) and 5µm (right)
Here you should only exclude small fragments and artifacts. With the Vessel
Classification action, you can then exclude entire vessels from the analysis
if necessary.
9
Press Preview to detect vessels on an upper level (vessels are classified as ‘vessel
with lumen’ and ‘vessel without lumen’) and ‘vessel lumen’ and ‘vessel wall’ on a
lower level.
10
Use the up and down arrows in the main toolbar to switch between levels (see Figure 7).
You can open the Scene Information pane (View > Scene Information)
to display some useful statistics for the currently active window and for all
subsets (see Figure 8).
11
Switch to the Vessel Classification.
12
Select the feature Area (µm²) and keep the default settings.
13
To exclude small vessels from the analysis activate the Use exclusion checkbox
and click on the button at the right side of the Feature 1 panel.
14
In the opening Select Single Feature dialog choose Object Features > Geometry
> Extent > Area (µm²) and confirm with OK.
15
Set the Operator to < and assign a value of 50.
16
Press Preview to classify the vessels into Vessel Large, Vessel Medium or Vessel
Figure 7: Vessel detection on lower (left) and upper (right) levels
12
Cellular Analysis
Figure 8: Scene Information window for Vessel Detection action
Small and exclude vessels with an area smaller than 50µm (see Figure 9).
Figure 9: Vessel Classification result
13
Tutorial 3: Metadata Import, Manual ROI Selection and Vessel Detection
14
Export
Export
The Default Export action takes screenshots of the classification results and creates result files with all information about the identified ROIs plus the nucleus objects and
marker area within the ROIs.
1
Click on the Default Export button.
2
Choose the screenshots you want to retrieve and make sure the Statistics and Statistics Per Slide checkboxes are active.
TIP: If you want to reuse the solution, we recommend storing it under the following
paths: ..\Application Data\Definiens\TissueStudio\Data\Solutions (Windows XP) or
C:\ProgramData\Definiens\TissueStudio\Data\Solutions (Windows 7). This way it is
directly accessible via the Load Solution button.
15
Tutorial 3: Metadata Import, Manual ROI Selection and Vessel Detection
Figure 10: The Review Heat Map window
16
Run and Review
Run and Review
Batch processing is always performed using the currently loaded solution. When you
run the analysis, a read-only .dax file of the solution – with the date and time of the analysis – will be stored in the results folder.
1
Switch to the Run tab. In the Workspace window click on the folder Tissue Slides
to display the image list.
2
Select the images you want to submit to the batch analysis and click Analyze Selected Images or simply click Analyze All Images if you would like to get results
for all images in the workspace.
You can now follow the status of the analysis in the Workspace window
– projects will switch from created to waiting to processing and finally to
processed – or in the Job Scheduler (for information on how to use the Job
Scheduler, refer to the Definiens XD Installation and Administration Guide).
3
When the analysis is done, switch to the Review tab.
4
Click on the Open Results Folder button.
Here you will find all exported results (screenshots, statistics and solution
.dax file).
You can also review slides in the Review Heat Map window (Figure 10).
Select any ROI and press the Details button.
5
Open the Review Heat Map via the View menu.. Thumbnail view is visible by default; you will need to select the name of the result container in the drop-down
box (for information on result containers, see the Tissue Studio® User Guide).
6
Choose the Level, Feature and Class via their respective drop-down boxes. You
can additionally choose statistical features.
7
Adjust the slider to change the thumbnail transparency and adjust the values for
minimum or maximum at either side of the color scale. Press Export to export the
image.
In the example in Figure 10, we have highlighted the median areas of vessels in the Review Heat Map. The largest vessels are towards the red end of
the spectrum; the smallest are towards the blue end.
17
www.definiens.com
Corporate Headquarters
Definiens AG
Bernhard-Wicki-Strasse 5
80636 Munich
Germany
Tel. +49-89-231180-0
Americas Headquarters
Definiens Inc.
1808 Aston Avenue, Suite 190
Carlsbad, CA 92008
USA
Tel. +1-760-893-8900
© 2015 Definiens AG. All rights reserved. Definiens®, Definiens Cognition Network Technology®, Tissue
Studio®, Image Miner®, TissueExplorer® and Tissue Phenomics® are registered trademarks of Definiens AG.
All trademarks are property of their respective owners.
The information in this document is subject to change without notice and should not be construed as a
commitment by Definiens AG. Definiens AG assumes no responsibility for any errors that may appear in this
document.
For research use only. Not for use in diagnostic procedures.
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising