Cisco | 3200 Series | Appendix A, “Connecting to the Cisco 3200 Series Router and Using

A P P E N D I X
A
Connecting to the Cisco 3200 Series Router and
Using the Command-Line Interface
This chapter describes how to connect to the router and use the Cisco IOS command-line interface (CLI)
that you can use to configure the Cisco wireless mobile interface card (WMIC).
Before You Start
Before you install the WMIC, make sure that your computer is connected to the same network as the
WMIC, and obtain the following information from your network administrator:
•
A system name for the WMIC
•
The case-sensitive wireless service set identifier (SSID) that your WMICs use
•
If not connected to a DHCP server, a unique IP address for your WMIC (such as 172.17.255.115)
•
If the WMIC is not on the same subnet as your PC, a default gateway address and subnet mask
•
A Simple Network Management Protocol (SNMP) community name and the SNMP file attribute (if
SNMP is in use)
Resetting the WMIC to the Default Settings
You can use the CLI to reset the WMIC to a factory default configuration.
Note
The following steps reset all configuration settings to factory defaults, including passwords, WEP keys,
the IP address, and the SSID.
To use the CLI to reset the WMIC configuration to factory default values, follow these steps, beginning
in privileged EXEC mode:
Step 1
Enter erase nvram: to erase all NVRAM files including the startup configuration.
Step 2
Enter Y when the following CLI message displays: Erasing the nvram filesystem will remove all
configuration files! Continue? [confirm].
Step 3
Enter reload when the following CLI message displays: Erase of nvram: complete. This command
reloads the operating system.
Cisco 3200 Series Wireless MIC Software Configuration Guide
OL-6415-04
A-1
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Cisco IOS Command Modes
Step 4
Caution
Step 5
Enter Y when the following CLI message displays: Proceed with reload? [confirm].
Do not interrupt the boot process to avoid damaging the configuration file. You can see the following
CLI message when the load process has finished: Line protocol on Interface Dot11Radio0, changed state
to up.
After the WMIC reboots, you can reconfigure the WMIC by using the CLI.
To display the IP address of the WMIC, you can use the show interface bvi1 CLI command.
Cisco IOS Command Modes
The Cisco IOS user interface includes many different modes. The commands available to you depend on
which mode you are currently in. Enter a question mark (?) at the system prompt to obtain a list of
commands available for each command mode.
When you start a session on the WMIC, you begin in user mode, often called user EXEC mode. Only a
limited subset of the commands are available in user EXEC mode. For example, most of the user EXEC
commands are one-time commands, such as show commands, which show the current configuration
status, and clear commands, which clear counters or interfaces. The user EXEC commands are not saved
when the WMIC reboots.
To have access to all commands, you must enter privileged EXEC mode. Normally, you must enter a
password to enter privileged EXEC mode. From this mode, you must enter privileged EXEC mode
before you can enter the global configuration mode.
Using the configuration modes (global, interface, and line), you can make changes to the running
configuration. If you save the configuration, these commands are stored and used when the WMIC
reboots. To access the various configuration modes, you must start at global configuration mode. From
global configuration mode, you can enter interface configuration mode and line configuration mode.
Table A-1 describes the main command modes, how to access each one, the prompt that is displayed for each
mode, and how to exit each mode. The examples in the table use the hostname BR.
Table A-1
Command Mode Summary
Mode
Access Method
Prompt
Exit Method
About This Mode
User EXEC
Begin a session with
your WMIC.
bridge>
Enter logout or quit.
Use this mode to:
Privileged EXEC While in user EXEC
mode, enter the
enable command.
bridge#
Enter disable to exit.
•
Change terminal settings
•
Perform basic tests
•
Display system
information
Use this mode to verify
commands. Use a password to
protect access to this mode.
Cisco 3200 Series Wireless MIC Software Configuration Guide
A-2
OL-6415-04
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Getting Help
Table A-1
Command Mode Summary (continued)
Mode
Access Method
Prompt
Exit Method
About This Mode
Global
configuration
While in privileged
EXEC mode, enter
the configure
command.
bridge(config)#
To exit to privileged
Use this mode to configure
EXEC mode, enter exit or parameters that apply to the
end, or press Ctrl-Z.
entire device.
Interface
configuration
While in global
configuration mode,
enter the interface
command (with a
specific interface).
bridge(config-if)#
To exit to global
configuration mode, enter
exit. To return to
privileged EXEC mode,
press Ctrl-Z or enter end.
Use this mode to configure
parameters for the Ethernet
and radio interfaces. The
2.4-GHz radio is radio 0.
Getting Help
You can enter a question mark (?) at the system prompt to display a list of that commands that are
available for each command mode. You can also obtain a list of the associated keywords and arguments,
as shown in Table A-2.
Table A-2
Help Summary
Command
Purpose
help
Obtains a brief description of the help system in any command mode.
abbreviated-command-entry?
Obtains a list of commands that begin with a particular character string.
For example:
bridge# di?
dir disable
abbreviated-command-entry<Tab>
disconnect
Completes a partial command name.
For example:
bridge# sh conf<tab>
bridge# show configuration
?
Lists all commands available for a particular command mode.
For example:
bridge> ?
command ?
Lists the associated keywords for a command.
For example:
bridge> show ?
command keyword ?
Lists the associated arguments for a keyword.
For example:
bridge(config)# cdp holdtime ?
<10-255> Length of time (in sec) that receiver must keep this packet
Cisco 3200 Series Wireless MIC Software Configuration Guide
OL-6415-04
A-3
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Abbreviating Commands
Abbreviating Commands
You have to enter only enough characters for the WMIC to recognize the command as unique. This
example shows how to enter the show configuration privileged EXEC command:
bridge# show conf
Using no and default Forms of Commands
Most configuration commands also have a no form. In general, use the no form to disable a feature or
function or reverse the action of a command. For example, the no shutdown interface configuration
command reverses the shutdown of an interface. Use the command without the keyword no to reenable
a disabled feature or to enable a feature that is disabled by default.
Configuration commands can also have a default form. The default form of a command returns the
command setting to its default. Most commands are disabled by default, so the default form is the same
as the no form. However, some commands are enabled by default and have variables set to certain default
values. In these cases, the default command enables the command and sets variables to their default
values.
Understanding CLI Messages
Table A-3 lists some error messages that you might encounter while using the CLI to configure your
WMIC.
Table A-3
Common CLI Error Messages
Error Message
Meaning
How to Get Help
% Ambiguous command:
“show con”
You did not enter enough characters
for your WMIC to recognize the
command.
Re-enter the command followed by a question mark (?)
with a space between the command and the question
mark.
The keywords that you can enter with the command are
displayed.
% Incomplete command.
You did not enter all the keywords or Re-enter the command followed by a question mark (?)
values required by this command.
with a space between the command and the question
mark.
The keywords that you can enter with the command are
displayed.
% Invalid input detected
at ‘^’ marker.
You entered the command
incorrectly. The caret (^) marks the
point of the error.
Enter a question mark (?) to display all the commands
that are available in this command mode.
The keywords that you can enter with the command are
displayed.
Cisco 3200 Series Wireless MIC Software Configuration Guide
A-4
OL-6415-04
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Using Command History
Using Command History
The Cisco IOS provides a history or record of commands that you have entered. This feature is
particularly useful for recalling long or complex commands or entries, including access lists. You can
customize the command history feature to suit your needs, as described in these sections:
•
Changing the Command History Buffer Size, page A-5
•
Recalling Commands, page A-5
•
Disabling the Command History Feature, page A-6
Changing the Command History Buffer Size
By default, the WMIC records 10 command lines in its history buffer. To change the number of command
lines that the WMIC records during the current terminal session, enter the following command in
privileged EXEC mode:
bridge# terminal history [size number-of-lines]
The range is from 0 to 256.
To configure the number of command lines the WMIC records for all sessions on a particular line, enter
the following command in privileged EXEC mode:
bridge(config-line)# history
[size number-of-lines]
The range is from 0 to 256.
Recalling Commands
To recall commands from the history buffer, perform one of the actions listed in Table A-4:
Table A-4
Recalling Commands
Action1
Result
Press Ctrl-P or the Up arrow key.
Recalls commands in the history buffer, beginning with the most recent command.
Repeat the key sequence to recall successively older commands.
Press Ctrl-N or the Down arrow key.
Returns to more recent commands in the history buffer after recalling commands
with Ctrl-P or the up arrow key. Repeat the key sequence to recall successively
more recent commands.
show history
While in privileged EXEC mode, lists the last several commands that you just
entered. The number of commands that are displayed is determined by the setting
of the terminal history global configuration command and the history line
configuration command.
1. The arrow keys function only on ANSI-compatible terminals such as VT100s.
Cisco 3200 Series Wireless MIC Software Configuration Guide
OL-6415-04
A-5
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Using Editing Features
Disabling the Command History Feature
The command history feature is automatically enabled.
To disable the feature during the current terminal session, enter the terminal no history command in
privileged EXEC command.
To disable command history for the line, enter the no history command in line configuration mode.
Using Editing Features
This section describes the editing features that can help you manipulate the command line. It contains
these sections:
•
Enabling and Disabling Editing Features, page A-6
•
Editing Commands Through Keystrokes, page A-7
•
Editing Command Lines that Wrap, page A-8
Enabling and Disabling Editing Features
Although enhanced editing mode is automatically enabled, you can disable it.
To reenable the enhanced editing mode for the current terminal session, enter this command in privileged
EXEC mode:
bridge# terminal editing
To reconfigure a specific line to have enhanced editing mode, enter this command in line configuration
mode:
bridge(config-line)# editing
To globally disable enhanced editing mode, enter this command in line configuration mode:
bridge(config-line)# no editing
Cisco 3200 Series Wireless MIC Software Configuration Guide
A-6
OL-6415-04
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Using Editing Features
Editing Commands Through Keystrokes
Table A-5 shows the keystrokes that you can use to edit command lines.
Table A-5
Editing Commands Through Keystrokes
Capability
Keystroke1
Purpose
Move around the command line to
make changes or corrections.
Ctrl-B or the left arrow
key
Moves the cursor back one character.
Ctrl-F or the right arrow
key
Moves the cursor forward one character.
Ctrl-A
Moves the cursor to the beginning of the command line.
Ctrl-E
Moves the cursor to the end of the command line.
Esc B
Moves the cursor back one word.
Esc F
Moves the cursor forward one word.
Ctrl-T
Transposes the character to the left of the cursor with the
character located at the cursor.
Recall commands from the buffer
Ctrl-Y
and paste them in the command line. Esc Y
The WMIC provides a buffer with the
last ten items that you deleted.
Recalls the most recent entry in the buffer.
Delete entries if you make a mistake Delete or Backspace
or change your mind.
Ctrl-D
Erases the character to the left of the cursor.
Capitalize or lowercase words or
capitalize a set of letters.
Recalls the next buffer entry.
The buffer contains only the last 10 items that you have
deleted or cut. If you press Esc Y more than ten times, you
cycle to the first buffer entry.
Deletes the character at the cursor.
Ctrl-K
Deletes all characters from the cursor to the end of the
command line.
Ctrl-U or Ctrl-X
Deletes all characters from the cursor to the beginning of
the command line.
Ctrl-W
Deletes the word to the left of the cursor.
Esc D
Deletes from the cursor to the end of the word.
Esc C
Capitalizes at the cursor.
Esc L
Changes the word at the cursor to lowercase.
Esc U
Capitalizes letters from the cursor to the end of the word.
Designate a particular keystroke as
Ctrl-V or Esc Q
an executable command, perhaps as a
shortcut.
Cisco 3200 Series Wireless MIC Software Configuration Guide
OL-6415-04
A-7
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Using Editing Features
Table A-5
Editing Commands Through Keystrokes (continued)
Capability
Keystroke1
Purpose
Scroll down a line or screen on
displays that are longer than the
terminal screen can display.
Return
Scrolls down one line.
Space
Scrolls down one screen.
Ctrl-L or Ctrl-R
Redisplays the current command line.
Note
The More prompt appears for
output that has more lines
than can be displayed on the
terminal screen, including
show command output. You
can use the Return and
Space bar keystrokes
whenever you see the More
prompt.
Redisplay the current command line
if the WMIC suddenly sends a
message to your screen.
1. The arrow keys function only on ANSI-compatible terminals such as VT100s.
Editing Command Lines that Wrap
You can use a wraparound feature for commands that extend beyond a single line on the screen. When
the cursor reaches the right margin, the command line shifts ten spaces to the left. You cannot see the
first ten characters of the line, but you can scroll back and check the syntax at the beginning of the
command.
To scroll back to the beginning of the command entry, press Ctrl-B or the left arrow key repeatedly. You
can also press Ctrl-A to immediately move to the beginning of the line.
Note
The arrow keys function only on ANSI-compatible terminals such as VT100s.
In this example, the access-list global configuration command entry extends beyond one line. When the
cursor first reaches the end of the line, the line is shifted ten spaces to the left and redisplayed. The dollar
sign ($) shows that the line has been scrolled to the left. Each time the cursor reaches the end of the line,
the line is again shifted ten spaces to the left.
bridge(config)#
bridge(config)#
bridge(config)#
bridge(config)#
access-list 101 permit tcp 131.108.2.5 255.255.255.0 131.108.1
$ 101 permit tcp 131.108.2.5 255.255.255.0 131.108.1.20 255.25
$t tcp 131.108.2.5 255.255.255.0 131.108.1.20 255.255.255.0 eq
$108.2.5 255.255.255.0 131.108.1.20 255.255.255.0 eq 45
After you complete the entry, press Ctrl-A to check the complete syntax before pressing the Return key
to execute the command. The dollar sign ($) appears at the end of the line to show that the line has been
scrolled to the right:
bridge(config)# access-list 101 permit tcp 131.108.2.5 255.255.255.0 131.108.1$
The software assumes you have a terminal screen that is 80 columns wide. If you have a width other than
that, use the terminal width privileged EXEC command to set the width of your terminal.
Cisco 3200 Series Wireless MIC Software Configuration Guide
A-8
OL-6415-04
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Searching and Filtering the Output of show and more Commands
Use line wrapping with the command history feature to recall and modify previous complex command
entries. For information about recalling previous command entries, see the “Editing Commands Through
Keystrokes” section on page A-7.
Searching and Filtering the Output of show and more Commands
You can search and filter the output for show and more commands. This is useful when you need to sort
through large amounts of output or if you want to exclude output that you do not need to see.
To use this functionality, enter a show or more command, followed by the pipe character (|), one of the
keywords begin, include, or exclude, and an expression that you want to search for or filter out:
command | {begin | include | exclude} regular-expression
Expressions are case sensitive. For example, if you enter | exclude output, the lines that contain output
are not displayed, but the lines that contain Output are displayed.
This example shows how to include in the output display only the lines in which the expression protocol
appears:
bridge# show interfaces | include protocol
Vlan1 is up, line protocol is up
Vlan10 is up, line protocol is down
GigabitEthernet0/1 is up, line protocol is down
GigabitEthernet0/2 is up, line protocol is up
Cisco 3200 WMIC Image Upload Procedure
This document provides the procedures for configuring a Cisco 3200 Series router (referred to as the
Mobile Access Router Card (MARC)) as a TFTP server and uploading a Cisco IOS image to the router
and two WMICs enclosed with the router. The major advantage of this procedure is that all the cards in
the router receive the same version of the Cisco IOS image to avoid conflicts when the devices
communicate.
Overview
The Cisco 3200 Series router is actually a stack of devices contained in an enclosure that can include
multiple devices that process data from the network independently. For example, a Cisco 3200 Series
router with two WMICs is actually three devices in one enclosure; one router, consisting of a MARC and
possibly a Fast Ethernet Switch mobile interface card (FESMIC) and/or a Serial mobile interface card
(SMIC), and two WMICS.
The MARC communicates with a FESMIC or a SMIC through the internal PCI bus. The FESMIC and
the SMIC depend on the MARC to process the data that the FESMIC or SMIC send and receive. As a
result, FESMIC and SMIC cards are seen by the MARC as expansion cards, similar to the way in which
a modular Cisco router increases functionality with the addition of expansion modules. The cards
physically and logically become part of the router.
Each WMIC has an on-board CPU that processes data it sends and receives independent of the MARC.
The WMICs draw power from the internal bus; they do not use the bus to communicate with the other
devices in the stack. The WMICs communicate with the router by using the switched Fast Ethernet ports
and the routed Fast Ethernet port to create a small, internal Ethernet network. As a result, each WMIC
must store a copy of the Cisco IOS image in its memory and be configured independently.
Cisco 3200 Series Wireless MIC Software Configuration Guide
OL-6415-04
A-9
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Cisco 3200 WMIC Image Upload Procedure
To avoid conflicts, we recommend that you upload the same image to all of the devices (CPUs) in the
enclosure by configuring the router as a TFTP server that can serve the Cisco IOS image to the WMICs.
The following major steps are required to upload the Cisco IOS image to all the devices in a Cisco 3200
Series router stack.
Step 1
Configure the router as shown in the “Configuration Example for the MARC” section and verify
connectivity to a TFTP server.
Step 2
To copy the image to the MARC, use the copy tftp flash:tarfilename command.
Step 3
Enter the tftp-server flash:tarfilename command to configure the MARC as a TFTP server, making the
image available to the WMICs.
Step 4
Configure router for IP connectivity to all of the WMICs. Examples are provided in the “Fast Ethernet
0/0 WMIC Configuration Example Configuration” section on page A-11, the “Configuration Example
for the WMIC Attached to Switch Port 4” section on page A-11, and the “Configuration Example for the
WMIC Attached to Switch Port 3” section on page A-12.
Step 5
Upload the new image to the WMICs, for example:
– Enter the archive download-software /overwrite tftp://20.20.20.1/c3202-k9w7-tar command
– Enter the archive download-software /overwrite tftp://10.10.10.1/c3202-k9w7-tar command
– Enter the archive download-software /overwrite tftp://10.10.10.2/c3202-k9w7-tar command
Step 6
To verify that the new image is in place, use the show version command.
Configuration Example for the MARC
hostname MAR
!
ip routing
!
interface FastEthernet0/0
ip address 20.20.20.1 255.255.255.0
!
interface FastEthernet2/0
no ip address
shutdown
!
interface FastEthernet2/1
no ip address
shutdown
!
interface FastEthernet2/2
no ip address
no shutdown
!
interface FastEthernet2/3
no ip address
no shutdown
!
interface Vlan1
ip address 10.10.10.1 255.255.255.0
Cisco 3200 Series Wireless MIC Software Configuration Guide
A-10
OL-6415-04
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Cisco 3200 WMIC Image Upload Procedure
no shutdown
!
tftp-server flash: c3202-k9w7-tar
!
end
Fast Ethernet 0/0 WMIC Configuration Example Configuration
WMIC attached to FastEthernet0/0 Configuration
hostname MAR1-AP
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
no shutdown
!
ssid tsunami
authentication open
infrastructure-ssid
!
cca 0
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 4000
station-role workgroup-bridge
infrastructure-client
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
no shutdown
!
interface BVI1
ip address 20.20.20.2 255.255.255.0
no ip route-cache
no shutdown
!
ip default-gateway 20.20.20.1
!
bridge 1 route ip
!
end
Configuration Example for the WMIC Attached to Switch Port 4
hostname MAR1-SWITCHPORT4
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
Cisco 3200 Series Wireless MIC Software Configuration Guide
OL-6415-04
A-11
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Cisco 3200 WMIC Image Upload Procedure
no shutdown
!
cca 0
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 4000
station-role root ap-only
infrastructure-client
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
no shutdown
!
interface BVI1
ip address 10.10.10.2 255.255.255.0
no ip route-cache
!
ip default-gateway 10.10.10.1
bridge 1 route ip
!
end
Configuration Example for the WMIC Attached to Switch Port 3
hostname MAR1-SWITCHPORT3
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
no shutdown
!
cca 0
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
rts threshold 4000
station-role root ap-only
infrastructure-client
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
no shutdown
!
interface BVI1
ip address 10.10.10.3 255.255.255.0
Cisco 3200 Series Wireless MIC Software Configuration Guide
A-12
OL-6415-04
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Cisco 3200 WMIC Image Upload Procedure
no ip route-cache
!
ip default-gateway 10.10.10.1
bridge 1 route ip
!
end
Cisco 3200 Series Wireless MIC Software Configuration Guide
OL-6415-04
A-13
Appendix A
Connecting to the Cisco 3200 Series Router and Using the Command-Line Interface
Cisco 3200 WMIC Image Upload Procedure
Cisco 3200 Series Wireless MIC Software Configuration Guide
A-14
OL-6415-04
Download PDF