Flash Quick Reference, Macromedia Flash 8 Cheat

Adobe®
Flash 8
Quick Reference Card
888.903.2432 | www.customguide.com
Flash 8 Window
Title Bar
Keystroke Shortcuts
Menu Bar
General
Timeline
Tools
panel
Color
panel
Stage or
Movie
Area
Library
panel
• To Create a New Document: Select File →
New → Layer from the menu, or press <Ctrl>
+ <N>.
• To Close: To close the current document, select
File → Close from the menu, or press <Ctrl> +
<W>. To close all open documents, select File →
Close All from the menu, or press <Ctrl> +
<Alt> + <W>.
• To Add a Layer: Select Insert → Timeline
→ Layer from the menu, or click the Insert Layer
button in the Timeline.
• To Modify Document Properties: Select
Modify → Document from the menu, or press
<Ctrl> + <J>.
• To Find and Replace: Select Edit → Find
and Replace from the menu, or press <Ctrl> +
<F>.
• To Change Preferences: Select Edit →
Preferences from the menu, or press <Ctrl> +
<U>.
• To Export an Image: Select File → Export
→ Export Image from the menu.
• To Export a Movie: Select File → Export
→ Export Movie from the menu or press
<Ctrl> + <Alt> +<Shift> + <S>.
• To Open a Duplicate Window: Select
Window → Duplicate Window from the
menu, or press <Ctrl> + <Alt> + <K>.
<Ctrl> + <N>
Open
<Ctrl> + <O>
Browse assets
<Ctrl> + <Alt>
+ <O>
First Scene
<Home>
Last Scene
<End>
Show/Hide Panels
<Tab>
Zoom in
<Ctrl> + < = >
Zoom out
<Ctrl> + < - >
Find next
<F3>
Hide panels
<F4>
Help
<F1>
Exit
<Ctrl> + < Q >
Graphics
Property Inspector
The Fundamentals
New
The Tools Panel
Arrow
Line
Pen
Oval
Pencil
Ink Bottle
Dropper
Subselect
Lasso
Text
Rectangle
Break Apart
<Ctrl> + <B>
New Symbol
<Ctrl> + <F8>
Convert to Symbol
<F8>
Duplicate Selection
<Ctrl> + <D>
Align
<Ctrl> + <K>
Group Selected
<Ctrl> + <G>
Import
<Ctrl> + <R>
Export
<Ctrl>+ <Shift> +
<R>
Brush
Paint Bucket
Eraser
Timeline
Insert Frame
<F5>
Insert Keyframe
<F6>
Insert Blank
Keyframe
<F7>
Clear Keyframe
<Shift> + <F6>
Copy Frames
<Ctrl> + <Alt> +
<C>
Cut Frames
<Ctrl> + <Alt> +
<X>
Paste Frames
<Ctrl> + <Alt> +
<V>
• To Display Tool Options: Click a tool and
select a tool option at the bottom of the Tools panel.
Remove Frames
<Shift> + <F5>
• To Constrain Shapes: Press the <Shift> key
while dragging the shape.
Play Movie
<Enter>
Rewind Movie
<Ctrl> + <Alt> +
<R>
• To End Open Path (Pen Tool): Press
<Ctrl> and click to end the path
Step Forward
<.>
• To Convert a Corner Point to a Curve
Point: Click the Subselection tool and press
<Alt>, click the point you want to change and drag.
Step Backward
<,>
Mute Sounds
<Ctrl> + <Alt> +
<M>
Hand
Zoom
Stroke Color
Fill Color
Black and White
No Color
Swap Colors
Snap to Objects
Smooth
Straighten
Customizable Business Training
9 Online Learning 9 Skills Assessments 9 Courseware
888.903.2432 | www.customguide.com
© 2010 CustomGuide
Graphics
Timeline
Show/
Hide All
Layers
Lock/
Unlock
All Layers
New Add
Layer Motion
Guide
Show All
Layers as
Playhead
Outlines
Insert Delete
Layer Layer
Folder
Center Onion
frame Skinning
buttons
Timeline
header
Frame
view
Elapsed time
Frame Rate
Current Frame
• To Show or Hide the Timeline: Select Window → Timeline from
the menu or press <Ctrl> +<Alt> + <T>.
• To Insert a Layer: Click the New Layer button in the Timeline, or
select Insert → Layer from the menu.
• To Hide a Layer: Select the layer and click the Show/Hide All
Layers button in the Timeline.
• To Delete a Layer: Select the layer and click the Delete Layer button
in the Timeline.
• To Insert a Frame: Click an empty frame on the Timeline and select
Insert → Frame from the menu, or press <F5>. Flash inserts frames
from the last frame or keyframe to the selected point.
• To Delete a Frame: Select the frame(s) and select Insert → Remove
Frames from the menu, or press <Shift> + <F5>.
• To Insert a Keyframe: Click an empty frame on the Timeline and select
Insert → Keyframe from the menu, or press <F6>.
• To Insert a Blank Keyframe: Click an empty frame on the Timeline
and select Insert → Blank Keyframe from the menu, or press <F7>.
• To Draw a Shape: Select the shape you want to use from the Tools
panel. Click and drag to draw the shape on the stage.
• To Select a Shape: Click the Selection Tool button on the Tools
panel and click and drag around the shape to select it or double-click the
shape.
• To Change the Fill or Line Color of a Shape: Click the Paint
Bucket Tool button on the Tools panel. Choose the new color in the
Stroke or Fill color buttons. Click the fill or line of the shape you want to
change. Select the colors you want to use in the Stroke color and Fill color
buttons on the Tools panel.
• To Create a New Symbol: Select Insert → New Symbol from the
menu or press <Ctrl> + <F8>. Name the symbol and draw the symbol.
Click Scene 1 to exit the symbol and return to the workspace.
• To Convert a Shape to a Symbol: Select the shape and press
<F8>.
• To Convert a Symbol to a Shape: Select the symbol and select
Modify → Break Apart from the menu, or press <Ctrl> + <B>.
• To Edit a Symbol: Select Edit → Edit Symbols from the menu, or
press <Ctrl> + <E>.
• To Change Document Background: Select Modify →
Document from the menu, or press <Ctrl> + <J>. Select the color in the
Background color box.
• To Import a Picture or Graphic: Select File → Import and select
Import to Stage or Import to Library from the menu.
• To Insert Text: Click the Text Tool button in the Tools panel and type
the text.
• To Format Text: Select the text in the text box. Click the Text menu on
the menu bar and select the formatting you want to apply to the text.
• To Convert Text to a Graphic: Select the text box and press <F8>.
• To Clear a Keyframe: Select the keyframe and select Insert → Clear
Keyframe from the menu, or press <Shift> + <F6>. The keyframe
becomes a regular frame.
• To Edit a Bitmap: Select the symbol and select Modify → Break
Apart from the menu, or press <Ctrl> + <B>. Edit the bitmap using
commands on the Tools panel as necessary.
• To Create Frame-by-Frame Animation: Insert a keyframe in the
selected layer, place an object on the stage. Insert a keyframe in the next
frame, change the object from the first frame, and repeat.
Movie Playback
• To Insert Motion Tween Animation: Insert a keyframe in the
selected layer and place a symbol or grouped object on the stage. Select the
last keyframe you want to include in the motion animation, and move the
symbol or group to the final point of the motion animation. Click the first
keyframe and select Insert → Create Motion Tween from the menu,
or click the Tween list arrow and select Motion from the list.
• To Insert Shape Tween Animation: Insert a keyframe in the
selected layer and draw a shape (the shape cannot be a symbol or grouped
object). Select the last keyframe you want to include in the motion tween, and
draw the final shape of the animation. Click the first keyframe and select
Insert → Create Shape Tween from the menu, or click the Tween
list arrow and select Shape from the list.
• To Use a Color Tween: Click the last keyframe of a Shape Tween.
Select the shape that you want to change colors and specify the new color for
the shape.
• To Add a Timeline Effect: Select the object to which you want to add
the effect. Select Insert → Timeline Effects from the menu and select
an effect from the list.
• To Play a Scene: Select Control → Play from the menu, or press
<Enter>.
• To Rewind a Scene: Select Control → Rewind from the menu, or
press <Ctrl> + <Alt> + <R>.
• To View One Frame at a Time: Select Control → Step Forward
One Frame from the menu, or press < . > (period).
• To Mute Movie Sounds: Select Control → Mute Sounds from
the menu, or press <Ctrl> + <Alt> + <M>.
• To Test the Movie: Select Control → Test Movie from the menu,
or press <Ctrl> + <Shift> + <Enter>.
• To Debut the Movie: Select Debug → Debut Movie from the
menu, or press <Ctrl> + <Enter>.
• To Export the Movie: Select Control → Play from the menu, or
press <Enter>. Edit the bitmap using commands on the Tools panel as
necessary.
Customizable Business Training
9 Online Learning 9 Skills Assessments 9 Courseware
888.903.2432 | www.customguide.com
© 2010 CustomGuide