This chapter covers the following topics: • ADSL Overview • Cisco

0732x01.book Page 176 Monday, November 17, 2003 2:49 PM
This chapter covers the following topics:
•
•
•
•
ADSL Overview
Cisco 6160 DSLAM Overview
Cisco 6400 UAC Overview
DSL Access Architectures and Protocols
0732x01.book Page 177 Monday, November 17, 2003 2:49 PM
CHAPTER
8
Using DSL to Access
a Central Site
This chapter focuses on Digital Subscriber Line (DSL) technology. DSL, like cable modem,
is one of the most popular broadband access methods and will be a new topic on the
CCNP exam.
After completing this chapter, you will understand the basic Asymmetric DSL (ADSL)
technology, Cisco 6160 DSL Access Multiplexer (DSLAM) configuration, and Cisco 6400
Universal Access Concentrator (UAC) configuration. You will also understand different
access architectures and protocols such as Integrated Routing and Bridging (IRB), Routed
Bridge Encapsulation (RBE), Point-to-Point Protocol over ATM (PPPoA), and Point-to-Point
Protocol over Ethernet (PPPoE).
Note that there are different flavors of DSL technologies. This chapter focuses on ADSL
technology.
ADSL Overview
DSL technology introduces a new family of products that can provide high-speed data and
voice service over existing copper pairs. Several flavors of DSL exist, but each type can be
categorized as either SDSL or ADSL. Symmetric DSL (SDSL) provides equal bandwidth
from the customer premises to the service provider (upstream) and from the service
provider to the customer (downstream). ADSL provides higher downstream speeds than
upstream.
Traditionally, ADSL has been used to provide high-speed data service by encoding data
on the local loop by using frequencies (up to 1 MHz) greater than voice (up to 4 kHz) so
that existing telephone service would be preserved and would travel simultaneously with
the data. At the central office (CO), the voice would be routed to the public switched
telephone network (PSTN) using a low-pass frequency filter called a POTS splitter
chassis (PSC).
Figure 8-1 depicts a typical end-to-end ADSL system. Beginning at the customer premises,
the user’s general-purpose computer is connected to the ADSL Terminating Unit-Remote
(ATU-R) over an Ethernet connection.
0732x01.book Page 178 Monday, November 17, 2003 2:49 PM
178
Chapter 8: Using DSL to Access a Central Site
Figure 8-1
Typical End-to-End ADSL System
DSLAM
ATU-R
ATU-C
Data Network
Local Loop
CPE Splitter
PSTN
CO Splitter
Phone
Voice Switch
The ATU-R is typically connected to an external splitter device. In some cases, however, the
external splitter is eliminated in lieu of an internal filter in the ATU-R and microfilters attached
to plain old telephone service (POTS) devices in the home. From the splitter, the loop is wired
to a Network Interface Device (NID) that serves as the demarcation point into the customer
premises. From the NID, the loop is connected to a splitter device in the central office that splits
off voice traffic and routes it to the PSTN. Data is connected to the ADSL Terminating UnitCentral Office (ATU-C). The user’s data traffic is then typically routed across the ATM network
to an aggregation gateway or router.
Modulation Methods
Three modulation methods for encoding data onto the local loop are Carrierless Amplitude and
Phase (CAP), Discreet MultiTone 2 - Issue 2 (DMT2), and G.lite. DMT was selected as the
preferred standard for ADSL modulation. CAP technology is cost-effective and readily available.
G.lite is a simplified DMT encoding scheme that provides limited features to facilitate
interoperability and minimize end-user interaction.
Table 8-1 shows the maximum data rates for downstream and upstream, line-coding
technologies, and maximum reach. Note that the maximum-reach number is best-case,
assuming “clean copper.”
Table 8-1
ADSL Data Rates
Maximum Data Rate
Downlink/Uplink
Line Coding Technology
Maximum Reach
8 Mbps/1 Mbps
CAP, DMT
18,000 feet/5.5 km
1.5 Mbps/640 kbps
G.lite
18,000 feet/5.5 km
Sources of Interference
Many sources of interference can degrade the quality of DSL. For instance, loading coils are
used as a low-frequency (300 to 3300 Hz) filter but cannot be present for ADSL operation.
0732x01.book Page 179 Monday, November 17, 2003 2:49 PM
Cisco 6160 DSLAM Overview
179
Other sources of interference include the following:
•
•
•
•
Impedance changes
Bridged taps
Crosstalk
Impulse hits
Techniques to Solve Interference
Several techniques exist for adjusting to interference:
•
•
Rate-Adaptive DSL (RADSL)—Used to adjust the transmission rate.
•
Bit interleaving—Used to avoid having consecutive errors delivered to the FEC
algorithm at the receiving end of the circuit.
•
Trellis coding—A modulation error-correction technique to improve error performance
during reception.
Reed-Solomon Forward Error Correction (FEC)—The process of correcting errors
mathematically at the receiving end of a transmission path rather than calling for a
retransmission.
Cisco 6160 DSLAM Overview
This section provides an overview of the Cisco 6160 DSLAM system and hardware components
and discusses basic Cisco DSLAM configuration.
System and Hardware Components
The Cisco 6160 can be operated as a carrier class DSLAM with ADSL, SDSL, and Integrated
Services Digital Network DSL (IDSL) interfaces. The Cisco 6160 is intended for use in North
American central office facilities. The Cisco 6160 DSLAM can support up to 256 subscribers
and concentrate traffic onto a single high-speed WAN trunk.
Examine Figure 8-2. The chassis has 32 short slots for line cards and two double-length slots
for Network Interface (NI-2) cards. Slots 10 and 11 hold the NI-2 cards. Slots 1 to 9 and 12 to 34
hold the line cards. Some of the essential functions the NI-2 card provides are ATM switching,
WAN interface, and subtending.
WAN interfaces can be either OC-3c or DS3 and can be used for trunking or subtending.
Subtending allows up to 12 other chassis to be subtended to a single host DSLAM system,
aggregating the subtended systems through a single network uplink.
DSL line cards come in several varieties. In this chapter, the Quad Flexicard is used. It supports
four ADSL connections and can be configured with CAP, DMT2, or G.lite line coding.
0732x01.book Page 180 Monday, November 17, 2003 2:49 PM
180
Chapter 8: Using DSL to Access a Central Site
Figure 8-2
Cisco 6160 DSLAM Chassis
Line Cards
10
Line Cards
11
Slots 12 - 18
Slots 1 - 9
NI-2 NI-2
NOTE
Line Cards
Line Cards
Slots 19 - 27
Slots 28 - 34
You can install line cards of two or more different types in a single Cisco 6160 chassis.
However, mixing different types of cards (Flexi ADSL, SDSL, and/or IDSL) on the same
side of the chassis might result in decreased performance.
Basic Cisco 6160 DSLAM Configuration
In this section, you will learn all the necessary information to successfully configure the
Cisco 6160 DSLAM.
Interface Numbering
Before you begin the configuration, it is important to know the interface numbering scheme
used by the Cisco IOS software in the 6160. Interfaces whose names begin with ATM0 (ATM0/0,
ATM0/1, and so forth) are NI-2 card WAN interfaces. ATM0/0 is the ATM switch’s interface
with the processor. There is no need to configure ATM0/0 unless you plan to use in-band
management. ATM0/1 is the trunk port. ATM0/2 and ATM0/3, if present, are subtending interfaces.
Table 8-2 illustrates the interface numbering scheme for Cisco 6160 DSLAM.
Table 8-2
Cisco 6160 DSLAM Interface Numbering
Interface
Description
ATM0/0
The ATM switch’s interface
ATM0/1
Trunk interface
ATM0/2
Subtend
ATMA/B
A = 1 to 34 (slot); B = 1 to 4 (port)
Ethernet0/0
Management Ethernet port
0732x01.book Page 181 Monday, November 17, 2003 2:49 PM
Cisco 6160 DSLAM Overview
181
As shown in Table 8-2, interfaces whose names begin with ATM1 through ATM34 are line card
interfaces. Ethernet0/0 is the interface for the LAN that connects the Cisco 6160 to its
management system. For line card interfaces, the number before the slash indicates the slot
number. The number after the slash indicates the interface or port number. For example, ATM5/4
is port 4 in slot 5.
Configuring Line Cards
Before you can use the Flexicard, you need to configure a slot for a specific card type. Use this
command:
slot slot# cardtype
slot# is the slot number; the range is 1 to 34. cardtype is the card type for which you want to
configure the slot. You must indicate the type of card. To configure the Quad Flexicard in slot 1
to use DMT modulation, you would enter the following:
lab-6160(config)#slot 1 ATUC-4FLEXIDMT
NOTE
You can use show hardware command to find out which cards are installed in the Cisco 6160
DSLAM.
Creating DSL Profiles
Except for a few dynamic operational modes, port configuration takes place through a
configuration profile rather than by direct configuration. A profile is a named list of configuration
parameters with a value assigned to each parameter. You can change the value of each
parameter in the profile. To configure a subscriber, you need only attach the desired profile
to that subscriber. When you change a parameter in a profile, you change the value of that
parameter on all ports using that profile. If you want to change a single port or a subset of
ports, you can copy the profile, change the desired parameters, and then assign the new
profile to the desired ports. Multiple ports can share the same profile, but one port cannot
have more than one profile. If you modify an existing profile, that change takes effect on
every ADSL port linked to that profile.
Every port is attached to a special profile named “default” by default. You can modify the
default profile (but not delete it). This is useful when you want to modify one or two default
parameters and apply this to every port in the system (rather than creating a new profile with
minor changes and attaching it to every port in the system).
When you create a profile, it inherits all the configuration settings of the default profile at the
time of creation. If you subsequently modify the special profile default, the new changes to the
default do not propagate to the previously created profiles.
0732x01.book Page 182 Monday, November 17, 2003 2:49 PM
182
Chapter 8: Using DSL to Access a Central Site
To create a DSL profile, or to select an existing profile for modification, use the following
command:
dsl-profile profile-name
To delete a DSL profile, use the following command:
no dsl-profile profile-name
In both examples, profile-name is the name of the profile you want to create, or an existing
profile you want to delete or modify. To create a DSL profile called ccnp, you would enter
the following:
lab-6160#configure terminal
lab-6160(config)#dsl-profile ccnp
After the DSL profiles are created, you can customize them with the following parameters:
•
•
•
•
•
Bit rate
DMT margin
Check bytes
Interleaving delay
Training mode
The following sections discuss these parameters in more detail.
Setting the Bit Rate
To set the maximum and minimum allowed bit rates for the fast-path and interleaved-path
profile parameters, use the following command:
dmt bitrate max interleaved downstream dmt-bitrate upstream dmt-bitrate
dmt-bitrate is a multiple of 32 kbps. If you enter a nonmultiple of 32 kbps, the Cisco IOS
software aborts the command.
In Example 8-1, the command sets the maximum interleaved-path bit rate of the ccnp profile to
8032 kbps downstream and 832 kbps upstream.
Example 8-1 Setting the Bit Rate
lab-6160#configure terminal
lab-6160(config)#dsl-profile ccnp
lab-6160(config-dsl-prof)#dmt bitrate interleaved-path downstream 8032
upstream 832
Setting the Margins
To set upstream and downstream signal-to-noise ratio (SNR) DMT margins, use the following
command:
dmt margin downstream dmt-margin upstream dmt-margin
0732x01.book Page 183 Monday, November 17, 2003 2:49 PM
Cisco 6160 DSLAM Overview
183
dmt-margin is equal to the upstream and downstream SNR margins in decibels. Values must be
nonnegative integers. The range is from 0 to 127 dB.
NOTE
Research has shown that the optimum margins for DMT service are 6 dB downstream and 6 dB
upstream.
In Example 8-2, the command sets the DMT SNR margins of the ccnp profile to 6 dB upstream
and 3 dB downstream.
Example 8-2 Setting the Margin
lab-6160#configure terminal
lab-6160(config)#dsl-profile ccnp
lab-6160(config-dsl-prof)#dmt margin downstream 3 upstream 6
Setting Check Bytes
Check bytes are also called FEC bytes. They are added to the user data stream to improve error
correction, but they slow performance. To set upstream and downstream check bytes, use the
following command:
dmt check-bytes interleaved downstream bytes upstream bytes
bytes values can be 0, 2, 4, 6, 8, 10, 12, 14, and 16. The default is 16 in each direction.
In Example 8-3, the command sets the interleaved check bytes for the ccnp profile to 6 upstream
and 12 downstream.
Example 8-3 Setting the Check Bytes
lab-6160#configure terminal
lab-6160(config)#dsl-profile ccnp
lab-6160(config-dsl-prof)#dmt check-bytes interleaved
downstream 12 upstream 6
Setting Interleaving Delay
To set the interleaving delay parameter, use this command:
dmt interleaving-delay downstream delay-in-µsecs upstream delay-in-µsecs
delay-in-µsecs specifies the interleaving delay in microseconds. The default value is
16000 microseconds in each direction. Allowable values are 0, 500, 1000, 2000, 4000, 8000,
and 16000 microseconds.
In Example 8-4, the command sets the interleaving delay of the ccnp profile to 2000 microseconds
downstream and 4000 microseconds upstream.
0732x01.book Page 184 Monday, November 17, 2003 2:49 PM
184
Chapter 8: Using DSL to Access a Central Site
Example 8-4 Setting the Interleaving Delay
lab-6160#configure terminal
lab-6160(config)#dsl-profile ccnp
lab-6160(config-dsl-prof)#dmt interleaving-delay downstream 2000 upstream 4000
Setting the Training Mode
Two training modes are available—standard and quick. Standard train relates to a training
procedure specified in ANSI standards document T1.413, which is considered the standards
reference for DMT ADSL. Quick train, also called fast train, uses a vendor-specific training
sequence that is shorter than the standard training sequence.
To modify the training mode in a DMT profile, use the following command:
dmt training-mode {standard / quick}
In Example 8-5, the command sets the ccnp profile’s training mode to quick.
Example 8-5 Setting the Training Mode
lab-6160#configure terminal
lab-6160(config)#dsl-profile ccnp
lab-6160(config-dsl-prof)#dmt training-mode quick
Cisco 6400 UAC Overview
This section provides an overview of 6400 Universal Access Concentrator (UAC) hardware
components (see Figure 8-3). Functional descriptions are provided for each component. How
all the components work together within the system is also described.
Figure 8-3
Cisco 6400 UAC Hardware Component
Slot #
1
2 3 4 0A 0B 5 6 7
P
E
M
A N N
R R
P P
P
E
M
B
N N
S S
P P
8
N N
L L
C C
Sub Slot 0
A B
N N
L L
C C
Sub Slot 1
0732x01.book Page 185 Monday, November 17, 2003 2:49 PM
Cisco 6400 UAC Overview
185
The 6400 is a broadband concentrator that supports Cisco’s ATM services, PPP termination,
and tunneling. The Cisco 6400 combines ATM switching and routing in a modular and scalable
platform.
The 6400 UAC comprises three major functional components:
•
Node Line Card (NLC)—A half-height line card. It features two OC-3 ATM interfaces
and supports SONET APS 1+1 redundancy.
•
Node Switch Processor (NSP)—The centerpiece of the 6400 system. It performs ATM
switching and per-flow queuing for the ATM virtual circuits.
•
Node Route Processor (NRP)—Based on the Cisco 7200 series router. It supports a
variety of configurations, including PPP over ATM and RFC 1483 bridging. It is a fullheight line card.
Figure 8-4 illustrates how these components work together.
Figure 8-4
Typical Traffic Flow for the Cisco 6400 UAC
DSLAM
ATM
N
L
C
N
S
P
N
R
P
Fast Ethernet
The NLC receives traffic from the DSLAM or other ATM network. The NLC sends this traffic
to the NSP. The NSP acts as an ATM switch. The ATM cells must be sent from the NSP to the
NRP. The NRP handles routing functions for the 6400. The NRP reassembles the ATM cells
into data packets and determines where the data needs to be sent. Direct data connections can
be made via a Fast Ethernet port on the NRP. Other data packets are sent back through the NSP
to the NLC, where these packets may be routed through the ATM network.
Understanding interface numbering is also important before you configure the 6400. The interface
slot/subslot/port convention is used for both NLC and NRP. For NLC, the valid subslot and port
number are 0 and 1. Because NRP is a full-height card, the subslot and port are always 0. In
Example 8-6, NRP is installed in slot 1 and NLC is installed in slot 8, subslot 1.
Example 8-6 Cisco 6400 UAC Interface Numbering
interface atm 1/0/0
interface atm 8/1/0
NRP in slot 1
NLC in slot 8, sub-slot 1, port 0
0732x01.book Page 186 Monday, November 17, 2003 2:49 PM
186
Chapter 8: Using DSL to Access a Central Site
All line cards are connected to the ATM backplane to the NSP. This interface is known as
interface ATM0/0/0 and can be thought of as the interface to the NSP from an NLC or NRP
card’s perspective. Example 8-7 shows information about the NSP’s ATM backplane.
Example 8-7 Internal Connection to the CPU Card
lab-6400NSP#show interface atm 0/0/0
ATM0/0/0 is up, line protocol is up
Hardware is CPU card
MTU 4470 bytes, sub MTU 4470, BW 155520 Kbit, DLY 0 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM, loopback not set
Keepalive not supported
Encapsulation(s):
4096 maximum active VCs, 0 current VCCs
VC idle disconnect time: 300 seconds
Signalling vc = 35, vpi = 0, vci = 16
UNI Version = 3.0, Link Side = user
To create an ATM PVC on the Cisco 6400, you can use the following command syntax:
interface atm slot/subslot/port
atm pvc vpi vci interface atm slot/subslot/port vpi vci
Example 8-8 shows you how to create an ATM PVC. From the NSP, to create PVC 1/100
coming from NLC 8/0/0 to NRP 1/0/0, the 6400 commands are as shown.
Example 8-8 Creating an ATM PVC from the NLC to the NRP
interface atm 8/0/0
atm pvc 1 100 atm1/0/0 1 100
DSL Access Architectures and Protocols
The following sections show you the different access architectures and protocols for the DSL
service. Four types of access architectures and protocols are covered in this chapter.
•
•
•
•
IRB
RBE
PPPoA
PPPoE
RFC 1483 Bridging and IRB Overview
When configured for RFC 1483 bridging, the ATU-R acts as a half bridge, forwarding all MAC
frames not present on the LAN side to the WAN interface. In the case of 1483 bridging,
802.3 MAC frames are encapsulated along with an LLC/SNAP header into cells using AAL5
segmentation. The LLC/SNAP header is used to identify the protocols encapsulated to the
0732x01.book Page 187 Monday, November 17, 2003 2:49 PM
DSL Access Architectures and Protocols
187
remote end. Bridge groups are defined by associating VCs with each other. Bridge groups can
be defined in several ways. Bridge members can communicate only with a network host,
between each member and use IRB to route out of the bridge.
Bridge Group Virtual Interface (BVI) is a virtual interface that resides in the Cisco 827 and
NRP. It acts as an interface between a bridge group and a routed interface. When configured for
IRB, the BVI is assigned a number that corresponds to the bridge group that is used to associate
the bridge group with the BVI. BVI is used as routed interface with network-layer attributes
such as IP address, filtering, and so on. On BVI, routing is enabled on a per-protocol basis. BVI
allows you to route a given protocol between routed interfaces and bridge groups. Figure 8-5
illustrates the RFC 1483 bridging protocol stack.
Figure 8-5
RFC 1483 Bridging Protocol Stack
IP
1483 over ATM
IP
802.3
802.3
IP
802.3
CAT 5
802.3
CAT 5
1483
ATM
ADSL
CPE
1483
ATM
ADSL
ATM
PHY
DSLAM
ATM
PHY
6400 UAC
ATM PVC
To configure IRB, follow these steps:
Step 1 Enable IRB with the following code:
bridge irb
Step 2 Specify the bridge protocol to define the type of Spanning Tree Protocol:
bridge bridge-group protocol {ieee | dec}
Step 3 Specify a protocol to be routed in a bridge group:
bridge bridge-group route protocol
Step 4 Configure the ATM subinterface and aal5snap encapsulation:
interface atm slot/0.subinterface-number {multipoint | point-to-point}
pvc [name] vpi/vci
encapsulation aal5snap
0732x01.book Page 188 Monday, November 17, 2003 2:49 PM
188
Chapter 8: Using DSL to Access a Central Site
Step 5 Assign a network interface to a bridge group:
bridge-group bridge-group
Step 6 Enables a bridge group virtual interface:
interface bvi bridge-group
Example 8-9 demonstrates the IRB configuration of the Cisco 6400 NRP.
Example 8-9 IRB Configuration
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
interface ATM0/0/0.133 point-to-point
description Integrated
no ip directed-broadcast
pvc 1/33
encapsulation aal5snap
!
bridge-group 1
!
interface BVI1
ip address 10.1.1.1 255.255.255.0
RBE Overview
When configured for RBE, the CPE configuration remains the same as that in IRB. RBE is
intended to address most of the RFC 1483 bridging issues, such as broadcast storms and
security. The ATU-R behaves like the routed-bridge interface that is connected to an Ethernet
LAN. For packets sending from the customer side, the destination IP address is examined,
and the Ethernet header is skipped. If the destination IP address is in the route cache, the packet
is fast-switched to the outbound interface. If the destination IP address is not the route cache,
the packet is queued for process switching.
For packets destined for the customer devices, the destination IP address is examined first,
and then the destination interface is determined from the IP routing table. To place a
destination MAC address in the Ethernet header, the router checks the ARP table for that
interface. If the MAC address is not found, the router generates an ARP request for the
destination IP address and forwards the ARP request to the destination interface only. If an
unnumbered interface is used and multiple subscribers are on the same subnet, the routedbridge interface uses proxy ARP. All of these can be achieved without using a bridge group
or BVI in the aggregation gateway and therefore are more scalable. Figure 8-6 illustrates
the RBE protocol stack.
0732x01.book Page 189 Monday, November 17, 2003 2:49 PM
DSL Access Architectures and Protocols
Figure 8-6
189
RBE Protocol Stack
IP
1483 over ATM
IP
802.3
IP
IP
802.3
CAT 5
1483
802.3
ATM
ADSL
CAT 5
1483
ATM
ADSL
CPE
ATM
PHY
DSLAM
ATM
PHY
6400 UAC
ATM PVC
To configure RBE, follow these steps:
Step 1 Configure the ATM subinterface, and use aal5snap encapsulation. ip
unnumbered is used when subscribers are on the same subnet and to
conserve IP address space. You can use the ip address command if
subscribers are on different subnets.
interface atm slot/0.subinterface-number {multipoint | point-to-point}
ip unnumbered interface-name-number
pvc [name] vpi/vci
encapsulation aal5snap
Step 2 Associate the RBE command with the ATM subinterface:
atm route-bridged ip
Step 3 Define the static host route. It is required if the IP unnumbered configuration
is used.
ip route network-number [network-mask] {address | interface} [distance]
[name name]
Example 8-10 demonstrates the RBE configuration of the Cisco 6400 NRP.
Example 8-10 RBE Configuration
interface Loopback0
ip address 192.168.1.1 255.255.255.0
no ip directed-broadcast
!
continues
0732x01.book Page 190 Monday, November 17, 2003 2:49 PM
190
Chapter 8: Using DSL to Access a Central Site
Example 8-10 RBE Configuration (Continued)
interface ATM0/0/0.1 point-to-point
ip unnumbered Loopback0
no ip directed-broadcast
atm route-bridged ip
pvc 1/35
encapsulation aal5snap
!
ip route 192.168.1.2 255.255.255.255 ATM0/0/0.1
PPPoA Overview
When configured for PPP over ATM, the ATU-R acts as a router, and additionally provides
DHCP and NAT services to the LAN side. In the case of PPP routing, IP packets are
encapsulated into a PPP frame and then are segmented into ATM cells through AAL5. The PPP
sessions initiated by the subscriber are terminated at the service provider that authenticates
users, either using a local database on the router or through a RADIUS server. After the user is
authenticated, IPCP negotiation takes place, and then the IP address gets assigned to the CPE.
Figure 8-7 illustrates the PPPoA protocol stack.
Figure 8-7
PPPoA Protocol Stack
IP
1483 over ATM
IP
PPP
IP
IP
802.3
CAT 5
802.3
CAT 5
PPP
1483
ATM
ADSL
1483
ATM
ADSL
CPE
ATM
PHY
DSLAM
ATM
PHY
6400 UAC
ATM PVC
Follow the next steps to configure PPPoA. (Note that local authentication is used here and that
the IP address for the CPE is assigned by the router. RADIUS can be used for these tasks.)
Step 1 Configure a username and password for local authentication:
username name password secret
0732x01.book Page 191 Monday, November 17, 2003 2:49 PM
DSL Access Architectures and Protocols
Step 2 Create an ATM subinterface and PVC:
interface atm slot/0.subinterface-number {multipoint | point-to-point}
pvc [name] vpi/vci
Step 3 Configure PPPoA encapsulation, and associate a virtual template with it:
encapsulation aal5mux ppp virtual-template number
aal5mux encapsulation is used for the PPPoA configuration. virtual-template
serves as the template, and the virtual-access interface is cloned from the
virtual template.
Step 4 Create a virtual template interface:
interface virtual-template number
Step 5 Conserve IP addresses by configuring the ATM subinterface as unnumbered,
and assign the IP address of the interface type you want to leverage:
ip unnumbered interface-name-number
Step 6 Create the local IP address pool:
ip local pool name begin-ip-address-range [end-ip-address-range]
Step 7 Specify the pool for the interface to use:
peer default ip address pool poolname
Step 8 Enable CHAP or PAP authentication on the interface:
ppp authentication {chap | pap | chap pap | pap chap} [if-needed]
{default | list-name} [callin]
Example 8-11 demonstrates the PPPoA configuration of the Cisco 6400 NRP.
Example 8-11 PPPoA Configuration
username cisco password 0 cisco
!
interface ATM0/0/0.133 point-to-point
no ip directed-broadcast
pvc 1/33
encapsulation aal5mux ppp Virtual-Template1
!
interface Virtual-Template1
description PPPoATM
ip unnumbered FastEthernet0/0/0
no ip directed-broadcast
peer default ip address pool ccnp
ppp authentication chap
!
ip local pool ccnp 10.1.1.10 10.1.1.50
191
0732x01.book Page 192 Monday, November 17, 2003 2:49 PM
192
Chapter 8: Using DSL to Access a Central Site
PPPoE Overview
For PPPoE, the ATU-R is transparent to this function, bridging the MAC/PPP frames across the
WAN interface. The PPPoE feature allows a PPP session to be initiated on a simple bridging
Ethernet-connected client. The session is transported over the ATM link via encapsulated Ethernetbridged frames. The session can be terminated at either a local exchange carrier central office or an
Internet service provider point of presence. The termination device is a Cisco 6400 UAC.
In the PPPoE architecture, the IP address allocation for the individual host running the PPPoE
client is based on the same principle of PPP in dial mode—that is, via IPCP negotiation. Where
the IP address is allocated from depends on the type of service the subscriber has subscribed
to and where the PPP sessions are terminated. The PPPoE uses the dialup networking feature
of Microsoft Windows. The IP address assigned is reflected with the PPP adapter. The IP
address assignment can be either by the UAC or the home gateways if L2TP is used. The IP
address is assigned for each PPPoE session. Figure 8-8 illustrates the PPPoE protocol stack.
Figure 8-8
PPPoE Protocol Stack
IP
1483 over ATM
802.3
IP
PPP
802.3
CAT 5
802.3
CAT 5
1483
ATM
ADSL
ATM
ADSL
CPE
ATM
PHY
DSLAM
IP
PPP
802.3
1483
ATM
PHY
6400 UAC
ATM PVC
To configure PPPoE, follow these steps. (Note that local authentication is used here, and the
router assigns IP addresses for the hosts. RADIUS can be used for these tasks.)
Step 1 Make sure Cisco Express Forwarding is enabled. If it isn’t, use the following
command to enable it:
ip cef
Step 2 Configure the username and password for local authentication:
username name password secret
Step 3 Enable the virtual private dialup network (VPDN) configuration:
vpdn enable
0732x01.book Page 193 Monday, November 17, 2003 2:49 PM
DSL Access Architectures and Protocols
193
Step 4 Configure the VPDN group to accept the dial-in and to be used to establish
PPPoE sessions. Also specify the virtual template that will be used to clone
virtual-access interfaces:
vpdn-group number
accept-dialin
protocol pppoe
virtual-template template-number
Step 5 Create the ATM subinterface and PVC. Also configure AAL5SNAP
encapsulation and specify the PPPoE protocol that the VPDN group will use:
interface atm slot/0.subinterface-number {multipoint | point-to-point}
pvc [name] vpi/vci
encapsulation aal5snap
protocol pppoe
Step 6 Create the virtual template interface:
interface virtual-template number
Step 7 Conserve IP addresses by configuring the ATM subinterface as unnumbered,
and assign the IP address of the interface type you want to leverage:
ip unnumbered interface-name-number
Step 8 Configure the maximum transmission unit (MTU):
ip mtu 1492
Because Ethernet has a maximum payload size of 1500 bytes, the PPPoE
header is 6 bytes and the PPP ID is 2 bytes, so the PPP MTU must not be
greater than 1492 bytes.
Step 9 Create a local IP address pool:
ip local pool name begin-ip-address-range [end-ip-address-range]
Step 10 Specify the IP address pool for the interface to use:
peer default ip address pool poolname
Step 11 Enable CHAP or PAP authentication on the interface:
ppp authentication {chap | pap | chap pap | pap chap} [if-needed]
{default | list-name} [callin]
Example 8-12 demonstrates the PPPoE configuration of the Cisco 6400 NRP.
Example 8-12 PPPoE Configuration
username cisco password 0 cisco
!
vpdn enable
!
vpdn-group 1
continues
0732x01.book Page 194 Monday, November 17, 2003 2:49 PM
194
Chapter 8: Using DSL to Access a Central Site
Example 8-12 PPPoE Configuration (Continued)
accept-dialin
protocol pppoe
virtual-template 1
!
ip cef
!
interface ATM0/0/0.133 point-to-point
no ip directed-broadcast
pvc 1/33
encapsulation aal5snap
protocol pppoe
!
interface Virtual-Template1
ip unnumbered FastEthernet0/0/0
no ip directed-broadcast
ip mtu 1492
peer default ip address pool ccnp
ppp authentication chap
!
ip local pool ccnp 10.1.1.10 10.1.1.50
Scenarios
This section presents several examples of DSL access configurations. The scenarios cover the
configuration for a DSLAM, a Cisco 6400 UAC NSP, a Cisco 6400 UAC NRP, and a DSL
CPE - Cisco 827.
Scenario 8-1: Configuring IRB over DSL
In this scenario, you will configure the DSL solution to support data transport using IRB.
When completed, the Cisco 827 should train up with the DSLAM, and you should be able to
ping and access all normal network services from a client PC attached to the DSL CPE modem.
Figure 8-9 illustrates how these devices are interconnected.
Figure 8-9
IRB Lab Scenario
ATM 0/1
NLC
ATM 8/0/0
NRP
ATM 1/0/0
ATM 1/1
PVC 1/51
lab-827A
lab-6400
lab-6160
0732x01.book Page 195 Monday, November 17, 2003 2:49 PM
Scenarios
195
In Example 8-13, the PVC is mapped from the Cisco 827 DSL connection (ATM1/1) to the
DSLAM trunking port (ATM0/1).
Example 8-13 ATM PVC Configuration for the Cisco 6160 DSLAM
interface ATM1/1
description IRB Architecture
no ip address
no atm ilmi-keepalive
atm pvc 1 51 interface ATM0/1 1 51
In Example 8-14, the PVC is configured from the DSLAM to the NSP and NRP. Interface
ATM8/0/0 is the network line card, and interface ATM1/0/0 is the NRP.
Example 8-14 ATM PVC Configuration for the NSP
interface ATM8/0/0
description OC3 connection to lab-6160
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
atm pvc 1 51 interface ATM1/0/0 1 51
A bridge group is configured for IP, and a BVI is created for IRB. The BVI becomes the
default gateway for the remote device attached to the CPE equipment (which will be in
subnet 10.1.121.0/24). A subinterface is created for a PVC to the NSP. (See the NSP
configuration. The NSP maps this PVC to another PVC from the DSLAM, which maps to
the subscriber PVC.) In this case, the 1/51 PVC is mapped across the NSP to the 6160. The
subinterface is also put in the bridge group. Example 8-15 shows the IRB configuration for
the NRP.
Example 8-15 IRB Configuration for the NRP
bridge irb
!
interface BVI1
ip address 10.1.121.1 255.255.255.0
no ip directed-broadcast
!
bridge 1 protocol ieee
bridge 1 route ip
!
interface ATM0/0/0
no ip address
no ip directed-broadcast
!
interface ATM0/0/0.51 point-to-point
continues
0732x01.book Page 196 Monday, November 17, 2003 2:49 PM
196
Chapter 8: Using DSL to Access a Central Site
Example 8-15 IRB Configuration for the NRP (Continued)
description IRB Configuration
no ip directed-broadcast
pvc 1/51
encapsulation aal5snap
!
bridge-group 1
Example 8-16 shows the bridging configuration for the DSL CPE.
Example 8-16 RFC 1483 Bridging Configuration for the Cisco 827
hostname lab-827A
!
ip subnet-zero
no ip routing
!
interface Ethernet0
ip address 10.1.121.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
bridge-group 1
!
interface atm0
mac-address 0001.96a4.8fae
<--- MAC Address from Ethernet 0
ip address 10.1.121.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 1/51
encapsulation aal5snap
!
bundle-enable
bridge-group 1
hold-queue 224 in
!
ip classless
no ip http server
!
bridge 1 protocol ieee
Scenario 8-2: Configuring RBE over DSL
In this scenario, you will configure the DSL solution to support data transport using RBE.
When completed, the Cisco 827 should train up with the DSLAM, and you should be able to
ping and access all normal network services from a client PC attached to the DSL CPE modem.
Figure 8-10 illustrates how these devices are interconnected.
0732x01.book Page 197 Monday, November 17, 2003 2:49 PM
Scenarios
197
Figure 8-10 RBE Scenario
ATM 0/1
NLC
ATM 8/0/0
NRP
ATM 1/0/0
ATM 1/2
PVC 1/52
lab-827B
lab-6400
lab-6160
In Example 8-17, the PVC is mapped from the Cisco 827 DSL connection (ATM1/2) to the
DSLAM trunking port (ATM0/1).
Example 8-17 ATM PVC Configuration for the Cisco 6160 DSLAM
interface ATM1/2
description RBE Architecture
no ip address
no atm ilmi-keepalive
atm pvc 1 52 interface ATM0/1 1 52
In Example 8-18, the PVC is configured from the DSLAM to the NSP and NRP. Interface
ATM8/0/0 is the network line card, and interface ATM1/0/0 is the NRP.
Example 8-18 ATM PVC Configuration for the NSP
interface ATM8/0/0
description OC3 connection to lab-6160
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
atm pvc 1 52 interface ATM1/0/0 1 52
Example 8-19 shows the RBE configuration for the NRP. You saw the configuration steps in the
previous section.
Example 8-19 RBE Configuration for the NRP
interface Loopback1
ip address 10.1.121.1 255.255.255.0
no ip directed-broadcast
!
interface ATM0/0/0
no ip address
no ip directed-broadcast
continues
0732x01.book Page 198 Monday, November 17, 2003 2:49 PM
198
Chapter 8: Using DSL to Access a Central Site
Example 8-19 RBE Configuration for the NRP (Continued)
!
interface ATM0/0/0.52 point-to-point
description RBE Configuration
ip unnumbered Loopback1
atm route-bridged ip
pvc 1/52
encapsulation aal5snap
!
ip route 10.1.121.2 255.255.255.255 ATM0/0/0.52
Example 8-20 shows the bridging configuration for the DSL CPE. As you can see, the CPE
configuration is the same when you configure the IRB over DSL.
Example 8-20 RFC 1483 Bridging Configuration for the Cisco 827
hostname lab-827B
!
ip subnet-zero
no ip routing
!
interface Ethernet0
ip address 10.1.121.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
bridge-group 1
!
interface atm0
mac-address 0001.96a4.8fae
ip address 10.1.121.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 1/52
encapsulation aal5snap
!
bundle-enable
bridge-group 1
hold-queue 224 in
!
ip classless
no ip http server
!
bridge 1 protocol ieee
Scenario 8-3: Configuring PPPoA over DSL
In this scenario, you will configure the DSL solution to support data transport using PPPoA.
When completed, the Cisco 827 should train up with the DSLAM, and you should be able to
ping and access all normal network services from a client PC attached to the DSL CPE modem.
Figure 8-11 illustrates how these devices are interconnected.
0732x01.book Page 199 Monday, November 17, 2003 2:49 PM
Scenarios
199
Figure 8-11 PPPoA Lab Scenario
ATM 0/1
NLC
ATM 8/0/0
NRP
ATM 1/0/0
ATM 1/3
PVC 1/53
lab-827C
lab-6400
lab-6160
In Example 8-21, the PVC is mapped from the Cisco 827 DSL connection (ATM1/3) to the
DSLAM trunking port (ATM0/1).
Example 8-21 ATM PVC Configuration for the Cisco 6160 DSLAM
interface ATM1/3
description PPPoA Architecture
no ip address
no atm ilmi-keepalive
atm pvc 1 53 interface ATM0/1 1 53
In Example 8-22, the PVC is configured from the DSLAM to the NSP and NRP. Interface
ATM8/0/0 is the network line card, and interface ATM1/0/0 is the NRP.
Example 8-22 ATM PVC Configuration for the NSP
interface ATM8/0/0
description OC3 connection to lab-6160
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
atm pvc 1 53 interface ATM1/0/0 1 53
Example 8-23 shows the PPPoA configuration for the NRP.
Example 8-23 PPPoA Configuration for the NRP
username cisco password 0 cisco
!
interface ATM0/0/0
no ip address
no ip directed-broadcast
!
interface ATM0/0/0.53 point-to-point
description PPPoA Configuration
pvc 1/53
continues
0732x01.book Page 200 Monday, November 17, 2003 2:49 PM
200
Chapter 8: Using DSL to Access a Central Site
Example 8-23 PPPoA Configuration for the NRP (Continued)
encapsulation aal5mux ppp Virtual-Template1
!
interface Virtual-Template1
description PPPoA
ip unnumbered Ethernet0/0/0
peer default ip address pool ccnp
ppp authentication chap pap
Example 8-24 shows the PPPoA configuration for the DSL CPE.
Example 8-24 PPPoA Configuration for the Cisco 827
hostname lab-827C
!
ip subnet-zero
!
interface Ethernet0
ip address 10.0.0.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
!
interface ATM0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 1/53
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface Dialer1
ip address negotiated
no ip directed-broadcast
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname cisco
ppp chap password cisco
!
ip classless
!
dialer-list 1 protocol ip permit
When a PPP connection is made, a virtual interface is created, as shown in Example 8-25. The
connection is authenticated with PAP/CHAP (using username “cisco” and password “cisco”).
IP addresses are negotiated and handed out from the address pool named ccnp.
0732x01.book Page 201 Monday, November 17, 2003 2:49 PM
Scenarios
201
Example 8-25 Verifying the Virtual Interface
lab-6400NRP#show interface virtual-access 1
Virtual-Access1 is up, line protocol is up
Hardware is Virtual Access interface
Description: PPPoA
Interface is unnumbered. Using address of Ethernet0/0/0 (10.1.1.190)
MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
LCP Open
Open: IPCP
Bound to ATM0/0/0.53 VCD: 3, VPI: 1, VCI: 53
Cloned from virtual-template: 1
Last input 00:00:03, output never, output hang never
Last clearing of "show interface" counters 14:05:57
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
10239 packets input, 141642 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
21626 packets output, 852074 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Scenario 8-4: Configuring PPPoE over DSL
In this scenario, you will configure the DSL solution to support data transport using PPPoE.
When completed, the Cisco 827 should train up with the DSLAM, and you should be able to
ping and access all normal network services from a client PC attached to the DSL CPE modem.
Figure 8-12 illustrates how these devices are interconnected.
Figure 8-12 PPPoE Lab Scenario
ATM 0/1
NLC
ATM 8/0/0
NRP
ATM 1/0/0
ATM 1/4
PVC 1/54
lab-827D
lab-6400
lab-6160
0732x01.book Page 202 Monday, November 17, 2003 2:49 PM
202
Chapter 8: Using DSL to Access a Central Site
In Example 8-26, the PVC is mapped from the Cisco 827 DSL connection (ATM1/4) to the
DSLAM trunking port (ATM0/1).
Example 8-26 ATM PVC Configuration for the Cisco 6160 DSLAM
interface ATM1/4
description PPPoE Architecture
no ip address
no atm ilmi-keepalive
atm pvc 1 54 interface ATM0/1 1 54
In Example 8-27, the PVC is configured from the DSLAM to the NSP and NRP. Interface
ATM8/0/0 is the network line card, and interface ATM1/0/0 is the NRP.
Example 8-27 ATM PVC Configuration for the NSP
interface ATM8/0/0
description OC3 connection to lab-6160
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
atm pvc 1 54 interface ATM1/0/0 1 54
Example 8-28 shows the PPPoE configuration for the NRP.
Example 8-28 PPPoE Configuration for the NRP
username cisco password 0 cisco
!
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
interface ATM0/0/0
no ip address
no ip directed-broadcast
!
interface ATM0/0/0.54 point-to-point
description LAB PPPoE Configuration
pvc 1/54
encapsulation aal5snap
protocol pppoe
!
interface Virtual-Template1
description PPPoE
ip unnumbered Ethernet0/0/0
ip mtu 1492
peer default ip address pool ccnp
ppp authentication chap pap
0732x01.book Page 203 Monday, November 17, 2003 2:49 PM
Scenarios
203
For PPPoE over DSL, the DSL CPE is also configured for pure RFC 1483 bridging, as shown
in Example 8-29.
Example 8-29 RFC 1483 Bridging Configuration for the Cisco 827
hostname lab-827D
!
ip subnet-zero
no ip routing
!
interface Ethernet0
no ip address
no ip directed-broadcast
no ip mroute-cache
bridge-group 1
!
interface atm0
mac-address 0001.96a4.8fae
ip address 10.1.121.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 1/52
encapsulation aal5snap
!
bundle-enable
bridge-group 1
hold-queue 224 in
!
ip classless
no ip http server
!
bridge 1 protocol ieee
When a PPP connection is made, a virtual interface is created, as shown in Example 8-30. The
connection is authenticated with PAP/CHAP (using username “cisco” and password “cisco”).
IP addresses are negotiated and handed out from the address pool named ccnp.
Example 8-30 Verifying the Virtual Interface
lab-6400NRP#show int Virtual-Access3
Virtual-Access3 is up, line protocol is up
Hardware is Virtual Access interface
Description: PPPoE
Interface is unnumbered. Using address of Ethernet0/0/0 (10.1.1.190)
MTU 1492 bytes, BW 100000 Kbit, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
LCP Open
Open: IPCP
continues
0732x01.book Page 204 Monday, November 17, 2003 2:49 PM
204
Chapter 8: Using DSL to Access a Central Site
Example 8-30 Verifying the Virtual Interface (Continued)
Bound to ATM0/0/0.54 VCD: 4, VPI: 1, VCI: 54
Cloned from virtual-template: 1
Last input 00:00:04, output never, output hang never
Last clearing of "show interface" counters 00:01:34
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
40 packets input, 2923 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
78 packets output, 6071 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Practical Exercise 8-1: PPPoA over DSL
In this practical exercise, both lab-827A and lab-827B are connected to the DSLAM, as shown
in Figure 8-13. You need to create two different DSL profiles—premium and standard. Each of
them has a different downstream and upstream speed. Assign a premium DSL profile to lab-827A
and a standard DSL profile to lab-827B. In this exercise, you will configure local authentication.
IP addresses are assigned to the DSL CPEs from the IP pool configured in the Cisco 6400.
Figure 8-13 Practical Exercise: PPPoA over DSL
ATM 1/1
PVC 0/35
ATM 0/1
NLC
ATM 1/0/1
lab-827A
NRP
ATM 3/0/0
ATM 1/2
PVC 1/35
lab-6400
lab-827B
lab-6160
Practical Exercise 8-1 Solution
Examples 8-31 through 8-35 show the PPPoA configurations for the DSL CPEs, Cisco 6160
DSLAM, and Cisco 6400.
0732x01.book Page 205 Monday, November 17, 2003 2:49 PM
Practical Exercise 8-1 Solution
205
Example 8-31 Configuration Output for lab-827A
lab-827A#show running-config
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lab-827A
!
ip subnet-zero
!
interface Ethernet0
no ip address
shutdown
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
dsl power-cutback 0
!
interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 1
ppp chap hostname cisco
ppp chap password 0 cisco
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
!
!
!
call rsvp-sync
!
voice-port 1
!
voice-port 2
!
voice-port 3
!
voice-port 4
!
!
continues
0732x01.book Page 206 Monday, November 17, 2003 2:49 PM
206
Chapter 8: Using DSL to Access a Central Site
Example 8-31 Configuration Output for lab-827A (Continued)
line con 0
stopbits 1
line vty 0 4
login
!
scheduler max-task-time 5000
end
Example 8-32 Configuration Output for lab-827B
lab-827B#show running-config
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname lab-827B
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0
no ip address
shutdown
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
!
interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 1
ppp chap hostname cisco
ppp chap password 0 cisco
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
ip pim bidir-enable
0732x01.book Page 207 Monday, November 17, 2003 2:49 PM
Practical Exercise 8-1 Solution
207
Example 8-32 Configuration Output for lab-827B (Continued)
!
!
!
!
line con 0
stopbits 1
line vty 0 4
login
!
scheduler max-task-time 5000
end
In Example 8-33, two DSL profiles, premium and standard, are defined. As you can see, each
of them is configured with different downstream and upstream speeds.
Example 8-33 Configuration Output for lab-6160
lab-6160#show running-config
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname lab-6160
!
slot 1 ATUC-4FLEXIDMT
slot 10 NI-2-155SM-DS3
!
!
dsl-profile default
!
dsl-profile premium
dmt bitrate maximum fast downstream 8064 upstream 864
dmt bitrate maximum interleaved downstream 0 upstream 0
!
dsl-profile standard
dmt bitrate maximum fast downstream 6400 upstream 640
dmt bitrate maximum interleaved downstream 0 upstream 0
!
network-clock-select 1 ATM0/1
redundancy
ip subnet-zero
!
!
no atm oam intercept end-to-end
atm address 47.0091.8100.0000.0030.96fe.db01.0030.96fe.db01.00
atm router pnni
no aesa embedded-number left-justified
node 1 level 56 lowest
redistribute atm-static
continues
0732x01.book Page 208 Monday, November 17, 2003 2:49 PM
208
Chapter 8: Using DSL to Access a Central Site
Example 8-33 Configuration Output for lab-6160 (Continued)
!
!
!
!
interface ATM0/0
no ip address
atm maxvp-number 0
atm maxvc-number 4096
atm maxvci-bits 12
!
interface Ethernet0/0
no ip address
shutdown
!
interface ATM0/1
no ip address
no atm ilmi-keepalive
!
interface ATM0/2
no ip address
no atm ilmi-keepalive
!
interface ATM0/3
no ip address
no atm ilmi-keepalive
!
interface ATM1/1
no ip address
dsl profile premium
no atm ilmi-keepalive
atm pvc 0 35 interface
!
interface ATM1/2
no ip address
dsl profile standard
no atm ilmi-keepalive
atm pvc 0 35 interface
!
interface ATM1/3
no ip address
no atm ilmi-keepalive
!
interface ATM1/4
no ip address
no atm ilmi-keepalive
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
ATM0/1 1 35
ATM0/1 2 35
0732x01.book Page 209 Monday, November 17, 2003 2:49 PM
Practical Exercise 8-1 Solution
209
Example 8-33 Configuration Output for lab-6160 (Continued)
line con 0
line aux 0
line vty 0 4
!
end
Example 8-34 Configuration Output for lab-6400NSP
lab-6400NSP#show running-config
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname lab-6400NSP
!
facility-alarm intake-temperature major 49
facility-alarm intake-temperature minor 40
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
ip subnet-zero
!
ip cef
!
atm address 47.0091.8100.0000.0050.7359.3581.0050.7359.3581.00
atm router pnni
no aesa embedded-number left-justified
node 1 level 56 lowest
redistribute atm-static
!
interface ATM0/0/0
no ip address
atm maxvp-number 0
!
interface Ethernet0/0/0
no ip address
bridge-group 1
!
interface ATM1/0/0
no ip address
no atm ilmi-keepalive
!
interface ATM1/0/1
no ip address
no atm ilmi-keepalive
!
interface ATM2/0/0
no ip address
no atm ilmi-keepalive
!
continues
0732x01.book Page 210 Monday, November 17, 2003 2:49 PM
210
Chapter 8: Using DSL to Access a Central Site
Example 8-34 Configuration Output for lab-6400NSP (Continued)
interface ATM2/0/1
no ip address
no atm ilmi-keepalive
!
interface ATM3/0/0
no ip address
no atm ilmi-keepalive
atm pvc 1 35 interface
atm pvc 2 35 interface
!
!
!
ip classless
ip http server
ip pim bidir-enable
!
line con 0
line 1 16
line aux 0
line vty 0 4
!
end
ATM1/0/1 1 35
ATM1/0/1 2 35
Example 8-35 Configuration Output for lab-6400NRP
lab-6400NRP#show running-config
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname lab-6400NRP
!
logging rate-limit console 10 except errors
no logging console
!
username cisco password 0 cisco
redundancy
main-cpu
auto-sync standard
no secondary console enable
ip subnet-zero
!
!
!
!
!
!
interface Loopback1
ip address 20.1.1.1 255.255.255.255
!
0732x01.book Page 211 Monday, November 17, 2003 2:49 PM
Practical Exercise 8-1 Solution
Example 8-35 Configuration Output for lab-6400NRP (Continued)
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
hold-queue 500 in
!
interface ATM0/0/0.135 point-to-point
pvc 1/35
encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM0/0/0.235 point-to-point
pvc 2/35
encapsulation aal5mux ppp Virtual-Template1
!
!
interface Ethernet0/0/1
ip address negotiated
!
interface Ethernet0/0/0
no ip address
shutdown
!
interface FastEthernet0/0/0
no ip address
half-duplex
!
interface Virtual-Template1
mtu 1460
ip unnumbered Loopback1
peer default ip address pool ccnp
ppp authentication chap
!
ip local pool ccnp 20.1.1.2 20.1.1.10
ip classless
ip http server
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end
Example 8-36 shows that lab-827A has successfully passed the PPP negotiation and
authentication. An IP address is assigned to the DSL connection.
211
0732x01.book Page 212 Monday, November 17, 2003 2:49 PM
212
Chapter 8: Using DSL to Access a Central Site
Example 8-36 Output of show ip interface brief for lab-827A
lab-827A#show ip interface brief
Interface
IP-Address
Ethernet0
unassigned
ATM0
unassigned
Dialer1
20.1.1.3
Virtual-Access1
unassigned
Virtual-Access2
unassigned
Virtual-Access3
unassigned
OK?
YES
YES
YES
YES
YES
YES
Method
NVRAM
NVRAM
BOOTP
unset
unset
unset
Status
Protocol
administratively down down
up
up
up
up
up
up
up
up
up
up
Example 8-37 shows that lab-827B has successfully passed the PPP negotiation and
authentication. An IP address is assigned to the DSL connection.
Example 8-37 Output of show ip interface brief for lab-827B
lab-827B#show ip interface brief
Interface
IP-Address
Ethernet0
unassigned
ATM0
unassigned
Dialer1
20.1.1.2
Virtual-Access1
unassigned
Virtual-Access2
unassigned
Virtual-Access3
unassigned
OK?
YES
YES
YES
YES
YES
YES
Method
NVRAM
NVRAM
BOOTP
unset
unset
unset
Status
Protocol
administratively down down
up
up
up
up
up
up
up
up
up
up
In Example 8-38, two virtual interfaces are cloned from the virtual template. They are served
as Layer 3 termination for the DSL CPEs—lab-827A and lab-827B. Examples 8-39 and 8-40
show the details of two virtual interfaces.
Example 8-38 Output of show ip interface brief for lab-6400NRP
lab-6400NRP#show ip interface brief
Interface
IP-Address
ATM0/0/0
unassigned
ATM0/0/0.135
unassigned
ATM0/0/0.235
unassigned
Ethernet0/0/1
unassigned
Ethernet0/0/0
unassigned
FastEthernet0/0/0
unassigned
Virtual-Access1
20.1.1.1
Virtual-Template1
20.1.1.1
Virtual-Access2
20.1.1.1
Loopback1
20.1.1.1
OK?
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
Method
NVRAM
unset
unset
NVRAM
NVRAM
NVRAM
TFTP
TFTP
TFTP
NVRAM
Status
Protocol
up
up
up
up
up
up
up
up
administratively down down
up
up
up
up
down
down
up
up
up
up
Example 8-39 Verifying the Virtual Interface for lab-827A
lab-6400NRP#show interface virtual-access1
Virtual-Access1 is up, line protocol is up
Hardware is Virtual Access interface
Interface is unnumbered. Using address of Loopback1 (20.1.1.1)
MTU 1460 bytes, BW 100000 Kbit, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
0732x01.book Page 213 Monday, November 17, 2003 2:49 PM
Practical Exercise 8-1 Solution
Example 8-39 Verifying the Virtual Interface for lab-827A (Continued)
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
LCP Open
Open: IPCP
Bound to ATM0/0/0.135 VCD: 1, VPI: 1, VCI: 35
Cloned from virtual-template: 1
Last input 00:00:03, output never, output hang never
Last clearing of "show interface" counters 00:12:13
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
100 packets input, 1841 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
200 packets output, 49806 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Example 8-40 Verifying the Virtual Interface for lab-827B
lab-6400NRP#show interface virtual-access2
Virtual-Access2 is up, line protocol is up
Hardware is Virtual Access interface
Interface is unnumbered. Using address of Loopback1 (20.1.1.1)
MTU 1460 bytes, BW 100000 Kbit, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 5 seconds on reset
LCP Open
Open: IPCP
Bound to ATM0/0/0.235 VCD: 2, VPI: 2, VCI: 35
Cloned from virtual-template: 1
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters 00:12:51
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
107 packets input, 1499 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
210 packets output, 53645 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
213
0732x01.book Page 214 Monday, November 17, 2003 2:49 PM
214
Chapter 8: Using DSL to Access a Central Site
Example 8-41 displays the DSL profile status for the default profile, premium profile, and
standard profile. Keep in mind that the premium and standard profiles are created in this
exercise. You can use show dsl profile [profile-name] to display a specific profile, all ports
to which the profile is currently attached, and those port settings.
Example 8-41 Output of show dsl profile
lab-6160#show dsl profile
dsl profile default:
Link Traps Enabled: NO
Alarms Enabled: NO
ATM Payload Scrambling: Enabled
DMT profile parameters
Maximum Bitrates:
Interleave Path:
downstream:
640 kb/s,
Fast Path:
downstream:
0 kb/s,
Minimum Bitrates:
Interleave Path:
downstream:
0 kb/s,
Fast Path:
downstream:
0 kb/s,
Margin:
downstream:
6 dB,
Interleaving Delay:
downstream: 16000 usecs,
Check Bytes (FEC):
Interleave Path:
downstream:
16,
Fast Path:
downstream:
0,
R-S Codeword Size:
downstream: auto,
Trellis Coding:
Disabled
Overhead Framing:
Mode 3
Operating Mode:
Automatic
Training Mode:
Quick
Minrate blocking:
Disabled
SNR Monitoring:
Disabled
Power Management Additional Margin:
downstream:
0 dB,
upstream:
upstream:
128 kb/s
0 kb/s
upstream:
0
upstream:
0
upstream:
6
upstream: 16000
upstream:
upstream:
upstream:
kb/s
kb/s
dB
usecs
16
0
auto
upstream:
0 dB
upstream:
upstream:
0 kb/s
864 kb/s
dsl profile premium:
Link Traps Enabled: NO
Alarms Enabled: NO
ATM Payload Scrambling: Enabled
DMT profile parameters
Maximum Bitrates:
Interleave Path:
Fast Path:
Minimum Bitrates:
Interleave Path:
Fast Path:
Margin:
Interleaving Delay:
Check Bytes (FEC):
Interleave Path:
Fast Path:
downstream:
downstream:
0 kb/s,
8064 kb/s,
downstream:
0
downstream:
0
downstream:
6
downstream: 16000
downstream:
downstream:
16,
0,
kb/s,
kb/s,
dB,
usecs,
upstream:
0
upstream:
0
upstream:
6
upstream: 16000
upstream:
upstream:
16
0
kb/s
kb/s
dB
usecs
0732x01.book Page 215 Monday, November 17, 2003 2:49 PM
Practical Exercise 8-1 Solution
215
Example 8-41 Output of show dsl profile (Continued)
R-S Codeword Size:
downstream: auto,
Trellis Coding:
Disabled
Overhead Framing:
Mode 3
Operating Mode:
Automatic
Training Mode:
Quick
Minrate blocking:
Disabled
SNR Monitoring:
Disabled
Power Management Additional Margin:
downstream:
0 dB,
dsl profile standard:
Link Traps Enabled: NO
Alarms Enabled: NO
ATM Payload Scrambling: Enabled
DMT profile parameters
Maximum Bitrates:
Interleave Path:
downstream:
0 kb/s,
Fast Path:
downstream: 6400 kb/s,
Minimum Bitrates:
Interleave Path:
downstream:
0 kb/s,
Fast Path:
downstream:
0 kb/s,
Margin:
downstream:
6 dB,
Interleaving Delay:
downstream: 16000 usecs,
Check Bytes (FEC):
Interleave Path:
downstream:
16,
Fast Path:
downstream:
0,
R-S Codeword Size:
downstream: auto,
Trellis Coding:
Disabled
Overhead Framing:
Mode 3
Operating Mode:
Automatic
Training Mode:
Quick
Minrate blocking:
Disabled
SNR Monitoring:
Disabled
Power Management Additional Margin:
downstream:
0 dB,
upstream:
auto
upstream:
0 dB
upstream:
upstream:
0 kb/s
640 kb/s
upstream:
0
upstream:
0
upstream:
6
upstream: 16000
upstream:
upstream:
upstream:
kb/s
kb/s
dB
usecs
upstream:
16
0
auto
0 dB
lab-827A is patched to port 1/1, and lab-827B is patched to port 1/2. Example 8-42 displays the
status of the DSL subscriber ports on a 6160 chassis.
Example 8-42 Using the show dsl status Command to Display the Status of DSL Ports
lab-6160#show dsl status
Subtend Node ID: 0
NAME
---ATM1/1
ATM1/2
ATM1/3
ATM1/4
ADMIN/OPER
---------UP/ UP
UP/ UP
UP/DOWN
UP/DOWN
DOWNSTREAM
(Kb)
-------8064
6400
0
0
UPSTREAM
(Kb)
-------864
640
0
0
SUBSCRIBER
(truncated)
-----------
CIRCUIT ID
(truncated)
-----------
0732x01.book Page 216 Monday, November 17, 2003 2:49 PM
216
Chapter 8: Using DSL to Access a Central Site
The show dsl interface atm slot#/port# command allows you to display DSL, DMT, and ATM
status for a port, as shown in Example 8-43.
Example 8-43 Displaying DSL, DMT, and ATM Status for Port 1/1
lab-6160#show dsl interface atm 1/1
Port Status:
Subscriber Name:
Circuit ID:
IOS admin: UP
oper: UP
Card status: ATUC-4FLEXIDMT
Last Change: 00 days, 00 hrs, 50 min, 28 sec No. of changes: 12
Line Status: TRAINED
Test Mode: NONE
ADSL Chipset Self-Test: NONE
CO Modem Firmware Version: 5.38
Configured:
DMT Profile Name: premium
Link Traps Enabled: NO
Alarms Enabled: NO
ATM Payload Scrambling: Enabled
DMT profile parameters
Maximum Bitrates:
Interleave Path:
downstream:
0 kb/s,
Fast Path:
downstream: 8064 kb/s,
Minimum Bitrates:
Interleave Path:
downstream:
0 kb/s,
Fast Path:
downstream:
0 kb/s,
Margin:
downstream:
6 dB,
Interleaving Delay:
downstream: 16000 usecs,
Check Bytes (FEC):
Interleave Path:
downstream:
16,
Fast Path:
downstream:
0,
R-S Codeword Size:
downstream: auto,
Trellis Coding:
Disabled
Overhead Framing:
Mode 3
Operating Mode:
Automatic
Training Mode:
Quick
Minrate blocking:
Disabled
SNR Monitoring:
Disabled
Power Management Additional Margin:
downstream:
0 dB,
Status:
Bitrates:
Interleave Path:
downstream:
0 kb/s,
Fast Path:
downstream: 8064 kb/s,
Attainable Aggregate
Bitrates:
downstream: 9440 kb/s,
Margin:
downstream:
12 dB,
Attenuation:
downstream:
1 dB,
Interleave Delay:
downstream:
0 usecs,
Transmit Power:
downstream:
9.5 dB,
upstream:
upstream:
0 kb/s
864 kb/s
upstream:
0
upstream:
0
upstream:
6
upstream: 16000
upstream:
upstream:
upstream:
kb/s
kb/s
dB
usecs
16
0
auto
upstream:
0 dB
upstream:
upstream:
0 kb/s
864 kb/s
upstream:
928 kb/s
upstream:
11 dB
upstream:
2 dB
upstream:
0 usecs
upstream: 12.1 dB
0732x01.book Page 217 Monday, November 17, 2003 2:49 PM
Practical Exercise 8-2 Solution
217
Example 8-43 Displaying DSL, DMT, and ATM Status for Port 1/1 (Continued)
Check Bytes (FEC):
Interleave Path:
downstream:
0,
Fast Path:
downstream:
0,
R-S Codeword Size:
downstream:
1,
Trellis Coding:
In Use
Overhead Framing:
Mode 3
Line Fault:
NONE
Operating Mode:
ITU G dmt Issue 1
Line Type:
Fast Only
Alarms:
status:
NONE
ATM Statistics:
Interleaved-Path Counters:
Cells:
downstream:
20
HEC errors:
downstream:
0
LOCD events:
near end:
1
Fast-Path Counters:
Cells:
downstream:
1729
HEC errors:
downstream:
1
LOCD events:
near end:
1
DSL Statistics:
Init Events:
4
Far End LPR Events:
0
Transmitted Superframes: near end:
161749170
Received Superframes:
near end:
161748691
Corrected Superframes:
near end:
176
Uncorrected Superframes: near end:
369
LOS Events:
near end:
2
LOF/RFI Events:
near end:
0
ES Events:
near end:
10
CPE Info:
Version Number:
0
Vendor ID:
34
upstream:
upstream:
upstream:
0
0
1
upstream:
upstream:
far end:
154
2
0
upstream:
upstream:
far end:
660
1
0
far
far
far
far
far
far
far
end:
end:
end:
end:
end:
end:
end:
0
0
0
1
0
0
1
Practical Exercise 8-2: RFC 1483 Bridging over DSL
In this practical exercise, lab-827A and lab-827B are connected to the DSLAM and will be
configured using RFC 1483 bridging, as shown in Figure 8-13. DSLAM and NSP configuration
remain the same as in the previous exercise. For this exercise, you will assign the ATM interface
of the CPEs and subinterfaces of the NRP to Bridge group 1. You will see the configuration
output as well as some useful commands to verify the bridging configuration.
Practical Exercise 8-2 Solution
Examples 8-44 and 8-45 show the bridging configurations of both DSL CPE devices.
0732x01.book Page 218 Monday, November 17, 2003 2:49 PM
218
Chapter 8: Using DSL to Access a Central Site
Example 8-44 Configuration Output for lab-827A
lab-827A#show running-config
Building configuration...
Current configuration : 763 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lab-827A
!
ip subnet-zero
no ip routing
!
interface Ethernet0
ip address 10.2.2.2 255.255.255.0
no ip route-cache
bridge-group 1
hold-queue 100 out
!
interface ATM0
mac-address 0001.96a4.84ac
ip address 10.2.2.2 255.255.255.0
no ip route-cache
no atm ilmi-keepalive
pvc 0/35
encapsulation aal5snap
!
dsl operating-mode auto
dsl power-cutback 0
bridge-group 1
!
ip classless
ip http server
!
bridge 1 protocol ieee
call rsvp-sync
!
line con 0
stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end
0732x01.book Page 219 Monday, November 17, 2003 2:49 PM
Practical Exercise 8-2 Solution
Example 8-45 Configuration Output for lab-827B
lab-827B#show running-config
Building configuration...
Current configuration : 670 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname lab-827B
!
no logging console
!
ip subnet-zero
no ip routing
!
interface Ethernet0
ip address 10.2.2.3 255.255.255.0
no ip route-cache
bridge-group 1
hold-queue 100 out
!
interface ATM0
mac-address 0001.96a4.8fae
ip address 10.2.2.3 255.255.255.0
no ip route-cache
no atm ilmi-keepalive
pvc 0/35
encapsulation aal5snap
!
dsl operating-mode auto
bridge-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
bridge 1 protocol ieee
!
line con 0
stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end
Example 8-46 shows the bridging configuration of the Cisco 6400.
219
0732x01.book Page 220 Monday, November 17, 2003 2:49 PM
220
Chapter 8: Using DSL to Access a Central Site
Example 8-46 Configuration Output for lab-6400NRP
lab-6400NRP#show running-config
Building configuration...
Current configuration : 907 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname lab-6400NRP
!
logging rate-limit console 10 except errors
no logging console
!
redundancy
main-cpu
auto-sync standard
no secondary console enable
ip subnet-zero
!
bridge irb
!
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
hold-queue 500 in
!
interface ATM0/0/0.135 point-to-point
pvc 1/35
encapsulation aal5snap
!
bridge-group 1
!
interface ATM0/0/0.235 point-to-point
pvc 2/35
encapsulation aal5snap
!
bridge-group 1
!
interface Ethernet0/0/1
ip address negotiated
!
interface Ethernet0/0/0
no ip address
shutdown
!
interface FastEthernet0/0/0
no ip address
half-duplex
!
0732x01.book Page 221 Monday, November 17, 2003 2:49 PM
Practical Exercise 8-2 Solution
Example 8-46 Configuration Output for lab-6400NRP (Continued)
interface BVI1
ip address 10.2.2.1 255.255.255.0
!
ip classless
ip http server
!
!
!
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
line aux 0
line vty 0 4
!
end
Example 8-47 shows that Bridge group 1 is running the IEEE Spanning Tree Protocol.
Example 8-47 Displaying the Spanning Tree Protocol (IEEE)
lab-6400NRP#show spanning-tree 1
Bridge group 1 is executing the ieee compatible Spanning Tree protocol
Bridge Identifier has priority 32768, address 0000.0c7f.70fc
Configured hello time 2, max age 20, forward delay 15
We are the root of the spanning tree
Topology change flag not set, detected flag not set
Number of topology changes 4 last change occurred 00:35:16 ago
from ATM0/0/0.235
Times: hold 1, topology change 35, notification 2
hello 2, max age 20, forward delay 15
Timers: hello 0, topology change 0, notification 0, aging 300
Port 6 (ATM0/0/0.135) of Bridge group 1 is forwarding
Port path cost 14, Port priority 128, Port Identifier 128.6.
Designated root has priority 32768, address 0000.0c7f.70fc
Designated bridge has priority 32768, address 0000.0c7f.70fc
Designated port id is 128.6, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
BPDU: sent 1663, received 2
Port 8 (ATM0/0/0.235) of Bridge group 1 is forwarding
Port path cost 14, Port priority 128, Port Identifier 128.8.
Designated root has priority 32768, address 0000.0c7f.70fc
Designated bridge has priority 32768, address 0000.0c7f.70fc
Designated port id is 128.8, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
BPDU: sent 1527, received 1
Example 8-48 shows the IP and MAC addresses of lab-827A and lab-827B. show arp is a
useful command to verify whether bridging is configured properly.
221
0732x01.book Page 222 Monday, November 17, 2003 2:49 PM
222
Chapter 8: Using DSL to Access a Central Site
Example 8-48 Displaying ARP Information
lab-6400NRP#show arp
Protocol Address
Internet 10.2.2.2
Internet 10.2.2.3
Internet 10.2.2.1
Age (min)
31
31
-
Hardware Addr
0001.96a4.84ac
0001.96a4.8fae
0050.7359.35a6
Type
ARPA
ARPA
ARPA
Interface
BVI1
BVI1
BVI1
Example 8-49 illustrates that both subinterfaces are in the same bridge group (Bridge group 1),
and traffic is passed among them. show bridge is another useful command to debug RFC 1483
bridging.
Example 8-49 Displaying Classes of Entries in the Bridge Forwarding Database
lab-6400NRP#show bridge verbose
Total of 300 station blocks, 298 free
Codes: P - permanent, S - self
BG Hash
Address
Action Interface
VC
1 21/0
0001.96a4.8fae forward ATM0/0/0.235
2
1 28/0
0001.96a4.84ac forward ATM0/0/0.135
1
Flood ports (BG 1)
RX count
TX count
ATM0/0/0.135
0
0
ATM0/0/0.235
0
0
Age
0
0
RX count
5
100
TX count
5
100
Summary
This chapter covered ADSL technology, Cisco DSL hardware components, and the
configuration of various DSL access architectures, such as IRB, RBE, PPPoA, and PPPoE. Keep
in mind that each DSL access architecture has its advantages and disadvantages. You should
further research these architectures to discover the best implementation for your DSL network
environment.
Table 8-3 summarizes the commands used in this chapter.
Table 8-3
Summary of Commands Used in This Chapter
Command
Description
slot slot# cardtype
Configures a slot for a specific card type.
dsl-profile profile-name
Creates a DSL profile.
dmt bitrate max interleaved downstream
dmt-bitrate upstream dmt-bitrate
Sets the maximum and minimum allowed bit
rates for the fast-path and interleaved-path
profile parameters.
dmt margin downstream dmt-margin
upstream dmt-margin
Sets the upstream and downstream SNR DMT
margins.
dmt check-bytes interleaved downstream
bytes upstream bytes
Sets the upstream and downstream check bytes.
0732x01.book Page 223 Monday, November 17, 2003 2:49 PM
Summary
Table 8-3
223
Summary of Commands Used in This Chapter (Continued)
Command
Description
dmt interleaving-delay downstream
delay-in-µsecs upstream delay-in-µsecs
Sets the interleaving delay parameter.
dmt training-mode {standard | quick}
Sets the training mode in a DMT profile.
bridge irb
Enables IRB.
bridge bridge-group protocol {ieee | dec}
Specifies the bridge protocol to define the type
of Spanning Tree Protocol.
bridge bridge-group route protocol
Specifies a protocol to be routed in a bridge group.
bridge-group bridge-group
Assigns a network interface to a bridge group.
interface bvi bridge-group
Enables a bridge group virtual interface.
atm route-bridged ip
RBE command. Typically used to associate with
an interface.
username name password secret
Configures a username and password for local
authentication.
encapsulation aal5mux ppp VirtualTemplate number
Configures PPPoA encapsulation and associates
a virtual template with it.
interface virtual-template number
Creates a virtual template interface.
ip unnumbered interface-name-number
Conserves IP addresses by configuring the
interface as unnumbered, and assigns the IP
address of the interface type you want to leverage.
ip local pool name begin-ip-address-range
[end-ip-address-range]
Creates the local IP address pool.
peer default ip address pool poolname
Specifies the pool for the interface to use.
ppp authentication {chap | pap | chap pap |
pap chap} [if-needed] {default | list-name}
[callin]
Enables CHAP or PAP authentication on the
interface.
ip cef
Enables Cisco Express Forwarding switching.
vpdn enable
Enables VPDN configuration.
vpdn-group number
Configures a VPDN group to accept the dial-in
and to be used to establish PPPoE sessions.
Specifies the virtual template that will be used to
clone virtual-access interfaces.
accept-dialin
protocol pppoe
virtual-template template-number
ip mtu bytes
Sets the MTU size of IP packets sent on an
interface.
show dsl profile
Displays the DSL profile you changed.
continues
0732x01.book Page 224 Monday, November 17, 2003 2:49 PM
224
Chapter 8: Using DSL to Access a Central Site
Table 8-3
Summary of Commands Used in This Chapter (Continued)
Command
Description
show dsl status
Displays the status of the DSL subscriber ports
on a chassis.
show dsl interface atm slot/port
Shows the status of a DSL port.
show spanning-tree bridge-group
Displays information on which Spanning Tree
Protocol is running.
show arp
Displays the entries in the ARP table.
show bridge group [verbose]
Displays the status of each bridge group in detail.
Review Questions
1
Which of the following modulation methods is not used for ADSL technology?
A. CAP
B. 2B1Q
C. DMT-2
D. G.lite
2
RFC 1483 when implemented is __________.
A. Bridged
B. Routed
C. Decrypted
D. Encrypted
3
PPPoA when implemented is __________.
A. Bridged
B. Routed
C. Decrypted
D. Encrypted
4
Which of the following interferences degrades DSL services?
A. Impedance changes
B. Bridged taps
C. Crosstalk
D. Impulse hits
E. All of the above
0732x01.book Page 225 Monday, November 17, 2003 2:49 PM
Review Questions
5
What is the function of the POTS splitter?
A. It separates low and high frequencies.
B. It manages ADSL signaling.
C. It generates ringing voltage.
D. It boosts the ADSL signal.
6
The DSL interface on a Cisco 827 is __________.
A. An FDDI interface
B. A Frame Relay interface
C. A serial interface
D. An ATM interface
7
With PPP over ATM, __________. (Choose all that apply.)
A. MAC frames are encapsulated into ATM cells
B. UDP frames are encapsulated using RFC 1483
C. IP packets are encapsulated into PPP frames and then into ATM cells
D. IP packets are encrypted
8
With RFC 1483 bridging, __________.
A. MAC frames are passed across the bridge after LLC/SNAP information is appended
B. IP frames are passed across the bridge unchanged
C. MAC frames are passed across the bridge unchanged
D. IP packets are encrypted
9
Which of the following cards in the Cisco 6400 can be used for Layer 3 packet services?
A. NSP
B. NLC
C. NRP
D. NI-2
10
Which of the following is part of PPPoA configuration?
A. encapsulation aal5mux ppp Virtual-Template 1
B. encapsulation aal5snap
C. atm route-bridged ip
D. bridge 1 protocol ieee
225