Yamaha | Studio Manager v.2 | Yamaha Studio Manager

STUDIO MANAGER
Owner’s Manual
Special Notices
• Studio Manager and this owner’s manual are exclusively copyright © by Yamaha Corporation.
• Duplication of the software or reproduction of this manual in whole or in part by any means is expressly forbidden without the written consent of the manufacturer.
• Duplication of the commercially available music sequence data and/or digital audio files is strictly prohibited,
except for your personal use.
• Yamaha makes no representations or warranties with regard to the use of the software and documentation and
cannot be held responsible for the results of using of this manual and software.
• This disc is a CD-ROM. Do not attempt to play the disc on an audio CD player. Doing so may result in irreparable
damage to your audio CD player.
• The screen displays as illustrated in this owner’s manual are for instructional purposes and may appear somewhat
different from the screens that appear on your computer.
• Future upgrades of application or system software and any changes to the specifications or functions will be
announced separately.
• All other trademarks are the property of their respective holders and are hereby acknowledged.
❏ Yamaha Pro Audio global site
❏ Yamaha synth.com
http://www.yamahaproaudio.com/
http://www.yamahasynth.com
Table of Contents
Mapping MIDI Ports . . . . . . . . . . . . . . . . . . . . . 5
Setting Preferences . . . . . . . . . . . . . . . . . . . . . . 6
Menu Bar/Pop-up Menu . . . . . . . . . . . . . . . . . . 6
Operation within Cubase SX. . . . . . . . . . . . . . . 8
Supported editors . . . . . . . . . . . . . . . . . . . . . . . 9
Overview of Studio Manager . . . . . . . . . . . . . . 2
Starting and Configuring Studio Manager . . . 3
Quitting Studio Manager . . . . . . . . . . . . . . . . . 4
Synchronizing Studio Manager . . . . . . . . . . . . 4
Working with Files. . . . . . . . . . . . . . . . . . . . . . . 5
* Specifications and descriptions in this owner’s manual are for information purposes only. Yamaha Corp. reserves
the right to change or modify products or specifications at any time without prior notice. Since specifications,
equipment or options may not be the same in every locale, please check with your Yamaha dealer.
Description of menus and buttons
In the event that menu and button names on a Windows system are different from those on a Macintosh,
this manual uses the Windows menu and button names followed by the Macintosh menu and button names
in parentheses.
1
Studio Manager Version 2 Owner’s Manual
Overview of Studio Manager
Studio Manager is a cross-platform application that enables you to start multiple Editors that control YAMAHA
hardware products remotely, and to save multiple Editor settings.
You can run Studio Manager as a stand-alone application, or as a plug-in within DAW applications that are compatible with Total Recall, such as Cubase SX 3.0 or later. In either case, the basic functionality is the same. For the latest
information on compatible DAW applications, refer to the following website.
http://www.studioconnections.org/
Hardware products
Open an editor from
Studio Manager
Synchronize
DM2000
DM2000 Editor
Synchronize
MOTIF ES6/7/8
Studio Manager
Start up Studio
Manager in
stand-alone form
Open from a
compatible DAW
application
MOTIF ES6/7/8 Multi Part Editor
Synchronize
SPX2000
SPX2000 Editor
The settings of each editor can be saved and recalled together from Studio Manager or the DAW application. In other
words, you can change the settings of your entire system in a single operation by recalling the settings for multiple
devices from Studio Manager or your DAW application. This capability is referred to as “total recall.”
When you want to save setting files, you can do this from Studio Manager to recall multiple devices at once, or from
an individual Editor to recall only a specific device. When you save your settings in your DAW application, the Studio
Manager settings will also be saved together with the DAW application file, and can also be recalled in the same way.
To use Studio Manager, you must first perform the following operations:
1. Start and configure Studio Manager (see page 3).
2. Start and configure an Editor.
3. Synchronize the application with the corresponding device (see page 4).
For more information on using the Editors, refer to the Owner’s Manual for the Editors.
2
Studio Manager Version 2 Owner’s Manual
Starting and Configuring Studio Manager
1 Start Studio Manager.
As a stand-alone application in Windows 2000/XP: Click the Start button, move the cursor to [Programs
(All Programs)], then [Yamaha Studio Manager], then click [Studio Manager].
As a stand-alone application in Mac OS X: Select and open the “Applications” folder, the “YAMAHA”
folder, then the “Studio Manager” folder, then double-click “SM2.”
With Cubase SX: From Cubase SX’s [Device] menu, choose [Yamaha Studio Manager] to open the Studio
Manager window. (Studio Manager starts running when Cubase SX is started.)
2 Select the devices you want to edit.
In the Setup window, open the Modify Workspace page. The Device Editor
section lists the names of the installed devices.
Select the desired device, then click the [Add->] button.
The selected device name appears in the Workspace section.
NOTE: Use the following buttons, if necessary:
[Remove]............. Removes the selected device from the Workspace section.
[Set Default]........ Click this button while devices to edit are listed in the
Workspace section, so that the next time you start Studio
Manager, the devices will be automatically selected.
[Recall Default] ... Recalls the default setting you made using the [Set
Default] button.
3 Specify the desired MIDI ports.
Select the [MIDI Ports] tab and specify the MIDI In/Out Ports to which the
devices are connected. However if you want to use Studio Manager in Cubase
SX, you’ll need to specify that MIDI port within Cubase SX.
NOTE: To activate MIDI ports in Studio Manager, you must specify the MIDI
ports in this MIDI Ports tab and in the Editor for the console or device.
4 Click [OK].
The Setup window closes and the Studio Manager window becomes active.
5 Double-click the icon for the console or
device you want to edit to open its Editor.
NOTE: Right-clicking the mouse in the window will
display a pop-up menu (see page 7).
NOTE: To change the icon name, select the icon, then
click the name.
Studio Manager window
3
Studio Manager Version 2 Owner’s Manual
Quitting Studio Manager
Select [Exit] from the [File] menu in the Studio Manager window (select [Quit SM2] from the [SM2] menu). If there
are no unsaved changes, all windows close and Studio Manager quits. If there are unsaved changes, a message asking
whether you want to save the changes appears. You can also quit Studio Manager by clicking the Close button in the
Studio Manager window.
If you’re using Studio Manager in your DAW application, quitting your DAW application will also quit Studio Manager. Simply closing the Studio Manager window does not quit Studio Manager. When you save your DAW application file, the Studio Manager settings are also saved within that file.
Synchronizing Studio Manager
In some cases, such as when Studio Manager starts up for the first time, the parameter settings on the devices and the
parameter settings in Studio Manager (in the devices’ Editor) may be different. Therefore, you must first synchronize
the parameter settings on the devices with those in Studio Manager (in the corresponding Editors). Follow the steps
below to synchronize Studio Manager with the devices.
NOTE: You can also synchronize the parameter settings with the corresponding devices in each Editor.
For information on using the Editors, refer to the Owner’s Manual for the Editors.
1 Select [Synchronize], then [Total Recall...] in the Studio Manager window.
The following window opens.
2 Select whether you want to transfer your settings to Studio Manager (each Editor), or
vice versa.
[To Hardware]: Transfers the current settings from Studio Manager (each Editor) to your console or device.
[From Hardware]: Transfers the settings from your console or device to Studio Manager (Editor).
3 Click [OK].
The synchronizing process begins.
Do not operate the device while synchronization is in progress.
4
Studio Manager Version 2 Owner’s Manual
Working with Files
You can save the various parameter setting files either as a complete set using Studio Manager or your DAW application, or individually using each Editor. The following table shows how to manage your setting files.
Creating a new file
Choose [New] from the [File] menu.
(only if Studio Manager is running as stand-alone)
Opening a previously saved file
Choose [Open (Import)] from the [File] menu.
Saving the current file
Choose [Save] from the [File] menu.
(only if Studio Manager is running as stand-alone)
Saving the current file with a new name
Choose [Save As... (Export)] from the [File] menu.
If you save a file in the Studio Manager window, all selected Editor settings are saved in a file with a file extension of
“.YSM”. If the “Automatically synchronize on file load” preference is turned on, opening a file will recall the entire set
of system settings (Total Recall function).
If you’re using Studio Manager with your DAW application, the settings of all selected Editors will be saved together
within the file of the DAW application. If desired, you can also save files from Studio Manager, and then open them
from Studio Manager running as a stand-alone application.
If you save a file in an Editor, only that Editor’s settings are saved in a file.
NOTE: When you create a new file, or open a previously saved file, a message appears asking whether you want
to save the currently-open file. Click [Yes] to save the current file and open another. Click [No] to open another
without saving the current one. Click [Cancel] to cancel the operation.
Mapping MIDI Ports
If MIDI ports specified in Editors are not
enabled on the computer (e.g., when you open a
file on another computer), it’s convenient to
change all MIDI port settings together in the Remap MIDI Ports window (shown on the right).
Choose [Re-map MIDI Ports] from the [File]
menu to display the window.
NOTE: This function is not available if you’re
using Studio Manager in your DAW
application.
❏ Workspace
This column lists the MIDI ports specified in
Editors by the corresponding device names
and [port names].
❏ System
This column lists the MIDI ports enabled on the computer. If the ports listed in the Workspace column and the
ports listed in the System column do not match, click the port name in the System column to display a pull-down
menu, then select a matching port from the menu.
5
Studio Manager Version 2 Owner’s Manual
Setting Preferences
You can also change the preference settings, if necessary. Choose [Setup...] from
the [File] menu, then click the [Preferences] tab to display the window shown
on the right.
Automatically synchronize on file
load: When you open a file in the Studio Manager window or open a file of
your DAW application, Studio Manager (Editors) will automatically synchronize with the corresponding
device. In this way, Studio Manager
performs the Total Recall function to
recall the entire system settings automatically when you open a file.
Menu Bar/Pop-up Menu
Menu Bar
❏ File Menu
New* (Ctrl+N /
+N)
Creates a new file.
Open (Ctrl+O/ +O)
Import (Ctrl+I/ +I)
Opens a previously saved file.
Save* (Ctrl+S / +S)
Saves the current file.
Save As
Export (Ctrl+E/ +E)
Saves the current file with a different name.
Setup
Open the Setup window to configure Studio Manager. Click a tab at the top
of the window to select the Modify Workspace page (see page 3), MIDI Ports
page (see page 3), or Preferences page (see page 6). On a Macintosh computer, choose [Preferences] from the [SM2] menu.
Re-map MIDI Ports*
Opens the Re-map MIDI Ports window (see page 5).
Exit* (Ctrl+Q)
Quits Studio Manager. On a Macintosh computer, choose [Quit SM2] from
the [SM2] menu.
* If you’re using Studio Manager with your DAW application, these menu items will not appear.
❏ Synchronize Menu
Total Recall
Synchronizes Studio Manager (Editors) with the corresponding devices
(see page 4).
6
Studio Manager Version 2 Owner’s Manual
❏ Windows Menu
Lists the Editors for which a window is currently open. When you select an Editor, the corresponding Editor window becomes active.
❏ Help Menu
Manual (F1)
Displays this manual in Adobe PDF format.
About YAMAHA Studio
Manager
Displays the information (such as a version number) of Studio Manager. On a
Macintosh computer, choose [About YAMAHA Studio Manager] from the
[SM2] menu.
Pop-up Menu
Right-click the mouse on an icon in the Studio Manager window (on a Macintosh computer, click an icon while
holding down the [control] key) to display the following pop-up menu.
Open/Show
Opens/activates the selected Editor.
Close
Closes the selected Editor.
Synchronize
Synchronizes with the corresponding device.
Total Recall Enabled
Specifies whether the Total Recall function will be performed for the corresponding device. If this check box is checked, Studio Manager will perform
the Total Recall function for the corresponding device and the indicator
located in the upper right corner of the corresponding icon will light up.
Configure Total Recall
If the corresponding device is selected for the Total Recall function, you can
specify the data items to be synchronized using this sub-menu. The submenu contents vary with the Editor. Some Editors enable you to select only
a single data item, and some enable you to select multiple data items.
Remove
Deletes the selected icon from the Studio Manager window.
Right-click the mouse anywhere except on any icon in the Studio Manager window (on a Macintosh computer, click
anywhere except on any icon while holding down the [control] key) to display the following pop-up menu.
Modify Workspace
Opens the Modify Workspace page in the Setup window (see page 3).
Arrange by Name
Check this to sort the icons by name.
Left to Right
Check this to position icons from left to right.
Top to Bottom
Check this to position icons from top to bottom.
7
Studio Manager Version 2 Owner’s Manual
Operation within Cubase SX
If you’re using Studio Manager in Cubase SX 3.0 or later. you can also control the various Editors from within
Cubase SX as follows.
Virtual MIDI port display
The MIDI port used by an Editor selected in Studio Manager is shown within Cubase SX as the MIDI port for that
device name. You can assign this port to a MIDI track.
Starting an Editor from Cubase SX
If you’ve assigned a virtual MIDI port to a MIDI track, you can directly open the Editor by clicking the [VST Instruments Settings] button in the inspector, just as if you were opening the control panel of a VST instrument.
8
Studio Manager Version 2 Owner’s Manual
Supported editors
Editors that can be opened from Studio Manager must support Open Plug-in Technology (subsequently abbreviated
as OPT) version 2. As of this date (September 2004), the following editors are OPT2-compatible.
❏ OPT2 compatible editors
•
•
•
•
•
•
•
•
DM2000 Editor
02R96 Editor
DM1000 Editor
01V96 Editor
SPX2000 Editor
MOTIF ES6/7/8 Multi Part Editor
MOTIF ES6/7/8 Voice Editor
01X Editor
Some OPT-compatible editors can also be opened from Studio Manager, but there are some limitations (see below)
on the functionality.
❏ OPT compatible editors that also support Studio Manager
•
•
•
•
•
•
•
•
Voice Editor for MOTIF6/7/8
Voice Editor for S90
Voice Editor for S08
VL Visual Editor
DX Simulator
AN Expert Editor
Plug-in Board Editor for PLG150-DR
Plug-in Board Editor for PLG150-PC
For the latest information on supported editors, refer to the following website.
http://www.studioconnections.org/
❏ Limitations on functionality
• Not supported by the Macintosh version.
• When saving all settings together from Studio Manager or a DAW application, only some settings will be saved;
this means that Total Recall is not supported.
• Cubase SX’s virtual MIDI port display (see page 8) is not supported.
• The editor cannot be opened directly from Cubase SX (see page 8)
• You will need to go to Cubase SX’s [Device] menu → [Device Settings], and make settings in “Yamaha Studio
Manager” to specify the MIDI ports you want to use.
About Open Plug-in Technology
Open Plug-in Technology (OPT) is a new software format that enables you to control MIDI devices from a music
DAW application software. For example, this allows you to start up and operate various parts of your music system,
such as plug-in board editors, and mixing control editors - directly from an OPT-compatible sequencer, without
having to use each separately. OPT also makes it unnecessary to set MIDI drivers for each application, streamlining
your music production system and making all operations more convenient and seamless.
In addition to the original OPT, there is also Open Plug-in Technology Version 2 (OPT2), designed for use with the
Total Recall software. Studio Manager is a host application that supports OPT 2.
9
Studio Manager Version 2 Owner’s Manual
❏ About the OPT Levels and Overview
The host application and its compatibility with OPT is divided into three levels, as shown below.
Level 1: OPT Panels provides basic support for opening and displaying OPT control panels that can
transmit data via the client’s external MIDI ports. Typically this will allow basic hardware editor control panels to operate properly.
Level 2: OPT Processors provides support for real-time MIDI processors and panel automation.
Typically this will allow both real-time and offline MIDI effects to operate properly and supply automation to OPT panels.
Level 3: OPT Views provides support for edit views and MIDI processors/panels that require direct
access to client program storage structures. Typically this will allow sophisticated MIDI edit views to
be supported.
OPT-compatible plug-in software is connected directly to an OPT-compatible
Editor
host application.
Host Application
OPT
Editor
Editor
❏ About the OPT2 Overview
Host Application
OPT2 is a plug-in format that enhances OPT Level 1 (Panels) and adds some convenient functions
for use with Total Recall. In addition to doing Total Recall functions using the Studio Manager as a
host application, you can use Total Recall in a DAW application (provided it is compatible with Total
Recall), via the Studio Manager.
Plug-in software compatible with OPT2 is indirectly connected
Editor
to the DAW application compatible with Total Recall, via the
OPT2
Studio Manager.
Studio
Manager
Editor
Editor
❏ Editors and host application support
Plug-in software
(editors)
OPT-compatible host
applications
(e.g., SQ01)
OPT2-compatible editors
(see page 9)
√
Some OPT2 compatible editors
MOTIF ES6/7/8 Multi Part Editor
MOTIF ES6/7/8 Voice Editor
01X Editor
etc.
√
OPT-compatible editors
√
Some OPT-compatible editors
(see page 9)
OPT2-compatible host
applications
(e.g., Studio Manager)
√
√
√
Supported only in Windows;
functionality is restricted
(see page 9)
For the latest information on Total Recall support, refer to the following website.
http://www.studioconnections.org/
U.R.G., Pro Audio & Digital Musical Instrument Division, Yamaha Corporation
© 2004 Yamaha Corporation
408IP-01B0
10
Studio Manager Version 2 Owner’s Manual
Download PDF