FileMaker Installation und neue Funktionen ®

FileMaker Installation und neue Funktionen ®
FileMaker
®
Installation und neue Funktionen
für FileMaker Pro 10 und FileMaker Pro 10 Advanced
© 2007-2009 FileMaker, Inc. Alle Rechte vorbehalten.
FileMaker, Inc.
5201 Patrick Henry Drive
Santa Clara, California 95054, USA
FileMaker, das Dateiordner-Logo, Bento und das Bento-Logo sind in den USA und anderen Ländern Marken
von FileMaker, Inc. Mac und das Mac-Logo sind Eigentum von Apple Inc., in den USA und anderen Ländern
eingetragen. Alle anderen Marken sind Eigentum der jeweiligen Inhaber.
Die FileMaker-Dokumentation ist urheberrechtlich geschützt. Sie dürfen diese Dokumentation ohne
schriftliche Genehmigung von FileMaker weder vervielfältigen noch verteilen. Diese Dokumentation darf
ausschließlich mit einer gültigen, lizenzierten Kopie der FileMaker-Software verwendet werden.
Alle in den Beispielen erwähnten Personen, Firmen, E-Mail-Adressen und URLs sind rein fiktiv und jegliche
Ähnlichkeit mit bestehenden Personen, Firmen, E-Mail-Adressen und URLs ist rein zufällig. Die
Danksagungen und Urheberrechtshinweise finden Sie im entsprechenden Dokument, das mit der Software
geliefert wurde. Die Erwähnung von Produkten und URLs Dritter dient nur zur Information und stellt keine
Empfehlung dar. FileMaker, Inc. übernimmt keine Verantwortung für die Leistung dieser Produkte.
Weitere Informationen finden Sie auf unserer Website unter www.filemaker.de.
Edition: 01
Inhalt
Kapitel 1
Bevor Sie beginnen
5
Über dieses Handbuch
Kundensupport und Produktinformationen
Update-Benachrichtigung
Über den Lizenzschlüssel
Hardware- und Software-Anforderungen
Anforderungen für Windows
Anforderungen für Mac OS
Netzwerkanforderungen
Anforderungen für Web-Publishing
Anforderungen an andere Funktionen unter Windows
Anforderungen an andere Funktionen unter Mac OS
Funktionen, die unter Windows nicht unterstützt werden
Funktionen, die unter Mac OS nicht unterstützt werden
Öffnen von Dateien aus früheren Versionen
Upgrade von FileMaker Pro von einer früheren Version
Aktualisieren des Anwenderwörterbuchs
Installieren unter einer Volumen-Lizenz
5
6
6
7
8
8
8
9
9
10
11
11
11
11
12
12
13
Kapitel 2
Installieren von FileMaker Pro unter Windows
15
Installationshinweise
Installieren von FileMaker Pro
Registrieren von FileMaker Pro
Installieren von FileMaker Pro über die Befehlszeile
Über die Installation von Bonjour
Speicherung von Dateien auf Ihrer Festplatte
Deinstallieren, Ändern oder Wiederherstellen von FileMaker Pro 10
Ändern der Cache-Größe in FileMaker Pro
Die nächsten Schritte
15
16
17
17
18
19
19
20
21
Kapitel 3
Installieren von FileMaker Pro unter Mac OS
23
Installationshinweise
23
4 | Inhalt
Installieren von FileMaker Pro
Registrieren von FileMaker Pro
Speicherung von Dateien auf Ihrer Festplatte
Installation der ODBC-Client-Treiber
Deinstallieren von FileMaker Pro 10
Ändern der Cache-Größe in FileMaker Pro
Die nächsten Schritte
24
25
25
25
25
26
27
Kapitel 4
Aktivieren von FileMaker Pro
29
Über die Aktivierung von FileMaker Pro
Aktivieren Ihrer Software über das Internet
Aktivieren Ihrer Software über das Telefon
Über die Aktivierungsfrist
Aktivieren von Software-Testversionen
Deaktivieren von FileMaker Pro
29
29
30
31
31
32
Kapitel 5
Neue Funktionen
33
Verbesserungen der Bedienerfreundlichkeit
Sharing und gemeinsame Nutzung
Scripts
Funktionen und Scriptschritte
33
34
35
35
Kapitel 1
Bevor Sie beginnen
Willkommen bei Ihrer FileMaker®-Software. Mit FileMaker können
Sie Informationen einfach und effizient verwalten.
Über dieses Handbuch
Dieses Handbuch Installation und neue Funktionen beschreibt die
Installation von FileMaker Pro 10 bzw. FileMaker Pro 10 Advanced
auf Ihrem Windows- oder Mac OS-Computer und stellt Ihnen die neuen
Funktionen der Software vor.
Hinweis In diesem Handbuch bezieht sich „FileMaker Pro“ sowohl
auf FileMaker Pro als auch auf FileMaker Pro Advanced. Ausgenommen
ist die Beschreibung von Funktionen, die spezifisch für
FileMaker Pro Advanced sind.
Das FileMaker Pro Benutzerhandbuch gibt Ihnen grundlegende
Informationen, damit Sie direkt produktiv arbeiten können. Wenn
Sie FileMaker Pro noch nie verwendet haben, arbeiten Sie den
FileMaker Pro Lehrgang durch, um die wichtigsten Funktionen
kennen zu lernen. Details und umfassende schrittweise Anweisungen
finden Sie in der FileMaker Pro Hilfe.
Das FileMaker Pro Advanced Entwicklerhandbuch beschreibt zusätzliche
Funktionen in FileMaker Pro Advanced, einschließlich Funktionen wie das
Anpassen von Menüs, das Kopieren und Importieren von Tabellen, die
Datenbank-Design-Reports und die Feld-, Variablen- und
Ausdruckskontrolle über die Datenanzeige.
Hinweis Wenn sich eine Funktion oder Vorgehensweise nur auf eine
bestimmte Plattform bezieht, beziehen sich auch die entsprechenden
Anweisungen und Abbildungen auf die entsprechende Plattform. Wenn
Funktionen oder Vorgehensweisen auf beiden Plattformen ähnlich sind, wird
nur eine Abbildung angezeigt, die sich auf Windows oder Mac OS bezieht.
Um Feedback zu diesem Handbuch zu senden, besuchen Sie
www.filemaker.com/company/documentation_feedback.html.
6 | Bevor Sie beginnen
Kundensupport und Produktinformationen
Informationen zum Kundensupport in Ihrem Land finden Sie unter
www.filemaker.com/intl.
Um auf Ressourcen der FileMaker-Website wie vorgefertigte Lösungen
und die FileMaker Knowledge Base zuzugreifen, wählen Sie Hilfe >
Ressourcencenter.
Für weitere Informationen zu FileMaker Pro und die Diskussion von
Supportthemen mit anderen Kunden besuchen Sie bitte das FileMaker
Forum. Wählen Sie Hilfe > Forum besuchen.
Hinweis Das FileMaker Forum steht nicht in allen Sprachen zur Verfügung.
Wenn Sie keinen Internet-Zugang haben, finden Sie weitere Informationen
im FileMaker-Kundendienst-Dokument, das mit der Software
geliefert wird.
Update-Benachrichtigung
FileMaker Pro 10 prüft alle sieben Tage automatisch auf
Software-Updates. Wenn Sie über eine Internet-Verbindung verfügen,
können Sie die Update-Webseite aufrufen und die Updater-Software
herunterladen. Sie können das Update später durchführen, indem
Sie Hilfe > Downloads und Updates wählen.
Hinweis Diese Funktion installiert nicht die Software für Sie. Sie benötigen
eine Internet-Verbindung, um auf die Updater-Software zuzugreifen und
sie herunterzuladen.
Um Update-Benachrichtigungen auszuschalten, führen Sie eine der
folgenden Aktionen aus:
1
1
Wählen Sie im Dialogfeld „Update-Benachrichtigung“
Nicht automatisch nach Updates suchen und klicken Sie auf Ja.
Windows: Wählen Sie Bearbeiten > Einstellungen. Mac OS:
Wählen Sie FileMaker Pro > Einstellungen. Deaktivieren Sie
Automatisch alle 7 Tage auf Updates prüfen im Register „Allgemein“.
Um Update-Benachrichtigungen wieder einzuschalten, aktivieren
Sie diese Option.
Über den Lizenzschlüssel | 7
Wenn Sie die Update-Benachrichtigung deaktivieren, wird das Dialogfeld
„Update-Benachrichtigung“ nicht angezeigt.
Über den Lizenzschlüssel
Die FileMaker-Software wird mit einem eindeutigen 35-stelligen
alphanumerischen Lizenzschlüssel ausgeliefert. Verlieren Sie den
Lizenzschlüssel nicht. Wir empfehlen, den Lizenzschlüssel für den Fall,
dass Sie die Software neu installieren müssen, an einem sicheren Ort
aufzubewahren.
Sie finden Ihre(n) Lizenzschlüssel auf der Rückseite der CD-Hülle. Wenn
Sie die Software über einen elektronischen Download installieren, gehen
Sie entsprechend den Anweisungen in der E-Mail mit der
Bestellbestätigung vor. Sie müssen einen gültigen Lizenzschlüssel
eingeben, um die Software zu installieren und zu aktivieren. Weitere
Informationen zur Aktivierung der Software finden Sie unter „Aktivieren
von FileMaker Pro“ auf Seite 29.
Der Lizenzschlüssel stellt die Einhaltung der FileMaker Pro- bzw.
FileMaker Pro Advanced-Software-Lizenz sicher, die die Nutzung
einer (1) Kopie der Software auf einem einzelnen Computer gleichzeitig
zusammen mit einer zweiten Kopie für die Verwendung auf einem Homeoder portablen Computer entsprechend den Beschränkungen der
Software-Lizenz gestattet. Weitere Informationen finden Sie in der
FileMaker Pro- bzw. FileMaker Pro Advanced-Software-Lizenz, die Sie
in dem Ordner finden, in dem Sie Ihre Software installiert haben.
Wenn der Lizenzschlüssel ungültig ist oder bereits eine mit demselben
Lizenzschlüssel installierte Version der Anwendung im Netzwerk läuft,
zeigt FileMaker Pro eine Fehlermeldung an: „FileMaker Pro wird von
der maximalen Anzahl lizenzierter Benutzer verwendet.“
Um FileMaker Pro auf mehreren Computern zu installieren, benötigen
Sie einen eindeutigen Lizenzschlüssel für jede Installation oder eine
Volumen-Lizenz für mehrere Computer. Sie müssen für jeden Computer
eine Kopie von FileMaker Pro lizenzieren.
8 | Bevor Sie beginnen
Hardware- und Software-Anforderungen
Wichtig Zum Zeitpunkt der Drucklegung dieses Dokuments hat FileMaker,
Inc. FileMaker Pro 10 mit in diesem Abschnitt aufgeführten Windows- und
Mac OS-Betriebssystemen getestet. FileMaker Pro kann möglicherweise
nicht mit neueren Versionen dieser Betriebssysteme ausgeführt werden.
Weitere Informationen zu neueren Betriebssystemen finden Sie unter
www.filemaker.de.
Um FileMaker Pro zu installieren und zu verwenden, benötigen Sie die
folgende Mindestausstattung und Software:
Anforderungen für Windows
1
1
1
Windows Vista SP1 Home, Business oder Ultimate: Pentium III
800 MHz oder schneller mit 512 MB RAM
Windows XP SP2: Pentium III 700 MHz oder schneller
mit 256 MB RAM
Grafikkarte mit SVGA (1024 x 768) oder höherer Auflösung
und passender Monitor
Anforderungen für Mac OS
1
1
1
Macintosh-Computer mit PowerPC G4-Prozessor oder schneller,
oder Intel-basierter Macintosh-Computer
Mac OS X Version 10.5 mit 512 MB RAM
Mac OS X Version 10.4.11 mit 256 MB RAM
Hinweis Mac OS Plugins, die für PowerPCs erstellt wurden, müssen als
Universal Binaries neu kompiliert werden, um direkt ausgeführt werden
zu können, wenn FileMaker Pro auf Intel-basierten Mac-Computern
ausgeführt wird. Als Universal Binaries können Anwendungen direkt
sowohl auf PowerPC- als auch auf Intel-basierten Macintosh-Computern
ausgeführt werden. Wenn Sie Plugins von früheren
FileMaker Pro-Versionen besitzen, die Sie mit FileMaker Pro 10 auf
einem Intel-basierten Macintosh verwenden möchten, können Sie
FileMaker Pro so einstellen, dass die Software unter Rosetta ausgeführt
wird. Wählen Sie im Finder FileMaker, wählen Sie Ablage > Information
und wählen Sie die Option Mit Rosetta öffnen.
Netzwerkanforderungen | 9
Netzwerkanforderungen
Um Dateien mit anderen Computern in einem Netzwerk gemeinsam zu
nutzen, unterstützt FileMaker Pro 10 das TCP/IP-Netzwerkprotokoll.
Wenn Sie nicht sicher sind, welches Netzwerkprotokoll auf dem
Computer installiert und im Einsatz ist, fragen Sie vor Installationsbeginn
Ihren Netzwerkadministrator.
Für die Verbindung zu einem Netzwerk benötigt Ihr Computer ferner eine
Netzwerkkarte und die erforderliche Software.
FileMaker Pro Netzwerk-Sharing unterstützt das Sharing von Dateien für
bis zu 9 gleichzeitige Benutzer (ohne den Host und Instant Web
Publishing-Verbindungen). Um Dateien mit mehr als 9 Benutzern
gleichzeitig in einem Netzwerk zu nutzen, empfiehlt FileMaker die
Verwendung von FileMaker Server, der erweiterte Verfügbarkeit,
verbesserte Sicherheit und zusätzliche Leistung bietet. Weitere
Informationen zu FileMaker Server finden Sie unter www.filemaker.de.
Anforderungen für Web-Publishing
Zur Veröffentlichung einer Datenbank im Web über FileMaker Pro
Instant Web Publishing benötigen Sie einen Host-Computer mit Internetoder Intranet-Zugang über TCP/IP.
FileMaker Pro Instant Web Publishing unterstützt die gemeinsame
Nutzung von Dateien durch bis zu fünf Benutzer gleichzeitig. Wenn
Sie eine stärkere Internet-Integration und Konnektivität benötigen,
verwenden Sie FileMaker Server Advanced, der Instant Web Publishing,
Custom Web Publishing sowie ODBC- und JDBC-Clients unterstützt.
Weitere Informationen zu FileMaker Server Advanced finden Sie unter
www.filemaker.de.
Hinweis Für den Zugang zum Internet wird ein Internet-Anbieter
(ISP Internet service provider) benötigt. FileMaker Pro stellt kein
Internetkonto zur Verfügung.
10 | Bevor Sie beginnen
Anforderungen an andere Funktionen unter Windows
Für einige der Funktionen von FileMaker Pro für Windows wird
zusätzliche Software benötigt.
Funktion
Software-Anforderungen
Scriptschritt „Mail senden“ Microsoft Exchange, Microsoft Outlook, Microsoft
Outlook Express und Eudora
unter Verwendung einer
E-Mail-Anwendung
Hinweis Diese Anforderung gilt nicht für SMTP-Mail.
Telefonnummernwahl
Rufnummernwähler oder andere TAPI-kompatible
Software
ODBC-Funktionen
Microsoft Data Access Components (MDAC) Version 2.8
SP1 (Windows XP) oder Windows DAC 6.0 (Windows
Vista). Um die MDAC-Software zu aktualisieren,
besuchen Sie www.microsoft.com.
Der Zugriff auf externe Datenquellen mit FileMaker Pro
als Client-Anwendung erfordert Third-Party-Treiber für
die verwendete Datenquelle.
Weitere Informationen zur Verwendung von ODBC
finden Sie unter www.filemaker.de/support/technologies.
Einfügen von
QuickTime-Movies und
-Bildern
QuickTime 7.5-Software (verfügbar unter
www.apple.com)
Anforderungen an andere Funktionen unter Mac OS | 11
Anforderungen an andere Funktionen unter Mac OS
Für einige der Funktionen von FileMaker Pro für Mac OS wird
zusätzliche Software benötigt.
Funktion
Software-Anforderungen
Scriptschritt „Mail senden“ Microsoft Entourage oder Mac OS Mail als
E-Mail-Client-Software
unter Verwendung einer
E-Mail-Anwendung
Hinweis Diese Anforderung gilt nicht für SMTP-Mail.
ODBC-Funktionen
Der Zugriff auf externe Datenquellen mit FileMaker Pro
als Client-Anwendung erfordert Third-Party-Treiber für
die verwendete Datenquelle.
Weitere Informationen zur Verwendung von ODBC
finden Sie unter www.filemaker.de/support/technologies.
Importieren von Dateien
aus Bento®
Bento 2 oder eine neuere unterstützte Version (verfügbar
unter www.filemaker.de)
Einfügen von
QuickTime-Movies und
-Bildern
QuickTime 7.5-Software (verfügbar unter
www.apple.com)
Funktionen, die unter Windows nicht unterstützt
werden
Unter Windows unterstützt FileMaker Pro folgende Scriptschritte nicht:
AppleScript ausführen, Sprechen. Ferner wird der Import von Dateien aus
Bento nicht unterstützt.
Funktionen, die unter Mac OS nicht unterstützt werden
Unter Mac OS unterstützt FileMaker Pro folgende Scriptschritte nicht:
Telefonnummer wählen, Objekt einfügen, DDE Execute senden,
Verknüpfung aktualisieren.
Öffnen von Dateien aus früheren Versionen
FileMaker Pro 10 kann Dateien öffnen, die mit früheren Versionen von
FileMaker Pro erstellt wurden. Informationen finden Sie in der
FileMaker Pro Hilfe.
12 | Bevor Sie beginnen
Upgrade von FileMaker Pro von einer früheren Version
Wenn Sie FileMaker Pro von einer früheren Version upgraden, empfiehlt
FileMaker, dass Sie auf die neue Version upgraden, bevor Sie die
vorherige Version deinstallieren.
So upgraden Sie FileMaker Pro von einer vorherigen Version:
1. Installieren Sie das Upgrade mit dem 35-Zeichen-Lizenzschlüssel, der
sich auf der Rückseite der CD-Hülle befindet oder Ihnen zusammen
mit dem Download-Link per E-Mail zugesandt wurde.
2. Verschieben Sie Plugins, Wörterbuchdaten und Ihre Einstellungen für
die neue Version von FileMaker. Weitere Informationen über das
Verschieben von Einstellungen finden Sie in der FileMaker
Knowledge Base unter www.filemaker.com/kb.
3. Wenn Sie vorhaben, nur die neueste Version zu verwenden,
deaktivieren und deinstallieren Sie die vorherige Version. Weitere
Informationen finden Sie unter „Deaktivieren von FileMaker Pro“ auf
Seite 32.
Wenn Sie die vorherige Version deinstallieren, bevor Sie auf die neueste
Version upgraden, stellen Sie sicher, dass Sie den Lizenzschlüssel für
die vorherige Version besitzen. Wenn Sie FileMaker Pro mit einem
Upgrade-Lizenzschlüssel installieren, sucht das Installationsprogramm
auf Ihrer Festplatte nach der vorherigen Version. Wenn keine vorherige
Version gefunden wird, werden Sie aufgefordert, den Lizenzschlüssel
für die vorherige Version des Produkts einzugeben.
Aktualisieren des Anwenderwörterbuchs
Wenn Sie einem Anwenderwörterbuch in einer Vorgängerversion
von FileMaker Pro Wörter hinzugefügt haben, können Sie dies mit
FileMaker Pro 10 verwenden. Informationen über das Konvertieren
eines Anwenderwörterbuchs finden Sie in der FileMaker Pro Hilfe.
Installieren unter einer Volumen-Lizenz | 13
Installieren unter einer Volumen-Lizenz
Wenn Sie mehrere Kopien von FileMaker Pro unter einer Volumen-Lizenz
installieren oder wenn Sie eine unsichtbare Installation vornehmen wollen,
können Sie den Vorgang automatisieren. Verwenden Sie die Datei „Assisted
Install.txt“ auf der FileMaker Pro-CD bzw. in Ihrem elektronischen
Download, um die normalen Installationsdialogfelder zu umgehen. Weitere
Informationen finden Sie im Handbuch Netzwerkinstallation für
FileMaker Pro und FileMaker Pro Pro Advanced. Weitere Informationen
zur Volumen-Lizenzierung finden Sie unter www.filemaker.de.
14 | Bevor Sie beginnen
Kapitel 2
Installieren von FileMaker Pro
unter Windows
Bevor Sie mit dem Installationsvorgang beginnen, beenden Sie andere
geöffnete Programme und speichern Sie Ihre Arbeit. Die neuesten
Informationen zu FileMaker Pro finden Sie auf der CD in der Datei
„Bitte Lesen“ oder auf der Website unter www.filemaker.de.
Installationshinweise
Bevor Sie FileMaker Pro installieren, lesen Sie sich folgende Hinweise
durch:
1
1
1
Um FileMaker Pro zu installieren, benötigen Sie Administratorrechte.
Verwenden Sie den Administrator-Benutzernamen und das
zugehörige Passwort.
Wenn auf dem Computer ein Virenschutzprogramm ausgeführt wird,
beenden Sie es, bevor Sie FileMaker Pro installieren, und starten Sie
es danach erneut.
Standardmäßig wird FileMaker Pro in diesem Ordner installiert:
C:/Programme/FileMaker/FileMaker Pro 10
Während der Installation können Sie ein anderes Laufwerk oder einen
anderen Ordner auswählen.
1
Standardmäßig wird FileMaker Pro Advanced in diesem Ordner
installiert:
C:/Programme/FileMaker/FileMaker Pro 10 Advanced
Während der Installation können Sie ein anderes Laufwerk oder einen
anderen Ordner auswählen.
1
Sie können auch festlegen, ob alle Programmfunktionen
(Vollständig) oder nur ausgewählte Teile des Programms installiert
werden (Benutzerdefiniert). Sie können z. B. festlegen, dass
bestimmte Funktionen nicht installiert werden, um weniger
Speicherplatz zu belegen.
16 | Installieren von FileMaker Pro unter Windows
1
1
Zu Beginn der Installation wählen Sie die Sprachversion für das
FileMaker Pro Installationsprogramm aus. Die Standardauswahl
entspricht der Sprache Ihres Betriebssystems. Eine vollständige
Installation installiert nur die Sprachversion, die Sie auswählen.
Sie können zusätzliche Sprachversionen installieren, indem Sie
die manuelle Installation und dann weitere Sprachpakete aus der
Liste der unterstützten Sprachen auswählen.
Vor der Installation eines Upgrades oder eines Software-Updates
durchsucht die FileMaker-Software alle Festplatten und Volumes, die
mit dem System verbunden sind, nach früheren Versionen. Diese
Suche kann einige Minuten dauern, wenn Sie mehrere Laufwerke oder
Volumes besitzen.
Installieren von FileMaker Pro
Sie müssen das Installationsprogramm verwenden, um FileMaker Pro
zu installieren. Sie können FileMaker Pro nicht installieren, indem Sie
Dateien auf die Festplatte ziehen.
Wenn Sie eine Installationsprotokolldatei erstellen möchten, in der
Registrierungseinträge und der Pfad aller installierten Dateien aufgelistet
werden, müssen Sie FileMaker Pro über die Befehlszeile installieren.
Weitere Informationen finden Sie unter „Installieren von FileMaker Pro
über die Befehlszeile“ auf Seite 17.
So installieren Sie FileMaker Pro auf der Festplatte:
1. Sie haben folgende Möglichkeiten:
1
1
Wenn Sie Ihre Software elektronisch erhalten haben,
doppelklicken Sie nach dem Download der Datei auf das
Installationssymbol (.exe-Datei).
Wenn Sie FileMaker von einer CD installieren, legen Sie die CD
in das CD- oder DVD-Laufwerk ein, öffnen Sie das FileMakerCD-Fenster und klicken Sie auf das Installationssymbol.
Registrieren von FileMaker Pro | 17
Hier klicken, um Klicken, um den
die Anwendung Inhalt der CD
zu installieren.
anzuzeigen.
Klicken, um zu
beenden.
2. Installieren Sie FileMaker Pro, indem Sie den Anweisungen auf dem
Bildschirm folgen.
Detaillierte Informationen zur Installation finden Sie unter
„Installationshinweise“ auf Seite 15.
3. Wenn die Installation abgeschlossen ist, klicken Sie auf Fertig stellen.
Das Dialogfeld „Produktregistrierung“ wird geöffnet.
Registrieren von FileMaker Pro
Bitte nehmen Sie sich einen Augenblick Zeit, Ihr Produkt zu registrieren.
Durch die Registrierung Ihrer Software kann FileMaker Sie dabei
unterstützen, Ihren Lizenzschlüssel für den Fall wiederherzustellen, dass
er verloren gehen sollte. Ferner erhalten Sie bevorzugt
Benachrichtigungen zu Software-Updates, Upgrades und speziellen
Angeboten. Folgen Sie den Anweisungen, um Ihre Registrierungs- und
Produkt- sowie weitere Informationen anzugeben.
Wenn Sie die FileMaker Pro-Testversion verwenden, müssen Sie Ihre
Software vor der Verwendung registrieren.
Sie können die Registrierung auch über Hilfe > Jetzt registrieren in
FileMaker Pro durchführen.
Installieren von FileMaker Pro über die Befehlszeile
So installieren Sie FileMaker Pro über die Befehlszeile und erstellen eine
Installationsprotokolldatei:
1. Legen Sie die CD in das CD- oder DVD-Laufwerk ein.
2. Öffnen Sie ein Befehlsfenster.
18 | Installieren von FileMaker Pro unter Windows
3. Geben Sie Folgendes in das Befehlsfenster ein:
E:\Files\setup.exe /v"/Lr
C:\FMP10InstallLog.txt"
wobei E: das CD- oder DVD-Laufwerk ist. Wenn Ihr CD- oder DVDLaufwerk eine andere Laufwerkskennung verwendet, geben Sie
diesen Buchstaben statt des E ein.
4. Folgen Sie den Anweisungen am Bildschirm.
Die Datei „FMP10InstallLog.txt“ wird im Stammverzeichnis Ihrer
Festplatte gespeichert. Sie können sie mit WordPad oder einem
Textverarbeitungsprogramm anzeigen.
Über die Installation von Bonjour
Der Bonjour-Dienst aktiviert die automatische Erkennung von
Computern, Geräten und Diensten in IP-Netzwerken. Bonjour muss auf
Ihrem System installiert sein, damit Remote-Hosts erkannt werden.
Wenn Bonjour nicht installiert ist oder der Dienst nicht läuft, kann
FileMaker Pro Remote-Netzwerke nicht erkennen. Sie sind dann zum
Beispiel nicht in der Lage, bereitgestellte Datenbanken im Dialogfeld
„Remote-Datei öffnen“ oder die Liste von Remote-Dateien für die
Verwendung als externe Datenquellen anzuzeigen.
Ohne Bonjour müssen Sie die IP-Adressen für Remote-Datenbanken
manuell eingeben.
Während der Installation von FileMaker Pro geht das
Installationsprogramm wie folgt vor:
1
Wenn Bonjour nicht erkannt wird, weist Sie das Installationsprogramm
darauf hin und fordert Sie auf, Bonjour zu installieren.
Speicherung von Dateien auf Ihrer Festplatte | 19
1
1
Wenn Bonjour erkannt wird, aber die installierte Version von
FileMaker nicht unterstützt wird, weist Sie das Installationsprogramm
darauf hin. Es fordert Sie auf, die ältere Version von Bonjour manuell
zu deinstallieren und die von FileMaker unterstützte Version manuell
zu installieren.
Wenn Bonjour erkannt wird und die installierte Version von
FileMaker unterstützt wird, meldet das Installationsprogramm nichts
und installiert Bonjour auch nicht.
So installieren Sie Bonjour manuell:
1. Öffnen Sie den FileMaker Pro-Installationsordner.
2. Öffnen Sie den Bonjour-Ordner.
3. Öffnen Sie den 32-Bit- oder 64-Bit-Ordner, je nach Ihrer Version
von Windows.
4. Doppelklicken Sie auf das BonjourSetup-Symbol.
5. Folgen Sie den Bildschirmanweisungen, um Bonjour zu installieren.
Speicherung von Dateien auf Ihrer Festplatte
Das Installationsprogramm von FileMaker Pro kopiert Dateien in
verschiedene Ordner auf der Festplatte, abhängig von den ausgewählten
Installationsoptionen und dem Betriebssystem. Wenn Sie die Installation
über die Befehlszeile ausgeführt und eine Installationsprotokolldatei
angegeben haben, können Sie diese Datei, in der der Speicherort jeder
Datei aufgelistet wird, anzeigen.
Deinstallieren, Ändern oder Wiederherstellen von
FileMaker Pro 10
Wichtig Deaktivieren Sie FileMaker Pro 10, bevor Sie die Software
deinstallieren. Weitere Informationen hierzu finden Sie unter „Deaktivieren
von FileMaker Pro“ auf Seite 32.
20 | Installieren von FileMaker Pro unter Windows
Über die Option „Software“ in der Windows XP-Systemsteuerung bzw.
der Windows Vista-Systemsteuerung „Programme und Funktionen“
können Sie FileMaker Pro deinstallieren, fehlende oder beschädigte
Dateien ersetzen oder die Installation von Funktionen ändern. Weitere
Informationen finden Sie in der Windows Hilfe.
Wenn Sie FileMaker Pro ändern oder wiederherstellen, werden Sie
möglicherweise dazu aufgefordert, Ihren Lizenzschlüssel einzugeben.
Ändern der Cache-Größe in FileMaker Pro
FileMaker Pro unterhält einen internen Cache für Teile Ihrer Datenbank.
Je nach Speicherkonfiguration des Computers können Sie die CacheGröße anpassen, um die Leistung zu optimieren.
Sie sollten eine Erhöhung der Cache-Größe in Erwägung ziehen, wenn
Sie Folgendes planen:
1
1
1
1
1
Arbeiten mit einer großen Datenbankdatei
gleichzeitiges Arbeiten mit mehreren Datenbankdateien
Hosten von Datenbankdateien
Verwendung einer Datenbankdatei, die viele Grafiken enthält
Einfügen einer großen Grafik in eine Datenbankdatei
Verringern Sie die Cache-Größe, wenn Sie mehrere Anwendungen
gleichzeitig ausführen möchten und begrenzter Arbeitsspeicher (RAM)
installiert ist.
Hinweis Wenn Sie die Cache-Größe in FileMaker Pro erhöhen oder
verringern, erhöhen und verringern Sie auch die Speichermenge, die für die
Ausführung von FileMaker Pro erforderlich ist.
Weitere Informationen zur Speicherverwaltung finden Sie in der
Dokumentation, die mit Ihrem Computer geliefert wurde.
So ändern Sie die von FileMaker Pro verwendete Cache-Größe:
1. Wählen Sie in FileMaker Pro Bearbeiten > Einstellungen.
Das Dialogfeld „Einstellungen“ wird angezeigt.
2. Klicken Sie auf das Register Speicher.
Die nächsten Schritte | 21
3. Geben Sie in das Feld Datei-Cache festlegen auf eine Zahl ein und
klicken Sie dann auf OK.
Beim nächsten Start von FileMaker Pro wird die neue Cache-Größe
verwendet.
Die nächsten Schritte
Nachdem Sie FileMaker Pro installiert haben, können Sie sofort mit der
Anwendung arbeiten. Hier finden Sie einige Vorschläge zu
weiterführenden Informationen in der Dokumentation:
1
1
1
1
1
Wenn Sie noch nicht mit Datenbanken vertraut sind, lesen Sie Kapitel 2,
„Verwenden von Datenbanken“, und Kapitel 3, „Erstellen von
Datenbanken“, im FileMaker Pro Benutzerhandbuch, um sich über
grundlegende Datenbankkonzepte zu informieren.
Wenn Sie FileMaker Pro noch nicht kennen, arbeiten Sie die
Lektionen im FileMaker Pro Lehrgang durch. Die PDF-Datei und die
Beispieldatei für den Lehrgang befinden sich im Ordner „Lehrgang“
innerhalb des Ordners „Deutsch Extras“.
Wenn Sie FileMaker Pro bereits kennen, lesen Sie Kapitel 5, „Neue
Funktionen“ dieses Handbuchs, um sich über neue Funktionen von
FileMaker Pro 10 zu informieren.
Um auf Ressourcen der FileMaker-Website wie vorgefertigte Lösungen
und die FileMaker Knowledge Base zuzugreifen, wählen Sie Hilfe >
Ressourcencenter.
Wenn Sie Benutzer von FileMaker Pro Advanced sind, lesen
Sie das FileMaker Pro Advanced Entwicklerhandbuch und die
FileMaker Pro Hilfe.
22 | Installieren von FileMaker Pro unter Windows
Kapitel 3
Installieren von
FileMaker Pro unter Mac OS
Bevor Sie mit dem Installationsvorgang beginnen, beenden Sie andere
geöffnete Programme und speichern Sie Ihre Arbeit. Die neuesten
Informationen zu FileMaker Pro finden Sie auf der CD in der Datei
„Bitte Lesen“ oder auf der Website unter www.filemaker.de.
Installationshinweise
Bevor Sie FileMaker Pro installieren, lesen Sie sich folgende Hinweise
durch:
1
1
1
1
1
Um FileMaker Pro zu installieren, benötigen Sie Administratorrechte.
Verwenden Sie den Administrator-Benutzernamen und das
zugehörige Passwort.
Wenn auf dem Computer ein Virenschutzprogramm ausgeführt wird,
beenden Sie es, bevor Sie FileMaker Pro installieren, und starten
Sie es danach erneut.
Während der Installation können Sie zwischen der einfachen (alle
Programmdateien werden installiert) und der manuellen Installation
(nur Teile des Programms) wählen. Sie können z. B. festlegen, dass
bestimmte Funktionen nicht installiert werden, um weniger Speicherplatz
zu belegen.
Bei einer einfachen Installation wird FileMaker Pro in der Sprache
Ihres Betriebssystems installiert. Sie können zusätzliche
Sprachversionen installieren, indem Sie die manuelle Installation
und dann weitere Sprachpakete aus der Liste der unterstützten
Sprachen auswählen.
Vor der Installation eines Upgrades oder eines Software-Updates
durchsucht die FileMaker-Software alle Festplatten und Volumes,
die mit dem System verbunden sind, nach früheren Versionen. Diese
Suche kann einige Minuten dauern, wenn Sie mehrere Laufwerke
oder Volumes besitzen.
24 | Installieren von FileMaker Pro unter Mac OS
Installieren von FileMaker Pro
Sie müssen das Installationsprogramm verwenden, um FileMaker Pro
zu installieren. Sie können FileMaker Pro nicht installieren, indem
Sie Dateien auf die Festplatte ziehen.
So installieren Sie FileMaker Pro auf der Festplatte:
1. Sie haben folgende Möglichkeiten:
1
1
Wenn Sie Ihre Software elektronisch erhalten haben, doppelklicken
Sie nach dem Download der Datei auf das Image-Symbol
(.dmg-Datei).
Wenn Sie FileMaker von einer CD installieren, legen Sie die CD
in das CD- oder DVD-Laufwerk ein und öffnen Sie das FileMakerCD-Fenster.
2. Suchen und doppelklicken Sie auf das Symbol FileMaker Pro
Installation.
FileMaker ProInstallationssymbol
3. Wenn Sie dazu aufgefordert werden, geben Sie den Benutzernamen
und das Passwort des Mac OS-Administrators ein.
4. Installieren Sie FileMaker Pro, indem Sie den Anweisungen auf dem
Bildschirm folgen.
Detaillierte Informationen zur Installation finden Sie unter
„Installationshinweise“ auf Seite 23.
5. Wenn die Installation abgeschlossen ist, klicken Sie auf Beenden.
Das Dialogfeld „Produktregistrierung“ wird geöffnet.
Registrieren von FileMaker Pro | 25
Registrieren von FileMaker Pro
Bitte nehmen Sie sich einen Augenblick Zeit, Ihr Produkt zu registrieren.
Durch die Registrierung Ihrer Software kann FileMaker Sie dabei
unterstützen, Ihren Lizenzschlüssel für den Fall wiederherzustellen, dass
er verloren gehen sollte. Ferner erhalten Sie bevorzugt
Benachrichtigungen zu Software-Updates, Upgrades und speziellen
Angeboten. Folgen Sie den Anweisungen, um Ihre Registrierungs- und
Produkt- sowie weitere Informationen anzugeben.
Wenn Sie die FileMaker Pro-Testversion verwenden, müssen Sie Ihre
Software vor der Verwendung registrieren.
Sie können die Registrierung auch über Hilfe > Jetzt registrieren in
FileMaker Pro durchführen.
Speicherung von Dateien auf Ihrer Festplatte
Das Installationsprogramm von FileMaker Pro kopiert Dateien in
verschiedene Ordner auf der Festplatte, abhängig von den ausgewählten
Installationsoptionen und dem Betriebssystem. Nach Abschluss der
Installation können Sie im FileMaker Pro 10-Ordner die
Installationsprotokolldatei anzeigen. In dieser Datei wird der
Installationsort jeder Datei aufgeführt. Sie können sie mit TextEdit oder
einem Textverarbeitungsprogramm anzeigen.
Installation der ODBC-Client-Treiber
Die FileMaker Pro ODBC-Unterstützung ermöglicht Ihnen, Daten aus
anderen Anwendungen auf Ihrem Computer oder über ein Netzwerk, z. B.
aus Oracle-Datenbanken, zu importieren. Weitere Informationen zur
Verwendung von ODBC einschließlich Links zu Treiberherstellern finden
Sie unter www.filemaker.de/support/technologies.
Deinstallieren von FileMaker Pro 10
Wichtig Deaktivieren Sie FileMaker Pro, bevor Sie die Software
deinstallieren. Weitere Informationen finden Sie unter „Deaktivieren von
FileMaker Pro“ auf Seite 32.
26 | Installieren von FileMaker Pro unter Mac OS
So deinstallieren Sie FileMaker Pro 10:
1. Deaktivieren Sie FileMaker Pro 10.
2. Ziehen Sie den Ordner „FileMaker Pro 10“ bzw. „FileMaker Pro 10
Advanced“ und seinen gesamten Inhalt aus dem Programme-Ordner
in den Papierkorb.
3. Ziehen Sie die FileMaker Pro- bzw. FileMaker Pro Advanced-
Einstellungsdatei in den Papierkorb.
Der Pfadname für die Einstellungsdatei lautet:
Für FileMaker Pro: <home>/Library/Preferences/FileMaker
Preferences/ FileMaker Pro 10.0 Prefs
Für FileMaker Pro Advanced: <home>/Library/Preferences/
FileMaker Preferences/ FileMaker Pro 10.0A Prefs
Ändern der Cache-Größe in FileMaker Pro
Mac OS weist den Anwendungen Speicher dynamisch nach Bedarf zu.
Es gibt keine Möglichkeit, FileMaker Pro eine bestimmte Speichermenge
zuzuweisen. Sie können jedoch die Größe des FileMaker Pro-Cache
anpassen.
Sie sollten in Erwägung ziehen, die Cache-Größe zu erhöhen, wenn Sie
Folgendes planen:
1
1
1
1
1
Arbeiten mit einer großen Datenbankdatei
gleichzeitiges Arbeiten mit mehreren Datenbankdateien
Hosten von Datenbankdateien
Verwendung einer Datenbankdatei, die viele Grafiken enthält
Einfügen einer großen Grafik in eine Datenbankdatei
Verringern Sie die Cache-Größe, wenn Sie mehrere Anwendungen
gleichzeitig ausführen möchten und begrenzter Arbeitsspeicher (RAM)
installiert ist.
So ändern Sie die von FileMaker Pro verwendete Cache-Größe:
1. Wählen Sie in FileMaker Pro FileMaker Pro > Einstellungen und
klicken Sie auf das Register Speicher.
Die nächsten Schritte | 27
2. Geben Sie in das Feld Datei-Cache festlegen auf eine Zahl ein und
klicken Sie dann auf OK.
Beim nächsten Start von FileMaker Pro wird die neue Cache-Größe
verwendet.
Die nächsten Schritte
Nachdem Sie FileMaker Pro installiert haben, können Sie sofort mit der
Anwendung arbeiten. Hier finden Sie einige Vorschläge zu
weiterführenden Informationen in der Dokumentation:
1
1
1
1
1
Wenn Sie noch nicht mit Datenbanken vertraut sind, lesen Sie
Kapitel 2, „Verwenden von Datenbanken“, und Kapitel 3, „Erstellen
von Datenbanken“, im FileMaker Pro Benutzerhandbuch, um sich
über grundlegende Datenbankkonzepte zu informieren.
Wenn Sie FileMaker Pro noch nicht kennen, arbeiten Sie die
Lektionen im FileMaker Pro Lehrgang durch. Die Lehrgang-PDFDatei und die Beispieldatei befinden sich im Ordner „Lehrgang“
innerhalb des Ordners „Deutsch Extras“.
Wenn Sie FileMaker Pro bereits kennen, lesen Sie Kapitel 5, „Neue
Funktionen“ dieses Handbuchs, um sich über neue Funktionen von
FileMaker Pro 10 zu informieren.
Um auf Ressourcen der FileMaker-Website wie vorgefertigte Lösungen
und die FileMaker Knowledge Base zuzugreifen, wählen Sie Hilfe >
Ressourcencenter.
Wenn Sie Benutzer von FileMaker Pro 10 Advanced sind, lesen Sie
das FileMaker Pro Advanced Entwicklerhandbuch und die
FileMaker Pro Hilfe.
28 | Installieren von FileMaker Pro unter Mac OS
Kapitel 4
Aktivieren von FileMaker Pro
Die FileMaker Pro-Software verwendet Online-Aktivierungstechnologie,
um sicherzustellen, dass Sie und Ihr Unternehmen eine echte Kopie der
FileMaker-Software einsetzen. Die Aktivierung hilft, FileMaker, Inc. vor
der unbefugten Distribution von Software zu schützen.
Hinweis Wenn Sie FileMaker Pro über ein Volumen-Lizenz-Programm
erworben haben, müssen Sie Ihre Software nicht aktivieren.
Über die Aktivierung von FileMaker Pro
Bis Sie FileMaker Pro aktiviert haben, wird das Dialogfeld
„FileMaker-Aktivierung“ jedes Mal angezeigt, wenn Sie die Anwendung
starten. Während der Aktivierung bezieht der FileMaker Activation
Server den Lizenzschlüssel und eine eindeutige Computer-ID von Ihrem
Computer. FileMaker, Inc. sammelt keine personenbezogenen Daten aus
diesem Verfahren.
Das Aktivierungsverfahren unterstützt die nicht gleichzeitige
Verwendung von FileMaker Pro auf maximal zwei Computern. Weitere
Informationen finden Sie in der FileMaker Pro- bzw. FileMaker Pro
Advanced-Software-Lizenz, die Sie in dem Ordner finden, in dem Sie Ihre
Software installiert haben.
Aktivieren Ihrer Software über das Internet
Verwenden Sie die folgende Tabelle, um FileMaker Pro über das Internet
zu aktivieren. Um FileMaker Pro über das Telefon zu aktivieren, siehe
„Aktivieren Ihrer Software über das Telefon“ auf Seite 30.
Ziel
Vorgehensweise in FileMaker Pro
Aktivieren von
Klicken Sie im Dialogfeld „FileMaker-Aktivierung“ auf
FileMaker Pro beim Start Aktivieren und folgen Sie den Anweisungen.
FileMaker Pro später
aktivieren
Klicken Sie im Dialogfeld „FileMaker-Aktivierung“ auf
Später aktivieren.
30 | Aktivieren von FileMaker Pro
Ziel
Vorgehensweise in FileMaker Pro
FileMaker Pro innerhalb
der Aktivierungsfrist
aktivieren
Wählen Sie Hilfe > Aktivieren. Klicken Sie im Dialogfeld
„FileMaker-Aktivierung“ auf Aktivieren.
Testsoftware aktivieren
Klicken Sie beim Start auf Lizenzschlüssel im Dialogfeld,
geben Sie Ihren Lizenzschlüssel ein und klicken Sie auf
Aktivieren. Oder wählen Sie während der Verwendung der
Software Hilfe > Aktivieren. Geben Sie im Dialogfeld
„FileMaker-Aktivierung“ Ihren Lizenzschlüssel ein und
klicken Sie auf Aktivieren. Weitere Informationen über die
Aktivierung einer Testversion finden Sie unter „Aktivieren
von Software-Testversionen“ auf Seite 31.
Deaktivieren der
FileMaker Pro-Software
Wählen Sie Hilfe > Deaktivieren. Wenn Sie Ihre Software
per Telefon aktivieren, können Sie sie auch nur per
Telefon deaktivieren. Weitere Informationen über die
Aktivierung bzw. Deaktivierung Ihrer Software über das
Telefon finden Sie unter „Aktivieren Ihrer Software über
das Telefon“ auf Seite 30.
Wichtig Sie müssen FileMaker Pro deaktivieren, bevor
Sie die Software deinstallieren (um sie zum Beispiel auf
einem anderen Computer zu installieren oder vor dem
Upgrade Ihres Betriebssystems). Weitere Informationen
über die Deaktivierung Ihrer Software finden Sie unter
„Deaktivieren von FileMaker Pro“ auf Seite 32.
Aktivieren Ihrer Software über das Telefon
Wenn Sie keine Internet-Anbindung besitzen oder FileMaker Pro
aufgrund von Netzwerksicherheitsbeschränkungen nicht aktivieren
können, können Sie Ihre Software auch über das Telefon aktivieren.
Über die Aktivierungsfrist | 31
Wenn Sie Ihre Software noch nicht aktiviert haben und nicht mit dem
Internet verbunden sind, wenn Sie das Programm starten, wird das
Dialogfeld „Aktivierung per Telefon“ angezeigt. Rufen Sie bei
geöffnetem Dialogfeld den FileMaker-Kundendienst unter der im
FileMaker-Kundendienstverzeichnis, das Ihrer Software beliegt,
genannten Rufnummer an. Sie werden aufgefordert, Ihren Anfragecode
und Ihren Lizenzschlüssel anzugeben. Der Kundendienst gibt Ihnen einen
entsprechenden Antwortcode und Ihre Software wird aktiviert.
Hinweis Wenn Sie Ihre Software per Telefon aktiviert haben, können Sie sie
auch nur per Telefon deaktivieren. Weitere Informationen finden Sie unter
„Deaktivieren von FileMaker Pro“ auf Seite 32.
Über die Aktivierungsfrist
Wenn Sie nicht mit dem Internet verbunden sind, wenn Sie
FileMaker Pro zum ersten Mal starten, können Sie FileMaker Pro
dennoch für 30 Tage verwenden. Jedes Mal, wenn Sie die Software
während der Aktivierungsfrist öffnen, zeigt das Dialogfeld
„Aktivierung“ die verbleibende Zeit der Frist an und fordert
Sie auf, Ihre Software zu aktivieren.
Um FileMaker Pro nach Ablauf der Frist weiter zu verwenden, müssen
Sie die Aktivierung über das Internet oder das Telefon abschließen.
Hinweis Testversionen haben keine Aktivierungsfrist. Sie müssen für die
Software innerhalb des Testzeitraums zahlen, um sie weiter zu verwenden.
Aktivieren von Software-Testversionen
Die Aktivierung für Testversionen und gekaufte Software unterscheidet
sich. Als Testbenutzer haben Sie Zeit (in der Regel 30 Tage), bevor Sie für
die Software zahlen müssen. Während des Testzeitraums können Sie
jederzeit für die Software zahlen und sie dann aktivieren, indem Sie beim
Start den Lizenzschlüssel eingeben. Nach Ablauf des Testzeitraums
müssen Sie für die Software zahlen und sie sofort aktivieren, um sie
weiter zu verwenden.
32 | Aktivieren von FileMaker Pro
Deaktivieren von FileMaker Pro
Wenn Sie aus einem beliebigen Grund FileMaker Pro deinstallieren
müssen, deaktivieren Sie die Software vor der Deinstallation. So können
Sie die Aktivierung auf einen anderen Computer übertragen oder neu
aktivieren, nachdem Sie das Betriebssystem auf Ihrem aktuellen
Computer neu installiert oder aktualisiert haben.
So deaktivieren und deinstallieren Sie FileMaker Pro:
1. Deaktivieren Sie FileMaker Pro auf dem aktuellen Computer.
1
1
Wenn Sie die Aktivierung über das Internet durchgeführt haben,
deaktivieren Sie, indem Sie Hilfe > Deaktivieren wählen.
Wenn Sie über das Telefon aktiviert haben, müssen Sie über
das Telefon deaktivieren. Rufen Sie, während Ihr Computer läuft,
den FileMaker-Kundendienst unter der gleichen Rufnummer an,
die Sie auch für die Aktivierung Ihrer Software verwendet haben.
Sie werden aufgefordert, den Antwortcode (den Sie im Dialogfeld
„Aktivierung per Telefon“ sehen) und Ihren Lizenzschlüssel
anzugeben.
2. Deinstallieren Sie FileMaker Pro auf dem aktuellen Computer.
Hinweise
1
1
Wenn Sie FileMaker Pro auf dem gleichen oder einem anderen
Computer neu installieren möchten, installieren Sie die Software
neu und aktivieren Sie sie.
Wenn Sie die Software nicht deaktivieren, aber später die gleiche
Kopie von FileMaker Pro auf einem anderen Computer installieren,
oder wenn Sie Ihren Computer neu formatieren und FileMaker Pro
dann neu installieren, verlieren Sie die Aktivierung für einen
Computer.
Kapitel 5
Neue Funktionen
Dieses Kapitel gibt Ihnen einen Überblick über die neuen Funktionen und
Verbesserungen in FileMaker Pro 10. Wenn nicht anderweitig vermerkt,
finden Sie weitere Informationen zu diesen Funktionen in der
FileMaker Pro Hilfe.
Verbesserungen der Bedienerfreundlichkeit
1 Statussymbolleiste – Verwenden Sie den neu gestalteten Statusbereich,
der jetzt als Symbolleiste oben im FileMaker Pro-Fenster angezeigt
wird, um die meisten Aufgaben auszuführen. Verwenden Sie zum
Beispiel die Statussymbolleiste, um Suchabfragen im Blättern- oder
Suchenmodus schnell auszuführen. Ziehen Sie Ihren Mauszeiger über
die Statussymbolleiste, um die QuickInfo anzuzeigen.
1
1
1
1
1
Gespeicherte Suchen – Speichern Sie komplexe Suchabfragen für
künftige FileMaker Pro-Sitzungen und greifen Sie auf die letzten
Suchen über Schaltflächen in der Statussymbolleiste zu.
Verbesserter Suchenmodus – Die
kennzeichnet jetzt die Felder
an, die Sie für eine Suche in Ihrer Datenbank verwenden können.
Layoutobjekt-QuickInfo – Jetzt können Sie FileMaker Pro
verwenden, um beschreibenden Text zu integrieren, der angezeigt
wird, wenn Sie den Zeiger über Layoutobjekte im Blättern- oder
Suchenmodus bewegen.
FileMaker-Direktstart – Erstellen Sie eine FileMaker Pro-Datenbank
aus einer Excel- oder Bento 2- (oder einer neueren unterstützten
Version) Datei. Greifen Sie auf Lehrmaterial wie Videos und den
FileMaker-Lehrgang über den Bereich „Lernen“ zu.
Verbesserte Starter-Lösungen – Erstellen Sie eine Datenbank aus
der aktualisierten Vorlage einer Starter-Lösung, um die neuen
FileMaker Pro-Funktionen zu nutzen.
34 | Neue Funktionen
1
1
1
1
Erweiterte Wiederherstellungsoptionen – Führen Sie eine
Konsistenzprüfung für Dateien aus, von denen Sie vermuten, dass
sie beschädigt sind, wählen Sie spezifische, wiederherzustellende
Dateikomponenten und zeigen Sie Informationen über den
Status einer Datei an. Zeigen Sie sowohl während als auch
nach der Wiederherstellung ein detailliertes Dateiwiederherstellungsprotokoll an.
Dynamische Zwischenergebnisberichte – Sehen Sie neu berechnete
Statistikwerte im Blätternmodus in Echtzeit, während sich die Daten
ändern.
Weitere Layout-Präsentationsstile – Wählen Sie neue
Layout-Präsentationsstile im Assistenten für neue Layouts, um Ihre
Berichte aufzuwerten.
Sortierfolge – Neue Datensätze werden in sortierter Reihenfolge
angezeigt, wenn Sie einer Ergebnismenge Datensätze hinzufügen.
Sharing und gemeinsame Nutzung
1 Zusätzliche Unterstützung für ODBC-Datenquellen (auch als externe
SQL-Quellen oder ESS bezeichnet) – Zeigen Sie Daten aus
SQL-Tabellen in Microsoft SQL Server 2008, Oracle 11g und
MySQL 5.1 Community Edition an, greifen Sie auf sie zu und nutzen
Sie sie. Definieren Sie Wertelisten unter Verwendung von Feldern aus
ODBC-Datenquellen-Tabellen. Nutzen Sie die
Windows-Authentifizierung (Single Sign-On), um auf ODBC-Daten
von Microsoft SQL Server zuzugreifen. Greifen Sie präzise auf
SQL-unterstützte Zeitstempeldaten aus ODBC-Datenquellen zurück.
1
1
Microsoft Excel 2007/2008 – Importieren Sie Daten aus und
exportieren Sie Daten in Excel 2007/2008-Format.
Verbesserte Unterstützung für den Import von Daten aus Bento 2
(Mac OS) – Verwenden Sie Standard-Importverfahren in
FileMaker Pro, um Informationen aus Bento 2 (oder einer neueren
unterstützten Version)-Datenquellen in eine FileMaker Pro-Datei zu
importieren.
Scripts | 35
1
Direkte SMTP-E-Mail-Unterstützung – Wählen Sie Datei (Windows)
bzw. Ablage (Mac OS) > Mail senden oder verwenden Sie ein Script,
um E-Mail-Nachrichten direkt aus FileMaker Pro-Dateien zu
versenden, ohne eine E-Mail-Client-Software zu verwenden.
Scripts
1 Script-Trigger – Geben Sie an, dass ein Script ausgeführt, falls ein
bestimmtes Ereignis eintritt, zum Beispiel wenn ein Benutzer oder
ein Script ein Feld aktiviert, ändert oder verlässt, wenn eine Taste
gedrückt wird; wenn ein Feld geändert wird oder wenn ein Datensatz
geschrieben wird.
1
1
Verbesserungen an der Scripting-Benutzeroberfläche – Verwenden
Sie die Funktion „Scripts verwalten“ (früher ScriptMaker), um ein
Standardscript anzuzeigen, dass Sie als Ausgangspunkt für die
Erstellung eigener Scripts verwenden können. Zudem können
Sie erkennen, ob einzelne Scriptschritte für Web Publishing oder
in FileMaker Server-Zeitplänen unterstützt werden u. v. m. Das
Dialogfeld „Scripts verwalten“ wird nicht mehr mit maximaler
Größe geöffnet, wenn das FileMaker Pro-Fenster maximiert ist.
Verbesserungen bei Fehlerberichten – Steuerungsscriptschritte
löschen die letzte Fehlerbedingung, die FileMaker Pro gemeldet hat,
nicht mehr.
Funktionen und Scriptschritte
1 Scriptschritt „BeiTimer-Script installieren“ – Führt ein angegebenes
Script in einem angegebenen Intervall aus.
1
1
Scriptschritt „Gespeicherte Suchen bearbeiten“ – Öffnet das
Dialogfeld „Gespeicherte Suchen bearbeiten“, in dem der Benutzer
neue Suchanweisungen erstellen oder vorhandene Suchanweisungen
bearbeiten kann.
Scriptschritt „Drucken“ – Sie können jetzt einen angegebenen
Zieldrucker mit einem Namen beliebiger Länge speichern, wenn ein
Script ausgeführt wird.
36 | Neue Funktionen
1
1
1
1
1
1
1
Scriptschritt „Feld nach Name einstellen“ – Ermöglicht die
Verwendung einer Formel, um einen Feldnamen in einem Script
dynamisch anzugeben, statt jeden möglichen Feldnamen in einer
Wenn...Sonst-Konstruktion anzugeben.
Funktion „Zeichen (Zahl)“ – Gibt das bzw. die Zeichen zurück, die die
Unicode-Punkte für eine angegebene Zahl darstellen.
Funktion „Code (Text)“ – Gibt den bzw. die Unicode-Punkt(e) für
die angegebenen Textzeichen in Zahlenformat zurück.
Funktion „HoleFeldname (Feld)“ – Gibt den voll qualifizierten
Feldnamen (Tabellenname::Feldname) zurück.
Funktion „Hole (DokumentePfadListe)“ – Gibt eine rekursive Liste
von Dateien und Ordnern im Ordner zurück, der durch die Funktion
„Hole (DokumentenPfad)“ zurückgegeben wird.
Funktion „Hole (TriggerTastendruck)“ – Gibt die Textzeichenfolge
zurück, die einen Script-Trigger „BeiObjektTastendruck“ oder
„BeiLayoutTastendruck“ aktiviert hat.
Funktion „Hole (TriggerKurztasten)“ – Gibt den Status der
Tastaturkurztasten (wie Umschalt- oder Strg-Taste) zurück, wenn ein
Script ausgelöst wurde.
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement