Kapitel 7: 3D-Objekte erstellen und bearbeiten

Kapitel 7: 3D-Objekte erstellen und bearbeiten
Draw-Handbuch
Kapitel 7
3D-Objekte erstellen
und bearbeiten
OpenOffice.org
Copyright
Copyright
Copyright und Lizenzen
Dieses Dokument unterliegt dem Copyright ©2006 seiner Autoren und Beitragenden,
wie sie im entsprechenden Abschnitt aufgelistet sind. Alle Markennamen innerhalb
dieses Dokuments gehören ihren legitimen Besitzern.
Sie können es unter der Voraussetzung verbreiten und/oder modifizieren, dass Sie sich
mit den Bedingungen einer der (oder aller) folgenden Lizenzen einverstanden
erklären:
•
GNU General Public License (GPL), Version 2 oder später
(http://www.gnu.org/licenses/gpl.html).
•
Creative Commons Attribution License (CCAL), Version 2.0 oder später
(http://creativecommons.org/licenses/by/2.0/).
•
Public Documentation License (PDL), Version 1 oder später:
Public Documentation License Notice
The contents of this Documentation are subject to the Public Documentation
License Version 1.0 (the "License"); you may only use this Documentation if you
comply with the terms of this License. A copy of the License is available at
http://www.openoffice.org/licenses/PDL.html.
Der Titel der Originaldokumentation ist „Draw-Handbuch,Kapitel 7, 3D-Objekte
erstellen und bearbeiten“.
Der/die ursprünglichen Autoren der Originaldokumentation sind im Abschnitt
„Autoren“ aufgeführt und können entweder unter [email protected]
oder bei Fragen/Anmerkungen zur Übersetzung unter [email protected]
kontaktiert werden.
Personen, die das Dokument in irgendeiner Weise nach dem unten angegebenen
Veröffentlichungsdatum verändern, werden im Abschnitt „Beitragende“ mitsamt
Datum der Veränderung aufgeführt.
Autoren
Beitragende
Linda Worthington
Daniel Carrera
Jean Hollis Weber
Agnes Belzunce
Bernd Schukat
Regina Henschel
Wolfgang Uhlig
Danksagung
Das Kapitel basiert auf einem Dokument von Michel Pinquier auf der Grundlage von
OpenOffice.org 1.x (ins Englische übersetzt von Alex Thurgood) und auf früherem von
Jim Taylor revidierten Inhalt. Dank gilt Linda Worthington als erster Betreuerin.
Veröffentlichung und Softwareversion
Die englische Version wurde am 10. April 2006 veröffentlicht, die deutsche am 19. Juni
2007. Das Dokument basiert auf der Version 2.2 von OpenOffice.org.
Sie können eine editierbare Version dieses Dokuments
von folgenden Seiten herunterladen:
http://oooauthors.org/de/veroeffentlicht/ oder
http://de.openoffice.org/source/browse/de/documentation/oooauthors/
Inhalt
Inhalt
Copyright..........................................................................................................
.....................ii
Copyright und Lizenzen.......................................................................................
.........ii
Autoren.......................................................................................................
..................ii
Beitragende.........................................................................................
.........................ii
Danksagung..................................................................................................
................ii
Veröffentlichung und Softwareversion.........................................................................ii
Inhalt...................................................................................................................................
....i
3D-Objekte erstellen................................................................................................
..............1
3D-Körper erstellen...................................................................................................
........1
Variante 1: Extrusion....................................................................................
................1
Variante 2: Rotationskörper.........................................................................................2
Variante 3: fertige Objekte benutzen..........................................................................
..3
3D Szenen...........................................................................................................
..........3
3D-Formen erstellen.......................................................................................................
...3
Variante 4: Extrusion von Formen................................................................................3
Variante 5: Fontwork.............................................................................
.......................4
3D-Objekte bearbeiten......................................................................................................
.....4
3D-Objekte drehen.........................................................................................
...................4
Verfahren für „3D-Körper“...........................................................................................4
Verfahren für „3D-Formen“..........................................................................................5
3D-Einstellungen für „3D-Körper“....................................................................................5
Dialog 3D-Effekte – Generelle Schaltflächen...............................................................5
Dialogseite Darstellung .............................................................................................11
Dialogseite Beleuchtung....................................................................................
.........14
Dialogseite Texturen..........................................................................................
.........16
Dialogseite Material...........................................................................
........................19
3D Einstellungen für „3D-Formen“.................................................................................20
Objekte in 3D Szenen kombinieren.................................................................................22
Anregungen für eigene Experimente..............................................................................23
3D-Objekte erstellen und bearbeiten
i
3D-Objekte erstellen
3D-Objekte erstellen
Auch wenn OpenOffice.org nicht mit führenden Zeichen- oder
Bildbearbeitungsprogrammen konkurrieren will, bietet es doch Werkzeuge für
beeindruckende 3D-Zeichnungen.
Draw kann 3D-Objekte selbst rendern1 oder OpenGL2 benutzen, wenn dies installiert
ist. Unter Extras > Optionen > OpenOffice.org > Ansicht (siehe Abbildung 1)
schalten Sie dies ggf. ein.
Abbildung 1: OpenGL-Option
Draw bietet zwei unterschiedliche Arten von 3D-Objekten an: die schon aus der
Version 1 bekannten „3D-Körper“ und die in der Version 2 neu eingeführten „3DFormen“. Abhängig von der gewählten Variante ergeben sich unterschiedliche
Möglichkeiten zur weiteren Bearbeitung des Objektes (Drehen, Beleuchtung,
Perspektive). Die Handhabung von „3D-Formen“ ist einfacher als die von „3DKörpern“, bietet aber auch wesentlich weniger Möglichkeiten.
3D-Körper erstellen
Es gibt mehrere Varianten, 3D-Körper zu erzeugen:
Variante 1: Extrusion
Sie erzeugen ein beliebiges Zeichenobjekt, z. B. mit den Schaltflächen
Quadrat/Rechteck oder Kreis/Ellipse
oder
der Symbolleiste Zeichnen.
Wählen Sie nun Ändern > Umwandeln > In 3D (alternativ rechter Mausklick auf das
Zeichenobjekt, Umwandeln > In 3D) oder die Schaltfläche
, um aus der jeweiligen
2D-Fläche ein 3D-Objekt zu erzeugen. Die Schaltfläche ist in der Symbolleiste
Zeichnen vorhanden, aber nicht sichtbar. Über den Eintrag Sichtbare Schaltflächen
im Symbolleistenmenü am rechten Ende der Symbolleiste könne Sie die Schaltfläche
sichtbar machen.
Abbildung 2: Extrudieren von 2D-Flächen zu 3D-Objekten
1 von engl. to render: übersetzen, übertragen. Der Vorgang, aus den geometrischen
Beschreibungen von 3D-Objekten die Darstellung auf einem zweidimensionalen Ausgabegerät zu
berechnen, wird „Rendern“ genannt.
2 OpenGL (Open Graphics Library) ermöglicht plattform- und programmiersprachenunabhängige
3D-Computergrafiken.
3D-Objekte erstellen und bearbeiten
1
3D-Objekte erstellen
Das Verfahren, das durch Parallelverschieben Flächen in 3D-Objekte umwandelt,
bezeichnet man als Extrudieren (Hochziehen) oder Extrusion. In diesem Fall wird die
2D-Fläche nach vorne aus der Zeichenebene herausgezogen. Gleichzeitig wird der
Körper etwas gekippt und Zentralprojektion eingeschaltet, damit man ihn besser
erkennen kann. Draw ermittelt für die Umwandlung automatisch einen Wert für das
Extrudieren (Körper-Tiefe) aus der Größe des Körpers. Der endgültige Wert wird erst
nach der Extrusion eingegeben (siehe 3D-Objekte bearbeiten auf Seite 4).
Variante 2: Rotationskörper
Wählen Sie ein beliebiges Zeichenobjekt aus, zum Beispiel eine nicht schwarze Linie.
Dann wandeln Sie dieses in einen Rotationskörper um. Dazu stehen Ihnen zwei
Methoden zur Verfügung.
1) Über das Symbol
in der Symbolleiste Zeichnen (auch dieses Symbol ist
standardmäßig nicht sichtbar) oder über Ändern > Umwandeln > In 3D
Rotationskörper. Bei dieser Umwandlungsmethode liegt die Rotationsachse
immer am linken Rand des umhüllenden, durch die grünen Griffe
gekennzeichneten Rechtecks.
Abbildung 3: Rotationskörper nach Variante 2.1
2) Über das Symbol
in der Abreißleiste „Effekte“ in der Symbolleiste Zeichnen.
Beachten Sie, dass in diesem Symbol der große rote Pfeil fehlt. Die gleiche
Symbolleiste können Sie auch über Ansicht > Symbolleisten > Modus öffnen.
Bei dieser Umwandlungsmethode können Sie die Lage der Rotationsachse ändern.
Abbildung 4: Rotationskörper nach Variante 2.2
Fassen Sie dazu die weißen Endpunkte mit der Maus an und ziehen Sie damit die
Achse an die gewünschte Stelle. Durch einen Umriss wird angedeutet, wie die
Figur rotiert wird. Wenn Sie dann neben die Figur klicken, wird die Rotation
durchgeführt.
3D-Objekte erstellen und bearbeiten
2
3D-Objekte erstellen
Variante 3: fertige Objekte benutzen
Benutzen Sie die Symbolleiste 3D-Objekte. Um diese Symboleiste zu aktivieren,
wählen Sie Ansicht > Symbolleisten > 3D-Objekte.
Abbildung 5: Die Symbolleiste 3D-Objekte
Wenn Sie das Symbol
in der Symbolleiste Zeichnen einfügen, steht Ihnen die
Leiste 3D-Objekte auch als Abreißleiste zur Verfügung.
Nach dem Auswählen eines Objekts klicken Sie mit der linken Maustaste an den
Startpunkt und ziehen mit gedrückter Maustaste diagonal, bis der sich aufziehende
Rahmen die gewünschte Objektgröße hat. Nach dem Loslassen der Maustaste
erscheint der 3D-Körper. Wenn Sie gleichzeitig die Umschalttaste gedrückt halten,
können Sie auch die Seitenverhältnisse variieren.
Bis auf Würfel und Kugel sind diese Körper als Rotationskörper konstruiert worden.
Würfel und Kugel sind eigenständige Typen, die direkt im Programmcode definiert
wurden.
3D Szenen
Bei allen diesen Varianten erhalten Sie als Ergebnis eine so genannte „3D Szene“. Bei
einem Klick auf das Objekt wird links unten in der Statusleiste der Text „3D Szene
markiert“ angezeigt. Eine solche 3D Szene ist eigentlich eine Gruppierung. Wie bei
Gruppierungen üblich (siehe Kapitel 6) können Sie über Ändern > Gruppierung
betreten in die Gruppierung hineinwechseln. Nun ändert sich in der Statusleiste die
Anzeige und die Art des Objekts wird angezeigt, z. B. „Kugel markiert“ oder
„Extrusionsobjekt markiert“. Wenn Sie nach obigen Methoden ein Objekt konstruiert
haben, enthält die 3D Szene nur den 3D-Körper als einziges Element. 3D Szenen
können aber auch um weitere 3D-Objekte erweitert werden, was später noch
beschrieben wird.
3D-Formen erstellen
Ab der Version 2.0 enthält Draw eine neue Art von Zeichenobjekten, „Formen“
genannt. Für diese Formen existiert eine besondere Variante des Extrudierens.
Variante 4: Extrusion von Formen
Abbildung 6: Die Symbolleiste Standardformen
Verwenden Sie die Symbolleiste Standardformen oder eine der anderen FormenSymbolleisten, um eine 2D-Fläche zu erzeugen. Formen wie „Zylinder“ oder „Würfel“
sind dabei zwar technisch möglich, aber wenig sinnvoll, weil sie an sich ja schon
Schrägbilder darstellen. Wenn Sie eine Form gezeichnet haben, wird die letzte
Schaltfläche
der Symbolleiste Zeichnen, aktiv.
Wenn Sie diese Schaltfläche betätigen, ändert sich die Darstellung in ein 3D-Objekt
(siehe Abbildung 7 ). Tatsächlich entsteht aber kein neuer Objekttyp, sondern es
ändert sich nur die Darstellung. Mit derselben Schaltfläche können Sie daher auch
3D-Objekte erstellen und bearbeiten
3
3D-Objekte erstellen
wieder in die 2D-Darstellung zurückschalten. Es ist ein Umschalter, was in dem
Symbol durch beide Darstellungsformen angedeutet wird. Die jeweiligen Einstellungen
gehen beim Umschalten nicht verloren.
Abbildung 7: 3D-Objekte aus Standardformen
Wenn sie auf ein solches Objekt klicken, steht Ihnen die Symbolleiste 3D-Einstellungen
zur Verfügung. Wenn sie sich nicht automatisch öffnet, können Sie die Leiste mit
Ansicht > Symbolleisten > 3D Einstellungen einschalten.
Abbildung 8: Die Symbolleiste 3D-Einstellungen
Die erste Schaltfläche
entspricht der Schaltfläche in der Symbolleiste Zeichnen.
Auch diese wirkt wie ein Umschalter. Nach dem Wechsel zu 2D verschwindet jedoch
die Symbolleiste 3D-Einstellungen. Um wieder auf 3D zu wechseln, müssen Sie die
Schaltfläche
der Symbolleiste Zeichnen benutzen.
Variante 5: Fontwork
Für Texte können Sie auch die Formen aus der Fontwork-Gallery benutzen. Diese
stellen teilweise die gleiche Art Extrusionsobjekte dar, wie solche nach der Variante 4
erzeugten. Die Fontwork-Gallery öffnen Sie mit der Schaltfläche
aus der
Symbolleiste Zeichnen.
Abbildung 9: Form-Extrusion aus der Fontwork Gallery
Zeichenobjekte vom Typ „Form“ können mit OpenOffice.org Version 1 nicht dargestellt
werden. Sie fehlen dann in der Zeichnung. Speichern Sie ein Dokument mit einer so
extrudierten Form im „alten“ *.sxd-Format, wird die Form in eine 3D-Szene
konvertiert.
3D-Objekte bearbeiten
3D-Objekte drehen
Verfahren für „3D-Körper“
Mit dem von 2D-Objekten bekannten Drehen-Befehl können auch 3D-Objekte
bearbeitet werden. Durch die zusätzliche Achse gibt es bei der Bearbeitung von 3DKörpern allerdings einige Unterschiede (siehe Abbildung 10). Die Anwahl des Objektes
erfolgt genau wie bei 2D-Objekten.
3D-Objekte erstellen und bearbeiten
4
3D-Objekte bearbeiten
Abbildung 10: 3D-Objekte drehen
Sie können das Objekt um jede Achse (X, Y, Z) drehen. Die X- und Y-Achse sind parallel
zu den Kanten der Zeichenebene, die Z-Achse zeigt aus der Zeichenebene hinaus. Die
Achsenrichtungen lassen sich nicht ändern. Die Drehachsen werden nicht direkt
angezeigt, das Symbol
zeigt aber den Schnittpunkt aller drei Achsen.
Sie möchten …
Sie müssen ...
das Objekt um die X- und / oder Y-Achse
drehen.
den Mauszeiger auf das Objekt bringen. Mit
gedrückter linker Maustaste können Sie es
nun beliebig drehen. Bei den roten Punkten
an den Randmitten beschränken Sie die
Drehung auf eine Achse.
das Objekt um die Z-Achse drehen.
den Griff an einem der Eckpunkte (z) mit
gedrückter linker Maustaste bewegen. Eine
Drehung um die Z-Achse ist unabhängig von
der Einstellung des Drehwinkels im Dialog
Position und Größe.
den Achsenschnittpunkt verschieben.
das Symbol
in die gewünschte Position
schieben. Standardmäßig liegt der
Achsenschnittpunkt in der Mitte des
Objekts.
Diese Drehungen können sowohl mit der gesamten 3D Szene als auch einzeln mit den
darin enthaltenen 3D-Objekten durchgeführt werden.
Verfahren für „3D-Formen“
Objekte nach den Varianten 4 und 5 lassen sich mit der oben beschriebenen Methode
nur um die Z-Achse drehen. Diese Drehung wird dann an der zugrunde liegenden 2DForm durchgeführt. Daher können Sie wie bei 2D-Objekten auch, diese Drehung über
Format > Position und Größe > Drehwinkel als Zahl eingeben. Für die Drehung
um die X- und Y-Achse haben die Form-Objekte eine eigene Methode. Wenn Sie unter
Ansichten > Symbolleisten die Symbolleiste 3D-Einstellungen angewählt haben, wird
diese aktiv und Sie können mit den Schaltflächen 2 bis 5 (siehe Abbildung 11) das 3DObjekt in 5°-Schritten um die X und die Y-Achse drehen.
Abbildung 11: Die Symbolleiste 3D-Einstellungen
3D-Einstellungen für „3D-Körper“
Dialog 3D-Effekte – Generelle Schaltflächen
Für die 3D-Objekte, die mit den Versionen 1 bis 3 erzeugt wurden, bietet der Dialog
3D-Effekte umfangreiche Einstellmöglichkeiten. Um den Dialog zu öffnen, klicken Sie
mit der rechten Maustaste auf ein solches 3D-Objekt. In dem sich daraufhin öffnenden
3D-Objekte erstellen und bearbeiten
5
3D-Objekte bearbeiten
Kontextmenü wählen Sie dann die Schaltfläche 3D-Effekte
. Sie können diese
Schaltfläche auch in der Symbolleiste Standard aktivieren oder einer Symbolleiste (z.
B. Zeichnen) hinzufügen: Symbolleiste anpassen > hinzufügen > Bereich Extras
> 3D-Effekte. Das Dialogfenster kann wie beim Navigator oder beim FormatvorlagenFenster auch angedockt werden.
Die Einstellmöglichkeiten sind zu Themenbereichen zusammengefasst. Mit den
Schaltflächen im oberen Teil wechseln Sie zu den entsprechenden Dialogseiten. Um
dem Objekt die vorgenommenen Einstellungen zuzuweisen, müssen Sie immer auf die
Schaltfläche Zuweisen
klicken. Damit werden dann alle Einstellungen, auch die auf
den anderen Dialogseiten, auf das Objekt übertragen.
Abbildung 12: Register im Dialog 3D-Effekte
Anmerkung
Es wird nur der ausgewählte 3D-Effekt auf das Objekt übertragen.
Es erfolgt keine Umwandlung. So kann z. B. ein Zylinder durch die
Zuordnung eines 3D-Effektes nicht zu einem Ring werden, aber er
kann wahlweise als Holz oder Metall-Körper erscheinen. 2DObjekte werden durch Zuweisung eines 3D-Effektes
automatisch in 3D-Objekte umgewandelt!
Damit der Dialog bei Aktivieren eines Objekts die schon vorhandenen Einstellungen
des Objekts übernimmt, muss die Schaltfläche
gedrückt sein. Wenn Sie diese
deaktivieren, bevor Sie ein Objekt verlassen, und das nächste aktivieren, bleiben in
dem Dialog die Einstellungen dieses speziellen Objekts erhalten. Dies können Sie
nutzen, um sich einen „Favoriten“ anzulegen und dessen Einstellungen komplett auf
andere Objekte zu übertragen. Im Normalfall sollte die Schaltfläche aber gedrückt
sein.
Im unteren Bereich des Dialogs befindet sich eine weitere Zeile mit Schaltflächen
(siehe Abbildung 13 ), die in allen Seiten des Dialogs vorhanden ist.
Abbildung 13: Die Schaltflächen für die Geometrie-Umwandlung
Die ersten zwei entsprechen den Menübefehlen: Ändern > Umwandeln > In 3D/In
3D-Rotationskörper. Wenn der Dialog für ein 3D-Objekt aufgerufen wird, sind diese
Schaltflächen inaktiv. Mit der dritten Schaltfläche wird die Perspektive eingestellt.
Wandelt die ausgewählte 2D-Fläche in einen Extrusionskörper um.
Wandelt die ausgewählte 2D-Fläche in einen Rotationskörper um.
Schaltet zwischen Zentralprojektion und Parallelprojektion um.
Bei einer Zentralprojektion laufen parallele Kanten mit größer werdendem Abstand
auf einen gemeinsamen Punkt zu, wie es auf dem Symbol zu sehen ist. Bei
Parallelprojektion bleiben alle parallelen Kanten parallel, so wie Sie es von den
Schrägbildern aus dem Schulunterricht kennen. Die Umschaltung bezieht sich auf die
gesamte 3D-Szene.
3D-Objekte erstellen und bearbeiten
6
3D-Objekte bearbeiten
Bei Zenralprojektion (Abbildung 14) stellt Draw die Objekte mit drei Fluchtpunkten
dar. Die Parameter für die Zenralprojektion werden indirekt durch die
Kameraeinstellungen auf der Dialogseite Darstellung festgelegt.
Abbildung 14: Darstellung mit Zentralprojektion. Zur
Verdeutlichung sind die Fluchtlinien hinzugefügt.
Dialogseite Geometrie
Über diese Dialogseite (Abbildung 15 ) können Sie Veränderungen an der Geometrie
eines 3D-Objekts vornehmen. Sie erreichen die Seite über die Schaltfläche Geometrie
im oberen Bereich des Dialogs 3D-Effekte.
Abbildung 15: Das Register Geometrie
Im ersten Beispiel soll die Tiefe (Länge) eines Körpers verändert werden. Das ist nur
für einen Körper sinnvoll, den Sie durch Extrusion hergestellt haben. Zeichnen Sie
daher einen Kreis und wandeln sie ihn nach der Variante 1 in ein 3D-Objekt (flachen
Zylinder) um (siehe Abbildung 16 a und b).
Falls notwendig, wählen sie den soeben erzeugten Zylinder wieder an. Ändern Sie nun
den Parameter Tiefe auf 3,5 cm und klicken sie dann auf die Schaltfläche Zuweisen
.
Der Zylinder sollte nun Abbildung 16c gleichen.
3D-Objekte erstellen und bearbeiten
7
3D-Objekte bearbeiten
Abbildung 16: Umwandlung eines 2D-Objektes (a) in ein 3D-Objekt (b)
und Veränderung seiner Tiefe (c)
Dieser Parameter kann weder auf Rotationskörper noch auf eines der fertigen 3DObjekte angewendet werden.
Mit dem Parameter Kantenrundung bestimmen Sie, wie stark die Kanten des 3DObjekts abgerundet werden. Wählen Sie, falls notwendig, den soeben verlängerten
Zylinder an und ändern Sie dann den Parameter Kantenrundung auf 30%. Der Zylinder
müsste nun Abbildung 17 gleichen.
Abbildung 17: Kantenrundung a = 0% und b = 30%
Dieser Parameter ist auch interessant, wenn Sie Text in ein 3D-Objekt umwandeln.
Auch die Kantenrundung wirkt nur bei Extrusionsobjekten.
Der Parameter Tiefenskalierung bestimmt bei durch Extrusion gebildeten Körpern das
Größenverhältnis zwischen Vorder- und Rückseite des 3D-Körpers. Die Vorderseite
eines 3D-Objekts ist in diesem Zusammenhang immer die durch Extrusion entstandene
Fläche, die Rückseite ist die ursprüngliche Fläche des Objektes, also die 2D„Ausgangsfläche“, auch wenn das Objekt inzwischen beliebig gedreht wurde.
Standardmäßig ist diese Skalierung auf 100% eingestellt, was bewirkt, dass beide
Flächen dieselben Abmessungen bekommen. Wenn Sie eine Skalierung von 50%
einstellen, wird aus dem Zylinder ein Kegelstumpf (siehe Abbildung 18).
Abbildung 18: Zylinder mit 50% Tiefenskalierung
Der Durchmesser der Vorderseite beträgt jetzt 50% desjenigen der Rückseite. Es ist
natürlich auch möglich, die Vorderseite gegenüber der Rückseite zu vergrößern,
indem Sie einen Wert eingeben, der größer als 100% ist.
Bei Rotationskörpern werden durch diesen Parameter die Streckenanteile beeinflusst,
die parallel zur Rotationsachse liegen, sodass am Ende der Volldrehung der
eingestellte Prozentwert erreicht wird. Der Abstand zur Rotationsachse bleibt
unverändert. In der Abbildung 19 wurde eine Linie gedreht und als Tiefenskalierung
0% eingestellt.
3D-Objekte erstellen und bearbeiten
8
3D-Objekte bearbeiten
Abbildung 19: Tiefenskalierung bei einem Rotationskörper
Der Parameter Endwinkel steht nur bei Rotationskörpern zur Verfügung. Mit ihm
können Sie einen Rotationskörper in ein beliebig großes Segment „aufbrechen“, indem
Sie einen Winkel < 360° wählen. Abbildung 20 zeigt eine Halbkugel mit einem
Endwinkel von 270°.
Abbildung 20: Halbkugel mit einem Endwinkel von 270°
Mit dem Parameter Horizontale und Vertikale Segmente definieren Sie die Anzahl der
Segmente, aus denen Draw Kugeln und Rotationskörper1 aufbaut. Bei
Rotationskörpern werden im Wesentlichen die horizontalen Segmente berücksichtigt.
Die vertikalen Segmente haben dort Einfluss auf die Kantenrundung. In Abbildung 21
besitzt die linke Kugel jeweils 10 horizontale und vertikale Segmente, während die
rechte Kugel aus 25 Segmenten besteht. Je mehr Segmente Sie wählen, desto glatter
wird die Oberfläche, aber um so länger dauert es, bis das Objekt auf dem Monitor
erscheint. Standardmäßig werden Kugeln und Halbkugeln aus jeweils 24 Segmenten
erzeugt. Für eine quadratische Pyramiden benötigen Sie vier horizontale Segmente.
Abbildung 21: Kugel aus jeweils 10 Segmenten (links) und 25 (rechts)
Dieses sind jeweils Eigenschaften jedes einzelnen Objekts. Wenden Sie die Einstellung
auf eine 3D Szene an, werden alle darin enthaltenen Objekte entsprechend verändert.
Wenn Sie unausgefüllte Kreise oder sich schneidende Linien mit Füllungen
extrudieren, dann ist das Ergebnis wahrscheinlich nicht so wie Sie es erwarten. In
diesem Fall hilft die Schaltfläche „Doppelseitig“
im unteren Teil der Dialogseite.
Die Wirkung wird deutlich, wenn man für das Objekt die Linieneigenschaft von
unsichtbar auf durchgängig stellt und dadurch Kanten angezeigt werden. Ist der Effekt
eingeschaltet, wird die Darstellung aller Flächen erzwungen. Anderenfalls kann es
1
Um den Rechenaufwand und die zu speichernde Datenmenge zu begrenzen, werden Kreise oft durch
regelmäßige Polygone ersetzt. Wenn sie eine Kugel (oder einen Zylinder) aus 10 Segmenten in der Mitte
durschneiden, erhalten sie als Schnittfläche ein 20-Eck, bei Halbkugeln ein 10-Eck.
3D-Objekte erstellen und bearbeiten
9
3D-Objekte bearbeiten
vorkommen, dass einige Flächen keine Füllung erhalten (siehe Abbildung 22). Für
Linien ohne Füllungen ist der Effekt standardmäßig eingeschaltet und kann auch nicht
ausgeschaltete werden. Auch dieses ist eine Eigenschaft eines einzelnen Objektes.
Abbildung 22: links: ohne „doppelseitig“
Mitte: ohne „doppelseitig“ mit durchgängiger Linie
rechts: mit „doppelseitig“
Die Schaltflächen im Abschnitt Normalen erlauben es Ihnen, die Normalen des 3DObjekts zu modifizieren. Eine Normale ist eine gerade Linie, die senkrecht auf der
Oberfläche eines Objektes steht. (Genauer ein Vektor, der senkrecht von der
Oberfläche startet und von Innen nach Außen zeigt.) Die Abbildung 23 zeigt einige
Normalen auf einer Kugel aus jeweils 10 Segmenten.
Abbildung 23: Normalen(-Vektoren) einer
3D-Kugel mit 10 Segmenten
Über die Normalen kann die Darstellung der Objektoberflächen und die
Wechselwirkung von Farben, Texturen und Licht gesteuert werden. Sie können so
beeinflussen, wie die Oberfläche gerendert wird.
Die drei Schaltflächen in der ersten Zeile wirken wie „Entweder–Oder–Schalter“. Es
kann immer nur ein Effekt zugewiesen werden, bzw. ein zugewiesener Effekt kann
durch „Drücken“ eines anderen Schalters geändert werden. Die Einstellung gilt für
jedes Objekt separat. Die restlichen Schaltflächen sind „normale“ An- /Aus- Schalter.
Folgende Effekte stehen zur Verfügung:
Objektspezifisch: Das Objekt wird so gerendert, dass abhängig von seiner Form
das beste Ergebnis erreicht wird. Die einzelnen Segmente werden dabei nicht
verändert, ihre „Kanten“ sind aber kaum sichtbar.
Flach: Die Oberfläche des 3D-Objekts wird in einzelne Polygone aufgeteilt, deren
„Kanten“ deutlich zu erkennen sind. Jedes Polygon wird in einem einheitlichen
Farbton dargestellt.
Kugelförmig: Es wird zunächst die Darstellung für eine das Objekt umgebende
Kugel berechnet. Das Ergebnis wird dann auf das Objekt projiziert. Diese
Darstellungsart erzeugt eine weiche Oberfläche bei der die „Kanten“der einzelnen
Segmente noch weicher abgerundet sind als bei „objektspezifisch“ (siehe
Abbildung 24). Bei Flächen, die spitz aneinander stoßen, wird die Beleuchtung
aber nicht realistisch dargestellt.
3D-Objekte erstellen und bearbeiten
10
3D-Objekte bearbeiten
Normalen umkehren: Bewirkt eine Umkehrung der Beleuchtungsrichtung.
Dadurch wird die Innenseite des Körpers als Außenseite behandelt. Diese
Einstellung gilt für jedes Objekt separat.
2-seitige Beleuchtung: Die Beleuchtung wird auch für die Innenseite des Objekts
berechnet. Anderenfalls wird der Beleuchtungswert der Außenseite einfach auf die
Innenseite übertragen. Diese Einstellung ist interessant für offene Objekte.
Es ist eine Eigenschaft der 3D-Szene und wirkt daher für alle enthaltenen Objekte.
Abbildung 24: Zylinder mit 10 Segmenten
a = objektspezifisch, b = flach, c = kugelförmig gerendert
Die folgende Tabelle zeigt das Zusammenwirken von zweiseitiger Beleuchtung und
Umkehr der Normalen.
Die Lichtquelle ist rechts.
Normalen
nicht umkehren
Normalen umkehren
keine zweiseitige
Beleuchtung
mit zweiseitiger
Beleuchtung
Dialogseite Darstellung
Diese Dialogseite (siehe Abbildung 25) bietet Funktionen für das Shading (engl. shade
=Farbton, to shade=schattieren) der Objektoberflächen, Hinzufügen von Schatten und
Einstellen der Kamera.
Shading nennt man das (Rendering-) Verfahren, um gekrümmte 3D-Flächen durch
Berücksichtigung der Lichtverhältnisse darzustellen. Die Flächen werden dazu in
kleine dreieckige Segmente unterteilt. Draw bietet für diesen Effekt die drei
wichtigsten Verfahren an: Flat, Phong and Gouraud. Die gewählte Einstellung gilt
einheitlich für alle Objekte der 3D-Szene.
3D-Objekte erstellen und bearbeiten
11
3D-Objekte bearbeiten
Abbildung 25: Das Register „Darstellung“
•
Flat ist das schnellste und einfachste Verfahren. Für jedes einzelne Segment
wird abhängig von den Lichtverhältnissen und der Richtung der Segmentfläche
ein spezieller Farbton ermittelt. Dieser wird für die gesamte Segmentfläche
benutzt. Die Segmentierung ist so deutlich sichtbar.
•
Phong ist das zeitaufwändigste Verfahren. Beim Phong-Verfahren wird von den
Normalen der Segmentkanten ausgehend für jedes Pixel die zugehörige
Normale durch Interpolation ermittelt. Dadurch erscheinen die Segmentflächen
gebogen und die Segmentübergänge sind nicht mehr sichtbar.
•
Gouraud ist ein relativ schnelles Verfahren. Es ermittelt die Farbwerte für die
Segmentecken und berechnet für jeden Pixel der Darstellung die Farbwerte
durch lineare Interpolation. Die Segmentkanten sind noch erkennbar, allerdings
wesentlich schwächer als beim Flat-Verfahren. Das Gouraud Verfahren
berücksichtigt nur Lichtreflektion an diffus reflektierenden Flächen (Streuung).
Abbildung 26: Flat-, Phong- und Gouraud- Shading
In Abbildung 26 wurde die linke Kugel mit dem Flat Shading-Verfahren gerendert, die
mittlere mit Phong und die rechte mit Gouraud. Die Qualität des Flat-Verfahrens
unterscheidet sich deutlich von den beiden anderen. Die Unterschiede zwischen Phong
und Gouraud sind geringer. Beim Gouraud-Verfahren kann man die Segmente noch
schwach erkennen und die so gerenderten Objekte haben etwas weniger „Glanz“ als
beim Phong-Verfahren.
Alle drei Verfahren gehen von dem Pixel in der Darstellung aus und sind daher nicht in
der Lage, Schatten und Spiegelungen innerhalb der Szene zu berechnen, so wie dies
bei Raytracing-Verfahren möglich ist.
3D-Objekte erstellen und bearbeiten
12
3D-Objekte bearbeiten
Mit der Schaltfläche Schatten
können Sie 3D-Objekte mit einem Schatten
versehen. Durch Änderung des Papierwinkels können Sie die Form des Schattens
beeinflussen (siehe Abbildung 27). Bei der linken Kugel beträgt der Neigungswinkel 0°
(das Papier steht senkrecht hinter dem Objekt), bei der rechten Kugel ist es um 45°
geneigt.
Abbildung 27: Schatten bei unterschiedlicher Papierneigung,
Die Form und Größe des Schattens sind von den Beleuchtungsverhältnissen abhängig.
Diese können auf der Dialogseite Beleuchtung eingestellt werden. Mehrere
Lichtquellen werden jedoch nicht unterstützt. Die Eigenschaft Schatten zu werfen
kann zwar bei jedem Objekt einzeln eingestellt werden. Aber es wird nur der Schatten
der gesamten Szene als Einheit dargestellt.
Sie können auch bei den einzelnen Objekten über deren Eigenschaft „Fläche“ einen
Schatten einstellen. Er wird dann mit der dort gewählten Farbe gezeigt, jedoch gemäß
der für die Szene eingestellten Beleuchtung. Dadurch sind auch farbige Schatten
möglich.
Im Feld Kamera können Sie die Optionen für die virtuelle Kamera festlegen. Die
Einstellungen für die Kamera beziehen sich nur auf die Darstellung in
Zentralprojektion und gelten für die gesamte 3D-Szene. Mit dem Parameter
Entfernung können Sie den Abstand zwischen Kamera und Szene einstellen. Der
Anfangswert ist bei einem Extrusionskörper so groß wie die automatisch gesetzte
Tiefe. Bei gleich langen Kanten vorn und hinten, wird bei größeren Entfernungen der
relative Unterschied in der Darstellung geringer. Der Standardwert für den Parameter
Brennweite beträgt 10 cm. Er hat die gleiche Bedeutung wie bei Fotokameras.
Größere Brennweiten wirken wie Teleobjektive, kleinere wie Weitwinkelobjektive. Wie
sich die Veränderungen der Kameraeinstellungen auswirken, zeigt Abbildung 28 .
Abbildung 28: Auswirkung der Kameraeinstellungen
Bild 28a zeigt das 3D-Objekt mit den Standardeinstellungen. Die einzelnen
Änderungen sind in der folgenden Tabelle dokumentiert.
a
b
c
d
Entfernung:
0,81 cm
3,81 cm
0,81 cm
0,81 cm
Brennweite:
10 cm
10 cm
5 cm
15 cm
3D-Objekte erstellen und bearbeiten
13
3D-Objekte bearbeiten
Dialogseite Beleuchtung
Mit der Seite Beleuchtung (Abbildung 29) definieren Sie, wie ein 3D-Objekt beleuchtet
wird. Die Einstellung gilt für alle Objekte einer Szene.
Abbildung 29: Dialogseite Beleuchtung
Sie können eine Szene maximal mit acht Lichtquellen gleichzeitig beleuchten. Für jede
dieser Lichtquellen kann eine eigene Lichtfarbe und die Position zur Szene definiert
werden. Die Lichtquellen werden durch acht kleine Glühbirnen symbolisiert. Wenn Sie
1
dieses Untermenü aufrufen, „leuchtet“ die erste Glühbirne
. Dieses Symbol
funktioniert wie ein Druckschalter. Mit dem ersten Mausklick wird der Schalter
angewählt
und mit dem zweiten gelangen Sie in den Einstellmodus dieser
Lichtquelle (siehe Abbildung 30)
In der Auswahlliste neben den Symbolen kann die Farbe der aktiven Lichtquelle
ausgewählt werden. Bei Bedarf kann über die Schaltfläche
eine Palette geöffnet
werden, mit der Sie eigene Farben zusammenstellen können. Dieser Dialog erlaubt
auch ein Ändern der Helligkeit unter Beibehalten des Farbwertes. Für die erste
Lichtquelle sollte der neutrale Farbton (Standard ist weiß) beibehalten werden, bei
mehreren Lichtern ist ein Reduzieren der Helligkeit angebracht.
1
Es muss immer mindestens eine Lichtquelle aktiv sein, da sonst die Render- und Shading-Funktionen nicht
richtig arbeiten können.
3D-Objekte erstellen und bearbeiten
14
3D-Objekte bearbeiten
Abbildung 30: Einstellen der Lichtquelle
In der rechten unteren Ecke des Menüs ist die Lichtquelle abgebildet. Mit dem
senkrechten Schieberegler können Sie den Einfallswinkel des Lichtes regulieren, mit
dem waagerechten die Lampe um das Objekt drehen. Alternativ können sie mit der
Maus auf den Lichtpunkt klicken und ihn mit gedrückter Maustaste verschieben (siehe
Abbildung 31). Mit einem Klick auf das kleine Quadrat rechts unten wechseln Sie in
der Vorschau zwischen einer Kugel und einem Würfel.
Abbildung 31: Verschiebung der
Lichtquelle
Um die geänderten Einstellungen auf das ausgewählte Objekt zu übertragen, klicken
Sie auf die Schaltfläche Zuweisen .
Durch die Benutzung weiterer Lichtquellen lassen sich beeindruckende Effekte
erzielen.
3D-Objekte erstellen und bearbeiten
15
3D-Objekte bearbeiten
Abbildung 32: Beleuchtung mit 3 unabhängigen Lichtquellen
In Abbildung 32 hat der Ring die Lichteinstellung aus Abbildung 31 mit der
Standardfarbe Weiß. Zusätzlich wurde er mit der Farbe Magenta angestrahlt und von
unten links auch noch mit Gelb. Die Anzahl und die Position der Lichtquellen wird in
dem Fenster unten rechts angezeigt. Welche Lichtquellen benutzt wurden, erkennt
man an den „leuchtenden“ Symbolen
.
Um die Wirkung der zugewiesenen Lichteffekte zu überprüfen, können diese auch
„ausgeblendet“ werden. Wenn Sie (bei angewähltem Objekt) mit der Maus auf eine
leuchtende Glühbirne klicken, wird diese „ausgeschaltet“ . Diese neue Eigenschaft
muss dann der Szene zugewiesen werden. Mit einem erneuten Mausklick kann die
Lichtquelle wieder „eingeschaltet“ werden. Auch diese Änderung muss der Szene
wieder zugewiesen werden.
Zusätzlich können Sie auch noch das Umgebungslicht einstellen. Die Auswahl dieser
Lichtfarbe erfolgt genauso wie bei den Lichtquellen.
Dialogseite Texturen
Texturen sind Rastergrafiken (Bitmaps), die Objekten als Eigenschaft ihrer Oberfläche
zugewiesen werden können. Jedes Objekt einer 3D-Szene kann seine eigene Textur
besitzen.
Sie können über die Eigenschaft „Fläche“ auch 3D-Objekten – genau wie 2D-Flächen –
sowohl Rastergrafiken als Textur zuweisen, als auch deren Oberfläche mit
Farbverläufen oder Schraffuren füllen. Die entsprechenden Arbeitsabläufe sind im
Kapitel 4, Objekte bearbeiten Teil 2, dieses Handbuches beschrieben. Wenn die
Flächeneigenschaft des Objekts auf „Farbe“ steht, ist die Dialogseite Textur inaktiv.
Wenn die Textur nicht gekachelt oder angepasst wird und kleiner ist als das Objekt,
wird der restliche Körper mit der auf der Dialogseite Material eingestellten
Objektfarbe gezeigt.
In der ersten Zeile der Dialogseite (Abbildung 33 ) sind zwei Schalter (Art) mit denen
Sie zwischen schwarz-weißer und farbiger Darstellung wechseln können (siehe
Abbildung 34)
3D-Objekte erstellen und bearbeiten
16
3D-Objekte bearbeiten
Abbildung 33: Das Textur-Menü
Abbildung 34: a = Ausgangskörper, b = Textur - farbig, c= Textur schwarz- weiß
Mit den beiden Schaltern in der Zeile Modus können Sie steuern, ob die Textur des
angewählten Objekts mit Licht und Schatten dargestellt wird (Schalter 2), oder nicht
(Schalter 1/ siehe Abbildung 35). Durch die Zuordnung von Licht und Schatten wirkt
die Darstellung realistischer.
Abbildung 35: Textur ohne (a) und mit (b) Licht- und Schatteneffekt
Projektion X / Y
Mit den jeweils drei Schaltflächen legen Sie fest, wie die Textur für diese
Koordinatenachsen auf das Objekt projiziert werden soll. Die Standardeinstellung
objektspezifisch ergibt im Normalfall das beste Ergebnis. Beispiele sind weiter unten
dargestellt.
Objektspezifis
ch
Die Textur wird automatisch an die Form und Größe des
Objekts angepasst.
3D-Objekte erstellen und bearbeiten
17
3D-Objekte bearbeiten
Parallel
Die Textur wird parallel zur Achse auf das Objekt projiziert.
Dadurch ist sie auf der Rückseite spiegelbildlich.
Kreisförmig
Die Achse des Texturmusters wird kugelförmig um das Objekt
gelegt.
Bei einem Rotationskörper zählt die Drehachse als Z-Achse und der Mantel als
X-Richtung, bei einem Extrusionskörper zählt die Extrusionsrichtung als Z-Achse und
die Fläche, die extrudiert wurde als X-Richtung. Dadurch ergeben sich
unterschiedliche Positionen der Textur, je nachdem wie der Körper hergestellt wurde.
OpenOffice.org
Projektion X
Projektion X
Projektion X
Flächenfüllung
ohne Kacheln,
mit Anpassen
Projektion Y
Projektion Y
(Unterschied ist gering)
Vorder- und Rückseite
Abbildung 36: Zylinder als Rotationskörper
OpenOffice.org
Projektion X
Projektion X
Projektion X
Flächenfüllung
ohne Kacheln,
mit Anpassen
Projektion Y
Projektion Y
(Unterschied ist gering)
Ober- und Unterseite
Abbildung 37: Zylinder als Extrusion
3D-Objekte erstellen und bearbeiten
18
3D-Objekte bearbeiten
Der Schalter Filtern
schaltet einen Unschärfe-Filter ein. Er kann leichte Störungen
und Fehler in der Textur verwischen.
Dialogseite Material
Auf dieser Seite (Abbildung 38) können Sie 3D-Objekten bestimmte
Materialeigenschaften zuordnen. In der Auswahlliste Favoriten können Sie aus den
gebräuchlichsten Materialien auswählen (Abbildung 39).
Abbildung 38: Die Dialogseite „Material“
Abbildung 39: Die Favoriten (von links nach rechts)
:
Metall, Gold, Chrom, Plastik und Holz
Mit den einzelnen Farbparametern können Sie zusätzliche Effekte einstellen. Die
Bedienung dieser Parameter entspricht der auf der Dialogseite Beleuchtung.
Materialien und Texturen können miteinander kombiniert werden. Bei allen
Einstellungen wird das Material eines Körpers ja nur simuliert und es erfordert einiges
Probieren, um die gewünschte Wirkung zu erzielen. Tipp: Benutzen Sie in den
einzelnen Farben nicht zu hohe Helligkeitswerte, weil sich diese addieren und
schließlich alles weiß aussieht.
3D-Objekte erstellen und bearbeiten
19
3D-Objekte bearbeiten
Die Leuchtfarbe erhellt die im Schatten
liegenden Teile des Objekts. Der Körper
leuchtet aus sich heraus.
Bei Texturen wird die Leuchtfarbe mit den
weißen Farbpartien der Textur kombiniert.
Links mit Leuchtfarbe schwarz, d. h. ohne
Leuchtfarbe, rechts mit Leuchtfarbe
Hellgrün.
Mit der Glanzpunkt-Farbe wird das
Reflexionsvermögen des Oberfläche
simuliert. Die Position des Glanzpunkts
richtet sich nach der ersten Lichtquelle.
Links: Setzen Sie die Glanzpunkt-Farbe
gleich der Objektfarbe und die GlanzpunktIntensität auf einen geringen Wert, um den
Eindruck eines matten Körpers zu erzeugen.
Rechts: Setzen Sie die Glanzpunkt-Farbe
gleich der Farbe der Lichtquelle, um einen
glänzenden Körper zu erzeugen.
Metallische Oberflächen und Glas lassen sich nicht so gut simulieren, weil dort der
Materialeindruck im Wesentlichen durch Spiegelungen hervorgerufen wird. Solche
kann OpenOffice.org leider nicht berechnen.
3D Einstellungen für „3D-Formen“
Das Aussehen der Form-Objekte wird über die Symbolleiste 3D-Einstellungen (siehe
Abbildung 40) eingestellt. Das Konzept unterscheidet sich völlig von den oben
besprochenen Objekten in den 3D-Szenen. Der oben beschriebene Dialog 3D-Effekte
darf für Form-Objekte nicht benutzt werden. Falls es Ihnen aus Versehen passiert,
können Sie diese falsche Formatierung mit Format > Standardformatierung
entfernen.
Abbildung 40: Die Symbolleiste 3D-Einstellungen
Mit den rechten Schaltflächen der Symbolleiste können Sie die Extrusionstiefe und
Perspektive, Beleuchtung und Materialbeschaffenheit sowie die Extrusionsfarbe
festlegen. Es sind Abreißleisten, die sich bei Klick auf das kleine schwarze Dreieck
öffnen. Die einzelnen Funktionen ergeben sich aus den Tooltips, bzw. sind
selbsterklärend. Im Gegensatz zu dem Dialog 3D-Effekte der 3D-Szenen, brauchen Sie
nichts „zuzuweisen“. Jede Aktion wird sofort wirksamund Sie können die Veränderung
direkt beobachten.
Anmerkung
Das Programm kommt manchmal (die Ursachen ist nicht genau
feststellbar)„aus dem Tritt“. Dann hilft es, das Form-Objekt mit
Format > Standardformatierung zurückzusetzen. Einer der
Gründe ist wohl, dass man auf ein Form-Objekt den alten 3DKörper-Effekt-Dialog anwendet. Siehe auch Issue 67732
3D-Objekte erstellen und bearbeiten
20
3D-Objekte bearbeiten
Hier nun einige Beispiele:
Tiefe
links:
0,3cm (benutzerdefiniert)
rechts:
1cm (Auswahl)
Richtung
Es sind Säulen dargestellt, die senkrecht zur
Zeichenebene stehen.
links:
5 cm hoch, Parallelprojektion
Mitte:
10 cm hoch, Perspektive
rechts:
Unendlich, Perspektive
Beleuchtung
Die Lichtfarbe ist gar nicht einstellbar, die
Helligkeit nur in drei Stufen, einige Einstellungen
werden noch nicht korrekt dargestellt.
links:
von links unten, abgeblendet
mitte:
von links unten, hell
rechts:
von rechts unten, normal
Oberfläche
Auch bei der Oberfläche sind nur vier fest
eingestellte Varianten möglich. Zurzeit werden nur
Drahtrahmen und Matte richtig dargestellt.
links: Drahtrahmen
rechts: Matte
Sie können für die Fläche auch Farbverlauf,
Schraffur oder Bitmap festsetzen, allerdings werden
diese nur auf die extrudierte Fläche angewendet, die
Seiten bleiben in der Objektfarbe.
3D-Objekte erstellen und bearbeiten
21
3D-Objekte bearbeiten
3D-Farbe
Hiermit wählen Sie die Farbe für die durch das
Extrudieren entstandenen Seitenflächen.
Das Symbol zeigt die Farbe des gerade gewählten
Form-Objekts.
Objekte in 3D Szenen kombinieren
Beim Erstelllung von 3D-Objekten wurde schon erwähnt, dass die eigentlichen
Extrusions- und Rotationsobjekte in einer Gruppierung liegen, die in der Statusleiste
als 3D Szene angezeigt wird. Dies gibt Ihnen die Möglichkeit, mehrere dieser Objekte
in einer Gruppe zusammenzufassen. Andere Objekttypen können Sie leider nicht
aufnehmen. Die Handhabung der Gruppe erfolgt wie an anderen Stellen auch über
Ändern > Gruppierung betreten und Ändern > Verlassen, siehe auch Kapitel 5, im
Abschnitt „Objekte gruppieren“.
Als Beispiel soll eine Spielfigur hergestellt werden.
Erzeugen Sie zunächst die beiden Objekte
unabhängig voneinander. Das spätere
Ausrichten zueinander ist einfacher, wenn Sie
bei beiden Objekte auf Parallelprojektion
umschalten und die Objekte in eine aufrechte,
gerade Position drehen.
Klicken Sie auf die Kugel und übernehmen Sie
die Szene mit Bearbeiten > Kopieren in die
Zwischenablage. Wenn Sie sicher sind, dass
Sie das Original nicht mehr benötigen, können
Sie auch Bearbeiten > Ausschneiden
benutzen. Anderenfalls schieben Sie die Kugel
anschließend etwas beiseite.
Klicken Sie nun auf den Kegel. In der
Statusleiste sehen sie „3D Szene markiert“.
Betreten sie diese Gruppierung. Sie sehen,
dass wie üblich die Elemente, die nicht zur
Gruppe gehören, etwas heller dargestellt
werden.
Benutzen Sie dann Bearbeiten > Einfügen.
Jetzt werden die Objekte (nicht die ganze
Szene) aus der Zwischenablage in diese Szene
eingefügt.
3D-Objekte erstellen und bearbeiten
22
3D-Objekte bearbeiten
An der alten Position der Kugel ist jetzt eine
neue Kugel hinzugekommen, die zu der Szene
gehört. Diese neue Kugel können Sie nun
anfassen und zu dem Kegel verschieben.
Verlassen Sie anschließend die Gruppierung.
Sie sehen hier, dass sich 3D-Objekte beim
Kombinieren durchdringen. Es gibt also
keinen Stapel wie bei 2D-Objekten.
Nun müssen Sie die Objekte zueinander
ausrichten. Sie können ein Objekt nicht vor
oder zurück bewegen, sondern nur parallel
zur Zeichenebene. Sie müssen daher die
gesamte Szene zunächst um 90° drehen.
Betreten Sie die Gruppierung wieder und
richten die Objekte zueinander aus. Achten Sie
mit einem Blick in die Statusleiste darauf,
welches Objekt markiert ist. Mit der
Tabulatortaste können Sie zum nächsten
Objekt wechseln, falls dies mit der Maus nicht
gelingen sollte. Verlassen Sie dann die
Gruppierung wieder.
Nun können Sie die gesamte 3D-Szene drehen
und ihre Spielfigur von allen Seiten
betrachten.
Anregungen für eigene Experimente
Alle Beispiele benutzen Objekte in 3D Szenen.
S chulte
3D-Objekte erstellen und bearbeiten
Bei einem 2D-Objekt mit Beschriftung,
werden beim Extrudieren die Buchstaben als
separate Objekte generiert und sie haben
eine größere Extrusionstiefe.
23
3D-Objekte bearbeiten
3D-Objekte vom Typ „Form“ können per
Schaltfläche als so genanntes Drahtmodell
dargestellt werden. Für die anderen 3DObjekte erreichen Sie diese Darstellung,
wenn Sie die Flächenfüllung auf „keine“
stellen und den Linienstil auf „durchgängig“.
Das Beispiel zeigt eine Pyramide als
Extrusionsobjekt.
Wenn Sie mehrere 2D-Objekte gemeinsam
markieren – nicht gruppieren – und
extrudieren, werden sie gemäß ihrer
Stapelreihenfolge mit verschiedenen Tiefen
umgewandelt, so dass das vormals obere
Objekt erhaben erscheint.
Nutzen Sie für 2D-Objekte die Option
Ändern > Formen >
Verschmelzen/Subtrahieren/ Schneiden, um
komplexe Objekte zu gestalten. Die
Ergebnisse lassen sich ebenfalls extrudieren
und rotieren.
Linien erzeugen beim Rotieren Hohlkörper.
Benutzen Sie eine helle Linienfarbe. Durch
eine hohe Anzahl vertikaler Segmente wird
der Übergang zum Boden relativ
scharfkantig. Vergessen Sie nicht,
„zweiseitige Beleuchtung“ einzuschalten.
Die Transparenz der Schale wird in den
Flächeneingenschaften des Körpers
eingestellt. Zur Wirkung kommt sie aber erst
dann richtig, wenn der transparente Körper
mit anderen Körpern kombiniert wird.
Die Farbschattierungen der Frucht wurden
durch mehrere Lichtquellen erzeugt, sind
also nicht „echt“. Sie drehen sich nicht mit,
wenn die Szene gedreht wird.
3D-Objekte erstellen und bearbeiten
24
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement