NISTread - Quick Start Guide

NISTread - Quick Start Guide
NISTread
For R&S®ZVA/B/T or R&S®ZNB/C
Quick Start Guide
Quick Start Guide
Test and Measurement
1175.6584.02 – 01
The Quick Start Guide describes the usage of the NIST read software with the following R&S Vector
Network Analyzer models:
,
,
,
,
,
,
,
,
,
,
,
,
,
,
,
,
,
,
,
,
®
R&S ZVA8, order no. 1145.1110.08/10
®
R&S ZVA24, order no. 1145.1110.24/26
R&S®ZVA40, order no. 1145.1110.40/42
R&S®ZVA50, order no. 1145.1110.50/52
R&S®ZVA67, order no. 1305.7002.02/04
R&S®ZVA80, order no. 1312.6750.02/03/04
R&S®ZVA110, order no. 1312.7004.08/10
R&S® ZVB4, order no. 1145.1010.04/06
R&S® ZVB8, order no. 1145.1010.08/10
R&S® ZVB14, order no. 1145.1010.14
R&S® ZVB14, order no. 1145.1010.17/19
R&S® ZVB20, order no. 1145.1010.20
R&S® ZVB20, order no. 1145.1010.23/25
R&S® ZVT8, order no. 1300.0000.08
R&S® ZVT20, order no. 1300.0000.20
R&S® ZNB4, order no. 1311.6010.22
R&S® ZNB4, order no. 1311.6010.24
R&S® ZNB8, order no. 1311.6010.42
R&S® ZNB8, order no. 1311.6010.44
R&S® ZNC3, order no. 1311.6004.12
Rohde&Schwarz would like to thank the open source community for their valuable contribution to embedded computing.
© 2012 Rohde & Schwarz GmbH & Co. KG
81671 Munich, Germany
Printed in Germany – Subject to change – Data without tolerance limits is not binding.
R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.
Trade names are trademarks of the owners.
NISTread
Table of Contents
Table of Contents
1 Introduction......................................................................................... 3
1.1
Installation on a R&S VNA ..........................................................................................4
1.2
Installation and setting up the software on any external PC ..................................5
2 Configuring the software ................................................................... 6
2.1
Storing an external system error correction to the VNA .........................................7
2.2
Remote controlling the software................................................................................7
Quick Start Guide 1175.6584.02 - 01
1
NISTread
Introduction
1 Introduction
NISTread is a software program that provides an interface between the R&S ZVA/B/T
or ZNB/C Vector network analyzers and NIST software programs such as
MultilineTRL.
The user may define various filenames for calibration standards to be measured in an
appropriate order as to input them into the desired software. The software may be
installed on the network analyzer or on any PC running a Microsoft Windows operating
system (XP or later).
If installed on a separate PC NISTread will establish a connection to the VNA by
means of VXI11, either GPIB or LAN. If the software is installed on the VNA itself it can
be fully remote-controlled. This includes setting the parameters and taking
measurements.
Installation of the software
You may choose to install the software either on the VNA or on a separate PC. For the
installation procedure, please refer to the appropriate section. The software is using
the .NET framework V2.0 and requires this framework to be installed as a prerequisite.
Hence we provide two different types of installers either with or without the .NET
framework package installed. The version not including the *.NET Framework is
named “_NoNET_” whereas the full installer has no additional information in the
filename. However, it is safe to start with the “_NoNET_” installer as the installer will
check whether all requirements are met during the installation process. It will also list
the .NET package found on the target machine for reference and request a later
package to be installed if necessary (s. figure 1). In the latter case, please choose the
full installer or download the .NET framework from the Microsoft website.
Fig. 1 Installer types and .NET version check during installation.
Quick Start Guide 1175.6584.02 - 01
3
NISTread
Introduction
1.1 Installation on a R&S VNA
If installed on a R&S Network Analyzer directly you may choose to put a link to the
software in the “External Tools” menu of the analyzer’s firmware to easily access the
software during measurements. If you want this, please make sure that the checkmark
“External Tools Shortcut” is set in the second installer page (s. figure 2). The installer
will put no other shortcuts to the desktop or start menu. Hence the alternative way to
start the software is to go to the specified installation directory (s. figure 2) and launch
the application by doubleclicking on “NISTread_.exe”.
Fig. 2 NISTread installerpage 2 and 3.
After installation including the external tools link you may access the software by
choosing “System>External Tools” from the ZVA/B/T firmware (s. figure 3).
Fig. 3 System/External Tools menu within ZVA/B/T firmware.
Choosing either start method the software will connect to the ZVA automatically so no
additional action is required to link the software to the instrument's firmware. You have,
however, to make sure that the instrument’s firmware is started before running the
additional software.
Quick Start Guide 1175.6584.02 - 01
4
NISTread
Introduction
1.2 Installation and setting up the software on any
external PC
If installed on an external PC make sure that the checkmark “External Tools Shortcut”
is not checked in the second installer page (s. figure 2) as this is only helpful if the
software is installed in combination with the network analyzer firmware. The installer
will put no other shortcuts to the desktop or start menu. Hence the software has to be
started from the specified installation directory (s. figure 2) by double clicking on
"NISTread.exe".
To establish a connection the VXI11 protocol layer has to be installed on the PC as
well. This is automatically the case if you are using a National Instruments GPIB
interface card on this PC already. If this is not the case, please refer to the installation
manual of any National Instruments control software to install this software on the PC
correctly. It is a prerequisite to run the software properly.
Please make sure that the firmware of the instrument you want to connect to is already
running.
Start the software by double clicking it in the installation directory (see above). Go to
the menu “Device Config” and choose an appropriate connection (i.e. GPIB or LAN) to
the instrument.
Click connect. If the connection is established successfully, the button will turn green
while changing its caption to “initialized”. The ID-string of the instrument is also shown
in the dialogue (s. figure 4). The software is now ready to use.
Fig. 4 Device Config dialogue used to connect to a network analyzer.
Quick Start Guide 1175.6584.02 - 01
5
NISTread
Configuring the software
2 Configuring the software
The purpose of this software is to connect to the network analyzer as to retrieve raw
waves and store them in touchstone files. The filename will be composed of two parts.
The “path” is to be set up in the Options tab (s. figure 5) while the name of the file to be
output has to be set in the main page.
Fig. 5 Dialogues to enter path (above) and filename (below) for data-dump.
In addition you may choose this measurement to be “Normal” or “Through” by selecting
the appropriate action from the combobox next to the filename.
In the configuration “Normal” the software will export a touchstone (S2P) file that
consist of all four S-parameters without any correction applied to the results.
Choosing the configuration “Through” will additionally save a touchstone file that
includes the switch-terms of the analyzer. The additional file is denoted by an
Quick Start Guide 1175.6584.02 - 01
6
NISTread
Configuring the software
preceeding “G” in the filename that is added automatically.
In any case a S2P file will be dumped into this filename.
The result files will be written to the path given in the options tab (s. figure 5).
2.1 Storing an external system error correction to the VNA
Once the calibration is performed using an external software like MultiLineTRL or
STATISTICal this data may be transferred to the VNA using NISTread. This can be
done either manually or by means of remote commands.
To transfer the data make sure that NISTread has already established a connection to
the VNA. Enter the filename of the system error coefficients using its full path into the
“Source Path” Textbox (s. figure 5). Enter the desired power level in dBm as well as
the IF-bandwidth settings in the appropriate data fields and click on “Copy to VNA”.
Alternatively you may use the remote commands as stated below.
The system error coefficients will be transferred to the VNA and the calibration is
instantly activated.
2.2 Remote controlling the software
If installed on a R&S network analyzer the software can also be controlled remotely via
the instruments firmware.
To do this you may send a SCPI command to the VNA following this syntax:
PROG:INIM '<PathToMacroAndMacroName>', '<Command> "<Parameter> "'
The default variable setting of <PathToMacroAndMacroName> is C:\Program
Files\NISTread\NISTread.
Please note that this variable has to be set according to the installation directory
combined with the macro name neglecting its file extension.
Command may be anything from the following list where a parameter has to be added
if necessary:
Command
Parameter
Description
ChangeFN1
(you may choose 1..8 to set the filenames)
Filename 1
Specify the filename to be listed in the
first textbox (e.g. Test.s2p)
ChangeMeas1
(you may choose 1..8 to set the
measurement procedures)
Normal|Through
Whether to measure “Normal” or
“Through”
Display
On|Off
Toggles the display on/off during the
acquisition of data
Quick Start Guide 1175.6584.02 - 01
7
NISTread
Configuring the software
Command
Parameter
Description
MeasureThrough
Filename
Starts a “Through” measurement and
dumps the data to the filename given
MeasureNormal
Filename
Starts a “Normal” measurement and
dumps the data to the filename given
SourcePowerLevel
Source Power Level
in dBm
Set the current source power level
IFBW
IF-bandwidth in Hz
Set the current IF-bandwidth
SECFilename
Filename (Full path)
Set the full path to the file containing
the system error correction
coefficients
TransferSEC
No parameter
Transfer the system error correction
data to the VNA
The result of any command being sent to the macro can be checked looking at the
Debug/Command Windows.
Upon every command that is received by the macro it will list
“A new command has been sent.”
You will also receive an information whether this command has been processed
correctly or not (s. figure 6).
Fig. 6 Response of NISTread’s remote engine to a valid (top) and invalid command (bottom).
In case you do not see any response, please check that the following prerequisites are given:
O
Option Linkbridge is enabled in the Options tab (s. figure 7)
O
The macro states “File surveillance is started…” on the main page
O
The filename/macroname is set correctly in the SCPI command
Fig. 7 Troubleshooting information
If the command is not understood, please check the syntax.
For any additional questions, please contact your local R&S representative.
Quick Start Guide 1175.6584.02 - 01
8
Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertising