Cisco | uBR904 | Specifications | Cisco uBR904 Specifications

Bridging and Routing Features for the
Cisco uBR904 Cable Modem
The following sections are provided:
•
•
•
•
•
•
•
•
•
Feature Summary, page 1
Prerequisites, page 4
Supported MIBs and RFCs, page 4
Functional Description, page 5
Configuration Options, page 7
Configuration Tasks, page 8
Configuration Examples, page 17
Command Reference, page 19
What to Do Next, page 37
Feature Summary
The Cisco uBR904 cable modem is a fully-functional Cisco IOS router and standards-based
Data-Over-Cable Service Interface Specification (DOCSIS) cable modem designed for use in small
office/home office data-over-cable applications. It enables the delivery of secure, high-speed
connections over small to medium-sized LANs. Downstream speeds up to 27 Mbps are supported
using the 64-QAM modulation technique, or 40 Mbps using 256-QAM. On the upstream, the
Cisco uBR904 can deliver 5 Mbps using Quadrature Phase-Shift Keying (QPSK) or 10 Mbps using
16-QAM.
The Cisco uBR904 is a compact device that supports the direct connection of up to four PCs and has
the familiar features and programming interface of other routers in Cisco’s extensive line of smalland medium-sized business product offerings. The Cisco uBR904 provides packet data transport and
network address translation for TCP/IP applications between home or office computers and the cable
headend.
You can configure your cable modem to act as a bridge or as a router. See Figure 1 and Figure 2. For
more detailed descriptions of these options, see the “Configuration Options” section on page 7.
Bridging and Routing Features for the Cisco uBR904 Cable Modem 1
Feature Summary
Figure 1
Cisco uBR904 in a Bridging Configuration
PC
Ethernet
PC
CATV
coaxial cable
Cisco uBR7200 series
CMTS
Ethernet
Cisco uBR900 series
cable access router
PC
Ethernet
HFC network
Cisco uBR904 in a Routing Configuration with a Hub
CATV
coaxial cable
Cisco uBR7246
CMTS
Cable
Modem
Ethernet
Ethernet
LAN
HUB
13306
Figure 2
13305
PC or hub
Ethernet
HFC network
Benefits
The Cisco uBR904 cable modem provides the following benefits for data-over-cable applications:
•
Enables the cost-effective deployment of advanced routing capabilities to the small office or
home office site
•
Provides a universal platform for deployment of both current and future modem technologies via
modular upgrades while protecting the operator’s invested capital
•
Leverages Cisco’s industry-standard routing hardware and Cisco IOS software to deliver
advanced network services and applications
List of Terms
CATV—Originally stood for Community Antenna Television. Now refers to any coaxial or fiber
cable-based system that provides television services.
Cable modem (CM)—Any device that modulates and demodulates digital data onto a CATV plant.
Cable router—A modular chassis-based router optimized for data-over-CATV hybrid fiber-coaxial
(HFC) applications.
Channel—A specific frequency allocation and bandwidth. Downstream channels used for television
in the United States are 6 MHz wide.
CM—Cable modem.
CMTS—Cable Modem Termination System. Any DOCSIS-compliant headend cable router, such
as the Cisco uBR7246.
2
Cisco IOS Release 12.0(3)T
List of Terms
DHCP—Dynamic Host Configuration Protocol. This protocol provides a mechanism for allocating
IP addresses dynamically so that addresses can be reused when hosts no longer need them.
DOCSIS—Data Over Cable Service Interface Specification. Defines technical specifications for
equipment at both subscriber locations and cable operators’ headends.
Downstream—The set of frequencies used to send data from a headend to a subscriber.
Headend—Central distribution point for a CATV system. Video signals are received here from
satellite (either co-located or remote), frequency converted to the appropriate channels, combined
with locally originated signals, and rebroadcast onto the HFC plant. For a CATV data system, the
headend is the typical place to create a link between the HFC system and any external data networks.
HFC—Hybrid fiber-coaxial (cable network). Older CATV systems were provisioned using only
coaxial cable. Modern systems use fiber transport from the headend to an optical node located in the
neighborhood to reduce system noise. Coaxial cable runs from the node to the subscriber. The fiber
plant is generally a star configuration with all optical node fibers terminating at a headend. The
coaxial cable part of the system is generally a trunk-and-branch configuration.
Host—Any end-user computer system that connects to a network. In this document, the term host
refers to the computer system connected to the LAN interface of the cable modem.
MAC layer—Media Access Control sublayer. Controls access by the cable modem to the CMTS
and to the upstream data slots.
MCNS—Multimedia Cable Network System Partners Ltd. A consortium of cable companies
providing service to the majority of homes in the United States and Canada. This consortium has
decided to drive a standard with the goal of having interoperable cable modems.
MSO—Multiple Service Operator. A cable service provider that also provides other services such
as data and/or voice telephony.
QAM—Quadrature Amplitude Modulation. A method of modulating digital signals onto a
radio-frequency carrier signal involving both amplitude and phase coding. QAM is a modulation
scheme mostly used in the downstream direction (QAM-64, QAM-256). QAM-16 is expected to be
usable in the upstream direction. Numbers indicate number of code points per symbol. The QAM
rate or the number of points in the QAM constellation can be computed by 2 raised to the power of
<number of bits/symbol>.
QPSK—Quadrature Phase-Shift Keying. A method of modulating digital signals onto a
radio-frequency carrier signal using four phase states to code two digital bits.
Ranging—The process of acquiring the correct timing offset such that the transmissions of a cable
modem are aligned with the correct mini-slot boundary.
SID (Service ID)—A number that defines (at the MAC sublayer) a particular mapping between a
cable modem (CM) and the CMTS. The SID is used for the purpose of upstream bandwidth
allocation and class-of-service management.
Subscriber Unit (SU)—An alternate term for cable modem. See cable modem.
Upstream—The set of frequencies used to send data from a subscriber to the headend.
Platforms
The Cisco uBR904 cable modem is a standalone device; it works in conjunction with the
Cisco uBR7246 universal broadband router.
Bridging and Routing Features for the Cisco uBR904 Cable Modem 3
Prerequisites
Prerequisites
In order to use the Cisco uBR904 cable modem for data-over-cable applications, the following
conditions must be met:
•
The Cisco uBR7246 universal broadband router must be installed at the cable headend and
configured. Refer to the Cisco uBR7246 Installation and Configuration Guide and the
Cisco uBR7246 Universal Broadband Router Cable Modem Card Installation and Configuration
for detailed information.
•
The Cisco uBR904 cable modem must be physically installed and cabled as follows:
— To the headend via CATV coaxial cable
— To at least one PC via the straight-through yellow Ethernet cable supplied with the cable
modem. Refer to the Cisco uBR904 Cable Modem Installation and Configuration Guide for
detailed information.
•
•
The PC(s) connected to the Cisco uBR904 cable modem must be configured for IP.
•
Cisco IOS Release 11.3(4)NA or later must be running on the Cisco uBR904 cable modem.
When the cable modem is up and running, you can display the IOS release number by entering
the show version command from user EXEC mode.
The cable service provider must have a correctly configured network DHCP server and
Electronic Industries Association (EIA) downstream channel.
Note If the Cisco uBR7246 universal broadband router at the cable headend is using MC16 modem
cards, Cisco IOS Release 11.3(7)NA or later must be running on the Cisco uBR904 cable modem.
Supported MIBs and RFCs
The Cisco uBR904 cable modem supports the following:
•
Cisco Standard MIBs: Cisco Product MIB, Cisco Chassis MIB, Cisco Syslog MIB, Cisco Flash
MIB, Bridge MIB, IF MIB, MIB-II.
•
Radio Frequency Interface Specification—Developed by the Multimedia Cable Network System
(MCNS) consortium. It defines the radio-frequency interface specification for high-speed
data-over-cable systems.
•
CiscoWorks—Network management program for planning, troubleshooting, and monitoring
Cisco internetworks. CiscoWorks uses Simple Network Management Protocol (SNMP) to
monitor all SNMP devices.
— For more information about CiscoWorks on CCO, follow this path:
Products & Ordering: Cisco Products: Network Management: CiscoWorks
— For more information about CiscoWorks on the Documentation CD-ROM, follow this path:
Cisco Product Documentation: Network Management: CiscoWorks
•
4
Radio Frequency Interface (RFI) MIB—Specific to Data-Over-Cable Service Interface
Specification (DOCSIS) cable implementations. The RIF MIB provides an interface that permits
management of the Cisco uBR904 cable modem over the cable or Ethernet interface. Using
SNMP management applications, this MIB allows access to statistics such as MAC, driver
configuration, and counters.
Cisco IOS Release 12.0(3)T
List of Terms
•
Cable Device MIB—Records statistics related to the configuration and status of the
Cisco uBR904 cable modem. Statistics include an events log and device status. The Cable Device
MIB is very similar to the RFI MIB in that both allow access to statistics; they are different in
that the Cable Device MIB reports statistics on the cable modem, while the RFI MIB reports
statistics on the radio frequency transmissions over the cable television line.
Functional Description
The Cisco uBR904 cable modem is the end-user part of the Cisco data-over-cable system; it is also
referred to as a subscriber unit. The subscriber unit functions as an interface between the subscriber’s
personal computer(s) at the small office/home office and the cable operator’s network (the headend).
The Cisco uBR904 has a single-cable F-connector interface for connection to the HFC network and
a built-in Ethernet 10BaseT hub that provides four RJ-45 ports to which subscriber devices can be
connected. All four ports are treated as one Ethernet interface by the Cisco IOS software. More hosts
can be connected to the unit by connecting one of the 10BaseT ports to a hub. An additional RJ-45
port provides a console interface for configuration and diagnostic purposes.
In compliance with MCNS requirements, the cable interface requires no configuration or setup
procedures other than connecting the Cisco uBR904 to the cable system. The unit is configured
automatically using a configuration file generated by the cable service provider and delivered via the
Cisco uBR7246 universal broadband router installed at the cable headend. The headend router
provides a path from the cable modem to the DHCP server for PC address assignment.
The personal computer(s) connected to the cable modem must be configured for Internet Protocol
(IP). In addition, the cable service provider must have a correctly configured network Dynamic Host
Configuration Protocol (DHCP) server and EIA downstream channel. Using DHCP, the universal
broadband router assigns an IP address to the cable modem each time it connects to the network. The
IP address identifies the computer on the network and enables the universal broadband router to
route data to and from the PC.
After the cable modem is installed and the connected PC is configured for IP, and after DHCP
services are enabled and communication to the headend is established, the Cisco uBR7246 universal
broadband router downloads configuration information to the cable modem. The initial
configuration connection to the headend can take several minutes.
See Figure 3 for a sample network topology.
Bridging and Routing Features for the Cisco uBR904 Cable Modem 5
Functional Description
Figure 3
CMTS to Cable Modem Network Sample Topology
ISP
WAN
IP-related
ATM, FDDI, 100BT...
100BT
100BT
Proxy server
Cisco
uBR7246
CMTS
Analog TV
100BT
ISP @ home...
100BT
MSD: Maintenance Service
Organization, Cable companies
Upconvertor
DS-RF 54-860 Mhz
Digital TV
Fiber
Transceiver
80 km
1000 ft
Fiber node
(Telephone pole,
underground box)
Top
amplifier
Drop box
13304
Distribution
amplifier
Cisco u BR904
cable modem
6
Cisco IOS Release 12.0(3)T
Configuration Options
Configuration Options
The Cisco uBR904 cable modem is usually configured automatically via a configuration file
generated by the cable service provider; however, you can also manually configure the cable modem
to function either as a bridge or as a router. The following sections give brief descriptions of both
applications.
Note When the unit is shipped from the factory, it is configured for bridging by default.
Bridging
The Cisco uBR904 cable modem complies with the MCNS standards for interoperable cable
modems; it supports full transparent bridging as well as DOCSIS-compliant transparent bridging.
In bridging applications, the Cisco uBR904 acts as a transparent bridge for up to three PCs plugged
directly into three of the four Ethernet ports on the rear panel of the unit. The cable modem is
connected to the Internet via the coaxial cable. All three Ethernet ports are treated as one Ethernet
interface by the Cisco IOS software. The IP addresses for the PCs and the coaxial cable interface are
in the same subnet.
Figure 4
Cisco uBR904 in a Bridging Configuration
PC
Ethernet
CATV
coaxial cable
Cisco uBR7200 series
CMTS
Cisco uBR900 series
cable access router
PC
Ethernet
PC
Ethernet
HFC network
13305
PC or hub
Ethernet
DOCSIS-compliant transparent bridging is the default configuration of the Cisco uBR904 cable
modem. If your cable service provider is using a DHCP server, all you need to do is connect the
cables and power on the cable modem; your service provider’s configuration program will
automatically configure both the coaxial cable interface and the bridging functionality. You do not
need to set up IP addresses for the attached PCs or enter any Command Line Interface (CLI)
configuration commands. This type of operation is called plug-and-play bridging.
In addition to the plug-and-play method, you can configure a bridging application on the
Cisco uBR904 using one of the following methods:
•
Manual configuration using the CLI. See the sections “Configuring Bridging” on page 13 and
“Customizing the Cable Modem Interface” on page 16 for details.
•
Advanced configuration using the System Configuration dialog box in the setup facility. See the
chapter “Configuring Advanced Routing or Bridging Using Setup” in the Cisco uBR904 Cable
Modem Installation and Configuration Guide for details.
Bridging and Routing Features for the Cisco uBR904 Cable Modem 7
Configuration Tasks
Routing
In this application, the cable modem acts as a router to connect to existing networks. A typical use
would be if you are connecting the cable modem to an internal Ethernet hub that is connected to an
existing PC network. You can also connect the cable modem directly to as many as four PCs via the
Ethernet ports on the rear panel.
The cable modem is automatically configured to use the IP address of the Cisco uBR7246 headend
cable router as the cable modem’s default IP gateway.
Cisco uBR904 in a Routing Configuration with a Hub
CATV
coaxial cable
Cable
Modem
Ethernet
Cisco uBR7246
CMTS
Ethernet
LAN
HUB
13306
Figure 5
HFC network
You can configure the Cisco uBR904 cable modem to function like a router using one of the
following methods:
•
Manual configuration using the CLI. See the sections “Configuring a Host Name and Password”
on page 9 and “Customizing the Cable Modem Interface” on page 16 for details.
•
Advanced configuration using the System Configuration dialog box in the setup facility. See the
chapter “Configuring Advanced Routing or Bridging Using Setup” in the Cisco uBR904 Cable
Modem Installation and Configuration Guide for details.
Configuration Tasks
The Cisco uBR904 cable modem typically is configured automatically on power-up using a
configuration file generated by the cable service provider and delivered via the Cisco uBR7246
universal broadband router installed at the cable headend. All of the configuration tasks listed below
are optional.
•
•
•
•
•
•
Configuring a Host Name and Password, page 9
Configuring Ethernet and Cable Modem Interfaces, page 10
Configuring Routing, page 11
Configuring Bridging, page 13
Reestablishing Plug-and-Play Bridging, page 15
Customizing the Cable Modem Interface, page 16
Note Console sessions and TTY sessions are supported by the cable modem.
8
Cisco IOS Release 12.0(3)T
Configuring a Host Name and Password
Configuring a Host Name and Password
One of the first configuration tasks you might want to perform is to configure a host name and set an
encrypted password. Configuring a host name allows you to distinguish multiple Cisco uBR904
cable modems from each other. Setting an encrypted password allows you to prevent unauthorized
configuration changes.
Note Passwords are case sensitive.
To configure a host name and an encrypted password for a Cisco uBR904 cable modem, perform the
following tasks, starting in global configuration mode:
Step
Command
Purpose
1
uBR904(config)# hostname cisco
cisco(config)#
Change the name of the uBR904 to a meaningful
name. Substitute your host name for cisco.
2
cisco(config)# enable secret guessme
Enter an enable secret password. This password
provides access to enable (privileged EXEC) mode.
After configuring a password, when you enter enable
at the EXEC prompt, you must enter the enable secret
password to gain access to configuration mode.
Substitute your enable secret password for guessme.
3
cisco(config)# line console 0
cisco(config-line)# exec-timeout 0 0
cisco(config-line)# exit
cisco(config)#
Enter line configuration mode to configure the console
port.
Prevent the EXEC facility from timing out if you do
not type any information on the console screen for an
extended period.
Exit back to global configuration mode.
Verifying the Host Name and Password
To verify that you configured the correct host name and password, enter the show running-config
command from global configuration mode:
cisco(config)# show running-config
Using 1888 out of 126968 bytes
!
version XX.X
.
.
!
hostname cisco
!
enable secret 5 $1$60L4$X2JYOwoDc0.kqa1loO/w8/
•
Check the host name and encrypted password displayed near the top of the command output.
Bridging and Routing Features for the Cisco uBR904 Cable Modem 9
Configuration Tasks
•
Exit global configuration mode and attempt to reenter it using the new enable password:
cisco# exit
cisco con0 is now available
Press RETURN to get started.
cisco> enable
Password: guessme
cisco#
Troubleshooting Tips
If you are having trouble:
•
•
Make sure Caps Lock is off.
Make sure you entered the correct passwords. Passwords are case sensitive.
Configuring Ethernet and Cable Modem Interfaces
To assign an IP address to the Ethernet or cable modem interface so that it can be recognized as a
device on the Ethernet LAN, perform the following tasks, starting in global configuration mode:
Step
Command
Purpose
1
uBR904(config)# interface ethernet 0
Enter interface configuration mode for the Ethernet
and/or the cable modem interface.
or
uBR904(config)# interface modem-cable0
uBR904(config-if)#
2
uBR904(config-if)# ip address
172.16.1.1 255.255.255.0
Assign the appropriate IP address and subnet mask
to the interface.
3
uBR904(config-if)# Ctrl-Z
uBR904#
Return to privileged EXEC mode.
%SYS-5-CONFIG_I: Configured from console
by console
This message is normal and does not indicate an
error.
Verifying IP Address Configuration
To verify that you have assigned the correct IP address, enter the show arp command:
uBR904# show arp
Protocol Address
Internet 172.16.1.1
Internet 4.0.0.28
Age (min)
-
Hardware Addr
0009.0613.6030
00e0.1ed7.524d
Type
ARPA
ARPA
Interface
cable-modem0
Ethernet0
Troubleshooting Tips
If you are having trouble:
•
•
10
Make sure you are using the correct IP address.
Make sure the cable interface is not shut down. Use the show running-config command to check the cable
interface status.
Cisco IOS Release 12.0(3)T
Configuring Routing
Configuring Routing
If you have one or more PCs directly connected to your cable modem, you can change the cable
modem’s configuration from bridging to routing. When configured as a bridge, the cable modem can
have a maximum of three PCs directly connected; when configured as a router, it can have four PCs
directly connected. See the “Configuration Options” section on page 7 for details on both of these
configurations.
To configure the Cisco uBR904 cable modem for routing, perform the following tasks, starting in
global configuration mode:
Step
Command
Purpose
1
uBR904(config)#interface cable-modem0
Enter interface configuration mode for the cable
modem interface.
2
uBR904(config-if)#no cable-modem
compliant bridge
Turn off MCNS auto-configured bridging.
uBR904(config-if)#end
Return to global configuration mode.
3
uBR904(config)#ip routing
Enable IP routing for the cable modem.
4
uBR904(config)#router rip
Enter router configuration mode and enable Routing
Information Protocol (RIP) on the cable modem.
5
uBR904(config-router)#network
network-number
Specify the network connected to the cable modem on
which the RIP process will operate. If the cable modem
is attached to more than one network, enter each IP
address in a separate command.
6
uBR904(config-router)#end
Exit router configuration mode.
Return to interface configuration mode for the cable
modem interface.
uBR904(config)#interface cable-modem0
7
uBR904(config-if)#ip rip receive v 2
Specify that only RIP Version 2 packets will be
received on the coaxial cable interface.
8
uBR904(config-if)#ip rip send v 2
Specify that only RIP Version 2 packets will be sent on
the coaxial cable interface.
9
uBR904(config-if)#end
Exit interface configuration mode for the cable modem
interface and enter interface configuration mode for the
Ethernet0 interface.
uBR904(config)#interface ethernet0
10
uBR904(config-if)#ip rip receive v 2
Specify that only RIP Version 2 packets will be
received on this Ethernet interface.
11
uBR904(config-if)#ip rip send v 2
Specify that only RIP Version 2 packets will be sent on
this Ethernet interface.
12
uBR904(config-if)#Ctrl-z
Return to privileged EXEC mode.
Save the configuration to nonvolatile RAM so that it
won’t be lost in the event of a reset, power cycle, or
power outage.
uBR904#copy running-config
startup-config
Building configuration...
Bridging and Routing Features for the Cisco uBR904 Cable Modem 11
Configuration Tasks
Verifying Routing
To verify that bridging is not configured, routing is enabled, and that Routing Information Protocol
is configured on the interfaces, enter the show startup-config command:
uBR904# show startup-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname ubR904
!
!
ip host sw-lab-fw 4.0.0.1
ip domain-name cisco.com
ip name-server 171.69.209.10
clock timezone EST 2
!
!
interface Ethernet0
ip address 4.0.0.33 255.0.0.0
ip rip send version 2
ip rip receive version 2
no keepalive
!
interface cable-modem0
ip address 172.16.1.42 255.255.0.0
ip rip send version 2
ip rip receive version 2
no keepalive
cable-modem downstream saved channel 699000000 39
cable-modem downstream search-band 88 453000000 855000000 6000000
cable-modem downstream search-band 89 93000000 105000000 6000000
cable-modem downstream search-band 90 111250000 117250000 6000000
cable-modem downstream search-band 91 231012500 327012500 6000000
cable-modem downstream search-band 92 333015000 333015000 6000000
cable-modem downstream search-band 93 339012500 399012500 6000000
cable-modem downstream search-band 94 405000000 447000000 6000000
cable-modem downstream search-band 95 123015000 129015000 6000000
cable-modem downstream search-band 96 135012500 135012500 6000000
cable-modem downstream search-band 97 141000000 171000000 6000000
cable-modem downstream search-band 98 219000000 225000000 6000000
cable-modem downstream search-band 99 177000000 213000000 6000000
cable-modem downstream search-band 100 91000000 860000000
!
router rip
network 4.0.0.0
network 172.16.0.0
!
ip default-gateway 172.16.1.1
ip classless
!
line con 0
line vty 0 4
login
!
end
12
Cisco IOS Release 12.0(3)T
Configuring Bridging
Configuring Bridging
The Cisco uBR904 cable modem is configured for bridging by default. If it becomes necessary to
reconfigure the unit for bridging after it has been configured for routing, you can erase the routing
configuration and return the unit to factory default configuration settings, or you can reconfigure the
unit manually using the CLI. To return the cable modem to factory default settings, see the section
“Reestablishing Plug-and-Play Bridging” on page 15 for details. To reconfigure the cable modem
manually, perform the following tasks, starting in global configuration mode:
Step
Command
Purpose
1
uBR904(config)#no service pad
Disable packet assembler/disassembler
commands; prevent the uBR904 from accepting
incoming or outgoing Packet
Assembler/Disassembler (PAD) connections.
2
uBR904(config)#no service
password-encryption
Disable password encryption.
3
uBR904(config)#no ip routing
Disable IP routing on the uBR904.
4
uBR904(config)#interface Ethernet0
Enter interface configuration mode for the
Ethernet0 interface.
5
uBR904(config-if)#no ip route-cache
Disable high-speed switching caches for IP
routing.
6
uBR904(config-if)#bridge-group
bridge-group
Assigns the Ethernet0 interface to a bridge group.
The bridge group must be an integer between 1
and 63.
7
uBR904(config-if)#bridge-group
bridge-group spanning-disabled
Disable spanning tree on the Ethernet interface.
8
uBR904(config-if)#end
Exit interface configuration mode for the
Ethernet0 interface and enter interface
configuration mode for the cable modem interface.
uBR904(config)#interface cable-modem0
9
uBR904(config-if)#no ip address
Disable the IP address of the coaxial cable
interface, if one has been set. The uBR7246 cable
router assigns an IP address to the cable modem
each time it connects to the network.
10
uBR904(config-if)#no ip route-cache
Disable high-speed switching caches for IP
routing on the cable interface.
11
uBR904(config-if)#no keepalive
Disable keepalives on the cable interface.
12
uBR904(config-if)#bridge-group
bridge-group
Assign the cable modem interface to a bridge
group. The bridge group must be an integer from 1
to 63. (The default is 59.)
13
uBR904(config-if)#bridge-group
bridge-group spanning-disabled
Disable spanning tree on the cable interface.
14
uBR904(config-if)#end
Exit interface configuration mode.
uBR904(config)#ip classless
(Optional) At times, the uBR904 might receive
packets destined for a subnet of a network that has
no network default route. This global
configuration mode command allows the Cisco
IOS software to forward such packets to the best
network route possible.
uBR904(config)#line console 0
Enter line configuration mode to configure the
console port.
15
Bridging and Routing Features for the Cisco uBR904 Cable Modem 13
Configuration Tasks
Step
Command
Purpose
16
uBR904(config-line)#line vty 0 4
Identify the last line in a contiguous group of
virtual terminals you want to configure.
17
uBR904(config-line)#Ctrl-z
Return to privileged EXEC mode.
Save the configuration to nonvolatile RAM so that
it won’t be lost in the event of a reset, power cycle,
or power outage.
uBR904#copy running-config startup-config
Building configuration...
When the cable interface comes up, the IP address and downstream channel are configured
automatically.
Note To configure multiple PCs, repeat Steps 4 through 7 above for each additional PC. You can
connect a maximum of three PCs to the Cisco uBR904 cable modem in a bridging application.
Verifying Bridging
To verify that routing has been disabled on all interfaces and that bridging has been reenabled, enter the show
startup-config command from privileged EXEC mode:
uBR904# show startup-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
no service password-encryption
!
hostname uBR904
!
no ip routing
!
interface Ethernet0
no ip address
no ip route-cache
bridge-group 59
bridge-group 59 spanning-disabled
!
interface cable-modem0
no ip address
no ip route-cache
no keepalive
cable-modem downstream saved channel 699000000 36
bridge-group 59
bridge-group 59 spanning-disabled
!
ip classless
!
line con 0
line vty 0 4
login
!
end
14
Cisco IOS Release 12.0(3)T
Reestablishing Plug-and-Play Bridging
Reestablishing Plug-and-Play Bridging
To erase the current non-default cable modem configuration and return the unit to its factory default
plug-and-play bridging configuration, perform the following task from privileged EXEC mode:
Step
Command
Purpose
1
uBR904#erase startup config
Erase the current configuration (assuming the current
running configuration has been saved to NVRAM).
After entering this command, perform a warm reset of the Cisco uBR904 cable modem by pressing
and holding down the Reset button for less than 10 seconds. For information on the location and
operation of the Reset button, refer to the “Physical Description” section in the chapter “Installing
the Cisco uBR904 Cable Modem” in the Cisco uBR904 Cable Modem Installation and
Configuration Guide.
Verify Plug-and-Play Bridging
To verify that the cable modem is configured for Plug-and-Play bridging, enter the show
startup-config command from privileged EXEC mode. The configuration should look like this:
uBR904# show startup-config
Building configuration...
Current configuration:
!
version 12.0
no service pad
no service password-encryption
!
hostname uBR904
!
no ip routing
!
interface Ethernet0
no ip address
no ip route-cache
bridge-group 59
bridge-group 59 spanning-disabled
!
interface cable-modem0
no ip address
no ip route-cache
no keepalive
cable-modem downstream saved channel 699000000 36
bridge-group 59
bridge-group 59 spanning-disabled
!
ip classless
!
line con 0
line vty 0 4
login
!
end
Bridging and Routing Features for the Cisco uBR904 Cable Modem 15
Configuration Tasks
Customizing the Cable Modem Interface
Different geographical regions and different cable plants use different frequency bands. The
Cisco uBR904 cable modem uses a built-in default frequency scanning feature to address this issue.
After the cable modem finds a successful downstream frequency channel, it saves the channel and
power setting to NVRAM. The cable modem recalls this value the next time it needs to synchronize
its frequency or register with the cable service provider’s CMTS.
However, you can customize the cable modem’s interface configuration if you need to deviate from
the default setting that ships with the modem. For example, you might need to specify a different
compliant mode, modify the saved downstream channel setting and upstream power value, or enable
a faster downstream search algorithm.
Note Most cable network scenarios will not require you to use these commands.
To customize the cable modem interface, perform the following tasks, starting in global
configuration mode:
Step
Command
Purpose
1
uBR904(config)#interface cable-modem 0
Specify cable modem interface 0.
2
uBR904(config-if)#cable-modem
compliant bridge
Enable DOCSIS-compliant bridging.
3
uBR904(config-if)#cable-modem
downstream saved channel ds-frequency
us-power
Modify the saved downstream channel setting and
upstream power value. If you do this, you must specify
an exact downstream frequency and a power value.1
4
uBR904(config-if)#cable-modem
fast-search
Enable a faster downstream search algorithm.
1. Use the no cable-modem downstream saved channel ds-frequency us-power command to remove a saved frequency and power
setting from NVRAM.
Note For more information on the use and effects of the commands in Step 3 and Step 4 above,
refer to the command reference pages for those commands.
16
Cisco IOS Release 12.0(3)T
Sample Bridging Configuration
Configuration Examples
Sample Bridging Configuration
This is a typical bridging configuration for a single PC connected to the Cisco uBR904 cable modem.
Note that the configuration for multiple PCs (maximum of three) is the same.
version 12.0
no service pad
no service password-encryption
!
hostname uBR904
!
!
no ip routing
!
!
!
interface Ethernet0
no ip address
no ip route-cache
bridge-group 59
bridge-group 59 spanning-disabled
!
interface cable-modem0
no ip address
no ip route-cache
no keepalive
bridge-group 59
bridge-group 59 spanning-disabled
!
ip classless
!
line con 0
line vty 0 4
login
!
end
When the cable interface is up, the following lines are included in cable interface configuration:
ip address 172.16.1.40 255.255.0.0
cable-modem downstream saved channel 699000000 34
Bridging and Routing Features for the Cisco uBR904 Cable Modem 17
Configuration Examples
Sample Routing Configuration
This is a typical routing configuration for the Cisco uBR904 cable modem. Note that the cable IP
address and downstream channel are configured automatically.
!
version 12.0
no service pad
no service password-encryption
!
hostname uBR904
!
!
!
!
!
interface Ethernet0
ip address 4.0.0.33 255.0.0.0
ip rip send version 2
ip rip receive version 2
!
interface cable-modem0
ip address 172.16.1.40 255.255.0.0
ip rip send version 2
ip rip receive version 2
no keepalive
cable-modem downstream saved channel 699000000 34
no cable-modem compliant bridge
!
router rip
network 4.0.0.0
network 188.188.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.1
!
line con 0
line vty 0 4
login
!
end
18
Cisco IOS Release 12.0(3)T
Sample Routing Configuration
Command Reference
This section describes new and changed commands for the Cisco uBR904 cable modem for
Cisco IOS Release 12.0(3)T.
All other commands used with this feature are documented in the Cisco IOS Release 12.0 command
references.
•
•
•
•
•
•
•
•
cable-modem compliant bridge
cable-modem downstream saved channel
cable-modem fast-search
cable-modem upstream preamble qpsk
interface cable-modem
show bridge cable-modem
show dhcp
show interfaces cable-modem
Bridging and Routing Features for the Cisco uBR904 Cable Modem 19
Command Reference
cable-modem compliant bridge
To enable DOCSIS-compliant transparent bridging for a cable modem interface at startup, use the
cable-modem compliant command from interface configuration mode. Use the no form of this
command to disable DOCSIS-compliant bridging for the interface.
cable-modem compliant bridge
no cable-modem compliant bridge
Syntax Description
This command has no arguments or keywords.
Default
Enabled
Command Mode
Interface configuration
Usage Guidelines
This command first appeared in Cisco IOS Release 11.3 NA.
It is normally not necessary to enter this command in data-over-cable bridging applications because
DOCSIS-compliant bridging is enabled by default. If you wish to do full transparent bridging rather
than DOCSIS-compliant bridging, use the no form of the command, then configure full transparent
bridging using CLI commands. See the “Configuring Bridging” section on page 13 for instructions.
Example
The following example shows how to enter the cable-modem compliant bridge command for a
cable modem interface, starting from global configuration mode:
uBR904(config)# interface cable-modem 0
uBR904(config-if)# cable-modem compliant bridge
uBR904(config-if)#
Related Commands
cable-modem downstream saved channel
cable-modem fast-search
cable-modem upstream preamble qpsk
interface cable-modem
20
Cisco IOS Release 12.0(3)T
cable-modem downstream saved channel
cable-modem downstream saved channel
To modify the saved downstream channel setting and upstream power value on a cable modem
interface, enter the cable-modem downstream saved channel command from interface
configuration mode. Use the no form of this command to remove the saved settings, which will be
resaved at the next initialization cycle.
cable-modem downstream saved channel ds-frequency us-power
no cable-modem downstream saved channel ds-frequency us-power
Syntax Description
ds-frequency
Downstream channel frequency in Hz, which can be from 91000000 to 860000000.
us-power
Upstream power level in decibels per millivolt (dBmV), which can be from 8 to 61.
Default
Enabled
Command Mode
Interface configuration
Usage Guidelines
This command first appeared in Cisco IOS Release 11.3 NA.
This command is auto-generated by the operation of the cable MAC layer process. The MCNS
DOCSIS RFI specification requires that cable modems remember the downstream frequency and
upstream power of the last successfully ranged session. These parameters are called up as the first
downstream frequency and upstream power to use the next time the cable modem is booted. This
operation dramatically speeds up the channel search.
Use the no cable-modem downstream saved channel ds-frequency us-power command to remove
the saved frequency and power setting from the running configuration, which will be resaved at the
next initialization cycle.
Cisco recommends that this command NOT be used by end users of the Cisco uBR904 cable modem.
Example
The following example shows how to remove the downstream frequency of 91000000 Hz and the
upstream power level of 33 dBmV from the running configuration of a cable-modem interface,
starting from global configuration mode.
uBR904(config)# interface cable-modem 0
uBR904(config-if)# no cable-modem downstream saved channel 91000000 33
uBR904(config-if)#
Bridging and Routing Features for the Cisco uBR904 Cable Modem 21
Command Reference
Related Commands
cable-modem compliant bridge
cable-modem fast-search
cable-modem upstream preamble qpsk
interface cable-modem
22
Cisco IOS Release 12.0(3)T
cable-modem fast-search
cable-modem fast-search
To enable a faster downstream search algorithm on a cable modem interface, use the cable-modem
fast-search command from interface configuration mode. Use the no form of this command to
disable the downstream fast-search feature.
cable-modem fast-search
no cable-modem fast-search
Syntax Description
There are no keywords or arguments for this command.
Default
Disabled
Command Mode
Interface configuration
Usage Guidelines
This command first appeared in Cisco IOS Release 11.3 NA.
This feature speeds up the frequency search performed by the cable modem. Normally it takes the
cable modem about 30 to 50 seconds to sample 30 to 50 frequencies. The cable-modem fast-search
command can reduce this search time. However, there might be some cases where this fast-search
algorithm might not perform as well as the default algorithm. Trial and error is the only way to
discover how well this feature works for your environment.
Example
The following example shows how to enter the cable-modem fast-search command, starting from
global configuration mode:
uBR904(config)# interface cable-modem 0
uBR904(config-if)# cable-modem fast-search
uBR904(config-if)#
Related Commands
cable-modem compliant bridge
cable-modem downstream saved channel
cable-modem upstream preamble qpsk
interface cable-modem
Bridging and Routing Features for the Cisco uBR904 Cable Modem 23
Command Reference
cable-modem upstream preamble qpsk
To enable the QPSK modulation scheme in the upstream direction from the cable modem interface
to the headend, enter the cable-modem upstream preamble qpsk command from interface
configuration mode. Use the no form of this command to disable upstream modulation for the
interface.
cable-modem upstream preamble qpsk
no cable-modem upstream preamble qpsk
Syntax Description
This command has no arguments or keywords.
Default
Enabled
Command Mode
Interface configuration
Usage Guidelines
This command first appeared in Cisco IOS Release 11.3 NA.
Example
The following example shows how to enter the cable-modem upstream preamble qpsk command
for a cable modem interface, starting from global configuration mode:
uBR904(config)# interface cable-modem 0
uBR904(config-if)# cable-modem upstream preamble qpsk
uBR904(config-if)#
Related Commands
cable-modem compliant bridge
cable-modem downstream saved channel
cable-modem fast-search
interface cable-modem
24
Cisco IOS Release 12.0(3)T
interface cable-modem
interface cable-modem
To specify the cable modem interface on a Cisco uBR904 cable modem, enter the interface
cable-modem command from global configuration mode.
interface cable-modem number
Syntax Description
number
The interface number of the cable-modem interface on the rear panel of the cable
modem.
Default
Disabled
Command Mode
Global configuration
Usage Guidelines
This command first appeared in Cisco IOS Release 11.3 NA.
When this command is entered, the Cisco cable modem switches from global configuration mode to
interface configuration mode.
Example
The following example brings up cable modem interface 0 and displays the available cable-modem
interface configuration commands:
uBR904(config)# interface cable-modem 0
uBR904(config-if)# cable-modem ?
compliant
Enter compliant modes for interface
downstream
Downstream channel characteristics
fast-search Enable/disable the DS fast search
upstream
upstream channel characteristics
uBR904(config-if)#
Related Commands
cable-modem compliant bridge
cable-modem downstream saved channel
cable-modem fast-search
cable-modem upstream preamble qpsk
Bridging and Routing Features for the Cisco uBR904 Cable Modem 25
Command Reference
show bridge cable-modem
To display bridging information for a cable modem, enter the show bridge cable-modem command
from privileged EXEC mode.
show bridge cable-modem number
Syntax Description
number
The interface number of the cable-modem interface on the rear panel of the cable
modem.
Command Mode
Privileged EXEC
Usage Guidelines
This command first appeared in Cisco IOS Release 11.3 NA.
Examples
Following is a sample output for this command:
uBR904# show bridge cable-modem 0
Total of 300 station blocks, 298 free
Codes: P - permanent, S - self
Bridge Group 59:
Table 1 describes the significant fields shown in the display.
Table 1
Show Bridge Cable-Modem Field Descriptions
Field
Description
Total of 300 station blocks
Total number of forwarding database elements in the system. The memory to hold
bridge entries is allocated in blocks of memory sufficient to hold 300 individual
entries. When the number of free entries falls below 25, another block of memory
sufficient to hold another 300 entries is allocated. Thus, the total number of
forwarding elements in the system is expanded dynamically, as needed, limited by
the amount of free memory in the router.
Bridge Group
The number of the bridge group to which this interface is assigned.
Related Commands
show dhcp
show interfaces cable-modem
26
Cisco IOS Release 12.0(3)T
show dhcp
show dhcp
To display the current DHCP settings on point-to-point interfaces, enter the show dhcp command
from privileged EXEC mode.
show dhcp {lease | server}
Syntax Description
lease
Show DHCP addresses leased from a server.
server
Show known DHCP servers.
Command Mode
Privileged EXEC
Usage Guidelines
You can use this command on any point-to-point type of interface that uses DHCP for temporary IP
address allocation.
Examples
Following is sample output for the show dhcp lease command:
uBR904# show dhcp lease
Temp IP addr: 188.188.1.40 for peer on Interface: cable-modem0
Temp sub net mask: 0.0.0.0
DHCP Lease server: 4.0.0.32, state: 3 Bound
DHCP transaction id: 2431
Lease: 3600 secs, Renewal: 1800 secs, Rebind: 3150 secs
Temp default-gateway addr: 188.188.1.1
Next timer fires after: 00:58:01
Retry count: 0
Client-ID: 0010.7b43.aa01
Table 3 describes the significant fields shown in the display.
Table 2
Show DHCP Lease Field Descriptions
Field
Description
Temp IP addr
IP address leased from the DHCP server for the cable modem interface.
Temp subnet mask
Temporary subnet mask assigned to the cable modem interface.
DHCP Lease server
IP address of the DHCP server that assigned an IP address to this client.
state
Current state of this client (the cable modem interface). Possible states are Bound,
Renew, or Rebinding. For descriptions of these states, see RFC 2131.
DHCP transaction id
Unique number established by the uBR904 before the first request message is sent to
the DHCP server. The same transaction id is used as long as the lease keeps getting
renewed and is valid. If a new “discover” message is sent, a new transaction id is used.
Lease
Time (in seconds) for which the leased IP address is valid; the duration of the lease.
Bridging and Routing Features for the Cisco uBR904 Cable Modem 27
Command Reference
Table 2
Show DHCP Lease Field Descriptions (Continued)
Field
Description
Renewal
Time interval (in seconds) from address assignment until the client transitions to the
renewing state. When the renewal (T1) time expires, the client sends a unicast
dhcprequest message to the server to extends its lease. The default value of this timer is
0.5 times the duration of the lease.
Rebind
Time interval (in seconds) from address assignment until the client transitions to the
rebinding state and sends a broadcast dhcprequest message to any DHCP server to
extends its lease. The default value of this timer (T2) is 0.875 times the duration of the
lease.
Temp default-gateway addr
IP address of the router closest to this client on the network.
Next timer fires after
Time in hours, minutes, and seconds until the next timer expires.
Retry count
Number of times the client has sent any message to the DHCP server -- most likely a
request message to extend its lease. When the lease is renewed, the Retry count is reset
to 0.
Client-ID
MAC address (with optional media type code) that uniquely identifies the client on the
subnet for binding lookups.
Following is sample output for the show dhcp server command:
uBR904# show dhcp server
DHCP server: ANY (255.255.255.255)
Leases:
1
Offers:
1
Requests: 2
Acks: 1
Declines: 0
Releases: 0
Bad: 0
TFTP Server Name: SOHOSERVER
TIME0: 1.2.0.250, TIME1: 0.0.0.0
Subnet: 255.255.255.0
Naks: 0
Table 3 describes the significant fields shown in the display.
Table 3
28
Show DHCP Server Field Descriptions
Field
Description
DHCP server
MAC address used by the DHCP server.
Leases
Number of current leased IP addresses.
Offers
Number of offers for an IP address sent to a proxy-client from the server.
Requests
Number of requests for an IP address to the server.
Acks
Number of ‘acknowledge’ messages sent by the server to the proxy-client.
Naks
Number of ‘not acknowledge’ messages sent by the server to the proxy-client.
Declines
Number of offers from the server that have been declined by the proxy-client.
Releases
Number of times IP addresses have been relinquished gracefully by the client.
Bad
Number of bad packets received due to wrong length, wrong field type, or other causes.
TFTP Server Name
Name (if any) configured for the server providing TFTP downloads to the cable modem.
TIME0
IP address of the primary Time of Day (TOD) server.
TIME1
IP address of the secondary Time of Day (TOD) server.
Subnet
Subnet containing the DHCP server.
Cisco IOS Release 12.0(3)T
show dhcp
Related Commands
interface cable-modem
ip address-pool
ip dhcp-server
peer default ip address
show bridge cable-modem
show interfaces cable-modem
Bridging and Routing Features for the Cisco uBR904 Cable Modem 29
Command Reference
show interfaces cable-modem
To display information about the Cisco uBR904 cable modem’s cable interface, enter the show
interfaces cable-modem command from either user EXEC mode or privileged EXEC mode.
show interfaces cable-modem number [accounting | counters | crb | irb | type]
Syntax Description
number
Cable modem interface number.
accounting
(Optional) Displays the number of packets of each protocol type that has been sent
through the cable modem interface.
counters
(Optional) Shows MIB counters on the cable interface.
crb
(Optional) Displays concurrent routing and bridging information for each interface
that has been configured for routing or bridging. This option does not really apply to
the uBR904; it is included because it is part of the subsystem that provides
DOCSIS-compliant bridging. For more information, refer to the Bridging and IBM
Networking Command Reference.
irb
(Optional) Displays integrated routing and bridging information for each interface
that has been configured for routing or bridging. This option does not really apply to
the uBR904; it is included because it is part of the subsystem that provides
DOCSIS-compliant bridging. For more information, refer to the Bridging and IBM
Networking Command Reference.
type
(Optional) Designed to display information about virtual LANs associated with the
interface; however, this option is not supported on the uBR904.
Command Mode
User EXEC or privileged EXEC
Usage Guidelines
This command first appeared in Cisco IOS Release 11.3 NA.
When this command is entered without a keyword, general information about the cable interface is
displayed.
Examples
Traffic passing through the cable modem interface is shown in the following example:
uBR904# show interfaces cable-modem 0
cable-modem0 is up, line protocol is up
Hardware is BCM3220, address is 0010.7b6b.7821 (bia 0010.7b6b.7821)
Internet address is 172.16.1.60/16
MTU 1500 bytes, BW 27000 Kbit, DLY 1000 usec,
reliablility 255/255, txload 1/255, rxload 1/255
Encapsulation DOCSIS, loopback not set, keepalive not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:07:04, output 00:00:41, output hang never
Last clearing of "show interface" counters never
30
Cisco IOS Release 12.0(3)T
show interfaces cable-modem
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
4495 packets input, 1153221 bytes, 0 no buffer
Received 8 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
12841 packets output, 1708272 bytes, 0 underruns
0 output errors, 0 collisions, 11 interface resets
0 output buffer failures, 0 output buffers swapped out
Table 4 describes the significant fields shown in the display.
Table 4
Show Interfaces Cable-Modem Field Descriptions
Field
Description
cable-modem0 is up
Indicates that the interface is currently active. “Disabled” indicates the interface
has received more than 5000 errors in one keepalive interval (10 seconds by
default if keepalive is set); “administratively down” indicates the interface has
been taken down by an administrator.
line protocol is up
Indicates that the software processes that handle the line protocol believe the
interface is usable.
Hardware
Hardware type and MAC address.
Internet address
Internet address followed by the shorthand notation for the subnet mask.
MTU
Maximum Transmission Unit (equivalent of the maximum packet size) for the
interface.
BW
Bandwidth of the interface in kilobits per second.
DLY
Delay of the interface in microseconds.
reliability
Reliability of the interface, expressed as a fraction of 255, calculated as an
exponential average over a 5-minute period. (255/255 equals 100% reliability.)
tx load/rx load
Load on the interface caused by transmitting and receiving, expressed as a
fraction of 255, calculated as an exponential average over a 5 minute period.
Encapsulation/loopback/keepalive
Encapsulation method assigned to the interface.
loopback
Indicates whether or not loopback is set.
keepalive
Indicates whether or not keepalives are set.
ARP type
Type of Address Resolution Protocol configured for the interface.
ARP Timeout
Number of hours, minutes, and seconds an ARP cache entry will stay in the
cache.
Last input/output
Number of hours, minutes, and seconds since the last packet was successfully
received/transmitted by the interface.
output hang
Number of hours, minutes, and seconds since the interface was last reset because
of a transmission that took too long. When the number of hours in any of the
“Last..” fields exceeds 24, the number of days and hours is displayed. If the field
overflows, asterisks are printed.
Bridging and Routing Features for the Cisco uBR904 Cable Modem 31
Command Reference
Table 4
Show Interfaces Cable-Modem Field Descriptions (Continued)
Field
Description
Last clearing of “show interface”
counters
Time at which the counters that measure cumulative statistics (such as number of
bytes transmitted and received) shown in this report were last reset to zero. Note
that variables that might affect routing (for example, load and reliability) are not
cleared when the counters are cleared.
*** indicates the elapsed time is too large to be displayed.
0:00:00 indicates the counters were cleared more than 231 milliseconds (and less
than 232 milliseconds) ago.
Queueing strategy
Type of queueing strategy in effect on the interface.
Output queue/drops
Number of packets in the output queue followed by the size of the queue and the
number of packets dropped due to a full queue.
input queue/drops
Number of packets in the input queue followed by the size of the queue and the
number of packets dropped due to a full queue.
5 minute input rate
5 minute output rate
Average number of bits and packets received and transmitted per second in the
last 5 minutes. If the interface is not in promiscuous mode, it senses network
traffic it sends and receives (rather than all network traffic).
The 5-minute input and output rates should be used only as an approximation of
traffic per second during a given 5-minute period. These rates are exponentially
weighted averages with a time constant of 5 minutes. A period of four time
constants must pass before the average will be within two percent of the
instantaneous rate of a uniform stream of traffic over that period.
32
packets input
Total number of error-free packets received by the system.
bytes input
Total number of bytes, including data and MAC encapsulation, in the error-free
packets received by the system.
no buffer
Number of received packets discarded because there was no buffer space in the
main system. Compare with ignored count. Broadcast storms on Ethernet
networks and bursts of noise on serial lines are often responsible for no input
buffer events.
Received broadcasts
Total number of broadcast or multicast packets received by the interface.
runts
Number of packets discarded because they were smaller than the medium’s
minimum packet size. For example, any Ethernet packet less than 64 bytes is
considered a runt.
giants
Number of packets discarded because they were larger than the medium’s
maximum packet size. For example, any Ethernet packet larger than 1518 bytes
is considered a giant.
throttles
Number of times the receiver on the port was disabled, possibly due to buffer or
processor overload.
input errors
Includes runts, giants, no buffer, CRC, frame, overrun, and ignored counts. Other
input-related errors can also cause the input errors count to be increased, and
some datagrams may have more than one error; therefore, this sum may not
balance with the sum of enumerated input error counts.
CRC
Number of cyclic redundancy checksums generated by the originating LAN
station or far-end device that do not match the checksum calculated from the data
received. On a LAN, this usually indicates noise or transmission problems on the
LAN interface or the LAN bus itself. A high number of CRCs is usually the
result of collisions or a station transmitting bad data.
frame
Number of packets received incorrectly, having a CRC error and a noninteger
number of octets. On a LAN, this is usually the result of collisions or a
malfunctioning Ethernet device.
Cisco IOS Release 12.0(3)T
show interfaces cable-modem
Table 4
Show Interfaces Cable-Modem Field Descriptions (Continued)
Field
Description
overrun
Number of times the receiver hardware was unable to hand received data to a
hardware buffer because the input rate exceeded the receiver’s ability to handle
the data.
ignored
Number of received packets ignored by the interface because the interface
hardware ran low on internal buffers. These buffers are different from the system
buffers mentioned previously in the buffer description. Broadcast storms and
bursts of noise can cause the ignored count to be increased.
abort
Number of packets whose receipt was aborted.
packets output
Total number of messages transmitted by the system.
bytes
Total number of bytes, including data and MAC encapsulation, transmitted by
the system.
underruns
Number of times the transmitter has been running faster than the router can
handle.
output errors
Sum of all errors that prevented the final transmission of datagrams out of the
interface being examined. Note that this may not balance with the sum of the
enumerated output errors, as some datagrams might have more than one error,
and others might have errors that do not fall into any of the specifically tabulated
categories.
collisions
Number of messages retransmitted due to an Ethernet collision. This is usually
the result of an overextended LAN (Ethernet or transceiver cable too long, more
than two repeaters between stations, or too many cascaded multiport
transceivers). A packet that collides is counted only once in output packets.
interface resets
Number of times an interface has been completely reset. This can happen if
packets queued for transmission were not sent within several seconds. On a
serial line, this can be caused by a malfunctioning modem that is not supplying
the transmit clock signal, or by a cable problem. If the system notices that the
carrier detect line of a serial interface is up, but the line protocol is down, it
periodically resets the interface in an effort to restart it. Interface resets can also
occur when an interface is looped back or shut down.
output buffer failures
Number of times the output buffer has failed.
output buffers swapped out
Number of times the output buffer has been swapped out.
To display the number of packets and bytes of each protocol type passing through the cable modem
interface, use the accounting option with the show interface cable-modem command:
uBR904# show interface cable-modem 0 accounting
cable-modem0
Protocol
Pkts In
Chars In
IP
545
185502
Trans. Bridge
3878
964995
ARP
73
3066
Pkts Out
159
12597
86
Chars Out
90240
1611142
4128
Bridging and Routing Features for the Cisco uBR904 Cable Modem 33
Command Reference
Table 5 describes the fields shown in this display.
Table 5
Show Interfaces Cable-Modem Accounting Descriptions
Field
Description
Protocol
List of protocols operating on the cable-modem interface.
Pkts In
Number of packets of each protocol received on the interface.
Chars In
Number of bytes of each protocol received on the interface.
Pkts Out
Number of packets of each protocol transmitted on the interface.
Chars Out
Number of bytes of cach protocol transmitted on the interface.
MIB counters on the cable interface are displayed in the next example:
uBR904# show int cable-modem 0 counters
Cable specific counters:
Ranging requests sent : 50982
Downstream FIFO full
: 0
Re-requests
: 7277
DS MAC Message Overruns: 0
DS Data Overruns
: 0
Received MAPs
: 254339485
Received Syncs
: 53059555
Message CRC failures
: 0
Header CRC failures
: 1394
Data PDUs
: 5853
DS MAC messages
: 307861745
Valid Headers
: 307869065
Sync losses
: 0
Pulse losses
: 1
BW request failures
: 6
Table 6 describes the counters shown in this display.
Table 6
34
Show Interfaces Cable-Modem Counters Descriptions
Field
Description
Ranging requests sent
Number of ranging requests sent by the uBR904 to the CMTS.
Downstream FIFO full
Number of times the downstream input first-in first-out (FIFO) buffer became full on
the uBR904.
Re-requests
Number of times a bandwidth request generated by the uBR904 was not responded to
by the CMTS.
DS MAC Message Overruns
Number of times the uBR904’s DMA controller had a downstream MAC message
and there were no free MAC message buffer descriptors to accept the message.
DS Data Overruns
Number of times the uBR904’s DMA controller had downstream data and there were
no free data PDU buffer descriptors to accept the data.
Received MAPs
Number of times a MAP message passed all filtering requirements and was received
by the uBR904.
Received Syncs
Number of times a timestamp message was received by the uBR904.
Message CRC failures
Number of times a MAC message failed a cyclic redundancy (CRC) check.
Cisco IOS Release 12.0(3)T
show interfaces cable-modem
Table 6
Show Interfaces Cable-Modem Counters Descriptions (Continued)
Field
Description
Header CRC failures
Number of times a MAC header failed its 16-bit CRC check. The MAC header CRC
is a 16-bit Header Check Sequence (HCS) field that ensures the integrity of the MAC
header even in a collision environment.
Data PDUs
Total number of data PDUs (protocol data units) of all types received by the uBR904.
DS MAC messages
Number of MAC messages received by the uBR904.
Valid Headers
Number of valid headers received by the uBR904, including PDU headers, MAC
headers, and headers only.
Sync losses
Number of times the uBR904 lost timebase sync with the CMTS.
Pulse losses
Number of times the uBR904 did not receive expected timestamp messages from the
CMTS.
BW request failures
Number of times the uBR904 sent the maximum number of re-requests for bandwidth
allocation and the request was still not granted.
Information about routing and bridging protocols and filtering on the cable modem interface is
displayed in the following example:
uBR904# show int cable-modem 0 crb
cable-modem0
Bridged protocols on cable-modem0:
ip
Software MAC address filter on cable-modem0
Hash Len
Address
Matches Act
Type
0x00: 0 ffff.ffff.ffff
3877 RCV Physical broadcast
0x2A: 0 0900.2b01.0001
0 RCV DEC spanning tree
0x7A: 0 0010.7b43.aa01
573 RCV Interface MAC address
0xC2: 0 0180.c200.0000
0 RCV IEEE spanning tree
0xC2: 1 0180.c200.0000
0 RCV IBM spanning tree
Table 7 describes the software MAC address filter information for the cable modem interface.
Table 7
Show Interfaces Cable-Modem Routing and Bridging Descriptions
Field
Description
Hash
Hash key/relative position in the keyed list for this MAC address filter.
Len
Length of this entry to the beginning element of this hash chain.
Address
Canonical (Ethernet ordered) MAC address of this filter.
Matches
Number of received packets that match this MAC address.
Act
Action to be taken when this address is looked up; choices are to receive or discard
the packet.
Type
MAC address type.
Bridging and Routing Features for the Cisco uBR904 Cable Modem 35
Command Reference
Related Commands
cable-mocem compliant bridge
cable-modem downstream saved channel
cable-modem fast-search
show bridge cable-modem
interface cable-modem
36
Cisco IOS Release 12.0(3)T
show interfaces cable-modem
What to Do Next
For additional software configuration information and related documentation, refer to the following
publications:
•
•
•
•
•
•
•
•
•
•
•
•
•
Cisco uBR904 Cable Modem Installation and Configuration Guide
Update to the uBR904 Cable Modem Installation and Configuration Guide
Regulatory Compliance and Safety Information for the Cisco uBR904
Troubleshooting Tips for the Cisco uBR904 Cable Modem
Cisco uBR7246 Installation and Configuration Guide
Cisco uBR7223 Installation and Configuration Guide
Cisco uBR7200 Series Configuration Notes
Cisco Network Registrar for the uBR7200 Series
Cisco uBR7246 Universal Broadband Router Features
Cisco uBR7246 Universal Broadband Router Feature Enhancements
MC16 Modem Card for uBR7246
Regulatory and Safety Compliance for the Cisco uBR7246
Regulatory and Safety Compliance for the Cisco uBR7223
Bridging and Routing Features for the Cisco uBR904 Cable Modem 37
What to Do Next
38
Cisco IOS Release 12.0(3)T
Download PDF