Roland | Picza PIX-4 | User`s manual | Roland Picza PIX-4 User`s manual

User's Manual
Unauthorized copying or transferal, in whole or in part, of this manual is
prohibited.
The contents of this operation manual and the specifications of this product
are subject to change without notice.
The operation manual and the product have been prepared and tested as
much as possible. If you find any misprint or error, please inform us.
Roland DG Corp. assumes no responsibility for any direct or indirect loss
or damage which may occur through use of this product, regardless of any
failure to perform on the part of this product.
* Windows(R) and Windows NT(R) are registered trademark or trademark of Microsoft(R) Corporation in the United States
and/or other countries.
* Pentium is a registered trademark of Intel Corporation in the United States.
* Adobe Acrobat is a trademark of Adobe Systems Incorporated.
Other company names and product name are trademarks or registered trademarks of their respective holders.
Copyright (C) 2001 Roland DG Corporation
Table of Contents
Part 1 What's Dr.PICZA3?...............................................................................................................3
1-1 System Requirements ...................................................................................................................................... 3
1-2 Overview of Dr.PICZA3 ................................................................................................................................. 3
1-3 What You Can Do with Dr.PICZA3 ............................................................................................................... 4
1-4 Names and Functions of Screen Items ............................................................................................................ 5
Part 2 Operation Procedures ............................................................................................................6
Step 1: Connect the computer and the 3D scanner with a cable ............................................................................ 6
Step 2: Choose the communication port ................................................................................................................ 6
Step 3: Load the object to be scanned on the 3D scanner...................................................................................... 6
Step 4: Start scanning ............................................................................................................................................ 7
Step 5: Save the file ............................................................................................................................................... 7
Step 6: Edit the scanned data ................................................................................................................................. 7
Part 3 Hints and Tips.........................................................................................................................8
3-1 Scanning only part of an object ....................................................................................................................... 8
3-2 Beep When Scanning Ends ............................................................................................................................. 8
3-3 Save a file in binary format ............................................................................................................................. 8
3-4 Combine two or more objects.......................................................................................................................... 9
3-5 Change the view method ................................................................................................................................. 9
3-6 Change the view during scanning.................................................................................................................... 9
3-7 Cut the scanning data .................................................................................................................................... 10
3-8 Perform engraving using the data.................................................................................................................. 10
3-9 Compatibility with earlier versions ............................................................................................................... 10
3-10 Changing the Measurement System for Numerical Values......................................................................... 10
Part 4 Commands.............................................................................................................................11
4-1 Toolbar buttons ............................................................................................................................................. 11
4-2 [File] menu .................................................................................................................................................... 13
[File] - [New] command ...................................................................................................................................13
[File] - [Open...] command ...............................................................................................................................13
[File] - [Save] command ...................................................................................................................................13
[File] - [Save As...] command...........................................................................................................................13
[File] - [Export] - [DXF] command ..................................................................................................................14
[File] - [Export] - [STL] command...................................................................................................................14
[File] - [Export] - [Point Group] command ......................................................................................................14
[File] - [Run 3D Editor...] command ................................................................................................................14
[File] - [Run MODELA Player...] command....................................................................................................15
[File] - [Run 3D Engrave...] command .............................................................................................................15
[File] - [Scan] command ...................................................................................................................................15
[Scan] dialog box..............................................................................................................................................16
[Settings for Scanning] dialog box - Rotary Scanning ..................................................................................17
[Settings for Scanning] dialog box - Plane Scanning ....................................................................................19
[File] - [Print...] command ................................................................................................................................21
1
[File] - [Print Preview] command.....................................................................................................................21
[File] - [Page Setup...] command......................................................................................................................21
[Page Setup] dialog box....................................................................................................................................22
[File] - [Preferences...] command .....................................................................................................................23
[Preferences] dialog box ...................................................................................................................................23
[File] - [Exit] command ....................................................................................................................................24
4-3 [Edit] menu.................................................................................................................................................... 25
[Edit] - [Undo] command .................................................................................................................................25
[Edit] - [Redo] command..................................................................................................................................25
[Edit] - [Remove Noise] command...................................................................................................................25
4-4 [View] menu.................................................................................................................................................. 26
[View] - [Top] command..................................................................................................................................26
[View] - [Front] command................................................................................................................................26
[View] - [Fit to Screen] command....................................................................................................................26
[View] - [Coordinates and Distances...] command...........................................................................................26
[Coordinates and Distances] window ...............................................................................................................27
[View] - [Point Group] command.....................................................................................................................27
[View] - [Wire Frame] command .....................................................................................................................27
[View] - [Hide Lines] command.......................................................................................................................28
[View] - [Rendering] command........................................................................................................................28
[View] - [Tool Bar] - [Standard] command......................................................................................................28
[View] - [Tool Bar] - [Edit / View] command..................................................................................................28
[View] - [Status Bar] command........................................................................................................................28
[View] - [Options...] command.........................................................................................................................29
[Options] dialog box .........................................................................................................................................29
4-5 [Select] menu................................................................................................................................................. 30
[Select] - [Select Area With Rectangle] command...........................................................................................30
[Select] - [Select Area With Ellipse] command................................................................................................30
[Select] - [Select Area With Polygon] command .............................................................................................30
4-6 [Help] menu................................................................................................................................................... 31
[Help] - [Contents] command ...........................................................................................................................31
[Help] - [About...] command ............................................................................................................................31
Part 5 If You Think There's a Problem... ......................................................................................32
5-1 3D scanner doesn't function. ......................................................................................................................... 32
5-2 Error Messages.............................................................................................................................................. 32
5-3 Other symptoms ............................................................................................................................................ 34
Items That May Not Be Copied ..................................................................................................35
Appendix ...........................................................................................................................................36
Glossary............................................................................................................................................................... 36
2
Part 1 What's Dr.PICZA3?
1-1 System Requirements
- Microsoft(R) Windows(R) 95, Windows 98, Windows Me, Windows NT(R) 4.0, Windows 2000, or Windows
XP operating system
- The minimum required CPU for the operating system (Pentium(R) or higher recommended)
- The minimum amount of required RAM for the operating system (64 Mbytes or more recommended)
- 10 Mbytes or more of free hard disk space for installation
- 256-color video card with a resolution of 640 x 480 (OpenGL-compatible video board with 800 x 600 resolution
and 16-bit color (High Color) or higher recommended)
* This is the system structure for the PICZA programs, including both Dr. PICZA3 and 3D Editor.
1-2 Overview of Dr.PICZA3
Dr.PICZA3 is a Windows application for controlling the 3D scanner.
Main Features of Dr.PICZA3
Scan a three-dimensional object with the 3D scanner
- Set the scan pitch
- Set the scanning area
- Set the scan quality
- After scanning, set the scanning area and rescan
Examine the object from different angles
Add color to the object's faces (Rendering function)
Export data to 3D Editor, the program for editing 3D data
Export data to MODELA Player, the cutting program
Export data to 3D Engrave (version 1.7 or later), the relief engraving program
3
1-3 What You Can Do with Dr.PICZA3
Scan three-dimensional shapes and create 3D data
You use a 3D scanner from Roland DG Corp. to scan the object to be scanned.
Rescan any locations you want
After scanning, you can change the scanning conditions and scan the areas you want.
Export scanning data to another program
You can export some or all of the scanning data to 3D Editor, MODELA Player, or 3D Engrave.
4
1-4 Names and Functions of Screen Items
(1) Title bar
The file name and program name are displayed here.
The window can be moved by dragging the title bar.
(2) Menu Bar
Runs the various commands for Dr.PICZA3.
(3) Toolbar
The toolbar is provided with buttons for running Dr.PICZA3 commands. Moving the mouse pointer over a button
displays a brief description of the button's function.
(4) Coordinate axis display
This shows the object's coordinate axes. Note that the point of intersection of the coordinate axes is not the origin
point!
(5) Status Bar
This shows Dr.PICZA3's state of operation and provides brief descriptions of commands.
(6) Object
The object that is scanned. Shown as a polyhedron made up of triangles, squares, and other polygons.
(7) Minimize button
This shrinks the window to a button on the taskbar.
(8) Maximize button / Restore button
This expands the window to fill the screen.
To restore the window size, click again.
(9) Close button
This ends the program.
If changes made to the file being edited have not been saved, a dialog box asking if you wish to save the changes
is displayed.
5
Part 2 Operation Procedures
Step 1: Connect the computer and the 3D scanner with a cable
Use a cable to connect the computer and the 3D scanner.
For more information about cable connections, refer to the user's manual for the 3D scanner.
Step 2: Choose the communication port
Start up Dr.PICZA3 and make the choose the communication port that matches the terminal where the cable is
connected.
If the communication port is not set correctly, the 3D scanner will not operate. Be sure to make the setting after
setup.
1. From the [File] menu, click [Preferences...].
The [Preference] dialog box appears.
2. Choose the communication port.
3. Click [OK].
Step 3: Load the object to be scanned on the 3D scanner
Prepare the object to be scanned, and secure it on the 3D scanner.
For information on how to secure it in place, refer to the user's manual for the 3D scanner.
6
Step 4: Start scanning
Scan the object loaded on the 3D scanner.
.
1. Click
The [Scan] dialog box appears.
2. Choose the scanning method, then click the corresponding button.
For more details about the [Scan] dialog box, go to Part 4 Commands and refer to the section on the [Scan] dialog
box.
Log File
When you start scanning, a file called "Dr.PICZA Latest Log.*****.plg" is created in the Dr.PICZA3 folder.
This is a temporary file for holding data during scanning.
If for some reason scanning doesn't end normally, you can use this file to save the data generated while
scanning was in progress.
1. Double-click on the Dr.PICZA Latest Log.*****.plg file.
2. From the [File] menu, click [Save As...].
3. Choose a destination for saving the file and enter a file name.
4. Click [Save].
Step 5: Save the file
Save the scanning data to a file.
.
1. Click
The [Save As] dialog box appears.
2. Choose a location for saving the file.
3. Enter a name for the file.
4. Click the [Save] button.
Step 6: Edit the scanned data
To edit the scanning data, use 3D Editor.
.
1. Click
To export an object or a portion of the object you want to 3D Editor, then before you run this command, select
the area to export.
For information about how to use 3D Editor, refer to the help screens or the manual for 3D Editor.
7
Part 3 Hints and Tips
3-1 Scanning only part of an object
To scan only a portion of an object, limit the scanning area to only the desired portion of the object.
To make the settings for the scanning area, display the [Scan] dialog box and click [Make Settings and Scan].
1. From the [File] menu, click [Scan].
The [Scan] dialog box appears.
2. Click [Make Settings and Scan].
The [Settings for Scanning] dialog box appears.
3. Specify the portion you want to scan as the scanning area.
For more information about how to make the settings for the scanning area, see the section on the [Settings for
Scanning] dialog box.
4. Click [Scan].
3-2 Beep When Scanning Ends
You can play a sound when scanning ends. You can also choose the sound that is played.
1. From the [File] menu, click [Preferences...].
The [Preference] dialog box appears.
2. Select [Beep when scanning ends] to activate it.
3. Click [Browse...].
The [Open] dialog box appears.
4. Specify a sound file in WAV format, then click [Open].
5. To test-play the sound, click the Play button ([
]).
3-3 Save a file in binary format
Scanning data is normally saved in text format.
Saving in binary format can reduce the size of the data compared with text format.
1. From the [File] menu, click [Preferences...].
The [Preference] dialog box appears.
2. Select [Save PIX file in binary format] to activate it.
8
3-4 Combine two or more objects
Use 3D Editor to combine objects into a single object.
With 3D Editor, you can open and edit not only Dr. PICZA data, but also general-use data such as DXF and STL.
For information about how to use 3D Editor, refer to the help screens or the manual for 3D Editor.
3-5 Change the view method
Dr.PICZA3 provides four types of view methods for objects.
You can choose from among Point Group, Wire Frame, Hide Lines, and Rendering to use the view that is best
suited to the task.
Point Group
Wire Frame
Hide Lines
Rendering
Only scanning points are shown.
This is used to confirm the general shape shown only with lines.
This hides lines that normally cannot be seen, making the wire frame easier to view.
This shows the scanned object in a form approximating an actual object.
3-6 Change the view during scanning
You can select any of the following three methods for viewing data during scanning.
Detail View
Simple View
No View
A wire-frame view at the same level of detail as the wire-frame view after scanning
A view of only the wire frames parallel to the scanning direction
No view until after scanning ends
Displaying the scanning data while scanning is in progress lets you monitor the progress of scanning.
To minimize the amount of memory used during scanning, turn off data display while scanning is in progress.
1. From the [File] menu, click [Preferences...].
The [Preference] dialog box appears.
2. To view data on screen while scanning is in progress, select [Show data during scanning] to turn it on
3. When you want to monitor the progress of scanning but don't need a detailed view of the scanned shape, select
[Simple display] to turn it on.
9
3-7 Cut the scanning data
You can cut the 3D data you have scanned using a modeling machine.
You can create reduced-scale objects of a different size than the scan object.
1. To cut only a portion of the scanning data, use the commands on the [Select] menu to specify the range.
2. From the [File] menu, click [Run MODELA Player...].
MODELA Player starts and the scanning data is exported.
3. Operate MODELA Player and set the cutting parameters.
For more information about how to operate MODELA Player, refer to the help screens or the manual for
MODELA Player.
3-8 Perform engraving using the data
You can use the 3D data you have scanned to engrave shapes and text on the surface of a scan object.
1. To engrave only a portion of the scanning data, use the commands on the [Select] menu to specify the range.
2. From the [File] menu, click [Run 3D Engrave...].
3D Engrave starts and the scanning data is exported.
3. Operate 3D Engrave to create a tool path.
The method of engraving on a curved surface is explained in detail in the 3D Engrave help screens, in "Trying
It Out - Engraving on a Curved Surface." Refer to that for more information.
For more information about how to operate 3D Engrave, refer to the help screens or the manual for 3D Engrave.
3-9 Compatibility with earlier versions
You can open files created with version 1.x and 2.x with Dr. PICZA version 3.
When you open a file from an older version, it is converted to the format for version 3. When this happens, color
information is lost.
When you open a file from an older version, the following message appears.
This file was saved using an older version of Dr. PICZA.
Color information is lost.
You cannot save a file in the format for an older version. Files in version 3 format cannot be opened with older
versions of Dr. PICZA.
If you want to keep the older-version file, use the [Save As...] command to save the file with a different name.
3-10 Changing the Measurement System for Numerical Values
The measurement system used for numerical values depends on the unit setting for Windows in effect when
Dr.PICZA3 starts up. The settings for Windows can be changed with [Measurement System] on the [Number]
tab under [Control Panel] - [Regional Setting].
If the measurement system has been changed, Dr.PICZA3 must be stopped and restarted for the new setting to
take effect.
10
Part 4 Commands
4-1 Toolbar buttons
The toolbar is provided with buttons for running Dr.PICZA3 commands. Moving the mouse pointer over a button
displays a brief description of the button's function.
The following buttons are available on the toolbar.
New
This creates a new file.
Open
This opens a Dr.PICZA file.
Save
This saves the file, overwriting the previous version of the file.
Undo
This erases the change just made and returns to the previous form.
Redo
This cancels an [Undo] command that has just been run.
Export
This saves data in a file format other than Dr. PICZA3 format.
Run 3D Editor
This starts 3D Editor, which you can use to edit three-dimensional shapes that have been scanned.
Run MODELA Player
This launches MODELA Player to perform cutting on the Modeling Machine.
Run 3D Engrave
This starts 3D Engrave and exports the scanning data.
Scan
This chooses the scanning method.
Remove Noise
This reduces marked unevenness (noise) on an object or a selected surface, thereby smoothing the surface.
Area Rectangle
This selects polygons by using a rectangle.
11
Area Ellipse
This selects polygons by using an ellipse.
Area Polygon
This selects polygons by using a multi-sided shape.
Rotate Point of View
This command allows the object to be rotated by dragging with the mouse to change the angle of view.
Shortcut:
Hold down the [Space] key while dragging the object.
Using the Arrow Keys
Move Point of View
This command allows the object to be moved by dragging with the mouse.
This is used to view parts of the object which lie beyond the edge of the window.
Shortcut:
Hold down the [Ctrl] key while dragging the object.
Zoom In / Out
This command enlarges or reduces the view of the object.
Drag toward the top of the screen to zoom in or toward the bottom to zoom out.
Shortcut:
Hold down the [Shift] key while dragging the object.
Fit to Screen
This command expands or reduces the size of the object shown to fill the screen.
Point Group
This displays only the scanning points of objects.
Wire Frame
This command displays the object using only a gridwork of lines.
Hide Lines
The lines that represent the back of the object, which ordinarily is hidden from view, are called "hidden
lines."
This command toggles the display of these hidden lines on and off.
Rendering
This command adds color and shadowing to the displayed object.
Coordinates and Distances
This command toggles display of the [Coordinates and Distances] window on or off.
12
4-2 [File] menu
[File] - [New] command
This creates a new file.
If changes made to a file being edited have not been saved, a window asking if you wish to save the changes is
displayed.
Toolbar button:
Keyboard shortcut: [Ctrl]+[N]
[File] - [Open...] command
This opens a Dr.PICZA file.
Running this command opens the [Open] dialog box.
If changes made to a file being edited have not been saved, a window asking if you wish to save the changes is
displayed.
Toolbar button:
Keyboard shortcut: [Ctrl]+[O]
[File] - [Save] command
This saves the file, overwriting the previous version of the file.
To save the file with a different name or in a different area, use the [Save As...] command.
Toolbar button:
Keyboard shortcut: [Ctrl]+[S]
[File] - [Save As...] command
This saves the file with a different name.
Running this command opens the [Save As] dialog box.
Normally, ".pix" is used as the file extension.
13
[File] - [Export] - [DXF] command
This saves the 3D data as a file in DXF format.
When you have specified an area or object, only the selected portion is saved.
The output file can be read by applications that support the DXF file format. Color information for rendering is
not saved.
Toolbar button:
[File] - [Export] - [STL] command
This saves the 3D data as a file in STL format. Color information for rendering is not saved.
When you have specified an area or object, only the selected portion is saved.
Running this command displays a dialog box for choosing the STL file format.
Make sure the program supports the STL file format, then choose either [Text] or [Binary] format. If both are
supported, it is usually better to choose the binary format, which uses comparatively less space.
Toolbar button:
[File] - [Export] - [Point Group] command
This saves the coordinate values of polygon vertices as a text file.
When you have specified an area or object, only the selected portion is saved.
The coordinates are exported in one of the following formats, depending on the separator character. The
coordinate values are in millimeters.
Comma:
Space:
Tab:
<X coordinate>, <Y coordinate>, <Z coordinate> [CR][LF]
<X coordinate> <Y coordinate> <Z coordinate> [CR][LF]
<X coordinate> [TAB] <Y coordinate> [TAB] <Z coordinate> [CR][LF]
* [CR] and [LF] are new-line control codes.
* [TAB] is tab control codes.
Toolbar button:
[File] - [Run 3D Editor...] command
This starts 3D Editor, which you can use to edit three-dimensional shapes that have been scanned.
You can perform such tasks as changing the size or severing a three-dimensional shape, or reducing the number of
polygons.
By selecting polygon and then running this command, you can export only the selected portion to 3D Editor.
Toolbar button:
14
[File] - [Run MODELA Player...] command
This launches MODELA Player to perform cutting on the Modeling Machine.
By selecting polygon and then running this command, you can export only the selected portion to MODELA
Player.
Toolbar button:
[File] - [Run 3D Engrave...] command
This starts 3D Engrave and exports the scanning data.
You can engrave shapes and text on the surface of the scan object.
By selecting polygon and then running this command, you can export only the selected portion to 3D Engrave.
3D Engrave version 1.7 or later is required.
Toolbar button:
[File] - [Scan] command
This chooses the scanning method.
Running this command opens the [Scan] dialog box.
Toolbar button:
15
[Scan] dialog box
This automatically sets the scanning conditions and performs rotary scanning.
Choose this to scan objects that are nearly spherical or cylindrical, and that have smooth curves with little
unevenness.
Make Settings and Scan - Rotary Scanning
This manually sets the scanning conditions and performs rotary scanning.
Clicking this button opens the [Settings for Scanning] dialog box.
16
[Settings for Scanning] dialog box
- Rotary Scanning
This shows the displayed scanning area as a three-dimensional solid or as a plane.
This rotates the displayed scanning area by five degrees in the direction of the arrow.
Preview
This performs a rough scan of the shape of the scan object and adds a view of the scanning area.
Circumferential
Enter the circumferential scanning area.
To limit the scanning area, enter the scan-start (first) and scan-end (last) angles, referenced to 0 degrees.
The orientation of 0 degrees differs according to the model of 3D scanner.
To perform scanning over the entire direction without limiting the angle, enter from 0 to 360.
Height
Enter the scanning area in the height direction.
17
Circumferential pitch
This sets the angle of adjacent scanning points or the number of scanning points on the circumference.
Height-direction pitch
This sets the distance between scan points.
A narrower scan pitch results in scanning of greater precision, but the scan time also becomes
correspondingly longer. Conversely, a wider scan pitch yields shorter scan times, but scanning results are
rougher.
Required memory
This calculates the amount of memory that the program uses during scanning, based on the number of
scanning points.
The actual required amount of memory is not determined solely by the number of scanning points, so this
value is not necessarily accurate. Please consider it a rough estimate.
Estimated Scan Time
This estimates the scanning time based on the scanning parameters that have been set.
This performs complex calculations based on such factors as the number and locations of the scanning
point and the scanning speed of the 3D scanner, yielding a rough calculation of the scanning time.
.
To recalculate the estimated time after changing the scanning parameters, click
Scan
This starts scanning on the 3D scanner.
Rescan
This lets you specify a portion of a scanned object that you want to rescan, then rescan it with changed
conditions. After the previous scanning, continue with rescanning without removing the scan object from the
scanner.
This is available only for objects that have been rotary scanned.
To redo a portion whose shape is different from the scan object, click
.
To make a partial change in scanning pitch, click
.
You can specify a number of areas, but you can't set different scanning pitches for individual areas. The
selection can be canceled by clicking the right button.
Running this command opens the [Select Scanning Area Mode] dialog box.
Selecting a scanning area narrower than three times the scanning pitch results in an error message.
18
This automatically sets the scanning conditions and performs plane scanning.
This is an all-powerful scanning method that has fewer shape-related restrictions than rotary scanning.
Make Settings and Scan - Plane Scanning
This manually sets the scanning conditions and performs plane scanning.
Clicking this button opens the [Settings for Scanning] dialog box.
[Settings for Scanning] dialog box
- Plane Scanning
Surfaces to Scan
This sets the number of scanning surfaces.
When divided into two or more surfaces, the scanning data for the respective surfaces is merged after
scanning.
You cannot change the angle of the scanning surfaces.
This rotates the displayed scanning area by five degrees in the direction of the arrow.
This shows the displayed scanning area as a three-dimensional solid or as a plane.
19
Preview
This performs a rough scan of the shape of the scan object and adds a view of the scanning area.
Height
Enter the scanning area in the height direction.
The scanning area is applied to all surfaces, and cannot be set individually for each surface.
Width
Enter the scanning area in the width direction.
The scanning area is applied to all surfaces, and cannot be set individually for each surface.
Offset Amount
Enter the amount of displacement from the center of the plane. You can make this setting only when you
are scanning a single surface.
Pitch
This sets the distance between scan points.
A narrower scan pitch results in scanning of greater precision, but the scan time also becomes
correspondingly longer. Conversely, a wider scan pitch yields shorter scan times, but scanning results are
rougher.
Required memory
This calculates the amount of memory that the program uses during scanning, based on the number of
scanning points.
The actual required amount of memory is not determined solely by the number of scanning points, so this
value is not necessarily accurate. Please consider it a rough estimate.
Estimated Scan Time
This estimates the scanning time based on the scanning parameters that have been set.
This performs complex calculations based on such factors as the number and locations of the scanning
point and the scanning speed of the 3D scanner, yielding a rough calculation of the scanning time.
.
To recalculate the estimated time after changing the scanning parameters, click
Scan
This starts scanning on the 3D scanner.
20
[File] - [Print...] command
This sends the image on the screen to the printer.
By selecting an object and running this command, you can print only the selected portion.
Running this command opens the [Print] dialog box. This dialog box is normally used to make settings for paper
size, orientation, number of copies, and the like, but the available setting items will vary according to the printer.
Keyboard shortcut: [Ctrl]+[P]
[File] - [Print Preview] command
This allows you to check the printing results on-screen before actually printing the data.
Running this command makes the window change to the Preview screen.
Preview screen commands
Print...
This performs printing. The [Print] dialog box appears.
Page Setup... This allows you to make settings for paper size, margins, and the like. The [Page Setup] dialog
box appears.
Zoom In
This enlarges the view size of the print image.
Zoom Out
This reduces the view size of the print image.
Close
This closes the Preview screen for printing.
[File] - [Page Setup...] command
This allows you to set the printing position and size.
Running this command displays the [Page Setup] dialog box.
21
[Page Setup] dialog box
Position
This displays, as numerical values, the object's printing position on the paper.
The values show the object's distance in millimeters (or inches) from the paper's upper-left edge.
The printing position can also be set by typing in numerical values directly in the text box.
Paper Size
This displays the paper's printing area without margins.
To change the paper size or type of printer, click [Printer Setup...].
Gray Area
The gray squares indicate the size of the object when printed.
This square can be dragged to change the object's position on paper when printed. Dragging a square pointer
( ) changes the size of the object on the paper. The object's vertical and horizontal ratio is always maintained
[Preview...] button
This allows you to check the printing results on-screen before actually printing the data.
Running this command makes the window change to the Preview screen.
Preview screen commands
Print...
This performs printing. The [Print] dialog box appears.
Page Setup... This allows you to make settings for paper size, margins, and the like. The [Page Setup]
dialog box appears.
Zoom In
This enlarges the view size of the print image.
Zoom Out
This reduces the view size of the print image.
Close
This closes the Preview screen for printing.
22
[File] - [Preferences...] command
This allows you to switch the display of data while scanning on or off, select a file format, switch the beep when
scanning ends on or off, and select a communication port.
Running this command makes the [Preferences] dialog box appear.
[Preferences] dialog box
Show data during scanning
This constantly updates the on-screen image of the object as it is being scanned.
When this is off, the scanned object isn't shown until after scanning has finished. To minimize memory use
during scanning, turn off this setting.
Simple display
This displays a simplified image of the object while scanning is in progress.
Select this when it's not necessary to display the shape of the object in detail while scanning is in progress, or
when you want to monitor scanning progress. This command is enabled when "Show data during scanning" is
on.
Use triangular planes
When this is selected, the shape of the object's planes changes from quadrilaterals to triangles.
Disable data not on pitch
When you are using a 3D scanner with automatic correction, then depending on the shape of the scan object,
points that lie between the scanning pitch may be scanned.
When this setting is on, points scanned because of such correction are ignored. Unless a special requirement
exists, this should normally be left off.
23
Save PIX file in binary format
This saves a Dr.PICZA3 file (PIX file) in binary format.
This can reduce the size of the file compared with when the setting is off (text format).
Beep when scanning ends
This plays a sound to signal when scanning ends.
To choose a sound type, click [Browse...]. To test-play a chosen sound, click the Play button ([ ]).
You can specify a file in WAV format as the signal sound. WAV is a sound-data file format used as a standard
for Windows.
Undo Count
This determines the number of operations that can be canceled using the [Undo] command.
Port
This sets the communication port for connecting the 3D scanner to the computer with a cable.
The 3D scanner and the computer cannot communicate if the port is not set correctly.
[File] - [Exit] command
This ends the program.
If changes made to the file being edited have not been saved, a dialog box asking if you wish to save the changes
is displayed.
Shortcut:
Click the button for closing the application window.
24
4-3 [Edit] menu
[Edit] - [Undo] command
This erases the change just made and returns to the previous form.
Toolbar button:
Keyboard shortcut: [Ctrl]+[Z]
[Edit] - [Redo] command
This cancels an [Undo] command that has just been run.
Toolbar button:
Keyboard shortcut: [Ctrl]+[Y]
[Edit] - [Remove Noise] command
This reduces marked unevenness (noise) on an object or a selected surface, thereby smoothing the surface.
Height is adjusted so as to reduce differences in height (along the Z axis) between adjacent scan points.
Toolbar button:
25
4-4 [View] menu
[View] - [Top] command
This displays the object drawn in the XY plane using the perspective projection method.
The view is expanded or reduced in size to fill the screen.
Because the orientation of the coordinate axis may vary according to the 3D scanner, this may not produce a
figure as seen from above in actual space.
[View] - [Front] command
This displays the object drawn in the XZ plane using the perspective projection method.
The view is expanded or reduced in size to fill the screen.
Because the orientation of the coordinate axis may vary according to the 3D scanner, this may not produce a
figure as seen from front in actual space.
[View] - [Fit to Screen] command
This command expands or reduces the size of the object shown to fill the screen.
Toolbar button:
[View] - [Coordinates and Distances...] command
This command toggles display of the [Coordinates and Distances] window on or off.
Display the [Coordinates and Distances] window to find out the coordinates of a point or the distance between two
points.
Toolbar button:
26
[Coordinates and Distances] window
Current
This displays the coordinates of the mouse pointer (X/Y/Z) at all times.
Point 1
This shows the coordinates (X/Y/Z) of the position where you first click the mouse.
When it is difficult to specify the point, then move or rotate objects, or zoom in or out.
Move
Drag while holding down the [Ctrl] key.
Rotate
Drag while holding down the [Space] key.
Zoom in/zoom out
Drag while holding down the [Shift] key.
Point 2
This shows the coordinates (X/Y/Z) of the position you click after you specify "Point 1."
When it is difficult to specify the point, then move or rotate objects, or zoom in or out.
Move
Drag while holding down the [Ctrl] key.
Rotate
Drag while holding down the [Space] key.
Zoom in/zoom out
Drag while holding down the [Shift] key.
Dist.
This shows the distance from "Point 1" to "Point 2" for each axis (X/Y/Z).
Length
This shows the linear distance from "Point 1" to "Point 2."
[View] - [Point Group] command
This displays only the scanning points of objects.
To change the color of the points, from the [View] menu, click [Options...].
Toolbar button:
[View] - [Wire Frame] command
This command displays the object using only a gridwork of lines.
To change the color of the frame, from the [View] menu, click [Options...].
Toolbar button:
27
[View] - [Hide Lines] command
The lines that represent the back of the object, which ordinarily is hidden from view, are called "hidden lines."
This command toggles the display of these hidden lines on and off.
This command can be useful when the view of the object is cluttered by too many lines, making it hard to make
out the front and back of the object.
To change the color of the frame, from the [View] menu, click [Options...].
Toolbar button:
[View] - [Rendering] command
This command adds color and shadowing to the displayed object.
To change the color of rendering, from the [View] menu, click [Options...].
Toolbar button:
[View] - [Tool Bar] - [Standard] command
This command toggles display of the Standard tool bar on or off.
[View] - [Tool Bar] - [Edit / View] command
This command toggles display of the Edit / View tool bar on or off.
[View] - [Status Bar] command
This command toggles display of the status bar window on or off.
The status bar shows helpful comments amount commands. We recommend leaving the status bar on until you're
familiar with how Dr.PICZA3 works.
Turning off the status bar enlarges the object's display area.
28
[View] - [Options...] command
This specifies the drawing method and color scheme for the screen display.
Running this command makes the [Options] dialog box appear.
[Options] dialog box
Drawing
This specifies the command set (graphic library) used to draw three-dimensional shapes on the screen.
Generally, high-speed drawing is performed when you specify a general-use library such as [OpenGL]. If the
display is corrupt, make the setting in [Software], or adjust the operating system's setting for [Hardware
acceleration].
General-use libraries that the operating system does not include are not displayed as selections.
Foreground
This specifies the color for Wire Frame view and Point Group view.
Clicking this opens [Color] dialog box.
Surface
This specifies the colors for the surfaces of objects when in Rendering view.
Clicking this opens [Color] dialog box.
Background
This specifies the background color for objects.
Clicking this opens [Color] dialog box.
29
4-5 [Select] menu
[Select] - [Select Area With Rectangle] command
This selects polygons by using a rectangle.
The rectangle is created by the placing the mouse pointer at the desired start point (the corner of the rectangle),
then dragging. This selected area is shown in red.
To select more than one area, drag the object while holding down the [Shift] key. At this time, you cannot zoom in
or out by dragging an object while holding down the [Shift] key.
To cancel the selection, click the right button.
Toolbar button:
[Select] - [Select Area With Ellipse] command
This selects polygons by using an ellipse.
The ellipse is created by the placing the mouse pointer at the desired start point (the corner of a quadrilateral
circumscribed by the ellipse or circle), then dragging. This selected area is shown in red.
To select more than one area, drag the object while holding down the [Shift] key. At this time, you cannot zoom in
or out by dragging an object while holding down the [Shift] key.
To cancel the selection, click the right button.
Toolbar button:
[Select] - [Select Area With Polygon] command
This selects polygons by using a multi-sided shape.
The point clicked first becomes the polygon's start point. The polygon's apices are then created by clicking at the
desired point for each. The end point for the polygon is set by double-clicking.
To select more than one area, drag the object while holding down the [Shift] key. At this time, you cannot zoom in
or out by dragging an object while holding down the [Shift] key.
To cancel the selection, click the right button.
Toolbar button:
30
4-6 [Help] menu
[Help] - [Contents] command
This displays the contents page for online help.
[Help] - [About...] command
This displays the version number and copyright information for Dr.PICZA3.
31
Part 5 If You Think There's a Problem...
5-1 3D scanner doesn't function.
Has the correct port been selected for Dr.PICZA3?
The communication port is selected with Dr.PICZA3's [File] - [Preferences...] command.
Make sure the port where the cable is connected has been correctly selected.
5-2 Error Messages
"Unexpected file format."
Make sure the file you want to open is a Dr.PICZA file.
Dr. PICZA can't open a file saved using [Export] from the [File] menu.
"Low on memory"
If insufficient memory occurs during processing, close all other applications or restart Windows.
If the message about insufficient memory still appears, check the amount of free space on your hard disk.
Windows normally uses a portion of the hard disk for virtual memory, and it may be that there is not enough space
left on the hard disk. If this is the case, free up space on the hard disk by deleting unneeded files or moving them
to another disk. If the message about insufficient memory still appears after doing this, it is recommended that you
increase the amount of memory in your computer.
"Memory will be too low for scanning with this setting. Resize the scanning area smaller or make the
scanning pitch larger."
The amount of memory require to scan the selected area exceeds the amount of memory that is now available.
If you try to perform scanning without changing this setting, you may run out of memory while scanning is in
progress.
If this happens, you can resolve the problem with one or more of the following procedures.
- Reduce the width of the scanning area.
- Enlarge the scanning pitch.
- Close all other applications.
- Restart Windows.
- Free up space on the hard disk.
If the same message appears even after you've taken action as described above, we recommend increasing the
amount of memory installed in your computer.
"The scanning area is too small."
A scanning area narrower than three times the scanning pitch was set.
Make the scanning area wider, or make the scanning pitch narrower.
"Can't find 3D Editor"
3D Editor cannot be found your hard disk.
Install 3D Editor.
"Can't find MODELA Player"
MODELA Player cannot be found your hard disk.
Install MODELA Player.
32
"Can't find 3D Engrave"
3D Engrave cannot be found your hard disk.
Install 3D Engrave.
"3D Editor is not in 'exe' format. File is missing or corrupted."
3D Editor cannot be started correctly.
If the same message keeps appearing, reinstall 3D Editor.
"MODELA Player is not in 'exe' format. File is missing or corrupted."
MDDELA Player cannot be started correctly.
If the same message keeps appearing, reinstall MODELA Player.
"3D Engrave is not in 'exe' format. File is missing or corrupted."
3D Engrave cannot be started correctly.
If the same message keeps appearing, reinstall 3D Engrave.
"File required by PICZA Driver not found. Please reinstall."
A file needed by PICZA Driver could not be found. Reinstall PICZA Driver.
"Cannot communicate with present scanner.. Try again?"
Test communication with the 3D scanner received no response.
Check the following.
- Is the power to the 3D scanner turned on?
-> Turn on the power.
- Is the cable disconnected or loose?
-> Connect the cable securely.
- Is the correct cable used to make the connection?
-> For information about cables, refer to the user's manual for the 3D scanner.
- Is the port selection correct?
-> Use the [File] - [Preference...] command to check the setting for the communication port.
"Library for the [Model Name] not found. Reinstall."
A library file for the 3D scanner (a file containing hardware information) cannot be found. Reinstall PICZA
Driver.
"[Port Name] not ready. Please verify that the port is valid or is not in use by another application."
The specified port is not in a usable state.
Make sure the specified port is not incorrect and is not being used by a printer driver. A port now in use cannot be
used concurrently.
"[File Name] was not found."
This message appears when the specified file in the [Recent File] list from the [File] menu cannot be found.
You can't open a file from the [Recent File] list when the location of the file you specify has been moved or the
specified file has been deleted.
Also, after this message appears, the name of the file that could not be found is removed from the [Recent File]
list.
"Data cannot be saved. Either there are only points and lines but no surface, or there is no surface whose
height is 0 (zero)."
There are no valid polygon surfaces, so the data could not be saved to another 3D program (file).
Data that contains only points and lines cannot be saved.
If there are no polygon surfaces within the specified range, reselect the range.
33
"It is likely that the scanning time will greatly exceed the estimate. To make the actual time match the
estimated time more closely, clear the selection for showing data during scanning. Do you want to scan with
[Preferences] - [Show data during scanning] turned off?"
The time required to display an object on screen is the main cause of differences between estimated and actual
times.
To switch off the display of data while scanning is in progress, click [Yes]. Doing this clears the selection for
[Show data during scanning] in the [Preferences] dialog box.
To display data while scanning, click [No].
To keep this message from appearing again, select [Do not show this message again]. (The setting for [Do not
show this message again] is not saved, and it returns to the default setting when you restart Dr. PICZA.)
"Could not detect scan object."
An object that cannot be scanned is mounted on the scanner, or no object is mounted.
For more information about objects that cannot be scanned, refer to the user's manual for the 3D scanner.
If no object to be scanned is mounted on the scanner, then mount a scan object.
5-3 Other symptoms
The [Settings for Scanning] dialog box display is garbled.
Upgrading to the latest version of the display driver may correct this problem.
34
Items That May Not Be Copied
Unauthorized reproduction of a copyrighted item for any purpose other than personal use may be a violation of
copyright. Roland DG Corp. will not be responsible for any violation of third-party copyright by any article
made through use of this product.
35
Appendix
Glossary
Dr. PICZA files
A file saved in Dr. PICZA format. This normally has ".pix" as the extension.
DXF
DXF, the proprietary format for AutoCAD®, is also widely used as a format for exchanging data between
different applications. 3D Editor can export files in the DXF format for AutoCAD® Release 12.
Object
This refers to a three-dimensional object shown on the Dr. PICZA screen.
OpenGL
OpenGL is a one of high-performance graphics library for 3D graphics and image processing.
When you use a commercially available 3D accelerator board for OpenGL drawing in your computer, you can
make the drawing speed for 3D models even faster.
Polygon
"Polygon" refers to a multi-sided shape, and is the commonest method used in 3D computer graphics to represent
surfaces.
Dr. PICZA uses triangular polygons or quadrilateral polygons, according to the circumstances.
STL
STL (Stereo Lithography file) is a data format that lets different 3D applications exchange data.
The STL format represents solid objects as a collection of triangles.
36
R3-011227
Download PDF