RAMMS 1.3.0

RAMMS 1.3.0

4 Working with RAMMS

4.1 General

To successfully start a new RAMMS project, a few important preparations are necessary.

Topographic input data (ascii format), project boundary coordinates and georeferenced maps or remote sensing imagery should be prepared in advance (.tif format and .tfw file, maps and imagery are not mandatory, but nice to have). Georeferenced datasets have to be in a Cartesian coordinate system (e.g. Swiss CH1903+ LV95), polar coordinate systems

(e.g. WGS84 Long Lat) are not supported. Fore more information about specific national coordinate systems please contact the national topographic agency.

4.1.1 Project / Scenarios

A project is defined for a region of interest. Within a project, one or more scenarios can be specified and analyzed. For every scenario, a calculation can be executed. A project consists therefore of different scenarios (input files) with different input parameter files (release and friction files). The basic topographic input data is the same for every scenario. If you want to change the topographic input data (e.g. change the input DEM resolution or the project boundary coordinates) you have to create a new project. Other input parameters (like friction parameters, release areas, calculation domain, calculation grid resolution, end time, time step etc.) can be changed for every scenario.

23

CHAPTER 4. WORKING WITH RAMMS

Figure 4.1: Project extent (area of interest) - topographic map c

(BA091601).

4.1.2 Input data

There are different kind of data to be provided to successfully perform a calculation with

RAMMS. Topographic data, definition of release area and release mass as well as information about friction parameters are mandatory.

RAMMS is able to process (see Figs.

4.2

and

4.3

)

• ESRI ASCII Grid and

• ASCII X,Y,Z single space data.

These data types are also available e.g. from www.swisstopo.ch. Because RAMMS needs the topographic data as an ESRI ASCII Grid, ASCII X,Y,Z data can be converted within

RAMMS into an ESRI ASCII Grid.

4.2 Model input data

24 RAMMS User Manual

4.2. MODEL INPUT DATA

4.2.1 Topographic data - Digital Elevation Model

The topographic data is the most important input requirement. The simulation results depend strongly on the resolution and accuracy of the topographic input data. The topographic data MUST be provided as an ESRI ASCII Grid. No other type is allowed at the moment. The user must therefore prepare the topographic data according to this limitation. The header of an ESRI ASCII Grid must contain the information shown in

Fig.

4.2

Figure 4.2: Example ESRI ASCII Grid.

An ESRI ASCII GRID can be created in ArcGIS with the function ArcToolbox→Conversion

Tools→From Raster→Raster to ASCII.

It is possible to import ASCII X,Y,Z single space data and convert the data into an ESRI

ASCII Grid (using Track→New...→Convert XYZ to ASCII Grid ).

4.2.2 Forest information

Forest information is not required for a successfull simulation, but recommended, because the friction parameters depend strongly on forest information. Forest information can be provided as:

• ESRI ASCII GRID (0: no forest, 1: forest)

• Polygon shapefile

WSL Institute for Snow and Avalanche Research SLF 25

CHAPTER 4. WORKING WITH RAMMS

Figure 4.3: Example ASCII X,Y,Z single space data.

If no such files are available, the user can draw a polygon shapefile in RAMMS and import it as forest information (see section

4.10

on page

51 ).

4.2.3 Release information

The definition of release areas and release heights have a very strong impact on the results of RAMMS simulations. Therefore we recommend to use reference information such as photography, GPS measurements or filed maps to draw release areas. This should be done by people with experience concerning the topographic and meteorological situation of the investigation area.

Users have to draw their own release polygon shapefiles, see section

4.6

on page

40 . All

release informations are saved as polygon shapefiles and can be easily imported in GIS-

Software (e.g. ArcGIS). Shapefiles created in e.g. ArcGIS can be imported into RAMMS by using GIS/GRASS → Convert Shapefile... → Polygon Shapefile to RAMMS Release

Shapefile.

4.2.4 Global parameters

The two global parameters return period and avalanche volume category influence the classification of the friction information.

26 RAMMS User Manual

4.3. THE PROJECT WIZARD

4.2.5 Friction information

An automatic RAMMS procedure calculates friction values based on topographic data analysis (slope angle, altitude and curvature), forest information and global parameters, see section

4.8

on page

46 . All friction informations are saved as polygon shapefiles and

can be easily imported in GIS-Software (e.g. ArcGIS).

4.2.6 Calculation parameters

Calculation parameters such as output name, simulation grid resolution, end time, time step etc. can be changed interactively in RAMMS.

4.3 The Project Wizard

A new project is created with the RAMMS Project Wizard, shown in the exercise below.

The wizard consists of four steps:

WSL Institute for Snow and Avalanche Research SLF 27

CHAPTER 4. WORKING WITH RAMMS

Exercise 4.3.a: How to create a new project.

Click or Track ⇒ New ⇒ Project wizard to open the RAMMS Project

Wizard.

The following window pops up:

28

Figure 4.4: RAMMS Avalanche Project Wizard: Step 1 of 4.

RAMMS User Manual

4.3. THE PROJECT WIZARD

Step 1:

Enter a project name (1).

Add some project details (2).

The project location (3) suggested is the current working directory. To change the location click into the location field. A second window appears and you can browse for a different folder (see figure below, VERY IMPORTANT: Do NOT use BLANKS or special characters in the project location path!).

◦ Click Next (4).

Figure 4.5: Step 1 of the RAMMS project wizard: Project information.

Figure 4.6: Window to browse for a new project location.

Step 2:

Locate your DEM- and FOREST-file in the folder set in the RAMMS preferences. Click into the corresponding fields to browse for the appropriate files

(1).

If you don’t want to use a FORESTfile, select ”Do NOT use forest information” (2).

Click Next (3).

Figure 4.7: information.

Step 2 of the

RAMMS project wizard: GIS

WSL Institute for Snow and Avalanche Research SLF 29

CHAPTER 4. WORKING WITH RAMMS

Step 3:

Enter the X- and Y-coordinates of the lower left and upper right corner of your project area, using the Swiss Coordinate System CH1903+ LV95 (or another cartesian coordinate system), as it is shown below for the Valle de la Sionne area.

swisstopo (BA091601).

30

Figure 4.9: Step 3 of the RAMMS project wizard: Project boundary coordinates.

RAMMS User Manual

4.3. THE PROJECT WIZARD

Step 4:

Check the project summary, especially if a DEM- and

FOREST-file was found.

To make changes click Previous, to create the project click Create Project Example1.

Figure 4.10: Step 4 of the RAMMS project wizard: Project summary.

End of exercise 4.3.a

WSL Institute for Snow and Avalanche Research SLF 31

CHAPTER 4. WORKING WITH RAMMS

The creation process can take a while. Different status bars will pop up and show the progress of the project creation process, see table below:

Progress bar Purpose

GRASS function: Import the

DEM file

GRASS function: Import the

FOREST file and export the file forest5m.asc

GRASS function: Export the file Example1.xyz with the topographic data

Reading topographic data (x-, y- and z-coordinates).

Analysing the topography and calculating curvature and slope angles

Preparing topography for displaying in RAMMS

Searching georeferenced maps in the Maps-Folder

32 RAMMS User Manual

4.3. THE PROJECT WIZARD

If more than one map was found, the user can select a map

If the map is much bigger than the project-region, the user can crop the map to improve the quality of the mapvisualization

Searching georeferenced maps in the Orthophoto-Folder

If no image was found, the user can specify another folder or abort the process

WSL Institute for Snow and Avalanche Research SLF 33

CHAPTER 4. WORKING WITH RAMMS

The following files will be created in the project-folder

34

File / Folder doc (folder) grassloc (folder) logfiles (folder) shell (folder)

.grassrc6

dhm.asc

Example1.av2

Example1.dom

Example1 dom.shp

Example1 dom.shx

Example1 dom.dbf

Example1.xyz

forest shp.shp

forest shp.shx

forest shp.dbf

Figure 4.11: Created project files.

Purpose

Folder containing input and ouput LOG files

Folder containing GRASS files: do NOT delete or change them

Log-files for GRASS operations

Folder containing GRASS shell scripts

GRASS ini file: do NOT delete or change

ASCII Grid with altitude values

Input file

Calculation domain ASCII file

Calculation domain shapefile

Calculation domain shapefile

Calculation domain shapefile

Topographic data used in RAMMS

Extracted forest shapefile

Extracted forest shapefile

Extracted forest shapefile

RAMMS User Manual

4.4. MOVING, RESIZING AND CHANGING THE VIEW OF THE MODEL forest5m.asc

ASCII Grid with forest information (0:no forest,

1:forest)

4.4 Moving, resizing and changing the view of the model

Once the project is created, there are several useful tools that might be helpful when working with RAMMS. They are explained in the excercises below.

WSL Institute for Snow and Avalanche Research SLF 35

CHAPTER 4. WORKING WITH RAMMS

Exercise 4.4.a: Moving and resizing the model

a) Terrain model has a dimension of 100% or smaller:

By clicking on the ”arrow” , the model can be moved and resized.

Swisstopo (BA091601)

◦ To move the model without changing size or aspect ratio, move to the model and check if the cursor turns to . Then click and hold the left mouse button and drag the model to the desired position.

To resize the model without changing the aspect ratio, move to one of the green corners. If the cursor turns to , click and hold the left mouse button. By moving the mouse towards the model, the size will be reduced (move away to enlarge the model). Alternatively you can resize the model by changing the percentage value in the horizontal toolbar .

36 RAMMS User Manual

4.4. MOVING, RESIZING AND CHANGING THE VIEW OF THE MODEL

To resize the model by changing the aspect ratio, go on one of the green lines.

When the mouse cursor changes to , click and hold the left mouse button and change the size by moving the mouse.

b) Terrain model has a dimension > 100%:

All steps explained above are still possible. Especially for the last two steps explained, the view of one of the corners or lines is required.

In addition to this, the white hand right next to the rotation button becomes active as well. After clicking on this so-called ”view pan” button , it is also possible to move the model.

End of exercise 4.4.a

Exercise 4.4.b: Rotating the model

◦ After activating the rotation button , the model can be rotated along the rotation axis, by moving the cursor directly on one of the axis until the cursor changes from to . Otherwise a freehand rotation in any direction is possible.

Figure 4.13: ”Active” project with rotation axes, topographic map c

(BA091601).

End of exercise 4.4.b

WSL Institute for Snow and Avalanche Research SLF 37

CHAPTER 4. WORKING WITH RAMMS

Exercise 4.4.c: How to switch between 2D and 3D mode

Click to switch from 3D to 2D view. This button then changes to by clicking again, you will return to 3D view.

and

38

Figure 4.14: 3D view of example Figure 4.15: 2D view of example stopo (BA091601).

stopo (BA091601).

In 2D-mode you have all possibilities that you know from 3D-mode. It works for input files as well as for simulations. For the following functions of RAMMS it is necessary to switch from 3D to 2D view:

INPUT:

New release area

Release area information

Edit Release area

New domain

OUTPUT:

Line profile

End of exercise 4.4.c

RAMMS User Manual

4.5 Global parameters

4.5. GLOBAL PARAMETERS

Figure 4.16: RAMMS global parameters.

Prior to creating a new muxi-file, choose the return period and the volume category. The

MuXi-file will be calculated based on these values. Changing the return period and/or volume category has no effect on already existing muxi-files. The default volume category is chosen based on the specified release volume.

WSL Institute for Snow and Avalanche Research SLF 39

CHAPTER 4. WORKING WITH RAMMS

4.6 Release areas

There are different possibilities to include a release area into the project. This is of course necessary to run a calculation. The following table gives an overview of the possibilities

RAMMS offers. For further explanations see the exercises below.

Create a new release area

Load an existing release area

Import a shapefile and convert it to a release area

If there is no release area available for your project, or you wish to create a new one, switch to 2D mode and click .

Load an existing release area with Input ⇒ Release area ⇒ Load existing release area.

Draw a release area using a GIS-tool and save it as shapefile (.shp).

Then convert the shapefile using

GIS/GRASS ⇒ Convert Shapefile ⇒ Polygon

Shapefile to RAMMS Release Shapefile.

The defnition of release areas and release heights have a very strong impact on the results of RAMMS simulations. Therefore we recommend to use reference information such as photography, GPS measurements or filed maps to draw release areas. This should be done by people with experience concerning the topographic and meteorological situation of the investigation area.

40 RAMMS User Manual

4.6. RELEASE AREAS

Exercise 4.6.a: How to create a new release area.

Switch to 2D mode by clicking .

Activate the project by clicking on it once.

Click .

Click into the project where you want to start drawing the outline of the release polygon.

◦ Continue drawing the release polygon by moving the cursor and clicking the left mouse button.

To end the release polygon, double-click the left mouse button. The polygon will be closed automatically.

Figure 4.17: Project with emerging release area.

Before the release area is created, you have to answer a few questions:

Add more release areas?

You can either answer with Yes and create a second release polygon as explained above or answer with No and continue with the next step.

Choose a new release filename:

Enter a new name for the release area. The ending *rep.shp is added automatically.

The release area will now be created and opened directly, as well as the colorbar.

End of exercise 4.6.a

WSL Institute for Snow and Avalanche Research SLF 41

CHAPTER 4. WORKING WITH RAMMS

Exercise 4.6.b: How to load an existing release area.

◦ Choose Input→Release area→Load existing release area.

Select release file (*rep.shp) and click open.

⇒ The release area appears in the project as well as the colorbar for the variable release height (m)

End of exercise 4.6.b

42 RAMMS User Manual

4.6. RELEASE AREAS

Once a release area is created or loaded, you have to specify the release height. Choose

Input→Release Area...→View and Edit Release Areas or click the button and choose the release area polygon by selecting it with the left mouse button. The appearing window yields information about release area, mean slope angle, mean altitude and estimated release volume. And, most importantly, the release height can be entered, see exercise below.

Additional release information is found in the avalanche panel in the volumes-tab, see

Figure below.

Figure 4.18: Release area and volume information.

WSL Institute for Snow and Avalanche Research SLF 43

CHAPTER 4. WORKING WITH RAMMS

Exercise 4.6.c: Specify release height and view release information

Switch into 2D mode by clicking .

Click on the ”View and Edit Release Information” button (in the horizontal toolbar or in the Volumes-tab in the panel) or choose Input→Release

Area...→View and Edit Release Areas.

Then click on the release area you want to get information on. A red polygon is drawn around the selected release area. The following window appears:

44

Figure 4.19: Release area information window.

Remark: The estimated release volume shown is estimated, calculated with a mean slope angle for the whole release area.

To change the release height enter a new value (the resulting release volume is directly adjusted. Click OK if you want to keep the changes, Cancel otherwise.

End of exercise 4.6.c

RAMMS User Manual

4.7. CALCULATION DOMAIN

4.7 Calculation Domain

To save calculation time you can specify a calculation domain. If you know where the avalanche path is situated (e.g. by running a calculation with a coarse cell size, e.g. 25m), you can exclude the area which is not of interest. Switch to 2D mode and chose Input

→ Calculation Domain... → Draw new Domain. Now you can draw a polygon containing the area of interest accordingly to drawing a new release area (see exercise ”Create release area” on page

40 ). We strongly recommend to use Calculation Domains especially

if you calculate with small cell sizes (e.g. < 5m).

Figure 4.20: Calculation domain in green confines the area of interest and saves calculation time.

WSL Institute for Snow and Avalanche Research SLF 45

CHAPTER 4. WORKING WITH RAMMS

4.8 Friction parameters

RAMMS employs a Voellmy-fluid friction model. This model divides the frictional resistance into two parts: a dry-Coulomb type friction (coefficient µ) that scales with the normal stress and a velocity squared drag (coefficient ξ). The frictional resistance S (Pa) is then

Figure 4.21: RAMMS Voellmy-fluid friction model.

where ρ is the flow density, g gravitational acceleration, φ the slope angle, H the flow height and U the flow velocity. This model has found wide application in the simulation of mass movements, especially snow avalanches. The Voellmy model has been in use in

Switzerland for a long time and a set of calibrated parameters is available.

RAMMS offers a constant and a variable calucation mode. If a calculation is done with constant friction values, of course, no terrain undulations and forest areas are considered.

Therefore we suggest to use the variable friction values if possible. µ and ξ depend strongly on the global parameters return period and avalanche volume. Therefore, you

MUST define an appropriate return period and check your avalanche volume in the Global

Parameters (Input→Global Parameters) BEFORE creating a new MuXi file!

46 RAMMS User Manual

4.8. FRICTION PARAMETERS

Figure 4.22: RAMMS — Automatic MuXi Procedure.

How to create a new MuXi file is demonstrated in the exercise ”How to create a new MuXi file” on page

47

below.

Before running a calculation, make sure you chose variable friction parameters if you want to take the topography into account (Mu/Xi tab in the Run calculation window).

In case you closed and then reopened a project and did not save it with the created MuXi file, you can simply load the MuXi file again and do not have to create it again (see exercise

”How to load an existing MuXi file” on page

47 ).

WSL Institute for Snow and Avalanche Research SLF 47

CHAPTER 4. WORKING WITH RAMMS

Exercise 4.8.a: How to create a new MuXi file.

Choose Input→Friction Values...→Create new MuXi file (Automatic

Procedure).

Enter a file name.

Unless you know better, leave the values as they are...

Click OK.

The MuXi file will be loaded after it is created. If you create the first MuXi file for this project, this procedure can take a while, depending on your computer’s performance (CPU and RAM). The creation of following MuXi files will be much faster.

You can switch between the release area (if already loaded), the Mu and Xi value via the avalanche panel.

End of exercise 4.8.a

48

Exercise 4.8.b: How to load an existing MuXi file.

Choose Input→Friction values→Load existing MuXi file.

A window opens to browse for an existing MuXi file (*MuXi.shp)

Click Open and the file will be loaded.

End of exercise 4.8.b

RAMMS User Manual

4.9. COLORBAR

4.9 Colorbar

As soon as a parameter is shown in the project, the colorbar appears on the right side of the main window. It can be turned on and off by clicking on .

Exercise 4.9.a: Editing the colorbar

Changing the min and max values of the colorbar as well as changing the number of colors used is done in the Avalanche Panel under Display.

Simply type a new value into the respective field and hit the return key on the keyboard. The display will be refreshed.

A further, very helpful thing to change is the transparency. This is useful when the topography should be visible through the avalanche.

ATTENTION: The line Values < x.xxx are not displayed!! is important.

Depending on your min and max values, check this line to know, which values are not displayed!

Figure 4.23: The avalanche ’Display’ panel.

WSL Institute for Snow and Avalanche Research SLF 49

CHAPTER 4. WORKING WITH RAMMS

Open the editing window by either choosing

Edit→Edit colorbar properties (only

INPUT) or clicking in the vertical toolbar.

To change the colorbar properties simply click into the field you want to change, then click OK.

Figure 4.24: The colorbar properties window.

End of exercise 4.9.a

50 RAMMS User Manual

4.10. FOREST

4.10 Forest

It is necessary to take forest areas into account, when running a simulation with variable friction parameters (Mu and Xi).

The easiest way to consider forest, is to have a digital forest file (ASCII grid or forest shapefile) located in the folder set in the RAMMS preferences (FOREST directory). In this case the forest file will already be included while creating the project. Step 2 of the

RAMMS::Avalanche Project Wizard deals with the DEM- and FOREST-files. Click into the field once, to browse for your FOREST-file.

If you have a forest-file available and located in the FOREST folder but don’t want to use it, click ”Do NOT use forest information”. This is necessary, e.g., if you want to simulate a situation without considering the forest.

WSL Institute for Snow and Avalanche Research SLF 51

CHAPTER 4. WORKING WITH RAMMS

Exercise 4.10.a: How to create a FOREST file.

Switch to 2D mode by clicking .

Activate project by clicking on the map once.

Click or choose Input→Forest...→Draw New Forest Areas.

Trace the forest outline by creating as many FOREST area polygons as necessary (proceed as in exercise ”How to create a new release area” on page

40 )

and name your new FOREST file. A new FOREST shapefile is saved.

You are asked, if you want to import the created FOREST file into your project.

Click YES, if you want to use the newly created FOREST (ignore the next point in this case). Otherwise click NO and import the FOREST file later, as explained in the next point.

Import the new FOREST shapefile: Choose Input→Forest...→Import Forest Area From SHAPEFILE, then select your FOREST shapefile.

This new FOREST information is not automatically taken over in existing

MuXi-files. Therefore, recreate existing MuXi-files if needed. If you create a new MuXi file with Input→Friction Values...→Create new MuXi file

(Automatic Procedure), the forest will now be considered.

End of exercise 4.10.a

52 RAMMS User Manual

4.11. PROJECT INFORMATION

4.11 Project information

There are two ways to view your project settings and information. First you can open your project’s input log file (or output log file, in OUTPUT mode), or you can check your project’s region extent and area in the avalanche panel in the region tab.

You can open the project’s input log with Project→Project Input

Log. The following window opens:

This window provides information about all your project’s input specifications, like number of nodes and cells, release areas, forest files, used DEM, the loaded map and ortho images as well as your global simulation parameters.

Figure 4.25: RAMMS Project Input Log Information.

WSL Institute for Snow and Avalanche Research SLF 53

CHAPTER 4. WORKING WITH RAMMS

Figure 4.26: Region extent (X-, Y- and

Z-Coordinates, total area).

To view the project coordinates, click the region tab in your avalanche panel. The region tab lists X- and Y-Coordinates of the lower left (min values) and upper right (max values) corner (this are the coordinates you entered when creating the project) as well as the global minimum and maximum of altitude (Z value). The

X- and Y-Coordinates do not correspond exactly to the clipping values you entered at creation time of the project. This is due to the clipping algorithm in GRASS.

Additionally, the total region area is shown (in km

2

).

54 RAMMS User Manual

4.12. CHANGING MAPS AND REMOTE SENSING IMAGERY

4.12 Changing maps and remote sensing imagery

It is possible to change the map or imagery of a project anytime. Take into account, that the corresponding TFW-file (world-file) has to be in the same folder as the actual map

(*.tif). If this is not the case, the map will not be found!

Exercise 4.12.a: How to add or change maps.

Go to Extras→Add/Change Map.

If more than one map is found, the following window pops up, listing the maps found:

Figure 4.27: Window to choose map image.

Information on the image dimensions (x-Dim and y-Dim, pixel) and size (in

MB) are provided and might be a selection criterion.

Select the map you wish to add and click Load selected map.

If the question ”No map found, continue search?” appears, you either don’t have an appropriate map, the Map-folder directory is set wrong or the map is saved in a different folder. In the latter case click Yes and choose the correct folder.

Click No to cancel search.

Click Yes to continue search.

A window pops up to browse for the correct map location and file.

WSL Institute for Snow and Avalanche Research SLF 55

CHAPTER 4. WORKING WITH RAMMS

If the question ”Map area is much larger than your region! Do you wish to crop the map?” appears, as it says, your map is much larger than your project area.

Click No to load the map without croping. It may lead to a bad resolution.

We suggest to click Yes. The map will be cropped to the same size as the project region. A window opens to enter a name for the new map. The default saving location is the one set in the RAMMS preferences. You can change it if necessary.

End of exercise 4.12.a

Exercise 4.12.b: How to add or change remote sensing imagery.

Go to Extras→Add/Change image.

See exercise ”How to add and change maps” on page

55

above.

End of exercise 4.12.b

To check which map and imagery are currently loaded in the project, open the project input (or output) log (Project→Project Input Log. Next to ”Map image:” and ”Ortho image:” you will find the location and name of the loaded map and imagery, respectively.

56 RAMMS User Manual

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project