RAMMS 1.3.0

RAMMS 1.3.0

5 Calculation and Results

5.1 Running a calculation

To run a calculation one has to have created a project, loaded a release area and if a calculation with variable friction parameters is desired, a muxi-file must have been created as well. Below you find two short examples, one for running a constant calculation (constant release height and constant friction parameters µ and ξ) and one for using variable release height and friction parameters.

57

CHAPTER 5. CALCULATION AND RESULTS

Exercise 5.1.a: How to run a constant avalanche calculation.

To run a calculation choose Run→Run Avalanche Calculation or click .

The RAMMS::Input Parameters window opens.

Before clicking RUN CALCULATION, you should check the input parameters.

General:

(1) Project name

(2) Project infos. You can change them by simply typing into the field.

(3) Additional information: Calculation domain file and DEM file.

(4) Select an output filename.

Figure 5.1: General information.

58 RAMMS User Manual

5.1. RUNNING A CALCULATION

Params:

(1) Change grid resolution, if necessary.

(2) Choose end time of simulation.

(3) Choose dump step interval.

(4) Keep the default value for density.

(5) Change numerical solver, 1st or 2nd order scheme (we recommend 2nd order).

Figure 5.2: Calculation parameters

Mu/Xi:

(1) For a calculation with constant MuXi-values, click constant.

(2) Enter Mu and Xi values.

Choose Help→RAMMS

Manuals...→Friction Parameter Table (PDF) or see friction value table in the appendix for an idea of µ and

ξ!

Figure 5.3: Friction values MuXi.

◦ Release:

(1) The text field should indicate your release shapefile.

(2) The estimated release volume is stated in the second text field.

Figure 5.4: Release information.

WSL Institute for Snow and Avalanche Research SLF 59

CHAPTER 5. CALCULATION AND RESULTS

◦ Stop:

(1) The stopping criteria in

RAMMS is based on the momentum.

In classical mechanics, momentum (SI unit kgm/s, or, equivalently,

Ns) is the product of the mass and velocity of an object (p

= mv).

For every DUMP

STEP, we sum the momenta of all grid cells, and compare it with the maximum momentum sum. If this percentage is lower than a user defined threshold value (see below), the program is interrupted and the avalanche is regarded as stopped. Threshold values between 1-10% are reasonable, but this is only a suggestion and must be validated by the individual user himself.

Figure 5.5: Stop criteria.

60 RAMMS User Manual

5.1. RUNNING A CALCULATION

Click RUN CALCULATION (fig.

5.4

).

The following window appears, showing the status of the calculation.

Figure 5.6: Status window of calculation.

Once it’s finished, the simulation is opened in RAMMS.

End of exercise 5.1.a

WSL Institute for Snow and Avalanche Research SLF 61

CHAPTER 5. CALCULATION AND RESULTS

Exercise 5.1.b: How to run a variable avalanche calculation.

The process for a variable calculation is almost the same than for a constant calculation! Therefor this exercise only shows the difference to the exercise above (exercise

”How to run a constant avalanche calculation” on page

57 ).

Mu/Xi:

(1) For a calculation with variable

MuXi-values, click variable.

(2) Check, if the correct MuXi-file is used.

If a different file should be used, click into the field and browse for the desired file.

Figure 5.8: MuXi settings for a variable calculation.

End of exercise 5.1.b

62 RAMMS User Manual

5.2. RESULTS

5.2 Results

This section just gives a short overview on what is possible to do with the simulation results. The interpretation of the results has to be done by an avalanche expert who is familiar with the topographic and meteorological situation of the investigation area. The

RAMMS simulation results should not be used without questioning them! Perform sensitivity studies!

The drop down menu Results offers the following functions:

• Flow Height

• Flow Velocity

• Flow Pressure

• Flow Momentum

• Max values (Height, Velocity, Pressure, Momentum)

• DEM Adaptations (Add Deposition to DEM)

• Flow Analysis (Summary of Moving Mass)

• Friction Values (Mu, Xi)

These results are all visualized by a colorplot in the topography. See exercise ”Displaying max values” on page

64 .

In the horizontal toolbar you find two further functions:

• Line Profile

• Time plot

Line profile

A line profile is a good alternative to the color plot, if the avalanche snow height, velocity or pressure should be known at a specific location. The graph shows the currently active parameter. Every line profile is saved in the file profile.txt in the project directory. If you want to keep this line profile, you have to save it, see exercise ”How to draw a line profile” on page

64 .

WSL Institute for Snow and Avalanche Research SLF 63

CHAPTER 5. CALCULATION AND RESULTS

Time plot

This function provides a time plot at a single point. This is helpful, when knowing the position of an obstacle (building, dam, tree...) and the (max) values at this location over time are a relevant information. Every point is saved in the file point.txt and a pointinfo file point info.txt is additionally saved in the project directory. If you want to keep this point, you have to save it, see exercise ”How to create a timeplot” on page

64 . The

point-info file can be visualized with Extras→Point...→View Point Info File.

Exercise 5.2.a: Displaying max values of flow height, flow velocity and pressure.

The maximum values of snow height, velocity and pressure give a good view on the dimension of the avalanche. You find them under

Results ⇒ Max values...

⇒ Max flow height

⇒ Max velocity

⇒ Max pressure

64

Figure 5.9: Results: Maximum values of flow height (left), velocity (middle) and pressure

End of exercise 5.2.a

RAMMS User Manual

5.2. RESULTS

Exercise 5.2.b: How to draw a line profile.

a) Draw a new line profile:

Switch to 2D mode by clicking .

Activate the project by clicking on it once, then click

Extras→Profile...→Draw New Line Profile.

or choose

Define the line profile in the same way you specify a new release area. Finish the line profile with a double-click with the left mouse button.

A window opens, displaying the line profile.

Figure 5.10: Line profile plot.

filled grey area → active parameter (scale on left side).

red line → active parameter (multiplied by 50) added to the track profile (altitude, scale on the right side).

black line → track profile (altitude, scale on the right side).

bottom scale: projected profile distance (in m).

If you change the active parameter, min or max values or the dump step in

RAMMS, the plot is directly updated. You can also start the simulation and then watch the time variations in your line profile plot.

It makes sense to either draw a profile line perpendicular to the flow direction or to draw the line along the avalanche path. Basically every imaginable path is possible.

WSL Institute for Snow and Avalanche Research SLF 65

CHAPTER 5. CALCULATION AND RESULTS

66

Figure 5.11: Line profile perpendicular to flow direction, topographic map

Figure 5.12: Line profile along the

Swisstopo (BA091601).

To save the coordinates of the points belonging to the line profile, go on

Extras→Profile...→Save Line Profile Points and enter a file name.

To save the line profile parameters (distance in m and the active parameter, e.g.

the flow height in m) at the current dump step, go on

Extras→Profile...→Export Profile Plot Data and enter a file name.

RAMMS User Manual

5.2. RESULTS b) Load an existing line profile:

Switch to 2D mode by clickin .

Activate the project by clicking on it once and click

Extras→Profile...→Draw New Line Profile.

Click the middle mouse button once.

or choose

A window pops up and you can browse for the line profile you wish to open.

End of exercise 5.2.b

Exercise 5.2.c: How to create a time plot.

a) Select time plot point:

Click or choose Extras→Point...→Choose Point.

Click into the map at the point where you want to create a time plot.

◦ A window opens, displaying the time plot a the point of interest (active parameter vs time).

Figure 5.13: Time plot window.

WSL Institute for Snow and Avalanche Research SLF 67

CHAPTER 5. CALCULATION AND RESULTS

To save the point coordinates, choose Extras→Point...→Save Point Location and enter a file name.

To save the time plot data (time in s and the active paramter, e.g. the flow height, for every dump step), choose Extras→Point...→Export Point Plot

Data and enter a file name.

b) Load a time plot:

To reopen the time plot graph window of the last selected point, go on

Extras→Point...→Create Point Time Plot.

To open an arbitrary time plot that was saved anytime before, click .

Click the middle mouse button once.

A window pops up and you can browse for the time plot file you wish to open.

End of exercise 5.2.c

68

Exercise 5.2.d: Enter point coordinates and get a time plot.

Go to Extras→Point...→Enter Point Coordinates (X/Y).

Enter X-coordinate of your point of interest. Click OK.

Enter Y-coordinate of your point of interest. Click OK.

The time plot opens.

End of exercise 5.2.d

RAMMS User Manual

5.3. EXTRAS

5.3 Extras

5.3.1 Creating an image and a GIF animation

Image:

It is possible to export your results as an image in different formats (e.g. .png, .jpg, .gif

. tif etc.). Choose Track→Export... and define a new file name with the corresponding extension or click . An image of the visible part in the viewer will then be saved.

GIF animation:

Creating a GIF animation is of course only possible in output mode.

Click and wait until the simulation stopped and a window opened. Enter a file name and location. The GIF animation folder as well as the corresponding gif animation file is saved in the simulation folder. In the avalanche tab in the preferences you can define the interval for the GIF animation (GIF animation interval (s)).

WSL Institute for Snow and Avalanche Research SLF 69

CHAPTER 5. CALCULATION AND RESULTS

5.3.2 Creating a dam

RAMMS offers the possibility, to simulate a dam by increasing the altitude at the position where a dam should be considered.

Exercise 5.3.a: How to create a new DEM to simulate a dam.

Create a polygon (”release area”) where a dam is supposed to be build.

Create a second, inner polygon, if you wish to have a two-stage dam.

Go on GIS/GRASS→Add DAM to DEM....

You will be asked to ”Open dam file (*.rel)”. Select the shapefile you want to use as the outer edge of the dam.

The question pops up, if you want to ”Open 2nd dam shapefile (inner polygon)?”

• Click No to continue with the next step.

• Click Yes to choose 2nd dam file (*.rel).

Next step is to ”Enter TOTAL elevation height of dam (m)”.

This is the elevation (masl.) of the dam crest.

If you loaded an inner polygon file, you will be asked to ”Enter intermediate height (m)” as well.

At last you have to ”Enter new DEM name”. Your new DEM, containing the

”dam” is created in the folder set as DEM directory (RAMMS preferences ).

End of exercise 5.3.a

To run a simulation based on the new created DEM, you first have to create a new project.

Do almost exactly the same as if creating a regular project without the dam information.

The only important difference is, that you have to choose the correct DEM-file manually during step 2 of the project wizard.

70 RAMMS User Manual

5.3. EXTRAS

Figure 5.14: Project before (top) and after (bottom) creating a dam,

(BA091601).

Figure 5.15: Avalanche beeing stopped by

(BA091601).

WSL Institute for Snow and Avalanche Research SLF 71

CHAPTER 5. CALCULATION AND RESULTS

5.3.3 Creating a new DEM with avalanche deposition

In case you wish to simulate an avalanche flowing down over an old avalanche, you should take into acount the deposition of the first avalanche, because the path of the second avalanche will be influenced by the changed terrain.

In output mode RAMMS provides the option of adding the snow height of an avalanche, at an arbitrary dump step, to the DEM. A new project can be created based on the updated

DEM.

Exercise 5.3.b: How to add avalanche deposition to new DEM.

The deposition height of the avalanche varies with time. So first run the simulation to the specific dump step.

Go to Results→DEM Adaptations→Add Deposition to DEM.

Enter a new name for the new DEM.

The new DEM, containing the deposition information, is created. To run a simulation based on this DEM create a new project and manually choose the

DEM file during step 2 of the wizard as explained above for the dam.

End of exercise 5.3.b

72 RAMMS User Manual

5.4. HOW TO SAVE INPUT FILES AND PROGRAM SETTINGS

5.4 How to save input files and program settings

Once a project is created, it is saved under the name and location you entered during step 1 of the RAMMS::Avalanche Project Wizard (see figure

4.5

on page

29 ). The created

inputfile has the ending *.av2.

The second situation in which the input file is saved automatically, is when a calculation is started. The saved input file has the same name as the created output file.

Exercise 5.4.a: How to save input files and program settings manually.

a) Input file:

In case you want to save the input file manually before running a calculation, go on Track→Save. This is helpful, when a release area and muxi-file was loaded but you wish to close the project before doing the calculation.

If you wish to save a copy of your file under a new name, go on Track→Save

Copy As or click .

A window pops up to choose an old file which should be overwritten or to type in a new name, then click Save.

Continue working on the original file, not the just saved one!

b) Program settings:

If you have moved and/or rotated your project for a better view, you can save this position by going on Extras→Save Active Position.

You can now get back to this position anytime by choosing Extras→Reload

Position.

End of Example 5.4.a

WSL Institute for Snow and Avalanche Research SLF 73

CHAPTER 5. CALCULATION AND RESULTS

5.5 How to open input and output files

Exercise 5.5.a: How to open an input file.

Close any active project file.

Go to Track→Open...→Inputfile or click .

A window opens to browse for an avalanche input file (*.av2).

◦ Click Open after file name was selected.

The project will be opened.

End of Example 5.5.a

Exercise 5.5.b: How to open an output file/avalanche simulation.

Close any active project file.

◦ Go to Track→Open...→Avalanche Simulation or click .

A window opens to browse for an avalanche simulation file (*.out.gz)

Click OK.

The simulation will be opened.

End of Example 5.5.b

Exercise 5.5.c: How to load an optional shapefile.

To load a shapefile, click .

A window opens to browse for a shapefile (*.shp).

Click Open after file was selected.

End of Example 5.5.c

74 RAMMS User Manual

5.6. ABOUT RAMMS

5.6 About RAMMS

Some information about the RAMMS installation on your computer is found here: ?→About

RAMMS....

Figure 5.16: About RAMMS...

WSL Institute for Snow and Avalanche Research SLF 75

CHAPTER 5. CALCULATION AND RESULTS

76 RAMMS User Manual

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project