QGIS User Guide - OSGeo Server

QGIS User Guide - OSGeo Server

4 FEATURES AT A GLANCE

4. Features at a Glance

After a first and simple sample session in Section

3

we now want to give you a more detailed overview of the features of QGIS. Most features presented in the following chapters will be explained and described in own sections later in the manual.

4.1. Starting and Stopping QGIS

In Section

3.3

you already learned how to start QGIS. We will repeat this here and you will see that

QGIS also provides further command line options.

Assuming that QGIS is installed in the PATH, you can start QGIS by typing: qgis at a command prompt or by double clicking on the QGIS application link (or shortcut) on the desktop or in the application menu.

• Start QGIS using the Start menu or desktop shortcut, or double click on a QGIS project file.

Double click the icon in your Applications folder. If you need to start QGIS in a shell, run

/path-to-installation-executable/Contents/MacOS/Qgis.

To stop QGIS, click the menu options { File QGIS} > Quit, or use the shortcut

¨

Ctrl+Q .

§

¥

¦

4.1.1. Command Line Options

QGIS supports a number of options when started from the command line. To get a list of the options, enter qgis --help on the command line. The usage statement for QGIS is: qgis --help

Quantum GIS - 1.4.0-Enceladus ’Enceladus’ (exported)

Quantum GIS (QGIS) is a viewer for spatial data sets, including raster and vector data.

Usage: qgis [options] [FILES] options:

[--snapshot filename]

[--width width]

[--height height]

[--lang language]

[--project projectfile] emit snapshot of loaded datasets to given file width of snapshot to emit height of snapshot to emit use language for interface text load the given QGIS project

[--extent xmin,ymin,xmax,ymax] set initial map extent

[--nologo] hide splash screen

[--help] this text

QGIS 1.4.0 User Guide 16

4.1

Starting and Stopping QGIS

FILES:

Files specified on the command line can include rasters, vectors, and QGIS project files (.qgs):

1. Rasters - Supported formats include GeoTiff, DEM and others supported by GDAL

2. Vectors - Supported formats include ESRI Shapefiles and others supported by OGR and PostgreSQL layers using the PostGIS extension

Tip 2 E

XAMPLE

U

SING COMMAND LINE ARGUMENTS

You can start QGIS by specifying one or more data files on the command line. For example, assuming you are in the qgis_sample_data directory, you could start QGIS with a vector layer and a raster file set to load on startup using the following command: qgis ./raster/landcover.img ./gml/lakes.gml

Command line option

--snapshot

This option allows you to create a snapshot in PNG format from the current view. This comes in handy when you have a lot of projects and want to generate snapshots from your data.

Currently it generates a PNG-file with 800x600 pixels. This can be adapted using the --width and

--height command line arguments. A filename can be added after --snapshot .

Command line option

--lang

Based on your locale QGIS, selects the correct localization.

If you would like to change your language, you can specify a language code. For example: --lang=it starts QGIS in italian localization. A list of currently supported languages with language code and status is provided at http://www.qgis.org/wiki/GUI_Translation_Progress

Command line option

--project

Starting QGIS with an existing project file is also possible.

Just add the command line option

--project followed by your project name and QGIS will open with all layers loaded described in the given file.

Command line option

--extent

To start with a specific map extent use this option. You need to add the bounding box of your extent in the following order separated by a comma:

--extent xmin,ymin,xmax,ymax

QGIS 1.4.0 User Guide 17

4 FEATURES AT A GLANCE

Command line option

--nologo

This command line argument hides the splash screen when you start QGIS.

4.2. QGIS GUI

When QGIS starts, you are presented with the GUI as shown below (the numbers 1 through 6 in yellow ovals refer to the six major areas of the interface as discussed below):

Figure 2: QGIS GUI with Alaska sample data (KDE)

Note: Your window decorations (title bar, etc.) may appear different depending on your operating system and window manager.

The QGIS GUI is divided into six areas:

QGIS 1.4.0 User Guide 18

4.2

QGIS GUI

1. Menu Bar

2. Tool Bar

3. Map Legend

4. Map View

5. Map Overview

6. Status Bar

These six components of the QGIS interface are described in more detail in the following sections.

4.2.1. Keyboard shortcuts

QGIS provides default keyboard shortcuts for many features. You find them in Section

4.2.2

below. Additionally the menu option Settings > Configure Shortcuts allows to change the default keyboard shortcuts and to add new keyboard shortcuts to QGIS features.

Figure 3: Define shortcut options (KDE)

Configuration is very simple. Just select a feature from the list and click on Change , Set none or Set default . Once you have found your configuration, you can save it as XML file and load it to another QGIS installation.

4.2.2. Menu Bar

The menu bar provides access to various QGIS features using a standard hierarchical menu. The top-level menus and a summary of some of the menu options are listed below, together with the icons

QGIS 1.4.0 User Guide 19

4 FEATURES AT A GLANCE of the corresponding tools as they appear on the toolbar, as well as keyboard shortcuts.

2

Although most menu options have a corresponding tool and vice-versa, the menus are not organized quite like the toolbars. The toolbar containing the tool is listed after each menu option as a checkbox entry. For more information about tools and toolbars, see Section

4.2.3

.

Menu Option Shortcut Reference Toolbar

File

New Project

Open Project

Open Recent Projects

Save Project

Save Project As

Save as Image

New Print Composer

Composer manager

Print Composers

Exit

¨

Ctrl+N

Ctrl+O

§

¨

Ctrl+P

§

¥

¦

¨

Ctrl+S

¥

¦

Ctrl+Shift+S

§

¥

¦

¥

¦

¨

Ctrl+Q

§

¥

¦ see Section

4.5

see Section

4.5

see Section

4.5

see Section

4.5

see Section

4.5

see Section

4.6

see Section

10

see Section

10

see Section

10

File

File

File

File

File

File

Edit

Undo

Redo

Cut Features

Copy Features

Paste Features

Move Feature

Delete Selected

Simplify Feature

Add Ring

Add Part

Delete Ring

Delete Part

¨

Ctrl+Z

¦

Ctrl+Shift+Z

¥

Ctrl+X

Ctrl+C

¥

Ctrl+V

§ ¦

¥

¦ see Section

5.5.5

see Section

5.5.5

see Section

5.5.4

see Section

5.5.4

see Section

5.5.4

see Section

5.5.4

see Section

5.5.4

see Section

5.5.5

see Section

5.5.5

see Section

5.5.5

see Section

5.5.5

see Section

5.5.5

⊠ Advanced Digitizing

⊠ Advanced Digitizing

Digitizing

⊠ Digitizing

Digitizing

Digitizing

⊠ Digitizing

⊠ Advanced Digitizing

Advanced Digitizing

⊠ Advanced Digitizing

Advanced Digitizing

⊠ Advanced Digitizing

2

Keyboard shortcuts can now be configured manually (shortcuts presented in this section are the defaults), using the

Configure Shortcuts tool under Settings Menu.

QGIS 1.4.0 User Guide 20

Reshape Features

Split Features

Merge selected Features

Node Tool

Rotate Point Symbols

4.2

QGIS GUI see Section

5.5.5

⊠ Advanced Digitizing see Section

5.5.5

⊠ Advanced Digitizing see Section

5.5.5

Advanced Digitizing see Section

5.5.4

⊠ Digitizing see Section

5.5.5

Advanced Digitizing

After activating toogle editing mode for a layer, you will find a capture feature icon in the Edit menu depending on the layer type (point, line or polygon).

Capture Point

Capture Line

Capture Polygon see Section

5.5.4

Digitizing see Section

5.5.4

Digitizing see Section

5.5.4

⊠ Digitizing

View

Pan Map

Zoom In

Zoom Out

Select Features

Deselect Features

Identify Features

Measure Line

Measure Area

Zoom Full

¨

Ctrl++

¥

Ctrl+-

§ ¦

¤

I

¡

¢

¥

M

¡

¦

J

¢

¥

F

§ ¦

Map Navigation

⊠ Map Navigation

Map Navigation

⊠ Attributes

Attributes

⊠ Attributes

Attributes

Attributes

Map Navigation

4 FEATURES AT A GLANCE

Layer

New Vector Layer

¨

Ctrl+Shift+N

¥ see Section

5.5.6

Add Vector Layer

Add Raster Layer

Add PostGIS Layer

Add SpatiaLite Layer

Add WMS Layer

Ctrl+Shift+V

Ctrl+Shift+R

Ctrl+Shift+D

Ctrl+Shift+L see Section see Section see Section see Section

5

6

5.2

5.3

Ctrl+Shift+W see Section

7.2

§ ¦

Open Attribute Table

Toggle editing

Save As Shapefile

Save Selection As Shapefile

Remove Layer

¨

Ctrl+D

§

Properties

Add to Overview

¥

¦

¨

Ctrl+Shift+O

§

Add All To Overview

¥

¦

Remove All From Overview

¨

Hide All Layers

Ctrl+Shift+H

¥

Show All Layers

Ctrl+Shift+S

§ ¦

Manage Layers

File

⊠ File

File

⊠ File

File

Attributes

⊠ Digitizing

Properties

Manage Layers

Manage Layers

⊠ Manage Layers

Settings

Panels

Toolbars

Toggle Fullscreen Mode

Project Properties

Custom CRS

Style Manager

Configure shortcuts

Options

¨

P

§

¥

¦ see Section see Section see Section

4.5

8.4

4.7

Plugins - (Futher menu items are added by plugins as they are loaded.)

Manage Plugins

Python Console see Section

11.1

Plugins

QGIS 1.4.0 User Guide 22

4.2

QGIS GUI

Help

Help Contents

QGIS Home Page

Check QGIS Version

About

¨

F1

¥

¦

Ctrl+H

§

¥

¦

Help

Note:

The Menu Bar items listed above are the default ones in KDE window manager. In GNOME,

Settings menu is missing and its items are to be found there:

Project Properties

Options

Custom CRS

Panels

Toolbars

Toggle Fullscreen Mode

File menu

⊠ Edit

⊠ Edit

View

View

⊠ View

4.2.3. Toolbars

The toolbars provide access to most of the same functions as the menus, plus additional tools for interacting with the map. Each toolbar item has popup help available. Hold your mouse over the item and a short description of the tool’s purpose will be displayed.

Every menubar can be moved around according to your needs. Additionally every menubar can be switched off using your right mouse button context menu holding the mouse over the toolbars.

Tip 3 R

ESTORING TOOLBARS

If you have accidentally hidden all your toolbars, you can get them back by choosing menu option Settings >

Toolbars .

4.2.4. Map Legend

The map legend area is used to set the visibility and z-ordering of layers. Z-ordering means that layers listed nearer the top of the legend are drawn over layers listed lower down in the legend. The checkbox in each legend entry can be used to show or hide the layer.

Layers can be grouped in the legend window by adding a layer group and dragging layers into the group. To do so, move the mouse pointer to the legend window, right click, choose Add group . A

QGIS 1.4.0 User Guide 23

4 FEATURES AT A GLANCE new folder appears. Now drag the layers onto to the folder symbol. It is then possible to toggle the visibility of all the layers in the group with one click. To bring layers out of a group, move the mouse pointer to the layer symbol, right click, and choose Make to toplevel item . To give the folder a new name, choose Rename in the right click menu of the group.

The content of the right mouse button context menu depends on whether the loaded legend item you hold your mouse over is a raster or a vector layer. For GRASS vector layers the toggle editing is not available. See section

9.7

for information on editing GRASS vector layers.

Right mouse button menu for raster layers

Zoom to layer extent

Zoom to best scale (100%)

Show in overview

Remove

Properties

Rename

Add Group

Expand all

Collapse all

Right mouse button menu for vector layers

Zoom to layer extent

Show in overview

Remove

Open attribute table

Toggle editing (not available for GRASS layers)

Save as shapefile

Save selection as shapefile

Properties

QGIS 1.4.0 User Guide 24

4.2

QGIS GUI

Rename

Add Group

Expand all

Collapse all

Right mouse button menu for layer groups

Remove

Rename

Add Group

Expand all

Collapse all

If several vector data sources have the same vector type and the same attributes, their symbolisations may be grouped. This means that if the symbolisation of one data source is changed, the others automatically have the new symbolisation as well. To group symbologies, open the right click menu in the legend window and choose

Show file groups . The file groups of the layers appear. It is now possible to drag a file from one file group into another one. If this is done, the symbologies are grouped. Note that QGIS only permits the drag if the two layers are able to share symbology (same vector geometry type and same attributes).

4.2.5. Map View

This is the ’business end’ of QGIS - maps are displayed in this area! The map displayed in this window will depend on the vector and raster layers you have chosen to load (see sections that follow for more information on how to load layers). The map view can be panned (shifting the focus of the map display to another region) and zoomed in and out. Various other operations can be performed on the map as described in the toolbar description above. The map view and the legend are tightly bound to each other - the maps in view reflect changes you make in the legend area.

Tip 4 Z

OOMING THE

M

AP WITH THE

M

OUSE

W

HEEL

You can use the mouse wheel to zoom in and out on the map. Place the mouse cursor inside the map area and roll the wheel forward (away from you) to zoom in and backwards (towards you) to zoom out. The mouse cursor position is the center where the zoom occurs. You can customize the behavior of the mouse wheel zoom using the Map tools tab under the Settings > Options menu.

QGIS 1.4.0 User Guide 25

4 FEATURES AT A GLANCE

Tip 5 P

ANNING THE

M

AP WITH THE

A

RROW

K

EYS AND

S

PACE

B

AR

You can use the arrow keys to pan in the map. Place the mouse cursor inside the map area and click on the right arrow key to pan East, left arrow key to pan West, up arrow key to pan North and down arrow key to pan

South. You can also pan the map using the space bar: just move the mouse while holding down space bar.

4.2.6. Map Overview

The map overview panel provides a full extent view of layers added to it. It can be selected under the menu Settings > Panels . Within the view is a rectangle showing the current map extent. This allows you to quickly determine which area of the map you are currently viewing. Note that labels are not rendered to the map overview even if the layers in the map overview have been set up for labeling.

You can add a single layer to the overview by right-clicking on it in the legend and select x Show in overview . You can also add layers to, or remove all layers from the overview using the Overview tools on the toolbar.

If you click and drag the red rectangle in the overview that shows your current extent, the main map view will update accordingly.

4.2.7. Status Bar

The status bar shows you your current position in map coordinates (e.g. meters or decimal degrees) as the mouse pointer is moved across the map view. To the left of the coordinate display in the status bar is a small button that will toggle between showing coordinate position or the view extents of the map view as you pan and zoom in and out.

A progress bar in the status bar shows progress of rendering as each layer is drawn to the map view.

In some cases, such as the gathering of statistics in raster layers, the progress bar will be used to show the status of lengthy operations.

If a new plugin or a plugin update is available, you will see a message in the status bar. On the right side of the status bar is a small checkbox which can be used to temporarily prevent layers being rendered to the map view (see Section

4.3

below). At the far right of the status bar is a projector icon.

Clicking on this opens the projection properties for the current project.

4.3. Rendering

By default, QGIS renders all visible layers whenever the map canvas must be refreshed. The events that trigger a refresh of the map canvas include:

QGIS 1.4.0 User Guide 26

4.3

Rendering

Tip 6 C

ALCULATING THE CORRECT

S

CALE OF YOUR

M

AP

C

ANVAS

When you start QGIS, degrees is the default unit, and it tells QGIS that any coordinate in your layer is in degrees. To get correct scale values, you can either change this to meter manually in the General tab under Settings > Project Properties or you can select a project Coordinate Reference System (CRS) clicking on the projector icon in the lower right-hand corner of the statusbar. In the last case, the units are set to what the project projection specifies, e.g. ’+units=m’.

Adding a layer

Panning or zooming

Resizing the QGIS window

• Changing the visibility of a layer or layers

QGIS allows you to control the rendering process in a number of ways.

4.3.1. Scale Dependent Rendering

Scale dependent rendering allows you to specify the minimum and maximum scales at which a layer will be visible. To set scale dependency rendering, open the Properties dialog by double-clicking on the layer in the legend. On the General tab, set the minimum and maximum scale values and then click on the x Use scale dependent rendering checkbox.

You can determine the scale values by first zooming to the level you want to use and noting the scale value in the QGIS status bar.

4.3.2. Controlling Map Rendering

Map rendering can be controlled in the following ways:

a) Suspending Rendering

To suspend rendering, click the x Render checkbox in the lower right corner of the statusbar.

When the x Render box is not checked, QGIS does not redraw the canvas in response to any of the events described in Section

4.3

. Examples of when you might want to suspend rendering include:

• Add many layers and symbolize them prior to drawing

Add one or more large layers and set scale dependency before drawing

QGIS 1.4.0 User Guide 27

4 FEATURES AT A GLANCE

Add one or more large layers and zoom to a specific view before drawing

Any combination of the above

Checking the x Render box enables rendering and causes and immediate refresh of the map canvas.

b) Setting Layer Add Option

You can set an option to always load new layers without drawing them. This means the layer will be added to the map, but its visibility checkbox in the legend will be unchecked by default. To set this option, choose menu option Settings >

Options and click on the Rendering & SVG tab.

Uncheck the x By default new layers added to the map should be displayed checkbox. Any layer added to the map will be off (invisible) by default.

c) Updating the Map Display During Rendering

You can set an option to update the map display as features are drawn. By default, QGIS does not display any features for a layer until the entire layer has been rendered. To update the display as features are read from the datastore, choose menu option Settings >

Options click on the

Rendering & SVG tab. Set the feature count to an appropriate value to update the display during rendering. Setting a value of 0 disables update during drawing (this is the default). Setting a value too low will result in poor performance as the map canvas is continually updated during the reading of the features. A suggested value to start with is 500.

d) Influence Rendering Quality

To influence the rendering quality of the map you have 3 options. Choose menu option Settings >

Options click on the Rendering & SVG tab and select or deselect following checkboxes.

• x Make lines appear less jagged at the expense of some drawing performance

• x Fix problems with incorrectly filled polygons

4.4. Measuring

Measuring works within projected coordinate systems only (e.g., UTM). If the loaded map is defined with a geographic coordinate system (latitude/longitude), the results from line or area measurements will be incorrect. To fix this you need to set an appropriate map coordinate system (See Section

8 ).

Both measuring modules also use the snapping settings from the digitizing module. This is useful, if

QGIS 1.4.0 User Guide 28

4.5

Projects you want to measure along lines or areas in vector layers.

4.4.1. Measure length and areas

QGIS is also able to measure real distances between given points according to a defined ellipsoid. To configure this, choose menu option Settings > Options , click on the Map tools tab and choose the appropriate ellipsoid. There you can also define a rubberband color and your preferred measurement units (meters or feet). The tool then allows you to click points on the map. Each segment-length as well as the total shows up in the measure-window. To stop measuring click your right mouse button.

Areas can also be measured. In the measure window the accumulated area-size appears

In addition, the measuring tool will snap to the currently selected layer, provided that layer has its snapping tolerance set. (See Section

5.5.1

). So if you want to measure exactly along a line feature,

or around a polygon feature, first set its snapping tolerance, then select the layer. Now, when using the measuring tools, each mouse click (within the tolerance setting) will snap to that layer.

Figure 4: Measure tools in action

(a) Measure lines (b) Measure areas

4.5. Projects

The state of your QGIS session is considered a Project. QGIS works on one project at a time.

Settings are either considered as being per-project, or as a default for new projects (see Section

4.7

). QGIS can save the state of your workspace into a project file using the menu options File >

Save Project or File > Save Project As .

Load saved projects into a QGIS session using

File

>

Open Project or

File

>

Open Recent Project .

If you wish to clear your session and start fresh, choose File >

QGIS 1.4.0 User Guide 29

4 FEATURES AT A GLANCE

New Project . Either of these menu options will prompt you to save the existing project if changes have been made since it was opened or last saved.

The kinds of information saved in a project file include:

Layers added

• Layer properties, including symbolization

• Projection for the map view

Last viewed extent

The project file is saved in XML format, so it is possible to edit the file outside QGIS if you know what you are doing. The file format was updated several times compared to earlier QGIS versions. Project files from older QGIS versions may not work properly anymore. To be made aware of this, in the

General tab under Settings > Options you can select x Promt to save project changes when required x Warn when opening a project file saved with an older version of QGIS .

Project Properties

In the properties window for the project under

File > Project Properties or

Project Properties you set project specific options. These include:

Settings >

• In the General tab the project title, selection and background color, layer units, precision, and the option to save relative paths to layers can be defined. In addition the topological editing, and layerwise snapping options are set here.

• The CRS Coordinate Reference System tab enables you to choose the CRS for this project, and to enable on-the-fly reprojection of vector layers when displaying layers from a different

CRS.

With the third Identifiable layers tab you set (or disable) which layers will respond to the identify tool. (See the Map tools paragraph from the

4.7

section to enable identifying of multiple layers.)

4.6. Output

There are several ways to generate output from your QGIS session. We have discussed one already in Section

4.5

: saving as a project file. Here is a sampling of other ways to produce output files:

QGIS 1.4.0 User Guide 30

4.7

GUI Options

Menu option

Save as Image opens a file dialog where you select the name, path and type of image (PNG or JPG format). A world file with extension PNGW or JPGW saved in the same folder georeferences the image.

Menu option

Print Composer opens a dialog where you can layout and print the current map canvas (see Section

10 ).

The

12.16

).

Quick Print plugin allows to print a simple map with minimal effort (see Section

4.7. GUI Options

Some basic options for QGIS can be selected using the Options dialog. Select the menu option Settings >

Options . The tabs where you can optmize your options are:

General Tab

• x Promt to save project changes when required

• x Warn when opening a project file saved with an older version of QGIS

• Change Selection and backgroud Color

• Change the icon theme (choose between default, classic, gis and nkids)

• x Capitalise layer names in legend

• x Display classification attribute names in legend

• x Hide splash screen at startup

• x Open identify results in a dock window (QGIS restart required)

• x Open attribute table in a dock window

• x Add PostGIS layers with double click and select in extended mode

Rendering & SVG Tab

• x By deafult new layers added to the map should be displayed

QGIS 1.4.0 User Guide 31

4 FEATURES AT A GLANCE

Define number of features to draw before updating the display.

• x Use render caching where possible to speed up redraws

• x Make lines appear less jagged at the expense of some drawing performance

• x Fix problems with incorrectly filled polygons

• x Use new generation symbology for rendering

Add and remove path(s) to search for Scalable Vector Graphics (SVG) symbols

Map tools Tab

The Mode setting determines which layers will be shown by the Identify tool. By switching to

Top down or Top down, stop at first instead of Current layer attributes for all identifiable layers (see the Project properties section under:

4.5

to set which layers are identifiable) will be shown with the Identify tool.

• x Open feature form, if a single feature is identified

Define search radius as a percentage of the map width

Define ellipsoid for distance calculations

Define rubberband color for measure tools

• Define preferred measurement units (meters or feet)

• Define Mouse wheel action (Zoom, Zoom and recenter, Zoom to mouse cursor, Nothing)

Define Zoom factor for wheel mouse

Overlay

• Define placement algorithm for labels (choose between central point (standard), chain, popmusic tabu chain, popmusic tabu and popmusic chain)

Digitizing Tab

• Define Rubberband Color and line width for Digitizing

• Define default snap mode (to vertex, to segment, to vertex and segment)

Define default snapping tolerance in map units or pixel

QGIS 1.4.0 User Guide 32

4.7

GUI Options

Define search radius for vertex edits in map units or pixel

• x Show markers only for selected features

Define vertex marker style (Cross, semi transparent circle or none) and size

• x Suppress attributes pop-up windows after each created feature

CRS Tab

• x Prompt for Coordinate Reference System (CRS)

• x Project wide default Coordinate Reference System (CRS) will be used

• x Global default Coordinate Reference System (CRS) displayed below will be used

• Select global default Coordinate Reference System (CRS)

Locale Tab

• x Overwrite system locale and use defined locale instead

Information about active system locale

Proxy Tab

• x Define timeout for network requests in ms

• x Use proxy for web access and define host, port, user, and password.

• Set the Proxy type according to your needs

Default Proxy : Proxy is determined based on the application proxy set using

Socks5Proxy : Generic proxy for any kind of connection. Supports TCP, UDP, binding to a port (incoming connections) and authentication.

HttpProxy : Implemented using the "CONNECT" command, supports only outgoing TCP connections; supports authentication.

HttpCachingProxy : Implemented using normal HTTP commands, it is useful only in the context of HTTP requests

FtpCachingProxy : Implemented using an FTP proxy, it is useful only in the context of

FTP requests

QGIS 1.4.0 User Guide 33

4 FEATURES AT A GLANCE

Excluding some URLs can be added to the textbox below the proxy-settings (see fig.

5 ) by pressing

the Add -button. After that double-click into the just created URL-field and enter the URL you would like to exclude from using the proxy. Obviously the button Remove removes the selected entry.

If you need more detailed information about the different proxy-settings, please refer to the manual of the unterlaying QT-library-documentation at http://doc.trolltech.com/4.5/qnetworkproxy.html#ProxyType-enum

.

Figure 5: Proxy-settings in QGIS

Tip 7 U

SING

P

ROXIES

Using proxies can sometimes be tricky. It is useful to ’trial and error’ the above proxy types and check if they succeed in your case.

You can modify the options according to your needs. Some of the changes may require a restart of

QGIS before they will be effective.

• settings are saved in a texfile: $HOME/.config/QuantumGIS/qgis.conf

• you can find your settings in: $HOME/Library/Preferences/org.qgis.qgis.plist

• settings are stored in the registry under:

\\HKEY\CURRENT\USER\Software\QuantumGIS\qgis

QGIS 1.4.0 User Guide 34

4.8

Spatial Bookmarks

4.8. Spatial Bookmarks

Spatial Bookmarks allow you to “bookmark” a geographic location and return to it later.

4.8.1. Creating a Bookmark

To create a bookmark:

1. Zoom or pan to the area of interest.

2. Select the menu option View > New Bookmark or press

¨

Ctrl-B .

§

¥

¦

3. Enter a descriptive name for the bookmark (up to 255 characters).

4. Click OK to add the bookmark or Cancel to exit without adding the bookmark.

Note that you can have multiple bookmarks with the same name.

4.8.2. Working with Bookmarks

To use or manage bookmarks, select the menu option View >

Show Bookmarks .

The

Geospatial Bookmarks dialog allows you to zoom to or delete a bookmark. You can not edit the bookmark name or coordinates.

4.8.3. Zooming to a Bookmark

From the Geospatial Bookmarks dialog, select the desired bookmark by clicking on it, then click

Zoom To . You can also zoom to a bookmark by double-clicking on it.

4.8.4. Deleting a Bookmark

To delete a bookmark from the Geospatial Bookmarks dialog, click on it then click Delete .

Confirm your choice by clicking Yes or cancel the delete by clicking No .

QGIS 1.4.0 User Guide 35

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement

Table of contents