JProbe Installation Guide

JProbe Installation Guide

1

Supported Platforms

You can install JProbe on the following operating systems using this guide:

Microsoft Windows ......................................................................................................................16

Sun Solaris ..................................................................................................................................18

IBM AIX .......................................................................................................................................19

Linux x86 .....................................................................................................................................21

Linux EM64T/AMD64 ..................................................................................................................25

Caution

Updates to the lists of supported JVMs and application servers are available at:

www.quest.com/jprobe/release_information.aspx

16 JProbe

Installation Guide

Microsoft Windows

System Requirements

You need the following minimum system requirements:

• One of the following OS systems:

• Microsoft Windows XP Professional SP2 or later

• Microsoft Windows Server 2003 SP2 or later

• Microsoft Windows Server 2008

• Microsoft Windows Vista

• Intel Pentium IV @2.4 GHz

• 2 GB RAM

• 200 MB free disk space

Supported JVMs

The following development kits contain a supported JVM:

• JRockit 1.4.2

• JRockit 5.0

• JRockit 6.0

• IBM 32-bit SDK, Java 2 Technology Edition, Version 1.4.2, SR1 or later

Note

IBM JVMs are only supported for use with IBM WebSphere Application Server.

Note

IBM JDK 1.4.2 is not fully supported with Memory due to severe problems with the heap dump provided by the JVM profiling interface (JVMPI). Workaround: You can take memory snapshots without a heap dump. You can also import an IBM heap dump.

• IBM 32-bit SDK, Java 2 Technology Edition, Version 1.5

• IBM 32-bit SDK, Version 1.6.0

• Sun Java 2 SDK, Standard Edition, 1.4.2

• Sun J2SE Development Kit 5.0

• Sun Java Platform, Standard Edition 6

Chapter 1: Supported Platforms

Microsoft Windows

17

Validated Application Servers

At time of release, the following application servers are tested and supported:

• Apache Geronimo 2.0.1 and 2.1.x

• Apache Tomcat 5.0, 5.5, and 6.0

• BEA WebLogic Server 8.1, 9.2, and 10.0

• BEA WebLogic Server Portal Server 8.1 and 9.2

• Caucho Resin 3.1 and 3.2

• IBM WebSphere Application Server Community Edition 2.0 and 2.1

• IBM WebSphere Portal Server 6.1

• IBM WebSphere Application Server 6.0.1+, 6.1, and 7.0

Note

On Windows XP and Windows Vista, IBM WebSphere Portal Server and IBM

WebSphere Application Server are only supported for development use.

• JBoss 4.0.x, 4.2.x, and 5.x

• Open Source GlassFish v2 UR2

• Oracle OC4J 10g 10.1.2 and 10.1.3

• Oracle Application Server 10g 10.1.3.x

• Oracle WebLogic Server 10.3

• Sun Java System Application Server 8.2 SE and 9.1 PE

Note

Sun Java System Application Server 9.1 PE is supported for Windows XP only.

• Sun Java System Web Server 6.1 and 7.0

Application servers are not supported on versions of Windows which are not officially supported by the application server vendor. Listed application servers may not be tested on every supported version of Windows.

In some cases, additional versions of the validated platforms are also supported, however these are typically older releases which are not formally validated. Other application servers may be available on request.

18 JProbe

Installation Guide

Sun Solaris

System Requirements

You need the following minimum system requirements:

• One of the following OS systems:

• Sun Solaris 8, 9, and 10 on Sun UltraSPARC processor (not SPARC Station or

Intel)

• Sun Solaris 10 on an x86 system

• 2 GB RAM

• 200 MB free disk space

Supported JVMs

The following development kits contain a supported JVM:

• JRockit 5 R26

Note

Vendor supports this version for Solaris 9 and 10 only.

• JRockit 6.0

• Sun Java 2 SDK, Standard Edition, 1.4.2, plus patches

Note

You can find patches on the Sun Microsystem Web site:

java.sun.com

.

• Sun J2SE Development Kit 5.0

• Sun Java Platform, Standard Edition 6

Validated Application Servers

At time of release, the following application servers are tested and supported:

• Apache Tomcat 5.0, 5.5, and 6.0

• BEA WebLogic Server 8.1, 9.2, and 10.0

• BEA WebLogic Server Portal Server 8.1 and 9.2

• IBM WebSphere Application Server 6.0.1+, 6.1, and 7.0

Note

Vendor supports IBM WebSphere Application Server versions 6.1 and 7.0 for Solaris

9 and 10 only.

Chapter 1: Supported Platforms

IBM AIX

19

• JBoss 4.0.x, 4.2.x, and 5.x

• Open Source GlassFish v2 UR2

• Oracle OC4J 10g 10.1.2 and 10.1.3

• Oracle Application Server 10g 10.1.3.x

• Oracle WebLogic Server 10.3

• Sun Java System Application Server 8.2 SE and 9.1 PE

Note

Vendor supports Sun Java System Application Server 8.2 SE for Solaris 8 and 9 only.

Note

Vendor supports Sun Java System Application Server 9.1 PE for Solaris 9 and 10 only.

• Sun Java System Web Server 6.1 and 7.0

Note

Vendor supports Sun Java System Web Server 6.1 for Solaris 8 and 9 only.

Note

Vendor supports Sun Java System Web Server 7.0 for Solaris 10 only.

Application servers are not supported on versions of Solaris which are not officially supported by the application server vendor. Listed application servers may not be tested on every supported version of Solaris.

In some cases, additional versions of the validated platforms are also supported, however these are typically older releases which are not formally validated. Other application servers may be available on request.

IBM AIX

Note

To run JProbe successfully on this platform, you need to ensure that the machine that

JProbe runs on has the required AIX level and fixes to run the IBM Java 6 JRE used by the

JProbe Console.

System Requirements

You need the following minimum system requirements:

• IBM AIX version 5.3 or 6.1

Note

JProbe on AIX require libC version 6, available from fileset xlC.aix50.rte version

6.0.0.0.

20 JProbe

Installation Guide

• IBM Power PC processor

• 2 GB RAM

• 200 MB free disk space

Supported JVMs

The following development kits contain a supported JVM:

• IBM 32-bit SDK for AIX, Java 2 Technology Edition, Version 1.4.2 SR1 or later, plus patches

Note

IBM JDK 1.4.x is not fully supported with Memory due to severe problems with the heap dump provided by the JVM profiling interface (JVMPI). Workaround: You can take memory snapshots without a heap dump. You can also import an IBM text heap dump.

Note

IBM requires that you install AIX patches to run Java correctly. Patches should be automatically installed when you install a supported IBM Developer Kit.

• IBM 32-bit SDK for AIX, Java 2 Technology Edition, Version 5 or later

Note

This version requires at least AIX 5L 5.3.0.30.

• IBM 32-bit SDK for AIX, v5. Java Technology Edition, Version 6

• IBM 64-bit SDK for AIX, Java 2 Technology Edition, Version 1.4.2

• IBM 64-bit SDK for AIX, Java 2 Technology Edition, Version 5

• IBM 64-bit SDK for AIX, v5. Java Technology Edition, Version 6

Validated Application Servers

At time of release, the following application servers are tested and supported:

• Apache Tomcat 5.0, 5.5, and 6.0

• BEA WebLogic Server 9.2 and 10.0

• IBM WebSphere Application Server 6.0.1+, 6.1, and 7.0

Note

IBM WebSphere Application Server 7.0 requires AIX 6.1 with Recommended

Maintenance package 6100-00-04, or AIX 5L 5.3 with Service Pack 5300-07-01.

• IBM WebSphere Portal Server 6.1

Note

IBM WebSphere Portal Server 6.1 requires AIX V6.1 with Service Pack 4, or AIX

V5L V5.3 with Service Pack 5300-04-01.

• JBoss 4.x and 5.x

Chapter 1: Supported Platforms

Linux x86

21

Application servers are not supported on versions of AIX which are not officially supported by the application server vendor. Listed application servers may not be tested on every supported version of AIX.

In some cases, additional versions of the validated platforms are also supported, however these are typically older releases which are not formally validated. Other application servers may be available on request.

Linux x86

System Requirements

You need the following minimum system requirements:

Note

While Quest Software only supports some versions of Linux, JProbe should work with any Linux distribution that includes glibc 2.3.4 or later.

• One of the following OS systems:

• Red Hat Enterprise Linux (RHEL) 4.0, 5.0, 5.1, 5.2, and 5.3

• Novell SUSE Linux Enterprise Server (SLES) 9.0, 10.0, and 10.3

• CentOS 5.x

• Intel ia32 (x86) architecture machine

• 2 GB RAM

• 256 MB free disk space

Novell SUSE Linux Enterprise Server (SLES)

The following sections list the supported Java developer kits and application servers for

SLES 9.0, 10.0, and 10.3.

Supported JVMs

• JRockit 1.4.2

• JRockit 5.0

• JRockit 6.0

• Sun Java 2 SDK, Standard Edition, 1.4.2 or later

22 JProbe

Installation Guide

• Sun J2SE Development Kit 5.0 plus patches

Note

You can find patches on the Sun Microsystem Web site:

java.sun.com

.

• Sun Java Platform, Standard Edition 6

• IBM 32-bit SDK for Linux on Intel Architecture, Java 2 Technology Edition,

Version 1.4.2, SR1 or later

Note

IBM JDK 1.4.2 is not supported with Memory due to severe problems with the heap dump provided by the JVM profiling interface (JVMPI). Workaround: You can import an IBM heap dump.

• IBM 32-bit SDK for Linux on Intel Architecture, Java 2 Technology Edition,

Version 5

• IBM 32-bit SDK for Linux on Intel architecture, Java Technology Edition,

Version 6

Validated Application Servers

• Apache Geronimo 2.0.1 and 2.1

• Apache Tomcat 5.0, 5.5, and 6.0

• BEA WebLogic Server 8.1, 9.2, and 10.0

• IBM WebSphere Application Server 6.0.1+, 6.1, and 7.0

Note

IBM WebSphere Application Server 7.0 requires at least SLES 9 SP4 or SLES 10 update 1.

• JBoss 4.0.x, 4.2.x, and 5.x

• Oracle OC4J 10g 10.1.2 and 10.1.3.x

• Oracle Application Server 10g 10.1.3

• Oracle WebLogic Server 10.3

Application servers are not supported on versions of Linux which are not officially supported by the application server vendor. Listed application servers may not be tested on every supported version of Linux.

In some cases, additional versions of the validated platforms are also supported, however these are typically older releases which are not formally validated. Other application servers may be available on request.

Chapter 1: Supported Platforms

Linux x86

23

Red Hat Enterprise Linux

The following sections list the supported Java developer kits and application servers for

RHEL 4.0 and 5.x.

Supported JVMs

• JRockit 1.4.2

• JRockit 5.0

• Sun Java 2 SDK, Standard Edition, 1.4.2 or later

• Sun J2SE Development Kit 5.0 plus patches

Note

You can find patches on the Sun Microsystem Web site:

java.sun.com

.

• Sun Java Platform, Standard Edition 6

• IBM 32-bit SDK for Linux on Intel Architecture, Java 2 Technology Edition,

Version 1.4.2, SR1 or later

Note

IBM JDK 1.4.2 is not supported with Memory due to severe problems with the heap dump provided by the JVM profiling interface (JVMPI). Workaround: You can import an IBM heap dump.

• IBM 32-bit SDK for Linux on Intel Architecture, Java 2 Technology Edition,

Version 5

• IBM 32-bit SDK for Linux on Intel architecture, Java Technology Edition,

Version 6

Validated Application Servers

• Apache Geronimo 2.0.1 and 2.1

• Apache Tomcat 5.0, 5.5, and 6.0

• BEA WebLogic Server 8.1, 9.2, and 10.0

Note

Vendor supports BEA WebLogic Server version 9.2 for Red Hat Enterprise Linux only.

• BEA WebLogic Server Portal Server 9.2

Note

Vendor supports this version for Red Hat Enterprise Linux only.

• IBM WebSphere Application Server Community Edition 2.0 and 2.1

• IBM WebSphere Application Server 6.0.1+, 6.1, and 7.0

Note

IBM WebSphere Application Server 7.0 requires at least RHEL 4 Update 6 or RHEL

5 update 1.

24 JProbe

Installation Guide

• JBoss 4.0.x, 4.2.x, and 5.x

• Open Source GlassFish v2 UR2

• Oracle OC4J 10g 10.1.2 and 10.1.3

• Oracle Application Server 10g 10.1.3.x

• Oracle WebLogic Server 10.3

• Sun Java System Application Server 9.0 PE and 9.1

Note

Vendor supports Sun Java System Application Server 9.0 PE for Red Hat Enterprise

Linux only.

Application servers are not supported on versions of Linux which are not officially supported by the application server vendor. Listed application servers may not be tested on every supported version of Linux.

In some cases, additional versions of the validated platforms are also supported, however these are typically older releases which are not formally validated. Other application servers may be available on request.

CentOS 5.x

The following sections list the supported Java developer kits and application servers for

CentOS 5.x.

Supported JVMs

• JRockit 1.4.2

• JRockit 5.0

• Sun Java 2 SDK, Standard Edition, 1.4.2 or later

• Sun J2SE Development Kit 5.0 plus patches

Note

You can find patches on the Sun Microsystem Web site:

java.sun.com

.

• Sun Java Platform, Standard Edition 6

• IBM 32-bit SDK for Linux on Intel Architecture, Java 2 Technology Edition,

Version 1.4.2, SR1 or later

Note

IBM JDK 1.4.2 is not supported with Memory due to severe problems with the heap dump provided by the JVM profiling interface (JVMPI). Workaround: You can import an IBM heap dump.

• IBM 32-bit SDK for Linux on Intel Architecture, Java 2 Technology Edition,

Version 5

Chapter 1: Supported Platforms

Linux EM64T/AMD64

25

• IBM 32-bit SDK for Linux on Intel architecture, Java Technology Edition,

Version 6

Validated Application Servers

• Apache Geronimo 2.0.1 and 2.1

• Apache Tomcat 5.0, 5.5, and 6.0

• JBoss 4.0.x, 4.2.x, and 5.x

Application servers are not supported on versions of Linux which are not officially supported by the application server vendor. Listed application servers may not be tested on every supported version of Linux.

In some cases, additional versions of the validated platforms are also supported, however these are typically older releases which are not formally validated. Other application servers may be available on request.

Linux EM64T/AMD64

System Requirements

You need the following minimum system requirements:

• One of the following OS systems:

• Red Hat Enterprise Linux (RHEL) AS 4.0 or 5.x

Note

While Quest Software only supports some versions of Linux, JProbe should work with any Linux distribution that includes glibc 2.3.4 or later. 32-bit compatibility libraries may also need to be installed.

• SUSE Linux Enterprise Server (SLES) 9.0 or 10.0

Note

While Quest Software only supports some versions of Linux, JProbe should work with any Linux distribution that includes glibc 2.3.4 or later. 32-bit compatibility libraries may also need to be installed.

• CentOS 5.x

• 2 GB RAM

• 200 MB free disk space

26 JProbe

Installation Guide

Supported JVMs

• JRockit 1.4.2

• JRockit 5.0

• IBM 64-bit SDK for Linux on Intel, Java 2 Technology Edition, Version 1.4.2,

SR1 or later

Note

IBM JDK 1.4.2 is not supported with Memory due to severe problems with the heap dump provided by the JVM profiling interface (JVMPI). Workaround: You can import an IBM heap dump.

• IBM 64-bit SDK for Linux on AMD64/EM64T, Java 2 Technology Edition,

Version 5.0

• IBM 64-bit SDK for Linux on AMD64/EM64T, Java Technology Edition,

Version 6

• Sun Java 2 SDK, Standard Edition, 1.4.2 or later

• Sun J2SE Development Kit 5.0 for Linux 64-bit AMD64/EM64T Processors plus patches

Note

You can find patches on the Sun Microsystem web site:

java.sun.com

. Support for

AMD64 / EM64T 64-bit mode for Linux was introduced in J2SE 5.0 Update 2. Before

Update 2, J2SE 5.0 supported AMD Opteron (64) Linux.

Validated Application Servers

At time of release, the following application servers are tested and supported:

• Apache Tomcat 5.5 and 6.0

• BEA WebLogic Server 9.2 and 10.0

Note

Vendor supports BEA WebLogic Server 9.2 version for Red Hat Enterprise Linux only.

• IBM WebSphere Application Server 6.1 and 7.0

Note

IBM WebSphere Application Server 7.0 requires at least RHEL 5 Update 1 or SLES

10 Update 1.

• JBoss 5.x

• Oracle Application Server 10g 10.1.3.x

• Oracle WebLogic Server 10.3

Chapter 1: Supported Platforms

Linux EM64T/AMD64

27

Application servers are not supported on versions of Linux which are not officially supported by the application server vendor. Listed application servers may not be tested on every supported version of Linux.

In some cases, additional versions of the validated platforms are also supported, however these are typically older releases which are not formally validated. Other application servers may be available on request.

28 JProbe

Installation Guide

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement

Table of contents