Clip View. AUTOHELM ABLETON

Add to my manuals
553 Pages

advertisement

Clip View. AUTOHELM ABLETON | Manualzz

98

Chapter 8

Clip View

The Clip View is where clip properties can be set and adjusted.

The Clip View is opened by clicking on the Clip Overview or double-clicking a clip in the

Session or Arrangement View.

The Clip View.

CHAPTER 8. CLIP VIEW

99

Clicking the Clip

Overview Opens the

Clip View.

In the Session View, clicking on a Track Status Field opens the Clip View for editing the clip that is currently running in the track.

The properties of more than one clip can be edited collectively in the Clip View as a multiselection. To create a multi-selection, click and drag from an empty clip slot to highlight the clips, or select one clip and use the

Ctrl

(PC) / (Mac) or modi ers to add to your selection. The properties available in the Clip View for a multi-selection depend on the contents of the clips; generally only properties which the clips have in common are shown.

Clicking a Session View

Track Status Field Opens the Clip View.

Controls such as sliders and knobs behave slightly differently when they are part of a multiselection. If the clips in a multi-selection have differing values for any particular knob or slider parameter (clip transposition, for example), the range of these values will be displayed and can be adjusted with the control. Dragging the knob or slider to its absolute maximum or minimum value will make the clips' settings thereafter identical, adjustable as a single value.

MIDI clips and audio clips in Live have different sets of properties and, consequently, do not share the same set of Clip View controls. The two types of clips do have the following

Creating a Clip

Multi-Selection.

CHAPTER 8. CLIP VIEW

100 in common:

ˆ The Clip box contains basic clip settings.

ˆ The Envelopes box and the Envelope Editor manage the clip's envelopes, which are used to modulate the effects, mixer, and clip or MIDI controls. Clip envelopes and their associated Clip View components are covered in detail in a

separate manual chapter .

ˆ The Launch box controls clip launch behavior and, as such, only appears for Session

View clips. Setting Session View clip launch properties is covered in detail in a

separate manual chapter .

Audio clips have these additional Clip View controls:

ˆ The Sample Display toggles with the Envelope Editor on the right-hand side of the

Clip View, and controls Live's

sample-warping capabilities

and

clip playback settings .

ˆ The Sample box contains settings pertaining to how the clip plays its sample and displays it in the Sample Display.

MIDI clips have these additional Clip View controls:

ˆ The MIDI Editor toggles with the Envelope Editor on the right-hand side of the Clip

View, and allows

editing and creating MIDI notes and velocities .

ˆ The Notes box contains settings pertaining to how Live plays a MIDI clip and what it displays in the MIDI Editor.

The Clip View for an

Audio Clip.

CHAPTER 8. CLIP VIEW

101

To make best use of the screen real estate, you can show or hide the Launch, Envelopes, and Sample or MIDI boxes using the Clip View Box selector in the Clips box. You can also toggle between the Sample Display/MIDI Editor and the Envelope Editor by clicking in the title bars of the Sample/Notes box and the Envelopes box, respectively.

The Clip View for a MIDI

Clip.

The Clip View Box

Selector Shows and

Hides Various Clip View

Components.

CHAPTER 8. CLIP VIEW

8.1

The Clip Box

102

8.1.1

Clip Activator Switch

Using this switch, you can deactivate a clip so that it does not play when launched in the

Session View or during Arrangement playback. Clips can also be activated/deactivated directly from the Session or Arrangement View with their menus.

(PC) /

Ctrl

(Mac) context

8.1.2

Clip Name and Color

The Clip Name eld allows naming the clip. By default, a clip's name matches the name of the le it references but, in general, the clip name is independent from the le name.

You can also rename a clip by selecting it in the Session grid or Arrangement View and using the Rename command in the Edit menu or the clip's (PC) /

Ctrl

(Mac) context menu. This method also allows you to create your own

info text

for the clip via the Edit Info

Text command.

Renaming an audio clip does not rename the referenced sample le. To rename a le, select it in Live's File Browsers, and then choose the Edit menu's Rename command.

The Clip Color chooser allows choosing a clip color.

The Clip Box.

CHAPTER 8. CLIP VIEW

103

8.1.3

Clip Signature

Using the Clip Signature elds, you can specify the time signature of a MIDI or audio clip. This setting is relevant only for display; it does not affect playback. Please note that

Clip Signature is completely separate from the project's time signature, and can be set independently for each clip. This makes it easy to create complex polymetric textures by simultaneously triggering clips with different meters and/or loop lengths.

8.1.4

Clip Groove Chooser

The Clip Groove chooser selects the groove used for the clip from the grooves available in the

Groove Pool .

The Open Groove Pool entry in this chooser can be used to open the Groove Pool if it is closed. If you want to quickly try out a variety of grooves, you can enable the

Hot-Swap

button above the chooser and then step through the grooves in the Browser while the clip plays.

The Commit button under the chooser writes the current groove settings to the clip and disables the assigned groove. If the groove uses the Velocity parameter, committing on an audio clip will create a volume

Clip Envelope

in order to convert the groove's velocity information into audio volume changes. Note that this will overwrite any volume Clip

Envelope that was already in the clip.

The Clip Groove

Chooser.

CHAPTER 8. CLIP VIEW

104

8.1.5

Clip Offset and Nudging

To jump within a playing clip in increments the size of the global quantization period, you can use the Nudge buttons in the Clip box.

These buttons can also be

mapped to keys or MIDI controllers . In MIDI Map Mode, a scrub

control will appear between the Nudge buttons and can be assigned to a rotary encoder wheel for continuous scrubbing.

Using the Nudge

Buttons to Jump

Through a Clip.

With quantization set to values less than one bar, it is easy to offset clip playback from Live's master clock by launching clips, using the Nudge buttons or

scrubbing within the clip .

The Scrub Control in

MIDI Map Mode.

CHAPTER 8. CLIP VIEW

8.2

The Sample Box

8.2.1

Warp Controls

105

When the Warp switch is off, Live plays the sample at its original, normal tempo, irrespective of the current Live Set tempo. This is useful for samples that have no inherent rhythmic structure: percussion hits, atmospheres, sound effects, spoken word and the like. Turn the Warp switch on to play rhythmically structured samples (such as sample loops, music recordings, complete music pieces, etc.) in sync with the current song tempo.

The Sample Box Warp

Controls.

The Control Bar's Tempo

Field.

To verify this, note that a warped sample's speed follows the tempo as you change the

Control Bar's Tempo control.

Live offers a number of controls to adjust the time-warping engine for

optimal stretching quality . For accurate warping, Live needs to know the sample's metrical structure. For

properly prepared loops, tempo and duration are calculated automatically; most of the time this is accurate enough that the sample is immediately ready for use in Live. For other samples, you may have to

provide some hints . We will examine these topics thoroughly in

the

Tempo Control and Warping

chapter.

CHAPTER 8. CLIP VIEW

8.2.2

Sample Loop/Region and Display

Zooming and Scrolling

106

Zooming and scrolling in the Sample Display work much like they do in the

Arrangement

View . When Warp is disabled, zooming and scrolling can be done anywhere in the Sample

Display. When Warp is enabled, however, scrolling only happens in the beat-time ruler and the bottom half of the waveform.

Click and drag vertically in these areas to smoothly change the zoom level, and horizontally to scroll the display.

The Clip Zoom/Scroll

Area.

The Clip Overview provides additional zoom/scrolling functionality. It always shows the complete clip, from start to end. The black rectangular outline represents the part of the clip that is currently displayed. You can click within the outline and drag horizontally or vertically to scroll or zoom.

The Clip Overview.

CHAPTER 8. CLIP VIEW

107

To have the Sample Display follow the play position and scroll automatically, turn on the

Follow switch, or use the Follow command from the Options menu.

The Follow Switch.

Playing and Scrubbing Clips

The section of the sample that plays when a clip is launched is set with the clip's region and

loop controls . An unlooped clip will play from its start marker to its end marker or until it is

stopped.

These markers can be clicked and dragged to new positions in the Sample Display, or they can be moved with the and keys. To move the entire clip region (i.e., both the start and end markers), select the start marker, hold down , and use the arrow keys.

The Clip Start and End

Markers.

Using Clip Start and End

Controls to Change Clip

Length.

CHAPTER 8. CLIP VIEW

108

You can also adjust the clip start and end numerically using the respective value elds to the left of the Sample Display. For warped clips, these elds display values as bars-beatssixteenths; for unwarped clips, the display is in minutes-seconds-milliseconds. Notice that you can use the Set buttons here to place the markers during playback. Setting markers this way is quantized according to global quantization.

When Permanent Scrub Areas is enabled in Live's Look/Feel Preferences, clicking in the lower half of the waveform or in the beat-time ruler will make clip playback jump to that point.

The size of this jump is quantized by the global quantization setting, which can be quickly changed using the

Ctrl

6

(PC) /

6

(Mac),

7

,

8

,

9 and

0 shortcuts. While the mouse is held down over the scrub area, a portion of the clip the size of the chosen quantization setting will be repeatedly played. With small quantization settings, or a setting of None, this allows you to scrub through the music.

When the Permanent Scrub Areas preference is off, you can still scrub by anywhere in the scrub area or in the beat time ruler.

-clicking

The Clip Scrub Area.

Looping Clips

To have the clip play as a (potentially in nite) loop, turn on the Loop switch. Note that the Warp switch must be activated before the Loop switch is accessible, as unwarped clips

CHAPTER 8. CLIP VIEW

109 cannot be looped.

You can click and drag to change the position and length of the loop brace in the Sample

Display, or you can type exact values into the Loop Length and Position elds to the left of the display.

The loop brace can be selected with the mouse and its position changed with commands from the computer keyboard:

ˆ

ˆ and nudge the loop brace to the left/right by the current

grid setting .

and shift the loop brace left/right in steps the size of its length.

ˆ

Ctrl

(PC) / current

grid setting .

ˆ

Ctrl

(PC) /

(Mac) shortens or lengthens the loop brace by the

(Mac) doubles or halves the loop length.

Regardless of the position of the loop brace, clip play will begin at the position marked by the start marker, which means you can set up the clip to run into a loop.

The Clip Loop Controls.

CHAPTER 8. CLIP VIEW

110

The Loop Length and Position elds are equipped with Set buttons, which can be used to create loops spontaneously during playback:

ˆ Playing the clip and then clicking the Set Loop Position button moves the beginning of loop to the current playback position (rounded to the global quantization setting) and engages the loop. Then, clicking the Set Loop Length button moves the end of the loop to the current playback position. This lets you capture the music in a loop on the y.

ˆ While the loop is still off, you can click the Set Loop Length button to set the loop to end at the current playback position without changing its preset length. This simultaneously activates looping.

The Set buttons, the Loop switch, the loop brace and the start/end markers can all be

mapped to MIDI controls . You could, for example, use a rotary encoder to move the loop

through a sample in increments the size of the chosen quantization interval.

Setting the Clip to Run

Into a Loop.

CHAPTER 8. CLIP VIEW

8.2.3

Clip Pitch and Gain

111

The Clip Pitch and Gain

Controls.

The Transpose control shifts the clip pitch in semitones.

The Detune eld ne-tunes the clip in cents (100 cents = one semitone).

The Clip Gain slider, calibrated in dB, changes the clip gain.

8.2.4

Destructive Sample Editing

The Edit button opens the sample in an external sample editing application, which you can specify in the File/Folder Preferences. To process a sample in an external program, you have to stop Live's playback. When you return to Live, the edited version of the sample will be played back. The current set of Warp Markers is retained only if the sample length remains the same as it did prior to editing. Remember that changes made to one sample may affect other clips that play the same sample.

The Launch Sample

Editor Button.

CHAPTER 8. CLIP VIEW

8.2.5

Saving Default Clip Settings with the Sample

112

The Save Default Clip button saves the current clip's settings with the sample. With multiple clips selected, this button will save them all simultaneously. Once saved, Live will restore the current clip settings whenever you drop the sample into a Live Set. This is especially useful with regards to the Warp Markers, which have to be set correctly for Live to play long les in sync. Note that you can use the Save button without affecting any existing clips;

Save just saves default settings for future clips using this sample.

The clip data becomes part of the

analysis le

that accompanies the sample.

Note that storing default clip settings with the sample is different from saving the clip as a

Live Clip , which also saves devices and device settings.

The Save Default Clip

Button.

8.2.6

High Quality Interpolation

If the High Quality switch is on, Live uses an advanced sample-rate conversion algorithm that provides better sound quality at the expense of a higher

CPU load . Samples processed

with the Hi-Q algorithm generate less distortion, particularly at high frequencies, when transposing a sample and/or matching an imported sample's sampling rate to the system's sampling rate. With this mode enabled, samples can be transposed roughly 19 semitones in either direction before aliasing is likely to be audible.

Note: As of Live 7, the Hi-Q mode uses an algorithm that produces even smaller audible artifacts than in previous versions. Although we think this has greatly improved sound quality, any Sets made in older versions that used Hi-Q mode may now sound different. For

The High Quality Switch.

CHAPTER 8. CLIP VIEW

113 this reason, we have provided a Legacy Hi-Q Mode option, which is enabled by default in the Options menu whenever you load an old Set that has Hi-Q enabled for any clips. Simply disable this option if you wish to use the new mode.

8.2.7

Clip Start and End Fades

The Clip Fade switch, when enabled, applies a short fade to the clip start and end to avoid clicks at the clip edges. The length of the fade is signal-dependent and ranges from 0-4 milliseconds.

This switch is only available for clips in Session View. In Arrangement View, clip fades are adjusted via

envelopes .

The Clip Fade switch is on by default for all new clips when the Create Fades on Clip Edges option is enabled in the Record/Warp/Launch Preferences.

The Clip Fade Switch.

Automatically Create

Short Fades At Clip

Edges.

CHAPTER 8. CLIP VIEW

8.2.8

Clip RAM Mode

114

If the RAM Mode switch is on, Live is loading the audio referenced by the clip into the computer's memory rather than reading it from disk in real time. RAM Mode can help with these problems:

ˆ Your computer's hard disk is too slow to deliver audio for as many tracks as desired in real time. For more information on disk-related problems, please refer to

Managing the Disk Load

.

ˆ You are experiencing audio dropouts when playing clips in

Legato Mode .

Use RAM Mode with care, as RAM is usually a scarce resource. Your computer is using the hard disk for swapping out RAM contents that have not been used in a while. The more clips you are running in RAM Mode, the higher the likelihood for them to be swapped out. Live can handle disk overloads more gracefully than swapped-out audio arriving late:

Disk overloads result in unwanted mutes, whereas RAM overload results in both mutes and rhythmical hiccups.

The RAM Mode Switch.

8.2.9

Reversing Samples

This function creates a new sample by reversing the sample referenced by the current clip.

It then reapplies the old clip's settings (according to some rules that we will explain in a moment), and replaces the original sample with the reversal in the Clip View. The new sample can be found, after saving the Live Set, in the Set's

Project folder , under Samples/

The Reverse Button.

CHAPTER 8. CLIP VIEW

115

Processed/Reverse. Until the Set is saved, new samples remain at the location speci ed by the

Temporary Folder .

There are a few rules for the reversing process. First, any

Warp Markers

will remain xed to their positions in the sample. This means that a Warp Marker on the downbeat of the second bar of a clip will end up on the downbeat of the second-to-last bar after reversal.

Clip loop/region settings are similarly ipped. Second,

clip envelopes

remain xed to their position in time. Therefore, a mixer volume envelope that lowers the volume of the rst half of a clip will continue to do exactly that after reversal.

The reversal process is quite fast (about as fast as copying), but for very long samples it might take a little time. When this is the case, the Status Bar in the lower portion of the Live screen will give you a progress display, and further actions in the program will be temporarily locked

(though running clips will continue to play). You can play the reversed clip and perform other actions in the program as soon as Live begins to draw the new waveform into the Sample

Display. Once a sample is reversed, a link to the reversed sample will be maintained until you quit the program, and reversing the same clip again (or a copy) will be instantaneous.

It is not recommended that you reverse clips in a live performance situation, as a slight glitch can sometimes occur while Live reapplies the warp and loop settings.

8.2.10

Cropping Audio Clips

The Sample Display's (PC) /

Ctrl

(Mac) context menu includes the Crop Sample command. This function creates, similarly to the

Reverse function , a new sample by copying

the one currently in use - but only the excerpt that is actually used plus a 50 millisecond safety margin on both ends. The new sample can be found, after saving the Live Set, in the

Set's

Project folder , under Samples/Processed/Crop. Until the Set is saved, the new sample

remains at the location speci ed by the

Temporary Folder .

8.2.11

Replacing and Editing the Sample

To replace the sample referenced by the clip with a different one, drop the new sample directly from the File Browser into the Clip View. Clip settings like pitch and volume will

CHAPTER 8. CLIP VIEW

116 be retained. The Warp Markers will be retained only if the new sample has the exact same length as the old sample.

The Sample Display's (PC) /

Ctrl

(Mac) context menu includes the Manage Sample

File command. This opens the File Manager for the current Set with the sample referenced by the clip selected. From there, you can

replace and destructively edit the sample , in such

a way that all clips and instruments referencing the sample will be affected. You can also use the Show in Browser command in the the le in the Browser.

(PC) /

Ctrl

(Mac) context menu to reveal

8.3

The Notes Box

8.3.1

Tempo Controls

The Orig. BPM eld displays Live's interpretation of the tempo at which the clip's MIDI was recorded. When dragging up or down in the Original BPM eld, or clicking the :2 and

*2 buttons, you will see that the notes in the MIDI Editor are correspondingly stretched or compressed. This is useful for aligning notes that you have recorded without a tempo reference, like Live's

metronome .

The Notes Box.

CHAPTER 8. CLIP VIEW

117

8.3.2

Bank and Program Change

Live can send MIDI bank/program change messages to external devices and plug-ins that support MIDI program change messages. According to the settings in these controls, launching a clip also sends its bank/program change message. If you are using Live to send

MIDI to your synth, this means that each MIDI clip in your Live Set can play a different sound on your synth. Live offers messages for 128 banks with 128 sub-banks, each of which has

128 programs. Please see the documentation that came with your synthesizer to determine how many of these messages it can use. If you do not want your clip to send program or bank change messages, simply set the bank/program choosers to None.

8.3.3

MIDI Loop/Region

These controls manage how the contents of a MIDI clip are played and shown in the MIDI

Editor. They work the same way as those for

audio clips .

In the MIDI Editor, the zoom/scroll area is located above the beat-time ruler, the scrub area just below.

8.4

Clip Defaults and Update Rate

You can change the rate at which Live applies your Clip View settings to a running clip. Clip

View changes will be quantized by the rate selected from the Clip Update Rate chooser in the Record/Warp/Launch Preferences. Certain clip settings, such as Launch Mode and Warp

Mode, can be set up as defaults for all new clips. This is also done in the Record/Warp/

Launch Preferences.

advertisement

Was this manual useful for you? Yes No
Thank you for your participation!

* Your assessment is very important for improving the workof artificial intelligence, which forms the content of this project

Related manuals

Download PDF

advertisement

Table of contents