Recording New Clips. AUTOHELM ABLETON

Add to my manuals
553 Pages

advertisement

Recording New Clips. AUTOHELM ABLETON | Manualzz

198

Chapter 15

Recording New Clips

This chapter is about recording new clips from audio and MIDI input signals. Note that this is a different kind of recording than the

capturing of Session clips into the Arrangement .

For successful audio recording, please make sure the audio preferences are set up properly.

For more on this, please see the built-in program lesson on setting up Audio Preferences.

Also, keep in mind that devices such as microphones, guitars and turntables do not operate at line level, meaning that they will need to have their levels boosted before they can be recorded. For these devices, you must therefore use either an audio interface with a preamp, or an external preamp.

15.1

Choosing an Input

A track will record whatever input source is shown in its In/Out section, which appears when the View menu's In/Out option is checked. (In the Arrangement View, unfold and resize the track in order to completely see the In/Out section.)

CHAPTER 15. RECORDING NEW CLIPS

199

Audio tracks default to recording a stereo signal from the external input pair 1/2.

MIDI tracks default to recording all MIDI that is coming in through the

active external input devices . The computer keyboard is, by default, activated as a

pseudo-MIDI input device ,

allowing you to record MIDI even if no MIDI controller hardware is currently available.

For every track, you can choose an input source other than the default: any mono or stereo external input, a speci c MIDI channel from a speci c MIDI-in device, audio from ReWire slave programs or a signal coming from another track. The

Routing chapter

describes these options in detail.

The Track In/Out Section in the Arrangement

(Left) and Session View

(Right).

15.2

Arming (Record-Enabling) Tracks

To select a track for recording, click on its Arm button. It doesn't matter if you click a track's

Arm button in the Session View or in the Arrangement View, since the two

share the same set of tracks .

By default, armed tracks are monitored, meaning that their input is passed through their device chain and to the output, so that you can listen to what is being recorded. This behavior is called auto-monitoring and you can

change it to t your needs .

Track Arm Buttons in the

Arrangement (Left) and

Session (Right) Mixers.

CHAPTER 15. RECORDING NEW CLIPS

200

If you are using a natively supported control surface, arming a MIDI track will automatically

lock this control surface

to the instrument in the track.

Clicking one track's Arm button unarms all other tracks unless the

Ctrl

(PC) / (Mac) modi er is held. If multiple tracks are selected, clicking one of their Arm buttons will arm the other tracks as well. Arming a track selects the track so you can readily access its

devices in the Track View .

15.3

Recording

Recording can be done in both the Session and the Arrangement Views. If you want to record onto more than one track simultaneously and/or prefer viewing the recording linearly and in-progress, the Arrangement View may be the better choice. If you want to break your recording seamlessly into multiple clips or record while you are also launching clips in Live, use the Session View.

15.3.1

Recording Into the Arrangement

1

3

4

6

5

2

Recording Into the

Arrangement.

CHAPTER 15. RECORDING NEW CLIPS

201

1. Recording commences when the Control Bar's Record button is activated and the Play button is pressed.

2. Recording creates new clips in all tracks that have their Arm button on.

3. When the Overdub switch is on, the new clips contain a mix of the signal already in the track and the new input signal. The Overdub option only applies to MIDI tracks.

4. To prevent recording prior to a punch-in point, activate the Punch-In switch. This is useful for protecting the parts of a track that you do not want to record over and allows you to set up a pre-roll or warm-up time. The punch-in point is identical to the Arrangement Loop's start position.

5. Likewise, to prevent recording after the punch-out point, activate the Punch-Out switch. The punch-out point is identical to the Arrangement Loop's end position.

6. When you are recording into the

Arrangement Loop , Live retains the audio

recorded during each pass.

You can later unroll a loop recording, either by repeatedly using the Edit menu's Undo command or graphically in the Clip View: After loop recording, double-click on the new clip.

In the Clip View's Sample Display, you can see a long sample containing all audio recorded during the loop-recording process. The Clip View's

loop brace

de nes the audio taken in the last pass; moving the markers left lets you audition the audio from previous passes.

15.3.2

Recording Into Session Slots

You can record new clips, on the y, into any Session slots.

CHAPTER 15. RECORDING NEW CLIPS

4 3 2 1

202

1. Set the Global Quantization chooser to any value other than None to obtain correctly cut clips.

2. Activate the Arm button for the tracks onto which you want to record. Clip

Record buttons will appear in the empty slots of the armed tracks.

3. Click on any of the Clip Record buttons to commence recording. A new clip will appear in the slot with a red Clip Launch button that shows it is currently recording. To go from recording immediately into loop playback, press the clip's

Launch button.

4. Alternatively, you can click a Clip Stop button or the Stop button in the Control

Bar to stop recording, leaving the new clip silent.

Note that, by default, launching a

Session View scene

will not activate recording in empty record-enabled slots belonging to that scene. However, you can use the Start Recording on Scene Launch option from the Record/Warp/Launch Preferences to tell Live that you do want empty scene slots to record under these circumstances.

Recording a New Clip

Into the Session View.

CHAPTER 15. RECORDING NEW CLIPS

203

15.3.3

Overdub Recording MIDI Patterns

Live makes pattern-oriented recording of drums and the like quite easy. Using Live's

Impulse

instrument and the following technique, you can successively build up drum patterns while listening to the result. Or, using an instrument such as

Simpler , which allows for chromatic

playing, you can build up melodies or harmonies, note by note.

1. Set the Global Quantization chooser to one bar.

2. To automatically quantize the notes you are about to record, choose an appropriate value for

Record Quantization .

3. Double-click any of the Session View slots in the desired MIDI track (the one containing the Impulse or other instrument). A new, empty clip will appear in the slot. The new clip will default to a loop length of one bar, but you can change that by double-clicking the clip and changing its

loop properties .

4. Arm the track.

5. Launch the clip.

6. The notes you play are added into the looping clip, and you can observe your recording in the Clip View.

7. By default, the Control Bar's Overdub switch is activated, so that you can build your pattern layer by layer. However, if you would like to pause recording for a moment to rehearse, you can deactivate the Overdub switch. The contents of the clip will continue to play, but you can play along without being recorded.

When you are ready to record again, simply turn on the Overdub switch.

8. Stop recording by pressing a Clip Stop button or the Stop button in the Control

Bar.

Note that holding

Alt

(PC) /

Alt

(Mac) while double-clicking the empty slot to create a new clip will implicitly arm the track and launch the clip.

At any time while overdub recording is going on, you can use the Undo command to remove the last take, or even draw, move or delete notes in the Clip View's Note Editor.

Note that you can also add notes to existing Session clips while the Overdub switch is on.

CHAPTER 15. RECORDING NEW CLIPS

204

15.3.4

MIDI Step Recording

The MIDI Editor allows you to record notes with the transport stopped by holding down keys on your controller or

computer MIDI keyboard

and advancing the insert mark according to the grid settings. This process, known as step recording, allows you to enter notes at your own pace, without needing to listen to a metronome or guide track.

2

1

3

1. Arm the MIDI track that contains the clip into which you want to record.

2. Enable the Preview switch in the clip's MIDI Editor.

3. Click in the MIDI Editor to place the insert mark at the position where you want to begin recording.

Pressing on your computer keyboard will move the insert mark to the right, according to the grid settings. Any notes that are held down as you press will be added to the clip. If you continue holding notes as you press again, you will extend their duration. To delete notes that you've just recorded, keep them depressed and press .

The step recording navigators can also be

MIDI mapped .

Step Recording in the

MIDI Editor.

CHAPTER 15. RECORDING NEW CLIPS

15.4

Recording in Sync

205

Live keeps the audio and MIDI you have recorded in sync, even when you later decide on a different song tempo. In fact, Live allows you to change the tempo at any time before, after and even during recording. You could, for instance, cheat a bit by turning down the tempo to record a technically dif cult part, and pull it up again afterwards.

It is important to record in sync to make sure everything will later play in sync.

The easiest way to record in sync is to play along with or to use the built-in metronome, which is activated via its Control Bar switch and will begin ticking when the Play button is pressed or a clip is launched.

The Metronome Switch.

To adjust the metronome volume, use the mixer's Preview Volume knob.

Notice that Live's metrical interpretation of the audio being played can be edited, at any time, using the

Warp Markers

. Warp Markers can be used to x timing errors and to change

the groove or feel of your recordings. Using Warp Markers, you can x things in your recordings that would otherwise require complicated editing or could not be done at all.

Likewise, the metrical interpretation of recorded MIDI can be changed after recording, using the MIDI clip's

Original BPM controls .

The Preview Volume

Knob.

CHAPTER 15. RECORDING NEW CLIPS

15.5

Recording Quantized MIDI Notes

206

If you will be recording MIDI, you have the option of automatically quantizing MIDI notes while recording. The Record Quantization chooser in the Edit menu allows selecting the meter subdivisions with which your recorded notes will align. When recording

into Session slots

or

into the Arrangement , record quantization is an independent step in Live's Undo

history. This means that if, for example, you recorded with Record Quantization set to

Eighth Note Triplet Quantization and then changed your mind, using the Edit menu's

Undo command would undo only the quantization and leave your recording otherwise intact.

For Session and Arrangement recording, the Record Quantization setting cannot be changed mid-recording.

When

overdub recording

with the Clip View Loop activated, changes to the Record Quantization take effect immediately, and they cannot be separately undone with the Edit menu command.

Recorded MIDI notes can also be quantized post-recording with the Edit menu's Quantize command, as described in the chapter on

editing MIDI .

15.6

Recording with Count-in

A count-in for recording can be set in Live's Record/Warp/Launch Preferences. When the

Count-In preference is set to any value other than None, Live will not begin recording until the count-in is complete. The Arrangement Position elds in the Control Bar display the count-in in orange as bars-beats-sixteenths.

The Count-In is

Displayed in the Control

Bar.

The count-in runs from negative bars-beats-sixteenths (beginning at -2.1.1., for example, with a Count-In setting of 2 bars) up to 1.1.1., at which point recording commences.

Note that count-in recording does not apply when Live is

synced to external MIDI devices or being used as a ReWire slave .

CHAPTER 15. RECORDING NEW CLIPS

15.7

Setting up File Types

207

The following Preferences from the Record/Warp/Launch tab are relevant to the sample les that are created by recording:

ˆ The sample le type you would like Live to create can be chosen from the File Type chooser in the Record/Warp/Launch Preferences.

ˆ The bit depth of the sample le you will create by recording can be chosen from the

Bit Depth chooser in the Record/Warp/Launch Preferences.

You can save time by setting up reasonable defaults for the clips you are recording in the

Record/Warp/Launch Preferences tab. In particular, it is smart to indicate the rough category of sound to be recorded by choosing the appropriate default Warp Mode. If you decide later on a different song tempo, the program will automatically maintain

good sound quality ,

usually without further adjustment.

15.8

Where are the Recorded Samples?

Recorded samples are stored with the current Set's

Project folder , under Samples/Recorded.

Until the Set is saved, it remains at the location speci ed by the Temporary Folder preference which is found in the Preferences' File/Folder tab. To make sure Live will not run out of disk space while recording into a new Set, please make sure the Temporary Folder is on a drive/ partition with suf cient free space.

15.9

Using Remote Control for Recording

Using

Key Map Mode and MIDI Map Mode , you can operate Live's recording functions

without using the mouse.

You can map the Control Bar's Record and transport controls as well as the track Arm buttons.

For recording into the Session slots, you can map the individual slots as well as the relative navigation controls to initiate recording remotely; for instance:

CHAPTER 15. RECORDING NEW CLIPS

208

The Scene Up/Down

Buttons.

One key is used to jump to the next scene...

A Track Launch Button.

... and another key to start and end recording in the respective track.

You can also map the

step recording

navigators.

This allows you to, for example, use MIDI foot pedals to move the clip's insert mark, thereby keeping both hands free for playing a keyboard.

The Step Recording

Arrows.

advertisement

Was this manual useful for you? Yes No
Thank you for your participation!

* Your assessment is very important for improving the workof artificial intelligence, which forms the content of this project

Related manuals

Download PDF

advertisement

Table of contents