Working with Instruments and Effects. AUTOHELM ABLETON

Add to my manuals
553 Pages

advertisement

Working with Instruments and Effects. AUTOHELM ABLETON | Manualzz

209

Chapter 16

Working with Instruments and

Effects

Every track in Live can host a number of devices. These devices can be of three different sorts:

ˆ MIDI effects act upon MIDI signals and can only be placed in MIDI tracks.

ˆ Audio effects act upon audio signals and can be placed in audio tracks. They can also be placed in MIDI tracks as long as they are downstream from an instrument.

ˆ Instruments are devices that reside in MIDI tracks, receive MIDI and output audio.

The Track View is where you insert, view and adjust the devices for the selected track. To select a track and open the Track View to access its devices, double-click the track's name.

The Track View appears in the bottom area of the Live screen.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

210

To save space in the Track View, a device can be collapsed by double-clicking on its title bar or by choosing Fold from its (PC) /

Ctrl

(Mac) context menu.

Devices in the Track

View.

To learn about a particular device and how to operate it, consult the

Live Audio Effect

Reference ,

Live MIDI Effect Reference

or the

Live Instrument Reference .

To learn about creating and using custom groupings of instruments and effects, check out the

Instrument, Drum and Effect Racks

chapter.

Get hands-on with devices by assigning their parameters to

MIDI or key remote control .

Devices Can Be Folded.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

16.1

Using the Live Devices

211

Click on the Device Browser selector to access the palette of Live's built-in devices. You will notice that MIDI effects, audio effects and instruments each have their own folders in the

Browser.

The easiest way to place a device in a track is to double-click on it in the Browser, which creates a new track to hold the device. Alternatively, select a destination track by clicking within it, then select a device or preset in the Browser and press

Return to add it to the selected track.

You can also drag devices into tracks or drop areas in the Session and Arrangement Views, or into the Track View. Dragging a sample to the Track View of a MIDI track creates a

Simpler

instrument with this sample loaded.

Note: If you are using an external input signal to feed your Live track using the default settings, the track's Arm button in the mixer must be activated in order to hear the input through the devices in your track's device chain. On MIDI tracks, this is normally activated automatically when inserting an instrument.

The Live Device Browser.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

212

This is how you would play live instruments through effects on a track, for example, or use a MIDI keyboard's input to play a track's instrument. Note that you can easily move from this setup into

recording new clips

for further use in Live. If you have alternative monitoring preferences, please see the

Monitoring section

to learn how to make these settings.

To add another device to the track, simply drag it there or double-click its name to append it to the device chain. Signals in a device chain always travel from left to right.

You can drop audio effects in at any point in an audio track's device chain, keeping in mind that the order of effects determines the resulting sound. The same is true for a MIDI track's device chain.

If you drop an instrument into a MIDI track's device chain, be aware that signals following

(to the right of) the instrument are audio signals, available only to audio effects. Signals preceding (to the left of) the instrument are MIDI signals, available only to MIDI effects. This means that it's possible for a MIDI track's device chain to hold all three types of devices: rst

MIDI effects, then an instrument, and nally audio effects.

MIDI and Audio Track

Arm Buttons

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

213

To remove a device from the chain, click on its title bar and press your computer's or

Delete key, or select Delete from the Edit menu. To change the order of devices, drag a device by its title bar and drop it next to any of the other devices in the Track View. Devices can be moved to other tracks entirely by dragging them from the Track View into the Session or Arrangement Views.

Edit menu commands such as cut, copy, paste and duplicate can be used on devices.

Pasted devices are inserted in front of the selected device. You can paste at the end of a device chain by clicking in the space after the last device, or by using the key to move the selection there. Generally, devices can be placed, reordered and deleted without interrupting the audio stream.

A MIDI Track's Device

Chain Can Contain All

Three Device Types.

Devices are turned on and off using their Activator switches. Turning a device off is like temporarily deleting it: The signal remains unprocessed, and the device does not consume

CPU cycles. Live devices generally do not load down the CPU unless they are active.

For more information, please refer to the

CPU load section . The Freeze Track command

discussed there is especially helpful when working with CPU-intensive devices.

Device Activator

Switches.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

214

Devices in Live's tracks have input and output level meters. These meters are helpful in nding problematic devices in the device chain: Low or absent signals will be revealed by the level meters, and relevant device settings can then be adjusted, or the device can be turned off or removed.

Note that no clipping can occur between devices because there is practically unlimited headroom. Clipping can occur when an overly strong signal is sent to a physical output or written to a sample le.

Further information about track types in Live can be found in the

Routing and I/O chapter , in-

cluding information on using return tracks to distribute the effect of a single device amongst several tracks. After reading about using devices in Live, it might also be interesting to look into

clip envelopes , which can modulate individual device parameters on a per-clip basis.

The Level Meters

Between Devices in a

Chain.

16.1.1

Live Device Presets

Every Live device can store and retrieve their parameter settings as presets. Presets for Live instruments and effects are managed through the Device Browser. Each device appears there as a folder that can be opened to reveal its presets.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

215

Presets in the Device

Browser.

You can browse and load presets quickly with the computer keyboard:

ˆ Scroll up and down using the and keys.

ˆ Close and open device folders using the

ˆ Press

Return to load a device or preset.

and keys.

Clicking a device's Hot-Swap Presets button will temporarily link the Browser to a device, calling up its presets in the Device Browser. With the device and Browser linked in this manner, you can quickly browse, load and audition different presets. You can even replace the current device with a new one by simply selecting another device's preset. To load a device's default factory settings, select the parent folder of its presets (i.e., the one with the device's name) from the Device Browser.

The link between the Device Browser and the device will be broken if a different view is selected, or if the Hot-Swap button is pressed again. Preset hot-swapping can also be cancelled with a press of the

Esc key or by pressing the close button in the Hot-Swap bar at the top of the Browser.

Note that although importing via the Browser is the recommended method, presets can also be dropped directly into Live from the Explorer (Windows)/Finder (Mac).

The Hot-Swap Presets

Button.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

Saving Presets

You can create and save any number of your own presets in the Device Browser.

216

Click the Save Preset button to save a device's current settings (including any custom

info text ) as a new preset. You will be redirected to the Browser, where you can press

Return to use Live's suggested name, or you can type one of your own. You can also save presets to speci c folders in the Browser (such as your Current Project folder) by dragging from the title bar of the device and dropping into the Browser location of your choice.

For detailed information on what can be done with the Browser, please see the

Managing Files and Sets chapter . For more on how to store project-speci c presets, see the

appropriate section .

The Save Preset Button.

Default Presets

Presets saved to the Defaults folders in Live's Library will load in place of Live's generic device settings. There are also Defaults folders that allow you to customize how Live responds to various user actions, such as sample dropping and

slicing .

To save the current settings of a device as a default preset, open the (PC) /

Ctrl

(Mac) context menu on the device's header and select Save as Default Preset. This works

The Default Presets folders in Live's Library.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

217 for all of Live's instruments, MIDI effects and audio effects (including the various types of

Racks ). If you have already saved a default preset for a particular device, Live will ask you

before overwriting it.

To specify how Live behaves when dragging a sample to a Drum Rack or the Track View of a MIDI track:

ˆ Create an empty Simpler or Sampler

ˆ Adjust the parameters as you like

ˆ Drag the edited device to the On Drum Rack or On Track View folder, which can be found at Library/Defaults/Dropping Samples

To adjust how Live behaves when slicing an audio le:

ˆ Create an empty Drum Rack

ˆ Add an empty Simpler or Sampler to the Drum Rack to create a single chain

ˆ Add any additional MIDI or Audio Effects to this chain

ˆ Adjust parameters in any of the devices

ˆ Assign

Macro Controls

to any of the controls in the chain's devices

ˆ Drag the entire Drum Rack to the Library/Defaults/Slicing folder

You can create multiple slicing presets and choose between them in the Slicing Preset chooser in the slicing dialog.

16.2

Using Plug-Ins

The collection of devices that you can use in Live can be extended with plug-ins. Live supports Steinberg Media's VST Plug-ins format, as well as the Audio Units (AU) Plug-ins format (Mac OS X only).

Working with VST and Audio Units Plug-ins is very much like working with Live devices. VST and AU instruments can only be placed in Live MIDI tracks and, like Live instruments, they will receive MIDI and output audio signals. Plug-in audio effects can only be placed in audio

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

218 tracks or following instruments. Please see the previous section,

Using the Live Devices , for

details.

Audio Units and VST Plug-ins are browsed and imported using the Plug-In Device Browser, which is accessed via its selector. Plug-in instruments can be differentiated from plug-in effects in the Browser, as they appear with a keyboard icon.

The Browser's search functionality is only available for Audio Units Plug-ins, as is loading presets directly from Track View devices via the Hot-Swap button. In some instances, factory presets for Audio Units will only appear in the Browser once the device has been placed in a track and its Hot-Swap button activated.

Note: The rst time you start Live, no plug-ins will appear in the Plug-In Device Browser, as you must rst activate your plug-in sources. Activating your plug-in sources tells Live which plug-ins you want to use and where they are located on your computer. Information on activating (and deactivating) plug-in sources can be found later in this chapter, in the sections on the

VST Plug-in folder

and

Audio Units Plug-ins .

Note for Intel

® Mac users: Intel® Mac computers cannot natively run VST or AU plugins that have been written for the PowerPC platform. Only plug-ins of type (Universal) or

(Intel

®) can be used in Live.

If you install/de-install a plug-in while the program is running, Live will not detect your changes or implement them in the Plug-In Device Browser until the next time you start the program. Use the Rescan button in the File/Folder Preferences to rescan your plug-ins while

The Plug-In Device

Browser.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

219

Live is running, so that newly installed devices become immediately available in the Plug-In

Device Browser.

You can also rescan if you believe that your plug-in database has somehow become corrupted. Holding down the

Alt

(PC) /

Alt

(Mac) modi er while pressing Rescan will delete your plug-in database altogether and run a clean scan of your plug-ins.

16.2.1

Plug-Ins in the Track View

Once a plug-in is dragged from the Browser into a track, it will show up in the Track View.

For plug-ins with fewer than 32 modi able parameters, a Live panel will represent all of the parameters as horizontal sliders. Plug-ins that contain more than 32 parameters will open with an empty panel, which you can then con gure to show the parameters you want to access. The plug-in's original interface can be opened in a

separate window .

A VST Plug-In in the

Track View.

You can view or hide the plug-in's parameters by toggling the title bar.

button in the plug-in's

The Plug-In Unfold

Button.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

220

The X-Y control eld can be used to control two plug-in parameters at once and is therefore especially well-suited for live control. To assign any two plug-in parameters to the Live panel

X-Y eld, use the drop-down menus directly beneath it.

Showing Plug-In Panels in Separate Windows

The Plug-In Edit button opens a oating window that shows the original VST or Audio Units

Plug-in panel. Changing parameters on the oating window has the same effect as changing them in the Live panel, and vice versa.

There are a few important Plug-In Preference settings for working with plug-in edit windows:

ˆ If activated, the Auto-Open Plug-In Windows Preference assures that plug-in edit windows open automatically when plug-ins are loaded into tracks from the Browser.

ˆ If the Multiple Plug-In Windows option in the Plug-In Preferences is activated, you can open any number of plug-in windows at once. Even with this option off, you can hold down the

Ctrl

(PC) / (Mac) modi er when opening a new plug-in window to keep the previous window(s) from closing.

ˆ Using the Auto-Hide Plug-In Windows preference, you can choose to have Live display only those plug-in windows belonging to the track that is currently selected.

You can use the View menu's Show/Hide Plug-In Windows command or the

Ctrl Alt

(PC) /

Alt

P

P

(Mac) shortcut to hide and show your open plug-in windows. Notice that the name of the track to which the plug-in belongs is displayed in the title bar of the plug-in editor window.

The Plug-In Edit Button.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

Plug-In Con gure Mode

221

Con gure Mode allows you to customize Live's panel to show only the plug-in parameters that you need to access. To do this:

ˆ Enter Con gure Mode by pressing the Con gure button in the device's header.

ˆ Click on a parameter in the plug-in edit window to add it to Live's panel. (For some plug-ins, it may be necessary to actually change the parameter's value. Additionally, certain plug-ins do not publish all of their parameters to Live. These parameters cannot be added to Live's panel.)

While in Con gure Mode, parameters in Live's panel can be reordered or moved by dragging and dropping them to new locations. Parameters can be deleted by pressing the

Delete key. If you try to delete a parameter that has existing

automation data ,

clip envelopes , or

MIDI, key

or

Macro

mappings, Live will warn you before proceeding.

The parameters that you assign are unique for each instance of a given plug-in in your Set, and are saved with the Set. If you would like to save a setup using a particular collection of parameters, you can

create a Rack

containing the con gured plug-in. Racks can then be saved to your Library and loaded into other Sets.

Certain plug-ins do not have their own windows, and instead only show their parameters in

Live's panel. For these plug-ins, it is not possible to delete parameters when in Con gure

Mode (although they can still be moved and reordered).

There are several ways to add plug-in parameters to Live's panel without entering Con gure

Mode:

The Con gure Button.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

222

ˆ Adjusting a parameter in the plug-in's oating window creates temporary entries for that parameter in the clip envelope and automation choosers, as well as the choosers in the panel's X-Y eld. These entries are removed when you adjust another parameter. To make the entry permanent (thus adding it to Live's panel), either edit the parameter's automation or clip envelope, select another parameter in the automation or clip envelope choosers or select the temporary parameter in one of the X-Y eld's choosers.

ˆ When a parameter is changed on a plug-in's edit window during recording, automation data is recorded automatically. When recording is stopped, the automated parameters are automatically added to Live's panels for any plug-ins that were adjusted.

ˆ When in MIDI, key or Macro mapping mode, adjusting any parameter in the plug-in's window will create it in Live's panel. The new panel entry will be automatically selected, allowing you to map it immediately.

Once a plug-in is placed in a track and you have (optionally) con gured its parameters in

Live's panel, you can use it just like a Live device:

ˆ You can map MIDI controller messages to all of the parameters in Live's panel.

ˆ You can drag or copy the device to different locations in the device chain or to other tracks, according to the rules of audio effects and instruments.

ˆ You can modulate its continuous parameters with clip envelopes.

ˆ You can use the multiple I/O features of some plug-ins by assigning them as sources or targets in the routing setup of tracks. See the

Routing and I/O chapter

for details.

ˆ You can create custom

info text

for the plug-in.

Macintosh only: The oating editor windows of some VST Plug-ins do not receive computer key strokes. This is generally an implementation error in the plug-in itself. If it is necessary to type into a plug-in window, for instance for entering a serial number or unlock code, hold down while clicking the Plug-In Edit button. The editor window will then appear as a normal application window, rather than as a oating window, and receive your typing.

Note that this functionality is intended only as a workaround for the limitations of such plugins. We recommend closing the window after you have nished typing, then reopening it normally before working with the plug-in parameters.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

223

16.2.2

Plug-In Performance Options

The CPU Preferences contain a Plug-In Buffer Size setting for balancing plug-in latency and performance. Here you can set the number of samples processed at any one time by the plug-in. Higher settings may result in a noticeable performance increase but will also result in higher latencies.

With the As Audio Buffer setting selected, the plug-in will calculate the exact number of samples per millisecond as the computer's sound card. This setting usually means that very few dropouts or performance problems will occur, especially with DSP cards.

The size of the computer's sound card buffer (i.e., the number of samples it calculates per millisecond) can be set using the Buffer Size setting in the Audio Preferences.

16.3

VST Plug-Ins

16.3.1

The VST Plug-In Folder

When you start Live for the rst time, you will need to activate your VST Plug-in sources before working with VST Plug-ins. Depending on your computer platform, you may also have to tell Live about the location of the VST Plug-in folder containing the devices you want to use. In order to set up your VST sources, press the Activate button in the Plug-In

Device Browser, or open the File/Folder Preferences by pressing

Ctrl

,

(PC) /

,

(Mac). There you will nd the Plug-In Sources section.

For Windows, proceed as follows:

1. Use the VST Plug-In Custom Folder entry to tell Live about the location of your

VST Plug-ins: Click the Browse button to open a folder-search dialog for locating and selecting the appropriate folder.

Setting up VST Plug-In

Sources for Windows.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

2. Once you have selected a VST Custom Folder and Live has scanned it, the path will be displayed. Note that, on Windows, Live may have found a path in the registry without the need for browsing.

3. Make sure that the Use VST Plug-In Custom Folder option is set to On, so that your selected folder is an active source for VST Plug-ins in Live. Note that you can choose not to use your VST Plug-ins in Live by turning off the Use VST

Plug-In Custom Folder option.

224

Set up your VST Plug-ins under Mac OS X by doing the following:

1. Your VST Plug-ins will normally be installed in the following folder in your home and local directories: /Library/Audio/Plug-Ins/VST. You can turn Live's use of these plug-ins on or off with the Use VST Plug-ins in System Folders option.

2. You may have an alternative folder in which you store your VST Plug-ins (perhaps those that you use only with Live). You can use VST Plug-ins in this folder in addition to, or instead of, those in the System folders. To tell Live about the location of this folder, click the Browse button next to the VST Plug-In Custom Folder entry to open a folder-search dialog for locating and selecting the appropriate folder.

3. Note that you can turn off your VST Plug-ins in this folder using the Use VST

Plug-In Custom folder option.

Once you have con gured your Plug-In Preferences, the Plug-In Device Browser will display all plug-ins it nds in the selected VST Plug-in folder(s) as well as any sub-folders.

It is also possible to use VST Plug-ins stored in different folders on your computer. To do this, create a Mac OS or Windows alias of the folder where additional VST Plug-ins are stored, and then place the alias in the VST Plug-In Custom folder (or in the VST Plug-In

Setting up VST Plug-In

Sources for Mac OS X.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

225

System folder on Mac OS X) selected in Live's File/Folder Preferences. The alias can point to a different partition or hard drive on your computer. Live will scan the set VST Plug-in folder as well as any alias folders contained therein.

Some VST Plug-ins contain errors or are incompatible with Live. During the scanning process, these may cause the program to crash. When you re-launching Live, a dialog will appear to inform you about which plug-in caused the problem. Depending on what Live detects about the plug-in, you may be given the choice between performing another scan or making the problematic plug-in unavailable. If you choose to rescan and they crash the program a second time, Live will automatically make them unavailable, meaning that they will not appear in the Plug-In Device Browser and will not be rescanned again until they are reinstalled.

16.3.2

VST Programs and Banks

Every VST Plug-in instance owns a bank of programs. A program is meant to contain one complete set of values for the plug-in's controls.

To select a program from the plug-in's bank, use the chooser below the title bar. The number of programs per bank is xed. You are always working in the currently selected program, that is, all changes to the plug-in's controls become part of the selected program.

Note that VST programs are different from

Live device presets : Whereas the presets for a

Live device are shared among all instances and Live Sets, the VST programs belong to this speci c instance of the VST Plug-in.

The VST Plug-In

Program Chooser.

To rename the current program, select the VST program chooser and execute the Edit menu's Rename Plug-In Preset command. Then type in a new program name and con rm by pressing

Return

.

Renaming a VST Plug-In

Program.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

226

VST programs and banks can be imported from les. Clicking the VST Program Load button brings up a standard le-open dialog for locating the desired le.

Windows only: Please select from the File Type menu whether you want to locate VST

Device Program les or VST Device Bank les.

To save the currently selected program as a le, click the VST Program/Bank Save button to bring up a standard le-save dialog; select VST Device Program from the Format menu

(Macintosh)/from the File Type menu (Windows); select a folder and name. For saving the entire bank as a le, proceed likewise but choose VST Device Bank as a le type/format.

The VST Program/Bank

Load Button (Left) and

Save Button (Right).

16.4

Audio Units Plug-Ins

Audio Units Plug-ins are only available in Mac OS X. In most respects, they operate just like

VST Plug-ins .

The rst time you open Live, Audio Units Plug-ins will not appear in the Plug-In Device

Browser. In order to activate your Audio Units as a plug-in source, please press the Activate button in the Plug-In Device Browser, or go to the File/Folder Preferences by pressing

Ctrl

,

(PC) /

,

(Mac). There you will nd the Plug-In Sources section. Turning

An Audio Units Plug-In.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

227 on the Use Audio Units option activates Audio Units Plug-ins so that they appear in Live's

Plug-In Device Browser.

Note that you can always turn this option off later if you decide not to use Audio Units.

Audio Units Plug-ins sometimes have a feature that allows choosing between different modes for the device. You might be able to choose, for example, between different levels of quality in the rendering of a reverb. Choosers for these device modes can only be accessed through the original plug-in panel, which is opened using the Plug-In Edit button.

Activating Audio Units

Plug-Ins.

Audio Units have presets that function just like those for the

Live effects . However, some

AU presets cannot be dragged to different locations in the Browser, as they are read-only.

Audio Units presets have an .aupreset extension and are stored in the following directory according to their manufacturer's name:

[Home]/Library/Audio/Presets/[Manufacturer Name]/[Plug-in Name]

Opening an Audio Units

Plug-In Window.

16.5

Device Delay Compensation

Live automatically compensates for delays caused by Live and plug-in instruments and effects, including those on the return tracks. These delays can arise from the time taken by devices to process an input signal and output a result. The compensation algorithm keeps all of Live's tracks in sync, regardless of what their devices are doing, while minimizing delay between the player's actions and the audible result.

CHAPTER 16. WORKING WITH INSTRUMENTS AND EFFECTS

228

Device delay compensation is on by default and does not normally have to be adjusted in any way. However, Live Sets that were created with Live 4 or earlier will open without device delay compensation. To manually turn latency compensation on (or off), use the

Delay Compensation option in the Options menu.

Unusually high

individual track delays

or reported latencies from plug-ins may cause noticeable sluggishness in the software. If you are having latency-related dif culties while recording and playing back instruments, you may want to try turning off device delay compensation, however this is not normally recommended. You may also nd that adjusting the individual track delays is useful in these cases.

Note that device delay compensation can, depending on the number of tracks and devices in use, increase the CPU load.

advertisement

Was this manual useful for you? Yes No
Thank you for your participation!

* Your assessment is very important for improving the workof artificial intelligence, which forms the content of this project

Related manuals

Download PDF

advertisement

Table of contents