Xcalibur 4.0 Data Acquisition and Processing User Guide Version A

Xcalibur 4.0 Data Acquisition and Processing User Guide Version A

7

Configuring and Managing the Data System

This chapter describes the data system configuration options, such as setting the font type and size for several of the views; the default directories for data files, methods, and report templates; and the default mass tolerance and mass precision values for processing. This chapter also describes how to use the File Converter utility to convert files from one format to another, how to check the disk space of the data system computer, and how to set up the instrument configuration in the Thermo Foundation platform.

For more information about setting up the instrument configuration, refer to the Thermo

Foundation Help and the Help provided with each instrument device. For information about creating custom My XApps pages, see

“Roadmap View” on page 166 .

Contents

Configuring the Xcalibur Data System

Converting File Formats

Checking Disk Space

Confirming the Properties of Thermo Foundation Security Service

Setting Up the Instrument Configuration in the Foundation Platform

Thermo Scientific Xcalibur Data Acquisition and Processing User Guide

129

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Configuring the Xcalibur Data System

Use the Xcalibur Configuration dialog box to configure the data system. Use the pages in the dialog box to define the location of data, methods, and report templates on your data system computer; to edit customer information; to select the fonts that you want to use; and to select error handling options.

To configure the Xcalibur data system, follow these procedures:

Opening the Xcalibur Configuration Dialog Box

Selecting Default Folders

Updating Customer Information

Configuring Fonts Used By the Xcalibur Data System

Selecting the Default Peak Detection Algorithms

Setting Up the Default Mass Options

Selecting Default Labeling and Scaling Options

Selecting Error Handling Options

Defining the Dataset List

Opening the Xcalibur Configuration Dialog Box

To open the Xcalibur Configuration dialog box

1. Choose Start > Programs > Thermo Xcalibur > Xcalibur from the taskbar.

The home page window opens.

2. Choose Tools > Configuration from the Roadmap view of the home page window.

The Xcalibur Configuration dialog box opens.

Selecting Default Folders

You can specify the default directory location for your raw data files, methods, and report templates.

The Xcalibur data system comes with example raw data files, processing methods, sequences, and report templates.

• The following folder contains the example raw data files (RAW) and result files (RST):

drive:\Xcalibur\examples\data\

130

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

• The following folder contains the example processing methods (PMD file type) and sequence files (SLD file type):

drive:\Xcalibur\examples\methods

• The following folder contains report templates:

drive:\Xcalibur\\templates

To open the Folders page

1. From the Roadmap view of the Xcalibur home page, choose Tools > Configuration from the menu bar.

2. Click the Folders tab.

The Folders page of the Xcalibur Configuration dialog box opens ( Figure 71

).

Figure 71. Folders page

Thermo Scientific

To select default file folders

1. Open the Folders page of the Thermo Xcalibur Configuration dialog box.

2. Select the appropriate folders as follows:

• To specify the default folder for your Xcalibur data files, click Browse to the right of the Data box and select the folder.

• To specify the default folder for your instrument methods, processing methods, and sequence files, click Browse to the right of the Methods box and select the folder.

• To specify the default folder for your report templates, click Browse to the right of the Report Templates box and select the folder.

3. To save the settings, click OK.

Xcalibur Data Acquisition and Processing User Guide

131

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Folders Page

Use the Folders page of the Xcalibur Configuration dialog box to specify the default location of your Xcalibur data, methods, and report templates.

Table 5 describes the parameters on the Folders page of the Xcalibur Configuration dialog

box.

Table 5. Folders page parameters

Parameter

Default Folders

Data

Description

Methods

Report Templates

Specifies the current default path to the folder that contains your

Xcalibur data. To change the path, click Browse and select the folder where you want to store your data. When you click OK, the data system changes the default path in the Data box to the new path.

Specifies the current default path to the folder that contains your

Xcalibur methods. To change the path, click Browse and select the folder where you want to store your. When you click OK, the data system changes the default path in the Methods box to the new path.

Specifies the current default path to the folder that contains your

Xcalibur report templates. To change the path, click Browse and select the folder where you want to store your report templates.

When you click OK, the data system changes the default path in the Report Templates box to the new path.

Updating Customer Information

The Customer Info page of the Xcalibur Configuration dialog box displays the current licensing information for your Thermo Scientific mass spectrometer. If this information is not already entered or it is incorrect, update the current entries.

To open the Customer Info page

1. From the Roadmap view of the Xcalibur home page, choose Tools > Configuration from the menu bar.

2. Click the Customer Info tab.

The Customer Info page of the Xcalibur Configuration dialog box opens ( Figure 72 ).

132

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

Figure 72. Customer Info page

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

To update the customer information

1. Open the Customer Info page of the Thermo Xcalibur Configuration dialog box.

2. If the information on the Customer Info page is incomplete or incorrect, type the new information.

3. To save the settings, click OK.

Thermo Scientific Xcalibur Data Acquisition and Processing User Guide

133

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Customer Info Page

Use the Customer Information page of the Xcalibur Configuration dialog box to confirm and update the following Xcalibur software license information.

Table 6 describes the parameters on the Customer Info page of the Xcalibur Configuration

dialog box.

Table 6. Xcalibur software license parameters

Parameter

User Name

Organization

Address

Voice Phone

Fax

Email

Print User Info

Description

Specifies the name assigned to the Xcalibur license agreement. To change the user name, log on to your computer as an administrator.

Specifies the organization assigned to the Xcalibur license agreement. To change the organization, log on to your computer as an administrator.

Specifies the address assigned to the Xcalibur license agreement.

Commas separate the sections of the address, for example: city, state, and country.

Specifies the voice telephone number assigned to the Xcalibur license agreement.

Specifies the fax telephone number assigned to the Xcalibur license agreement.

Specifies the email address assigned to the Xcalibur license agreement.

Prints a report that lists the current user name, organization, address 1, address 2, voice phone number, and fax telephone number.

134

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Configuring Fonts Used By the Xcalibur Data System

Grid plots in the Xcalibur data system use both a fixed-pitch font and a proportional font.

The application default fixed-pitch font is Courier New with a minimum size of 7 points and a maximum size of 12 points. The Xcalibur default proportional font is Arial with a minimum size of 7 points and a maximum size of 12 points. To use other fonts, font styles, or font sizes, change the font settings.

To open the Fonts page

1. From the Roadmap view of the Xcalibur home page, choose Tools > Configuration from the menu bar.

2. Click the Fonts tab.

The Fonts page of the Thermo Xcalibur Configuration dialog box opens (

Figure 73 ).

Figure 73. Fonts page

Thermo Scientific

To configure the Xcalibur fonts

1. Open the Fonts page of the Thermo Xcalibur Configuration dialog box.

2. To select a fixed-pitch font, do the following: a. Select a font name in the Fixed Pitch Font list.

The selected font name is displayed at the top of the list. b. Enter the minimum size of the selected font in the Min list.

c.

Enter the maximum size of the selected font in the Max list.

Xcalibur Data Acquisition and Processing User Guide

135

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System d. View the font sample, minimum size (top) and maximum size (bottom), in the Fixed

Pitch Font Preview area.

3. To select a proportional font, do the following: a. Select a font name in the Proportional Pitch Font list.

The selected font name is displayed at the top of the list.

b. Enter the minimum size of the selected font in the Min list.

c.

Enter the maximum size of the selected font in the Max list.

d. View the font sample, minimum size (top) and maximum size (bottom), in the

Proportional Pitch Font Preview area.

Tip If the values in the spectrum list view appear in light gray when you work in the Qual Browser window, close the Qual Browser window and return to the

Roadmap view of the Xcalibur home page. Choose Tools > Configuration to open the Xcalibur Configuration dialog box. Select the Fonts tab and set all font sizes to a minimum of 10 points.

4. To save the settings, click OK.

Fonts Page

Use the Fonts page of the Xcalibur Configuration dialog box to change the appearance of fonts in the data system.

Note If the data system displays the elemental composition values in light gray, close Qual

Browser and choose Xcalibur Roadmap > Tools > Configuration to display the

Configuration page. Select the Fonts tab and set all font sizes to a minimum of 10 points.

Table 7 describes the parameters on the Fonts page of the Xcalibur Configuration dialog box.

Table 7. Fonts page parameters (Sheet 1 of 3)

Parameter

Fixed Pitch Font

Font

Description

Specifies the fixed pitch (non-proportional) font that the Xcalibur data system currently uses; the name appears in the topmost Font box. The default fixed-pitch font is Courier New. The Fixed Pitch Font list displays all of the fixed-pitch fonts that are currently available on your data system. Fixed-pitch fonts have characters whose width is constant.

To change the font, select a font in the Font list. The data system displays the selected font in the topmost box and displays an example in the associated Preview area. When you click OK, the Xcalibur data system implements this font throughout all Xcalibur programs wherever fixed-pitch fonts are used.

136

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

Thermo Scientific

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Table 7. Fonts page parameters (Sheet 2 of 3)

Parameter Description

Min

Max

Specifies the minimum fixed-pitch font size that the data system currently uses; the number appears in the topmost Min box. The default minimum fixed-pitch font size is 7 points. To change this value, select another font size in the list. The data system displays the selected font size in the topmost box and displays both the current font and the selected font size in the top row of the associated Preview area.

Specifies the maximum fixed-pitch font size that the data system currently uses; the number appears in the topmost Max box. The default maximum fixed-pitch font size is 12 points. To change this value, select another font size in the list. The data system displays the selected font size in the topmost box and displays both the current font and the selected font size in the bottom row of the associated Preview area.

Fixed Pitch Font Preview

Preview View the following examples:

• Example text with fixed-pitch font at minimum size.

• Example text with fixed-pitch font at maximum size.

Proportional Pitch Font

Font

Min

Specifies the proportional-pitch font that the data system currently uses; the name appears in the topmost Font box. The default proportional-pitch font for the data system is Arial. The Proportional

Pitch Font list displays all of the proportional-pitch fonts that are currently available on your data system. Proportional pitch fonts have characters that vary in width. For example, the widest character is W.

To change the font, select a font in the Font list. The application displays the selected font in the topmost box and displays an example in the associated Preview area. When you click OK, the data system implements this font throughout all Xcalibur programs wherever proportional-pitch fonts are used.

Specifies the minimum proportional-pitch font size that the data system currently uses; the number appears in the topmost Min box.

The default minimum proportional-pitch font size is 7 points. To change this value, select another font size in the list. The application displays the selected font size in the topmost box and displays both the current font and the selected font size in the top row of the associated

Preview area.

Xcalibur Data Acquisition and Processing User Guide

137

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Table 7. Fonts page parameters (Sheet 3 of 3)

Parameter

Max

Description

Specifies the maximum proportional-pitch font size that the data system currently uses; the number appears in the topmost Max box.

The default maximum proportional-pitch font size is 12 points. To change this value, select another font size in the list. The application displays the selected font size in the topmost box and displays both the current font and the selected font size in the bottom row of the associated Preview area.

Proportional Pitch Font Preview

Preview Displays the following examples:

• Example text with proportional-pitch font at minimum size.

• Example text with proportional-pitch font at maximum size.

Selecting the Default Peak Detection Algorithms

Use the Peak Detection page of the Xcalibur Configuration dialog box to view or change the default peak detection algorithms for all data types.

To open the Peak Detection page

1. From the Roadmap view of the Xcalibur home page, choose Tools > Configuration from the menu bar.

2. Click the Peak Detection tab.

The Peak Detection page of the Xcalibur Configuration dialog box opens ( Figure 74 ).

Figure 74. Peak Detection page

138

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

Thermo Scientific

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

To specify the default peak detection algorithms

1. Open the Peak Detection page of the Thermo Xcalibur Configuration dialog box.

2. Make the following selections:

• To select the Default Peak Detection Algorithm for MS Data, select an algorithm name from the corresponding list.

• To select the Default Peak Detection Algorithm for PDA/UV Data, select an algorithm name from the corresponding list.

• To select the Default Peak Detection Algorithm for Other Data Types, select an algorithm name from the corresponding list.

3. To save the settings, click OK.

Peak Detection Page

Use the Peak Detection page of the Xcalibur Configuration dialog box to select which peak detection algorithm to use as the default for different data types. All new processing setup methods are created using the currently selected Xcalibur default peak detection algorithm.

You can return to the Peak Detection page at any time to change the Xcalibur default peak detection algorithm. Specify a default algorithm to use for different data types in the Default

Peak Detection Algorithm area.

Table 8 describes the parameters on the Peak Detection page of the Xcalibur Configuration

dialog box.

Table 8. Peak Detection page parameters

Parameter

Default Peak Detection Algorithm

Default Peak Detection Algorithm for MS Data

Description

Specifies the default peak detection algorithm for MS data.

Default Peak Detection Algorithm for PDA/UV Data

Default Peak Detection Algorithm for Other Data Types

(Data types other than MS and

PDA/UV)

Selections: ICIS, Genesis, or Avalon

Specifies the default peak detection algorithm for

PDA/UV data.

Selections: ICIS, Genesis, or Avalon

Specifies the default peak detection algorithm for data types other than MS, PDA, or UV data.

Selections: ICIS, Genesis, or Avalon

Xcalibur Data Acquisition and Processing User Guide

139

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Setting Up the Default Mass Options

Use the Mass Options page of the Xcalibur Configuration dialog box to set up the default mass tolerance, mass precision, and mass defect parameters that affect mass calculations and library searches.

To open the Mass Options page

1. From the Roadmap view of the Xcalibur home page, choose Tools > Configuration from the menu bar.

2. Click the Mass Options tab.

The Mass Options page of the Xcalibur Configuration dialog box opens ( Figure 75 ).

Figure 75. Mass Options page

To set up the mass options

1. Open the Mass Options page of the Thermo Xcalibur Configuration dialog box.

2. Specify a default value for mass tolerance as follows: a. Select the Use User Defined check box in the Default Mass Tolerance area.

The Mass Tolerance box becomes available.

b. Type a value from 0.1 to 50 000 in the Mass Tolerance box. c.

Select either mmu (millimass units) or ppm (parts per million) from the Units options.

140

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

Thermo Scientific

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

3. To specify a default value for mass precision, type a value from 0 to 5 in the Decimals box.

4. To specify the Default mass defects for lower values of mass, type a value from –2500 to

2500 in the first Defect box. Then, type a mass value from 0 to 10 000 in the first At

Mass box.

For example, enter a value of 50 in the Defect box for a value of 200 in the At Mass box.

5. To specify the Default mass defects for higher values of mass, type a value from –2500 to

2500 in the second Defect box. Then, type a mass value from 0 to 10 000 in the second

At Mass box.

For example, enter a value of 1000 in the Defect box for a value of 5000 in the At Mass box.

6. To save your settings, click OK.

Mass Options Page

Use the Mass Options page of the Xcalibur Configuration dialog box to select default values for Mass Tolerance, Mass Units, and Mass Precision. If you select the check box labeled Use

User Defined, you can specify the default values for the parameters in the Default Mass

Tolerance area. The data system uses these defaults throughout to acquire and display your data. If you do not select the Use User Defined check box, the application uses the values for mass options that are stored in the open raw data file in the data system.

(Use the Masses dialog boxes in the Processing Setup, Qual Browser, and Quan Browser windows to change the default settings for tolerance and precision in those windows.)

Table 9 describes the parameters on the Mass Options page of the Xcalibur Configuration

dialog box.

Table 9. Mass Options page parameter (Sheet 1 of 2)

Parameter

Default Mass Tolerance

Use User Defined

Description

Mass Tolerance

Makes the user-defined default settings for mass tolerance and mass units available.

Specifies the user-defined default setting for mass tolerance. To activate the user-defined settings, select the Use User Defined check box. Then, type a value from 0.1 to 50000.

The data system uses the default mass tolerance value only when you create a new method. It does not modify any existing methods

(for example, processing methods or Qual Browser layout files).

Qual Browser does not use the default mass tolerance value unless you delete the default layout file. The data system then creates a new default layout file with this mass tolerance value.

Xcalibur Data Acquisition and Processing User Guide

141

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Table 9. Mass Options page parameter (Sheet 2 of 2)

Parameter

Units

Description

Specifies the default units that are used in processing mass spectral data. To make the user-defined settings available, select the Use

User Defined check box. Then, select either the mmu option or the ppm option.

Default Mass Precision

Decimals Specifies the default number of decimal places (significant digits after the decimal point) that the data system uses to process mass spectral data. Specify from 0 to 5 decimal places. The number of decimal places applies throughout the data system.

Default Mass Defect

Specifies the parameters used in library searches so that you can correct for the differences between the actual masses and the nominal integer masses of the atoms in a molecule.

Assign a larger value (in millimass units) for the mass defect to larger molecules because, in general, they are composed of more atoms than smaller molecules; larger molecules need a larger correction factor to approximate the linear function that the data system uses to calculate masses. The values that you specify for the default mass defect are applied throughout the data system if no other value is available in the currently open method or raw data file.

Defect (mmu) Specifies default values (in millimass units) for the mass defect.

Specify a smaller value for lower mass ranges in the first box, and specify a larger value for higher mass ranges in the second box.

At Mass (amu)

The data system uses the default mass precision value only when you create a new method. It does not modify any existing methods

(for example, processing methods or Qual Browser layout files).

Qual Browser does not use the default mass precision value unless you delete the default layout file. The application then creates a new default layout file with this mass precision value.

Specifies the default masses at which the data system applies specified mass defect values to calculations of mass. Specify a smaller mass value in the first box, and specify a larger mass value in the second box.

142

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Selecting Default Labeling and Scaling Options

Use the Labeling and Scaling page of the Xcalibur Configuration dialog box to view or change default parameter values for labels and scales of the y axes in the spectrum and chromatogram views.

To open the Labeling and Scaling page

1. From the Roadmap view of the Xcalibur home page, choose Tools > Configuration from the menu bar.

2. Click the Labeling and Scaling tab.

The Labeling and Scaling page of the Xcalibur Configuration dialog box opens

( Figure 76

).

Figure 76. Labeling and Scaling page

Thermo Scientific

To specify labeling and scaling parameters

1. Open the Labeling and Scaling page of the Thermo Xcalibur Configuration dialog box.

2. In the Labeling Options area, to specify the Label for MS Data, select From Detector or

Custom from the corresponding list.

If you select Custom, type a label in the adjacent box.

3. To specify the Label for PDA/UV Data, select From Detector or Custom from the corresponding list.

If you select Custom, type a label in the adjacent box.

Xcalibur Data Acquisition and Processing User Guide

143

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

4. To specify the Label for Other Data Types (other than MS and PDA/UV), select From

Detector or Custom from the corresponding list.

If you select Custom, type a label in the adjacent box.

5. In the Use Absolute Scale area, select the data types to display on the y axis.

6. In the Retention Time Precision area, type the number of decimal places to include when reporting retention times.

7. To save the settings, click OK.

Labeling and Scaling Page

Use the Labeling and Scaling page of the Xcalibur Configuration dialog box to enter default values for labels and scales used to display data in the chromatogram and spectrum views.

Table 10

describes the parameters on the Labeling and Scaling page of the Xcalibur

Configuration dialog box.

Table 10. Labeling and Scaling page parameters (Sheet 1 of 2)

Parameter Description

Default Spectrum and Chromatogram Scaling

Labeling Options

Select default values for labeling and scaling in the displays of spectrum and chromatogram data. The values you specify as defaults are applied throughout the Xcalibur data system only if no other value is available in the currently open method or raw data file.

In Processing Setup and Quan Browser, for example, the data system uses the default values for labeling and scaling when you change the value for Detector Type. In Qual Browser, however, the data system uses the default values when you display a new spectrum, chromatogram, or map plot, or if the layout file (.lyt) in Qual Browser is unavailable.

144

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

Thermo Scientific

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Table 10. Labeling and Scaling page parameters (Sheet 2 of 2)

Parameter

Label for MS Data

Description

Specifies the default source of labels for the y axis of MS data.

Specify either custom (user-defined) labels or labels from the detector.

Label for PDA/UV

Data

Label for Other Data

Types

If you select custom labels, use the adjacent box to specify the label; for example, specify Intensity as a label.

Specifies the default source of labels for the y axis of PDA/UV data. Specify either custom (user-defined) labels or labels from the detector.

If you select custom labels, use the adjacent box to specify the label. For example, specify μAU as a label.

Specifies the default source of labels for the y axis of data types other than MS and PDA/UV. Specify either custom (user-defined) labels or labels from the detector.

If you select custom labels, use the adjacent box to specify the label. For example, specify mVolts as a label.

Use Absolute Scale

Selecting these check boxes specifies absolute scaling as the default for displays of spectrum and chromatogram data. The values you select are applied throughout the data system only if no other value is available in the currently open method or raw data file.

MS Data When you select this check box, the default (global) settings use absolute scaling with MS data.

PDA/UV Data When you select this check box, the default (global) settings use absolute scaling with PDA/UV data.

Other Data When you select this check box, the default (global) settings for data types other than MS and PDA/UV use absolute scaling.

Retention Time Precision

Decimals Specifies the number of decimal places to include when reporting retention times. The value can be from 1 to 5.

Xcalibur Data Acquisition and Processing User Guide

145

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Selecting Error Handling Options

Use the Intelligent Shutdown (Error Handling) page of the Xcalibur Configuration dialog box to define how the data system responds when an error occurs during data acquisition.

To open the Intelligent Shutdown (Error Handling) page

1. From the Roadmap view of the Xcalibur home page, choose Tools > Configuration from the menu bar.

2. Click the Intelligent Shutdown tab.

The Intelligent Shutdown (Error Handling) page of the Xcalibur Configuration dialog box opens (

Figure 77

).

Figure 77. Intelligent Shutdown (Error Handling page)

To change the error handling option

1. Open the Intelligent Shutdown (Error Handling) page of the Thermo Xcalibur

Configuration dialog box.

2. Select the following error handling option, Attempt to Stop the Devices and Pause the

Sequence.

3. To save the settings, click OK.

146

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Intelligent Shutdown (Error Handling) Page

Use the Intelligent Shutdown page of the Xcalibur Configuration dialog box to specify the response that the Xcalibur data system makes when an error occurs during data acquisition.

Table 11

describes the parameters on the Intelligent Shutdown page of the Xcalibur

Configuration dialog box.

Table 11. Intelligent Shutdown page parameters

Parameter

No Action

Attempt to Stop the

Devices and Pause the

Sequence

Attempt to Turn Off the Devices and Pause the Sequence

Description

Directs the data system to take no action and try to continue to the next sample when an error occurs during data acquisition.

Directs the data system to send a Stop command to all devices and pause the acquisition sequence before the next injection when an error occurs during data acquisition.

Directs the data system to send a Turn Off Device command to all devices and pause the acquisition sequence before the next injection when an error occurs during data acquisition.

Defining the Dataset List

As the administrator, use the Dataset List page of the Xcalibur Configuration dialog box to define or edit the list of dataset names that the user can choose from when selecting a dataset.

To open the Dataset List page

1. From the Roadmap view of the Xcalibur home page, choose Tools > Configuration from the menu bar.

2. Click the Dataset List tab.

The Dataset List page of the Xcalibur Configuration dialog box opens ( Figure 78 ).

Thermo Scientific Xcalibur Data Acquisition and Processing User Guide

147

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

Figure 78. Dataset List page

To define the list of dataset names

1. Open the Dataset List page of the Thermo Xcalibur Configuration dialog box.

2. To specify the name for the data system to use for a dataset, either select a name from the

Display Name list, or add a new name to the list.

3. To add new names to the Study List, do the following for each name that you want to add: a. Click Add New Study Name.

The Create New Dataset Name dialog box opens. b. Type a name in the box and click OK.

The new name appears in the Study List to the left.

Note If you change the display name to something besides Dataset, the data system renames the parameters on this page to reflect the change.

4. To delete a name from the list, select the name in the Study List and click Remove

Selected Study Name.

5. To specify whether a blank study name is a valid selection, do the following:

• Select the Blank Dataset Name is a Valid Selection check box to allow a user to select a blank name when asked to select a dataset in the Dataset Name Selector dialog box.

• Clear this check box to require the user to select a valid dataset.

148

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

Thermo Scientific

7

Configuring and Managing the Data System

Configuring the Xcalibur Data System

6. To specify whether the selection is restricted to the entered names, do the following:

• Select the Selection Restricted to Entered Names check box to specify that only the names listed in the Study List appear in the Dataset Name Selector dialog box.

• Clear this check box to specify that the names listed in the Study List as well as a those obtained from the database appear in the Dataset Name Selector dialog box.

7. To specify the maximum number of names to display in the Dataset Name Selector dialog box, type a number in the Maximum Number of Names to Display box.

8. To save the settings, click OK.

Dataset List Page

Use the Dataset List page of the Xcalibur Configuration dialog box to define or edit the list of dataset names available when the user chooses a dataset. Only the administrator can access this feature.

Note The names of several parameters on this page change when you select a new Display

Name. The default Display Name is Dataset. When you change the Display Name, the following four parameters are renamed: Dataset List, Add New Dataset Name, Remove

Selected Dataset Name, and Blank Dataset Name Is a Valid Selection. For example, if you change the Display Name from Dataset to Study, the parameter Dataset List changes to

Study List.

Table 12

describes the parameters on the Dataset List page of the Xcalibur Configuration dialog box.

Table 12. Dataset List page parameters (Sheet 1 of 2)

Parameter

Dataset List

Display Name

Description

Lists the dataset names that are stored in the registry. To add a new dataset name to the list, click Add New Dataset Name.

Specifies the name that the data system uses for a dataset. You can type a new name, or you can select a new name from the list. The options are Dataset, Study, and Job.

Add New Dataset

Name

Remove Selected

Dataset Name

When you change the Display Name, the parameters on this page and elsewhere are renamed to reflect the change. For example, if you change the Display Name from Dataset to Study, the Dataset

List parameter changes to Study List.

Opens the Create a New Dataset Name dialog box, where you can type a new dataset name. The data system adds the new dataset name to the Dataset List and the registry.

Removes the currently selected name from the Dataset List and from the registry but action does not remove the name from the database if the name has already been used.

Xcalibur Data Acquisition and Processing User Guide

149

7

Configuring and Managing the Data System

Converting File Formats

Table 12. Dataset List page parameters (Sheet 2 of 2)

Parameter

Blank Dataset Name

Is a Valid Selection

Description

When you select this check box, you can select a blank name for a dataset.

Selection Restricted to

Entered Names

When you clear this check box, you must select a valid dataset.

When you select this check box, the Dataset Name Selector dialog box lists only the names in the Dataset List.

Maximum Number of

Names to Display

Clear to show the names listed in the Dataset List as well as a those obtained from the database in the Dataset Name Selector dialog box.

Specifies the maximum number of dataset names that are shown in the Dataset Name Selector dialog box.

In the Dataset Name Selector dialog box, the dataset names from the Dataset List are shown first. Then, if allowed, the most recent dataset names stored in the database are used to fill the list until the maximum number of entries is shown.

Converting File Formats

Use the Thermo File Converter application to convert data files from a format used in another data system to the Xcalibur RAW file type or to convert Xcalibur RAW files to other file types.

For more information, see Thermo File Converter Application .

To convert data files from one file format to another with the Thermo File Converter application

1. Choose Tools > File Converter from the Roadmap view of the home page window.

The Thermo File Converter Application opens (

Figure 79 ).

150

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

Figure 79. Thermo File Converter application

7

Configuring and Managing the Data System

Converting File Formats

Thermo Scientific

2. To specify the source data type of the files you want to convert, select from the Source

Data Type list in the Conversion Source area.

The selections in the Source Data Type list are RAW, DAT, MS, CDF, and SPA. You can only batch process files with one source data type and one destination data type at a time.

You can perform other data type conversions in separate batches.

3. To select the files to be converted, click Browse and select the folder that contains the files.

The files appear in the Conversion Source list. The Xcalibur data system displays the File

Name, Type, Size, and Date.

Xcalibur Data Acquisition and Processing User Guide

151

7

Configuring and Managing the Data System

Converting File Formats

4. Create a list of files to convert using one of the following options:

• To convert all of the files in the Conversion Source list, click Select All, and then click Add Job(s).

All of the files appear on the Jobs page in the Conversion Destination area at the bottom.

• To convert a single file from the Conversion Source list, select the file and then click

Add Job(s).

• To delete a file that appears in the Conversion Source list, select the file and then click

Clear Selection.

5. To specify the destination data type of the files that you want to convert, select a destination from the Destination Data Type list in the Conversion Destination area.

6. To select a destination folder, click Browse to search for a folder to hold the converted files.

The source files remain in their original directories.

7. To start the file conversion using batch processing of the files on the Jobs page, click

Convert.

You can monitor the conversion progress by clicking the Status tab in the Conversion

Destination area.

The application continues file conversion processing until all files are converted and stored in the specified destination folder.

8. To convert a different source data type, click Clear Selection to clear all files displayed in the Conversion Source list. Then repeat

step 2

through

step 7

for the other source data type.

9. To close the File Converter application, click Close.

152

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

7

Configuring and Managing the Data System

Checking Disk Space

Checking Disk Space

Use the Disk Space dialog box to determine how much available disk space you have on a disk drive.

To open the Disk Space dialog box

Do one of the following:

• From the home page menu, choose Actions > Check Disk Space.

–or–

• In the Sequence Editor toolbar, click the Disk Space icon, .

The Disk Space dialog box opens (

Figure 80

).

Figure 80. Disk Space dialog box

Thermo Scientific Xcalibur Data Acquisition and Processing User Guide

153

7

Configuring and Managing the Data System

Checking Disk Space

To check the disk space for a particular directory

1. Click Directory.

The Select Directory dialog box opens (

Figure 81

).

Figure 81. Select Directory dialog box

2. In the Drives list, select the drive of interest.

3. Click Disk Space.

Information about the disk space appears on the right (

Figure 82

).

Figure 82. Select Directory dialog box with information about the disk space for drive C

154

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

7

Configuring and Managing the Data System

Confirming the Properties of Thermo Foundation Security Service

Confirming the Properties of Thermo Foundation Security Service

The authorization and auditing functions of an application such as the Xcalibur data system installed on the Thermo Foundation platform rely on two system services: the Thermo

Foundation Security Service and the Thermo Foundation Database Service. These services are installed when you install the application software. They automatically start whenever a user restarts a workstation.

The main function of the Thermo Foundation Security Service, which is installed with the

Xcalibur data system, is user authentication. If certain events require authentication, the

Thermo Foundation Security Service verifies the user names and passwords entered.

Note For information related to the Thermo Foundation Database Service, refer to the

Thermo Foundation Administrator Guide.

To confirm that the properties of the Thermo Foundation Security Service are set correctly

1. Open the Services window as follows: a. From the taskbar, choose Start > Control Panel.

b. In the Adjust Your Computer Settings window, in the View By list, select Category.

Then, choose System and Security > Administrative Tools and double-click

Services.

2. Confirm the properties for the service as follows: a. Right-click Thermo Foundation Security Service and choose Properties from the shortcut menu.

The Thermo Foundation Security Service Properties dialog box opens ( Figure 83

).

Thermo Scientific Xcalibur Data Acquisition and Processing User Guide

155

7

Configuring and Managing the Data System

Confirming the Properties of Thermo Foundation Security Service

Figure 83. General page b. On the General page, in the Startup Type list, select Automatic.

c.

Confirm that Service Status reads Started.

d. Click the Log On tab to display the Log On page ( Figure 84 ).

Figure 84. Log On page e.

Under Log On As, select the Local System Account option. f.

Select the Allow Service to Interact with Desktop check box.

g. Click OK to close the dialog box.

156

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

7

Configuring and Managing the Data System

Setting Up the Instrument Configuration in the Foundation Platform

Setting Up the Instrument Configuration in the Foundation Platform

To control your LC/MS or GC/MS system from the Xcalibur data system, you must first set up the instrument configuration in the Thermo Foundation™ platform. The instrument configuration includes the chromatography devices, the mass spectrometer, and the specific hardware options for these devices.

To set up the instrument configuration for your system, follow these procedures:

Adding Devices to the Foundation Instrument Configuration

Removing Devices from the Foundation Instrument Configuration

Adding Devices to the Foundation Instrument Configuration

To add hardware devices to the Foundation instrument configuration

1. Choose Start > Programs (or All > Programs) > Thermo Foundation x.x > Instrument

Configuration, where x.x is the version.

Note The data system computer must have compatible versions of the Foundation platform and the Xcalibur data system.

The Foundation Instrument Configuration dialog box opens (

Figure 85 ).

Figure 85. Foundation Instrument Configuration window

Thermo Scientific

2. To add devices to the instrument configuration, do the following for each device: a. In the Device Types list, select All.

The Available Devices area lists the installed device drivers. If you do not see the device that you want to configure, you might need to install the device driver

(instrument control software).

Xcalibur Data Acquisition and Processing User Guide

157

7

Configuring and Managing the Data System

Setting Up the Instrument Configuration in the Foundation Platform b. In the Available Devices area, select the icon for the device you want to add.

The device icon depresses to indicate that it is selected.

c.

To add the device to the Configured Devices area, click Add.

A copy of the selected device icon appears in the Configured Devices area.

Tip To copy a device icon to the Configured Devices area, you can also double-click the device icon in the Available Devices area.

3. To specify the configuration options for the devices in the Configured Devices area, do the following for each device: a. In the Configured Devices area, select the device icon for the device that you want to configure.

The device icon depresses to indicate that it is selected.

b. To configure the selected device, click Configure.

The DeviceName Configuration dialog box opens (the device name corresponds to the selected device).

Tip To open the DeviceName Configuration dialog box for a device, you can also double-click the device icon in the Configured Devices area.

c.

Enter the configuration information for the device.

Tip For information about the configuration options for the current device, refer to the Help for the device.

d. To save the settings and close the DeviceName Configuration dialog box, click OK.

The Foundation Instrument Configuration dialog box reappears.

4. To save the instrument configuration settings and close the Foundation platform, click

Done.

158

Xcalibur Data Acquisition and Processing User Guide Thermo Scientific

7

Configuring and Managing the Data System

Setting Up the Instrument Configuration in the Foundation Platform

Removing Devices from the Foundation Instrument Configuration

To remove hardware devices from the Foundation instrument configuration

1. Choose Start > Programs > Thermo Foundation x.x > Instrument Configuration, where x.x is the version.

The Foundation Instrument Configuration window opens (see

Figure 85 on page 157

).

2. To remove a device from the instrument configuration, do the following: a. In the Configured Devices area, select the device icon that represents the device that you want to remove.

The device icon depresses to indicate that it is selected.

b. Click Remove. c.

To save the settings and close the DeviceName Configuration dialog box, click OK.

The Foundation Instrument Configuration window reappears.

3. To save the instrument configuration settings and close the window, click Done.

Thermo Scientific Xcalibur Data Acquisition and Processing User Guide

159

Was this manual useful for you? yes no
Thank you for your participation!

* Your assessment is very important for improving the work of artificial intelligence, which forms the content of this project

Download PDF

advertisement

Table of contents