Tridium NiagaraAX
Manuals and User Guides for Tridium NiagaraAX. We found 1 manuals for free downloads User Guide
NiagaraAX is a software framework that enables the integration of control systems, devices, and applications. It can be used to manage a variety of building automation systems, including HVAC, lighting, security, and energy management. NiagaraAX provides a comprehensive set of tools and features for building and managing control systems, including a graphical user interface (GUI), a data and control model, and a driver architecture.
Key Features
Control systems integration
Graphical user interface (GUI)
Data and control model
Driver architecture
Pages: 530 Tridium NiagaraAX User Guide
Brand: Tridium Category: Software Size: 11 MB
Languages: English
Table of contents
- 3 Contents
- 21 Preface
- 21 Document Change Log
- 23 About NiagaraAX Framework
- 23 Well designed
- 24 The Niagara Framework solution
- 24 About control systems integration
- 25 About Java
- 26 About Virtual Machines
- 26 About common networking and Internet protocols
- 26 About programming for non-programmers
- 27 About embedded systems capabilities
- 27 About distributed systems capabilities
- 27 About component software design
- 28 About Niagara software architecture
- 29 About Baja
- 30 About APIs
- 30 javax.baja
- 30 com.tridium
- 30 About Niagara building blocks
- 31 About modules
- 31 About module characteristics
- 32 About jar files
- 32 About module versions
- 33 About module directory structure
- 33 About module benefits
- 34 About components
- 35 About slots
- 35 Slot type
- 36 Slot name
- 36 Slot definition
- 36 Flags
- 36 Facets
- 36 About master/slave components
- 37 About point components
- 38 About palettes
- 38 About presentation
- 39 About presentation modules
- 40 About presentation xml (px)
- 40 About presentation design philosophy
- 41 About presentation media
- 42 About stations
- 43 About BOG files
- 43 About ORDs
- 44 About views
- 45 About lexicons
- 47 About Workbench
- 47 Tour of the Workbench GUI
- 47 About Workbench window controls
- 48 About the side bar panes
- 49 About side bars
- 49 About the side bar title bar
- 50 Types of side bars
- 50 About the bookmark side bar
- 51 About the help side bar
- 52 About the nav side bar
- 53 Types of nodes in the nav side bar tree
- 54 About the nav side bar toolbar
- 55 About the palette side bar
- 55 About the palette side bar toolbar
- 56 About the jobs side bar
- 56 About the bound ords side bar
- 57 About the widget tree side bar
- 57 About the properties side bar
- 58 About the view pane
- 59 About the console
- 60 About the menu bar
- 60 About the toolbar
- 61 About the locator bar
- 62 About the view selector
- 62 Types of popup menus
- 63 About the nav side bar popup menus
- 64 About the wire sheet popup menu
- 64 About the property sheet popup menu
- 65 Px Editor popup menu
- 66 Customizing the Workbench environment
- 66 Creating Additional Windows
- 67 Creating tabs in the view pane
- 68 Workbench options
- 68 Alarm console options
- 69 Alarm portal options
- 69 Bajadoc options
- 70 General Workbench options
- 70 Text editor options
- 70 Wiresheet options
- 71 Lexicon options
- 73 Data and Control Model
- 73 About control points
- 74 Types of control points
- 74 Other control components
- 74 About data value categories
- 75 About point types
- 75 About point Out
- 76 About point inputs
- 76 About point actions
- 77 About override actions
- 78 About set (Fallback) action
- 79 Modifying default actions
- 80 About point facets
- 81 Accessing and editing facets
- 81 Facets importance for Enum points
- 83 Effect of facets on point actions
- 83 Effect of facets on proxy points
- 84 About point extensions
- 84 Extension process overview
- 85 Types of point extensions
- 85 About the proxy extension
- 86 About control extensions
- 86 Types of control extensions
- 87 About alarm extensions
- 88 Types of alarm extensions
- 89 About history extensions
- 89 Types of history extensions
- 90 About control triggers
- 91 How triggers are used
- 91 About related objects
- 91 About point status
- 92 Types of status flags
- 93 Priority of status indication
- 93 How status flags are set
- 93 Simple control point status
- 94 Propagate Flags status option (linked Math and Logic objects)
- 95 Proxy point status
- 96 About “isValid” status check
- 96 About proxy points
- 96 Location of proxy points
- 97 How proxy points are made
- 101 Proxy points versus simple control points
- 102 ProxyExt properties
- 103 About writable points
- 103 About the priority scheme
- 103 Priority input scan
- 104 Priority linking rules
- 104 Priority level conventions
- 105 About minimum On and Off times
- 105 About composites
- 106 Some composite examples
- 106 Point-level composite
- 108 Folder-level composite
- 110 Composite issues
- 111 Driver architecture
- 111 What are networks?
- 111 Where are networks located?
- 112 About Network architecture
- 112 Network component hierarchy
- 113 About network components
- 114 About device components
- 114 About device extensions
- 115 About the Driver Manager
- 115 Driver Manager New and Edit
- 116 New
- 116 Edit
- 117 Common network components
- 117 Network status properties
- 117 Status
- 117 Enabled
- 118 Health
- 118 About network Alarm Source Info
- 118 About Monitor
- 119 Monitor properties
- 120 Monitor considerations by driver
- 120 About Tuning Policies
- 121 Tuning Policy properties
- 122 Tuning Policy considerations by driver
- 122 About poll components
- 123 Poll scheduler operation
- 124 Poll component properties
- 125 Additional network components
- 125 About communication components
- 126 About driver-specific properties
- 127 About the Device Manager
- 127 Device New Folder and New
- 128 New Folder
- 128 All Descendants
- 129 New
- 129 Device Edit
- 130 Edit
- 130 Device “gang” edits
- 131 About Device Discover, Add and Match (Learn Process)
- 131 About Learn toggle
- 132 Discover
- 133 Add
- 133 Match (Device)
- 135 Manager table features
- 135 Table options menu
- 135 Column resorting
- 136 Common device components
- 136 Device status properties
- 136 Status
- 137 Enabled
- 137 Health
- 137 Device Alarm Source Info
- 137 Device address properties
- 138 Poll Frequency
- 138 Driver-specific device slots
- 138 Types of device extensions
- 139 About the Points extension
- 140 About the Histories extension
- 141 About the Retry Trigger
- 141 About the Alarms extension
- 141 Alarms extension properties
- 142 About the Schedules extension
- 143 About the Point Manager
- 144 Points New Folder and New
- 145 New Folder
- 146 New
- 147 Point Edit
- 147 Edit
- 148 Proxy point “gang” edits
- 148 About Point Discover, Add and Match (Learn Process)
- 149 Discover
- 151 Add
- 152 Match
- 153 About other Points views
- 154 About Histories extension views
- 154 History Import Manager
- 155 History Import New
- 155 History Import Edit
- 157 About History Import Discover, Add and Match (Learn Process)
- 159 History Export Manager
- 161 History Export New
- 161 History Export Edit
- 162 About History Export Discover, Add and Match (Learn Process)
- 164 About Schedules extension views
- 165 Schedule Import Manager
- 166 Schedule Import New
- 166 Schedule Import Edit
- 168 About Schedule Import Discover, Add and Match (Learn Process)
- 170 Schedule Export Manager
- 171 About the Niagara Network
- 171 NiagaraNetwork component notes
- 172 About the Fox Service
- 173 About History Policies
- 176 Niagara Station Manager notes
- 176 Station Learn and Discover notes
- 177 Station Add notes
- 178 NiagaraStation component notes
- 178 About station status properties
- 178 About client connection properties
- 178 About server connection properties
- 179 About the Bql Query Builder
- 179 About Bql Query Find filters
- 180 About Bql Query Match filters
- 181 About Bql Query Save, Load, and Edit
- 183 Niagara proxy point notes
- 183 Proxy of a proxy, other candidates
- 183 Link control and Niagara proxy points
- 184 Station Alarms notes
- 185 Station Schedules import/export notes
- 185 Niagara schedule import/export default configuration
- 185 Schedule Export Edit
- 189 Field Bus Integrations
- 189 Common field bus concepts
- 189 Driver architecture framework
- 189 Learn versus New devices and points
- 191 About Histories
- 192 Types of History Services
- 192 About the history service
- 193 About the history extension manager
- 193 About history service property sheet
- 194 History service actions
- 194 About the audit history service
- 195 About the log history service
- 196 Types of history space views
- 197 About the chart builder view
- 198 About the database maintenance view
- 199 About the nav container view
- 200 Types of history views
- 200 About the history chart view
- 201 About the collection table view
- 202 About the history table view
- 203 About the history summary view
- 204 About the history editor view
- 205 About the history process
- 207 Add history extensions to a component
- 207 Configure history extensions
- 209 About history names
- 210 Archiving
- 211 About editing history data
- 213 About alarms
- 213 Overview of the alarming process
- 214 About alarm sources
- 214 About alarm extensions and components
- 215 About alarm extension properties
- 218 About the alarm service
- 219 About memory alarm service
- 220 Types of alarm service views
- 220 About alarm service property sheet
- 221 About alarm extension manager
- 223 About alarm database maintenance
- 225 About the alarm class summary view
- 226 About alarm class
- 227 About alarm class properties
- 228 About alarm class mapping
- 230 Types of alarm recipients
- 230 About the console recipient
- 231 About the alarm console
- 233 About the station recipient
- 234 About the email recipient
- 235 About the lineprinter recipient
- 239 About Presentation XML (Px)
- 240 About Px views
- 241 Px views as slot properties
- 241 About the New Px View wizard
- 242 About Px files
- 243 Shared Px files
- 244 About Px viewer
- 245 About Px Editor
- 245 About the Px Editor Canvas
- 246 View Source XML dialog box
- 247 About Widgets
- 248 Widget layout
- 249 Types of panes
- 250 Widget painting
- 250 Commands
- 251 About widget properties
- 252 Animating Graphics
- 252 Data binding
- 253 Types of bindings
- 254 Types of binding properties
- 255 About bound label bindings
- 256 About value bindings
- 256 Types of Converters
- 256 About spectrum bindings
- 257 About setpoint bindings
- 258 About increment setpoint bindings
- 258 About spectrum setpoint bindings
- 258 About action bindings
- 259 About table bindings
- 259 About field editor bindings
- 260 Relative and absolute bindings
- 260 About Px target media
- 261 About Web Profiles
- 262 Default Wb Web Profile
- 262 Basic Wb Web Profile
- 263 Default Hx Profile
- 264 Basic Hx Profile
- 264 Px Editor workflow
- 264 About the Make Widget wizard
- 266 Make Widget wizard: examples
- 266 Create a bound label widget
- 270 Create a widget using a palette kit module
- 273 Create a widget with a Workbench view
- 276 Create a widget using a component properties option
- 279 Create an action widget
- 281 Create a Time Plot widget
- 284 Create a Chart widget
- 286 About the Nav file
- 287 Nav file elements
- 288 About the Nav File Editor
- 289 Nav File Editor source objects
- 290 Nav File Editor result tree
- 290 Nav File Editor buttons
- 293 About Security
- 293 Security model overview
- 294 Categories and security
- 295 Users and security
- 296 About built-in users
- 296 About authentication
- 297 Permissions and security
- 298 About permission levels
- 298 Component permission levels
- 299 File permissions
- 300 History permissions
- 300 UserService security notes
- 300 About user audits
- 301 AuditHistoryService configuration
- 301 AuditHistory content
- 302 Multi-station security notes
- 302 Domain-wide cookies authentication
- 303 To configure domain-wide cookies authentication
- 304 UserService
- 304 UserService properties
- 305 UserManager
- 306 User
- 307 Lockout notes
- 308 PermissionsBrowser
- 308 Show Configured
- 309 Permissions abbreviations
- 309 Access permissions
- 310 CategoryService
- 311 CategoryManager
- 312 Category properties
- 312 Category caveats
- 312 CategoryBrowser
- 313 Show Configured
- 314 CategorySheet
- 315 About Scheduling
- 315 About the scheduling model
- 315 Schedule component categories
- 316 Schedule component views
- 316 Refresh
- 317 Save
- 317 Schedule component links
- 317 Weekly schedule links
- 317 Trigger schedule links
- 318 Schedule special events
- 318 Schedule exports and imports (master/slave)
- 319 About weekly schedules
- 319 Types of weekly schedule components
- 319 About the BooleanSchedule
- 320 About the EnumSchedule
- 320 About the NumericSchedule
- 320 About the StringSchedule
- 320 Weekly schedule output processing
- 320 Out slot
- 320 Out Source slot
- 321 Next Time and Next Value slots
- 321 Weekly Scheduler view
- 321 Weekly Schedule
- 323 Special Events
- 327 Properties
- 329 Summary
- 331 About calendar schedules (holidays)
- 331 CalendarSchedule Usage
- 332 Calendar Scheduler view
- 332 Adding calendar events
- 333 Right-click menus and other controls
- 334 Calendar day selections
- 334 Date selection notes
- 334 Date range selection notes
- 335 Week and day selection notes
- 336 Custom selection notes
- 336 CalendarSchedule slots and other notes
- 337 About trigger schedules
- 337 Trigger Scheduler view
- 338 Adding trigger events
- 339 Adding trigger event times
- 340 Right-click menus and other controls
- 341 TriggerSchedule slots and other notes
- 341 Trigger Missed slot
- 342 Using schedules
- 342 Adding a schedule or calendar
- 342 To add a component from the schedule palette
- 342 To copy an existing, saved (configured) schedule component
- 343 Configuring schedules and calendars
- 343 Configuring weekly schedules
- 343 To configure a weekly schedule
- 343 To configure a weekly schedule’s properties
- 343 To configure the weekly (normal) schedule
- 344 To add and configure special events
- 344 To review a weekly schedule’s configuration
- 344 Configuring calendar schedules
- 344 To configure a calendar schedule
- 345 Configuring trigger schedules
- 345 To configure a trigger schedule
- 346 Linking schedules
- 346 Linking weekly schedules
- 346 To link a weekly schedule using the wire sheet
- 346 To link a weekly schedule using the Nav tree
- 347 Linking trigger schedules
- 347 To link a trigger schedule using the wire sheet
- 347 To link a trigger schedule using the Nav tree
- 348 Importing schedules
- 348 Importing NiagaraAX schedules or Bacnet Schedules
- 348 To import a NiagaraAX schedule or BACnet Schedule or Calendar
- 349 Types of Workbench tools
- 349 Alarm portal
- 351 Bacnet service
- 352 Lexicon editor
- 352 Lexicon Report
- 353 Lexicon Editor
- 353 Lonworks service manager
- 353 Credentials manager
- 354 New module wizard
- 355 New station wizard
- 355 License request dialog box
- 355 Workbench service manager
- 357 Performing Workbench tasks
- 357 Starting and exiting Workbench
- 357 To start Workbench
- 357 To close a Workbench window
- 358 To exit Workbench
- 358 Getting started with stations
- 358 To open a platform using Workbench GUI
- 359 To connect to a platform using Workbench GUI
- 359 To close a platform using Workbench
- 359 To disconnect from a platform using Workbench
- 360 To start a station using Workbench
- 360 To stop a station using Workbench
- 361 To open a station
- 361 To close a station using Workbench
- 361 To connect to a station using Workbench
- 362 To disconnect from a station
- 362 Using the side bar pane
- 362 To open the side bar pane
- 363 To open the bookmarks side bar
- 363 To open the help side bar
- 363 To open the nav side bar
- 363 To open the palette side bar
- 363 To close a side bar
- 363 To close the side bar pane
- 363 To vertically resize a side bar
- 363 To restore a side bar to a previous size
- 364 To maximize a side bar:
- 364 Using bookmarks
- 364 To add a bookmark
- 364 To manage bookmarks
- 365 To edit a bookmark
- 365 To remove a bookmark
- 365 Using the help side bar
- 365 To search for topics in the help side bar:
- 366 Using the nav side bar (tree)
- 366 To refresh a nav side bar tree node
- 366 To Go Into a nav side bar tree node
- 367 Using the jobs side bar
- 367 To view job details
- 367 To cancel a job from the jobs side bar
- 367 To dismiss a job
- 367 Using the palette side bar
- 368 To open a palette
- 368 To close a palette
- 368 Using the view pane
- 368 Editing components
- 369 Selecting a component
- 369 To select a component
- 369 To select multiple components in the nav tree
- 369 To select a multiple components in the wire sheet
- 369 Viewing a component
- 370 To select a component view
- 370 To reorder components (in a component container)
- 370 To create a composite view
- 371 Editing component data
- 372 To add a new component (property sheet, nav side bar, or wire sheet view)
- 372 To delete a component (property sheet, nav side bar, or wire sheet view)
- 372 To rename a component (property sheet, nav side bar, or wire sheet view, slot sheet)
- 373 To duplicate a component (property sheet, nav side bar, or wire sheet view)
- 373 To paste a component (property sheet, nav side bar, or wire sheet view)
- 373 To drag a component to the property sheet, nav side bar, or wire sheet (left-click method)
- 373 To drag a component to the property sheet, nav side bar, or wire sheet (right-click method)
- 374 Using the property sheet
- 374 To add an extension to a component property sheet view:
- 374 To add a component facet:
- 375 To remove a component facet:
- 375 Using the wire sheet
- 375 To pin a slot
- 375 To paste a component onto the wire sheet
- 376 To drag a component to the wire sheet (left-click method)
- 376 To drag a component to the wire sheet (right-click method)
- 376 Using the slot sheet
- 376 To add a new slot
- 377 To delete a slot
- 377 Using the link sheet
- 377 To delete a link using the link sheet view
- 377 To edit a link using the link sheet view
- 378 Using alarms
- 378 Creating alarms
- 378 To set up alarm conditions for a control point
- 378 Routing alarms
- 378 To add an alarm class to the alarm service
- 379 To add a console recipient to the alarm service
- 379 To add a station recipient to the alarm service
- 379 To add an email recipient to the alarm service
- 380 Managing alarms
- 380 To acknowledge alarms from the alarm console view
- 380 To acknowledge alarms from the alarm portal
- 381 To delete old alarm records
- 382 Using the Px Editor
- 382 Making widgets
- 382 To make a new widget using the Make New Widget wizard:
- 383 Binding widgets
- 383 To bind a value to a widget
- 383 Editing widget properties
- 383 To edit a widget property
- 384 Animating widget properties
- 384 To animate a widget property
- 384 Using the Nav File Editor
- 385 Creating a new Nav file
- 385 To create a new nav file:
- 385 To delete nav file (Delete Key):
- 385 To delete nav file (popup menu):
- 385 To rename a nav file:
- 386 Editing a Nav file in the Nav File Editor
- 386 To open a nav file in the Nav File Editor:
- 386 To add nodes to a nav file using the Nav File Editor:
- 387 To delete nodes from a nav file:
- 387 To edit the node hierarchy (tree structure) in a nav file:
- 387 To edit nodes in a nav file:
- 389 Component Guides
- 389 Component Reference Summary
- 390 Components in alarm module
- 390 alarm-AlarmClass
- 390 alarm-AlarmConsoleOptions
- 390 alarm-AlarmPortalOptions
- 391 alarm-AlarmService
- 391 alarm-AlarmSourceExt
- 391 AckAlarm
- 391 SilenceAlarm
- 391 alarm-AlarmSourceInfo
- 391 alarm-BooleanChangeOfStateAlarmExt
- 392 alarm-BooleanCommandFailureAlarmExt
- 392 alarm-ConsoleRecipient
- 392 Scan Unacked Alarms
- 392 Actions
- 392 alarm-FaultAlgorithm
- 393 alarm-EnumChangeOfStateAlarmExt
- 393 alarm-EnumCommandFailureAlarmExt
- 393 alarm-LinePrinterRecipient
- 393 alarm-MemoryAlarmService
- 394 alarm-OffnormalAlgorithm
- 394 alarm-OutOfRangeAlarmExt
- 394 alarm-StationRecipient
- 394 alarm-StatusAlarmExt
- 394 Components in backup module
- 394 backup-BackupService
- 395 BackupService configuration
- 395 Components in baja module
- 396 baja-Category
- 396 baja-CategoryService
- 396 baja-Component
- 397 Using Containers
- 397 baja-DataFile
- 397 baja-Directory
- 397 baja-FileSystem
- 397 baja-Folder
- 397 baja-Format
- 398 baja-IpHost
- 398 baja-Job
- 399 baja-StationSaveJob
- 399 baja-JobService
- 399 baja-LocalHost
- 399 baja-Module
- 399 baja-ModuleSpace
- 400 baja-Permissions
- 400 baja-PermissionsMap
- 400 baja-PxView
- 400 baja-ServiceContainer
- 400 baja-Spy
- 400 baja-Station
- 400 Station Save
- 400 baja-UnrestrictedFolder
- 401 baja-User
- 401 baja-UserService
- 401 baja-Vector
- 401 baja-WsTextBlock
- 401 baja-ZipFile
- 401 Components in bajaui module
- 402 bajaui-BorderPane
- 402 bajaui-Bookmark
- 402 bajaui-BoundTable
- 402 bajaui-Button
- 403 bajaui-CanvasPane
- 403 bajaui-CheckBox
- 403 bajaui-ConstrainedPane
- 403 bajaui-EdgePane
- 403 bajaui-Ellipse
- 403 bajaui-ExpandablePane
- 403 bajaui-FlowPane
- 403 bajaui-GridPane
- 404 bajaui-HyperlinkLabel
- 404 bajaui-Label
- 404 bajaui-Line
- 404 bajaui-RadioButton
- 404 bajaui-Rect
- 404 bajaui-Path
- 405 bajaui-Polygon
- 405 bajaui-ScrollPane
- 405 bajaui-Separator
- 405 bajaui-Slider
- 405 bajaui-SplitPane
- 405 bajaui-TabbedPane
- 405 bajaui-TextEditorOptions
- 407 bajaui-ToggleButton
- 407 bajaui-ValueBinding
- 407 Components in chart module
- 407 chart-BarChart
- 407 chart-ChartCanvas
- 407 chart-ChartHeader
- 407 chart-ChartPane
- 407 chart-DefaultChartLegend
- 407 chart-LineChart
- 408 Components in control module
- 408 control-BooleanPoint
- 408 control-BooleanWritable
- 408 control-DiscreteTotalizerExt
- 408 control-EnumPoint
- 409 control-EnumWritable
- 409 control-NullProxyExt
- 409 control-NumericPoint
- 409 control-NumericTotalizerExt
- 409 control-NumericWritable
- 409 control-StringPoint
- 410 control-StringWritable
- 410 control-TimeTrigger
- 410 Components in converters module
- 410 converters-EnumToSimpleMap
- 410 Components in crypto module
- 410 crypto-CryptoService
- 410 crypto-SslProvider
- 410 Components in devkit module
- 410 devkit-LexiconOptions
- 411 Components in driver module
- 411 driver-ConfigRule
- 411 driver-DriverContainer
- 411 driver-HistoryNetworkExt
- 411 driver-PingMonitor
- 412 driver-SendTimer
- 412 driver-SendTimes
- 412 driver-TuningPolicy
- 412 driver-TuningPolicyMap
- 412 Components in email module
- 412 email-Email
- 413 email-EmailRecipient
- 413 Actions
- 413 RouteAlarm
- 413 email-EmailService
- 413 email-IncomingAccount
- 413 email-OutgoingAccount
- 413 Components in file module
- 414 file-ApplicationFile
- 414 file-AudioFile
- 414 file-BajadocFile
- 414 file-BogFile
- 414 file-BogScheme
- 415 file-BogSpace
- 415 file-CFile
- 415 file-CssFile
- 415 file-ExcelFile
- 415 file-GifFile
- 415 file-HtmlFile
- 415 file-ImageFile
- 415 file-JavaFile
- 415 file-JpegFile
- 415 file-NavFile
- 415 file-PaletteFile
- 416 file-PdfFile
- 416 file-PngFile
- 416 file-PowerPointFile
- 416 file-PrintFile
- 416 file-PxFile
- 416 file-TextFile
- 416 file-VideoFile
- 416 file-VisioFile
- 416 file-WordFile
- 416 file-XmlFile
- 416 Components in fox module
- 417 fox-FoxClientConnection
- 417 Actions
- 417 fox-FoxFileSpace
- 417 fox-FoxServerConnection
- 417 Actions
- 417 fox-FoxService
- 417 fox-FoxSession
- 417 fox-ServerConnections
- 418 Components in gx module
- 418 gx-Brush
- 418 Components in help module
- 418 help-BajadocOptions
- 418 Components in history module
- 419 history-AuditRecord
- 419 history-AuditHistoryService
- 419 history-BooleanCovHistoryExt
- 419 history-BooleanIntervalHistoryExt
- 419 history-ConfigRule
- 420 history-ConfigRules
- 420 history-CovAlgorithm
- 420 history-EnumCovHistoryExt
- 420 history-EnumIntervalHistoryExt
- 420 history-FoxHistory
- 420 history-FoxHistorySpace
- 420 history-HistoryConfig
- 420 history-HistoryDevice
- 421 history-HistoryEditorOptions
- 421 history-HistoryId
- 421 history-HistoryService
- 421 CloseUnusedHistories
- 421 FlushHistories
- 421 history-IntervalAlgorithm
- 421 history-LocalDatabaseConfig
- 421 history-LogHistoryService
- 422 history-NumericCovAlgorithm
- 422 history-NumericCovHistoryExt
- 422 history-NumericIntervalAlgorithm
- 422 Actions
- 422 Collect
- 422 CommenceCollection
- 422 history-NumericIntervalHistoryExt
- 422 Actions
- 423 Collect
- 423 CommenceCollection
- 423 history-StringCovHistoryExt
- 423 history-StringIntervalHistoryExt
- 423 Components in kitPx module
- 423 kitPx-ActionBinding
- 424 kitPx-AnalogMeter
- 424 kitPx-Bargraph
- 424 kitPx-BoundLabelBinding
- 424 kitPx-BoundLabel
- 424 kitPx-GenericFieldEditor
- 425 kitPx-ImageButton
- 425 kitPx-IncrementSetPointBinding
- 425 kitPx-RefreshButton
- 426 kitPx-SaveButton
- 426 kitPx-SetPointBinding
- 426 kitPx-SetPointFieldEditor
- 426 Components in ldap module
- 426 ldap-LdapClient
- 427 ldap-LdapConfiguration
- 427 ldap-LdapUserService
- 427 Components in net module
- 427 net-InternetAddress
- 427 Components in niagaraDriver module
- 427 niagaraDriver-DistributedQuery
- 428 niagaraDriver-NiagaraAlarmDeviceExt
- 428 niagaraDriver-NiagaraFoxService
- 428 niagaraDriver-NiagaraHistoryDeviceExt
- 428 niagaraDriver-NiagaraHistoryImport
- 428 niagaraDriver-NiagaraNetwork
- 428 niagaraDriver-NiagaraPointDeviceExt
- 428 niagaraDriver-NiagaraPointFolder
- 429 niagaraDriver-NiagaraProxyExt
- 429 niagaraDriver-NiagaraScheduleDeviceExt
- 429 niagaraDriver-NiagaraScheduleImportExt
- 429 niagaraDriver-NiagaraStation
- 429 Ping
- 429 niagaraDriver-NiagaraStationFolder
- 429 niagaraDriver-PointChannel
- 430 PushPointEvent
- 430 niagaraDriver-QueryService
- 430 niagaraDriver-StationDiscoveryTask
- 430 niagaraDriver-StationWorker
- 430 Components in program module
- 430 program-Program
- 430 Actions
- 430 program-ProgramService
- 431 Actions
- 431 Components in pxeditor module
- 431 pxeditor-NewPxViewDialog
- 431 Components in raster module
- 431 raster-RasterEditorOptions
- 431 Components in rdb module
- 431 rdb-RdbmsFolder
- 431 rdb-RdbmsNetwork
- 431 rdb-RdbmsWorker
- 432 Components in rdbDb2 module
- 432 rdbDb2-Db2Database
- 432 rdbDb2-Db2HistoryDeviceExt
- 432 Components in rdbOracle module
- 432 rdbOracle-OracleDatabase
- 432 rdbOracle-OracleHistoryDeviceExt
- 432 Components in rdbSqlServer
- 432 rdbSqlServer-SqlServerDatabase
- 432 rdbSqlServer-SqlServerHistoryDeviceExt
- 433 Components in schedule module
- 433 schedule-BooleanSchedule
- 433 Using Schedules
- 433 schedule-CalendarSchedule
- 433 schedule-EnumSchedule
- 433 schedule-NumericSchedule
- 434 schedule-StringSchedule
- 434 schedule-TriggerSchedule
- 434 Components in timesync module
- 434 timesync-TimeServer
- 434 timesync-TimeSyncService
- 435 ForceSync
- 435 Sync
- 435 Components in web module
- 435 web-WebService
- 435 Components in workbench module
- 435 workbench-ComponentFinder
- 436 workbench-WbFieldEditorBinding
- 436 workbench-WbViewBinding
- 436 workbench-WsOptions
- 437 Plugin Guides
- 437 alarm-AlarmConsole
- 437 Viewing Alarms
- 437 Acknowledging Alarms
- 437 Acknowledge
- 438 Hyperlink
- 438 Silence
- 438 Filter
- 438 Alarm Report Dialog
- 438 Viewing Alarm Record
- 438 Notes
- 438 alarm-AlarmDbMaintenance
- 439 alarm-AlarmClassSummary
- 439 alarm-AlarmExtManager
- 439 alarm-AlarmPortal
- 439 backup-BackupManager
- 440 chart-ResourceManager
- 440 devkit-LexiconEditor
- 440 LexiconEditor Menus
- 440 LexiconEditor Pulldowns and Buttons
- 441 LexiconEditor Toolbar
- 441 Lexicon
- 441 Module
- 441 Hide Ref Values
- 441 Hide Accelerators
- 441 Show Missing Only
- 441 Value
- 441 Change
- 441 Add New Key
- 442 devkit-LexiconReport
- 442 LexiconReport Menus
- 442 LexiconReport Pulldowns and Buttons
- 442 LexiconReport Toolbar
- 442 New Lexicon
- 442 Delete Lexicon
- 442 driver-DeviceManager
- 443 driver-DriverManager
- 443 driver-HistoryExportManager
- 443 driver-HistoryImportManager
- 443 driver-PointManager
- 443 email-EmailAccountManager
- 443 help-BajadocViewer
- 444 BajadocViewer Menus
- 444 Show Baja Only
- 444 Flatten Inheritance
- 444 Subclasses
- 444 Properties
- 445 Actions
- 445 Topics
- 446 history-DatabaseMaintenance
- 446 history-HistoryChart
- 446 history-HistoryChartBuilder
- 446 history-HistoryEditor
- 446 history-HistoryExtManager
- 446 HistoryExtManager Menus
- 446 HistoryExtManager Toolbar
- 447 HistoryExtManager Enable Collection
- 447 HistoryExtManager Disable Collection
- 447 HistoryExtManager Rename History
- 447 HistoryExtManager Default History Name
- 447 history-HistorySummaryView
- 447 history-HistoryTable
- 447 Query
- 448 Filter
- 448 Filter Config
- 448 html-WbHtmlView
- 448 Introduction
- 448 WbHtmlView Menus
- 448 WbHtmlView Toolbar
- 448 HTML Support
- 448 HTML Tags
- 450 HTML Attributes
- 450 Character Entity References
- 451 Stylesheet Support
- 451 Introduction
- 451 Pseudo-classes and Pseudo-elements
- 451 CSS1 Properties
- 452 html-SpyViewer
- 453 ldap-LdapUserManager
- 453 niagaraDriver-NiagaraHistoryExportManager
- 453 niagaraDriver-NiagaraHistoryImportManager
- 453 niagaraDriver-NiagaraPointManager
- 453 Learn
- 454 Paste As ProxyPoint
- 454 Create Graphics Page
- 454 niagaraDriver-NiagaraScheduleExportManager
- 454 niagaraDriver-NiagaraScheduleImportManager
- 454 niagaraDriver-ServerConnectionsSummary
- 455 niagaraDriver-StationManager
- 455 program-BatchEditor
- 455 program-ProgramEditor
- 455 Introduction
- 455 ProgramEditor Edit
- 455 ProgramEditor Slots
- 455 ProgramEditor Imports
- 456 ProgramEditor ImportType
- 456 ProgramEditor ImportPackage
- 456 ProgramEditor Remove
- 456 ProgramEditor Source
- 457 ProgramEditor Menus
- 457 ProgramEditor Toolbar
- 457 ProgramEditor Compile & Save
- 458 ProgramEditor Compile
- 458 program-RobotEditor
- 458 RobotEditor Menus
- 458 RobotEditor Toolbar
- 458 RobotEditor Compile
- 458 RobotEditor Compile & Run
- 458 pxEditor-PxEditor
- 459 raster-RasterEditor
- 459 RasterEditor Menus
- 459 RasterEditor Toolbar
- 460 OriginalView
- 460 Fit To Window
- 460 ImageInformation
- 460 ViewPaletteTransparency
- 460 SetPaletteTransparency
- 460 Zoom
- 460 Selection
- 460 Dropper
- 460 PaintBrush
- 460 FloodFill
- 461 Text
- 461 Shape
- 461 raster-RasterViewer
- 461 rdb-RdbmsHistoryExportManager
- 461 rdb-RdbmsSessionView
- 461 schedule-CalendarScheduler
- 461 schedule-CurrentDaySummary
- 461 schedule-Scheduler
- 462 Weekly Schedule
- 462 Special Events
- 462 Properties
- 462 Default Output
- 462 Cleanup Special Events
- 462 Summary
- 462 schedule-TriggerScheduler
- 463 timesync-TimeSyncManager
- 463 wiresheet-WireSheet
- 463 WireSheet Menus
- 463 WireSheet Main Menu
- 463 WireSheet Component Menu
- 464 WireSheet Background Menu
- 464 WireSheet Link Menu
- 465 WireSheet Toolbar
- 465 Delete Links
- 465 Pin Slots
- 465 Arrange
- 465 Select All
- 465 Show Thumbnail
- 465 Show Grid
- 465 Show Status Colors
- 466 workbench-PrintDialog
- 466 workbench-CompositeEditor
- 466 workbench-ExportDialog
- 466 wbutil-CategoryBrowser
- 466 wbutil-CategoryManager
- 467 wbutil-CategorySheet
- 467 wbutil-PermissionsBrowser
- 467 wbutil-ResourceEstimator
- 467 wbutil-TodoList
- 467 wbutil-UserManager
- 468 workbench-CollectionTable
- 468 workbench-DirectoryList
- 468 DirectoryList Menus
- 468 DirectoryList Toolbar
- 468 Refresh
- 468 New
- 469 workbench-HexFileEditor
- 469 workbench-JobServiceManager
- 469 workbench-LinkSheet
- 469 LinkSheet Main Menu
- 469 LinkSheet Toolbar
- 470 GoTo
- 470 workbench-ModuleSpaceView
- 470 OptionsButton
- 470 workbench-NavContainerView
- 470 workbench-NavFileEditor
- 470 workbench-PropertySheet
- 470 PropertySheet Menus
- 471 PropertySheet Toolbar
- 471 Config Flags
- 471 Links
- 471 OrdChooser
- 472 workbench:FileOrdChooser
- 472 Back
- 472 Uplevel
- 472 Home
- 472 New Folder
- 472 ListView
- 472 DetailsView
- 472 Bookmarks
- 472 Show/Hide Preview
- 472 workbench:DirectoryOrdChooser
- 473 New Folder
- 473 Bookmarks
- 473 workbench:HistoryOrdChooser
- 473 workbench:RefChooser
- 473 workbench:BqlQueryBuilder
- 473 Ord Qualifier
- 473 workbench:ProjectionBuilder
- 473 Bql Expressions"
- 474 workbench:ExtentBuilder
- 474 workbench:QualifierBuilder
- 474 Edit Facets
- 474 Add
- 474 Remove
- 474 Enum Range Dialog
- 475 workbench-SlotSheet
- 475 SlotSheet Main Menu
- 475 SlotSheet Component Menu
- 476 SlotSheet Toolbar
- 476 Add Slot
- 476 Rename Slot
- 476 Add Name Map
- 476 Config Facets
- 476 workbench-StationSummary
- 477 workbench-TextFileEditor
- 477 TextFileEditor Menus
- 477 TextFileEditor Toolbar
- 477 File Types
- 477 C Files
- 477 CSS Files
- 477 HTML Files
- 478 Java Files
- 478 JavaScript Files
- 478 Properties Files
- 478 Python Files
- 478 Xml Files
- 479 workbench-ServiceManager
- 479 workbench-WbPxView
- 479 WbPxView Menus
- 479 PxViewer View Source Xml
- 479 workbench-WbServiceManagerView
- 481 Appendix A References
- 481 In this appendix (introduction)
- 481 About keyboard shortcuts
- 482 Types of menu bar items
- 483 About the File menu
- 485 About the Edit menu
- 487 About the Search menu
- 488 About the Bookmarks menu
- 488 About the Tools menu
- 489 About the Window menu
- 490 About the Px Editor menu
- 491 About the Help menu
- 491 Types of popup menu items
- 492 About the nav side bar popup menu items
- 493 About the wire sheet popup menu items
- 493 About the property sheet popup menu items
- 493 About the Px Editor popup menu items
- 494 Types of edit commands
- 495 Types of toolbar icons
- 496 Standard toolbar icons
- 496 Slot Sheet toolbar icons
- 497 Px Editor toolbar icons
- 498 History editor toolbar icons
- 498 Types of views
- 498 Types of view selector menus
- 498 Types of dialog boxes
- 498 About console commands
- 499 About console command usage
- 499 Types of console commands
- 500 Console commands optional flags
- 500 SVG Colors
- 507 Glossary
Frequently Answers and Questions
What is NiagaraAX?
NiagaraAX is a software framework that enables the integration of control systems, devices, and applications. It can be used to manage a variety of building automation systems, including HVAC, lighting, security, and energy management. As viewed in the document, it was published on June 24, 2005, by Tridium, Inc.
What are the benefits of using NiagaraAX?
According to the document, NiagaraAX offers various benefits, including: Well-designed, a comprehensive solution for control systems integration, utilizing common networking and internet protocols, built for non-programmers, capabilities for embedded and distributed systems, and a component software design. This information is extracted from the "About NiagaraAX Framework" section of the viewed document.
What are some of the key features of NiagaraAX?
NiagaraAX includes a user-friendly graphical user interface (Workbench), a data and control model that provides a consistent way to represent and manage data, and a driver architecture that allows you to connect to a variety of devices and networks. This information can be found in the "Contents" section of the viewed document.
advertisement